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CONTACT CENTER SOLUTIONS
Mitel Contact Center Solutions Enterprise, Business, and Workgroup Editions integrate with the
3300 MCD platform to provide contact centers with the tools they need to efficiently and effectively
measure and manage contact center operations. Contacts are routed intelligently across all media
types (voice, email, and chat), increasing customer satisfaction and streamlining agent interactions.
Contact center efficiency and agent performance can be monitored both historically and in real time
and can be measured using a wide variety of reports. Flexible licensing packages provide access to
specific features and applications and enable you to build a contact center package that best suits
your business needs.

WHAT'S NEW IN VERSION 7.1?
The following section briefly describes the features and product enhancements that were introduced
in Contact Center Solutions and Business Reporter Version 7.1.
MiCollab Client and Ignite integration
The MiCollab Client and Ignite integration combines the advanced call handling features of MiCollab
Client with the multimedia handling abilities provided by Ignite, resulting in an all-inclusive agent
desktop experience. The MiCollab Client and Ignite integration also offers Enterprise presence,
extended ACD presence, and Enterprise Instant Messaging presence indicators, informing coworkers of your real-time availability.
This integration is also available in conjunction with Basic MiCollab Client, but with reduced
functionality.
For information regarding voice handling using Ignite and MiCollab Client, see "MiCollab and Ignite
integration" on page 467. For information regarding handling non-voice media types using Ignite and
MiCollab Client, see the Multimedia Contact Center Installation and Deployment Guide.
Workgroup Edition
Workgroup Edition is a competitively priced, entry level contact center solution for the MiVoice
Business platform. General business reporting, contact center reporting, contact center real-time
monitoring, client desktops, and advanced IVR Routing capabilities are included in a single starter
pack with available options for customization. Workgroup Edition supports single and multi-node
MiVoice Business environments. If your contact center needs increase in size or sophistication, you
can seamlessly upgrade to either Contact Center Business or Enterprise Edition.
For more information, see the licensing section of the Contact Center Solutions and Business
Reporter System Engineering Guide.
Business Reporter
Business Reporter, formerly Call Accounting, has been revamped for Version 7.1. While continuing
to provide call costing, Traffic Analysis, and Subscriber Services, Business Reporter now also
includes support for ring group monitoring and reporting for general business purposes.
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Business Reporter is included in all licensing starter packs but is also available as a standalone
product. A Business Reporter license must be owned for each extension, including non-ACD
extensions, that will be reported on or viewed in real time. All licensed Business Reporter extensions
can be monitored in real-time using the new Extension Now monitor, available in Contact Center
Client.
For more information, refer to the Business Reporter User Guide.
Support for ring groups
Members of ring groups can now be reported on and viewed in real-time.
In Version 7.1, voice queue reports apply to both ACD paths and ring group configurations (when
applicable). For more information regarding ring group reporting, see the reports guide that applies to
your contact center edition (Enterprise, Business, Workgroup, or Business Reporter).
Ring group members can be monitored in all Contact Center Client queue monitors, except the
Agent State by Time for Queue monitor. Interactive Visual Queue does not support ring groups. For
more information regarding ring group real-time monitoring, see the Real-time Monitors chapter in this
guide.
Ring group support requires MCD 7.0+.
For information regarding ring group configuration, see "Adding ring groups" on page 147.MadCap
Software
Ignite enhancements
Version 7.1 includes several enhancements to Ignite, including the following.
For more information regarding updated Ignite features, see the Multimedia Contact Center
Installation and Deployment Guide. and "MiCollab and Ignite integration" on page 467.
l

l

l

Ability to send outbound emails
Outbound emails can be sent from email queues in Ignite using the New Email button. Inprogress outbound emails are stored in the Drafts folder. Queue signatures are automatically
inserted into outbound emails if configured for the queue. Preferred agent routing is supported
to enable ongoing conversations between agents and email recipients.
Ignite profile settings
Selecting options within the new General Settings tab in Ignite dictates how Ignite displays
and behaves on startup, when the inbox is emptied, and in conjunction with MiCollab Client.
For example, if you primarily focus on voice contacts, you can set Ignite to show only the
Sidebar and, when a multimedia item is accepted, the main Ignite window will also open
allowing full access to email and chat processing application areas.
Additional Ignite Sidebar functionality
Options have been added to the Ignite Sidebar that enable agents to set Account Codes and
Classification Codes (supported for voice contacts only), remove Work Timer, set Ignite
profile options, and view handling statistics by media type using only the Sidebar. This
optimizes desktop real estate when agents are handling voice-only items in conjunction with
MiCollab Client desktop.
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l

Licensing updates that increase access to Ignite
Availability of Ignite has been expanded to include:
l

Contact Center Workgroup Edition Standard employees

l

Contact Center Business Edition Desktop agents

l

l

l

l

l

l

Contact Center Enterprise Edition Standard, Advanced, and Premium agents (pre-7.1,
only Premium agents gave access to Ignite)

Support for email signatures
Custom email signatures can be created and applied on a queue by queue basis, providing
uniform and consistent customer responses. Signatures can be applied to email queues and
automatically inserted into agent email responses or, if permitted, agents can create and use
personalized signatures.
Email requeue behavior
You can now specify, by queue, whether emails in employees’ inboxes requeue automatically
on employee logout or remain in the inbox for a designated duration after employee logout.
Security settings
Security setting options have been expanded to include the ability to prevent employees from
picking contacts out of queue, transferring contacts from queues to their inbox, and
designating contacts as Junk.
Agent group presence control
Agents can now choose to be present in all groups or absent from all groups with a single click
by selecting ‘Select All’ or ‘Clear All’ agent groups.
Changes to Ignite folder structure
The following folders have been added to Ignite:
l

Drafts - contains in-progress emails

l

My History - contains historical email and chat contacts

l

l

l

Processed – a queue level folder that contains in-progress and historical email and chat
contacts by queue for agents associated to that queue. Emails and chats there were
not able to route are also contained here
In Progress – provides supervisors with a view of all email and chat contacts currently
in agent inboxes
Outbox – contains outbound emails and agent email replies in the process of being
sent. If send attempts exceed the default limit of five, the contact’s media icon flashes
and displays in red

The following folder has been updated:
l

l

l
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Queue Folder – the Queue Folder view displays agent availability, number of contacts
in queue, longest wait time, and service level for each Unified Queue, Reporting Queue,
and Individual Queue for which an employee’s agent group answers contacts.

Improved Ignite search ability
Supervisors and agents, depending on licensing level, can now more readily locate specific
items in Ignite’s folders using search filters.
Rerouting failed emails
Emails that fail to route are stored in Ignite’s Failed folders. Clicking the Reroute button
removes emails from these folders and transfers them back to the queue. Alternatively,
agents can choose to forward emails from this folder or mark them as Junk.
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l

l

Chat transcript actions
Agents can forward chat transcripts to multiple parties as an email (with additional recipients
copied and blind-copied if needed). If chat transcripts route to the Failed folder in Ignite, agents
can remove them by designating them as Junk.
Enhancements to chat request page customization
There is now a greater range of customization choices available for the CCMWa/Chat chat
request form and the individual chat queue request forms. Using a new JavaScript file, you
can:
l

Control chat request form customizations on a queue by queue basis

l

Add a corporate logo and customize its placement on the chat request form

l

Change the background color and whether it displays as a solid color or gradient

l

Show or hide the Estimated Wait Time statistic

l

Show or hide the topic field on the chat request form

l

Provide a label for the queue that displays both on the chat request form and the
browser title bar

Support for non-empty Namespace IMAP providers
Multimedia Contact Center now supports integration with IMAP providers that use non-empty
Namespace. Non-empty Namespace support has been tested with BlueHost.
For more information, see the Multimedia Contact Center Installation and Deployment Guide.
IBM Domino mail server support
Multimedia Contact Center now supports IBM Domino Version 9.0.1 or greater as a mail server.
See the following KB article for more information:
http://micc.mitel.com/kb/KnowledgebaseArticle52166.aspx
Enhancements to Silent Monitor
Contact Center Solutions Version 7.1 leverages MCD 7.0 and MCD 7.0.1 capabilities to improve
silent monitoring. For example, in conjunction with MCD 7.0/7.0.1, up to six supervisors can monitor
the same agent across all call states. Also, supervisors can access Class of Service controlled
monitoring of non-prime lines and can start monitoring an agent or extension before they handle a
call. When the call starts, silent monitoring begins automatically.
For more information, see "Silent monitoring calls" on page 453.
Addition of Whisper Coach ability
Whisper Coach is a feature of Silent Monitor, enabling supervisors to talk to the agent and coach
them throughout the call without the customer hearing what the supervisor is saying. If needed,
supervisors can conference into an active call to talk to the customer.
Whisper Coach requires either MCD 7.0+ on a MiVoice Business for ISS platform, a Multi Instance
Platform, or VMWare for Virtual Appliance. Whisper Coach is not supported on Mxe platforms.
For more information, see "Coaching agents and extensions on a call with customers" on page 454.
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IVR support for PCI compliancy
An IVR Routing workflow for PCI compliant systems is now available. This workflow supports the
security protocols and feature capabilities that can enable organizations to comply with PCI DSS.
For more information, see "Workflow for PCI Compliant systems" on page 652.
Inter-Tel database import tool
The Inter-Tel database import tool enables customers with historical CSM data (collected using
either a 5000 or 3300 media server) to convert their data when migrating to Contact Center Solutions
Business, Workgroup, or Enterprise Edition. The import tool is designed to process data from either
Access or DB2 databases.
For more information, see the Contact Center Management Installation Guide.
Updates to Interactive Visual Queue
The following changes have been made to Interactive Visual Queue:
l

l

l

Supervisors monitoring queues in Interactive Visual Queue can preview the contacts of
queued email and chat contacts. Previewed emails display in a window that shows the
contents of the email. Supervisors can preview embedded files in the email and download
attachments, such as images and e-signatures, but they cannot edit previewed emails or
preview emails that are in an agent’s inbox. Only one email can be previewed at a time.
Previewed chats show the content of the chat session. Supervisors can open links in the
previewed chat session but they cannot view embedded media or participate in the chat. Only
one chat can be previewed at a time.
In the Queued media grid, supervisors can redirect multimedia contacts between queues or
directly to agents who are available or in Make Busy/Overloaded states. They can also
redirect email contacts to specific email addresses.
The Interactive Visual Queue monitor can now be sorted by column.

Enhanced queue routing using IVR Routing
Quick configuration shortcuts can be used with IVR Routing to minimize the MCD programming
required to simulate resilient queues. In YourSite Explorer, administrators can copy and paste and
use write back to retain the properties of the original queue and configure a duplicate queue on an
alternate MCD in the cluster. Then they can multi-select the duplicate queues and create a virtual
queue group. These virtual queue groups can be referenced by the IVR during routing or in queue
conditions. When routing to a virtual queue group, if the primary PBX is offline, then the IVR will
transfer the call to the secondary PBX.
For more information, see "Duplicating devices in YourSite Explorer" on page 77, "Adding Virtual
queue groups" on page 156, and "Configuring options and adding devices to Transfer activities" on
page 623
You can also refer to the article located here:
http://micc.mitel.com/kb/KnowledgebaseArticle52215.aspx
Lifecycle report filtering
Lifecycle reports now include Classification Codes.
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Licensing changes
In Contact Center Solutions Version 7.1, licensing components have been added to enable:
l

Workgroup Edition

l

MiCollab and Ignite integration

Additional changes to licensing for Version 7.1 include the following:
l
l

l

l

l

l

Business Reporter is now included in all starter pack levels for all contact center editions.
Previously, Call Accounting reports could be run against an unlimited number of non-ACD
extensions, however, in Version 7.1, a Business Reporter (previously Call Accounting)
license must be applied to each extension that will be viewed in real time or reported on.
Business Reporter now includes support for ring groups and, although it continues to include
call costing capabilities, they are no longer its primary focus. The call costing features
included in Business Reporter are supported in the following areas only: North America, Latin
America, United Kingdom, and the Benelux regions. Other regions can access Business
Reporter for its general business features and functionality.
The OAISYS Call Recording Connector is now included in the following starter packs:
Contact Center Workgroup Edition, Contact Center Business Edition base package, and
Contact Center Enterprise Edition Standard, Advanced, and Premium packages. The
OAISYS Call Recording Connector is not included in Business Reporter or the Contact
Center Enterprise Edition Basic package (however it is available as an option for this package
level).
Ignite is now available to more licensing levels, including Contact Center Business Edition
Desktop Agents (if Multimedia Contact Center is not owned, Desktop Agents will have
access to Ignite for voice contacts only), Workgroup Edition Standard Employees, and
Contact Center Enterprise Edition Standard, Advanced, and Premium level agents.
The number of System Administrators included in contact center edition starter packs has
been aligned. All starter packs now include two System Administrators. Contact Center
Business Edition includes two Desktop Supervisors.

Licensing is described in detail in the Contact Center Solutions and Business Reporter System
Engineering Guide.
Technology changes
The following technology changes have been introduced in Version 7.1.
Support for:
l

l

MCD 7.0 and MCD 7.0.1 (some features included in Contact Center Solutions Version 7.1
require at least MCD 7.0)
SQL Server 2014

Support for the following technologies has been discontinued in Version 7.1:
l

Intelligent Queue (used as a historical media server only)

l

MCD Versions 4.0 SP4, 5.0 SP2

l

VMware ESXi Versions 4.5 and 5.0
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CONTACT CENTER ENTERPRISE EDITION, BUSINESS
EDITION, AND WORKGROUP EDITION
The Contact Center Solutions portfolio comprises Contact Center Enterprise Edition, Contact
Center Business Edition, and Contact Center Workgroup Edition.
Contact Center Enterprise Edition is for sophisticated contact centers and supports voice, email,
and chat communication. This scalable, resilient solution combines robust IP communications
platforms, Automatic Call Distribution (ACD), and a modular suite of feature-rich, web-based
applications for streamlining contact center management and enabling agent productivity.
Contact Center Business Edition is for individual contact centers with 50 or fewer agents. When
customers purchase Contact Center Business Edition, they can select from a number of
applications including historical reporting, real-time monitoring, dynamic agent and queue control,
screen pops, and intelligent messaging.
Workgroup Edition is a competitively priced, entry level contact center solution for the MiVoice
Business platform. General business reporting, contact center reporting, contact center real-time
monitoring, client desktops, and advanced IVR Routing capabilities are included in a single starter
pack with available options for customization. Workgroup Edition supports single and multi-node
MiVoice Business environments. If your contact center needs increase in size or sophistication, you
can seamlessly upgrade to either Contact Center Business or Enterprise Edition.
The Contact Center Solutions applications and contact center devices available to you depend on
whether you have Enterprise Edition, Business Edition or Workgroup Edition.
Contact Center Solutions includes the following applications, depending on your licensing level:
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l

Contact Center Management

l

Contact Center Client

l

Interactive Contact Center

l

Interactive Visual Queue

l

Contact Center PhoneSet Manager

l

Contact Center Softphone

l

Multimedia Contact Center

l

Contact Center Screen Pop

l

Flexible Reporting

l

IVR Routing

l

Salesforce.com Connector

l

Workforce Scheduling

l

Employee Portal

l

Schedule Adherence

l

Traffic Analysis

l

Ignite

l

MiCollab Client

Licensing

l

Enterprise Node

l

Mitel Border Gateway Connector

l

CTI Developer Toolkit

LICENSING
An employee is a physical person you track in your contact center. In the YourSite database, you
must create an employee ID for each employee who works in your contact center. Employees can
have multiple agent IDs, but only one employee ID. You can run reports on licensed employees only.
The number of employees you license in YourSite Configuration must be consistent with your
software license.
To view details on your software license
l

Click Help=>About your Mitel applications.

To view details on applications installed by Professional Services
l

Click Help=>About your Mitel applications=>Professional Services

ABOUT THIS USER GUIDE
This user guide provides information on how to manage your contact center using the Contact
Center Solutions applications. To make full use of Contact Center Solutions, you must have a
working knowledge of the Microsoft Windows operating environment and Microsoft Excel 2007 or
greater. The tutorials that accompany Microsoft Windows and Excel provide information on basic
use.
To report an issue with this document, please email micctechpubs@mitel.com.
Chapter 1 Contact Center Solutions
Chapter 1 describes
l

The features and benefits of Contact Center Management

l

Licensing

l

The layout of the user guide

l

Document conventions

l

Information on how to install client applications from the Contact Center Management website

Chapter 2 Contact Center Concepts
Chapter 2 describes
l

The inbound contact center environment

l

How resources interact to process contacts
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Chapter 3 Contact Center Planning and Management
Chapter 3 provides information on how to plan and manage your contact center, including how to
l

Establish a corporate Service Level objective

l

Collect data.

l

Forecast the Call Load.

l

Calculate the resources required.

l

Schedule agents.

l

Determine contact center costs.

Chapter 4 Getting Started
Chapter 4 describes how to
l

Register your software

l

View multiple Contact Center Management sessions

l

Back up and restore the YourSite database and raw telephone system data files

l

Set up client computers to use Contact Center Management

l

Specify user preferences

Chapter 5 Services and Database Administration
Chapter 5 describes how to
l

Start and stop the Contact Center Management services

l

Perform database and maintenance functions

Management Console resides in the Contact Center Client real-time application. Using Management
Console, you can
l

Back up and restore YourSite database configuration data

l

Update the server IP address

l

Import configuration data used to configure the YourSite database

l

Run the maintenance routine

l

Summarize data for running reports

l

Create a support package

Chapter 6 Configuration
Chapter 6 describes how to
l

l

Configure the YourSite database using Synchronization

l

Create business hour schedules

l

Configure media server alarms

l

l
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Configure contact center devices in the YourSite database so you can view real-time activity
and generate reports on these devices

Implement security measures to restrict user access to specific Contact Center Solutions
application areas and contact center devices
Configure call recordings

About this user guide

Chapter 7 Real-time Monitors and device control
Chapter 7 describes how to
l

View real-time agent and queue statistics on real-time monitors

l

Configure alarms for agent and queue performance

l
l
l

Customize monitor display characteristics
Build marquee monitors and broadcast statistics and messages
Chat online with agents or supervisors

l

Configure and display real-time statistics on one or more wall signs

l

Set up support for teleworking

l

Add and view call notes appended to calls

Chapter 8 Reports
Chapter 8 describes how to
l

Generate on-demand reports

l

Set up timetables for generating reports

Chapter 9 Forecasting
Chapter 9 describes how to
l

Create forecasts

l

Export forecasts to Excel

Chapter 10 Data-mining Tools
Chapter 10 describes how to
l
l

Search for specific contact center events
View the historical real-time events that occurred on a particular date, in the sequence they
occurred

Chapter 11 Data Collection
Chapter 11 describes how to
l

Verify media servers are receiving telephone system data

Chapter 12 Interactive Contact Center
Chapter 12 describes how to
l

Control the availability of agents and ACD queues

Chapter 13 Interactive Visual Queue
Chapter 13 describes how to
l

View calls within queues and move calls from busy queues to less active queues

l

Call back abandoned callers
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Chapter 14 Contact Center PhoneSet Manager and Contact Center Softphone
Chapter 14 describes how to
l

Enable agents to use their desktop computers as IP-based phones

Chapter 15 Contact Center Screen Pop
Chapter 15 describes how to
l
l

Launch applications or webpages when agents receive calls
Provide agents with caller and account information via pop-ups on their computer monitors
when they receive calls

Chapter 16 MiCollab Client and Ignite integration
Chapter 16 describes how to
l

Use MiCollab Client with Ignite for voice handling

Chapter 17 Flexible Reporting
Chapter 17 describes how to
l

Design your own report templates and customize existing reports

Chapter 18 IVR Routing
Chapter 17 describes how to
l

Install and configure IVR Routing

Chapter 19 Workforce Scheduling
Chapter 19 describes how to
l

Schedule agents

l

Measure employee adherence to schedules

Chapter 20 Traffic Analysis
Chapter 20 describes how to
l

Set up the telephone system and YourSite database so you can collect data and run reports
on the traffic data stream

Chapter 21 Contact Center Management Remote Servers
Chapter 21 describes how to
l
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Configure and deploy Remote Servers as part of your enterprise

Document conventions

Chapter 22 CTI Developer Toolkit
Chapter 22 describes
l

Common uses of the CTI Developer Toolkit

l

Examples of how to use the CTI Developer Toolkit to customize applications

Chapter 23 Salesforce.com Connector
Chapter 23 describes how to
l

Integrate your Mitel phone directly into the Salesforce.com user interface

LOCATING THE LATEST VERSION OF OUR GUIDES
Mitel recommends you obtain the latest version of the Mitel Contact Center Solutions User Guide
from http://edocs.mitel.com.

DOCUMENT CONVENTIONS
This document uses the following conventions.
UI syntax
The following terms apply to actions you perform on the UI:
l

Click precedes options you select with the mouse, such as buttons, menus, and items in list
boxes.

l

Press precedes keys you use on the keyboard.

l

Select or clear precedes options you turn on or turn off, such as check boxes.

l

Select precedes options you select in combo boxes (text boxes with attached list boxes).

For example,
1. Click OK.
2. Press Enter.
3. Select the PFdatabase check box.
4. Drag and drop the name to the Available list.
Italics
Italic typeface is used
l
l

For emphasis (for example, hot desking)
To set off words, letters, and numbers referred to as themselves in the text (for example,
overflow is the routing of calls to more than one queue; the application saves text files as
MMDDYYYY.sql)
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Bold
Bold typeface designates paths you select in your root directory and items you click, press, type, or
select.
For example,
1. Click OK.
2. Delete 50 and type 60.
3. Select the Check database integrity check box.
UI Menu items
UI menu items you select are separated by an arrow [=>]. For example, File=>Open tells you to
select the Open submenu on the File menu.
Note
The word NOTE: designates essential user information.

REQUIRED AND OPTIONAL SOFTWARE COMPONENTS
Contact Center Solutions applications have a number of required and optional applications you
install on client computers. You can download these applications from Mitel Online under
Support=>Software Downloads=>Contact Center Enterprise Edition or Contact Center Business
Edition.

REQUIRED COMPONENTS
In order to use Contact Center Solutions and Business Reporter applications, the following
components must be installed on client computers.
l

l

l

l

l
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Microsoft .NET Framework enables your computer to run applications created with .NET. All
client computers must have supported versions of .NET Framework installed.
Microsoft Internet Explorer updates your browser software to the latest version. All client
computers require IE 8.0 or greater.
NOTE: If you use Internet Explorer 10 or 11, you must enable Compatibility View.
Microsoft Report Viewer 2005 Redistributable Package includes Windows Forms and
ASP.NET Web server controls for viewing reports designed using Microsoft reporting
technology.
Web Services Enhancements (WSE) 3.0 for Microsoft .NET is the Microsoft .NET
Framework version 3.0 redistributable package that installs the common language runtime
and associated files required to run applications developed to target the .NET Framework.
Microsoft DirectX significantly enhances graphics, sound, music, and 3-D animation in
Windows applications.

Required and optional software components

OPTIONAL COMPONENTS
You can install the following application on client computers.
l

l

l

Adobe Reader enables you to view documents and reports in .pdf format. You require Acrobat
Reader to view the online user guide, user tutorial, reporting guide, and reports
Microsoft Excel 2007 or greater is required to both view Contact Center Solutions reports and
automatically distribute reports for printing. Optionally, Microsoft Excel Viewer may be
installed as an alternative to Microsoft Excel to view reports, but it cannot be used to
automatically distribute reports for printing.
Remote Server installs media servers and selected services on a computer other than the
Enterprise Server. For more information on the services included with Remote Server
installation, see the Mitel Contact Center Management Installation Guide.

CLIENT COMPONENT PACK
Client Component Pack contains all of the Contact Center Management, Flexible Reporting,
Multimedia Contact Center, and Workforce Scheduling software components that contact center
employees could need on their computers. You require administrator privileges to run this
installation.
You can install Client Component Pack on individual client computers or servers running Citrix
Terminal Services.
You can install the following software components.
l

l

l

l

Contact Center Client enables you to monitor devices in real time, run Contact Center
PhoneSet Manager or Contact Center Softphone, and Management Console.
Flexible Reporting enables you to run reports, create new report templates, redesign report
templates based on existing Contact Center Management voice reports, and modify report
templates available in Flexible Reporting.
Salesforce.com Connector enables you to integrate Contact Center Solutions with
Salesforce.com
The Workforce Scheduling download enables you to run Workforce Scheduling on client
computers.
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CONTACT CENTER CONCEPTS
Contact centers process a high volume of contacts to meet marketing, sales, customer service,
technical support, and other business objectives. A fine-tuned contact center distributes contacts
efficiently and optimizes the use of agents and other resources. This section describes the inbound
contact center environment and how resources interact to process voice contacts.

AUTOMATIC CALL DISTRIBUTION (ACD)
Automatic Call Distribution (ACD) is a specialized mechanism for distributing incoming calls. The
primary goal of ACD is to ration calls to agents in a cost-effective manner that provides acceptable
service to callers.
To optimize the use of agents, you cross-train them so they can handle a variety of inquiries. Rather
than distributing calls to a number of small, specialized agent or extension groups, ACD distributes
them efficiently among the entire pool of available agents. When you consolidate resources (use the
Pooling Principle), the same number of contact center agents handle more calls while maintaining
Service Levels.
Typically, you program ACD to ensure the first call to arrive reaches the first available agent or the
agent who has been idle the longest. However, you can vary the order of calls and agents to provide
superior service to preferred customers, and skills-based routing.

UNDERSTANDING ACD CALL FLOW
The path of an incoming call is as follows. A caller telephones your contact center via the Public
Switched Telephone Network (PSTN). (The PSTN is a global collection of Central Offices (COs)
interconnected by long-distance telephone switching systems.) The local CO directs the call to one
of your trunk groups. An available trunk picks up the call. Typically, calls from the PSTN arrive to the
contact center over incoming trunks and calls from the contact center to the PSTN travel over
outgoing trunks. If no trunks are available, the call does not get through to the system (it is blocked)
and the caller receives a busy signal.
When a trunk picks up a call, it forwards it through to a group of agents handling calls, or to some
other answering point. The call arrives at the ACD queue of an agent group. The queue delays the
call rather than blocking the call from entering the system. The length of time the caller waits in
queue is the queue time. While waiting in queue, the caller listens to product features,
announcements, or other messages provided by a Recorded Announcement Device (RAD). The
caller can wait patiently in queue for an available agent, leave a voice mail message, or hang up
(abandon) the call. (See Figure 1.)
An agent handles the call. The time the caller spends talking to the agent is the ACD Handling Time
(including the hold time). If the agent calls the supervisor in search of more information (while the
caller is on hold) and/or transfers or conferences the call, these times are added to the ACD Handling
Time value.
For example, an agent speaks to a caller for two minutes and then puts the caller on hold for three
minutes and tries to solve the problem. This may include a call to the supervisor. The agent then
initiates a conference call with the caller and a third party and they speak for three minutes and
resolve the issue. Therefore, the ACD Handling Time for the agent is 2 + 3 + 3 = 8 minutes.
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When the call is completed, the agent might need to perform additional work associated with the call.
The time taken to perform this work is the Wrap Up Time.

Figure 1: Call flow

Monitoring the call flow process
Second-by-second (real-time) statistics presented on wall signs and desktop monitors enable you to
monitor the service provided to callers. You can monitor the number of incoming calls, the time it
takes to process them, the queue load, and the availability of agents using a Management
Information System (MIS). The MIS refers processes data produced by the telephone system. The
MIS uses telephone system records to provide forecasting, real-time monitoring, and reporting
functions.

Ensuring traffic-carrying efficiency
To optimize traffic-carrying efficiency ensure
l

Sufficient trunks are available to carry incoming calls.

l

Callers experience a delay in queue.

l

There is a random distribution of calls among available agents.

Scheduling to optimize call flow
You schedule agents so the number of incoming calls at any given time typically exceeds the
number of agents currently available. The intent is that callers experience a slight delay before
agents answer their calls. The expected number of incoming calls forecasted for the time of day, and
day of the week influence scheduling decisions.
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Routing calls
Call routing options you program in the telephone system provide a set of instructions that automate
the movement of calls to their intended answering points. You can define options—for example, if
the caller dials 1, the system forwards the caller to customer service. You can specify re-routing for
calls not answered after a set period of time and parse incoming Automatic Number Identification
(ANI) and Dialed Number Identification Service (DNIS) data to direct call routing. (See Figure 2.)

Figure 2: Call routing

Dialing an agent’s extension
In the simplest call scenario, a single trunk picks up an incoming call to your contact center. The
telephone system presents the caller with options to dial various answering points. The caller dials
an individual agent at an extension through a queue number. A queue number is an address
mechanism for a queue or other answering point. The programming associated with the queue
number defines the routing and timing features of the call. The telephone system collects data on the
agent and trunk involved in the call. The ACD management reporting application produces reports on
agent and trunk activity.

Dialing a queue
In the next call scenario a trunk group picks up an incoming call to your contact center. The system
presents the caller with options to dial various answering points. The caller dials queue number 1 to
reach queue 1 (Customer Service). The system forwards the call to the first available agent in the
agent or extension group associated with queue 1. The call is an ACD call because one dialable
number represents all of the agents in the group. The telephone system collects data records for the
call. The ACD management software produces Queue Reports on queue 1.
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Overflowing calls
An ACD call that is not answered immediately is placed in a queue. If an agent does not pick up the
call after a set amount of time (the overflow time) the system places the call in the queue of another
agent group, in addition to keeping it in the first queue. The first available agent in either group
handles the call. The overflow feature limits the delay faced by callers by queuing calls against two
or more agent groups. (See Figure 3.)

Figure 3: Multiple queue routing

Interflowing calls
You can program the telephone system to direct a queue delayed call to voice mail or to another
answering point. The interflow timer runs independently of the overflow timer. If the interflow timer
expires, the system removes the call from the queue and re-directs it to another answering point,
such as a trunk or voice mail.

RING GROUPS
Contact Center Solutions and Business Reporter support ring groups. Ring groups are a call
distribution mechanism that offers an alternative to ACD for distributing calls in your business. While
ACD is focused on rationing calls to pools of available agents, ring groups are configured to
distribute calls to a pool of specific extensions. Users can configure ring groups within YourSite
Explorer, monitor them in Contact Center Client, and report on them within CCMWeb.
When an incoming call rings the ring group, the member extensions configured in the ring group are
rung until one extension answers. Ring groups can be programmed to offer calls to extensions using
five different algorithms:
l
l

l

Ring All: Rings all available extensions in the ring group simultaneously.
Terminal: Starting from the first extension in the member list, rings the first available
extension.
Terminal Cascade: Starting from the first extension in the member list, rings the first
available extension for the duration of the Cascade Ring Timer before calling the next
available extension in the member list.
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l

l

Circular: Starting from the last member to handle a call, rings the next available extension in
the members list
Circular Cascade: Starting from the last member to handle a call, rings the next available
extension in the member list for the duration of the Cascade Ring Time before calling the next
available extension in the member list.

Ring groups enable a business to ensure that in settings where employees may not have a set
physical location or mobile device, such as a warehouse or back office, calls can be effectively
distributed to an answering extension. Calls to ring groups can be ACD or non-ACD in Contact
Center Solutions real-time and reporting.
Incoming calls are handled differently than ACD path queues as well. If a call comes in, it will be
queued if any one of the ring group’s extensions are available. Available extensions are those that
are:
l

Idle

l

Busy (ACD, Non ACD, or Out)

If the ring group’s extensions are not available, the call is overflowed immediately (if an overflow
point has been configured) or receives no answer. Extensions in the following states are not
available:
l

Do Not Disturb

l

Out of Service

l

Not Present

l

Reseize Timer

For more information about extension states, see "Extension states" on page 211.

THE INBOUND CALL ENVIRONMENT
The inbound contact center environment has unique characteristics that must be considered in
effective planning and management.
Predicting call arrivals
Calls arrive randomly to contact centers. You cannot predict the minute-to-minute arrival of calls.
This results in unanticipated increases in workload, and impacts staffing calculations and the load
carried by system and network resources.
You can predict the pattern of call arrivals for 15-minute or longer intervals. For example, you can
predict that next Monday between 1:00 P.M. and 1:30 P.M. you will receive 60 phone calls.
However, you cannot predict how many calls will arrive in the first five minutes, the second five
minutes, and so on.
Understanding caller tolerance
Several factors influence a caller’s tolerance to queue delays:
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l

The immediacy of the caller’s requirement

l

The availability of similar products or services

l

The caller’s expectations for service

The inbound call environment

l

The time available to make the call

l

Whether or not the caller is paying for the call
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CONTACT CENTER PLANNING AND
MANAGEMENT
Effective contact center management involves having the right resources in place at the right times
to handle an accurately forecasted workload at the desired level of service. Commitment to a
systematic planning and management strategy is essential. The strategy is based on corporate
objectives that you continually assess and refine.
Whether you are managing a start-up contact center or refining the performance of an existing
operation, the process illustrated in Figure 4 applies. It is the basic framework for achieving and
maintaining your service objectives.

24

Figure 4: Planning cycle
The objective of contact center management is to find the right balance between the agents
scheduled and the service provided to customers. This involves assessing and re-assessing tradeoffs between the Service Level, agents scheduled, and average call duration for a known Call Load
for each 15-minute or half-hour interval of the day. Collecting, properly interpreting, and applying
ACD and other information allows you to accurately forecast the workload and schedule sufficient
agents to meet your service objectives.
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STEP #1 ESTABLISH A CORPORATE SERVICE
OBJECTIVE
The Service Level % is a performance metric contact center managers use to determine what
proportion of customers, who contact you by voice/email/chat, receive 'good' service. Using the
Service Level %, you can gauge the level of service customer's experience, from a historical and a
real-time perspective.
Defining and adequately funding a service objective should be closely tied to your corporate mission.
The service objective identifies the average length of time a caller who has obtained a trunk waits for
an available agent. It is the basis for planning and budgeting and links the resources you require to
your service objectives. Choosing a service objective is the first step in a comprehensive planning
and management solution. Once you set a service objective, you should routinely access it to see
how consistently you are meeting it, on a 15-minute or half-hour basis.
Contact centers in different industries use different criteria for measuring service. Your service
objective should reflect the type of service being provided and the expectations of callers seeking
the service. For example, a company that sells magazine subscriptions has less to lose in the
outcome of any one call than a car dealership does. A caller to a credit card 'lost or stolen' line might
expect different service than a caller to a customer service department at a bank. Contact center
metrics across industries are designed to reflect this.
Performance targets must suit the primary function of a contact center. In revenue-based contact
centers where agents sell products or services, the net revenue per call is considered when defining
a service objective. Revenue-based contact centers strive to provide a high level of service with
minimal blocking and delays.

UNDERSTANDING THE SERVICE LEVEL
The Service Level applies to all of the media types (voice/email/chat/) and is expressed as a
percentage of a statistical goal: it specifies the Service Level Time and the Service Level % goals for
the queue or agent group.
The Service Level is expressed as X percent of calls handled in Y seconds or less, such as 80
percent of calls handled in less than 20 seconds. Why is Service Level the standard measurement of
service? Service Level provides the most accurate representation of the callers’ experience. It is
ultimately the caller who decides what constitutes good service, and whether or not to end a call. It
applies to inbound transactions that must be addressed as they arrive.
When a caller enters a queue, the call is processed in one of three ways:
l
l

l

An agent answers the contact (handled contact).
The client disconnects before an agent answers (abandoned contact) (for calls and chats
only).
The contact is removed from the queue, and sent to another handling point (for example, to
voice mail, an automated attendant, or another queue), (Interflowed contact).

For detailed information on Calls Offered, Calls Handled, Calls Abandoned, Calls Interflowed, and
other Service Level parameters see "Choosing a Service Level goal" on page 28.
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UNDERSTANDING WHY THE SERVICE LEVEL IS THE MOST
MEANINGFUL STATISTIC
The Service Level is one of many ACD statistics used to measure performance. Each statistic has
its purpose. For example, the Grade of Service (GOS) statistic relates the number of trunks to the
level of traffic and indicates the likelihood an attempted call will receive a busy signal. It is expressed
as a decimal fraction. For example, a GOS of P.02 means a caller will have a two percent chance of
receiving a busy signal. Since trunk costs are insignificant compared to agent costs contact centers
are well advised to schedule sufficient trunks, abandons should be minimal.
A delayed call is a call placed in the ACD queue because it cannot be answered immediately by an
agent. The probability of delay statistic relates the number of agents or extensions to the level of
traffic carried by the trunks and indicates the likelihood and amount of delay experienced. The GOS,
probability of delay, and Quality of Service rendered by agents provide vital information about the
callers’ experience. (See Figure 5.)

Figure 5: Service criteria
The GOS and probability of delay contribute to our understanding of what happens to the calls not
answered in Y seconds, and give meaning to Service Level. Service Level is the primary statistic
used in planning and budgeting because it is the most stable measurement of queue activity.
The following statistics are also meaningful contact center indicators:
ASA
The Average Speed of Answer (ASA) is an ACD statistic that measures how long the average caller
waits on hold before the call is picked up by an agent. ASA is a valuable measure of service quality,
but is often misinterpreted. The average does not represent what is typically experienced by
individual callers. Most calls are answered by agents more quickly than the average, but a small
percentage of callers wait several minutes in queue. ASA is a useful parameter, but Service Level is
a more reliable indicator of what callers experience.
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Abandonment
ACDs collect statistics on how long callers wait before abandoning calls, and what percentage of
calls are abandoned. Unfortunately, abandonment is difficult to forecast because it is impossible to
predict caller behavior with any reliability. Sometimes when the Service Level is high more callers
abandon than expected. There are no industry standards for abandonment. It is a somewhat
unreliable measure of contact center performance. However, abandonment statistics assist in
planning Service Levels, and provide valuable information used to create in-queue and message-onhold announcements.

CHOOSING A SERVICE LEVEL GOAL
Contrary to popular belief, there is no industry standard Service Level. Some contact centers base
their Service Level goal on the targets of same-industry companies. In doing so, they assume these
companies are actually meeting their intended targets. Companies are setting increasingly rigorous
Service Level targets in sectors where outstanding customer service is the norm. In a survey of over
100 UK contact centers Opta Consulting was surprised to find an average performance target of 90
percent of calls answered in 15 seconds. They found that companies setting extremely rigorous
targets did not necessarily meet them, and the investment required to achieve 'best in class' targets
was difficult to justify.
Setting an appropriate Service Level goal for your contact center is not easy. The motivation and
expectations of your customers, the availability of similar goods or services, the Service Level
targets of same-industry companies, and the value of calls are things to consider. It may be useful to
run some calculations to determine the trade-offs in Service Level associated with adding or
removing an agent, and implement customer satisfaction surveys. When defining your corporate
Service Level, consider several factors and rate their relative importance.
An appropriate Service Level is one that
l

Satisfies callers’ expectations for service

l

Keeps abandonment in check (at less than five percent)

l

Minimizes expenses and maximizes revenue

l

Meets with the approval and support of agents, supervisors, and senior management

Consider this modest objective. For a Service Level of 80 percent of calls answered in less than 20
seconds, callers receive the following service:
l

Approximately 30 percent of callers experience a delay in queue.

l

The longest wait time is approximately three minutes.

l

The average speed of answer is approximately 12 seconds.

Is this acceptable service for you and for your callers?

UNDERSTANDING QUALITY OF SERVICE
Agent statistics reflect the time agents spend in various states and are used to assess agent
performance. The average time an agent spends handling contacts, and in the Make Busy, Do Not
Disturb, Unavailable, and Wrap Up states directly affects the agent’s availability and the Service
Level provided to callers.
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Service Level alone does not ensure customer satisfaction. The quality of the interaction between
the caller and agent leaves a lasting impression. The Quality of Service reflects an agent’s ability to
provide excellent service to each customer. The knowledge of the agent, the accuracy and
completeness of the information provided, and the courtesy extended to the caller contribute to the
caller’s experience.

MONITORING CALL HANDLING TECHNIQUES
Silent monitoring systems complement ACD statistics by providing a snapshot of quality and
productivity in your contact center. You can track call handling techniques and determine where
improvements can be made in individual performance. Advanced systems capture the voice
conversations between agents and callers and record agent data tables for a complete picture of call
handling. They provide online evaluation forms so you can annotate recordings with feedback.
Silent monitoring takes the bias out of performance evaluation. Silent monitoring provides a
systematic process for monitoring and grading agent calls. You can schedule sessions across
different times of the day, days of the week, and evaluators promoting fairness and consistency.
Showing agents where improvement is needed is more effective than just telling them. Silent
monitoring can contribute to a reduction in call time, a reduction in monitoring time and personnel,
and increased training efficiency.
You can use pre-recorded conversations between agents and customers to train agents and for
ongoing evaluation.
You can use the information to
l

l

Provide recorded examples of exceptional service and unacceptable service to agents in
training.
Record, review, annotate with feedback, and forward call records to agents who then review
your comments within the context of the actual call.

l

Calibrate and routinely access the scoring consistency of call monitors.

l

Assess the effectiveness of current training programs.

l

Assess the efficiency of the monitoring and assessment process.

Defining scoring parameters
The parameters used to evaluate how well agents handle calls are based on the purpose of the calls.
Goals vary across calls for inbound and outbound services. For example, in an outbound sales
environment quality may be based on whether or not the agent made the sale, took advantage of
cross-sell opportunities, and adhered to a pre-defined script. In an inbound environment quality may
be based on the completeness and accuracy of the information and whether or not the caller’s
questions were answered satisfactorily. Agents are also evaluated on 'soft skills', such as voice
quality, pausing at regular intervals, rate of speech, use of positive language, and other listening and
communication skills.
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Setting performance standards and goals
Once you determine appropriate scoring parameters, you define standards for exceptional and
acceptable levels of performance. Assessment standards are based on consensus and must be
clearly defined and communicated to monitors and agents. Collaborate with agents in setting
performance goals and clearly define exceptional service and interim performance steps. Determine
a baseline of current performance and set performance steps for an agent group. Provide agents in
the group who meet or exceed the interim target with rewards and recognition commensurate with
their performance. When systematically used in training and coaching recorded sessions positively
impact productivity. Fair assessment is good for moral and motivation, and contributes to an
environment in which agents can learn and grow.
Monitoring frequency
The frequency of monitoring sessions is determined by individual companies and ranges from once a
month to 15 or 20 sessions a month. Implementing five to 10 monitoring sessions per month is
common practice. Trainees and agents with consistently low scores are monitored more frequently
than other agents. Resource limitations typically influence the frequency of monitoring.

MONITORING SYSTEMS AND TOOLS
The following monitoring systems and tools help you evaluate the performance and manage the
quality of service of your contact center.
Silent monitoring systems
Silent monitoring systems range from tape recorders to client/server based recording systems.
Advanced systems schedule, record, and store voice files in a compressed digital format using a
real-time link to your telephone system. They capture any data tables accessed by the agent in
addition to voice data. Silences are eliminated to optimize monitoring efficiency. Recording sessions
can be played back from any telephone, anywhere, at any time. You can customize agent evaluation
forms and define parameters for quality with advanced systems. They provide activity, status, and
management reports for evaluating agents and observation practices.
IT support systems
Information Technology (IT) support systems are commonplace in contact centers. Contact center
agents divide their time between listening to customer requests, entering and updating customer
information and other entries, searching for required information, and providing feedback to
customers. In order to provide prompt and complete information, agents must have immediate online
access to information including customer records and case histories, products and services, and
company policies and procedures.
The push to increase agent efficiency and customer service has placed new demands on computer
information systems and information technology. Information products that enhance agent
productivity are continually being developed. Contact center systems are designed to incorporate
some, or all of the following specialized support functions.
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CTI
Computer telephony integration (CTI) is the merging of computers and telephone systems. Today’s
computer-based telephone systems deliver synchronized voice and data, voice and data
conferencing, automatic information retrieval for calls, caller-based messaging and routing, and
desktop productivity tools. You can use customer databases in call handling to enhance customer
service and agent productivity. When databases are shared between contact center departments
each agent can access a caller’s contact information, purchasing records, call history, and
preferences by a caller ID number.
ANI
Automatic Number Identification (ANI) identifies the telephone numbers of callers to your contact
center, so agents can receive screen pops with calls. You can connect a database to your telephone
system to simultaneously send calls and caller information. The telephone system forwards the
caller’s telephone number to a software application that relays database records on the caller to the
agent. Alternately, the caller enters an ID number that the database associates with a set of records
for the caller and the agent is sent the information.
ANI saves agents time since they do not have to ask for and enter a name for a caller, and wait for
the database to respond. This time savings significantly impacts staffing requirements and
telephone service charges. ANI also identifies telephone numbers of callers who abandon calls so
they can be contacted later for potential business.
Reports can identify the volume of usage and costs of internal line numbers, and help you track the
long distance distribution per line number and maximize long distance efficiency.
DNIS
Dialed Number Identification Service (DNIS) is a feature of toll-free lines that identifies the telephone
number the caller dials. This assists agents who handle calls for more than one business or product
line. Each business or product line has its own toll-free number. When a caller dials a toll-free
number, the telephone system forwards information to the agent so the agent can identify who the
caller dialed. For example, a caller dials a toll-free number for a cruise line. The telephone system
sends a script to the agent along with the call. The agent then knows to answer 'Good morning.
Thank you for calling Southern Cruises', instead of the name of another cruise line serviced by the
center.

AUTOMATING HELP DESK WORKFLOW
Agents at IT help desks require quick access to customer information and call history, and the ability
to rapidly log all of the support calls and incidents. Advanced help desk packages offer automated
desk help workflow systems. They assist agents in logging service requests (tickets), dispatching
them to prioritized queues or agents, tracking them, and documenting activities.
External applications, help desk operators, or end users (in web-based applications) generate
tickets. The system generates them manually, or in some cases automatically, in response to
system events. It can correlate multiple incidents with single tickets, and multiple problems with a
single call.
Automated help desk workflow systems track each step taken in answering a call, with automatic
time stamping of all of the referrals, escalations, reminders, alerts, and email notifications. Calls are
prioritized and referred to other departments without reassignment, reassigned (escalated) to other
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technicians or specialized staff, and placed in an alert condition when they are not resolved
promptly. Activities are date and time stamped automatically. Most help desks offer outgoing email
notification and paging. Some help desks offer automated logging of incoming emails, and
automated call acknowledgment emails to clients.

STEP #2 COLLECT DATA
Telephone systems generate an enormous amount of real-time and historical data used in planning
and management of your contact center. You use real-time data to monitor the current Call Load and
agent availability so minute-to-minute adjustments can be made. You use historical information in
forecasting, staffing, and scheduling. Other critical management information comes from customer
surveys, market studies, employees, external departments, telephone networks, workforce
management systems, competitors, and the media. Data collection is a continuous process you
implement as soon as your telephone system is up and running.
Telephone systems provide detailed report data on every aspect of call transactions. You can
program computer-based telephone systems connected to a Local Area Network (LAN). Users on
the LAN can view or print real-time and historical reports. Using web-enabled telephone systems,
you can view and generate reports in a Web browser. You can monitor contact center activities
remotely, and distribute reports to people on different networks.

COLLECTING DATA ON CALL HANDLING
Contact center reporting software displays real-time telephone system data on desktop monitors and
wall signs. Using real-time data, you can manage current conditions and ensure agents respond to
changing contact center events. The telephone system provides information on call activity, agent
activity, and queue activity.
You can use historical data in forecasting and in assessing the performance of your resources.
Historical reports provide vital information on load activity, resource activity, and queue activity. For
example, resource activity reports on trunks can tell you the highest number of trunks used during
peak traffic periods, and the total duration of calls handled by each trunk for the reporting period. You
can determine how busy your trunks are, and whether or not you have the right number of trunks
scheduled.
CTI provides in-depth information on call transactions. Detailed information on keystroke
sequences, databases searched on, and on-screen assistance provides a clear picture of agent
activities. Using ANI data, you can identify callers by area code and collate information on
demographic trends in caller behavior.
Workforce management systems use telephone system data to forecast and schedule agents.
Some packages monitor the real-time adherence of agents to scheduled activities, so you know the
number of agents currently logged on and available to handle calls. Workforce management systems
collect and store real-time adherence data. This data provides a historical account of adherence
used in agent assessment.
Customer surveys provide valuable supporting information on callers’ tolerance to delay, and
expectations for service. They address some of the following questions: Was the agent accessible?
Was the caller put on hold for too long? Was the agent courteous and responsive to my request?
Was the agent well informed? Did the agent provide the correct information and keep commitments?
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Contact centers use this information to estimate the repercussions of poor service: escalated costs,
duplication of work, lost customers.
As the economy moves towards individual, personalized services, new ways of handing calls
continue to emerge. These new features add to the complexity of collecting and measuring
information. It is vital you establish an integrated, reliable system for measuring the key indicators of
performance: the efficiency of call handling, the service callers experience, and their perceptions of
that service.

STEP #3 FORECAST THE CALL LOAD
Finding the right balance between resources and traffic volumes is a critical step in effective contact
center management. Estimating resource requirements is particularly challenging as the number of
calls and the total duration of calls expected for a given time interval is difficult to predict.
Forecasting impacts contact center operations and performance in the following ways:
l

The number of blocked and abandoned calls

l

The level of service provided to callers and callers’ perception of service

l

Agent workload, call behavior, and retention

l

The accuracy and usefulness of schedules

l

The success of periodic sales campaigns

FORECASTING ACCURATELY
Forecasting is an imprecise science. The accuracy of your forecast increases markedly with the
size of your data sample. You take a year (or preferably two or three years) of ACD queue traffic
data, examine trends in Call Load patterns, break down the information, and determine the ACD
Handling Times of the calls. You then modify the forecast based on current contact center activities
and other considerations, such as absenteeism, agent breaks, holidays, and training.
The range of forecast dates you specify depends on the purpose of the forecast. Using long-term
forecasts, you can estimate future budgets and expansion opportunities, and establish corporate
objectives. Using short-term forecasts (of one to three months) you can determine seasonal staffing
requirements, plan for short-term sales campaigns, and assess upcoming hiring needs. You can use
weekly, daily, hourly and half-hour forecasts to tweak agent schedules and adjust for absenteeism.

CONDUCTING FORECASTS
Conducting a forecast involves accurately estimating the three components of Call Load: the ACD
Handling Time, Wrap Up Time, and Calls Offered. After you run a forecast, it is useful to examine
the data and make adjustments based on present contact center conditions. You tweak the forecast
by adding or reducing calls based on your intuition and on information gathered by yourself and
others.
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To forecast the agent requirement, you
1. Examine trends in Call Load patterns.
2. Break the information down in to monthly, weekly, daily, half-hour, and 15-minute intervals
that reflect Call Load patterns.
3. Determine the handling times of calls.
4. Modify the forecast based on current contact center activities and other considerations, such
as absenteeism, agent breaks, holidays, and training.
You may need to consider the following issues: hardware or software system changes, expected
callers, advertising and media, changes to your products, services, or pricing, new products, product
performance, competitors' actions, and international, national, and corporate events. It is vital to
have a systematic forecasting process in place that all of the departments support. For detailed
information on Call Load, ACD Handling time, Wrap Up Time parameters, see "Forecasting terms"
on page 326.

STEP #4 CALCULATE THE RESOURCES REQUIRED
You calculate the agent requirement in conjunction with the trunking requirement. The number of
available agents affects the likelihood and length of delay experienced by callers. The delay affects
the load trunks must carry. Because the number of available agents impacts the number of trunks
required, you calculate the agent requirement first.
The Erlang C formula uses your historical Call Load and Average Talk Time data to predict the agent
requirement for the time interval and date range in the forecast. The resultant spreadsheet displays
the Call Load and agents required across time intervals.

PREDICTING AGENT REQUIREMENTS
Agent costs account for over 60 percent of all of the contact center costs. Accurately predicting the
agent requirement, making the most effective use of agents, and standardizing and monitoring agent
activities are paramount to achieving your service objectives. Agents are your most valuable
resource: make team building and team management a high priority.
You can predict the agent requirement for your Service Level Percentage and Service Level Time
targets by applying the Erlang C equation to the estimated Call Load and Average Talk Time.

UNDERSTANDING ERLANG C
Staffing models consider important factors unique to the inbound contact center environment:
l
l

l

Call arrival is random.
Consolidating resources allows the same number of contact center agents to handle more
calls while maintaining Service Levels.
Maintaining high Service Level targets requires staffing a large number of agents that will be
idle a significant portion of the day.

The industry standard Erlang C equation operates on these principals. Most contact center reporting
packages use Erlang C. An Erlang measures telephone traffic, or the flow of calls and call attempts
to your contact center during a given period. One Erlang equals one hour or 60 x 60 = 3,600 seconds
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of telephone conversation. This could be one call lasting one hour, six calls lasting 10 minutes, or
any combination of calls and call durations that equal 60 minutes. The Erlang formulas provide a
mathematical basis for making predictions about randomly arriving workloads.
A.K. Erlang, a Danish engineer who worked for the Copenhagen Telephone Company, developed
Erlang C in 1917. Agent and delay calculations use the Erlang C equation. It predicts the resources
required to keep delay times within your Service Level objective. Three variables influence the delay
time: the number of agents, the number of waiting callers, and the average time it takes to handle
each call.
Limitations of Erlang C
Erlang C has fundamental principles that do not reflect real-world circumstances. It assumes all of
the calls reach the contact center and all of the callers wait indefinitely to reach agents. Because
Erlang C assumes no blocking or abandons, it may overestimate the agents you need. Erlang C
requires accurate information on call flow where voice messaging and call overflow are employed,
assumes your Call Load prediction is extremely accurate, and assumes you have the same number
of agents handling calls the entire half hour.
Although Erlang C has its limitations, it is the preferred planning tool as it provides reasonable traffic
estimates for contact centers that maintain good service-minimal blocking and few abandons.

Considerations when predicting resource requirements
Erlang C provides theoretical numbers for staffing that you need to assess in light of the following
contact center realities:
l
l

The contact center blocks a certain proportion of calls and some callers abandon their calls.
Talk time is unpredictable, and although most calls may last two to three minutes, a few calls
can last upwards of an hour.

l

Agents in training may require more time to process calls.

l

Agents may use wrap up (after-call paperwork) time inconsistently during busy periods.

l

Not all of the agents within an agent group are available at all times to handle calls offered to
the agent group.

Erlang C predicts staffing needs fairly accurately. However, contact centers that use skills-based
routing, overflow, interflow, and advanced routing options need to use intuition and experience in
adjusting the final numbers.
The Erlang C formula uses your historical Call Load and Average Talk Time data to predict the agent
requirement for the time interval and date range in the forecast. The resultant spreadsheet displays
the Call Load and agents required across time intervals.

PERFORMING 'WHAT-IF' SCENARIOS
After you run a forecast, you can perform 'what-if' scenarios on the resultant data by changing the
value of forecast parameters and recalculating the results. You can enter values for the ACD Calls
Offered, average ACD Handling Time, Wrap Up Time, and Service Level Percent and Time and
recalculate the number of agents required. For example, you can reduce the average handling time
and recalculate the agents required and the calls handled across 15-minute time intervals for the
shift.
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UNDERSTANDING THE RELATIONSHIP BETWEEN AGENTS
AND TRUNKS
You are already familiar with the terms GOS (probability of blockage) and Service Level (average
wait time).
The following definitions are essential to understanding the relationship between agents and trunks.
Delay
Trunk calculations assume no queuing. For trunk calculations, the delay includes the time from when
a trunk picks up a call until an agent answers it.
Agent Load
The Agent Load includes the ACD Handling Time and Wrap Up Time.
Trunk Load
The Trunk Load includes the time from when a trunk picks up a call until the agent finishes speaking
to the caller and disconnects. The Trunk Load does not include Wrap Up Time.
Callers expect to have a 95 percent or better chance of obtaining a free trunk in to your contact
center, and expect to connect to an agent within a reasonable amount of time. There must be
sufficient trunks available to pick up calls, and sufficient agents available to handle the level of traffic
carried by the trunks. The more agents handling a given Call Load, the less delay callers’ experience.
Callers experience a delay if there are insufficient agents available. If the delay is considerable, calls
back up and some calls do not reach the contact center.
Traffic engineering involves estimating the number of trunks and amount of communications
equipment needed to service an anticipated number of callers. It revolves around basic questions
concerning the relationships between service parameters and trunk and agent resources. How much
traffic can a particular number of trunks handle for a particular GOS? What is the GOS for a particular
number of trunks and traffic level? How many trunks are required to handle a particular traffic level
and GOS? What is the probability of delay and length of delay experienced for a particular traffic level
and number of agents? How many agents are required to handle a particular traffic level for a given
set of delay characteristics?

UNDERSTANDING ERLANG B
Contact centers use the Erlang B equation to estimate the number of trunks required. Erlang B
assumes calls are not queued and that callers who receive a busy signal do not attempt to call again.
It can underestimate the trunks required. One Erlang equals one hour or 60 x 60 = 3,600 seconds of
telephone conversation.
Predicting your trunk requirement involves

36

l

Determining your Busy Hour Traffic (BHT)

l

Deciding how many blocked calls you can tolerate, or Grade of Service (GOS)
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BHT
The Busy Hour Traffic (BHT) statistic, measured in Erlangs, is the number of hours of call traffic (or
trunk traffic) you experience during the busiest hour of operation. It is important that your busy hour
figure represent the busiest Call Load your trunks will ever receive, and not just today’s peak traffic.
BHT is the (average call duration + average delay) x calls per hour ÷ 3600. This value represents the
highest Trunk Load (occupancy) in hours.
The call center traffic is the average number of trunks busy during the hour in question. One Erlang
equals one hour, or 60 x 60 = 3,600 seconds of telephone conversation. If a contact center
experiences 6.12 erlangs (or 6.12 hours of telephone conversation) during an hour, an average of six
trunks were busy.
GOS
The Grade of Service (GOS) value is a decimal fraction. A GOS of P.02 means a caller has a two
percent chance of receiving a busy signal. Contact centers use GOS in calculating the number of
trunks required. It is important to specify a GOS that is right for you in order for the trunk calculation
to be realistic.

PREDICTING TRUNK REQUIREMENTS
The number of trunks you require reflects the level of traffic expected during your busiest hour of
operation. The busy hour is the hour during the workday in which a trunk group carries the most
traffic. You calculate the Trunk Load after you forecast the Call Load for the busiest hour and
determine the number of agents required to handle the Call Load for your Service Level objective.
Traffic calculators used to predict contact center resource requirements are available on the Web
from companies such as erlang.com. You can obtain basic calculators at no cost. Calculators that
display and print results or calculations made during the previous week are available at a modest
cost.
To calculate the trunks required you simply input two of the figures and calculate the third. For
example, if you know that your Busy Hour Traffic is 10 erlangs and you want to determine how many
trunks are required when two calls are blocked in every 100 call attempts, you input the busy hour
time (10) and your target rate of blocking (0.02). The calculator displays a value for the trunks
required (17).
Figure 6 illustrates the trunks required across a spectrum of GOS values. Whether you chose a GOS
of 0.01, 0.05, or somewhere in between these values reflects how may calls per 100 call attempts
you can afford to lose. In revenue-based contact centers minimal blocking and delay is a priority.
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Figure 6: Estimating the trunk requirement
Although some contact centers base the trunk requirement on a staff-to-trunk ratio, such as 1.5
trunks per agent, many use the Erlang B equation. Whatever ratio results will be the right one for you.
It is better to slightly overestimate than slightly underestimate the number of trunks required: trunks
are inexpensive, compared to agent costs. You can always cancel a trunk if periodic Trunk Load
calculations show low occupancy on the trunk.
No staffing approach is absolute. You need to acknowledge the assumptions implicit in your
calculations and use common sense when estimating your resource requirements. When you
schedule resources, they must be closely monitored to ensure you are making full use of them.

STEP #5 SCHEDULE AGENTS
Scheduling involves accurately forecasting the workload and determining which agents should work
which shifts. This has traditionally been a labor-intensive manual process for contact center
supervisors. You can schedule agents for breaks, split shifts, ACD and non-ACD work periods,
repeating work patterns, holidays, and on call work. You can categorize agents by pay level,
overtime eligibility, skill level, employment status (part time or full time), and scheduling preferences.
Matching these shift and agent variables to the anticipated workload, and re-allocating agents in
response to employee absenteeism can be a daunting task.
Scheduling is becoming increasingly challenging, as contact centers support a wider range of
products and services, and agents require more frequent and specialized training. Advances in
technology have automated many agent tasks and have resulted in more varied and challenging
calls and responsibilities.
Accurately forecasting and building schedules that reflect the workload as it changes across
intervals for days of the week, weeks of the month, and seasons of the year is essential in meeting
your service objectives. You need a schedule that accurately matches agents to the anticipated
workload and agents who aspire to adhere to the activities scheduled.
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You can track the availability and activities of agents throughout the day and verify agents are
performing the duties for which they are scheduled. Not adhering to the schedule, such as forgetting
to log out for a break, or performing non-ACD work when scheduled to perform ACD work adversely
affects your Service Level and the moral of other agents who must compensate for the unavailable
agent.

UNDERSTANDING THE SHRINKAGE FACTOR
Accurately forecasting the workload and scheduling agents to satisfy your Service Level objective is
a good start, but does not account for the activities that prevent agents from sitting at their desks and
handling telephones.
Agents scheduled for ACD work can be involved in some of the following activities:
l

On a bathroom break

l

Making or receiving personal calls

l

Conferring with the supervisor or another agent

l

On the phone with other departments

l

Sending emails or faxes

l

Involved in a lengthy, difficult call

l

Prolonged in after-call work

l

Absent due to illness or compassionate leave

To account for short-term or daily unscheduled absences, you can calculate the rostered staff factor
(Shrinkage Factor). The Shrinkage Factor is a numerical value that defines the percentage of time
agents are scheduled to work but are unavailable to handle calls. It tells you the number of agents
you must schedule in addition to the base number of agents required to meet your Service Level.

CALCULATING THE SHRINKAGE FACTOR
You calculate the Shrinkage Factor for one or more agent groups as follows:
1. Determine the base staff forecasted by hour or half hour for the day.
2. Make a list of activities that prevent ACD agents from handling calls.
3. Add the base staff to the number of agents who are unavailable to handle calls because they
are absent, on break, at an unanticipated meeting, etcetera.
4. Calculate the Shrinkage Factor for each time interval by dividing the scheduled staff by the
base staff required to handle telephones.
The result is a set of Shrinkage Factors that represent the expected shrinkage by half hour.
See Figure 7.
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Figure 7: Calculating the Shrinkage Factor
You multiply shrinkage values against the base staff required on telephones when setting future
schedules. If your agent requirements vary considerably on certain days of the week, you can
calculate a separate set of Shrinkage Factors for these days. You must use your good judgment in
identifying absences that are relevant to include in your Shrinkage Factor calculations. Anticipating
higher absenteeism on Fridays and Mondays is a safe bet while factoring in daily compassionate
leave is not. As with all of the steps in contact center planning, routinely assess the accuracy of your
shrinkage predictions and adjust them as required.

OPTIMIZING SCHEDULES
Now that you have adjusted your agent requirement to account for unanticipated absences, the next
step is to design a schedule that makes the most of your resources.
The following examples illustrate ways to adequately staff a contact center without having agents sit
idle during slower periods.
Scheduling split shifts
Although not everyone likes to take a long break in the middle of a shift, for some agents split shifts
fit well with priorities outside of work. For contact centers that experience heavy call traffic in the
morning and evening, split shifts prevent overstaffing during these periods.
Staggering shifts
Staggering shifts allows you to maintain staffing levels over busy periods or periods when agents are
on breaks. For example, one set of agents could start at 8:00 A.M., a second group at 9:00 A.M., and
a third group at 10:00 A.M. so the contact center is fully staffed when it starts getting busy midmorning. Alternately, you could schedule morning and afternoon shifts that overlap from noon until
1:00 P.M. to enable the morning shift to break for lunch while the afternoon shift handles calls.
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Staggering breaks
Making slight adjustments to the timing of morning, lunch, and afternoon breaks has a tremendous
effect on call handling. The Erlang C equation predicts 28 agents can handle 300 calls, each lasting
280 seconds and delayed 20 seconds. (See Figure 8.)
Figure 8 illustrates that changing the availability by one agent decreases the average delay time by
five seconds, and allows the contact center to handle 16 additional calls.

Figure 8: Staggering breaks to optimize call handling
Forecasting non-ACD work
Not all of the non-ACD work must be performed immediately. For example, call-backs to clients,
emails, and discussions with staff and supervisors can sometimes wait until less busy periods.
Forecast and schedule non-ACD work for slow times to ensure sufficient agents are available during
peak periods. Set availability priorities and regularly communicate them to agents.
Scheduling part-time agents and agents on call
When practical, scheduling part-time agents and agents on call can be an effective strategy for
topping up your pool of available agents. Scheduling agents on call is particularly useful for days of
the week and seasons when absenteeism is noticeably higher.

ROUTING CALLS TO OPTIMIZE COVERAGE
To optimize service, you can use the following routing strategies that involve resources outside of
the target agent group.
Overflowing calls to less busy agent groups
You can overflow calls from busy agent groups to less busy agent groups during peak periods. You
can route calls to agents who primarily perform non-ACD work but act as reinforcements during busy
periods, and to supervisors.
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Employing call-back messaging
You can program the ACD to forward calls to voice mail so callers can leave messages instead of
waiting for live agents. Call-back messaging helps to balance agent workloads between peak call
periods and slow periods.
Contracting calls to customer care bureaus
Contracting calls is a growing industry. During peak periods, you can route simple, routine calls
externally to customer care bureaus. Service bureaus collaborate with contact centers to set up
scheduling and monitoring practices, and train agents to handle calls that vary in complexity.
Employing ACD enterprise call routing
Contact centers that provide extended, or around-the-clock service, can interflow calls to other sites.
For example, you can interflow mid-day calls received by a busy center in San Francisco to agents
working the late-afternoon shift at a center in Philadelphia. This optimizes call handling without
scheduling additional agents.

SCHEDULING CONSIDERATIONS
Scheduling should be a collaborative effort. Agents have schedule preferences, and want to know
when they are working well in advance. Agents are more likely to adhere to schedules if they are
involved in defining the conditions of schedule adherence and non-adherence, and in other areas of
the planning process.
Producing long-term schedules is less efficient than producing monthly schedules, as contact center
conditions and agent availability are continually changing. Short-term scheduling is more accurate,
but less popular with agents. It is important to find a good balance.
Measuring scheduling accuracy
You can measure the effectiveness of your scheduling process. Create a line graph of the Service
Level for each half-hour interval for each day over the past week. Draw a horizontal line across the
graph to indicate your service objective. Look for inconsistencies in the service provided for different
time intervals across days, and how far you stray from your service objective.
If the Service Level is erratic, you may have enough resources in place, but they may not be
consistently available to handle calls. If the Service Level is inconsistent at certain time intervals
across the week, or you are not meeting your Service Level objective, investigate to see if you are
adequately staffed at these times and are making the best use of resources. Try to assess how
consistently the agents are responding to real-time information displays. Determine if they are
restricting non-ACD activities to slow periods and adhering to the schedule.
Scheduling agents with workforce management tools
Workforce management tools assist you in scheduling agents for work and holiday periods. Many
packages offer an integrated forecasting component that uses historical data to partially automate
the scheduling process for established agents. Scheduling is not entirely automated: you must
tweak agent schedules and enter shift and agent variables for agents manually.
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STEP #6 DETERMINE CONTACT CENTER COSTS
An effective budget conveys what is currently happening in the contact center, projections for the
upcoming year, and business objectives. It is important to highlight the trade-offs between the
service provided to callers and costs to the organization by developing at least two budgets that
reflect different scenarios.
You need to provide a clear indication of how the money is being spent, what you are doing to reduce
or curb spending, and what equipment is required to meet service objectives and expected growth
over the next year. Budgeting is on-going process that needs continuous refinement.

BREAKING DOWN EXPENSES
The costs associated with contact center operations include
l

l

l

Loaded labor costs
Loaded labor costs include wages, fringe benefits, and facilities, and account for over 60
percent of contact center costs. This is a significant cost and underlines the importance of
accurate forecasting and scheduling.
Equipment and automation costs
Equipment and automation costs include the cost of the telephone system, computer
systems, and furniture, and account for about five percent of total expenses.
Transmission costs
Transmission costs include costs incurred for voice (telephone lines) and data transmission,
and account for 25 to 30 percent of contact center costs. Transmission costs have decreased
considerably in the past few years and are continuing to drop. In revenue-based contact
centers, toll-free lines cost approximately 15 cents per minute, or nine dollars per hour, per
line.

The following statistics help you breakdown and analyze your contact center costs:
l

l

l

Cost of Delay
When insufficient agents are available to handle a given Call Load, the delay increases as
does the Trunk Load. Calls are queued. For toll-free services each call delayed in queue is a
cost to the organization. You are charged for the toll-free service from the time a trunk picks up
a call until an agent completes the call and hangs up. The expense of queuing callers is known
as the Cost of Delay. Staffing affects toll-free service costs: if insufficient agents are
available and the Service Level is continually low, network costs will be high. You need to
consider the Cost of Delay when estimating the agent requirement, and closely monitor it.
Cost per Call
You use a cost-per-call analysis to measure contact center profitability and performance. The
cost per call measures labor, communication, and equipment costs against the revenue
generated. You calculate it by dividing the total cost by the total calls for a particular period of
time.
Average Call Value
You use the Average Call Value in revenue-based contact centers. You calculate it by dividing
the total revenue by the number of calls received for a given period. Sales and reservations
environments use the Average Call Value. The value of each call is balanced against the
service provided to customers.
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ANTICIPATING GROWTH
Predicting company growth is a challenging and essential aspect of contact center costing. Growth
predictions impact budgeting considerations and must be clearly communicated to senior
management. It is useful to map out your projected costs and time frames for the upcoming year and
substantiate them with statistics and graphs. Determine when and how many resources you require,
and lead-time issues.
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GETTING STARTED
After you install Contact Center Management on the Enterprise Server, you must set up the
Enterprise Server and client computers to use Contact Center Management. This section provides
basic information on post-installation procedures. For detailed information on installation and postinstallation procedures, see the Contact Center Management Installation Guide.

REGISTERING CONTACT CENTER MANAGEMENT
NOTE:
l

l

If you have not registered your Contact Center Management software, seven days after you
install it you will no longer be able to log on to Contact Center Management and will be
required to contact Mitel to register the software. After you register your contact center Mitel
emails permanent license files to you. You implement these license files on the Enterprise
Server to activate your software.
Registration information is processed during regular business hours only (Monday to Friday
from 8:30 A.M. to 6:00 P.M. ET).

When you initially register your software with Mitel, for 90 days you receive
l

The latest Contact Center Management software updates.

l

Free technical support.

NOTE: When you purchase base products, 90 days of Software Assurance is included with the
option of purchasing more. See the Contact Center Solutions and Business Reporter System
Engineering Guide for more detailed Software Assurance information.
To register with Mitel
l

l

Call Mitel at 1-800-722-1301 (North American customers) or your approved Mitel vendor (for
customers residing in Latin America, Europe, the Middle East, Africa, and Asia Pacific).
The turnaround is immediate. (Recommended)
Visit Mitel Online, click Products=>Applications=>Mitel MiContact Center. Under
Related Links, click MiContact Center Partner Portal. Then click Online
tools=>Software Registration and fill out the registration form. Click Submit.

ACTIVATING CONTACT CENTER MANAGEMENT
If you did not activate Contact Center Management during installation, you can activate it now. If you
have access to the Internet, you can rerun the Installation Wizard at any time to register Contact
Center Management online. If you do not have access to the Internet or if you cannot access our
license server, you can register offline.
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To activate the Contact Center Management software online
1. On the Enterprise Server, navigate to the Mitel program folder and open Mitel Contact
Center Management Licensing.
2. Click Register Online.
The Online Registration window opens.
3. Type your 26-digit site serial number and click Register.
To activate the Contact Center Management software
1. On the Enterprise Server, navigate to the Mitel program folder and open Mitel Contact
Center Management Licensing.
2. Click Register Offline.
The Offline Registration window opens.
3. Click the here link in the first step to open the directory that contains the license package.
4. Email the license package to miccsupport@mitel.com.
Mitel will sign the license files and send them back to you.
5. After you receive the signed license files, save them to a directory.
NOTE: We recommend you place the license files in the original directory.
6. Repeat steps 1-2 to open the Offline registration window.
7. Type your 26-digit site serial number.
8. Click Browse and specify the directory that contains your .dlsc license file.
9. Click Apply License.
The license registration is complete.

Updating license files on the Enterprise Server
You must update the license files on your Enterprise Server with the new license files Mitel sends
you.
To implement new license files
1. On the Enterprise Server, start Windows Explorer.
2. Save the new license files in the following directory, <drive>:\Program Files (x86)
\prairieFyre Software Inc\CCM.
3. Click Yes to overwrite the existing files.

SETTING UP CONTACT CENTER MANAGEMENT ON
THE ENTERPRISE SERVER
After you install the Contact Center Management software on the Enterprise Server, you need to set
up the server and client computers to use Contact Center Management. To view detailed installation
procedures, click Help=>Documentation and click the Contact Center Management Installation
Guide to open it.
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SETTING UP CONTACT CENTER MANAGEMENT ON
CLIENT COMPUTERS
NOTE:
l

l

The date format for Contact Center Management is tied to the regional settings on your client
computer. For example, if you configure your computer to display the date as mm/dd/yyyy,
when you browse to the Contact Center Management Web UI, the Contact Center
Management applications display the date as mm/dd/yyyy.
The system administrator must provide all of the Contact Center Management users with a
user name and password.

To set up a client computer to use Contact Center Management on the client computer
1. Start Contact Center Management.
See "Starting Contact Center Management" on page 48.
2. Install Client Component Pack.
3. Use Client Role Selector to select your Contact Center Client role.

STARTING CONTACT CENTER MANAGEMENT
To start Contact Center Management on the Enterprise Server or on a client computer
1. Start Internet Explorer type your Enterprise Server IP address http://[your Enterprise Server
IP address]/CCMWeb/. Otherwise, click the Contact Center Management desktop icon.
2. If you do not see the Contact Center Management desktop icon, to create a shortcut to
Contact Center Management, move the Contact Center Management Web address to your
desktop using a drag-and-drop operation.

INSTALLING THE LATEST VERSION OF CLIENT COMPONENT
PACK
NOTE:
l

l

l
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Microsoft .NET Framework 4.5 must be installed on your system before you install the Client
Component Pack. If .NET Framework 4.5 is not installed on client machines and you are
connected to the Internet, the installer will install .NET Framework 4.5. If you are not
connected to the internet, you must install .NET Framework 4.5 on client machines manually.
Note that Windows 8 includes .NET Framework 4.5
The Microsoft Report Viewer 2010 Redistributable Package must be installed on all clients
before you install the Client Component Pack. If Microsoft Report Viewer 2010
Redistributable Package is not installed on client machines and you are connected to the
internet, the installer will install Microsoft Report Viewer 2010 Redistributable Package during
the installation. If you are not connected to the internet, it must be installed manually. It can be
downloaded from http://www.microsoft.com/en-us/download/details.aspx?id=6442.
If you use Contact Center PhoneSet Manager or Contact Center Softphone, you must install
Visual C++ Redist 2010 RTM on client machines. If connected to the internet, this will be
installed automatically during the installation. You can download this application from
Microsoft: http://www.microsoft.com/en-ca/download/default.aspx.

Setting up Contact Center Management on client computers

You can install Client Component Pack on individual client computers or servers running Citrix
Terminal Services.
NOTE: If the client is on an external network, you can either:
l

VPN to the internal network and install the Contact Center Client, or

l

Copy the Contact Center Client from the server to the client using a CD or USB key

l

Use an administrative procedure to silently install Client Component Pack on remote
desktops
See "Installing Client Component Pack using an administrative procedure" on page 49.

To install Client Component Pack on the client computer
1. On the client computer, start Internet Explorer and type http://[your Enterprise Server IP
address]/CCMWeb.
2. If prompted, type your user name and password and click Submit.
3. Click Help=>Software downloads/Installations.
4. Click Client Component Pack.
The File Download - Security Warning window opens.
5. Click Run.
6. Click Continue.
The Mitel Contact Center Solutions Client Component Pack Self Extractor window opens.
7. Click Accept to install Microsoft Visual Studio 2010 Report Viewer.
8. Click Install to install Microsoft WSE 3.0 Runtime, CheckForEnterpriseServerInstall,
prairieFyre-Enable .Net, and prairieFyre - Client System Requirements Check.
The Mitel Contact Center Solutions Client Component Pack - InstallShield Wizard opens.
9. Click Next.
10. After Enterprise IP Address, type the IP address of the Enterprise Server. Optionally, click
Test to test the client computer connection to the Enterprise Server.
11. If your Enterprise uses SSL, select the SSL check box.
12. Click Install.
The program features you selected are installed.
13. Click Finish.
The Select role window opens. See "Using the Client Role Selector to select your Contact
Center Client role" on page 51

INSTALLING CLIENT COMPONENT PACK USING AN
ADMINISTRATIVE PROCEDURE
You can install Client Component Pack silently on remote desktops using an MSI (Microsoft
Installer) administrative installation procedure. A silently installed program is a program that can be
installed with no user interaction.
To install client software silently on remote desktops
1. Install the prerequisite software.
2. Locate the client_setup_x86_x64.exe and extract Client Component Pack.msi.
3. Perform the .msi procedure for the administrative installation.
4. Run the silent installations.
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Installing the prerequisite software
Before you install client software, you must install the prerequisite software. If client computers are
connected to the Internet or run Windows 8, skip step 1.
To install the prerequisite software
1. If the client computer runs Windows 7 and is not connected to the Internet, install .NET
Framework 4.5 on the machine.
2. On the Enterprise Server, start Internet Explorer and type the URL http://[the Enterprise
Server IP address]/CCMWeb/.
3. Log in to CCMWeb and click Help.
4. Click on the Software downloads/Installations tab.
5. Click Software Downloads.
6. Download and run Client Component Pack.

Locating the client_setup_x86_x63.exe and extracting Client
Component Pack.msi
To locate the client_setup_x86_x64.exe and extract Client Component Pack.msi
1. Go to the src folder located in your Contact Center Solutions Installation folder.
NOTE: The default location of this folder is C:\CCM\src.
2. Open client_setup_x86_x64.exe.
3. Open the folder that was modified the same day you extracted client_setup.exe. The folder
naming format will be xxx_xxxx.
Client Component Pack.msi will be in that folder.

Performing the MSI procedure for the administrative installation
NOTE: See "Installing the prerequisite software" on page 50 for a list of programs that must be
installed on each computer before you install Client Component Pack.
You must create a command for the administrative installation that is similar to the following
example: msiexec /a”\\Mitel Installations\Setup\Client Component Pack.msi” SSLSTATUS=0
ENTERPRISEIPADDRESS=10.1.4.12
To perform the MSI procedure for the silent installation
1. Open the command prompt window.
2. Open the folder where the msi file is located.
3. Type MsiExec.exe /a.
4. Press the spacebar.
5. Drag the msi file from the folder where it is located to the command prompt window.
6. Press the spacebar.
7. Type SSLSTATUS=.
8. If the Enterprise Server uses a secure socket layer, type 1. If it does not, type 0.
9. Press the spacebar.
10. Type ENTERPRISEIPADDRESS=.
11. Type the Enterprise Server IP address or DNS name.
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12. Press Enter.
The InstallShield Wizard opens.
13. Follow the instructions of the Wizard.
14. Ensure the file is saved to a network drive.

Running the silent installation
NOTE: Subsequent updates are done via the prairieFyre Updater Service.
To silently install Client Component Pack
1. In Windows, open the Run command.
2. Type “\\<path to administrative installation package>\Client Component Pack.msi”
/qb
Contact Center Client and the prairieFyre Updater Service are installed.

USING THE CLIENT ROLE SELECTOR TO SELECT YOUR
CONTACT CENTER CLIENT ROLE
The Contact Center Management client installation includes the Client Role Selector. It is a wizard
that helps you select a Contact Center Client role based on the functions you perform. The roles are
as follows:
l

Supervisor is designed for supervisors and managers who monitor devices (for example
agents and queues) and schedule agents.

l

Agent is designed for agents who monitor themselves and/or other agents and queues.

l

Administrator is designed for employees who manage the Enterprise Server.

l

Power user is designed for employees who may perform the functions of a supervisor, agent,
and administrator.

You can re-run the Client Role Selector on a client computer at any time to change the components
and applications installed on the client computer.
NOTE: If you want to customize the client installation, select Power User. For example, if a
supervisor also performs administrative functions, select the Power User role and choose the
components and applications the supervisor will need.
Table 1 lists the components and applications available for installation with each client role
installation. Only those applications for which you have a license are listed here.
Table 1: Client role installation
COMPONENTS/APPLICATIONS SUPERVISOR AGENT ADMINISTRATOR
Ignite*

x

Contact Center Client

x
x

Flexible Reporting*

x

Contact Center Softphone*

x

POWER
USER
x

Optional

x
x

x

x

51

Contact Center Solutions User Guide

Table 1: Client role installation (continued)
COMPONENTS/APPLICATIONS SUPERVISOR AGENT ADMINISTRATOR
Mitel Border Gateway Connector*

x

Workforce Scheduling*

x

x

POWER
USER
x
x

YourSite Explorer

x

x

Salesforce.com Connector*

x

x

x

x

Employee Portal*

x

x

x

x

*Ignite, Flexible Reporting, Contact Center Softphone, Mitel Border Gateway Connector,
Salesforce.com Connector, Workforce Scheduling, Employee Portal, and Multimedia Contact
Center are optional applications to Contact Center Management that you purchase separately
depending on your license level. Some of these components are included in contact center starter
packs. For more information, see the licensing section of the Contact Center Solutions and
Business Reporter System Engineering Guide.

Running Client Role Selector
To run Client Role Selector:
1. If you are installing software on the client computer for the first time, go to step 2. Otherwise,
open the Client Role Selector.
2. Click a client role.
3. Click Next.
4. Select the check boxes of the features to be installed.
•

Ignite

•

Contact Center Client

•

Flexible Reporting

•

Contact Center Softphone

•

Mitel Border Gateway Connector

•

Workforce Scheduling

•

YourSite Explorer

•

Salesforce Integration

•

Employee Portal

5. Click Finish.
After the wizard installs the features you selected, the Contact Center Client log on window
opens.
6. Close the Contact Center Client log on window.
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DISABLING THE IE SECURITY WARNING
When you browse Contact Center Management, you may see an Internet Explorer (IE) security
warning. You can disable the warning.
To disable the IE security warning
1. Start Internet Explorer in your browser.
2. Click Tools=>Internet Options=>Security.
3. Select the Web content zone used to access the site.
The Web contact zone is typically Internet.
4. Click Custom Level.
5. Under Settings select Miscellaneous.
6. Under Miscellaneous, after Display mixed content, click Enable.
7. Click OK.

PROVIDING MITEL BORDER GATEWAY
FUNCTIONALITY TO REMOTE EMPLOYEES
The Mitel Border Gateway Connector replaces what was formerly called Teleworker support for
Contact Center Solutions and Business Reporter software. Using Mitel Border Gateway Version 7.1
or greater, remote employees can connect to the Enterprise Server using a VPN-like connection, and
use all Contact Center Solutions and Business Reporter applications as if they were in the office.
With the Mitel Border Gateway Connector, customers can now optionally configure connections to
multiple instances of the Mitel Border Gateway. When employees connect to the system using the
Mitel Border Gateway Connector, they can specify which Mitel Border Gateway they will connect to.
After remote employees attempt to connect to the system for the first time, a Mitel Border Gateway
system administrator must approve the Mitel Border Gateway certificate from the Mitel Border
Gateway web application. Once approved, remote users are connected and have access to all of the
Contact Center Solutions and Business Reporter applications for which they are licensed and have
the required security permissions. While active, the Mitel Border Gateway Connector is visible in the
Windows system tray and displays the name of the active connection. Only one connection can be
made at a time. The name of the Mitel Border Gateway connection will become the address in all
application login windows and users sign in with their normal username and password.
The Mitel Border Gateway Connector offers the same trusted characteristics as with a standard
Mitel Border Gateway deployment: local streaming, secure RTP, jitter buffering and packet handling
QoS, and G.729 and G.711 encoding. For more information on how to configure Contact Center and
Business Reporter software to support Mitel Border Gateway, see the Contact Center Management
Installation Guide.
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NOTE:
l
l

l

l

l

l

The Mitel Border Gateway Connector supports Mitel Border Gateway V7.1 and V8.
The following corporate firewall ports must be open in order to take advantage of the full
features and functionality provided by the Mitel Border Gateway Connector: 80, 443, 1433,
5024, 5025, 5026, 5030, 7001, 7003, 8083, 8084, 36000-36004, 35001-35007, and 42440.
You must disable IIS and SQL Server Reporting Service services as they consume port 80,
which is required for the Mitel Border Gateway Connector. Any other applications or services
that consume port 80 or 443 should also be disabled or shut down.
You cannot use the Windows Authentication sign-in model for Contact Center Solutions and
Business Reporter
Ensure the Start button is enabled at all times on the Mitel Border Gateway web application
user interface or the Mitel Border Gateway Connector will fail.
You must be logged in as an administrator on a client computer in order to configure a
connection to a Mitel Border Gateway. Once the connection has been made, any user on the
computer can connect using the Mitel Border Gateway Connector.

SETTING UP PHONES FOR REMOTE AGENTS AND
EMPLOYEES
If you are working at the office and select Remember my credentials when you log on to Contact
Center Client, and then subsequently attempt to log on at home, your log on will fail. Contact Center
Client does not recognize your office IP address when you log on remotely.
NOTE: Before you set up the soft phone on your client computer, ensure your network administrator
has configured your soft phone as a 5020 IP phone on the telephone system.
To set up Contact Center Softphone and Contact Center PhoneSet Manager to support the Mitel
Border Gateway Connector, you must
1. Register your phones for use with Mitel Border Gateway V7.1 or V8.
2. Approve the Mitel Border Gateway V7.1 or V8 certificate.
3. Log in to client computers using an administrative account and set up the connection to the
Mitel Border Gateway from the Mitel Border Gateway Connector.

REGISTERING PHONES FOR USE WITH MITEL BORDER
GATEWAY
The system administrator must register your phone before you can use the Mitel Border Gateway
Connector. Contact Center PhoneSet Manager treats new extensions like new phones; each time
you enter a new extension you must use the dial pad to type the password (provided by your system
administrator) to register the phone.
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To register your phone with Mitel Border Gateway
1. Ensure you have completed the steps listed under "Configuring Mitel Border Gateway on the
Mitel Application Server" in the Contact Center Management Installation Guide and that you
have added an ICP to the Mitel Border Gateway.
2. On the Mitel Border Gateway server, under Applications, click Mitel Border Gateway.
3. On the Status tab, ensure that the Mitel Border Gateway status is enabled. If it is not, after
Start or stop MBG, click Start.
4. Click Services=>MiNet Devices.
5. Click Add a MiNet device.
6. For Contact Center Softphone phones, after Device ID, type a1:21:00:00:xx:xx, where xx:xx
is the extension.
7. For Contact Center PhoneSet Manager phones, after Device ID, type the MAC address
located under the agent’s Mitel phone.
8. If required, specify other optional settings.
9. Click Save.

APPROVING THE MITEL BORDER GATEWAY CERTIFICATE
The Mitel Border Gateway system administrator must approve the Mitel Border Gateway V7.1 or V8
certificate before agents and employees can use the Mitel Border Gateway Connector.
To approve the Mitel Border Gateway certificate
1. Log on to the Mitel Border Gateway server.
2. In the left pane under Security, select Certificate Management.
The Manage Certificates window opens.
3. Under Queued CSRs, select the certificate that needs approval.
4. Select Approve or Revoke.

RUNNING THE MITEL BORDER GATEWAY CONNECTOR
In order to use Contact Center Solutions and Business Reporter applications with Mitel Border
Gateway, you must run the Mitel Border Gateway Connector and configure the connection to the
Mitel Border Gateway.
NOTE: A user with administrative credentials must be logged in to client computers when
configuring connections to the Mitel Border Gateway for the first time. After this is complete, any
user can sign in to the computer, run the Mitel Border Gateway Connector, and connect to a Mitel
Border Gateway.
To install and configure the Mitel Border Gateway Connector
1. If this is not the first time you have run the Mitel Border Gateway Connector, skip to step 9.
Otherwise, consult your network administrator to confirm your soft phone extension number.
2. Ensure your headphone is connected.
3. Run Client Component Pack.
See the Contact Center Management Installation Guide.
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4. If you are installing software on the client computer for the first time, go to step 5. Otherwise,
open the Client Role Selector.
5. Click a client role.
l

l

l

Supervisor—The Supervisor role is for supervisors and managers who monitor devices,
such as agents and queues, and schedule agents.
Agent—The Agent role is for agents who monitor themselves and/or other agents and
queues.
Power user—The Power user role is for employees who may perform the functions of a
supervisor, agent, and administrator.

6. Click Next.
7. Select Mitel Border Gateway Connector and all other options you need, such as Contact
Center Softphone.
8. Click Finish.
9. In Windows, open the Mitel Border Gateway Connector.
Ensure you are logged in to the computer with administrative credentials.
10. Click New.
11. After Name, type a name for the connection to the Mitel Border Gateway.
12. After IP address, type the IP address of the Mitel Border Gateway.
13. After MAC address
l

l

If you have a desk phone, type the MAC address located on the sticker under your desk
phone.
If you have a soft phone, click Extension, type your soft phone extension number, and
click OK.

14. Click OK.
The connection to the Mitel Border Gateway you just created will display in the Mitel Border
Gateway Connector list.
To run the Mitel Border Gateway Connector
1. Start the Mitel Border Gateway Connector.
2. Select a connection to a Mitel Border Gateway from the list.
3. Optionally, enable the Connect automatically checkbox.
Enabling this checkbox will automatically connect you to the configured Mitel Border Gateway
when you launch the Mitel Border Gateway Connector.
4. Click Connect.
A message displays stating 'Waiting for certificate approval'. If the request is rejected,
contact your system administrator to approve the certificate.
Once your certificate has been approved, you can begin using all Contact Center Solutions
and Business Reporter applications remotely as if you were in the office. Any user configured
with administrative credentials on the computer can change the Mitel Border Gateway
connection settings and delete connections from the Mitel Border Gateway Connector at any
time.
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SETTING UP USER PREFERENCES
You can change your preferences at any time. They are found in CCMWeb (formerly known as the
Contact Center Management website) under My options. From this menu, you can:
l

Specify your language preference

l

Change your password

l

View your security role properties

l

Configure email contacts

SPECIFYING YOUR LANGUAGE PREFERENCE
NOTE: Contact Center Solutions applications, such as YourSite Explorer and Contact Center
Client, all leverage the language settings of the operating system in addition to the language
preference set for Contact Center Solutions. Ensure that if you adjust the language settings of
Contact Center Solutions, you also adjust the language settings of your operating system to match.
To specify your language preference
1. In CCMWeb, under My options tab, click My preferences.
2. After Display this language, select a language.
3. Click Save.

CHANGING YOUR PASSWORD
To change the password for your login
1. In CCMWeb, My options tab, click My password.
2. After Old password, type your old password.
3. After New password, type your new password.
4. After Confirm new password, type your new password.
5. Click Save.

VIEWING SECURITY ROLE PROPERTIES
You can view your security role properties. They describe the application areas to which you can
gain access. Only employees with access to YourSite=>Configuration can change the security role
properties of employees.
To view the security role properties of the credentials with which you logged in
l

Click My options=>My security role.
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CONFIGURING EMAIL CONTACTS
You can create a list of email contacts and email contact groups to whom you email reports. Contact
groups can contain both user-configured contacts from CCMWeb as well as all existing employees
from YourSite Explorer.
NOTE: You must configure SMTP settings in YourSite Explorer before you can configure email
contacts. See "Configuring SMTP connections to Contact Center Solutions" on page 83.
To create a contact group
1. Add email contacts
2. Add contact groups
3. Add email contacts to the groups

Adding email contacts
To add an email contact
1. In the My options tab menu, click My contacts=>My email contacts.
Alternatively, click My options. In the My contact tab, click My email contacts.
2. Click Add.
3. After First name, type the first name of your contact.
4. After Last name, type the last name of your contact.
5. After Email address, type the email address of your contact.
6. To save this contact, click Save.
7. To save this contact and add another contact, click Save & Add.

Adding contact groups
To add a contact group
1. In the My options tab menu, click My contact=>My email contact groups.
Alternatively, click My options. In the My contact tab, click My email contact groups.
2. Click Add.
3. After Name, type the name of the contact group.
4. After Description, type the description of the contact group.
5. To share this contact group with other CCMWeb users, select Shared Contact Group.
A shared contact group can be viewed, used, and edited by other users.
6. To save this contact group, click Save.
7. To save this contact group and add another contact group, click Save & Add.
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Adding email contacts to contact groups
To add an email contact to a contact group
1. In the My options tab menu, click My contacts=>My email contact groups.
Alternatively, click My options. In the My contact tab, click My email contact groups.
2. Click Members for the contact group with which you want to associate agents.
3. If you want to add members from your contacts configured in CCMWeb, click Contacts.
If you want to add members from the employees configured in YourSite Explorer, click
Employees.
Both contacts and employees can be added to the same contact group.
4. Under Available contacts, select the check boxes of the members you want to add to the
group and click Add >>.
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SERVICES AND DATABASE ADMINISTRATION
This chapter includes a description of how to back up data and of the functions available in
Management Console (updating server IP addresses, running the maintenance routine immediately,
summarizing data, creating a support package, controlling services, and converting Toolbox and
Contact Center Solutions data files to Mitel data files).

BACKING UP DATA
We recommend backing up Enterprise Server data on a regular basis as a preventive measure in
case of events that could cause loss of data and necessitate system restoration. The frequency of
backups depends on how important the data is to your business. If losing one week of data is
acceptable, then backing up once a week is sufficient. If losing more than one day of data is
unacceptable, then a daily backup strategy should be implemented.
NOTE: We strongly recommend storing backup files in a location outside of the Enterprise Server in
order to maintain essential data in the case of a hardware failure or catastrophic event. We
recommend you back up the SQL server data files, YourSite Database configuration data files, and
raw telephone system data files to an off-board media type (DVD, CD, tape, alternate network
drive).
The data files contained in the following default folders should be backed up using your corporate
backup solution. Suggested backup tools include Symantec Backup Exec and Microsoft System
Center Data Protection Manager:
l

l

<drive>:\Program Files (x86)\prairieFyre Software Inc\CCM\BackupFiles - This folder
contains the nightly .xml backups of configuration data and IVR Routing and Multimedia
Contact Center workflows and prompts that are created during nightly maintenance.
<drive>:\Program Files (x86)\prairieFyre Software Inc\CCM\DataDirectory - This folder
stores all raw telephone system data from the media servers. Using this data you can resummarize your raw data to enable reporting. This folder also contains the Multimedia
repository for all media, excluding voice.

In the event of server failure, you can restore your company history and configuration with
l

A backup copy of .xml files.

l

A backup copy of the SQL server data files.

l

A backup copy of the YourSite database.

l

The raw telephone system data files stored on the local hard drive.

BACKING UP .XML FILES
The maintenance routine automatically backs up an .xml file of the YourSite database every night.
This backup file is stored in the directory: <drive>:\Program Files (x86)\prairieFyre Software
Inc\CCM\Backup Files. The maintenance routine keeps an .xml file for each of the last 30 days
maintenance ran.
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To back up or restore the .xml files
1. Start Contact Center Client.
2. Click Tools=>Management=>Configuration.
3. Click Back up/Restore configuration data.
4. Follow the steps in the Backup and Restore Wizard to back up or restore the database.

BACKING UP RAW TELEPHONE SYSTEM DATA FILES
To back up raw telephone system data files
1. On the Enterprise Server, right-click Start=>Explore.
2. Copy the <drive>:\Program Files (x86)\prairiefyre software inc\CCM\DataDirectory
folder to the desktop, a network share, or optionally store it on a CD.

BACKING UP ENTERPRISE SERVER CONFIGURATION DATA
CAUTION: Restoring the YourSite database deletes all of the current database table entries and
replaces them with the entries defined at the time of your last database backup. Any changes made
to the database in the interim are lost.
Backing up and restoring Enterprise Server configuration data offers protection in case you program
the database incorrectly, or a careless user reconfigures it. Mitel recommends you perform this
backup weekly, in addition to regular database maintenance. If required, you can later recover the
YourSite database data exclusively, rather than restoring the entire SQL database.
NOTE: As a security measure, if backed up data is restored on an Enterprise Server with a different
IP address than the Enterprise Server it was backed up on, all mail server incoming and outgoing
usernames and passwords will be blank in YourSite Explorer. Administrators must manually re-enter
mail server incoming and outgoing usernames and passwords.
To back up or restore the YourSite database
1. Start Contact Center Client.
2. Click Tools=>Management=>Configuration.
3. Click Back up/Restore configuration data.
4. Follow the steps in the Backup and Restore Wizard to back up or restore the database.
For any additional information contact Mitel technical support at 1-800-722-1301 (North American
customers) or your approved Mitel vendor (for customers residing in Latin America, Europe, the
Middle East, Africa, and Asia Pacific).

BACKING UP SQL SERVER DATA FILES
You back up SQL Server data files to ensure you can replace corrupted or lost data as a result of
media problems, user errors, hardware failures, and natural disasters. Please review Microsoft
procedure for creating a recovery model that controls the backup and restores operations for a
database.
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Understanding SQL Server recovery models
The following section details SQL Server recovery models and how they relate to backups and disk
space usage. There are three recovery models available for use with SQL Server:
1. Simple
2. Full
3. Bulk logged
For detailed information on backing up SQL Server through SQL Server Management Studio, see
http://msdn.microsoft.com/en-us/library/ms187510.aspx.
For a complete overview of SQL Server recovery models, see
http://msdn.microsoft.com/en-us/library/ms175987(SQL.90).aspx
By default, SQL Server Express uses the Simple recovery model. Retail versions of SQL Server use
the Full recovery model. There are two things you must consider when deciding which recovery
model to use:
1. The importance of the data being stored in the SQL Server database.
2. The amount of disk space used by the transaction log file.
The only way to recover a SQL Server database is to restore it from a SQL Server backup. The type
of recovery model you use impacts the ability to restore the database.
The Simple recovery model is recommended for customers who do not have an IT department upon
which to rely for regular backups and who believe the summarization process is sufficient to regenerate historical data. There are several things that should be considered when using the Simple
recovery model:
l

l

l

l

The log file does not continually grow and is truncated each time a successful transaction is
completed.
When the log file is 80% full, the log will automatically clear out old transactions and rewrite
the log file with the newer transactions.
Point-in-time recovery is not supported with this model and the database can be restored only
from the last full or differential backup.
This model is ideal when the data in the database is not considered mission critical, is being
backed up periodically, or can be restored from another means, such as summarization.

The Full recovery model is recommended for customers who have an IT department that can
manage scheduled backups. There are several things that should be considered when using the Full
recovery model:
l

l
l

The log file will grow until a transaction log backup is successfully completed against the SQL
Server database. Transaction logs can be applied to full database backups to ensure point-intime recovery, up to the time when the last transaction log backup was taken.
Point-in-time recovery is supported with this model
This model requires a regular backup schedule and sufficient disk space to house the log file
as it grows between backups.

Frequency and scope of configuration changes may be a suitable indicator in determining which
recovery model to use. If configuration changes are infrequent and point-in-time recovery is not
critical, the Simple recovery model may be sufficient. However, when using the Simple recovery
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model, we highly recommend that SQL Server backups are performed after any significant
configuration changes have been made to the database.
Regardless of the recovery model used, it is strongly recommended that the data files collected by
the Contact Center Solutions applications are backed up on a regular basis, as these files are used
in the summarization process to re-generate historical data.

MANAGEMENT CONSOLE
The Management Console application resides in Contact Center Client. Using Management
Console, you can administer the database, perform maintenance functions, create support
packages, and update your Contact Center Management software.
Management Console consists of the following menus:
l

Configuration

l

Maintenance

l

Support

l

System

OPENING MANAGEMENT CONSOLE
You open Management Console in Contact Center Client. The Console is available to users whose
security permissions permit them to use Management Console. See Figure 9 for the options
available in Management Console.
To open Management Console
1. Open Contact Center Client.
2. If prompted, type your user name and password.
3. Verify the Enterprise Server IP address.
4. Click Log on.
5. In the ribbon, click Tools=>Management.
6. Access the Configuration, Maintenance, Support, and System options by clicking on the
applicable icon in the Console.
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Figure 9: Management Console

CONFIGURATION
The Configuration menu enables you to update the server IP address.

Updating server IP addresses
If you want to apply Enterprise Server or SQL Database Server IP address changes to all Contact
Center Solutions applications, you use the Update Server IP Address Wizard.
To apply the IP address change to all Contact Center Solutions applications
1. In Management Console, click Configuration.
2. Click Update server IP address.
3. Follow the steps in the wizard to apply the IP address change universally.
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MAINTENANCE
Using the Maintenance menu, you can
l

Run the maintenance routine

l

Summarize data

Running the maintenance routine immediately
Contact Center Management runs the prairieFyre Maintenance Alarm Dispatcher service
automatically at 2:00 A.M. However, you can manually invoke the prairieFyre Maintenance Alarm
Dispatcher service at any time with the Run maintenance command.
To run the maintenance routine
1. In Management Console, click Maintenance.
2. Click Run maintenance.
A message notifies you that processing is complete.

Summarizing data
The Summarize Data Wizard uploads historical telephone system data to the SQL database for a
specific date range.
If you run a report and notice that data for a particular device is missing from the report output, verify
the device is programmed in the telephone system and in the YourSite database. If you determine
the device is missing from the database, add it to the database and use the Summarize command to
update Collector Service and the SQL database with the complete raw telephone system data
(stored on the local hard drive). You can then produce reports on the device.
NOTE:
l

l

When a summarize is performed the devices not programmed in the telephone system or
YourSite database are identified and logged to an XML file located in the Logs directory. The
files are named as in the following example, summarizeInspection[29-01-2007][29-01-2007]
[29-01-2007].xml, where the first date is the current date, the second is the start date of the
summarize, and the third is the end date of the summarize.
If you attempt to summarize data and there is no data for that date an error opens. Please
select another date.

To summarize data
1. In Management Console, click Maintenance.
2. Click Summarize data.
3. Follow the steps in the Summarize Data Wizard to summarize the data.

SUPPORT
Using the Support menu, you can
l

Create an Enterprise Server support package

l

View contact information
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Creating an Enterprise Server support package
You can package your Enterprise Server telephone system records and YourSite configuration data
to send to Mitel for troubleshooting issues using the Support Package Wizard. The Support package
formats your data in a way that helps to resolve any problems.
To create an Enterprise Server support package
1. In Management Console, click Support.
2. Click Create support package.
3. Follow the steps in the Support Package Wizard to package your telephone system records
and YourSite configuration data.
4. Click Finish.

Viewing contact information
Should you need to contact Mitel for support, contact information is provided in Management
Console.
To view contact information
1. In Management Console, click Support.
2. Click View contact information.

SYSTEM
Using the System menu, you can
l

Control services

l

Convert data files

Controlling services
Services Manager controls all Contact Center Management services and mandatory system
services. A complete list of these services displays in the Services Manager.
To control services
1. In Management Console, click System.
2. Click Services Manager.
3. Select the service you want to control.
4. Right-click the service.
The right-click menu opens. This enables you to control the service the following ways:
l

Start

l

Stop

l

Pause

l

Resume

l

Restart

l

Refresh

l

Restart All Running Services

5. Select the action you want to perform.
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Converting data files
The Data file conversion tool enables you to convert Toolbox data files to Mitel data files. This
enables you to restore all historical data from competitor products when changing your contact
center solution to Contact Center Solutions.
1. In Management Console, click System.
2. Click Data file conversion tool.
3. Select a media server from the list.
4. Click Browse and specify the location of the data files to be converted.
NOTE: The path must be accessible from the server. We recommend you use a Universal
Naming Convention (UNC) share.
5. Click Next.
The data file conversion will then process.
6. Click Finish to complete the data file conversion.

Converting Inter-Tel data
The Inter-Tel database import tool enables customers with historical CSM data (collected using
either a 5000 or 3300 media server) to convert their data when migrating to Contact Center Solutions
Business, Workgroup, or Enterprise Edition. The import tool is designed to process data from either
Access or DB2 databases. Telephone system information, such as agents and extensions will be
imported and all historic records will be converted into ACD and SMDR files. A historical media
server will be created, allowing you to retain data for reporting purposes.
Historical media servers enable
l

Historical reporting for queues, agents, and extensions

l

Forecasting

l

ACD and SMDR Inspector functionality

l

Auditor functionality

Inter-Tel summary-based options, such as service level and spectrum values, can be modified in
YourSite Explorer. Summarize is performed on an on-demand basis from Management Console in
Contact Center Client. Historical media servers have no real-time functionality. All devices
associated with historical media servers are historical by default and cannot be edited or used to
collect any new data.
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NOTE:
l

l

l

l

If the CSM server that houses the DB2 database is offline or not accessible through the
network, you must install and configure a DB2 Server on the host machine. After installing the
DB2 Server, restore the DB2 databases onto this server. You will access the databases here
using the import tool.
For Access databases, the import tool requires the following files: System.mdw, config.mdb,
and one or any combination of the following: Ha<MMYYYY>.mdb, Hc<MMYYYY>.mdb,
Haday.mdb, Hcday.mdb, Hamonth.mdb, Hcmonth.mdb. For Version 4.11 or earlier, select
cvgwcfg.mdb instead of config.mdb.
You should run, save, and store a copy of your CSM reports before decommissioning your
CSM server.
Hunt groups and extensions in CSM convert into paths, agent groups, and agents when
migrating to Contact Center Solutions.

To convert Inter-Tel data
1. Open the Inter-Tel Import Tool, which is found in the <InstallDir>CCM/Applications folder.
2. Under Database Source, select either Microsoft Access or DB2.
3. If DB2 is selected, in the CSM Databases text field, type the IP address of the machine
where the DB2 database resides and the name of the DB2 database using the following
format: <IP Address>\<Database Name>, and enter the login credentials of a DB2
Administrator on the host machine.
4. If Microsoft Access is selected, after CSM Databases, click Browse and browse to the
location of the files to import/convert.
5. Click OK.
6. After Start Date, select the start date for the data you want to import.
7. After End Date, select the end date for the data you want to import.
The Detected Inter-Tel Version will update based on the version you are running.
8. If you want to retain historic Inter-Tel data for reporting purposes, ensure the Create historic
media server check box is selected.
This option is selected by default. The files will be imported into <installation drive>:\Program
Files (x86)\prairieFyre Software Inc\CCM\DataDirectory. You can optionally choose to import
the files to an alternate location, and not create a historical media server, by selecting the
Target for Import check box. See step 11.
9. If you have multiple, interconnected 5000 media servers that are configured through a CT
Gateway, select the Synchronized system uses CT Gateway check box.
NOTE: if the Create historic media server check box is enabled, the Synchronized system
uses CT Gateway option will be disabled.
10. If you want to summarize the data immediately after the conversion, select the Summarize
on completion check box.
This option is selected by default.
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11. Optionally, to generate data files without creating a media server in the database, beside the
Target for Import field, click Browse, and select a location to which you want to import the
data.
The Target for Import option is not available if you selected the Create historic media server
check box.
12. Click Import.
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CONFIGURATION
The following section focuses on configuration for voice contact centers. For detailed information on
configuring Multimedia Contact Center devices, see the Multimedia Contact Center Installation and
Deployment Guide.
You configure Contact Center Management in the following order.
1. In YourSite Explorer, under Enterprise, set up your Enterprise structure by specifying
Enterprise settings, adding sites, and adding media servers to the sites.
See "Configuring enterprise settings" on page 80, "Adding sites" on page 82, and "Adding
media servers" on page 84.
2. In YourSite Explorer, under Devices, configure the YourSite database to mirror the information
on your telephone system. Add devices in the following order:
l

l
l

Add employees. Configure their general settings and licensing attributes and select the
media types they will handle. When you select a media type, an agent of that media
type is automatically created and associated to the employee.
Add agent groups and associate employees to those groups.
Add queues and associate agent groups to those queues.
If you intend to run reports on employee groups, queue groups, teams, extensions,
extension groups, trunks, trunk groups, DNIS numbers, Account Codes, ANI, Make
Busy and Do Not Disturb Reason Codes, or phone numbers, you must add these
devices and device groups as well.

3. In YourSite Explorer=>Schedules, create schedules that specify the business hours of your
operation that will be used for media servers, queues, alarms, WallBoarder sign plans, and
Interactive Contact Center Queue control.
See "Creating and modifying schedules" on page 176.
4. In YourSite Explorer=>Alarms, specify alarm settings.
See "Monitoring and alarming subsystem" on page 178.
5. In YourSite Explorer=>Security, restrict user access to specific devices and Contact Center
Solutions application areas.
See "Security roles" on page 189.

YOURSITE DATABASE APPLICATION AREAS
The YourSite database includes four application areas. You must set them up in the following order:
l

Enterprise
Enterprise settings and sites and 3300 ICP and Multimedia Contact Center media servers are
configured in YourSite Explorer.
See "Enterprise setup" on page 79.

l

Configuration
You set up the YourSite database to mirror the information on your telephone systems.
See "YourSite database configuration" on page 98.
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l

Schedules
You create schedules and apply them to media servers, queues, alarms, and wall signs.
See "Business hour schedules" on page 175.

l

Security
You allow or restrict user access to specific areas of the Contact Center Solutions software
using security lists and security roles.
See "Security roles" on page 189.

YOURSITE EXPLORER
YourSite Explorer streamlines configuration by providing a single interface for all device
configuration in your contact center. You can multi-select devices and change their attributes in one
step, view group membership in the same window as the selected device, and view multiple device
windows simultaneously and tab between them.
NOTE:
l

l

l

Only one set of pending configuration changes can be saved at any time. If another user
saves changes to the same element of YourSite Explorer that you are updating, you receive
an error message when attempting to save your changes. In these instances you must refresh
YourSite Explorer after the other user’s changes have been saved. You may then re-enter and
save your changes. We recommend you save your configuration changes frequently, in order
to avoid losing work.
YourSite Explorer enables you to have multiple device tabs open simultaneously. However,
as a best practice, we recommend you only have the device tabs open that you are currently
using.
We recommend you avoid modifying large data sets from within YourSite Explorer as
performance levels will be negatively affected. As a best practice, all large dataset
modifications should be made on the telephone switch directly and synchronized back to
Contact Center Management. If you prefer to perform modifications inside YourSite Explorer,
we recommend you partition the changes into smaller chunks of data.

STARTING YOURSITE EXPLORER
NOTE: Launching client-side applications from the task bar causes them to bypass the Updater
Service process. To ensure successful updates from the Enterprise Server, after an upgrade close
all client-side applications for 15 minutes or reopen them from the Start menu/Start screen.
To start YourSite Explorer
1. Open YourSite Explorer.
2. If prompted, type your Username and Password and verify the Enterprise Server IP
address.
3. If you use Secure Socket Layer, select the SSL check box.
4. Optionally, select the Remember my credentials check box.
5. Click Log in.
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YourSite Explorer Start Page
The YourSite Explorer Start Page is a startup resource that provides links to both information
resources for getting started as well as system information for Contact Center Solutions. By default,
if enabled, the Start Page opens automatically with each new session of YourSite Explorer.
The Start Page has two tabs: Getting Started and System Information.
l

Getting Started—provides configuration overviews for Contact Center Solutions and
includes the following tabs:
l

l

l
l

l

l

Welcome—details the contents of both the Getting Started tab and the System
Information tab
Contact Center Management—overview of Contact Center Management
configuration
Business Reporter—overview of Business Reporter configuration
Workforce Scheduling—overview of Workforce Scheduling configuration for
employees and schedules
NOTE: You must be licensed for Workforce Scheduling to view this tab.
IVR Routing—overview of IVR Routing configuration
NOTE: You must be licensed for IVR Routing to view this tab.

System Information—provides documentation as well as system and license information
and includes the following tabs:
l

l
l

Documentation—provides links to Contact Center Solutions and Business Reporter
documentation
About—provides system information, custom reports, and contact information for Mitel
Alarms—provides information on currently active Contact Center Management alarms,
with links to corresponding Mitel Knowledge Base articles

Configuring the YourSite Explorer Start Page
You can configure the Start Page to open automatically when you start YourSite Explorer. You can
also configure whether or not the Start Page automatically loads in the View tab of YourSite
Explorer.
To prevent the Start Page from opening automatically
1. Start YourSite Explorer.
2. On the Start Page, clear the Show page on startup checkbox.
To configure whether the Start Page opens in the View tab
1. Click YourSite=>View.
2. To load the Start Page automatically on startup, select the Show start page check box.

Searching
When you perform searches in YourSite Explorer, you can filter on specific criteria to narrow the
search. YourSite Explorer searches on criteria you type into the Search box. The search result will
consist of all instances of the search item. For example, if you ran a search for ext, your search
result could contain: extension, text, and next time.
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After you perform an initial search, you can type additional criteria in the box to narrow the search. If
no words or numbers match your search request, the resultant list will be blank.
YourSite Explorer can search several variables for devices. For example, for the following devices,
the following variables can be searched
l

Employees, employee groups—first and last name

l

Extensions, extension groups—reporting number

l

l

Trunks, trunk groups, DNIS, DNIS groups, Account Codes, divisions—name and reporting
number
Phone numbers, phone number groups—search on information found in all columns except
Created by, Created date, Last modified by, or Last modified.

To search for a specific word or number
l

Select a device, and, in the Search box, type the word or number.

Paging
Paging enables you to specify the number of items to be included per page. You can reduce the page
size to increase the application speed. By default, the page size allows for 100 items. When
changing the page size, you must close and re-open the device window.
To change the number of items viewed per page
1. In YourSite Explorer, click YourSite.
2. On the ribbon, click the View tab.
3. After Page size, select the number of items to be viewed per page.
4. Click Save.

Filtering
The filtering bar enables you to access records alphabetically and numerically.
To filter records alphabetically
l

On the filter bar, click the letter with which the record begins.

To filter numerically
l

On the filter bar, click # to view records that start with numbers 0 through 9.

To reset filtering
l

On the filter bar, click All to view all records.

You can filter and then search within the filtered records. For example, click F to filter for all records
that start with the letter F. Then type th to search within that list for any record with th.

Customizing the user interface
You can customize the user interface by minimizing aspects of it, changing the order of the columns,
changing column options, and adjusting the page size. This customization is referred to as a profile.
Your profile is associated with the username you use to access YourSite Explorer. Each time you
close YourSite Explorer, your profile is automatically saved. When you reopen YourSite Explorer
using the same username, the user interface displays your profile.
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Minimizing aspects of the user interface
To add space to the user interface so you can view additional rows of data, you can minimize the
l

l

l

Filter bar
The filter bar is the bar on which the alphabet is displayed.
Page bar
The page bar is located above the filter bar. The page number is displayed on the left side of
the page bar.
Ribbon
The ribbon is located at the top of the user interface. The ribbon includes Home, View, and
Configuration tabs, and enables you to add devices and change the view (horizontal or
vertical). Ribbon attributes change depending on the area you are viewing.

To hide the filter bar
1. On the ribbon, click the View tab.
2. Click Save.
3. In YourSite Explorer, click YourSite.
4. Clear the Show filter bar check box.
To hide the page bar
1. On the ribbon, click the View tab.
2. Click Log on.
3. In YourSite Explorer, click YourSite.
4. Clear the Show paging bar check box.
To minimize the ribbon
1. In YourSite Explorer, under Enterprise, click Media servers.
2. Click Minimize the Ribbon.
The ribbon at the top of YourSite Explorer is hidden.

Selecting the first record of each list
You can save time by configuring YourSite Explorer to automatically select the first record on a
page.
To select the first record of each list
1. On the ribbon, click the View tab.
2. In YourSite Explorer, click YourSite.
3. Select the Select the first record check box.
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Changing the order of the columns
You can reorder columns in either of two ways. You can drag a column heading to a different position
on the table, or you can change column order using Column options. See "Changing column options"
on page 77.
To drag column headings
1. With the device window open, select the column heading to be moved.
2. Drag it to a different position on the table.

Changing column options
You can adjust the width and order of columns, and hide or show columns in device windows.
To adjust column width
1. Drag the column to the left or right to adjust its width.
2. Click OK.
To hide a column
1. Right-click a column heading.
The Column options window opens.
2. Select Column options.
3. Select the column heading to be hidden.
4. Click <<.
5. Click OK.
To change the order of columns
1. Right-click a column heading.
The Column options window opens.
2. Select Column options.
3. Select the column heading to be moved.
4. Use the arrows to change the order of the column headings.
The top column displays first in the device window.
5. Click OK.

Duplicating devices in YourSite Explorer
Devices in YourSite Explorer can be copied and pasted to create duplicate devices for the
configuration of a resilient contact center. A copied device has the same configuration as the original
and any unique fields must be changed to new values before the copied device can be saved.
Duplicated devices will duplicate the membership of the original, so that a duplicate queue, for
example, would have the same agent group members as the original queue.
NOTE:
l

l

Embedded RAD messages on 3300 media servers may not be copied as they need to be
saved locally on that 3300 media server.
YourSite Explorer does not support copying and pasting devices using CTRL+C and
CTRL+V.

77

Contact Center Solutions User Guide

To duplicate a device in YourSite Explorer
1. Select a device or range of devices.
2. In the ribbon, click the Home tab.
3. Click Copy.
4. Click Paste.
5. For any copied device, put new values into fields that must be unique to a single device.
6. Click Save.
Alternatively, to duplicate a device in YourSite Explorer
1. Right-click on the device and select Copy.
2. Right-click and click Paste.
3. For any copied device, put new values into the fields that must be unique to a device.
4. Click Save.

Making multiple changes
In one action, you can edit common information across multiple devices of the same type. If, for
example, you recently set up your system to be resilient, you must configure your employees as
resilient. You assign resiliency to multiple employees by selecting multiple employees and then
selecting the This employee is resilient check box.
You can change information that is common across multiple devices only. For example, you cannot
change Name and Reporting number across multiple employees because they are specific to each
device item.
You can make multiple changes to
l

Employees

l

Trunk groups

l

DNIS

Changing the YourSite Explorer view
You can select from two window orientations: horizontal or vertical. The horizontal view displays
information in a horizontal layout. The vertical view displays information in a vertical layout.
When you close YourSite Explorer and then restart it, YourSite displays the view and device
windows that were open the last time you used YourSite Explorer.
To select a particular view
1. On the ribbon, click View.
2. Click YourSite.
3. Select Horizontal or Vertical.
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Submitting feedback
YourSite Explorer includes a feedback form for users to indicate areas of the application they like or
dislike, highlight problems they experienced, or to provide suggestions for future YourSite Explorer
development.
To submit YourSite Explorer Feedback
1. In the YourSite Explorer ribbon, click the File tab.
2. Click Feedback.
3. Select a category for your feedback.
4. Under Comments, enter your feedback.
5. If you want to provide your feedback a rating, click on the star buttons.
Clicking on the left side of a star gives a .5 of a star, while clicking on the right side of a star
gives a full star.
6. If you want to clear the form, click Reset.
7. Click Send.

ENTERPRISE SETUP
For all telephone system types, you set up your enterprise structure in YourSite Explorer.
To set up your enterprise structure
1. Specify enterprise settings.
2. Add a site.
3. Add media servers to the site.
See "Adding media servers" on page 84.
You must understand the following terms to set up your enterprise structure.
l

Enterprise
The enterprise is all of the sites that comprise your company.
See Figure 10.

l

l

Site
A site is an office location with one or more media servers. It can be the office where the
Enterprise Server is installed or a branch office.
Media server
The media servers are the means by which customers communicate with you. For example, if
customers contact you by telephone only, and you have a 3300 ICP telephone system, then
you would configure a 3300 ICP media server.

For example, you have a business called ABC Company. You have two offices. One office is in Salt
Lake City and your head office is in Los Angeles. The Salt Lake City site has Contact Center
Management software installed on the Enterprise Server. Both sites have the 3300 ICP telephone
system and the Exchange Server installed. Your customers contact you at either site by telephone
or email.
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When setting up your enterprise site structure, you install Contact Center Management on the
Enterprise Server. You define the site with the Enterprise Server (Salt Lake City). You add the Los
Angeles site to the enterprise. Finally, you program two media servers at each site, one for voice and
one for email.

Figure 10: Enterprise structure

CONFIGURING ENTERPRISE SETTINGS
When programming the enterprise, you configure Enterprise Server general settings, global system
language settings, some maintenance services, email settings for alarm notifications, as well as
settings for Contact Center Screen Pop (see "Configuring Contact Center Screen Pop options" on
page 459) and Multimedia Contact Center (see the relevant section in the Multimedia Contact Center
Installation and Deployment Guide). The Enterprise Server is the computer on which Contact Center
Management is installed.

Configuring the Enterprise Server settings
To configure the Enterprise Server settings
1. Click YourSite=>Enterprise.
2. In the Enterprise tab, type the Name of the Enterprise.
3. Verify the IP address/DNS name of the Enterprise Server. If the IP address is incorrect, after
IP address/DNS name, type the IP address of the Enterprise Server.
NOTE: If you want to change the Enterprise IP address, use the Contact Center Client
Update Server IP Wizard. See "Updating server IP addresses" on page 65.
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4. After Real-time port, type the real-time port number.
The default real-time port is 5024.
The real-time port is used to communicate real-time events.
5. After Auditor port, type the Auditor port number.
The default Auditor port is 5025.
The Auditor port is used to run Auditor events.
6. After MiTAI proxy server port, type the MiTAI proxy server port number.
The default MiTAI proxy server port is 5026.
7. If you want Lifecycle reports, select the Enable LifeCycle reports check box.
8. If you use Secure Socket Layer, select the This server uses Secure Socket Layer (SSL)
check box.
9. If you want to be notified when your warranty is about to expire, select the Display warranty
warning and expiration message check box.
10. If you do not want client applications to be automatically updated, clear the Auto update
client applications check box.
By default, client applications are updated automatically.
11. Click Save.

Changing the global system language
Administrators can control the default global language of their system using enterprise settings.
During the installation of Contact Center Solutions, a default global system language is selected.
This default language is applied to the alarming RSS feed and emails sent out by YourSite Explorer.
Administrators can optionally change this default language post-installation, modifying the language
of the alarming RSS feed and emails.
NOTE: Contact Center Solutions applications, such as YourSite Explorer and Contact Center
Client, all leverage the language settings of the operating system in addition to the language
preference set for Contact Center Solutions. Ensure that if you adjust the language settings of
Contact Center Solutions, you also adjust the language settings of the operating system to match.
To change the global system language
1. Click YourSite=>Enterprise.
2. Click the Enterprise tab.
3. After Language, select the global system language from the drop-down menu.
4. Click Save.

Configuring enterprise maintenance functions
To configure enterprise maintenance functions
1. Click YourSite=>Enterprise.
2. Click the Maintenance tab.
3. After Zip files older than, select the number of days after which you want to zip data files.
4. After Purge reports older than, select the age after which reports will be discarded.
5. After Delete maintenance logs older than, select the age after which maintenance logs will
be discarded.
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6. After Delete configuration backup files older than, select the age after which configuration
backup files will be discarded.
7. After Time Maintenance Service runs, select the time the maintenance service summarizes
data.
The maintenance service is set to run at 2:00 A.M. by default. Select a time for the
maintenance manager to run when your contact center is closed or is the least busy.
8. After Purge Life cycle reports older than, select the age after which Life cycle reports will
be discarded.
9. Click Save.

Configuring email settings
You configure email settings so you are notified by email about Enterprise Server and real-time
performance issues.
To configure email settings
1. Click YourSite=>Enterprise.
2. Click the Email settings tab.
3. After Mail Server address, select the IP address of the SMTP Mail Server.
4. After Email notification interval minutes, select the duration (in minutes) after which you
will be notified when an alarm occurs.
5. After Send Enterprise Server alarms to the following address(es), type the email address
of the employee(s) who will receive the email notification.
6. Click Save.

ADDING SITES
A site is an office location with one or more media servers. It can be the office where the Enterprise
Server is installed or a branch office.
Your site structure determines how you view statistics and reports. When you set up your site
structure, you specify site and media server information. When you add a site, you add the name of
the site and the time zone. By making each site distinct, you can restrict user access to sites. For
more information on restricting user access, see "Configuring security roles" on page 193. The site’s
language determines the default language setting for employees associated to it. Changing the site’s
language will change the language setting for employees associated to it.
Administrators can also restrict the site’s use of Contact Center Client’s Chat Integration, which
enables employees to chat with each other in Contact Center Client. Prior to Version 7.0, there was
an option to use Microsoft Lync as the default chat client instead of Contact Center Chat. In Version
7.0 and greater, YourSite Explorer automatically detects if you have Lync Server and enables it as
the default chat client. If your contact center is a mixed environment where some users have Lync
and others do not, you may want to use Contact Center Chat to ensure all employees can
communicate. For information on using Contact Center Chat in an environment with Lync on some
systems, see the following Mitel Knowledge Base article:
http://micc.mitel.com/kb/KnowledgebaseArticle52084.aspx
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To add a site
1. Click YourSite=>Site.
2. Click Add.
3. After Site Name, type the name of the site.
4. After Time Zone, select the time zone and closest location from the drop-down list.
5. After Site Language, select the site language from the drop-down list.
6. To disable Contact Center Client Chat Integration, clear Chat Enabled.
7. Click Save.

ADDING MAIL SERVERS
To add a mail server
l

Click YourSite=>Mail servers=>Add.

After adding the mail server, you must configure SMTP connections to Contact Center Solutions.

Configuring SMTP connections to Contact Center Solutions
The following configurations take place in YourSite=>Mail servers=>Outgoing.
Configuring an SMTP connection enables Contact Center Solutions to send outgoing mail through a
contact center’s email server. The following explains how to configure an SMTP connection between
Contact Center Solutions and email servers. The outgoing settings you configure are applied to any
email your system sends, such as server alarms and reports.
NOTE: The following procedures require information on your business' email server. Consult the
appropriate server documentation to retrieve this information.
Configuring an SMTP connection requires you to
l

Add the mail server to YourSite Explorer
If the mail server has not already been added, see "Adding mail servers" on page 83.

l

Specify the server information for outgoing emails

l

Specify the email account's 'From' name and address

l

Optionally, request logon credentials to send outgoing mail

l

Test the servers' SMTP socket connection to Contact Center Solutions
NOTE: To test the connection, you must have an email address configured for yourself in the
Employees page. This email address receives notification of whether the test was
successful.

To specify the server information for outgoing emails
1. After SMTP Server, type the server’s IP address or name.
2. Select the Use SSL check box if the server uses Secure Sockets Layer.
3. After SMTP Port, type the server’s SMTP port number.
NOTE: Google Apps for Business’ port 465 is not supported.
4. After Connection Timeout, type how many seconds the system has to connect to the server
before timing out.
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To specify the email account’s ‘From’ name and address
1. After From Name, type the name that appears on outgoing mail.
For example, ‘XYZ Company Sales’.
2. After From Email Address, type the email address that appears on outgoing mail.
For example, ‘xyzsales@email.com’.
To request logon credentials to send outgoing mail
1. Select the SMTP Authentication Required check box.
2. Enter the Username, Password, and Domain information for the server’s email account.
3. Click Save.
To test the server’s SMTP socket connection to Contact Center Solutions
l

Click Test Outgoing Mail. If an error message is received, verify that the Outgoing Server,
User, and Logon information is entered accurately. To troubleshoot, the default installation
location for verbose logs is C:\Users\<current
user>\Documents\CCMLogs\YourSiteExplorer.txt.

ADDING MEDIA SERVERS
NOTE: The SX-200, Axxess, and 5000 media servers are not supported with Version 7.1, except as
historical media servers. When upgrading to Version 7.1, SX-200 media servers, along with their
associated extensions, agents, agent groups, queues, trunks, and trunk groups, are set to historical.
Axxess and 5000 media servers must be marked as historical before upgrading to Version 7.1 to
retain historical data.
For information on adding email and chat media servers, see the Multimedia Contact Center
Installation and Deployment Guide.
When you first install Contact Center Management, a 3300 ICP media server is added to YourSite
Explorer by default. If you do not plan to use this server, we recommend you delete it to avoid
receiving unnecessary alarms or error messages.
To distinguish between the various types of media for management and reporting purposes, you
must make each media server distinct when you set up your site.
In CCMWeb, you can click Help=>About Your Mitel Applications to verify the types of media
servers and the number of employees for which you are licensed. You can access the same
information in the System Information tab in the YourSite Explorer Start Page.
Contact Center Management works with the following media server types:
3300 IP Communications Platform (ICP)
The 3300 ICP ACD system streams SMDR and ACD real-time data over TCP/IP.
See "Adding 3300 ICP media servers" on page 85.
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Multimedia Contact Center Email
The Multimedia Contact Center Email routing engine dynamically allocates emails from customers
to agents on their desktops. Email servers must support IMAP version 4 and maintain a reliable
connection to the Enterprise Server. In addition, we recommend that the mail account from which
Multimedia Contact Center retrieves emails supports aliases.
See the Multimedia Contact Center Installation and Deployment Guide for more information.
Multimedia Contact Center Chat
The Multimedia Contact Center Chat routing engine dynamically allocates live chat sessions over
the Web from customers to agents on their desktops. The routing engine uses HTTP to
communicate between customer and agent.
See the Multimedia Contact Center Installation and Deployment Guide for more information.

ADDING 3300 ICP MEDIA SERVERS
You must first add the 3300 ICP media server and then configure its location settings, telephone
system settings, data summary options, data collection settings, MiTAI options and, optionally,
write-back functionality and call recording.
NOTE:
l

l

As a best practice, we recommend you perform Full Synchronization after adding and
configuring a media server in YourSite Explorer and before configuring telephone system
settings for the media server. For more information on synchronization, see "Configuring the
YourSite database using synchronization" on page 101. For information on performing
synchronization, see "Performing synchronization" on page 105.
If you are adding media servers as part of a new installation, we recommend you perform
synchronization after all media servers have been added. For more information, see the
Contact Center Management Installation Guide.

Prior to Version 7.0, media servers could be one of three types: Enterprise Node, which is a standard
media server, Agent/extension gateways, which did not file queue data to SQL, and Queueing
gateways, which did not file agent or extension data to SQL. As of Version 7.0 and greater, all media
servers are Enterprise Node by default.
When upgrading to Version 7.1, agent and extension gateways and Queueing gateways are
converted into Enterprise Nodes. Agent and Extension gateways will have queues created for them.
Converted Queueing gateways will have employees, agents, and extensions created for them.
To add a 3300 ICP media server
1. In YourSite Explorer, click YourSite=>Media servers.
2. Click Add=>3300 ICP.
3. After Name, type the name of the media server.
NOTE:
l

l

To distinguish between the various types of media for management and reporting
purposes, you must name each media server distinctly when setting up your site.
The Media server ID field will be populated with a unique number after the media server
has been saved.
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4. After Site, select the site where the media server resides.
5. After Computer name, select the computer where the server resides.
6. The field after Telephone System Version is read-only and is automatically populated after
synchronizing with the telephone system. It describes the active software load version on the
telephone system.
7. To be informed of media server alarms, select the Enabled for alarms check box.
NOTE: Selecting this check box will inform you of media server alarms via RSS and email.
For more information, see "Monitoring and alarming subsystem" on page 178.
8. The SDS Mode check box is automatically selected, if applicable, after synchronizing with
the telephone system.
NOTE: In a network or cluster of elements, the System Data Synchronization (SDS) feature
keeps programming data, such as Interconnect Handling Restrictions, Feature Access
Codes, and Class of Service Options, identical at each element.
9. If you have hot desking agents, select the Uses hot desking agents check box.
NOTE:
l

l

If this is selected, all created agents will be hot desking agents. You cannot mix hot
desking and standard agents.
‘Uses hot desking agent’ is enabled by default. It is recommended that Workgroup
Edition only use hot desking agents.

10. Select Licensed for Business Reporter if you are applying for a Business Reporter license.
NOTE: This check box is selected by default when you add a 3300 ICP media server and
have remaining Business Reporter media server licenses. If you are licensed for Contact
Center Management and Business Reporter, you must select 'Licensed for Business
Reporter' to have access to Business Reporter. If you are not licensed for a product, you will
not be able to select the check box for that product.
11. If you want to designate the media server for historical reporting use only, click Make
historical.
Making a media server historical terminates all active licenses for devices associated with
that media server. Historical data is retained on the media server but no new data is collected.
12. After IP address /DNS name, specify the IP/DNS address of the media server.
13. After Username, type the username used to connect to the telephone system.
14. After Password, type the password used to connect to the telephone system.
15. After Confirm password, type the password used to connect to the telephone system.
16. Click the Test Connection button to test the connection between the media server and the
Enterprise Server.
This connection is required to ensure Synchronization functionality.
17. Click Save.
18. Configure the location settings.
See "Configuring location settings for 3300 ICP media servers" on page 87.
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Configuring location settings for 3300 ICP media servers
To configure location settings for a 3300 ICP media server
1. Click the Location tab.
2. After Country, click the Browse button and select the country where the media server is
located.
3. After Area, click the Browse button and select the appropriate area code for the media
server's location.
4. After Minimum digits to dial locally, specify the minimum number of digits required for a
local external call.
NOTE: Digits less than the minimum are treated as internal calls.
5. After Maximum digits to dial locally, specify the maximum number of digits required for a
local external call.
NOTE: Digits exceeding the maximum are treated as long distance external calls.
6. After Outbound dialing prefix, specify the number dialed to access an outside line.
7. Configure the data summary options for the 3300 ICP.
See "Configuring data summary options for 3300 ICP media servers" on page 87.

Configuring data summary options for 3300 ICP media servers
Contact centers operating over midnight should have ‘This enterprise operates 24 hours a day’
selected for the media server. This option provides more accurate reporting over midnight and
determines when and how agent shifts are opened and closed after midnight.
If this option is selected, the system automatically closes and re-opens agent shifts at midnight. All
agents remain logged into the system. Agent shift reporting is uninterrupted over this period.
If this option is not selected, the system closes agent shifts after the last agent event before
midnight. The system re-opens agent shifts after the first agent events after midnight. All agents
remain logged into the system. Agent shift reporting is not extended between the time agent shifts
close and the time they re-open.
To configure data summary options for a 3300 ICP media server
1. Click the Data summary options tab.
2. If you want to use Trace reporting, select the Inbound/Outbound/Make Busy Trace
reporting check box.
3. If your business operates over midnight, select This enterprise operates 24 hours a day.
NOTE: If you do not select this option, but have agents logged in to Contact Center Solutions
applications overnight, you may experience difficulties with shift-related statistics, such as
agent shift monitor and Make Busy Reason codes. For example, if agents are logged in to
Contact Center Client overnight with a Make Busy Reason code, when you change the Make
Busy Reason code the following day, Contact Center Client will display 'Unknown Make
Busy code'. This can be remedied by logging out of the application and logging back in.
4. To track outbound calls that were not answered, select the Credit unanswered outbound
calls check box.
5. If you want to display when calls ring at agents’ extensions, select the Monitor Agent
Ringing state check box.
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6. After Digits dialed prefix, type the digits that must precede a telephone number to make an
outbound call.
7. After Digits dialed postfix, type the digits that must follow a telephone number to make an
outbound call.
8. After Maximum MiTAI monitors, specify the maximum number of MiTAI monitors.
9. Under Agent state timeout audit, after Clear line if agent Hold Time exceeds, specify the
number of minutes or hours you are in a hold state before the telephone system clears the line.
10. After Clear line if agent primary Talk Time exceeds, select the number of minutes or hours
an agent can be in a single state on the primary line (ACD line) before the system clears that
line.
11. After Clear line if agent secondary Talk Time exceeds, specify the number of minutes or
hours an agent can be in a single state on the secondary line (non-ACD) before the system
clears that line.
12. After Change the agent state from Ringing to Idle after, specify the number of minutes or
hours after which you want the agent state to change from Ringing to Idle.
13. If you do not want to report on the secondary line (non-ACD and outbound calls), select the
Ignore agent secondary line activity check box.
14. Select the Reset MKB/DND time in realtime after call ends check box to enable the
MKB/DND time to reset in real time when the call concludes.
15. Under ACD Options, to store ACD redundant events, select the File all ACD stream
redundant events check box.
16. If you do not consider ACD real-time sequence errors as record errors, select the Ignore ACD
real-time sequence errors as record errors check box.
17. Configure Data collection settings.
See "Configuring data collection settings for a 3300 ICP" on page 88.

Configuring data collection settings for a 3300 ICP
CAUTION: Selecting the TCP, Enterprise Manager (OPS Manager), or Simulation tabs will change
the media server’s data collection mode. Ensure that you select the tab for the appropriate data
collection mode. Be aware that Simulation mode halts data collection and is used for demonstration
purposes only. We do not recommend you run media servers in simulation mode. However, if you
want to simulate media server real-time data collection and reporting, see the following Mitel
Knowledge Base article: http://micc.mitel.com/kb/KnowledgebaseArticle51207.aspx
To configure data collection settings for a 3300 ICP media server
1. Click the Data collection tab.
2. If you do not use Enterprise Manager (OPS Manager), click TCP. Otherwise, skip to step 8.
3. After SMDR, type the SMDR port number of the media server.
4. If you will be entering ACD information, select the ACD check box and type the ACD port
number of the media server.
5. If you use Traffic Analysis, select the Traffic Analysis check box and type the Traffic
Analysis port number of the media server.
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6. After Data Alarm Timeout Minutes, select the duration of the time lapse in minutes from
when the data stops streaming to when you want the alarm to display.
NOTE: In a resilient environment, SMDR and ACD data timeout alarms may trigger
unnecessarily. To prevent this, set Data Alarm Timeout Minutes to zero.
7. After Notify me during these business hours, click the Search button, select a schedule
that reflects the hours of operation for the media server, and click OK.
8. If you use Enterprise Manager (OPS Manager), click Enterprise Manager (OPS Manager).
9. After IP address/DNS name, type either the IP address or the DNIS name of the
Enterprise Manager (OPS Manager) computer.
10. After FTP port, type the FTP port number.
11. After FTP user name, type the FTP user name to gain access to Enterprise Manager (OPS
Manager).
12. After FTP password, type the FTP password to gain access to Enterprise Manager (OPS
Manager).
13. After Remote directory to data files, type the directory path where the data from the
telephone system is stored by Enterprise Manager (OPS Manager).
14. Configure the media server's MiTAI options.
See "Configuring MiTAI options for 3300 ICP media servers" on page 89.

Configuring MiTAI options for 3300 ICP media servers
To configure MiTAI options for a 3300 ICP media server
1. Click the MiTAI Options tab.
2. After Maximum messages per second, select the number of messages per second from the
drop-down list.
The default number of messages is 10 per second. The higher the version of MiTAI, the
greater the number of messages per second.
3. After MiTAI auto-synchronization will occur at, select the time from the list that you want
Automatic Synchronization to run.
4. After Specify the port used for the MiTAI data stream, type the port number used for the
MiTAI data stream.
5. To enable write-back functionality, see "Enabling write-back functionality" on page 89.

Enabling write-back functionality
For changes that you make to the configuration settings in YourSite Explorer to be written back to
the telephone switch, you must enable the read/write option in YourSite Explorer.
To enable write-back functionality
1. In YourSite Explorer, click YourSite=>Media servers.
2. Select the media server for which you want to enable read/write functionality.
3. On the ribbon, click the Telephone System tab.
4. In the Settings section, select Read/Write.
5. Configure the telephone system settings for the media server.
See "Configuring telephone system settings for 3300 ICP media servers" on page 90.

89

Contact Center Solutions User Guide

Configuring telephone system settings for 3300 ICP media servers
To configure telephone system settings for a 3300 ICP media server
1. Click the Telephone system settings tab.
2. Click System options.
3. After Feature access code for silent monitoring, type the feature access code used for
silent monitoring, as programmed on the 3300 ICP telephone system.
NOTE: The feature access code for silent monitoring must be unique and up to four digits in
length. Do not use * and # alone to define feature access codes.
4. If applicable, after Replacement Access Code, enter the replacement access code
programmed on the telephone system.
5. If applicable, after Registration Access Code, enter the registration access code
programmed on the telephone system.
6. After ACD Make Last Agent Unavailable on No Answer, select Yes by default.
NOTE: In MCD 5.0, this telephone system setting is called 'ACD Auto Logout Last Agent on
No Answer'. In MCD 6.0, this telephone system setting is called 'ACD Make Last Agent
Unavailable on No Answer'.
7. After ACD Real-Time Events Feature Level, set the value to 1.
8. After ACD Make Busy Walk Away Codes, select Yes by default.
9. Click SMDR options.
10. If applicable, correct the SMDR Options settings.
For the SMDR Options settings list, see Table 2.
11. Click Class of Service and select a Class of Service number.
The properties for the selected Class of Service are shown in the right-hand pane.
12. After Default type, enter the Class of Service type.
13. After Comment, enter a description for the Class of Service.
14. Select Yes for the following Class of Service options:
l

l

l

l

HCI/CTI/TAPI call control allowed
Selecting Yes enables the softphone extensions and IVR Routing ports to be controlled
by the host computer.
HCI/CTI/TAPI monitor allowed
Selecting Yes enables an HCI monitor to be initiated against softphone extensions and
IVR Routing ports.
SMDR external
Selecting Yes enables trunking SMDR.
SMDR internal
Selecting Yes enables SMDR internal records to be generated.

15. After Call forward delay, enter the amount of time to wait before forwarding a call.
16. After Call forward no answer timer, enter the amount of time to wait for a forwarded call to
be answered.
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17. Select Yes or No for the following additional Class of Service options:
NOTE: You will receive a warning in YSE if you choose a Class of Service option that is not
recommended.
l

l

l

l

l

l

Message waiting
This option permits a phone to enable and disable message waiting notification on
another phone.
Message waiting audible tone notification
This option enables message waiting notifications to take the form of a tone every time
the phone goes off-hook.
Do not Disturb
This option enables users to change their Do not Disturb status and prevents the phone
from ringing on incoming calls.
Do not Disturb permanent
This option sets the phone permanently in Do not Disturb.
Public network access via DPNSS
This option enables devices to originate calls to directory numbers on the PSTN.
Selecting 'No' disables network access.
Suppress simulated CCM after ISDN progress
This option prevents the PBX from sending an answer message to a party calling on an
ISDN trunk, preventing systems using MiTAI or HCI to play ringback or call processing
tones when the call is answered.
NOTE: Enable this option on end nodes only. Do not enable this option on transit
nodes.

l

l

l

l

Recorded announcement device
This option enables RAD ports to play recorded messages for one-way, outgoing audio.
Accept hot desk login
This option enables a hot desk login on a device.
Voice mail port
This option enables the voice mail system to uniquely identify the party that is receiving
a message.
External hotdesk user – answer confirmation
This option forces an external hotdesk user to press a DTMF key to answer incoming
calls.

18. After Answer Plus Message Length Timer, specify an amount of time to apply to MCD
RAD messages. The time specified should equal the time it takes for the RAD message to
play.
19. After Answer Plus Expected Off-hook Timer, specify the amount of time the RAD can be
off-hook and not playing messages before it requires servicing and is removed.
20. After Work Timer, specify the amount of time agents can be in a Class of Service Work
Timer state. For information on Work Timer, see "Configuring Work Timer" on page 197.
NOTE:
l

This timer applies to ACD extensions only

l

Class of Service Work Timer durations are dependent upon your telephone system.
l

MCD 5.0 and greater – 4 hours maximum

l

MCD 4.x or earlier – 10 minutes maximum
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21. Click Class of Restriction.
22. Select a Class of Restriction.
The properties for the selected Class of Restriction are shown in the right-hand pane.
23. After Do you want this Class of Restriction to be the default setting?, select Yes or No.
24. After Classes of Restriction for the group, enter the Class of Restriction numbers to
include in the group.
You may specify a range of numbers. Separate numbers using dashes or commas. For
example, 1 through 9 may be entered as 1-9, or a combination of individual numbers and
ranges may be entered as 1,2,3,7-10,13.
NOTE: Class of Restriction numbers must be entered in ascending order within each group.
25. Click Cluster Setting.
26. If this media server is part of a Mitel cluster, under Cluster setting, select the This media
server is part of a Mitel cluster check box.
27. If this media server is part of a Mitel cluster, after Cluster ID, type the cluster ID.
The cluster ID can be found on the telephone system.
28. If this media server is part of a Mitel cluster, after Cluster name, select the cluster name.
29. If this media server is part of a Mitel cluster, after Cluster ID Digits, type the digits used to
identify the cluster.
NOTE: After synchronization, cluster settings will automatically align with the telephone
system settings and these fields will auto-populate.
30. Click Save.
31. If you want to enable call recording, see "Call recording" on page 94.
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Table 2: SMDR Option Settings
SMDR OPTION
Extended digit length
MCD - Report transfers

VALUE
Yes
All

Network format

Yes

Report Account Codes

Yes

Report incoming calls

Yes

Report internal calls

Yes

Report meter pulses

No

Report outgoing calls

Yes

SMDR record transfer

Yes

System identification

Yes

Time change report

Yes

24-hour time reporting

Yes

ANI/DNIS/ISDN/CLASS number delivery
reporting

Yes

OLI node ID format for incoming trunk calls
Extended time to answer

Yes

Standardized network OLI

Yes

Standardized call ID format

Yes

Suite services reporting

No

Report internal unanswered calls

No

SMDR extended reporting level 1

Yes

SMDR extended reporting level 2

Yes

Report attendant name

Yes

Account Code number for internal calls

Yes

Path reporting number for internal ACD2 calls

Yes

SMDR Meter Unit Per Station

No
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Call recording
Contact Center Solutions offers 24/7 call recording by integrating with OAISYS Tracer, dvsAnalytics
Encore, or Red Box Quantify call recording software. For enhanced call security, Contact Center
Solutions also integrates with the Mitel Secure Recording Connector service to facilitate the
recording of Mitel encrypted voice streams by third party software. OAISYS Tracer can optionally be
used in conjunction with the Mitel Secure Recording Connector service. dvsAnalytics Encore and
Red Box Quantify must be used in conjunction with the Mitel Secure Recording Connector service.
For information, see "Configuring the Mitel Secure Recording Connector service" on page 94.
For specific information regarding supported third-party versions, see the relevant support
statements in the Contact Center Solutions and Business Reporter System Engineering Guide.

Configuring the Mitel Secure Recording Connector service
Contact Center Solutions integrates with Mitel Border Gateway’s Secure Recording Connector
service, which facilitates the recording of Mitel encrypted voice streams by third-party call recording
equipment. In order to use Contact Center Softphone in conjunction with the Mitel Secure Recording
Connector service, you must complete the configuration process described below.
NOTE:
l

l

Before you can configure call recording in YourSite Explorer, you must configure the Secure
Recording Connector service in Mitel Border Gateway. For Mitel Border Gateway
configuration information, see the Mitel Border Gateway Installation and Maintenance Guide.
If multiple Mitel Border Gateways are used in a clustered environment to take advantage of
load balancing and the soft phone is connected to the primary Secure Recording Connector
when that connector goes offline, the soft phone will re-connect as determined by the cluster.
New soft phones will attempt to connect to the first Mitel Border Gateway configured in
YourSite Explorer, then try the second Mitel Border Gateway configured in YourSite Explorer
and as a final attempt, try registering with the media server itself. If it registers with the media
server, call recording will not be possible.
For soft phone balancing in a Secure Recording Connector service environment to function
properly, you must alter a configuration file on the Mitel Border Gateway server. If you do not,
you will have to restart Contact Center Client and the soft phone in the event of a failover. For
instructions on how to make alterations, contact Mitel Technical Support at 1-800-722-1301 or
miccsupport@mitel.com (North American customers). For customers residing in Latin
America, Europe, the Middle East, Africa, and Asia Pacific, contact your approved Mitel
vendor.

To configure the Secure Recording Connector service
1. In YourSite Explorer, under Enterprise, click Media servers.
2. Select a 3300 ICP media server from the list.
3. Click the Call recording options tab.
4. Under Mitel Secure Recording, after IP address 1, type the primary IP address of the
Secure Recording Connector.
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5. If you use multiple Secure Recording Connectors, type the IP address of the secondary
Secure Recording Connectors after IP address 2.
If the soft phone fails to connect to the primary Secure Recording Connector, it will attempt to
connect to the secondary. If that fails, then soft phone will use the IP address of the media
server programmed in the data collection field. If it uses the IP address of the media server,
call recording will not be possible.
6. Click Save.

Configuring call recording integration
Contact Center Solutions offers 24/7 call recording by integrating with OAISYS Tracer, dvsAnalytics
Encore, or Red Box Quantify call recording software.
Using the OAISYS Tracer, Contact Center Solutions can optionally record calls based on predefined schedules. With OAISYS Tracer, call recording can be temporarily started or stopped in
Contact Center Client to ensure customer confidentiality or to create a record of volatile or sensitive
calls. See "Recording calls" on page 452.
Indirect recording is not supported with Contact Center Client Softphone.
When a call recording is complete, a hyperlink to the recording is appended to call-specific Lifecycle
reports. For more information about Lifecycle reporting, see the reports guide appropriate to your
edition of Contact Center Solutions
NOTE:
l

l

l
l

l

l

OAISYS Tracer, dvsAnalytics Encore, and RedBox Quantify call recording integration is
supported for use with the Mitel 3300 ICP only.
Before you can configure call recording in YourSite Explorer, you must configure your
OAISYS Tracer, dvsAnalytics Encore, or RedBox Quantify by following the recommended
installation and configuration guidelines included with these products.
Contact your OAISYS, dvsAnalytics, or RedBox approved vendor for all setup and
troubleshooting issues.
The dvsAnalytics Encore integration does not support External Hot Desking Agents.
Contact OAISYS, dvsAnalytics, or RedBox for information on integrating call recording with
the Mitel Secure Recording Connector.
Ensure call recordings are working properly for all configured extensions before activating the
call recording integration in YourSite Explorer.
If you use the Mitel Secure Recording Connector and Contact Center Softphone, you must
enter the IP addresses of the Mitel Secure Recording Connector in YourSite Explorer.

To configure OAISYS call recording integration
1. In YourSite Explorer, under Enterprise, click Media servers.
2. Select a media server from the list.
3. Click the Call recording options tab.
4. Under Call recording provider options
l

After Recorder type, select OAISYS from the drop-down list.

l

After OAISYS server address, type the IP address of the call recorder.

l

After OAISYS server port, specify the port of the call recorder.
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l

After Username, type the username to log into the call recorder.

l

After Password, type the password to log into the call recorder.

5. Click Save.
Call recordings are enabled and can be accessed from hyperlinks in call-specific Lifecycle
reports.
To configure dvsAnalytics Encore
1. In YourSite Explorer, under Enterprise, click Media servers.
2. Select a media server from the list.
3. Click the Call recording options tab.
4. Under Call recording provider options
l
l

After Recorder type, select dvs Encore from the drop-down list.
After Encore Web API address, type http://<Encore Server IP
address>/WebAPI/ECAPI.svc

5. Click Save.
Call recordings are enabled and can be accessed from hyperlinks in call-specific Lifecycle
reports.
To configure Red Box Quantify
1. In YourSite Explorer, under Enterprise, click Media servers.
2. Select a media server from the list.
3. Click the Call recording options tab.
l

After Recorder type, select Red Box Recorder.

l

After Recorder IP Address, type the IP address of the call recorder.

l

After Username, type the username of the call recorder

l

After Password, type the password of the call recorder.

4. Click Save.
Call recordings are enabled and can be accessed from hyperlinks in call-specific Lifecycle
reports.

MANAGING HISTORICAL MEDIA SERVERS
Media servers that are no longer in active use can be set as historical to retain data on the media
servers associated devices. Historical data is retained on the media server but no new data is
collected. When a media server is set to historical, it terminates all active licenses for devices
associated with that media server. These historical devices are preserved for historical reporting.
NOTE: The SX-200, Axxess, and 5000 media servers are not supported with Version 7.1, except as
historical media servers. When upgrading to Version 7.1, SX-200 media servers, along with their
associated extensions, agents, agent groups, queues, trunks, and trunk groups, are set to historical.
Axxess and 5000 media servers must be marked as historical before upgrading to Version 7.1 to
retain historical data.
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Associated devices affected by setting a media server to historical include
l

Agents

l

Agent groups

l

Queues

l

Extensions

l

Hunt groups

A historical media server is enabled for
l

Historical reporting for associated devices

l

Forecasting

l

ACD and SMDR Inspector functionality

Once made historical, a media server cannot be returned to active service. A historical media server
cannot be edited and can only be deleted.
To set a media server as historical
1. Under Enterprise, click Media Servers.
2. Select a media server
3. In the General tab, click Make Historical.
4. Click OK.
To delete a historical media server
1. Under Enterprise, click Media Servers.
2. Select a historical media server.
3. Click Delete.

DELETING MEDIA SERVERS
CAUTION: If you delete a media server, you will delete all of the devices associated to the media
server.
To delete a media server
1. In YourSite Explorer, click Media servers.
2. Select the media server you want to delete.
3. Click Delete.
A window opens with the message 'All of the data associated with this media server will be
permanently deleted. Are you sure you want to delete this media server?'
4. Click OK.
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VERIFYING NAME CHANGES OF REMOTE SERVERS
If you change the name of a remote server, you must perform several configuration steps to verify
that YourSite Explorer recognizes the name change and points to the renamed remote server as
expected.
To verify the name change of a remote server
1. On the Remote Server, after changing the Remote Server’s computer name, start Regedit.
2. Navigate to prairiefyre Software Inc\CCM\Common
On a 32-bit system, the path is \HKEY_LOCAL_
MACHINE\SOFTWARE\prairieFyreSoftware Inc\CCM\Common\ComputerName
On a 64-bit system, the path is \HKEY_LOCAL_
MACHINE\SOFTWARE\Wow6432Node\prairieFyreSoftware
Inc\CCM\Common\ComputerName
3. Right-click ComputerName and select Modify.
4. Under Value Data, enter the new name of the Remote Server.
5. Click OK.
6. On the Remote Server, start the Contact Center Management Configuration Wizard.
The Remote Server Configuration Wizard opens.
7. Run the Remote Server Configuration Wizard.
8. On the Enterprise Server, open YourSite Explorer.
9. Click Media servers.
Verify that media servers are pointing to the new remote server name.
10. Click Extensions.
Verify that remote ports are pointing to the new remote server name.
11. Click Servers
The renamed server is listed as a new entry. The server with the old name is listed as a
separate entry.
12. Select the old server entry.
13. Click Delete.
14. Click OK.

YOURSITE DATABASE CONFIGURATION
NOTE: YourSite Explorer enables you to have multiple device tabs open simultaneously. As a best
practice, we recommend you only have the device tabs open that you are currently using.
In an ACD contact center using Contact Center Management there are two main databases: the
telephone system database and the Mitel YourSite database. Your dealer is responsible for
assessing your contact center requirements and configuring the telephone system database
accordingly. You are responsible for configuring the YourSite database to mirror the trunk, extension,
agent, agent group, queue, Account Code numbers, and routing and timing options in use on the
telephone system. This can be achieved quickly using synchronization for the 3300 ICP. See
"Performing synchronization" on page 105.
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YourSite database permissions are based on teams and groups. In the YourSite database, you
create associations between devices and device groups in order to view real-time data and run
reports.
You must
1. Add employees.
2. Add agent groups.
3. Associate employees with agent groups.
4. Add queues.
5. Associate the agent groups with the queues for which they answer calls.
If you intend to run reports on extensions, queue groups, employee groups, trunks, trunk groups,
DNIS numbers, or Account Codes, you must also add these devices and device groups to the
YourSite database.

DETERMINING YOUR CONTACT CENTER CONFIGURATION
NEEDS
NOTE: If you are running Contact Center Management concurrently with Business Reporter, see the
Business Reporter User Guide for information on how to configure your system for Business
Reporter.
There is one recommended configuration scenario for Contact Center Solutions, where employees
only have a single voice agent and use agent group presence to control which queues they receive
calls from. Prior to Version 7.1, there was also a scenario for employees having multiple voice
agents, with each voice agent in a different agent group associated to a different queue. This
configuration scenario is no longer recommended. For more information, see "Multiple voice agents
for individual employees configuration scenario (not recommended)" on page 100.

Recommended configuration scenario
In the recommended configuration scenario, an employee has one agent login ID. The employee
belongs to four agent groups that handle calls for four queues. The employee is simultaneously
available to handle calls to all four queues without having to log out of one queue and into another
queue. (See Figure 11.)
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Figure 11: Recommended configuration scenario
In the recommended configuration scenario, you add your employees via synchronization,
importation, or manual creation. For each employee, you enable them for voice media, which
automatically creates an agent with the same name, reporting number, and other information as the
employee, so that the employee with Employee ID 1000 has an agent with the reporting number of
1000. In the Agent groups device page, you add the employee to Agent Group 1-4. Employee 1000
would now be able to handle contacts for Agent groups 1, 2, 3, and 4.

Multiple voice agents for individual employees configuration scenario
(not recommended)
It is possible to configure employees with one voice agent for each different agent group and queue
that they handle. In this scenario, employees log their different agents in and out to control which
queues they receive calls from. While Contact Center Solutions still supports the ability to configure
employees in this manner, this configuration is no longer recommended as the ability to limit which
queues an employee is handling with their agent is provided through Agent Group Presence.
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CONFIGURING YOURSITE DATABASE DEVICES
You can configure the YourSite database in the following ways:
l

Synchronization
If you have a 3300 ICP, you can synchronize the YourSite database with the queues, agents
(including their skill level within each agent group), agent groups, agent skill groups, trunks,
and extensions programmed on the telephone system using Synchronization. You can
perform Synchronization on individual 3300 ICPs or all 3300 ICPs in your enterprise.
See "Configuring the YourSite database using synchronization" on page 101.

l

l

Active Directory synchronization
If you specified the Windows Authentication model during the Contact Center Management /
Business Reporter Configuration Wizard, you can synchronize your system with Active
Directory at any time from within YourSite Explorer. When you run Active Directory
synchronization, employees in YourSite Explorer are synchronized with users in Active
Directory groups. If you use Windows Authentication and Active Directory synchronization,
users will not be prompted to authenticate themselves with a username and password when
they start Contact Center Solutions and Business Reporter applications.
Quick Setup
If you want to add a range of devices (employee groups, employee divisions, extensions,
extension groups, extension divisions, trunks, trunk groups, DNIS, DNIS groups, Account
Codes, Account Code groups, Make Busy Reason Codes, and teams) you can use Quick
Setup.
See "Configuring devices and device groups using Quick Setup" on page 113.

l

Comma-separated value (.csv) import
You can also add a range of devices (employee, employee groups, employee divisions,
agents, agent groups, queues, queue groups, extensions, extension groups, extension
divisions, trunks, trunk groups, DNIS, DNIS groups, Account Codes, Account Code groups,
Make Busy Reason Codes, Do Not Disturb Reason Codes, and teams) using .csv files.
See "Configuring devices using .csv files " on page 116.

l

Manual configuration
If you want to configure devices manually, see "Configuring devices manually" on page 120.

CONFIGURING THE YOURSITE DATABASE USING
SYNCHRONIZATION
Synchronization functionality differs depending on the telephone system in use.
Synchronization for the 3300 ICP
YourSite Explorer enables you to configure and write 3300 ICP queues, agent skill groups, and
agents (including skill level), and validate/edit contact center related Class of Service, Class of
Restriction, System Options, and SMDR Options settings using synchronization.
This enhanced functionality enables you to configure Contact Center Solutions applications from
your desktop. Validation of device and assignment form settings ensures quality data collection and
accurate reporting. After running synchronization, Class of Service and Class of Restriction settings
programmed in the telephone system can be edited in YourSite Explorer.
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During synchronization, administrators can preview device changes, identify devices that should be
excluded from synchronization, and manage the business rules related to synchronization of device
names and associated device creation.
While synchronizing data, the telephone system continues to operate without experiencing
downtime. After synchronization is complete, the Contact Center Client applications open on agent
desktops will be refreshed with a device update. A report is then generated to summarize the results
of synchronization. We highly recommend that you correct invalid programming, as detailed on the
Telephone system settings tab of media servers in YourSite Explorer, immediately.
In Mitel 3300 release MCD 4.0 SP4, configuring your network using SDS Directory synchronization
mode is optional. Customers can continue to operate in the Classic mode, with OPS Manager if
operating in a clustered environment. In Mitel 3300 release MCD 5.0 or greater, configuring your
network using SDS Directory synchronization mode is mandatory for all sites operating with 20
nodes or less.
Classic mode synchronization
Using YourSite Explorer and the 3300 ICP in Classic mode, you can add, edit, and delete standard
agents, agent groups, and queues, as well as ACD related Class of Service (COS), Class of
Restriction (COR), SMDR Options, and System Options. When not in a clustered environment, you
can also continue to add hot desk agents and all synchronization device names. Adding hot desk
agents in a clustered environment requires the use of Mitel OPS Manager.
SDS Directory synchronization mode
Using YourSite Explorer and the 3300 ICP in SDS Directory synchronization mode, you can add,
edit and delete standard and hot desk agents, agent groups, queues, trunks, trunk groups, and
extensions, synchronize device names, as well as ACD related Class of Service (COS), Class of
Restriction (COR) SMDR options and System Options in both a single site and in a clustered
environment. When operating in SDS Directory synchronization mode, you can configure Network
ACD queue setup on the 3300 ICP without any manual configuration previously required using Mitel
OPS Manager.
NOTE:
l

l

You can only use synchronization to synchronize the YourSite database with resilient,
Network ACD, and clustered telephone systems if you are using 3300 ICP Release MCD 4.0
SP4 or greater, with the SDS Directory synchronization option enabled on all of the telephone
systems in your enterprise.
If you edit the feature access code used for silent monitoring on the media server, you must
also manually edit the feature access code on the telephone system. The feature access code
entered in YourSite Explorer must be identical to that on the telephone system and be valid for
use with silent monitoring. See "Editing System options" on page 109.

Preparing for synchronization
NOTE: Only Mitel telephones that are programmed on the IP Multiline set assignment form will
synchronize with the YourSite database. For details on the phones that are supported, please refer to
your Mitel 3300 ICP documentation.
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Before you perform synchronization for the 3300 ICP
l

l

l

l

l

l

l

Ensure the 3300 ICP is V8.x or greater. You can only use synchronization to synchronize the
YourSite database with resilient, Network ACD, and clustered telephone systems if you are
using 3300 ICP Release MCD 4.0 SP4 or greater, with the SDS Directory synchronization
option enabled on all of the telephone systems in your enterprise.
Ensure that you have completed programming the 3300 ICP and created a username and
password for synchronization (on the 3300 ICP User Authorization Profile form). The 3300
ICP User Authorization Profile must include Application Access and System Admin Access.
Desktop Admin and Group Admin options can be disabled. These steps must be completed
for all 3300 ICPs in your Enterprise.
Ensure your MiXML service is started by navigating to the Control Panel in Windows and
selecting 'MiXML'. Verify that port 18000 is entered on the Settings tab and click Start.
Ensure that your Windows or Corporate firewall is not blocking the following ports
l

SOAP: 18000 (HTTPS)

l

UDP: 53

l

TCP: 7011

l

TCP: 22

l

TCP: 443 (SSH)

Configure the user name and password for each of the 3300 ICP media servers in YourSite
Explorer.
See the Contact Center Management Installation Guide.
If you have multiple NICs on your Enterprise Server, you must specify the NIC to use for
synchronizing data to the telephone system. To do this, navigate to the Control Panel in
Windows and select 'MiXML'. After NIC IP Address specify the primary NIC to be used to
send back data to the telephone system.
If you are running 3300 ICP Release 9.x or earlier, resilient Network ACD, and clustered
telephone systems must be programmed using OPS Manager, RDNs, and cluster element
IDs. 3300 ICPs programmed with Remote Agent Subgroups and ARS are not supported.
Contact Center Management clusters and cluster element IDs must match what is
programmed on the telephone system.
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Specifying synchronization settings
YourSite Explorer enables you to specify the synchronization settings, read options, and write
options used by synchronization. When you select a media server in YourSite Explorer, the following
synchronization options are available from the ribbon, on the Telephone system tab:
l

Settings
l

l

l

l

Read
This option will read devices programmed on your telephone systems and synchronize
them with the YourSite database.
Read/Write
This option will read the devices programmed on your telephone systems and
synchronize them with the YourSite database and enable devices programmed in
YourSite Explorer to be written to the telephone systems.

Read Options
l

l

l

l

l

l

Disabled
This option will fully disable synchronization.

Create employees with new agent
For every new agent added to the YourSite database, a new employee will be created
and associated with the agent.
Create employees with new extensions
For every new extension added to the YourSite database, a new employee will be
created and associated with the agent.
Use telephone system device names
Override device names programmed in YourSite Explorer with the device names
configured on the telephone system.
Default employee license
Select the default employee license that you want to be applied when synchronizing
new agents. Contact Center Enterprise Edition default employee licenses include
None, Basic, Standard, Advanced, and Premium employees. Contact Center Business
Edition default employee licenses include None, Reporting, and Desktop employees.
Contact Center Workgroup Edition default employee licenses include None and
Standard employees.
Default queue business hour schedule
Select the business hour schedule to be applied when synchronizing queues added on
the telephone system.

Write Options
l

Update telephone directory names
Override telephone directory names with agent, agent group, queue, and extension
names configured in YourSite Explorer.
NOTE: If you use MCD 4.0 with Enterprise Manager (OPS Manager) configured, we
recommend you disable the 'Update telephone directory names' option.
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Performing synchronization
There are two ways to perform synchronization:
l

l

Full synchronization
Running full synchronization will synchronize the devices programmed on the telephone
system and enable you to review all devices, and optionally exclude any devices, before
committing changes to YourSite Explorer.
Telephone system settings synchronization
Running telephone system settings synchronization will read the current telephone system
settings and enable you to view any errors or warnings related to the telephone system
configuration.

NOTE:
l

l

l

l

l

l

l

l

You can only use synchronization to synchronize the YourSite database with resilient,
Network ACD, and clustered telephone systems if you are using 3300 ICP Release 10.0
(MCD 4.0 SP4) or greater, with the SDS Directory synchronization option enabled on all of the
telephone systems in your enterprise.
As a best practice, we recommend all new installations run Full synchronization to ensure the
telephone systems in your enterprise are synchronized with the YourSite database and that
there are no critical telephone system programming errors.
You must program your 3300 ICPs and perform synchronization before you can configure
telephone system assignment form options in YourSite Explorer.
We recommend you do not exchange the reporting number of one device with that of another
device.
Synchronization will not synchronize a device being added to the YourSite database with the
telephone system if the device has the same reporting number as an existing device with a
different dialable number.
If you run synchronization for a 3300 ICP containing a queue added on the telephone system,
that queue is assigned your default queue business hour schedule. If you have not specified a
default queue business hour schedule, the default 24/7 schedule is assigned to the queue. For
information on setting the default queue business hour schedule, see "Specifying
synchronization settings" on page 104.
If you are synchronizing a single telephone system, agents and queues must be programmed
on the same telephone system. Single node synchronization can disassociate agents and
queues if agents and queues reside on separate telephone systems.
If you are running 3300 ICP Release 9.x or earlier and you synchronized your network ACD
assignments and/or resilient agents using OPS Manager, you must synchronize all of the
3300 ICPs in your enterprise. Otherwise, agent group and queue group associations will be
lost.

To perform full synchronization
1. In YourSite Explorer, under Enterprise, click Media servers.
2. Select a 3300 ICP media server from the list.
3. Click the Telephone system tab.
4. In the ribbon, specify the settings to use with synchronization.
See "Specifying synchronization settings" on page 104.
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5. In the ribbon, click Run.
The Synchronization window opens.
6. Select the media servers to synchronize.
7. Ensure Full synchronization is selected.
8. If this is the first time you have run synchronization, click Synchronize and continue to step
11. If you have already run full synchronization, click Next.
9. Optionally, select the telephone system media servers and devices to include with
synchronization.
All media servers and devices are selected by default.
10. Specify how you would like to proceed with synchronization:
l

l

l

l

Synchronize—selecting this option will synchronize the devices programmed on the
telephone system and enable you to review all entries and optionally exclude any
devices before committing them to YourSite Explorer. If you select this option, continue
to step 11.
Save settings—selecting this option will save the device settings you specified to be
used for the next scheduled or on-demand synchronization. If you select this option, the
synchronization window will close.
Cancel—selecting this option will cancel the synchronization. No changes will be
made to the YourSite database or the telephone systems. If you select this option, the
synchronization window will close.
Auto commit—selecting this option and clicking Synchronize will synchronize the
devices programmed on the telephone systems and automatically commit them to
YourSite Explorer. There will be no opportunity for you to review the entries and
optionally exclude any devices before committing them to YourSite Explorer.

11. When the synchronization report displays, you have the following three options:
l

l

Commit—selecting this option will commit the specified changes and synchronize
telephone system devices with YourSite Explorer.
Cancel—selecting this option will cancel the specified changes. No devices will be
synchronized and the synchronization window will close.

Edit—selecting this option will rerun synchronization and enable you to modify the
devices to be included in synchronization. If you select this option, return to step 9.
If this is the first time you have run synchronization, any telephone system errors and
warnings will display in the synchronization report. You can correct any errors or warnings
found in this report by clicking Edit, clicking the Telephone system settings tab and changing
the telephone systems settings to the recommended settings. If this is not the first time you
have run synchronization, the synchronization window will close once it is complete and you
can review any telephone system setting errors and warnings on by selecting a media server
in YourSite Explorer and clicking the Telephone system settings tab.
l

To perform telephone system synchronization
1. In YourSite Explorer, under Enterprise, click Media servers.
2. Select a 3300 ICP media server from the list.
3. Click the Telephone system tab.
4. In the ribbon, specify the settings to use with synchronization.
See "Specifying synchronization settings" on page 104.
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5. In the ribbon, click Run.
The Synchronization window opens.
6. Select the media servers to synchronize.
7. Ensure Telephone system settings is selected.
8. Click Synchronize.
The Synchronization report window opens and displays the progress and status of the
synchronization. Once synchronization is complete, any telephone system errors and
warnings will display in the synchronization report. You can correct any errors or warnings
found in this report by clicking Edit, clicking the Telephone system settings tab and changing
the telephone systems settings to the recommended settings.

Ring Group synchronization
YourSite Explorer can synchronize ring groups with your telephone system, but there are several
exclusions. Contact Center Solutions supports only Prime DNs as members of the ring group. When
synchronizing with the telephone system, YourSite Explorer only synchronizes with Prime DN
members of ring groups. If your synchronization settings are set to Read, synchronization skips
unsupported members on the telephone system when synchronizing with YourSite Explorer. If your
synchronization settings are set to Read/Write, then synchronization will delete unsupported
members during writeback to the telephone system.
Ring groups and their attributes and members can be added, modified, and deleted in YourSite
Explorer, but the following ring group attributes are not synchronized into YourSite Explorer:
l

Local-only DN

l

Ring Group Type

l

Predictive Overflow

l

Average Call Duration Minutes/Seconds

l

Absent/Present for members

ACTIVE DIRECTORY SYNCHRONIZATION
You can synchronize your system with Active Directory at any time from within YourSite Explorer.
Active Directory is a directory service created by Microsoft that is used for managing a domain.
Active Directory Synchronization will align Active Directory security groups and users with Contact
Center Solutions and Business Reporter employees and employee groups within selected
organizational units.
At any time, you can optionally re-synchronize or reset all client computers running Contact Center
Solutions and Business Reporter applications and refresh them with the latest configuration
changes. Re-synchronizing will send a delta of the latest configuration changes to client computers,
while resetting will completely drop client computer configurations and send the latest configurations
from YourSite Explorer.
When you run Active Directory synchronization, employees and employee groups in YourSite
Explorer are synchronized with users in Active Directory groups. Existing employees can also be
associated with specific Active Directory users.
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To run Active Directory synchronization
1. In YourSite Explorer, under YourSite, click Enterprise or Employees.
2. On the ribbon, click Active Directory.
3. Under Sync frequency (hh:mm), select how often you want automatic synchronization to
occur.
4. Click Select Sync paths.
The Select paths to sync window opens.
5. Click > or < to add or remove Active Directory entities from the Active Directory tree on the
left to the selected items list on the right and click OK.
The list of selected items on the right includes the Active Directory entities that will be
synched.
6. Under Security Role, click the Browse button and select a default security role to apply to
newly created employees.
7. Click OK.
8. Under Sites, click the Browse button and select a default site to apply to newly created
employees.
9. Click OK.
10. Click Run.
Active Directory synchronization is initiated and pertinent information is updated in YourSite
Explorer.
To send recent configuration changes to client computers
1. In YourSite Explorer, under YourSite, click Enterprise or Employees.
2. On the ribbon, click Tools.
3. Click Re-synchronize clients.
To completely reset client computers with the latest YourSite database configuration information
1. In YourSite Explorer, under YourSite, click Enterprise or Employees.
2. On the ribbon, click Tools.
3. Click Reset clients.
To associate an existing employee with an Active Directory user.
1. In YourSite Explorer, under YourSite, click Employee.
2. Select the employee you want to associate with an Active Directory user.
3. On the ribbon, click Active Directory.
4. Click Pick user.
5. Select a user from the Active Directory tree and click OK.
6. Click Save.
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EDITING TELEPHONE SYSTEM ASSIGNMENT FORMS
After you run Synchronization for the 3300 ICP in YourSite Explorer, you can edit a subset of contact
center related 3300 ICP System Options, SMDR Options, Class of Service, and Class of
Restriction assignment forms. Any changes made to the telephone system assignment forms in
YourSite Explorer are written to the telephone system when a user clicks Save.
After running synchronization, if the 3300 ICP System options, SMDR options, Class of Service
options, or Class of Restriction assignment forms are incorrectly configured, alerts will display
describing modifications that need to be made to achieve accurate telephone system settings. Alerts
are ranked according to severity to display in the following order of importance: errors, warnings, and
then informational messages. Only one message can display at a time in the information bar.
In addition, you can automatically repair certain configuration errors by clicking the Fix it button in the
information bar where errors, warnings, and information messages display. If the alert that is
currently displayed in the information bar is not able to be resolved by the Fix it button, the button will
not display. If the Fix it button displays, clicking it will automatically fix the warning or error that is
displaying in the information bar as well as fixing any other current warning or error that is enabled to
be automatically repaired.
NOTE: You must have read/write capabilities enabled in YourSite Explorer before running
synchronization if you want to receive these alerts. See "Specifying synchronization settings" on
page 104.

Editing System options
Using YourSite Explorer, you can configure access codes and select options for the ACD 2000,
ACD Real-time Events Feature Level, and ACD Make Busy Walk Away Codes. Recommended
values for these system options are displayed in YourSite Explorer
To edit System Options
1. In YourSite Explorer, in the left pane, click YourSite.
2. Under Enterprise, click Media servers.
3. Under Media servers, select a 3300 ICP media server.
4. Click the Telephone system settings tab.
5. In the left pane, click System options.
6. After Feature access code for silent monitoring, type the feature access code used for
silent monitoring, as programmed on the telephone system.
NOTE: If you edit the feature access code on the media server, you must also manually edit
the feature access code on the telephone system. The feature access code entered in
YourSite Explorer must be identical to that on the telephone system and be valid for use with
silent monitoring.
7. Specify remaining system options as required.
8. Click Save.
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Editing SMDR options
Using YourSite Explorer, you can edit a subset of contact center related SMDR options. YourSite
Explorer displays the recommended value for these SMDR options.
To edit SMDR Options
1. In YourSite Explorer, in the left pane, click YourSite.
2. Under Enterprise, click Media servers.
3. Under Media servers, select a 3300 ICP media server.
4. Click the Telephone system settings tab.
5. In the left pane, click SMDR options.
6. Specify the SMDR options.
7. Click Save.

Editing Class of Service options
Using YourSite Explorer, you can edit a subset of contact center related Class of Service options.
YourSite Explorer displays the recommended value for these Class of Service options.
NOTE:
l

l

When first provisioning or changing Class of Service Work Timer values, you must
synchronize with your telephone system. See "Performing synchronization" on page 105.
If you are using ring groups, it is recommended that you configure a default Class of Service
for ring groups.

To edit Class of Service options
1. In YourSite Explorer, in the left pane, click YourSite.
2. Under Enterprise, click Media servers.
3. Under Media servers, select a 3300 ICP media server.
4. Click the Telephone system settings tab.
5. In the left pane, click Class of Service.
6. Under Name, select the Class of Service to edit.
7. In the right pane, after Default type, select a default class of service. Alternatively, select
None and, after Comment, type a description for the Class of Service.
8. Specify the remainder of system options for each Class of Service.
NOTE: Class of Service Work Timer durations are dependent upon your telephone system.
l

MCD 5.0 and greater – 4 hours maximum

l

MCD 4.x or earlier – 10 minutes maximum

9. Click Save.
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Editing Class of Restriction options
Using YourSite Explorer, you can edit a subset of contact center related Class of Restriction
options.
To edit Class of Restriction options
1. In YourSite Explorer, in the left pane, click YourSite.
2. Under Enterprise, click Media servers.
3. Under Media servers, select a 3300 ICP media server.
4. Click the Telephone system settings tab.
5. In the left pane, click Class of Restriction.
6. Under Number, select the Class of Restriction to edit.
7. After Do you want this Class of Restriction to be the default setting, click Yes or No
8. After Classes of restriction for the group, enter the Class of Restriction numbers to include
in the group.
A range of numbers may be specified. Separate numbers using commas or dashes. For
example, 1 through 9 may be entered as 1-9 or a combination of individual numbers and
ranges may be entered as 1,2,3,7-10,13.
NOTE: Class of Restriction numbers must be entered in ascending order within each group.
9. Click Save.

ADDING RESILIENT AND/OR NETWORK ACD HOT DESKING
AGENTS
Resiliency and network ACD functionality is configured in your Mitel telephone system. For
information on configuring your telephone system for resilient and/or network ACD hot desking
agents, consult your Mitel telephone system documentation.
When your telephone systems are set up correctly for resiliency and network ACD hot desking, you
can configure your media servers in YourSite Explorer to use hot desking agents. See "Adding 3300
ICP media servers" on page 85.

Invalid ACD cluster programming
Combining traditional ACD agents and ACD hot desking agents on the same telephone system is
not supported. All media servers within a cluster must be configured with the same type of agents. If
the telephone systems within a cluster are configured with both ACD hot desking agents and
traditional ACD agents, agent states will not display correctly in Contact Center Client real-time
monitors and you will receive an 'Invalid ACD cluster programming' error in YourSite Explorer.
The 'Invalid ACD cluster programming' error is displayed when the following conditions are met
l

l

One or more media servers in a cluster are programmed with both traditional and ACD hot
desking agents and/or
The media servers in a cluster are not programmed with the same type of ACD agents

NOTE: As a best practice, we recommend you perform Synchronization before attempting to
resolve any invalid ACD cluster programming errors on the telephone system. This will ensure that
your configuration is accurate and any errors being reported are valid.

111

Contact Center Solutions User Guide

The following scenarios provide examples of different invalid ACD cluster programming, with the
problem areas identified in red text.
Scenario 1
In the scenario shown in Table 3, media servers with mixed agent types are programmed in YourSite
Explorer.
Table 3: Invalid ACD agent programming scenario 1
CLUSTER NAME: PRIMARY
MEDIA
SERVER

YOURSITE EXPLORER
AGENT TYPE

3300 ICP
AGENT TYPE

INVALID AGENT TYPE
PROGRAMMING

Kanata 3300
5th floor

Hot desking

Hot desking

No

Kanata 3300
7th floor

Traditional

Traditional

No

Scenario 2
In the scenario shown in Table 4, media servers have the correct agent type settings programmed in
YourSite Explorer, but have mixed agent types programmed against a single 3300 ICP.
Table 4: Invalid ACD agent programming scenario 2
CLUSTER NAME: MASTER
MEDIA
SERVER

YOURSITE EXPLORER
AGENT TYPE

3300 ICP
AGENT TYPE

INVALID AGENT TYPE
PROGRAMMING

Kanata 3300
5th floor

Traditional

Hot desking /
Traditional

Yes

Kanata 3300
7th floor

Traditional

Traditional

No

For more information on ACD agent programming, see the Mitel 3300 System Administration Tool
Help, which can be found at http://edocs.mitel.com/default.htm.
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CONFIGURING DEVICES AND DEVICE GROUPS USING
QUICK SETUP
You can use Quick Setup to add ranges of the following devices and device groups:
l

Employee groups and employee divisions

l

Extensions, extension groups, and extension divisions

l

DNIS and DNIS groups

l

Account Codes and Account Code groups

l

Make Busy Reason Codes

l

Teams

Extension Quick Setup
To add a series of extensions
1. In YourSite Explorer, in the left pane, click YourSite.
2. Under Devices, click Extensions.
3. Click Quick Setup.
4. In the Active number from and Active number to boxes, type a range of device numbers.
5. If you want to add a prefix or postfix to this range of device numbers, after Name prefix and/or
Name Postfix type the prefix and/or postfix.
6. On the General tab, select a media server and a failover media server for the extension.
7. If the extension will be costed with Business Reporter, select the Cost this extension check
box.
8. Select the Disable real-time monitoring and data collection on this device check box if
you do not want to enable the extension to be set with a MiTAI monitor, viewed in Contact
Center Client, and use Contact Center Softphone or Salesforce.com Connector.
By default, this check box is not selected.
9. Under Advanced options, select the Extension type.
10. If you want to create an employee for each extension, on the Employee associations tab,
select the Create an employee ID for each extension check box.
NOTE: Select this check box only if you have not already added employee IDs to the
database.
11. After Start the employee IDs at, type the first employee ID to associate to the extension
number range.
12. After Increment the employee IDs by, type the increment by which the employee IDs will
increase.
13. Click Run.

Trunk Quick Setup
To add a series of trunks
1. In YourSite Explorer, in the left pane, click YourSite.
2. Under Devices, click Trunks.
3. Click Quick Setup.
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4. In the Active number from and Active number to boxes, type a range of device numbers.
5. If you want to add a prefix or postfix to this range of device numbers, after Name prefix and/or
Name postfix type the prefix and/or postfix.
6. On the General tab, click Browse and select a media server for the trunk.
7. Click Run.

Trunk group Quick Setup
To add a series of trunk groups
1. In YourSite Explorer, in the left pane, click YourSite.
2. Under Devices, click Trunk groups.
3. Click Quick Setup.
4. In the Active number from and Active number to boxes, enter a range of device numbers.
5. If you want to add a prefix or postfix to this range of device numbers, after Name prefix and/or
Name postfix type the prefix and/or postfix.
6. On the General tab, click the Browse button and select the voice media server associated
with the trunk (for example, 3300 ICP Voice).
7. If this trunk group uses an intra switch, select the Intra switch check box.
8. To cost calls using this trunk, clear the Do not cost calls check box.
9. Click Run.

DNIS Quick Setup
To add a series of DNIS
1. In YourSite Explorer, in the left pane, click YourSite.
2. Under Devices, click DNIS.
3. Click Quick Setup.
4. In the Active number from and Active number to boxes, type a range of device numbers.
5. If you want to add a prefix or postfix to this range of device numbers, after Name prefix and/or
Name postfix type the prefix and/or postfix.
6. On the General tab, after Associate the devices to this media server, click Browse and
select a media server.
7. After Short Abandon, type the Short Abandon threshold for the DNIS.
8. After Service Level, type the Service Level time for the DNIS.
9. Click Run.

Account Code Quick Setup
To add a series of Account Codes
1. In YourSite Explorer, in the left pane, click YourSite.
2. Under Devices, click Account Codes.
3. Click Quick Setup.
4. In the Active number from and Active number to boxes, type a range of device numbers.
5. If you want to add a prefix or postfix to this range of device numbers, after Name prefix and/or
Name postfix type the prefix and/or postfix.
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6. To you want to create an employee for each Account Code, on the Employee Associations
tab, select the Create an employee ID for each Account Code check box.
NOTE: Select this check box only if you have not already added employee IDs to the
database.
7. After Start the employee IDs at, type the first employee ID number to associate to the
Account Code range.
8. After Increment the employee IDs by, type the increment by which the employee ID
numbers will increase.
9. Click Run.

Make Busy Reason Codes Quick Setup
To add a series of Make Busy Reason Codes
1. In YourSite Explorer, in the left pane, click YourSite.
2. Under Devices, click Make Busy Reasons.
3. Click Quick Setup.
4. In the Active number from and Active number to boxes, type a range of device numbers.
5. If you want to add a prefix or postfix to this range of device numbers, after Name prefix and/or
Name postfix type the prefix and/or postfix.
6. Click Run.

Team Quick Setup
To add a series of Teams
1. In YourSite Explorer, in the left pane, click YourSite.
2. Under Devices, click Teams.
3. Click Quick Setup.
4. In the Active number from and Active number to boxes, type a range of device numbers.
5. If you want to add a prefix or postfix to this range of device numbers, after Name prefix and/or
Name postfix type the prefix and/or postfix.
6. Click Run.

Device group Quick Setup
To add a series of Account Code groups, DNIS groups, employee groups and divisions, extension
groups and divisions, and queue groups
1. In YourSite Explorer, in the left pane, click YourSite.
2. Under Devices, click the device group name.
3. Click Quick Setup.
4. In the Active number from and Active number to boxes, type a range of device numbers.
5. To add a prefix or postfix to the range of device numbers, after Name prefix and/or Name
postfix type the prefix and/or postfix.
6. If you are adding an agent group, click Browse and select a media server and failover media
server to associate with the agent group.
7. Click Run.
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CONFIGURING DEVICES USING .CSV FILES
You can import devices to YourSite Explorer using comma-separated value (.csv) files. The
following device types are currently supported for use with the YourSite Explorer .csv import tool:
employees, employee groups, employee divisions, agents, queue groups, extensions, extension
groups, extension divisions, trunks, trunk groups, DNIS, DNIS groups, Account Codes, Make Busy
Reason Codes, teams, Do Not Disturb Reason Codes, traffic, and ANI.
A .csv file is used for the digital storage of data structured in a table of lists form, where each
associated item (member) in a group is in association with others also separated by the commas or
tabs of its set.
There are two ways to create .csv files: Notepad or Microsoft Excel. We recommend making .csv
files in Excel, as adding and editing a large number of entries at once using auto-fill functions is much
simpler and more convenient than using Notepad.
Alternatively, you can also import tabbed delimited text files created in Excel. Tabbed delimited text
files are almost identical to .csv files, but use tabs to differentiate data fields instead of commas.
NOTE: When creating .csv files, you must save the file as either a .csv or .txt file. Simply renaming
an Excel file or changing a file type extension to .csv will not work and you will be unable to import
device data into YourSite Explorer.
Figure 12 and Figure 13 provide two examples of how .csv files can be formatted. The following
figures display Microsoft Excel .csv formatting and Notepad .csv formatting. Both .csv examples
contain the following data: first name, last name, agent login ID, and media server.
NOTE: To import configuration options that display in the YourSite Explorer grid view as a check
box, you must enter True or False as the field data.

Figure 12: Microsoft Excel .csv formatting example
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Figure 13: Notepad .csv formatting example

Fields required for successful .csv imports
Table 5 details the fields that are required in order to successfully import devices into YourSite
Explorer using a .csv file.
NOTE: Data must be entered in .csv files using the exact order detailed in Table 5 below. Failure to
import data in the order specified will result in import errors.
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Table 5: Mandatory device fields for .csv imports
DEVICE
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MANDATORY FIELDS

OPTIONAL FIELDS

Employees

Reporting number, Last
name, First name

Username, Password, Email address, Middle
name, Suffix, Scheduling license, Nickname, Full
time, Site, Is a supervisor, Activated, Supervisor,
Security role, Use employee email for report
distribution, Fax number, Hire date, Preferred
printer, Birth date, Print locally, Business phone
number, Emergency contact phone number,
Emergency contact relationship, Emergency
contact name, Country, ZIP or postal code, Street
address, City, State or province, Pager number,
Phone number, Is active, Employee license,
Supervisor license, Phone type license, Integrated
client license, Licensed for Screen Pop

Employee
groups

Name, Reporting number

N/A

Employee
divisions

Name, Reporting number

N/A

Agents

Reporting number, Last
name, First name, Media
server, Real-time

Failover media server, Employee, MiTAI enabled,
Is active, Class of Service, Class of Restriction

Queue
groups

Name, Reporting number

Is Unified, Is Virtual

Extensions

Name, Reporting number,
Media server

Extension type, Failover media server, Server
Name, Workflow, Real-time, MiTAI enabled,
Licensed, Notes, Is general business hot desking

Extension
groups

Name, Reporting number

N/A

Extension
divisions

Name, Reporting number

N/A

Trunks

Name, Reporting number,
Media server

N/A

Trunk
groups

Name, Reporting number

Media server, Do not cost calls, Carrier plan, Intra
switch

DNIS

Name, Reporting number,
Media server

Short Abandon, Service Level, Carrier plan, Call
type, Call rate
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Table 5: Mandatory device fields for .csv imports (continued)
DEVICE

MANDATORY FIELDS

OPTIONAL FIELDS

DNIS
groups

Name, Reporting number

N/A

Account
Codes

Name, Reporting number

Use as classification code

Make Busy
Reason
Codes

Name, Reporting number

N/A

Teams

Name, Reporting number

N/A

Do Not
Disturb
Reason
Codes

Name, Reporting number

N/A

Traffic

Reporting number, Name

Pkey, Media server, TrafficType

ANI

Name, Ani

N/A

Importing a range of devices using a .csv file
Before you attempt to import a device using a .csv file, ensure
l

l

The .csv file contains data for all of the fields required to save a device in YourSite Explorer as
detailed in the following table.
If a device requires a dependency to be specified, for example specifying a media server is
required in order to save an agent, the dependency must already exist in YourSite Explorer.
The Import Wizard cannot create new dependencies and will fail if the dependency does not
already exist in the database.

To import a range of devices using a .csv file
1. In YourSite Explorer, under Devices, click the name of the device you will add using a .csv
file.
2. Click Import.
3. After Select file type, specify whether the .csv file uses Comma separated values or Tab
separated values.
4. After Select file, click Browse and specify the location of the .csv file.
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5. Under Options, specify how the Import Wizard will handle duplicate items.
If duplicates are found:
l

l

l

Overwrite entries if duplicates are found will use the .csv file as the master and
overwrite duplicate entries in the YourSite database with data in the .csv file.
Skip duplicate entries during import will retain data configured in YourSite Explorer
as the master and import any new data entries from the .csv file into the YourSite
database.
Do not import if duplicates are found will scan the .csv and YourSite database for
duplicates. If duplicates are found in either the .csv or the YourSite database, the import
is cancelled and no data is imported to the YourSite database.

6. Click Next.
7. On the Field Mappings window, map the fields in the Available columns list to the
Selected columns list using the arrow buttons, so they display in the same order as they do
in your .csv file.
8. Click Next.
9. When the import has completed, click Finish.
NOTE: If the import fails, the Import Wizard will notify you of whether the YourSite database
or .csv file contained the duplicate(s) and which row(s) of the .csv file contained the error(s)
that resulted in the failure. Fixing these errors will allow devices to be successfully imported.

CONFIGURING DEVICES MANUALLY
CAUTION:
l

l

For reporting purposes, the trunk, extension, agent, agent group, queue, DNIS, dialable
numbers, and Account Code numbers you configure in the YourSite database must be
identical to those of the telephone system.
Print a copy of your telephone system assignment forms to use as a guide for programming
YourSite Explorer. The numbers you enter in YourSite for extensions, trunks, and Account
Codes must be identical to those of the telephone system.

You add contact center devices in YourSite Explorer.
NOTE:
l

l
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When you configure numbers for groups in YourSite, use numerical characters only, such as 1
(for Extension group 1). Do not insert symbols, such as a star [*] or pound sign [#], in the
number.
If you attempt to add a device or device group to YourSite that is already in the database, the
system notifies you that the device or device group is already present. When you add a series
of devices or device groups to YourSite, such as Extensions 5001 to 5005, if the system
detects you have already added Extension 5002, then it will not add Extension 5002 or any
subsequent extensions in the series (that is, Extensions 5003 to 5005) to the database.
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Adding employees
Every employee configured in YourSite Explorer represents a unique member of a contact center.
Each employee is configured with agents. These agents are tied to the media servers supported by
Contact Center Solutions.
You must add all contact center employees (agents, supervisors, and managers) to YourSite
Explorer so you can run reports on employee activities and view employee performance in real time,
and so the employees can access Contact Center Solutions applications.
NOTE: You must assign each employee a unique ID number.
Adding an employee requires you to:
l

Add an employee

l

Configure general employee information

l

Configure employee licensing

l

Modify employee Workload
NOTE: Modifying employee Workload is only required if the employee is licensed for
Multimedia Contact Center.

l

Manage the media types an employee can handle

l

Configure user account information

Optionally, you can:
l

Assign non-ACD extensions and Account Codes

l

Configure employee personal information

l

Configure employee scheduling preferences for Workforce Scheduling

To add an employee
1. In YourSite Explorer, in the left pane, click YourSite=>Employees.
2. Click Add.
Continue to "Configuring general employee information" on page 121.

Configuring general employee information
The following procedures explain how to:
l
l

Configure general information for an employee
Configure Lync attributes for an employee
NOTE: Lync attributes are only available if you have Lync Server installed.

The following procedures take place in YourSite=>Employees.
To configure general information for an employee
1. Select an employee and click the General tab.
2. After First name, type the employee’s first name.
NOTE: Changes to the first name will carry over to any of the employee's associated agents
and extensions.
3. Optionally, after Middle name, type the employee’s middle name or initial.
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4. After Last name, type the employee’s last name.
NOTE: Changes to the last name will carry over to any of the employee's associated agents
and extensions.
5. Optionally, after Suffix, type the employee name suffix.
6. Optionally, after Nickname, type the employee’s nickname.
NOTE: In Multimedia Contact Center, nicknames may be used in chat sessions with
customers.
7. Optionally, after Activated, enter the date the employee became an active part of the
enterprise.
By default, the activated date is set to the current date.
NOTE: You must provide the date the employee became an active part of the enterprise if you
want to generate administrative employee reports, or if you have Workforce Scheduling and
will schedule employees based on seniority, or will manage time off entitlements and
business rules based on time off allocation.
8. After Employee ID, enter a unique employee ID number for the employee.
9. After Email, enter the employee’s email address.
NOTE: If the employee will use Contact Center Chat with Lync, you must enter the Lync SIP
email address in the email field.
10. Click Save.
11. If this is a new employee and you are using Microsoft Lync Server, continue to the procedure
below, otherwise continue to "Configuring Employee Licensing" on page 122.
To configure Lync attributes for an employee
1. Select an employee and click the General tab.
2. Type the employee’s SIP address.
3. Type the employee’s Line URI.
4. Click Save.
If this is a new employee, continue to "Configuring Employee Licensing" on page 122.

Configuring Employee Licensing
The following procedures explain how to:
l

Configure employee licensing for Enterprise Edition

l

Configure employee licensing for Business Edition

l

Configure employee licensing for Workgroup Edition

The following configuration takes place in YourSite=>Employees.
To configure employee licensing for Enterprise Edition
1. Select an employee and click the Licensing tab.
2. For Contact Center Enterprise Edition users, depending on licensing, select from None,
Basic. Standard, Advanced, or Premium employee.
l
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None: This option enables you to run reports on the employee, if data exists for that
employee, however, you cannot monitor the employee in real time and no new data will
be collected for the employee. When you select this option, historical data for the
employee continues to be stored and the employee's name is removed from all Contact

YourSite database configuration

Center Client device selection lists. If this is a non-ACD user, when configured with an
Integrated Client license, the user will have access to CCMWeb and Contact Center
Client for Contact Center PhoneSet Manager. Associated extensions can be viewed in
real time, either for general business purposes or Business Reporter (if associated
extensions are configured to be call costed).
CAUTION: If data exists for an employee who was previously licensed but is currently
unlicensed, that data can be accessed in reports. However, if a summarization is done
after the employee is no longer licensed, there is a risk that the collected data could be
lost.
l

l

l

l

Basic employee: is reported on historically, viewed in real time, and has access to
real-time monitors (except Callback and Port monitors, if licensed for IVR Routing).
Users also have access to CCMWeb My Options page to configure user options, such
as language preference.
Standard employee: includes all Basic employee features and functionality and has
access to Interactive Contact Center, Enterprise Presence and Chat, and Contact
Center PhoneSet Manager.
Advanced employee: includes all Standard employee features and functionality as
well as Contact Center Management and Interactive Contact Center resiliency
(requires a Network license), choice of CTI Toolkit Client, or Salesforce Client (requires
a Salesforce.com Connector), and Contact Center Screen Pop.
Premium employee: includes all Advanced employee features and functionality plus
access to Ignite and multimedia routing for all media types.
NOTE: Only one employee license can be selected for each employee. You cannot
license an employee if no licenses remain.

3. If the employee is a supervisor, depending on licensing, under Supervisor license select from
None, Advanced, or System Administrator supervisor.
l
l

l

None: use this option for employees who are agents or general business extensions.
Advanced supervisor: has access to the following: CCMWeb (reporting, forecasting,
and My Options), Flexible Reporting (if a Standard Starter Pack or greater is owned),
Contact Center Client for real-time monitoring (including Callback and Port monitors, if
licensed for IVR Routing), YourSite Explorer (read-access only to the Enterprise
section of YourSite Explorer), and Ignite (review and search through the Ignite
repository, excluding contacts in queue).
NOTE: Supervisors requiring the ability to handle contacts in Ignite or search contacts
in queue require a Premium employee license.
System Administrator: a System Administrator has full access to all Contact Center
Solutions, Business Reporter, IVR Routing software (if licensed) for the purposes of
configuration and network and system administration, and access to Ignite for
reviewing and searching the Ignite repository.
NOTE: Only one type of supervisor license can be selected for each employee.

4. Under Phone type license, depending on licensing, select a phone type license.
l

l

Mitel desk phone: select this option if the employee will use a Mitel desk phone. This
is the default option.
Softphone and/or Mitel desk phone: select this option if the employee will use and is
licensed for Contact Center Softphone.
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NOTE: If the employee requires the use of Contact Center Softphone in addition to or in
combination with a Mitel desk phone, select the Softphone phone type. Contact Center
Softphone licensing is available to Standard, Advanced, or Premium employees. If the
employee is a non-ACD employee (designated as employee type 'None'), you must
select 'Licensed for integrated client' to have access to Contact Center Softphone
functionality.
5. If you want the employee to be licensed for Workforce Scheduling, under Workforce
Scheduling license, select Licensed for Workforce Scheduling.
NOTE: Users must be configured as Basic, Standard, Advanced, or Premium to be scheduled
in Workforce Scheduling.
6. If this employee is a non-ACD employee who needs access to Contact Center PhoneSet
Manager, CTI Developer Toolkit Client, or Salesforce.com Client, under Integrated client
license, select Licensed for integrated clients. Integrated client license is a prerequisite for
Contact Center Softphone. Salesforce.com Connector is required to activate Salesforce.com
Client.
7. If this employee is a non-ACD employee who needs access to screen pop, under Screen Pop
license, select Licensed for Screen Pop. Integrated Client is a prerequisite for Screen Pop.
Ignite screen pop does not require this license.
8. Click Save.
If this is a new employee with Premium licensing, continue to "Adding employee Workload" on
page 127. Otherwise, continue to "Managing the media types an employee can handle" on
page 129.
To configure employee options for Business Edition
1. Select an employee and click the Licensing tab.
2. Depending on licensing, select from None, Reporting, or Desktop employee.
l

l

l

None: This option enables you to run reports on the employee, if data exists for that
employee, however, you cannot monitor the employee in real time and no new data will
be collected for the employee. When you select this option historical data for the
employee continues to be stored and the employee's name is removed from all Contact
Center Client device selection lists.
CAUTION: If data exists for an employee who was previously licensed but is currently
unlicensed, that data can be accessed in reports. However, if a summarization is done
after the employee is no longer licensed, there is a risk that the collected data could be
lost.
Reporting employee: is reported on historically, viewed in real time, and has access
to Enterprise Presence and Chat.
Desktop employee: is reported on historically, viewed in real time, has access to
Enterprise Presence and Chat, has the ability to view real-time monitors via Contact
Center Client, and has access to Ignite and multimedia routing for all applicable media
types.
NOTE: Only one employee license can be selected for each employee. You cannot
license an employee if no licenses remain. A Reporting license is a prerequisite for a
Desktop license. When you apply a Desktop license, you decrement both a Desktop
license and a Reporting license.

3. Depending on licensing, select from None or Desktop supervisor licensing.
l
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None: use this option for employees who are agents or general business extensions.
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l

Desktop supervisor: has access to CCMWeb (reporting, contacts, and forecasting),
Contact Center Client for real-time monitoring, YourSite Explorer for enterprise and
device configuration, and, if the contact center is licensed for Multimedia Contact
Center, Ignite (review and search through the Ignite repository, excluding contacts in
queue).
NOTE: Desktop supervisors requiring the ability to handle contacts in Ignite or search
contacts in queue require a Multimedia Contact Center BE agent license.

4. Depending on licensing, select a phone type license.
l

l

Mitel desk phone: select this option if the employee will use a Mitel desk phone. This
is the default option.
Softphone and/or Mitel desk phone: select this option if the employee will use and is
licensed for Contact Center Softphone.
NOTE: If the employee requires the use of Contact Center Softphone in addition to or in
combination with a Mitel desk phone, select the Softphone phone type license. If the
employee is a non-ACD employee (designated as employee type 'None'), you must
select 'Licensed for integrated client' to have access to Contact Center PhoneSet
Manager, CTI Toolkit Client, or Salesforce.com Client functionality.

5. Select additional licensing options as required.
l

Under Integrated Client license, select Licensed for integrated clients if you want
the employee to have access to Contact Center PhoneSet Manager, CTI Toolkit Client,
or Salesforce.com Client.
l

l

l

See the Contact Center Solutions and Business Reporter System Engineering
Guide for in-depth licensing information.

Under Screen Pop license, select Licensed for Screen Pop if you want the
employee to have access to Contact Center Screen Pop.
l

l

Integrated client license is a prerequisite for Contact Center Softphone.
Salesforce.com Connector is required for Salesforce.com Client.

Integrated Client is a prerequisite for Screen Pop.

Under Multimedia Contact Center license, select Licensed for Multimedia
Contact Center if you want the employee to be able to access voice and a choice of
two additional media types, including email and chat.

6. Click Save.
If this is a new employee who is licensed for Multimedia Contact Center, continue to "Adding
employee Workload" on page 127. Otherwise, continue to "Managing the media types an
employee can handle" on page 129.
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To configure employee licensing for Workgroup Edition
1. Select an employee and click the Licensing tab.
2. For Contact Center Workgroup Edition users, select from None or Standard.
l

l

None: This option enables you to run reports on the employee, if data exists for that
employee, however, you cannot monitor the employee in real time and no new data will
be collected for the employee. When you select this option, historical data for the
employee continues to be stored and the employee’s name is removed from all Contact
Center Client device selection lists. If this is a non-ACD user, when configured with an
Integrated Client license, the user will have access to CCMWeb and Contact Center
Client for Contact Center PhoneSet Manager. Associated extensions can be viewed in
real time, either for general business purposes or Business Reporter (if associated
extensions are configured to be call costed).
CAUTION: If data exists for an employee who was previously licensed but is currently
unlicensed, that data can be accessed in reports. However, if a summarization is done
after the employee is no longer licensed, there is a risk that the collected data could be
lost.
Standard employee: is reported on historically, viewed in real time, and has access to
real-time monitors. Users also have access to CCMWeb to configure user options,
Interactive Contact Center, Enterprise Presence and Chat, and Contact Center
PhoneSet Manager.
NOTE: Only one employee license can be selected for each employee. You cannot
license an employee if no licenses remain.

3. Under Supervisor license, select the employee's supervisor license type
l
l

l

None: use this option for employees who are agents or general business extensions
Advanced: an Advanced Supervisor has access to the following: CCMWeb (reporting,
forecasting, and My Options), Contact Center Client for real-time monitoring, and
YourSite Explorer (read-access only to the Enterprise section of YourSite Explorer)
System Administrator: a System Administrator has full access to all Contact Center
Solutions, Business Reporter, and IVR Routing software (if licensed) for the purposes
of configuration and network and system administration.
NOTE: Only one type of supervisor license can be selected for each employee.

4. Under Phone type license, depending on licensing, select a phone type license.
l

l

Mitel desk phone: select this option if the employee will use a Mitel desk phone. This
is the default option.
Softphone and/or Mitel desk phone: select this option if the employee will use and is
licensed for Contact Center Softphone.
NOTE: If the employee requires the use of Contact Center Softphone in addition to or in
combination with a Mitel desk phone, select the Softphone phone type.

5. If you want the employee to be licensed for Workforce Scheduling, under Workforce
Scheduling license, select Licensed for Workforce Scheduling.
NOTE: Users must be configured as a Standard agent to be scheduled in Workforce
Scheduling.
6. If this employee is a non-ACD employee who needs access to Contact Center PhoneSet
Manager, under Integrated client license, select Licensed for integrated clients.
Integrated client license is a prerequisite for Contact Center Softphone.
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7. Click Save.

Adding employee Workload
Employees handling multimedia contacts must be associated with a Workload.
When employees become licensed for Multimedia Contact Center, administrators must manually
assign them a Workload. Workloads define the maximum number of contacts that multimedia
agents can handle and specify which media types employees can handle concurrently.
When an employee reaches their maximum Workload for a media type, their agent is put into Make
Busy with the Overloaded reason code. When an employee is Overloaded, the employee will not be
offered inbound contacts for that media type. This state is automatically removed when they are no
longer at their maximum Workload. Employees in Ignite who have reached their maximum
concurrent contacts in one type of media are still able to pick contacts from the corresponding
media’s queues and receive transfers from other agents.
A default Workload is provided with Multimedia Contact Center. The default Workload can be
modified, but not deleted. Figure 14 shows the default Workload.

Figure 14: Default Workload
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There are two areas of configuration required for Workloads for each media type:
l

l

Concurrent contacts: This column of drop-down menus allows an administrator to set how
many contacts of each type of media an employee can handle concurrently.
Avoid routing to this media type when current media type is active: This matrix enables
administrators to prevent certain media types from being offered to employees when they are
handling a higher priority of media. When an employee is handling a media that filters another
kind of media, the employee’s agents for the blocked media are set into Make Busy. The
disallowing of media is reciprocal, so that if Chat is disabled when handling Voice, then Voice
would be disabled when handling Chat.
NOTE:
l
l

Agents can still receive transferred contacts of the disallowed media type.
Media icons are present for SMS media, but are disabled as this media type is not
supported in Version 7.1. The icons will be enabled when support for this media type is
added in a later release.

The following configuration takes place in YourSite=>Employees.
The following procedures explain how to:
l

Associate a Workload to an employee

l

Associate a new Workload to an employee

l

Edit an existing Workload

l

Delete a Workload
NOTE: We recommend disassociating a Workload from all employees before deleting it.

To associate an employee with a Workload
1. Select an employee and click the Workload tab.
2. After Workload Descriptor, click the Browse button.
3. Select a Workload.
Alternatively, if you want to create a new Workload to associate to the employee, click Add.
4. Click OK.
5. Click Save.
If this is a new employee, continue to "Managing the media types an employee can handle" on
page 129.
To add a new Workload to an employee
1. Select an employee and click the Workload tab.
2. After Workload Descriptor, click the Browse button.
3. Click Add.
4. Type a Name for the Workload.
5. To apply the Workload to outgoing voice calls, select Apply rule to outgoing voice calls.
6. For each media type, under Concurrent contacts, select the maximum number of
connections of that media type that can be handled concurrently.
7. For each media type, click the icons of the media you do not want employees to concurrently
handle when handling that type of media.
8. Click Save.
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To edit an existing Workload
1. Select an employee and click the Workload tab.
2. Click the Browse button.
3. Select a Workload and click Edit.
4. When you are done modifying the Workload, click Save.
To delete a Workload
1. Select an employee and click the Workload tab.
2. Click the Browse button.
3. Click Delete.
4. Click OK.

Managing the media types an employee can handle
Employees handle media through their associated agents. The General tab of an employee contains
icons representing each media type that has a configured media server. When an icon is selected,
an agent of that media type is automatically created and associated to the employee. If an employee
is a member of an agent group that has been enabled for multimedia using the Unified Queue Group
Wizard, they will automatically be enabled to handle the new media types. Table 6 contains an
explanation of which icons correspond to which media type.
Table 6: Media icons
MEDIA TYPE

MEDIA ICON

Voice

Chat

Email

NOTE: Employees must be licensed to handle non-voice media. See "Configuring Employee
Licensing" on page 122.
When you remove the employee's ability to handle non-voice media, the employee's agents are
made historical, but become active again if the employee is re-enabled to handle that non-voice
media. Multimedia agents can be deleted to be removed entirely from the system.
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The following procedures explain how to:
l

Enable an employee to handle voice media

l

Enable an employee to handle voice media using an existing agent

l

Edit an employee’s voice agent

l

Enable an employee to handle multimedia

l

Remove a voice agent from an employee

l

Remove an employee's ability to handle a type of media

l

Delete a multimedia agent

The following configuration takes place in YourSite=>Employees.
To enable an employee to handle voice media
1. Select an employee and click the General tab.
2. Under Enable ACD for this Media Type, click the Voice icon.
3. Optionally, change the agent’s First name.
4. Optionally, change the agent’s Last name.
5. Optionally, after Agent login ID, enter the reporting number for the voice agent.
6. After Media server, click the Browse button.
7. Select a media server and click OK.
8. If you want to disable real-time monitoring and data collection for this agent, select Disable
real-time monitoring and data collection on this device.
9. If a 3300 media server was selected, after COS, select a Class of Service from the list.
10. If a 3300 media server was selected, optionally, after COR, select a Class of Restriction from
the list.
11. If a 3300 media server was selected, if you want to add a failover media server, after Failover
media server, click the Browse button.
12. Select a media server and click OK.
13. Click Save.
To enable an employee to handle voice media using an existing agent
1. Select an employee and click the General tab.
2. Under Enable ACD for this Media Type, click the down arrow beside the Voice icon and
click Associate existing voice agent.
3. Select an unassigned agent and click OK.
4. Click Save.
To edit an employee’s voice agent
1. Select an employee and click the General tab.
2. Under Enable ACD for this Media Type, click the down arrow beside the Voice icon and
click <agent ID>=>Edit.
3. When you are finished editing the voice agent, click Save.
4. Click Save.
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To enable an employee to handle multimedia
1. Select an employee.
2. Under Enable ACD for this Media Type, click the media icons to select which media this
employee can handle.
3. Click Save.
To remove a voice agent from an employee
1. Select an employee and click the General tab.
2. Click the down arrow beside the Voice icon and click <agent ID>=>Delete.
3. Select the delete option:
l

l

l

Make the device historical—sets the agent as historical, but leaves it associated to
this employee
Disassociate the device—disassociates the agent so it can be used with another
employee
Remove the device from the system—deletes the agent

4. Click OK.
5. Click Save.
To remove an employee's ability to handle a type of media
1. Select an employee.
2. Under Enable ACD for this Media Type, click the enabled media icon.
3. Click Save.
To delete a multimedia agent
1. Select an employee.
2. Click the down arrow beside the media icon and click Delete.
3. Click Save.

Configuring user account information
It is recommended that user accounts be configured after security roles are configured. See
"Security roles" on page 189.
The following procedures explain how to:
l

Configure user account information for an employee

l

Configure an employee’s report distribution

The following configuration takes place in YourSite=>Employees.
To configure user account information for an employee
1. Select an employee
2. Click the User Account tab.
3. Type the employee’s Username.
4. Type the employee’s Password.
5. After The employee will reside at this site, click the Browse button.
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6. Select a site.
NOTE: The site determines the employee’s default language. Employees can change their
language settings in CCMWeb.
7. Click OK.
8. If you want to change the employee’s language, select a language from the Language dropdown menu.
NOTE: Contact Center Solutions applications, such as YourSite Explorer and Contact Center
Client, leverage the language settings of the operating system in addition to the language
preference set for Contact Center Solutions. Ensure that if you change the language settings
of Contact Center Solutions, you change the language settings of the operating system to
match.
9. After Security role, click the Browse button.
10. Select a security role.
The default Local Administrator allows employees full access to all of the Contact Center
Solutions applications and devices (to which the contact center is licensed) except for Write
Back for synchronization.
The default Enterprise Administrator allows employees the same access as the Local
Administrator, but includes Write Back for synchronization.
11. Click OK.
12. Click Save.
If this is a new employee
l
l

l

To configure an employee’s report distribution, continue to the procedure below.
To configure non-ACD extensions and Account Codes, continue to "Assigning nonACD extensions and Account Codes for employees" on page 133.
To configure employee personal information, continue to "Configuring employee
personal information" on page 134.

To configure an employee’s report distribution
1. Type the file path of the Network printer.
You must configure the network printer as the default printer on the Enterprise Server. The
printer path name is case sensitive.
2. If you want the employee’s reports to print from their desktop printer, select Send printed
report to the employee’s desktop printer.
3. If you want to use the employee’s email address for report distribution, select Use the
employee’s email address for report distribution.
4. Click Save.
If this is a new employee
l

l
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Assigning non-ACD extensions and Account Codes for employees
You can optionally assign non-ACD extensions and Account Codes to employees. If you are using
Business Reporter, Account Codes assigned to employees enable reporting on that Account Code
to see the outbound costs associated to that employee. Account Codes can only be associated to
one employee.
The following procedures explain how to:
l

Create a new extension and associate it with the employee

l

Associate an existing extension

l

Edit an existing associated extension

l

Create an Account Code to associate to the employee

l

Associate an existing Account Code

l

Edit an existing associated Account Code

The following configuration takes place in YourSite=>Employees.
To create a new extension and associate it with the employee
1. Select an employee and click the Devices tab.
2. Click the Extension button.
Alternatively, click the down arrow beside Extension and click Add.
3. To configure the new extension, see "Adding extensions" on page 158.
4. Click Save.
If this is a new employee, when you are done assigning non-ACD extensions or Account
Codes, continue to "Configuring employee personal information" on page 134.
To associate an existing extension
1. Select an employee and click the Devices tab.
2. Click the down arrow beside Extension and select Associate existing.
3. Select an extension and click OK.
The extension name is automatically populated with the employee’s name.
By default, the extension type is voice softphone, which emulates a 5020 IP set.
By default, the extension reporting number/dialable is populated with the employee’s business
phone.
4. Click Save.
If this is a new employee, when you are done assigning non-ACD extensions or Account
Codes, continue to "Configuring employee personal information" on page 134.
To edit an existing associated extension
1. Select an employee and click the Devices tab.
2. Click the down arrow beside the Extension button and click <extension>=>Edit.
3. When you are finished editing the extension, click Save.
4. Click Save.
If this is a new employee, when you are done assigning non-ACD extensions or Account
Codes information, continue to "Configuring employee personal information" on page 134.
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To create an Account Code to associate to an employee
1. Select an employee and click the Devices tab.
2. Click the Account Code button.
3. If you want to change the Account Code name, type a Name.
4. If you want to change the Account Code reporting number, type the Reporting number.
5. If you want to use this Account Code as a Classification Code, select Use as a
Classification Code.
6. Click Save.
If this is a new employee, when you are done assigning non-ACD extensions or Account
Codes, continue to "Configuring employee personal information" on page 134.
To associate an existing Account Code
1. Select an employee and click the Devices tab.
2. Click the down arrow beside Account Code and select Associate existing.
3. Select an Account Code and click OK.
4. Click Save.
If this is a new employee, when you are done assigning non-ACD extensions or Account
Codes, continue to "Configuring employee personal information" on page 134.
To edit an existing associated Account Code
1. Select an employee and click the Devices tab.
2. Click the down arrow beside the Account Code button and click <Account Code>=>Edit.
3. When you are finished editing the Account Code, click Save.
4. Click Save.
If this is a new employee, when you are done assigning non-ACD extensions or Account
Codes, continue to "Configuring employee personal information" on page 134.

Configuring employee personal information
To configure employee personal information
1. Select an employee and click the Details tab.
2. Enter the employee's personal information in the relevant fields.
3. Click Save.
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Adding employee groups
After adding employees, you add employee groups and associate employees to these groups.
Employee groups enable you to report on specific groups of employees.
The following procedures explain how to:
l

Add an employee group

l

Associate an employee with an employee group

l

Remove an employee from an employee group

To add an employee group
1. Click Multimedia=>Employee groups.
2. Click Add.
3. Type the employee group’s Name.
4. Type the Employee group ID.
5. Click Save.
To associate an employee with an employee group
1. Click Multimedia=>Employee groups.
2. Select an employee group from the list.
3. On the Membership tab, under Available members, select an employee and click > to move
the employee to the Selected members list.
4. Click Save.
To remove an employee from an employee group
1. Click Multimedia=>Employee groups.
2. Select an employee group from the list.
3. On the Membership tab, under Selected members, select an employee and click < to move
the employee to the Available members list.
4. Click Save.

Adding employee divisions
A division is composed of several employee groups. The Division tab shows the employee groups
that belong to the division currently selected. When you create employee divisions in YourSite, you
can run reports for several employee groups simultaneously.
To add an employee division
1. In YourSite Explorer, in the left pane, click YourSite.
2. Under Devices, click Employee Divisions.
3. Click Add.
4. Type a Name and Reporting number for the employee division.
5. On the ribbon, click Save.
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To associate an employee group with an employee division
1. In YourSite Explorer, in the left pane, click YourSite.
2. Under Devices, click Employee Divisions.
3. Select an employee division from the list.
4. On the Membership tab, under Available members, select an employee group and click > to
move the employee group to the Selected members list.
5. On the ribbon, click Save.

Adding agents
Agent IDs enable employees to handle different media and to be reported on and tracked in real time.
When an administrator enables an employee to handle a type of media, the employee has an agent
ID of that media type automatically created. A contact center employee can have multiple voice
agent IDs, but requires a unique agent ID for each of the other media types (email and chat) that they
handle.
Voice and multimedia agent IDs are added in the Employee section of YourSite Explorer. To add
different media agent IDs to an employee, see "Managing the media types an employee can handle"
on page 129. Voice agents can be created in the Agent section of YourSite Explorer, but it is
recommended to create agents within the Employee section. The Agent section also enables
administrators to delete agent IDs. Deleting an active agent removes an employee's capabilities to
handle the corresponding media. Historical multimedia IDs can only be deleted in the Agent section.
NOTE:
l

l

l

If agents are in a non-SDS clustered environment but not hot desking and not resilient, the
agent names will not display on the telephone switch. You must enter these agent names
outside of YourSite Explorer.
Workgroup Edition supports both traditional and hot desking agents, but it is recommended
that only hot desking agents are used with Workgroup Edition.
Workgroup Edition does not support Failover media servers

In order to provide Contact Center Work Timer functionality in Contact Center Client, every
traditional agent’s extension or every hot desking Agent ID must be enabled with a MiTAI monitor.
In YourSite=>Agents, administrators
l

Add voice agent IDs

l

Delete agent IDs

l

Associate unassociated voice agent IDs to employees

l

l

Specify 3300 ICP Class of Service, Class of Restriction, and Failover media server options
for voice agent IDs
Enable a voice agent for external hot desking

To add a voice agent ID
1. Click YourSite=>Agents.
2. Click Add.
3. If you want to associate the new voice agent ID to an employee, click the Browse button after
Employee.
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4. Type the voice agent ID's First name.
5. Type the voice agent ID's Last name.
6. After Agent login ID, enter the reporting number for the voice agent ID.
7. After Media Server, click the Browse button.
8. Select a media server and click OK.
9. Click Save.
NOTE: The Disable real-time monitoring and data collection on this device check box
is automatically selected if the employee that is associated to this agent has their licensing
attribute set to 'None'. See "Configuring Employee Licensing" on page 122 for more
information.
To delete an agent ID
1. Click YourSite=>Agents.
2. Select an agent.
3. Click Delete.
4. Click OK.
To associate an unassociated voice agent to an employee
1. Click YourSite=>Agents.
2. Select an unassociated voice agent ID.
3. After Employee, the Browse button.
4. Select an employee and click OK.
5. Click Save.
To configure 3300 ICP options for a voice agent ID
1. Click YourSite=>Agents.
2. Select an agent from the list.
3. Under 3300 ICP Options, after COS, select a Class of Service from the list.
4. After COR, select a Class of Restriction from the list.
5. After Failover media server, click the Browse button.
6. Select a failover media server from the list and click OK.
7. Click Save.
To enable a voice agent for external hot desking
1. Click YourSite=>Agents.
2. Select an agent from the list.
3. Select External hot desk user enabled.
4. After External dialing prefix, type the dialing prefix for the device to which calls will be
routed.
5. After External dialing number, type the dialing number for the device to which calls will be
routed.
6. Click Save.
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Adding agent groups
Administrators must add agent groups to the YourSite database and associate employees to these
agent groups. An employee and their agents can be associated to more than one agent group.
When agent groups are created, an employee’s agents are assigned a default group presence, either
Present or Absent. Employees whose agents’ default presence is Absent will have their state set to
Logged In Not Present Agent when they join their agent group. To handle that media type, the
employee must change their agent state manually in Contact Center Client. Employees whose
agents’ default presence is Present will be set in the Idle Agent state when they join their agent
group. For details about Agent States, see "Employee and Agent states" on page 207.
NOTE:
l

l

l

If you attempt to add a group to YourSite that is already in the database the system notifies
you that the group is already present. When you add a series of groups to YourSite, such as
Extension Groups 1 to 5, if the system detects you have already added Extension Group 3,
then it will not add Extension Group 3 or any subsequent extensions in the series (that is,
Extension Group 4 or 5) to the database.
Deleting an agent group that is currently the last member of a voice or multimedia queue will
invalidate that queue. Deleting an agent group that is associated to an activity in an Inqueue
workflow will create a validation error. The queue will not be able to be saved until another
agent group is associated to it. It is recommended that you disassociate agent groups from
queues and their associated Inqueue workflows before deleting the agent group.
Workgroup Edition does not support agent skills and Failover media servers. Workgroup
Edition agent groups do not support a mix of local and remote agents as members.

To set up an agent group, administrators must:
l

Add an agent group

l

Manage agent group membership, presence, and skill level

l

Specify agent group options for the 3300 ICP media server

The following procedures explain how to:
l

Add an agent group

l

Disable monitoring and device collection for an agent group

l

Specify if the agent group uses skills

The following configuration takes place in YourSite=>Agent groups.
To add an agent group
1. In Agent groups, click Add.
2. Type a Name for the agent group.
3. Type a Reporting number for the agent group.
4. Select the media type(s) the agent group will handle.
See Table 7.
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Table 7: Media icons
MEDIA TYPE

MEDIA ICON

Voice

Chat

Email

SMS*

* The SMS media type is not supported in Version 7.1. The SMS icon will be enabled when support is
added in a later release.
5. If you select voice media, select the voice media server and click OK.
NOTE: If this agent group is not handling voice contacts, then this option will not be available.
6. Click Save.
To disable monitoring and device collection for an agent group
1. Select an agent group.
2. Select Disable real-time monitoring and data collection on this device.
3. Click Save.
To specify if the agent group uses skills
1. Select an agent group
2. Select The group uses skills.
3. Click Save.

Managing agent group membership, presence, and skill level
After configuring an agent group, administrators must associate employees to the agent groups and
specify the default presence for each of the employee’s agent IDs for the media types the agent is
configured to handle. If the agent group uses skills, skill levels must be set for each employee. Skill
levels range from 1, which is the most skilled, to 255, which is the least skilled. The skill level
assigned to the employee is applied to each media the employee is capable of handling.
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Some employees may have multiple voice agents associated to them. When these are added to an
agent group, they are highlighted in yellow. Administrators can select which of an employee’s voice
agents are in the agent group. It is recommended that an employee only have one voice agent
associated to an agent group.
The following procedures explain how to
l

Add and remove agents from an agent group

l

Specify which of an employee’s multiple voice agents are in an agent group

l

Specify a member's default presence in an agent group

l

l

Specify a member's skill level
NOTE: Workgroup Edition does not support agent skill levels. If an agent group is
programmed to use skills on the telephone system, the agent group will be marked as
historical in YourSite Explorer until the skill levels are removed.
Edit a member employee

The following configuration takes place in YourSite=>Agent groups.
To add and remove agents from an agent group
1. Select an agent group and click the Membership tab.
2. To add employees to the agent group, under Available members, select an employee and
click >.
3. To remove agents from an agent group, under Selected members, select an employee and
click <.
4. Click Save.
To specify a member’s default presence in the agent group
1. Select an agent group and click the Membership tab.
2. Under Selected members, after the agent in the <media type> Presence column, click the
cell and select the default presence.
l

l

Absent—the employee’s agent ID will be put into the Logged in Not Present agent
state when they join the agent group.
Present— the employee’s agent ID will be put into Idle when they join the agent group.

3. Repeat Step 2 for each media type the member can handle in the agent group.
4. Click Save.
To specify a member’s skill level
1. Select an agent group and click the Membership tab.
2. Under Selected members, select a skill level from the drop-down list in the Skill level column
for each member.
3. Click Save.
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To edit a member employee
1. Select an agent group and click the Membership tab.
2. Under Selected members, select the employee you want to edit.
3. Click Edit.
For information on configuring employees, see "Adding employees" on page 121.
4. When you are done editing the employee, click Save.

Specifying 3300 ICP options for agent groups
The following configuration takes place in YourSite=>Agent groups.
To specify 3300 ICP options for an agent group
1. Select an agent group from the list.
2. On the 3300 ICP options tab, if you want to change your Skill Group ID, after Skill Group ID,
enter a new ID.
3. Click Browse and select a failover media server.
4. Specify if the agent group uses skills and if calls are to be queued to the agent group when no
agents are logged in.
5. Click Save.

Adding teams
After adding agent groups, you can add teams and associate agent groups to these teams.
To add teams
1.
2.
3.
4.
5.

In YourSite Explorer, in the left pane, click YourSite.
Under Devices, click Teams.
Click Add.
Type a Name and Reporting number for the team.
On the ribbon, click Save.

Associating agent groups to teams
To associate agent groups to teams
1. In YourSite Explorer, in the left pane, click YourSite.
2. Under Devices, click Teams.
3. Select a team from the list.
4. On the Membership tab, under Available members, select an agent group and click > to
move the agent group to the Selected members list.
5. On the ribbon, click Save.
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Adding queues
Queues receive inbound calls and then route them to either agents or extensions, depending on the
kind of queue. Queues can be voice queues, which are ACD paths that route calls to agent groups,
or ring groups, which route calls to a pool of extensions.
Non-voice multimedia queues receive inbound contacts, such as email or chats, and route them to
the agents in the associated agent groups to handle the contact. The associated agent groups
handle the contacts from that queue and generate statistics for reports on the queue. Reports can be
generated on queue activities and queue performance can be viewed in real time.
When you add a queue to the YourSite database, the configuration options available depend on the
media server you select. Media servers fall under three general categories: voice (a telephone
system with or without MiTAI enabled), email, and chat.
For instructions on adding multimedia queues, see the Multimedia Contact Center Installation and
Deployment Guide.

Adding voice queues (ACD path)
The default voice queue for Contact Center Solutions is the ACD path, which distributes calls to
groups of agents. When an administrator adds an ACD path voice queue, they:
l

Configure general voice queue information

l

Configure voice queue membership

l

Configure business hours for the voice queue

l

Configure Inqueue routing
NOTE: This requires licensing for IVR Routing.

l

Configure queue spectrum settings for voice queues

l

Optionally, set voice queue 3300 ICP options

If you are licensed for IVR Routing, for instructions on how to configure IVR Routing options for
queues, consult "Configuring queues" on page 518.
l

l

l

l

l

For information on configuring a queue for web callbacks, see "Enabling web callbacks" on
page 539.
For information on configuring a queue for abandon callbacks, see "Enabling abandon
callbacks" on page 537.
For information on associating a queue to an UPiQ workflow, see "Configuring Inqueue
routing" on page 518.
For information on setting up UPiQ workflows, see "Default Inqueue UPiQ workflow and
subroutine" on page 629.
For information on configuring a queue for RAD messages, see "Configuring RAD messages
for queues" on page 520.

NOTE: Queues cannot be saved until membership has been specified. Ensure that agent groups
have been configured before creating queues. See "Adding agent groups" on page 138.
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To add a voice queue
1. Click YourSite=>Queues.
2. Click Add and select Voice Queue.
3. Continue to "Configuring general information for voice queues " on page 143.
NOTE: New voice queues cannot be saved until agent group membership has been
configured for the queue.

Configuring general information for voice queues
When configuring general information for a queue, administrators specify common information,
service level objectives, handing configuration, and Queue Work Timer options. Queue Work Timer
options enable queues to change their Work Timer duration to be different than the Class of Service
Work Timer or force agents to enter call classification codes before they handle other requests. If
you select the Force entry of a classification code check box, agents will receive a pop up in Contact
Center Client forcing them to enter a call classification code before they can answer more calls.
The following procedures outline how to:
l

Configure common voice queue information

l

Set the voice queue service level objectives

l

Set the voice queue handling times

l

Configure the voice queue’s dialable number

l

Configure the Queue Work Timer options

NOTE: If you are configuring a new queue, you cannot save until agent membership has been
configured. See "Adding queue groups" on page 155.
The following procedures take place in YourSite=>Queues.
To configure common voice queue information
1. Select a queue and click the General tab.
2. Type a Name for the queue.
3. Type a Reporting number for the queue.
4. After Media server, click the Browse button.
NOTE: Once a queue has been saved, the media server cannot be changed.
5. Select the media server and click OK.
6. If you do not want the queue to be viewed in Contact Center Client and Ignite, select Disable
real-time monitoring and data collection on this device.
7. If this is a new queue, continue to the procedure below. If this is a previously added queue,
click Save.
To set the voice queue service level objectives
1. Select a queue and click the General tab.
2. Specify the Service Level goal and Service Level time for the queue.
3. If this is a new queue, continue to the procedure below. If this is a previously added queue,
click Save.
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To set the voice queue handling times
1. Select a queue and click the General tab.
2. After Short Handle less than, type the duration that will define a call as a short handle call.
For example, type 3 to define a short handle call as one that lasts less than 3 seconds. Short
talk calls are included in call statistics.
3. After Short abandon less than, type the duration that will define an abandoned call as
‘Abandoned (Short)’.
For example, type 5 to define a short abandon call as one that is abandoned in less than 5
seconds.
4. If this is a new queue, continue to the procedure below. If this is a previously added queue,
click Save.
To configure the voice queue’s dialable number
1. Select a queue and click the General tab.
2. After Dialable number, type the path directory number listed on the telephone system
assignment forms.
3. If this is a new queue, continue to the procedure below.
To configure the Queue Work Timer options
1. Select a queue and click the General tab.
2. To enable the queue for Work Timer, select Use queue work timer.
3. Under Use queue work timer, set the Queue Work Timer’s duration.
The default duration is 00:05:00.
NOTE:
l

l

Queue Work Timer maximum duration is dependent on your telephone system.
l

MCD 5.0 and greater – 4 hours maximum

l

MCD 4.x or earlier – 10 minutes maximum

A queue’s work timer must not exceed the Class of Service associated with any agents
in agent groups who are associated with this queue. See "Editing Class of Service
options" on page 110.

4. To force agents to enter call classification Account Codes, select Force entry of a
classification code.
This feature is hidden unless you are licensed for Integrated Client and use either Contact
Center PhoneSet Manager or Contact Center Softphone.
5. If you want Work Timer to end once the classification Account Code has been entered, select
Cancel queue work timer once code is entered.
This feature is hidden unless you are licensed for Integrated Client and use either Contact
Center PhoneSet Manager or Contact Center Softphone.
6. If you want to add Contact Center Work Timer to handling time in reports, select Include
queue work timer as part of handling time.
NOTE: When 'Include work timer as part of handling time' is enabled, the ACD handling time
durations for reporting purposes span from ACD pick up to the end of the Work Timer time.
When this option is disabled, the ACD handling time duration spans from ACD pick up to hang
up.
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7. If this is a new queue, continue to "Configuring voice queue membership" on page 145. If this
is a previously added queue, click Save.

Configuring voice queue membership
Agent groups must be assigned to a queue to handle ACD calls. Calls are offered to agent groups in
the order in which they are associated to the voice queue and are offered to the next agent group in
the list when the set overflow timer for that group expires. When configuring overflow timers for
associated agent groups, the Total Time to Agent Group column is automatically populated to
indicate how long a call will be waiting before being offered to that agent group. A maximum of four
agent groups can be assigned to a queue.
NOTE: Workgroup Edition only supports a single agent group per queue. Workgroup Edition does not
support overflow, only interflow. If additional agent groups are associated to the queue on the
telephone system, after synchronization, the queue will be marked as historical. Until the additional
agent groups are removed, you will be unable to save your queue.
The following procedures explain how to:
l

Associate an agent group to a queue

l

Remove an agent group association from a queue

l

Set the Overflow timer

The following procedures take place in YourSite=>Queues.
To associate an agent group with a queue
1. Select a queue from the list and click the Membership tab.
2. Under Available members, select an agent group and click > to move the agent group to the
Selected members list.
The order agent groups are added determines the order in which agent groups are offered
calls.
3. To adjust the order of selected members, select an agent group and click ^ or ˅.
4. Click Save.
To remove an agent group association from a queue
1. Select a queue from the list and click the Membership tab.
2. Under Available members, select an agent group and click < to move the agent group to the
Selected members list.
3. Click Save.
To set the overflow timer
1. Select a queue from the list and click the Membership tab.
2. Under Selected members, set the Overflow Timer for each agent group associated to the
voice queue.
3. Click Save.

145

Contact Center Solutions User Guide

Configuring business hours for voice queues
The following procedures explain how to:
l

Configure the business hours for a queue

l

Apply a queue’s business hours to all queues on the same media server

The following procedures take place in YourSite=>Queues.
To configure the business hours for a queue
1. Select a queue and click the Business Hours tab.
2. After Business-hour schedule, click the Browse icon.
3. Select a schedule and click OK.
4. If you want to restrict the production of real-time statistics and reports to only during business
hours, select Generate real-time statistics and reports only within the business hours
selected.
5. Click Save.
If this is a new queue, continue to "Configuring queue spectrum settings for voice queues" on
page 146.
To apply the business hours to all queues on the same media server
1. Select a queue and in the ribbon, click the Queue Tools tab.
2. Select Apply business hours to all.

Configuring queue spectrum settings for voice queues
Queue spectrum reports provide valuable information on how calls are dispersed in your contact
center. You configure answer, abandon, interflow, handle, and ringing thresholds for queues in
YourSite Explorer. The answer, abandon, interflow, and talk statistics will be distributed across the
queue spectrum reports in the time intervals you specify.
NOTE: The data in the queue spectrum ringing reports is derived from the ACD data stream. Queue
performance report data is derived from the SMDR data stream so cannot be compared to queue
spectrum ringing report data.
The following procedures take place in YourSite=>Queues.
To configure queue spectrum settings for a queue
1. Select a queue and click the Queue Spectrum tab.
2. Select the spectrum value(s) you want to include in reports and specify thresholds for each.
All threshold values are in seconds.
3. Click Save.
To apply queue spectrum settings to all queues on the same media server
1. Select a queue and in the ribbon, click the Queue Tools tab.
2. Select Apply queue spectrum to all.
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Configuring 3300 ICP options for voice queues
The Mitel 3300 ICP media server offers additional voice queue configuration options.
The following procedures explain how to:
l

Set priority level for the queue
See "Understanding call priority" on page 416.

l

Set queue unavailable answer point directory number

l

Set interflow options

The following procedures take place in YourSite=>Queues.
To set the priority level for the queue
1. Select a queue and click the 3300 ICP options tab.
2. After Priority, select the priority level for the queue.
The highest priority level is 1. The lowest priority level is 64.
3. Click Save.
To set the queue unavailable answer point directory number
1. Select a queue and click the 3300 ICP options tab.
2. Type the Queue unavailable answer point directory number.
3. Click Save.
To set the queue’s interflow options
1. Select a queue and click the 3300 ICP options tab.
2. To enable interflow, after Interflow enabled, select Yes.
3. Select the Interflow timeout.
4. Type the Interflow point directory number.
5. To enable overflow to interflow before time out, select Yes.
6. If you want interflow to this queue to use this queue’s priority, select Yes.
7. Click Save.

Adding ring groups
With Contact Center Solutions, you can configure ring groups, with the following limitations:
l
l

l

Ring groups are supported for MCD 7.0+
Clustered ring groups are not supported. Ring groups, their extensions, interflow points, and
IVR ports which transfer to ring groups must all be on the same media server.
Only Prime DNs and Hot Desk Users are supported as members of ring groups

It is recommended that ring groups have a default Class of Service configured on the 3300 media
server. For more information, see "Editing Class of Service options" on page 110.
If you are licensed for IVR Routing, ring groups are not supported for callback or UPiQ workflows,
subroutines, and related activities.
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When an administrator adds a ring group, they
l

Configure general ring group queue information

l

Configure ring group business hours

l

Configure ring group membership

l

Configure queue spectrum settings for ring groups

l

Configure ring group 3300 ICP options

To add a ring group queue
1. Click YourSite=>Queues.
2. Click Add and select Ring group.
3. Continue to "Configuring general information for ring group queues" on page 148.
NOTE: New ring group queues cannot be saved until the name, reporting number, and media
server have been configured for the queue.

Configuring general information for ring group queues
The following procedures outline how to:
l

Configure common ring group queue information

l

Set the ring group service level objectives

l

Set the ring group handling times

The following procedures take place in YourSite=>Queues.
To configure common ring group queue information
1. Select a queue and click the General tab.
2. Type a Name for the queue.
3. After Reporting number, type the ring group’s dialable number.
NOTE: The reporting number cannot be changed after saving the ring group.
4. After Media server, click the Browse button.
5. Select the media server and click OK.
NOTE: The media server cannot be changed after saving the ring group.
6. After Failover media server, click the Browse button.
7. Select the Failover media server and click OK.
8. If you do not want the queue to be viewed in Contact Center Client and Ignite, select Disable
real-time monitoring and data collection on this device.
9. Click Save.
If this is a new ring group, continue to the procedure below.
To set the ring group service level objectives
1. Select a ring group and click the General tab.
2. Specify the Service Level goal and Service Level time for the ring group.
3. Click Save.
If this is a new ring group, continue to the procedure below.
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To set the ring group handling times
1. Select a ring group and click the General tab.
2. After Short Handle less than, type the duration that will define a call as a short handle call.
For example, type 00:00:03 to define a short handle call as one that lasts less than 3 seconds.
Short talk calls are included in call statistics.
3. After Short abandon less than, type the duration that will define an abandoned call as
‘Abandoned (Short)’.
For example, type 00:00:05 to define a short abandon call as one that is abandoned in less
than 5 seconds.
4. Click Save.
If this is a new ring group, continue to "Configuring business hours for ring groups" on page
149.

Configuring business hours for ring groups
The following procedures explain how to:
l
l

Configure the business hours for a ring group
Apply a ring group’s business hours to all queues on the same media server
NOTE: The business hours are applied to all ring groups and ACD path voice queues on the
same media server.

The following procedures take place in YourSite=>Queues.
To configure the business hours for a ring group
1. Select a ring group and click the Business Hours tab.
2. After Business-hour schedule, click the Browse icon.
3. Select a schedule and click OK.
4. If you want to restrict the production of real-time statistics and reports to only during business
hours, select the Generate real-time statistics and reports only within the business
hours selected check box.
5. Click Save.
If this is a new ring group, continue to "Configuring membership for ring groups" on page 149.
To apply a ring group’s business hours to all queues on the same media server
1. Select a ring group and in the ribbon, click the Queue Tools tab.
2. Select Apply business hours to all.

Configuring membership for ring groups
Extensions or hot desking users must be assigned to a queue to handle ring group calls. Depending
on how the ring group is configured to distribute calls, calls will be offered to extensions in their order
in the member list.
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NOTE: All voice softphone extensions created in YourSite Explorer have the MCD setting ‘ACD
Enabled’ applied when written back to the telephone system. ACD enabled extensions can be added
as members of ring groups, but they cannot be made present in the ring group. This is a restriction
imposed by MCD. If a hot desking agent logs into an ACD extension, they will go out of service and
not be updated in the real-time monitors. ‘ACD Enabled’ can be removed from extensions in MCD.
For more information, consult your Mitel documentation.
Ring group extension members must be located on the same node as the ring groups. Ring groups
do not support multi-node configurations.
The following procedures explain how to:
l

Associate an extension to a ring group queue

l

Remove an extension association from a ring group queue

The following procedures take place in YourSite=>Queues.
To associate an extension with a ring group
1. Select a ring group queue from the list and click the Membership tab.
2. Under Available members, select an extension and click > to move the extension to the
Selected members list.
Depending on the algorithm selected, calls will be offered to a ring group’s extensions using
the order in the Selected members list.
NOTE: To ensure accurate reporting, hot desking users should be made members of the
same ring groups as the extensions to which they log in.
3. To adjust the order of selected members, select an extension and click ^ or ˅.
4. Click Save.
To remove an extension association from a ring group
1. Select a ring group from the list and click the Membership tab.
2. Under Available members, select an extension and click < to move the extension to the
Selected members list.
3. Click Save.

Configuring queue spectrum settings for ring groups
Queue spectrum reports provide valuable information on how calls are dispersed in your contact
center. The answer, abandon, interflow, and talk statistics will be distributed across the queue
spectrum reports in the time intervals you specify.
If you apply your queue spectrum settings on all queues on a media server, they are applied to both
ring groups and ACD path voice queues.
The following procedures take place in YourSite=>Queues.
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To configure queue spectrum settings for a ring group
1. Select a ring group and click the Queue Spectrum tab.
2. Select the spectrum value(s) you want to include in reports and specify thresholds for each.
All threshold values are in seconds.
NOTE: Ringing spectrum does not apply to ring groups.
3. Click Save.
To apply a ring group’s queue spectrum settings to all queues on the same media server
1. Select a ring group and in the ribbon, click the Queue Tools tab.
2. Select Apply queue spectrum to all.

Configuring ring group settings for ring group queues
Ring group specific queue settings are configured in the 3300 ICP Options tab.
The following procedures take place in YourSite=>Queues.
To configure the ring group settings for a ring group queue
1. Select a queue and click the 3300 ICP Options tab.
2. After Ring Algorithm, select the ring groups call distribution algorithm from the following:
l
l

l

l

l

Ring All: Rings all available extensions in the ring group simultaneously.
Terminal Cascade: Starting from the first extension in the member list, rings the first
available extension for the duration of the Cascade Ring Timer before calling the next
available extension in the member list.
Terminal: Starting from the first extension in the member list, rings the first available
extension.
Circular: Starting from the last member to handle a call, rings the next available
extension in the members list.
Circular Cascade: Starting from the last member to handle a call, rings the next
available extension in the member list for the duration of the Cascade Ring Time before
calling the next available extension in the member list.

3. After COS, select a Class of Service for the ring group.
If you have configured a default Class of Service for ring groups, the default ring group Class
of Service will be automatically applied.
4. If you selected a Cascade algorithm, after Cascade Ring Timer, set the time a call will ring
an extension before ringing the next member extension in the ring group.
5. After Call Queued Timer, set the maximum time a call will remain in queue for a ring group
before redirecting to the overflow point.
6. After Call Ringing Timer, set the maximum time a call will ring an extension before the call
is redirected to the overflow point.
7. After Call Coverage Service Number, enter a configured Call Coverage Service Number.
8. If you want to redirect incoming calls to another directory number if the ring group extensions
do not answer, after Overflow Point, type the dialable number for the overflow destination.
The Overflow Point can be any Prime DN destination, such as an extension or queue.
NOTE: If a traditional agent logs into the overflow point, calls will never be offered
9. Click Save.
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Setting a queue as historical
Voice and ring group queues can be set as historical, disabling real-time monitoring and data
collection on the queue. Historical voice queues retain their data for reporting, but cannot handle
contacts and are not available in Contact Center Client and Ignite. A historical queue can be restored
to active service.
To set a queue as historical or to reactivate a historical queue
1. Select a queue and click the General tab.
2. If you are setting the queue as historical, select Disable real-time monitoring and data
collection on this device.
3. If you are reactivating the queue, clear Disable real-time monitoring and data collection
on this device.
4. Click Save.

Deleting a queue
When you delete a queue, it is removed from both YourSite Explorer and the media server. No more
data is collected for the deleted queue, but any collected data for the queue is preserved and can be
reported on.
NOTE: If you restore a backup from before the queue was deleted, it will re-associate itself to the
collected data for the queue.
To delete a queue
1. Click YourSite=>Queues.
2. Select a queue and click Delete.
3. Click OK.

Automatically opening and closing queues
With Interactive Contact Center queue control, queues can be automatically opened and closed
based on business hour schedules and queue control plans. When closed, queues associated to
3300 ICP servers are placed in Do Not Disturb and redirected to an alternate answer point.
For example, the default Monday to Friday, 9-5 business hour schedule is applied to a 3300 ICP
queue using Interactive queue control. At 5:00 PM, the queue is placed into Do Not Disturb and
cannot receive calls. During these times, calls are routed to their unavailable answer point. At 9:00
AM, the queue is removed from Do Not Disturb and calls can again be routed to the queue.
Interactive Contact Center queue control automates queue availability to respond to your
businesses’ hours of operation, ensuring that calls do not idle in queue after hours.
The following procedures explain how to
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Opening and closing queues with business hour schedules
You can open and close queues by assigning a business hour schedule to the queue. You can also
remove the business hour schedule from the queue. For information on creating business hour
schedules, see "Business hour schedules" on page 175.
To assign a business hour schedule to a queue
1. Click YourSite=>Queues.
2. Select the queue and click the Interactive queue control tab.
3. Select the The queue uses Interactive Contact Center queue control check box and click
the Browse button.
4. Select a schedule to apply to the queue control plan and click OK.
5. Click Save.
To remove a business hour schedule from a queue
1. Click YourSite=>Queues.
2. After Interactive Contact Center queue control plan, click the Clear button.
3. Click Save.

Closing and re-opening queues with queue control plans
Queue control plans specify additional conditions under which a queue is automatically closed and
re-opened.
For example, if customers in queue are experiencing exceptionally high wait times, an administrator
might want that queue automatically closed. This prevents additional calls from reaching the queue
and prevents new callers from experiencing long wait times.
Each queue control plan monitors one queue and, based on the conditions specified, can close and
re-open the queue being monitored, a Directory Number, or an alternate queue. Only one queue
control plan can be applied to a queue, but a single queue control plan can be applied to multiple
queues.
Closing and re-opening queues with queue control plans requires you to
l

Add a queue control plan to YourSite Explorer

l

Specify conditions for closing queues

l

Specify how long conditions must be present until the queue is re-opened

l

Specify Monitor Settings

l

Associate the control plan to a queue

Optionally, you can
l

Remove a queue control plan from a queue

l

Delete the queue control plan
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To add a queue control plan to YourSite Explorer
1. Click YourSite=>Enterprise.
2. Select Queue Control Plans, click Add, and type a Name for the queue control plan.
3. Click Save.
Follow the steps under 'To specify conditions for placing the queue in DND', below.
To specify conditions for placing the queue in DND
1. Under Queue Condition Builder, click Add.
2. Under Name, select a criterion from the drop-down list.
For example, ‘Longest Wait Time’.
3. Select an Operator.
For example, 'GreaterThan'.
4. Specify a Value, or select a value from the drop-down list.
For example, ‘0:30:00’ (30 minutes).
5. To join conditions, select a Join Type, click Add, and repeat the steps above.
NOTE: 'And' means that all conditions must be met for the queue to go into DND. 'Or' means
that only one of the conditions must be met for the queue to go into DND.
6. Click Save.
Follow the steps under 'To specify how long conditions are present until the queue is reopened', below.
To specify how long conditions are present until the queue is re-opened
1. After Place the device in DND when the following conditions are true (sec), type the
number of seconds the queue conditions must be met before the queue enters DND.
For example, once the longest wait time has hit more than 30 minutes for 60 seconds, the
queue closes.
2. After Remove the device from DND when the following conditions are false (sec), type
the number of seconds the queue conditions must be absent before the queue is re-opened.
For example, once the longest wait time drops below 30 minutes for at least 120 seconds, the
queue re-opens.
3. Click Save.
Follow the steps under 'To specify Monitor Settings', below.
To specify Monitor Settings
NOTE: This configuration requires you to select the queue being monitored for the queue control plan
conditions. You then specify the queue or Directory Number upon which action is taken once the
monitored queue meets the specified conditions.
1. After Monitor, click the Browse button, select a queue to monitor and click OK.
2. Specify whether action will be taken on the Current Queue.
The ‘Current Queue’ is the queue to which the plan is assigned. See 'To associate a control
plan to a queue', below.
3. Alternatively, specify whether action will be taken on a Directory Number.
4. Alternatively, for action to be taken on an Alternate queue, click the Browse button, select
the queue, and click OK.
5. Click Save.
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To associate a control plan to a queue
1. Click YourSite=>Queues.
2. Select the queue and click the Interactive queue control tab.
3. Select This queue uses Interactive Contact Center queue control.
4. After Interactive Contact Center queue control plan, click the Browse button.
5. Select a queue control plan and click OK.
6. Click Save.
To remove a queue control plan from a queue
1. Click YourSite=>Queues.
2. Select the queue and click the Interactive queue control tab.
3. After Interactive Contact Center queue control plan, click the Clear button.
4. Click Save.
To delete a queue control plan
1. Click YourSite=>Enterprise=>Queue Control Plan.
2. Select the queue control plan and click Delete.
3. When prompted, click OK.
4. Click Save.

Adding queue groups
Administrators can group queues for common purposes. There are three kinds of queue groups
available:
l

l

l

Reporting—groups queues together for reporting and viewing their activities in real-time
NOTE: Ring group queues can only be part of reporting queue groups. Ring groups can be
grouped with non-ring group queues.
Mitel Virtual—groups queues across telephone systems that load balance ACD calls
between multiple queues
Unified Queue Group—groups queues of different media types that handle contacts for the
same service group in a contact center. For more information, see the Multimedia Contact
Center Installation and Deployment Guide.

Adding Reporting queue groups
Reporting queue groups enable administrators to run reports on activities for the grouped queues and
view queue group activities in real-time. Both voice queues and ring groups can be added to the
same queue group, but ACD queue statistics that do not apply to ring groups will display as 0 in realtime monitors and reporting. For more information, see "Viewing queue statistics" on page 230.
The following procedures explain how to:
l

Add a Reporting queue group

l

Associate a queue to a Reporting queue group

l

Remove a queue from a Reporting queue group
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To add a Reporting queue group
1. Click YourSite=>Queue groups.
2. Click Add=>Reporting.
3. Type a Name.
4. Type a Reporting number.
5. Click Save.
To associate a queue to a Reporting queue group
1. Click YourSite=>Queue groups.
2. Select a Reporting queue group from the list.
3. On the Membership tab, under Available members, select a queue and click > to move the
queue to the Selected members list.
4. Click Save.
To remove a queue from a Reporting queue group
1. Click YourSite=>Queue groups.
2. Select a Reporting queue group from the list.
3. On the Membership tab, under Selected members, select a queue and click < to move the
queue to the Available members list.
4. Click Save.

Adding Virtual queue groups
Virtual queue groups are comprised of two or more queues across one or more telephone systems
that all send ACD voice contacts to the same pool of agent groups, balancing loads across queues.
Queues within a Virtual queue group must have the same reporting numbers, the same agent groups,
and different dialable numbers. For example, in Figure 15 below, the virtual queue group is made
from two queues on two different telephone systems:
l

l
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Figure 15: Virtual queue group
Virtual queue groups provide the ability to merge multiple queues into a single visual representation
in Interactive Visual Queue and provide callers with an accurate position in queue through the
Updated Position in Queue service.
If you are licensed for IVR Routing, virtual queue groups can be used to provide resiliency paths for
activities such as Transfer.
NOTE:
l

l

Although Virtual queue groups are added and configured under Queue Groups in YourSite
Explorer, a virtual queue group is treated as a singular entity.
Ring groups are not supported for virtual queue groups.

The following procedures explain how to:
l

Add a Virtual queue group

l

Associate queues to a Virtual queue group

l

Remove queues from a Virtual queue group

l

Create a virtual queue group using the Virtual Queue Group button

To add a Virtual queue group
1. Click YourSite=>Queue groups.
2. Click Add=>Mitel Virtual.
3. Type a Name.
4. Type a Reporting number.
5. Click Save.
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To associate queues to a Virtual queue group
1. Click YourSite=>Queue groups.
2. Select a Virtual queue group from the list.
3. On the Membership tab, under Available members, select a queue and click > to move the
queue to the Selected members list.
Repeat as necessary.
4. Click Save.
To remove queues from a Virtual queue group
1. Click YourSite=>Queue groups.
2. Select a Virtual queue group from the list.
3. On the Membership tab, under Selected members, select a queue and click < to move the
queue to the Available members list.
Repeat as necessary.
4. Click Save.
To create a virtual queue group using the Virtual queue group button
1. Click YourSite=>Queues.
2. Select the queues you want to be part of the Virtual queue group
NOTE: Queues must be identically configured, with the exception of media servers and
dialable numbers.
3. In the ribbon, click Queue Tools.
4. Click Create virtual queue group.
5. After Name, enter the name for the virtual queue group
6. If you want to change the reporting number of the virtual queue group, after Reporting
number, enter the reporting number
By default, the reporting number will be the same as the member queues.
7. Click Save.

Adding extensions
When you perform Synchronization, YourSite Explorer is configured to mirror the phone set
extension numbers/base directory numbers (DNs) on the 3300 ICP. If you have traditional agents
that can sit at multiple locations within your organization, hot desking agents, or general business
hot desking extensions, we recommend you give these base extensions generic names based on
the position of the physical DNs (for example, Base DN: Floor 2, Desk 1). We recommend only
general business hot desking extensions assigned to specific hot desking users be given user-based
names (for example, Hot desking extension: John, Smith). If you have traditional ACD agents who
sit at the same desk every day, or traditional extension phone sets that belong to single users, we
recommend that the base DNs be configured with the user's names.
NOTE: Agents are programmed in YourSite Explorer. If agents are in a clustered environment but not
hot desking and not resilient, the agent names will not display on the telephone switch.
In order to provide Contact Center Work Timer functionality in Contact Center Client, every
traditional agent’s extension or every hot desking Agent ID must be enabled with a MiTAI monitor.
If your agents handle calls for multiple voice queues, you can add additional agent login IDs.

158

YourSite database configuration

When read/write is enabled on a media server, changes made to extensions may be written back to
the media server depending on the type of extension being changed. Changes made by adding or
deleting the following extension types are written back to the media server:
l

App server port

l

Hot desk user

l

Outbound port 5020 IP

l

Messaging port 5020 IP

l

RAD port 5020 IP

l

UPiQ port 5020 IP

l

Voice softphone

Changes made by adding or deleting the following extension types are not written back to the media
server:
l

Attendant console

l

Auto-attendant

l

Voice

l

Voice mail

For extensions that already exist on the media server, edits to any extension type in YourSite
Explorer will update the Name and Class of Service of that extension on the media server.
For information about enabling read/write on the media server, see "Enabling write-back
functionality" on page 89.
NOTE:
l

l

l

All voice softphone extensions created in YourSite Explorer have the MCD setting ‘ACD
Enabled’ applied when written back to the telephone system. Extensions enabled for
ACD can be made a member of a ring group, but are unable to make themselves present in
ring groups. If an extension is to be used in a ring group, use MCD to clear the ‘ACD Enabled’
setting. For more information, consult your Mitel Communications Director documentation.
For information on configuring extensions for IVR Routing, see "Configuring extensions" on
page 512.
Workgroup Edition does not support Failover media servers.

The following procedures explain how to:
l

Add an extension

l

Enable a Hot Desk User for external hot desking

To add an extension
1. Click YourSite=>Extensions.
2. Click Add.
3. After Name, enter a name for the extension.
4. After Reporting/Dialable number, enter the extension’s dialable number.
5. After Media server, click the Browse button.
6. Select a media server and click OK.
7. After Failover media server, click the Browse button.
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8. Click OK.
9. Select the Class of Service for the media server, from the drop-down list.
10. After Notes, enter any other information for administrators about the extension.
11. Select the Disable real-time monitoring and data collection on this device check box if
you do not want to enable the extension to be set with a MiTAI monitor, viewed in Contact
Center Client, and use Contact Center Softphone or Salesforce.com Connector.
By default, this check box is not selected.
12. To license this extension, select License this Extension check box.
Unlicensed extensions will not be updated in Contact Center Client real-time monitors.
Unlicensed extensions cannot be reported on and cannot be costed with Business Reporter.
13. Click Save.
To enable a Hot Desk User for external hot desking
1. Click YourSite=>Extension.
2. Select a Hot Desk User extension and select External hot desk user enabled.
Extensions that are enabled as external hot desk users can handle non-ACD calls while
logged in externally.
3. After External dialing prefix, type the dialing prefix for the external device to which calls will
be routed.
4. After External dialing number, type the dialing number for the external device to which calls
will be routed.
5. Click Save.

Adding extension groups
After adding extensions, you add extension groups and associate extensions with these groups.
To add an extension group
1. In YourSite Explorer, in the left pane, click YourSite.
2. Under Devices, click Extension groups.
3. Click Add.
4. Type a Name and a Reporting number for the extension group.
5. On the ribbon, click Save.

Associating extensions with extension groups
To associate an extension with an extension group
1. In YourSite Explorer, in the left pane, click YourSite.
2. Under Devices, click Extension groups.
3. Select an extension group from the list.
4. On the Membership tab, under Available members, select an extension and click > to move
the extension to the Selected members list.
5. On the ribbon, click Save.
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Adding trunks
NOTE:
l

l

If you want to report on SMDR information for SIP trunks you must ensure your SMDR tag is
numbered. Please see the Contact Center Management Installation Guide.
We recommend you name trunks and trunk groups in a way that helps you identify them as
either SIP or TDM trunks, enabling the trunk type to be easily identified in reports.

To add a trunk
1. In YourSite Explorer, in the left pane, click YourSite.
2. Under Devices, click Trunks.
3. Click Add.
4. Type a Name and a Reporting number for the trunk.
5. Click the Browse button and select a Media server to associate with the trunk.
6. On the ribbon, click Save.

Adding trunk groups
You add trunk groups and then associate trunks with the trunk groups.
NOTE:
l

l

If you have Traffic Analysis and/or Business Reporter and use the same trunk group numbers
across multiple telephone systems, you must associate each trunk group with a media server.
We recommend you name trunks and trunk groups in a way that helps you identify them as
either SIP or TDM trunks, enabling the trunk type to be easily identified in reports.

If you have Traffic Analysis and/or Business Reporter and use the same trunk group numbers across
multiple telephone systems, you must associate each trunk group with a media server.
To add a trunk group
1. In YourSite Explorer, in the left pane, click YourSite.
2. Under Devices, click Trunk groups.
3. Click Add.
4. Type a Name and a Reporting number for the trunk group.
5. Click ... and select a Media server to associate with the trunk group.
6. On the ribbon, click Save.

Associating trunks with trunk groups
To associate a trunk with a trunk group
1. In YourSite Explorer, in the left pane, click YourSite.
2. Under Devices, click Trunk groups.
3. Select a trunk group from the list.
4. On the Membership tab, under Available members, select a trunk and click > to move the
trunk to the Selected members list.
5. On the ribbon, click Save.
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Adding DNIS
Dialed Number Identification Service (DNIS) is a feature of toll-free lines that identifies the telephone
number the caller dials. This assists agents who handle calls for more than one business or product
line. Each business or product line has its own toll-free number. When a caller dials a toll-free
number, the telephone system forwards information to the agent allowing the agent to identify who
the caller dialed. For example, a caller dials a toll-free number for a cruise line. The telephone system
sends a script to the agent along with the call. The agent then knows to answer 'Good morning.
Thank you for calling Southern Cruises', instead of the name of another cruise line serviced by the
center.
To add a DNIS
1. In YourSite Explorer, in the left pane, click YourSite.
2. Under Devices, click DNIS.
3. Click Add.
4. Specify DNIS identification information and click the Browse button to select the media
server for the DNIS.
5. After Short Abandon, type the duration for the call abandon parameter. If the abandon time is
less than the call abandon parameter, then the call is a short abandon call and is not included
in the call statistics (for example, type 5 to define a short abandon call as a call that lasts less
than 5 seconds).
6. After Service Level, type the Service Level time.
7. If you have Business Reporter, select a carrier plan, call type, and call rate.
8. On the ribbon, click Save.

Adding DNIS groups
After adding DNIS, you can create DNIS groups and then associate DNIS numbers for specific
businesses or product lines to those groups.
To add a DNIS group
1. In YourSite Explorer, in the left pane, click YourSite.
2. Under Devices, click DNIS groups.
3. Click Add.
4. Type a Name and a Reporting number for the DNIS group.
5. On the ribbon, click Save.

Associating DNIS to DNIS groups
To associate a DNIS with a DNIS group
1. In YourSite Explorer, in the left pane, click YourSite.
2. Under Devices, click DNIS groups.
3. Select a DNIS group from the list.
4. On the Membership tab, under Available members, select a DNIS and click > to move the
DNIS to the Selected members list.
5. On the ribbon, click Save.
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Adding Account Codes
Account Codes can be verified, non-verified, or forced.
l

l

Verified and Non-Verified Account Codes
Verified and Non-Verified Account Codes allow callers to complete a call without entering a
code. These codes are used to categorize calls or portions of calls. You define Account
Codes in the YourSite database to generate reports for specific departments, services, and
companies. For example, an agent who receives calls for three catalog companies enters
Account Code 01 for calls to company X, Account Code 02 for calls to company Y, and
Account Code 03 for calls to company Z. When you configure the Account Codes, Contact
Center Management generates reports on the number, origin, and handling of calls for each of
the departments, services, or companies.
Forced Account Codes
Both Verified and Non-Verified Account Codes can be forced. With Forced Verified Account
Codes, you must enter the Account Code as soon as the phone is off-hook. With Forced NonVerified Account Codes, you must enter the Account Code after you dial the phone number.
For example, you might have 03 programmed on the telephone system as the trunk access
code for calling England. Before you make a call to England, you must preface the telephone
number with the Account Code 03, otherwise the call will not go through. To report on these
verified Account Codes, you define them in the YourSite database.

NOTE:
l

l

If you will used Forced Account Codes and have a Make Busy button programmed on your
Mitel phone set, you must remove the Make Busy button, or Forced Account Codes will not
work with Interactive Contact Center and Contact Center PhoneSet Manager.
If a Forced Verified Account Code is not entered in before Work Timer expires, then a -1 Non
Compliant Code will be automatically assigned to the call.

You can add Account Codes for individual departments, projects, and services and generate reports
on them. Agents can tag incoming calls or multimedia contacts with Account Codes for various
services. Account Codes not associated to a specific employee can be used by all employees when
handling contacts.
Agents who work for companies that use Business Reporter can use Account Codes to gain access
to outside lines (see "Assigning non-ACD extensions and Account Codes for employees" on page
133).
If you are adding Account Codes to be used by voice agents, you print a copy of your telephone
system assignment forms to use as a guide for programming. If you are adding Account Codes to be
used by email and chat agents, you enter Account Code reporting numbers of your choice.
You can label Account Codes as call classification codes. This option associates the entire handling
time to calls of this Account Code type. This option is available for contact centers that have the
3300 ICP only.
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To add an Account Code
1. In YourSite Explorer, in the left pane, click YourSite.
2. Under Devices, click Account Codes.
3. Click Add.
4. Type a Name and Reporting number for the Account Code.
5. If the Account Code will be used as a call classification code, select the Use as
Classification Code check box.
NOTE:
l

l

When the 'Use as Classification Code' check box is selected, the Account Code
duration spans from the time the call arrives until the call ends. When you deselect the
'Use as Classification Code' check box, the Account Code duration spans from the
time the code was entered until the next code is entered or the call ends.
As a best practice, we recommend you name all call classification codes for easy
identification or group call classification codes in Account Code groups.

6. On the ribbon, click Save.

Adding Account Code groups
You can create Account Code groups to group similar Account Codes or to differentiate traditional
Account Codes and call classification codes. Agents can readily identify and select appropriate
Account Codes using the soft phone or Interactive Contact Center and supervisors can report on
Account Code groups.
To add an Account Code group
1. In YourSite Explorer, in the left pane, click YourSite.
2. Under Devices, click Account Code Groups.
3. Click Add.
4. Type a Name and Reporting number for the Account Code group.
5. On the ribbon, click Save.

Associating Account Codes with Account Code groups
To associate an Account Code with an Account Code group
1. In YourSite Explorer, in the left pane, click YourSite.
2. Under Devices, click Account Code groups.
3. Select an Account Code group from the list.
4. On the Membership tab, under Available members, select an Account Code and click > to
move the Account Code to the Selected members list.
5. On the ribbon, click Save.
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Adding Account Code categories
In businesses that use a large number of Account Codes, Account Code categories can be used to
provide a hierarchical and grouped listing of the Account Codes available to agents and employees
from the soft phone toolbar within Contact Center Client. You configure Account Code categories
from within YourSite Explorer. Once you have configured Account Codes, they can be nested under
specific Account Code categories. An Account Code can only be in one category. Call Classification
Codes, which are treated the same way as Account Codes, can optionally be nested in Account
Code categories. Account Code category availability to agents and employees can optionally be
controlled using Contact Center Management / Business Reporter security. When Account Code
categories are enabled, Contact Center Management / Business Reporter reports will display the
Account Code category path (for example, Sales=>Automotive=>Tires).
To enable Account Code categories
1. In YourSite Explorer, in the left pane, click YourSite.
2. Under Devices, click Account Codes.
3. In the ribbon, click the Configuration tab.
4. Enable the Display Account Codes in categories checkbox.
To add an Account Code category
1. In YourSite Explorer, in the left pane, click YourSite.
2. Under Devices, click Account Codes.
3. In the ribbon, click the Configuration tab.
4. Ensure the Display Account Codes in categories checkbox is enabled.
5. Click Edit categories.
The Account Code category designer displays.
6. Using the Account Code category designer, add and name Account Code categories in the
left pane and then add the Account Codes you have configured, which display in the left pane)
to the custom categories.
Account Code categories are sorted by category name and Account Code reporting number.
Account Code categories will display in soft phone toolbars exactly as you have designed
them in the Account Code category designer. If you have Account Code categories enabled,
but do not assign Account Codes to categories, leaving them in the right pane of the designer,
these Account Codes will not be available in the soft phone toolbar.

Defining ANI data
Defining ANI data enables Contact Center Solutions to gather information on area codes and
geographic regions for incoming calls. ANI data can be given to agents in screen pops, used to route
calls to appropriate endpoints, or used in reporting.
NOTE: ANI you want reported on for accounting purposes in Business Reporter should be added as
phone numbers as well. For more information on phone numbers, see "Adding phone numbers" on
page 167.
The following procedures explain how to
l

Define ANI data

l

Delete ANI data
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To define ANI data
1. Click YourSite and, under Devices, click ANI=>Add.
2. After Name, type the geographical region to which the area code corresponds.
3. After ANI, type the area code for the geographical region.
4. To import ANI data from a .csv file, click Import and follow the steps under "Importing a range
of devices using a .csv file" on page 119.
5. Click Save.
To delete ANI data
1. Click YourSite=>Devices=>ANI.
2. Select the ANI and click Delete.
3. When prompted, click OK.
4. Click Save.

Adding Make Busy Reason Codes
Voice agents can place themselves in Make Busy using their phone sets, provided the Make Busy
with Reason option is enabled on the telephone system. Using Interactive Contact Center, agents
can place themselves in Make Busy with reason in Contact Center Client, and supervisors can
place agents in Make Busy with reason in Contact Center Client. Agents enter Make Busy Reason
Codes to indicate why they are placing themselves in Make Busy and not answering contacts.
If you have Interactive Contact Center or Multimedia Contact Center, you assign Make Busy
Reason Codes the reporting numbers of your choice. Otherwise, you type Make Busy Reason Code
reporting numbers listed on the telephone system assignment forms.
Four Make Busy Reason Codes are configured by default with Contact Center Management and
cannot be deleted from YourSite Explorer:
The -1 Make Busy Reason Code is allocated by the Enterprise server when calls or multimedia
contacts are requeued.
The -2 Make Busy Reason Code is allocated when hot desking agents are in a non-ACD call or are
off hook. This Code applies to voice only.
The -3 Make Busy Reason Code is allocated when agents are in Work Timer. This Code is
specifically allocated for configurations that use Queue Work Timer instead of the default Class of
Service Work Timer.
NOTE: The -3 Make Busy Reason Code is no longer used in Version 7.1. However, the Code
remains in the system in order to summarize Version 6.x data in reporting.
The -4 Make Busy Reason Code is allocated when agents reach their Workload maximum for a
media type. For more information on Workload, see "Adding employee Workload" on page 127.
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To add a Make Busy Reason Code
1. Click YourSite and, under Devices, click Make Busy Reasons.
2. Click Add.
3. Type a Name and Reporting number for the Make Busy Reason Code.
NOTE: You can program custom Make Busy Reason Codes using any digit between 1-9.
Make Busy Reason Code 0 is reserved for telephone system Make Busy.
4. Click Save.

Adding Do Not Disturb Reason Codes
Interactive Contact Center, an optional application, enables supervisors who have a 3300 ICP
telephone system to control the availability of agents and ACD queues. Likewise, agents can control
their own availability, including placing themselves in or removing themselves from Do Not Disturb.
There are many reasons why agents place themselves in Do Not Disturb.
To add a Do Not Disturb Reason Code
1. Click YourSite and, under Devices, click Make Busy Reasons.
2. Click Add.
3. Type a Name and Reporting number for the Do Not Disturb Reason Code.
4. Click Save.

Adding phone numbers
Phone numbers are used for running reports in Business Reporter. The phone number device
enables you to
l

Add area codes/city codes, city exchange information, and contacts.

l

Edit location information that displays in reports.

NOTE: Area codes you want to use in Contact Center Solutions to provide data to agents, route
calls to appropriate end points, and use to report on contact center functions should be added as
ANI. For more information on ANI, see "Adding phone numbers" on page 167.
When adding a phone number to the database, you select
l

l

l

Area/City code when you are adding or updating the area code for a province/state/city
For the phone number 613-599-0045, 613 is the area code.
City exchange when you are adding a new exchange
For the phone number 613-599-0045, 599 is the city exchange (Kanata).
Contact when you are adding a phone number with contact information
For the phone number 613-599-0045, 5990045 is the contact.

To add a phone number area/city code
1. In YourSite Explorer, in the left pane, click YourSite.
2. Under Devices, click Phone numbers.
3. Click Add=>Add an area/city code.
4. Select a country and type an area/city name and area code.
An area can be a city, region, province, or state.
5. On the ribbon, click Save.
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To add city exchange information
1. In YourSite Explorer, in the left pane, click YourSite.
2. Under Devices, click Phone numbers.
3. Click Add=>Add a city exchange.
4. After Country, select a country.
5. After Area/City name, select a city, region, province, or state (for example, Greater Toronto
Area).
6. After City name, type the name of a city or suburb (for example, Thornhill).
7. After City/Exchange, type a city exchange number (for example, 231).
For the phone number 416-231-5555, 231 is the city exchange.
8. On the ribbon, click Save.
To add phone number contact information
1. In YourSite Explorer, in the left pane, click YourSite.
2. Under Devices, click Phone numbers.
3. Click Add=>Add a contact.
4. After Country, select a country.
5. After Area/City name, select a city, region, province, or state (for example, Washington).
6. After City name, select a city or suburb (for example, Des Moines).
7. Type a contact name and number.
This information displays in the Phone Number Accounting Trace and Phone Number Group
Accounting Trace reports.
8. If you want to hide the contact name and number in reports select the Hide the name and
number in reports check box.
9. On the ribbon, click Save.

Adding phone number groups
You can associate Phone numbers with Phone number groups. Phone number groups are added in
YourSite Explorer and then Phone numbers are associated with them.
To add a Phone number group
1. In YourSite Explorer, in the left pane, click YourSite.
2. Under Devices, click Phone number groups.
3. Click Add.
4. Type a Name and Reporting number for the Phone number group.
5. On the ribbon, click Save.
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To associate a Phone number with a Phone number group
1. In YourSite Explorer, in the left pane, click YourSite.
2. Under Devices, click Phone number groups.
3. Select a phone number group from the list.
4. On the Membership tab, under Available members, select a Phone number and click > to
move the Phone number to the Selected members list.
5. On the ribbon, click Save.

CONFIGURING EMPLOYEE SCHEDULING
PREFERENCES
Schedule Builder uses employee preferences/options as parameters when scheduling employees.
You must configure employee scheduling preferences accurately in YourSite Explorer to create a
meaningful schedule.
To configure employee information for scheduling
1. Select the employee or employees you want to configure.
2. Specify the employee role.
See "Configuring employee roles" on page 169.
3. Specify employee work hours.
See "Configuring employee work hours" on page 170.
4. Specify employment status.
See "Configuring employment status" on page 170.
5. Specify employee payroll information.
See "Configuring employee payroll information" on page 170.
6. Specify employee availability.
See "Configuring employee availability" on page 171.
7. Specify time off information.
See "Configuring employee time off" on page 171.
8. Specify employee skills .
See "Configuring employee skills" on page 172.

CONFIGURING EMPLOYEE ROLES
To configure an employee role
1. In YourSite Explorer, in the left pane, click YourSite.
2. Under Devices, click Employees.
3. Select the employee to which you will add an employee role.
4. On the Workforce Scheduling tab, click General.
5. If the employee is a supervisor who will schedule employees, select the Is a supervisor of
scheduled employees check box.
6. After Schedule supervisor name, select the name of the scheduling supervisor from the list.
7. On the ribbon, click Save.
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CONFIGURING EMPLOYEE WORK HOURS
To configure employee work hours
1. In YourSite Explorer, in the left pane, click Workforce Scheduling.
2. Click Employees.
3. Select an employee.
4. On the Workforce Scheduling tab, click Work hours.
5. Enter the minimum and maximum number of hours the employee can work in a day, week, or
year.
6. If you want to schedule the employee for an unlimited number of hours, click Unlimited.
7. After Minimum time required between shifts, enter the minimum number of hours required
between the employee's shifts.
NOTE: Ensure you set a minimum time between shifts or Schedule Builder will schedule
back-to-back shifts for employees.
8. If the employee is permitted to work overtime, under Available, select an overtime type from
the list and click > to move the overtime type to the Assigned list.
9. On the ribbon, click Save.

CONFIGURING EMPLOYMENT STATUS
To configure employment status
1. In YourSite Explorer, in the left pane, click Workforce Scheduling.
2. Click Employees.
3. Select an employee.
4. On the Workforce Scheduling tab, click Payroll.
5. If the selected employee is full-time, under Employment status, select Full time.
6. If the selected employee is part-time, under Employment status, select Part time.
7. On the ribbon, click Save.

CONFIGURING EMPLOYEE PAYROLL INFORMATION
NOTE: If you want to schedule employees by seniority, the employee must be assigned a hire date.
To configure employee payroll information
1. In YourSite Explorer, in the left pane, click Workforce Scheduling.
2. Click Employees.
3. Select an employee.
4. On the Workforce Scheduling tab, click Payroll.
5. Under Salary, after Pay period, select the pay period for the employee.
6. If the employee is paid an hourly salary, next to Hourly salary, specify the employee's pay
per hour.
7. If the employee is paid a yearly salary, next to Yearly salary, specify the employee's yearly
salary and the typical number of hours the employee works in a week.
8. On the ribbon, click Save.

170

Configuring employee scheduling preferences

CONFIGURING EMPLOYEE AVAILABILITY
NOTE: If you do not specify availability, Schedule Builder assumes the employees are available 24
hours a day, seven days a week.
To configure employee availability
1. In YourSite Explorer, in the left pane, click Workforce Scheduling.
2. Click Employees.
3. Select an employee.
4. On the Workforce Scheduling tab, click Availability.
5. Select the Uses availability check box.
6. Under New Availability, after Work day, select the day of the week the employee availability
applies to from the list.
7. If the employee is available only during certain hours of the day, select Part of the day and
specify the hours the employee is available.
8. If the employee is available all day, select Full day.
9. Click Add availability.
10. On the ribbon, click Save.

CONFIGURING EMPLOYEE TIME OFF
To configure employee time off
1. In YourSite Explorer, in the left pane, click Workforce Scheduling.
2. Click Employees.
3. Select an employee.
4. On the Workforce Scheduling tab, click Time off.
5. If the employee's time off is carried over based on their start date, under Carryover date,
select Employee start date.
6. If the employee's time off is carried over based on a fixed date, under Carryover date, select
Fixed date and specify the carryover date.
7. If the employee is permitted time off, under Available, select the time off type from the list
and click > to move the time off type to the Assigned list.
8. On the ribbon, click Save.

OVERRIDING EMPLOYEE TIME OFF
To override an employee time off type
1. In YourSite Explorer, in the left pane, click Workforce Scheduling.
2. Click Employees.
3. Select an employee.
4. On the Workforce Scheduling tab, click Time off.
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5. Under Assigned time off, select a time off type to override.
6. If you want to override the total number of time off hours allowed, select the Override total
hours allowed check box and specify the number of hours.
7. If you want to override a percent of time off hours based on time worked, select the Override
% of hours worked check box and specify the number of hours.
8. If you want to override the number of hours that can be carried over, select the Override
allowed carry over and specify the number of hours.
9. If you want to override the time off hours available to the employee, after Available as of,
specify the date after which the time off hours are available and number of hours that will be
available.
10. On the ribbon, click Save.

CONFIGURING EMPLOYEE SKILLS
NOTE: If you have selected multiple employees to edit, skills that are not available to these
employees are grayed out and cannot be assigned.
To configure employee skills
1. In YourSite Explorer, in the left pane, click Workforce Scheduling.
2. Click Employees.
3. Select an employee.
4. On the Workforce Scheduling tab, click Skills.
5. After Name, type the name of the subscriber.
6. Under Available, select the skill type from the list and click > to move the skill type to the
Assigned list.
7. Repeat step 5 for all skills the employee will use.
8. On the ribbon, click Save.

CONFIGURING SCHEDULING OPTIONS
Before you can make schedules in Workforce Scheduling, you must configure the following
scheduling options in YourSite Explorer
l

l

l

l

l
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Employees
See "Adding employees" on page 121.
Holidays
See "Configuring holidays" on page 173.
Overtime types
See "Configuring overtime types" on page 173.
Time off types
See "Configuring time off types" on page 174.
Skills
See "Configuring skills" on page 175.

Configuring scheduling options

CONFIGURING HOLIDAYS
You configure holiday options on the Holidays window. You can add holidays that affect your contact
center, specify which holidays give employees the day off, and specify which holidays are paid.
To configure a holiday
1. In YourSite Explorer, in the left pane, click Workforce Scheduling.
2. Click Holidays.
3. Click Add.
4. After Name, type the name of the holiday.
5. If this holiday is a company holiday and you want to receive warnings when trying to schedule
employees for this day, select the This holiday is a company holiday check box.
6. Specify the pattern of the holiday.
l

l

l

If the holiday always falls on the same day of the month, select Every and specify the
month and date the holiday falls on.
If the holiday has a pattern of falling on a certain day, week, and month, select The and
specify the pattern, day of week, and month.
If the holiday is a calculated holiday, such as Good Friday or Easter Monday, select
Calculated holiday and specify the holiday.

7. On the ribbon, click Save.

CONFIGURING OVERTIME TYPES
You can configure the following overtime parameters:
l

l
l

l

l
l

l

Pay rate multiplier—The number of times by which the basic pay is increased to calculate
the overtime pay rate. For example, if the pay rate multiplier is 1.5 and applied to $10 per hour,
the overtime pay rate is $15 per hour
Color—The color in which the job displays in the time bar pane
Hours worked in a given day are greater than—The number of hours in a day an employee
must work before the employee is paid at the overtime pay rate
Hours worked in a given week are greater than—The number of hours in a week an
employee must work before the employee is paid at the overtime pay rate
Days of the week worked—Any work done on these days will be considered overtime pay
Day of the year worked—Any work done on this specific date will be considered overtime
pay
Holiday worked—Any work done on this specific holiday will be considered overtime pay

To configure an overtime type
1. In YourSite Explorer, in the left pane, click Workforce Scheduling.
2. Click Overtime.
3. Click Add.
4. After Name, type the name of the overtime type.
5. Under Effects, enter a pay rate modifier and select a color for the overtime type.
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6. Under Conditions, select either Hours worked, Days of the week worked, Days of the
year worked, or Holiday worked.
l

l

l

l

If you select Hours worked, you must select either Hours worked on a given day are
greater than or Hours worked on a given week are greater than and specify the number
of hours.
If you select Days of the week worked, select the days of the week to which this
overtime type applies.
If you select Days of the year worked, select the days of the year to which this overtime
type applies.
If you select Holiday worked, select the holiday to which this overtime type applies.

7. On the ribbon, click Save.

CONFIGURING TIME OFF TYPES
Employees might take time off work for a variety of reasons. Depending on the nature of time taken
off, employees might be paid, employees might be required to take a full day as time off, and
employees might accrue time off (for example, vacation).
Create time off types that reflect the time off that employees take at your contact center.
l

l

Consider if the type of time off should accrue, such as vacation, time off for a medical
procedure, or personal days.
Consider when the time off is accrued. For example, an employee might accrue 1 day of paid
sick leave per month.

l

Consider if the type of time off must be taken as a full day.

l

Consider if employees must qualify for the type of time off.

l

Consider if employees can carry the time off over to the next year.

Workforce Scheduling can warn you when employees do not qualify for the time off or when the
scheduled time off is not within the limits allowed.
To configure a time off type
1. In YourSite Explorer, in the left pane, click Workforce Scheduling.
2. Click Time off.
3. Click Add.
4. After Name, type the name of the time off type.
5. If employees will be paid for this time off type, under Effects, select the Paid time off check
box and select a color for the time off type.
6. If employees can request this type of time off from Employee Portal, under Effects, select the
Can be requested check box.
7. Under Employment duration qualification, select either the Employed for at least or
Employed no more than check box and specify the number of months.
8. Under Scheduling limitations, select either the You must schedule this type in
increments of at least or You must not schedule this type for more than check box and
specify the number of hours per day/week.
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9. If you want to limit the number of hours this time off type can be scheduled, select the Limit
the number of hours that can be scheduled check box.
l

l

l

l

l

If you want to fix the annual amount of this time off type, select Fixed annual amount
of and specify the number of hours.
If the annual hours of this time off type are accrued, select the Annual hours are
accrued check box and select either Weekly, Biweekly, or Monthly.
If you want to base this time off type on a percent of the number of hours worked, select
Based on hours worked at a rate of and specify a percent.
If you want to carry over a fixed amount of accumulated time off hours, select Percent
of accumulated hours, at a rate of and specify a percent.
If you want to carry over a percent of accumulated time off hours, select Percent of
accumulated hours, at a rate of and specify a percent.

10. On the ribbon, click Save.

CONFIGURING SKILLS
Employees offer a variety of different skills. For example, some employees might be bilingual or
have certification in a specialty. Using Workforce Scheduling, you can incorporate these skills when
you create your schedules.
Configuring the different types of skills allows you to create and manage schedules that incorporate
the skills and skill levels of your employees. When you create schedules, Workforce Scheduling
allows you to schedule employees with specific skill sets.
NOTE: Skill levels range from 1 to 10, level 10 being the highest skill level, or most skilled, and level
1 being the lowest skill level.
To configure a skill
1. In YourSite Explorer, in the left pane, click Workforce Scheduling.
2. Click Skills.
3. Click Add.
4. After Name, type a name for the skill.
5. On the ribbon, click Save.

BUSINESS HOUR SCHEDULES
Your contact center software performs certain tasks during business hours and other tasks after
business hours. You create schedules so that Contact Center Management knows your business'
hours of operation, and so you can apply these hours of operation to devices. You can create yearly
or seasonal schedules.
For example, Multimedia Contact Center can send ‘business hour’ auto-response messages to
customers contacting you during business hours, and ‘after hours’ auto-response messages to
customers contacting you after hours. Applying a schedule to a Multimedia Contact Center workflow
tells the system when to send each type of message.
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Contact Center Management ships with two default schedules: The default 24/7 schedule for
businesses that operate 24 hours a day, seven days a week, and the default Monday to Friday 9:00
AM to 5:00 PM schedule. You can modify these schedules according to your business needs. You
can also create schedule exclusion lists, which enable you to omit days such as national holidays
from schedules. See "Managing schedule exclusion lists" on page 177.
The following procedures tell you how to
l

Create and modify schedules

l

Manage schedule exclusion lists

CREATING AND MODIFYING SCHEDULES
The schedules you create do not expire. The weekly schedule configuration applies week after week
until you change the schedule or apply a different schedule to the device. You can exclude specific
dates from the schedule for national holidays.
To create a schedule
1. Select YourSite=>Schedules.
2. Click Add.
3. After Name, a descriptive name for the schedule.
4. To apply a schedule exclusion list, click the Browse button.
5. Select an exclusion list to apply and click OK.
NOTE: The Schedule exclusion list specifies days to be omitted from the schedule. To create
a schedule exclusion list, or to edit an existing schedule exclusion list, see "Managing
schedule exclusion lists" on page 177.
6. After Start time, type the business day start time for each day of the week.
7. After End time, type the business day end time for each day of the week.
8. After Disable for day, select the check box for each day your business is closed.
9. Click Save.
To modify a schedule
1. Select YourSite=>Schedules.
2. Select the schedule to modify.
3. After Name, type a new name for the schedule. For example, ‘Monday to Friday 8:00 AM to
6:00 PM’.
4. After Schedule exclusion list, click the Browse button.
5. Select a schedule exclusion list to apply to the schedule and click OK.
NOTE: The Schedule exclusion list specifies days to be omitted from the schedule. To create
a schedule exclusion list, or to edit an existing schedule exclusion list, see "Managing
schedule exclusion lists" on page 177.
6. After Start time, type the new business day start time for each day of the week.
7. After End time, type the new business day end time for each day of the week.
8. After Disable for day, select the check box for day your business is closed.
9. Click Save.
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Managing schedule exclusion lists
Schedule exclusion lists enable you to omit days from schedules you create. For example, you can
use a schedule exclusion list to omit national holidays from a yearly schedule.
The following procedures show you how to
l

Create and apply new exclusion lists to schedules

l

Apply existing exclusion lists to schedules

l

Remove exclusion lists from schedules

l

Edit and remove dates from schedule exclusion lists

l

Delete exclusion lists from YourSite Explorer

NOTE: To edit or delete a list you must first select a schedule with an exclusion list already applied
to it. You can then access schedule exclusion lists, and the buttons for editing and deleting lists, by
clicking ‘Manage schedule exclusion list’.
To create and apply a new exclusion list to a schedule
1. Click YourSite=>Schedules.
2. Click Add.
3. Click Manage schedule exclusion list.
4. After Name, type the name of the exclusion list.
NOTE: To create a new list for a schedule with an exclusion list already applied to it, click
'Add' and follow steps 4 onward.
5. On the calendar, click the dates to exclude from the schedule.
6. Click Save.
7. To apply the exclusion list to the selected schedule, click Apply. Otherwise, close the
schedule exclusion list designer window.
8. Click Save.
To apply an existing exclusion list to a schedule
1. Click YourSite=>Schedules.
2. Select the schedule to which you will apply a schedule exclusion list.
3. After Schedule exclusion list, click the Browse button.
4. Select a schedule exclusion list and click OK.
5. Click Save.
6. Repeat these steps for other schedules to which you will apply the exclusion list.
To remove an exclusion list from a schedule
1. Click YourSite=>Schedules.
2. Select the schedule from which you will remove a schedule exclusion list.
3. After Schedule exclusion list, click the Clear button.
4. Click Save.
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To edit and remove dates from an exclusion list
1. Click YourSite=>Schedules.
2. Select a schedule with an exclusion list applied to it and click Manage schedule exclusion
list.
3. Click Edit.
4. To add new dates, select the dates from the calendar.
5. To remove dates, select the dates from the list and click Remove.
6. To remove all dates, click Clear.
7. Click Save
8. To apply changes to the schedule, click Apply.
To delete an exclusion list from YourSite Explorer
1. Click YourSite=>Schedules.
2. Select a schedule with the exclusion list to delete.
NOTE: If you are deleting exclusion lists as part of clean-up, select any schedule with an
exclusion list applied to it and follow the steps below.
3. Click Manage schedule exclusion list.
4. From the drop-down list, select the exclusion list you want to delete.
5. Click Delete.
6. Click Save.

Applying schedules
You can apply the schedules you create to
l

Media servers— See "Adding media servers" on page 84.

l

Queues— See "Adding queues" on page 142.

l

l
l

l

Workflows, if you are licensed for IVR Routing.
See "Configuring the Schedule activity" on page 615.
Alarms— See "Monitoring and alarming subsystem" on page 178.
WallBoarder sign plan business hour and scheduled messages— See "Creating sign plans"
on page 293.
Interactive Contact Center Queue control— See "Opening and closing queues with business
hour schedules" on page 153.

MONITORING AND ALARMING SUBSYSTEM
Contact Center Solutions uses a centralized alarming system configured in YourSite Explorer. The
Maintenance Alarm Dispatcher service is located on the Enterprise Server and performs server
maintenance activities as well as controlling all alarming in the network. Alarm notifications are sent
for each device that is triggering an alarm and is distributed in the following ways:
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l

l

l
l

Email: Summary emails are sent to valid email subscribers and list all current, active alarm
statuses as well as a list of alarms that triggered the alert.
RSS: An RSS feed is published on the server and can be subscribed to by any RSS reader
that has been given access to the server.
SNMP: A count of alerting alarms for each category can be viewed in an SNMP manager.
Start Page: A list of currently active Contact Center Management alarms with a Knowledge
Base article list of descriptions, severities, impacts on contact centers, and troubleshooting
information can be viewed on the Start Page of YourSite Explorer. (See "YourSite Explorer
Start Page" on page 74.)

By default, alarms are configured to expire after 24 hours.
The Server Monitoring Agent is a standalone service that is deployed on each server in the
enterprise. It monitors performance counter values based on alarm configuration, collects external
alarm data from services, and notifies the prairieFyre Maintenance Alarm Dispatcher service when
alarm states surpass configured thresholds.
Alarms may also be viewed with the Enterprise Status icon and RSS feed link, located in the lowerright corner of the YourSite Explorer and Contact Center Client windows and in the upper-right corner
of CCMWeb. In order to view the Enterprise Status icon and RSS feed link in all of the applications
in which they are present, we recommend you log in as an Administrator.
The Enterprise Status icon is a circular, colored status indicator. The color indicates the highest level
of severity for all alarms currently alerting (Normal = Green, Minor = Yellow, Major = Orange, Critical
= Red, Unknown = Gray). If you subscribe to the RSS feed and your RSS reader is open, you will be
notified with changes to alarm states. If you don’t subscribe to the RSS feed, you can click the RSS
feed link and view active alarms in your default browser.
In addition to receiving notification of alarms, you can quickly view Enterprise status and active
alarms using the YourSite Explorer Start Page’s Alarms tab. The Alarms tab consists of two panes:
the Feed Preview and the Mitel Knowledge Base pane. The Feed Preview contains an RSS feed of
the active alarms. The Mitel Knowledge Base pane contains a table of contents linking to relevant
Knowledge Base (KB) articles for each alarm. Each KB article contains a description of the reason
for the alarm, the severity of the alarm, the impact on contact centers, and troubleshooting steps.
If you have multiple servers and you want to be able to determine which server is emailing an alarm,
you can set up a unique 'From' address for the emails delivered from the Contact Center
Management server in the 'From Name' field of the Outgoing tab in the mail server configuration
window in YourSite Explorer.
Alarms are categorized based on the type of data they analyze. There are three types of alarms:
l

Performance counter and Registered services performance counter alarms: based on
performance counters

l

Media server alarms: independently tracked for each media server

l

General alarms: all other alarms
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The following procedures explain how to
l

Configure Performance counter and Registered services performance counter alarms

l

Configure Media server alarms

l

Configure General alarms

l

Disable or enable alarms

l

Temporarily disable ('Snooze') alarms

These configurations take place in YourSite=>Alarms.
To configure Performance counter and Registered services performance counter alarms
1. Select the Performance counter or Registered services performance counter alarm you
want to configure and click the General tab.
2. To specify an SNMP category in which the alarm displays, after Category, select a category
type from the drop-down list.
3. Set Minor, Major, and Critical thresholds and threshold alert delays for the alarm.
NOTE: Thresholds determine the severity of the alarm when the specified condition is met.
The threshold alert delays determine the how long an alarm state is active before an alarm is
triggered and notification is sent.
4. To disable a threshold, from the drop-down list next to the threshold select Disabled.
5. To be notified when the alarm value changes, select the Realert on value change check
box.
6. Click the Actions tab.
7. To send subscribers emails of alarms when the alarm is triggered, under Email action, select
the Enabled check box.
8. Click Browse and select a Business hours: schedule to apply to the alarm.
9. To receive notifications of critical alarms, outside of business hours, select the Ignore
business hours for critical alerts: check box.
10. Click Save.
To configure Media server alarms
1. Select the Media server alarm you want to configure and click the General tab.
2. To specify an SNMP category in which the alarm displays, after Category, select a category
type from the drop-down list.
3. After Severity, select the level of severity to apply to this alarm (Minor, Major, or Critical).
4. After Alert delay, select how long the alarm state is active before an alarm is triggered and
notification is sent.
5. To disable the alarm for specific media servers, after Disable media servers:, click the …
button, select the media server from the Select disabled media servers window, and click
OK.
6. To clear a disabled media server selection, click Clear.
7. Click the Actions tab.
8. To send subscribers emails of alarms when the alarm is triggered, under Email action, select
the Enabled check box.
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9. Click the Browse button and select a Business hours: schedule to apply to this alarm.
10. To receive notifications of critical alarms, outside of business hours, select the Ignore
business hours for critical alerts: check box.
11. Click Save.
To configure General alarms
1. Select the General alarm you want to configure and click the General tab.
2. To specify an SNMP category in which the alarm displays, after Category, select a category
type from the drop-down list.
3. After Severity, select the level of severity to apply to this alarm (Minor, Major, or Critical).
4. After Alert delay, select how long the alarm state is active before an alarm is triggered and
notification is sent.
5. Click the Actions tab.
6. To send subscribers emails of alarms when the alarm is triggered, under Email action, select
the Enabled check box.
7. Click the Browse button and select a Business hours: schedule to apply to this alarm.
8. To receive notifications of critical alarms, outside of business hours, select the Ignore
business hours for critical alerts check box.
9. Click Save.
To disable or enable an alarm
1. To disable an alarm, select the alarm and click the General tab.
2. Click Disable.
3. Click Save.
4. To re-enable an alarm, select the alarm and click the General tab.
5. Click Enable.
6. Click Save.
To temporarily disable (‘Snooze’) an alarm
1. Select the alarm to disable and select the General tab.
2. Click Snooze and, from the drop-down list, select how long the alarm will be disabled.
3. To customize the snooze duration, from the Snooze drop-down list select Custom… and set
the date and time at which the alarm reactivates.
4. Click Save.

VALIDATING ALARMS
Some alarms require the system to be validated before the alarms will clear. The Validate button
must be clicked after the values have been corrected, otherwise the alarm will not be cleared until
nightly synchronization. The alarm may not clear with nightly synchronization if the value is still
wrong. See "Validating YourSite Explorer configuration" on page 189.
Consult the alarm’s Knowledge Base article for validation information.
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ENABLING SNMP AGENT FOR ALARMS
Contact Center Solutions/Business Reporter includes an SNMP agent that enables you to monitor
Contact Center Solutions/Business Reporter alarms through an SNMP manager. Contact Center
Solutions/Business Reporter SNMP agent integrates with the Windows SNMP service and requires
that a Windows SNMP Service be added and configured on the Enterprise Server.
The Contact Center Solutions/Business Reporter SNMP agent is primarily configured for traps only,
but also responds to Get-request messages for trap messages.
SNMP Agent provides information on nine categories of alarms:
l

General Category Alarm

l

Data Collection Alarms

l

Server Resource Alarm

l

Communication Alarm

l

License Violation Alarm

l

IVR Alarm

l

Reporting Alarm

l

Performance Alarm

l

Configuration Alarm

The value reported for each alarm category is the highest severity of alarm currently triggered in that
category.

Configuring Windows SNMP service for the SNMP agent
Contact Center Solutions and Business Reporter requires the use of the Windows SNMP service for
the Contact Center Solutions SNMP agent.
The following procedures outlines how to:
l

l

Install the Windows SNMP services (Windows Server 2008 R2 and Windows Server 2012
and 2012 R2)
Configure Windows SNMP service for the SNMP agent

To install the Windows SNMP services (Windows Server 2008 R2)
1. Start the Server Manager.
2. Under Features Summary, click Add Features.
The Add Features Wizard opens.
3. Select the following services:
l

SNMP Services
l

SNMP Service

l

SNMP WMI Provider

4. Click Next.
5. Click Install.
6. Click Close.
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To install the Windows SNMP services (Windows Server 2012 and 2012 R2)
1. Start the Server Manager.
2. Click Manage=>Add Roles and Features.
The Add Roles and Features Wizard opens.
3. Select Role-based or feature-based installation and click Next.
4. Select Select a server from the server pool and select the Enterprise Server.
5. Click Next.
6. Click Next.
7. Select the following services:
l

SNMP Service
l

SNMP WMI Provider

8. Click Add Features.
9. Click Next.
10. Click Install.
11. Click Close.
To configure Windows SNMP service for the SNMP agent
1. If you do not have SNMP Service installed on your server, install it using the Add/Remove
Program, Add Features, or Add roles and features function of your Window server.
2. After the installation has completed, navigate to Services.
3. Right-click on SNMP and select Properties.
4. Select the Traps tab.
5. Under Community name, type a community name, such as Public, and click Add to list.
6. Under Trap destinations:, click Add.
7. Under Host name, IP or UPX address:, type the destination for Contact Center Solutions
SNMP Agent traps.
8. Click Add.
9. Select the Security tab.
10. Click Add.
11. In the Community rights drop-down list, select READ WRITE.
12. Under Community name:, type Public.
13. Select the Log On tab.
14. Under Log on as:, select Local System Account.
15. Click OK.
NOTE: After setting up your SNMP Agent, it is recommended you test it using an appropriate
tool to confirm that it has been configured correctly.
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SNMP MIB summary
Table 8 and Table 9 summarize object information from the MIB. The MIB is located in <drive>]
/CCM/Services/MaintenanceAlarmDispatcher/Snmp.
Table 8: prairieFyre sub-tree
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OBJECT TYPE

OBJECT IDENTIFIER

enterpriseAlarms

prairieFyre 1

enterpriseAlarms

prairieFyre 2

enterpriseAlarms

prairieFyre 3
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Table 9: MIB enterpriseAlarms sub-tree summary
OBJECT TYPE

manufacturer

SYNTAX
INTEGER
manufacturer

MAX
DESCRIPTION
ACCESS
read-only

Mitel Networks
Contact Center
Suite

enterpriseAlarms 1

read-only

This is the
cumulative total
of all reporting
active alarms and
should be viewed
as the overriding
alarm state that
the Mitel suite is
now reporting.

enterpriseAlarms 2

read-only

When a software
entity raises an
alarm not covered
in the following
list then it is
categorized as a
general alarm.

enterpriseAlarms 3

read-only

One of the Media
Controller Data
Link Connections
within the Mitel
Enterprise is
offline. This could
be a connection
to a PBX or an
email server or
some other
controller of a
media transaction
that is configured
to be connected
to the Mitel suite.

enterpriseAlarms 4

unknownAlarm
(0)
overridingSystemAlarm

noAlarm(1)
minorAlarm(2)
majorAlarm(3)
criticalAlarm(4)

unknownAlarm
(0)
generalCatagoryAlarm

noAlarm(1)
minorAlarm(2)
majorAlarm(3)
criticalAlarm(4)

unknownAlarm
(0)
noAlarm(1)
dataCollectionAlarm

minorAlarm(2)
majorAlarm(3)
criticalAlarm(4)

OBJECT
IDENTIFIER
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Table 9: MIB enterpriseAlarms sub-tree summary (continued)
OBJECT TYPE

SYNTAX
INTEGER

MAX
DESCRIPTION
ACCESS

read-only

One or more
software services
in the Mitel suite
is reporting an
unusual
consumption of
computer
resources. This
may a result of an
exceptionally
high CPU
consumption or
running low on
physical memory,
for example. This
may require a
service restart to
resolve.

enterpriseAlarms 5

read-only

One or more
service endpoints
is reporting an
error in its control
channel with an
associated
endpoint. This
may be a socket
or WCF channel
or may be an
MSMQ error that
is preventing
normal process
flow in the Mitel
software suite.

enterpriseAlarms 6

unknownAlarm
(0)
serverResourceAlarm

noAlarm(1)
minorAlarm(2)
majorAlarm(3)
criticalAlarm(4)

unknownAlarm
(0)
communicationsAlarm

noAlarm(1)
minorAlarm(2)
majorAlarm(3)
criticalAlarm(4)
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Table 9: MIB enterpriseAlarms sub-tree summary (continued)
OBJECT TYPE

SYNTAX
INTEGER

MAX
DESCRIPTION
ACCESS

read-only

The prairieFyre
Enterprise
Licensing
Manager is
reporting that the
installation is
violating or has
attempted to
exceed enforced
license limits for
their installation.
This may be
configuring the
YSE services for
features or
capacity they
have not
purchased.

enterpriseAlarms 7

read-only

The Routing
services for
IVR Routing are
reporting an
alarm, which may
be due to media
ports being out of
service or an
inability to load a
workflow.

enterpriseAlarms 8

unknownAlarm
(0)
licenseViolationAlarm

noAlarm(1)
minorAlarm(2)
majorAlarm(3)
criticalAlarm(4)

unknownAlarm
(0)
ivrAlarm

noAlarm(1)
minorAlarm(2)
majorAlarm(3)
criticalAlarm(4)

OBJECT
IDENTIFIER
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Table 9: MIB enterpriseAlarms sub-tree summary (continued)
OBJECT TYPE

SYNTAX
INTEGER

MAX
DESCRIPTION
ACCESS

read-only

The reporting
engine is
reporting an error
that implies it
cannot generate a
requested report
due to a system
inoperability error.
This may be a
corrupt report
template or could
be a transaction
error on the
retrieval of SQL
data to fill the
report.

read-only

One or more of
the service
endpoints in the
Mitel suite is
reporting an
overload
condition

enterpriseAlarms 10

read-only

One or more of
the service
endpoints in the
Mitel suite is
reporting an error
when loading
configuration
data.

enterpriseAlarms 11

unknownAlarm
(0)
reportingAlarm

noAlarm(1)
minorAlarm(2)
majorAlarm(3)
criticalAlarm(4)

unknownAlarm
(0)
performanceAlarm

noAlarm(1)
minorAlarm(2)
majorAlarm(3)
criticalAlarm(4)
unknownAlarm
(0)

configurationAlarm

noAlarm(1)
minorAlarm(2)
majorAlarm(3)
criticalAlarm(4)
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Validating YourSite Explorer configuration

VALIDATING YOURSITE EXPLORER CONFIGURATION
The Validate button manually triggers a validation of your contact center system configuration by
going through Class of Service system options, SMDR options, agent groups, voice queues, and
media servers, firing or clearing alarms as appropriate. Validation automatically takes place with the
synchronization that occurs during nightly maintenance, but manual validation is required to clear
some alarms.
To validate YourSite Explorer configuration
1. In YourSite Explorer, click the Tools tab.
2. Click the Validate button.

SECURITY ROLES
You create security roles if you want to restrict employees from specific devices and Contact Center
Solutions application areas that their licensing would otherwise enable them to access.
NOTE: In order for you to assign security roles, your account must be associated with a security role
that has ‘May manage security’ enabled.
Contact Center Solutions has two default security settings:
l

l

Local administrator—allows employees full access to all of the Contact Center Solutions
applications (to which the contact center and employees are licensed) and devices, except
Write Back for synchronization.
Enterprise administrator—includes access to Write Back, for synchronization, and all local
administrator duties.

Employee access to applications is limited by their security role and their licensing. An employee’s
security role defines the application areas an employee can access and licensing limits what
applications an employee can access. For example, an employee with the Enterprise administrator
security role but no supervisor license would not be able to access YourSite Explorer.
When you install Contact Center Solutions, a default user is created. This ensures there is at least
one account with which you can access YourSite Explorer.
When you install Contact Center Management, a default user is created. This assures you there is at
least one account with which you can access YourSite Explorer
The default user name and password are
l

Username: _admin

l

Password: _password

l

Security Role: Enterprise Administrator

Security roles have two components:
Basic—Basic security controls user access to specific areas of Contact Center
Management, Flexible Reporting, and to Workforce Scheduling and Schedule Adherence.
Advanced—Advanced security controls user access to customized lists of devices, real-time
monitors, profiles, reports, sites, and users
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CREATING AND APPLYING SECURITY ROLES
You can create security roles that have a number of combinations of basic and advanced
authorizations applied to them. For example, you can create a security role with minimal security
restrictions, granting users access to as many Contact Center Management reports and applications
as you designate. You do this by leaving the security components listed under the Advanced tab set
to 'Not restricted'. Alternatively, you can create a security role that has full access to some Contact
Center Solutions application areas but is restricted from accessing other reports and devices (Figure
16.)
To create and apply a security role, you must
1. Ensure employees are configured in the YourSite database.
2. Create security lists (If you intend to use advanced security).
3. Configure basic security.
4. Optionally, configure advanced security.
5. Assign the security role to one or more employees.
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Figure 16: Security flow chart

CREATING SECURITY LISTS
You can use advanced security to restrict user access to sites, reporting, and real-time functions.
Before you can specify advanced security, you must create security lists (device lists, real-time
monitor lists, report lists, site lists, and user lists). Each list must contain the devices, real-time
monitors, reports, sites, and users to which employees are granted access. You can combine these
lists when you assign a security role. For example, you can specify advanced security that permits
users to create Employee Group Performance by Employee reports (specific report list) on Kanata
employees (specific device list) only.
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Use the following security lists to define advanced security:
l

l

l

l
l

l

l

Device list—Device lists specify devices for which employees may view real-time
information. You create device lists to restrict access to statistics on specific employees. For
example, you might want a manager to view certain employees only (specific device - Kanata
employees). The device list must contain the device (employee group - in this case, Kanata
employees) to which the user may gain access. Devices include Account Code Group, Agent
group, DNIS group, Employee Division, Employee group, Extension Division, Queue group,
Team, Trunk Group, Voice extension group, and Voice mail extension group.
NOTE: If you add an agent to a device list, you must also add the associated employee.
Report list—You create report lists to restrict users from viewing specific report types. For
example, you might want managers to view employee reports only (specific report category).
The report list must contain the reports the user may run. If you do not assign a report list to
the employee, then the employee will see every YourSite group and team when running
reports and monitoring real-time activities (unless a basic security role is assigned to that
employee that does not permit the employee to gain access to any reports).
Profile list—You create a profile list to restrict users from managing specific real-time monitor
profiles.
Site list—You create a site list to restrict users to accessing only certain sites.
Real-time monitor list—The real-time monitor list specifies real-time monitors to which you
are granted access. You create a real-time monitor list to restrict access to particular real-time
monitors. The real-time monitor list must contain the monitors that the user will access.
User list—You create a user list to restrict a user from chatting online with certain employees.
The user list must contain the employees with which the user may chat. For example, you
might want managers to chat online with only the employees they supervise. If Jane manages
Bill, Sue, and George, then you assign Jane an advanced security role that permits Jane to
chat with Bill, Sue, and George (the user list would contain Bill, Sue, and George).
Card design list—You create a card design list to restrict users from managing card designs
(card designs specify the information displayed on agent, employee, and extension real-time
monitors).

The security list configuration page is rendered from CCMWeb within YourSite Explorer. To ensure
proper configuration functionality, ensure that CCMWeb has been added as a Trusted Site. Failure to
add CCMWeb as a Trusted Site may result in the security list configuration page being disabled.
If you are using Windows Authentication, you must also enable the following browser settings:
l

l

Under Internet Options=>Security, enable ‘Automatic logon with current user name and
password’
Under Internet Options=>Advanced, enable ‘Enable Integrated Windows Authentication’

To create a security list
1. Under the Enterprise pane, click Security list.
2. Select the security list you want to create and click Add.
3. Type the list Name.
4. Type the list Description.
5. Click the Members tab.
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6. If you are creating a device or reports list, after Filter by, select a category to narrow the items
that display in the list (for example, Agent group).
7. Select the check boxes of the members you want to include in the list.
8. Click Save.
To delete a security list
1. Under the Enterprise pane, click Security list.
2. Select the security list you want to create and click Delete.

CONFIGURING SECURITY ROLES
You can configure basic security to restrict user access to specific areas of CCMWeb and the
Contact Center Client, YourSite Explorer, Workforce Scheduling, Employee Portal, and Ignite
applications. Figure 17 shows the options available in the Basic security tab. For example, if you
want to restrict users from viewing Contact Center Client and Enterprise Configuration, then you
must create a security role with those characteristics.

Figure 17: Basic security tab
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Table 10 describes the specific setting options for YourSite Explorer synchronization for basic
security.
Table 10: YourSite Explorer synchronization - security setting options
OPTION
No access

DESCRIPTION
If No Access is enabled you cannot configure Enterprise settings or devices in
YourSite Explorer.

Allow Read Allow Read Access enables you to read Enterprise and device configuration
Access
settings in YourSite Explorer.
Allow
Read/Write
Access

Allow Read/Write Access enables you to read Enterprise and device configuration
settings in YourSite Explorer and write them to the YourSite database.

Allow Full
Control

Allow Full Control enables you to read Enterprise and device configuration settings
in YourSite Explorer, write them to the YourSite database, and write back devices
programmed in YourSite Explorer to the telephone system.

You can configure advanced security to restrict access to reports, real time and Interactive Contact
Center statistics, Chat, sites, and real-time monitors. Advanced security options often require that
appropriate security lists be made. (See Figure 18).
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Figure 18: Advanced security tab
Many advanced security role options require the creation of a security list before the role can be
configured. Using these lists, you define a security role. See "Creating security lists" on page 191.
Security roles are assigned to employees in their User account tab. See "Configuring user account
information" on page 131.
The security roles configuration page is rendered from CCMWeb within YourSite Explorer. To ensure
proper configuration functionality, ensure that CCMWeb has been added as a Trusted Site. Failure to
add CCMWeb as a Trusted Site may result in the security roles configuration page being disabled.
If you are using Windows Authentication, you must also enable the following browser settings:
l

l

Under Internet Options=>Security, enable ‘Automatic logon with current user name and
password’
Under Internet Options=>Advanced, enable ‘Enable Integrated Windows Authentication’
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To add a security role
1. In the Enterprise pane, click Security role.
2. Click Add a role.
3. Type a Role name.
4. Type a Role description.
5. On the Basic tab, clear the check boxes of the items the user is not permitted to use.
If required, click the Advanced tab and specify advanced security.
6. Click Save.
To verify the properties of a security role
1. In the Enterprise pane, click Security role.
2. Click View adjacent to the security role for which you want to view properties.
You can assign the security roles to new users and to existing users.
To edit a security role
1. In the Enterprise pane, click Security role.
2. Click Edit beside the name of the security role you want to edit.
3. Make the desired changes to the security role.
4. Click Save.
NOTE: Users who are currently logged on will not be affected by changes made to their
associated role until the next time they log on.

VIEWING YOUR SECURITY ROLE PROPERTIES
Users with access to YourSite Explorer can view their own security role properties and determine
the application areas to which they have access. Only employees with access to
YourSite=>Configuration can change the security role properties of employees.
To view the security role properties for your login credentials in YourSite Explorer
l

Under Enterprise, click My Role Allowed.

To view the security role properties for your login credentials in CCMWeb
l
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Click My Options=>My Security Role.

Configuring Work Timer

ASSIGNING SECURITY ROLES TO EMPLOYEES
NOTE: Users who are currently logged on will not be affected by changes made to their associated
role until the next time they log on.
To assign a security role to an employee
1. Select an employee
2. Click the User Account tab.
3. After Security role, click the Browse button.
4. Select a security role.
The default Local Administrator allows employees full access to all of the Contact Center
Solutions applications and devices (to which the contact center is licensed) except for Write
Back for synchronization.
The default Enterprise Administrator allows employees the same access as the Local
Administrator, but includes Write Back for synchronization.
5. Click OK.
6. Click Save.

CONFIGURING WORK TIMER
Work Timer provides agents handling calls with a period of time after they finish a call to set
classification codes, handle paperwork, or deal with other administrative tasks before returning to
handling calls. The primary Work Timer, Class of Service Work Timer, is configured in the Class of
Service options for agents, but a secondary Work Timer, the Queue Work Timer, may also be
configured for individual queues that require agents handling calls from that queue to have less time
for post-call work.
When configured, after call completion, Class of Service Work Timer places the agent into the Work
Timer real-time state and ACD calls no longer route to them. As the agent enters into the Work Timer
agent state, their timer in PhoneSet Manager or Softphone begins counting down the configured
Class of Service Work Timer duration. (In real-time monitors in Contact Center Client, Work Timer
will count up.) When the countdown reaches 00:00:00 or if the employee manually ends Work Timer,
they are returned to the Idle real-time state where they can handle calls again.
Work Timer can be cancelled manually by an agent by pressing the Cancel Work Timer button on
their hard set or soft phone applications. If the 'Force entry of a classification code' is enabled,
agents must enter a classification code first. If they do not, Work Timer cannot be ended manually
and a non-compliance classification code will be assigned to the call when Work Timer ends. Work
Timer also automatically ends if the agent enters a classification code (if the 'Cancel Work Timer
once code' is entered is enabled).
Class of Service and Queue Work Timer’s maximum duration is dependent upon a contact center’s
telephone system:
l

MCD 5.0 and greater – 4 hours

l

MCD 4.x or earlier – 10 minutes

Queue Work Timer overrides Class of Service Work timer, sending a Remove Work timer MiTAI
command to the telephone system that removes the Class of Service Work timer when the Queue
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Work Timer reaches its duration. For MCD 5.0 and greater, Queue Work Timer must be set to a
lower time than Class of Service Work Timer. For MCD 4.x or earlier, Queue Work Timer's duration
must be greater than the Class of Service Work Timer. If no Queue Work Timer is set on the queue,
the default value configured on the Class of Service Work Timer will be used for that queue's
associated agents. Multimedia Queue Work Timer is not dependent on MCD Class of Service Work
Timer and can be set to any duration of time.
NOTE:
l

l

When leveraging the Queue Work Timer feature, the Class of Service Work Timer value must
be accurately synchronized to the Media Server for Queue Work Timer to function.
When an agent receives a transferred call and enters into Work Timer, regardless of the queue
the agent is in, their Work Timer duration is taken from the Queue Work Timer duration set on
the queue the call originally came in on.

For information on configuring Work Timer as a Class of Service for Media Servers, see "Editing
Class of Service options" on page 110.
For information on configuring Work Timer for queues, see "Adding queues" on page 142.

PREPARING MEDIA SERVER AGENT TIMEOUT OPTIONS
FOR MCD 5.0 OR GREATER
By default, YourSite Explorer is configured to clear lines if an agent using that line remains in a single
state for more than two hours. This can impact Work Timer’s functionality if Work Timer has been
configured to be greater than two hours. To make proper use of the four hour Work Timer feature
available to MCD 5.0+, you must configure the agent state timeout audit options for your media
servers to ensure that they do not interfere with Work Timer.
To configure the media server agent state timeout audit option
1. In YourSite Explorer, click Media Servers.
2. Select your media server from the list of media servers.
3. Click the Data summary options tab.
4. After Clear line if agent primary Talk Time exceeds, select 24 hours from the drop-down
list.
5. If you are using multiple media servers, repeat steps 2-4 for all your contact center media
servers.
6. Click Save.
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REAL-TIME MONITORS
The Enterprise Server continuously updates the real-time applications with telephone system data,
and simultaneously updates connected clients through Transmission Control Protocol-Internet
Protocol (TCP/IP). Contact Center Client real-time monitors are automatically updated to reflect
device and device group changes made in YourSite Explorer. Supervisors and agents are provided
with point-and-click access to real-time performance statistics for their contact center, enabling
them to identify issues in contact center performance and see who is available to answer or assist
with calls.
The real-time applications include Contact Center Client and WallBoarder. Supervisors and agents
can view real-time voice statistics in Contact Center Client and the phone availability of contact
center and general business employees. In contact centers that have the Multimedia Contact Center
optional application, supervisors and agents can view real-time voice, email, and chat statistics.
WallBoarder displays text messages and contact center statistics on one or more Spectrum Light
Emitting Diode (LED) reader boards (wall signs). See "WallBoarder" on page 278.
Contact Center Management integrates with OAISYS Tracer, dvsAnalytics Encore, Red Box
Quantify call recording software to enable 24/7 call recording. Call recordings are appended to
specific Lifecycle reports. See "Call recording" on page 94.
In addition to real-time monitors, Contact Center Client includes the following application areas:
l

Auditor
Using Auditor, supervisors can view the historical real-time events that occurred on a
particular date, in the sequence they occurred, at your own pace.
See "Auditor" on page 379.

l

Management Console
Using Management Console, network administrators can restart services, administer the
database, and perform maintenance functions.
See "Management Console" on page 64.

l

Contact Center Chat
Contact Center Client provides instant messaging capabilities for both supervisors and
agents and is typically used by contact center employees. Contact Center Chat provides the
online chat presence of contact center employees, including Available, Offline, and Away.
Agents can view the availability and presence of other contact center employees before they
transfer calls or send online chat messages. With Lync Server 2010 or 2013, Contact Center
Chat integrates with Lync to provide enhanced presence.
See "Using Contact Center Chat" on page 272.
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The following optional applications and features reside in Contact Center Client:
l

Interactive Contact Center
Interactive Contact Center is an optional application that enables supervisors to control the
availability of agents and ACD queues. Agents can log themselves on or off, and place
themselves in or remove themselves from Make Busy or Do Not Disturb.
See "Using Interactive Contact Center" on page 388.

l

Interactive Visual Queue
Interactive Visual Queue is an optional application that enables agents to monitor calls within
queues, move calls from busy queues to less active queues, and call back abandoned callers.
See "Using Interactive Visual Queue" on page 406.

l

Contact Center PhoneSet Manager and Contact Center Softphone
Contact Center PhoneSet Manager and Contact Center Softphone are optional applications
that enable agents to use their desktop computers as IP-based phones.
See "Contact Center PhoneSet Manager and Contact Center Softphone" on page 420.

l

Contact Center Screen Pop
Contact Center Screen Pop is an optional application that launches applications or webpages.
In addition, it enables agents to automatically receive caller and account information via popups on their computer monitors every time they receive calls.
See "Using Contact Center Screen Pop" on page 458.

l

Contact Center Chat with Lync
With the addition of Lync Server 2010 or 2013, agents and supervisors use Microsoft Lync as
their default instant messaging client. The presence of all company employees is natively
delivered in Contact Center Client. Contact center employees can view the presence of both
internal and external contacts to determine if they are available to communicate. In addition to
Available, Offline, and Away, employees see In a Meeting, Busy, In a call, Do Not Disturb, Be
Right Back, and other presence indicators.

Lync Server 2010 and Lync Server 2013 extend the capabilities of Contact Center Chat enabling
agents to communicate with people who are
l

In the same company, but are not using Contact Center Client

l

In the same company, but are not on the same intranet

l

l

External to the company, where the companies in which they work have a Lync Server
environment and use Lync
External to the company, communicate over the public Internet, and use popular instant
message services (MSN, AIM, Yahoo!)

In a Microsoft Lync environment, you can take advantage of other forms of communication:
computer voice calls, video conferencing, white boarding, and desktop sharing capabilities.
Communication with MSN, AIM and Yahoo! is typically limited to instant messaging only.
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CONTACT CENTER CLIENT
NOTE:
l

l

l

By default, all supervisors and agents view all real-time monitors and devices in Contact
Center Client. You can specify which monitors and devices users view in
YourSite=>Security=>Security lists. In addition, you can configure security in
YourSite=>Security=>Security roles that dictate whether users can manage personal and/or
global profiles.
An employee must be a member of an employee group in order for you to view the employee
on the employee group monitors in Contact Center Client. A queue must be a member of a
queue group in order for you to view the queue on the queue group monitors in Contact Center
Client.
The number of employees logged on at any time must be consistent with your software
license.

Contact Center Client uses ribbons for device and monitor control. (See Figure 19.)

Figure 19: Contact Center Client ribbon
Some tabs that display in the ribbon are dependent upon which monitor is active. These are referred
to as context sensitive tabs. When you enable context sensitivity for monitors, the associated
context sensitive tab for the active monitor automatically becomes the active tab. See Table 11 for a
list of the associated context sensitive tabs for each monitor. See Figure 20 for an example of
context sensitivity enabled for the Agent State by Position monitor. Note that the Agent and Monitor
Control tabs display in the ribbon.
NOTE: The options that display in the Contact Center Client ribbon are dependent upon your
individual security settings. Options which you are not given access to will not display.
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Table 11: Context sensitivity options display per monitor
MONITOR

ASSOCIATED CONTEXT SENSITIVE TABS

Agent State
by Position

Agent and Monitor Control tabs

Employee
State by
Position

Employee and Monitor Control tabs
Extension and Monitor Control tabs

Extension
State by
Position

NOTE: When an agent is logged into an
extension, the context sensitivity tab displays
'Agent Control'. When no agent is logged into the
extension, the context sensitivity tab displays
'Extension Control'.

Extension
Now

Monitor Options tab

Agent State
by Time

Agent and Monitor Control tabs

Agent State
by Time for
Queue

Agent and Monitor Control tabs

Employee
State by
Time

Employee and Monitor Control tabs

Agent Shift

Agent and Monitor Control tabs

Queue by
Period

Monitor Options tab

Queue Now

Monitor Options tab

Queue
Group Now

Monitor Options tab

Queue
Chart Options tab
Performance
Queue
Group
Chart Options tab
Performance
Queue

Chart Options tab
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Table 11: Context sensitivity options display per monitor
(continued)
MONITOR
Queue
Group
Interactive
Visual
Queue

ASSOCIATED CONTEXT SENSITIVE TABS
Chart Options tab
n/a
NOTE: Context sensitivity is not supported for
the Interactive Visual Queue monitor

Figure 20: Context sensitivity example - Agent Control tab

STARTING CONTACT CENTER CLIENT
You start Contact Center Client to access real-time functionality. Supervisors and agents can view
real-time voice statistics. In contact centers that have the optional Multimedia Contact Center
application, supervisors and agents can view real-time voice, email, and chat statistics. After
starting Contact Center Client, you can choose to minimize it to either the system tray or the
taskbar, depending on your operating system.
NOTE: Launching client-side applications from the task bar causes them to bypass the Updater
Service process. To ensure successful updates from the Enterprise Server, after an upgrade close
all client-side applications for 15 minutes or reopen them from the Start menu/Start screen
To start Contact Center Client
1. Open Contact Center Client.
2. If prompted, type your user name and password and verify the Enterprise Server IP address.
3. If you use Secure Socket Layer, select the SSL check box.
4. Optionally, select the Remember my credentials check box.
5. Click Log in.
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To display Contact Center Client in the taskbar
1. In Contact Center Client, click the Contact Center Client tab.
2. Click Options.
3. Clear the Hide when minimized check box and click OK.
Contact Center Client, when minimized, will display in the taskbar.
4. To save the profile, click the Contact Center Client icon button and click Save as.
5. Type a Name for the profile and click OK.
The profile is saved and will automatically be applied each time you open Contact Center
Client.
When device associations to device groups are changed in YourSite Explorer (add, delete,
rename), these changes will be automatically made in Contact Center Client real-time
monitors saved with user profiles

CONFIGURING CONTACT CENTER CLIENT OPTIONS
You can customize the Contact Center Client user interface and real-time monitor device control and
display options by accessing the Options menu.
NOTE: The Contact Center Client tab is the leftmost tab with the Contact Center Client icon. The
following options are available from the Contact Center Client tab: New, Open, Open from file, Save,
Save as, Save as file, Feedback, Options, About, Logout, and Exit.
To configure Contact Center Client options
1. In the ribbon, click the Contact Center Client tab.
The Options window displays.
See Figure 21.
2. Under User interface display, select a Toolbar style, Real-time icon type, Background
color, Page size, and whether you want to hide Contact Center Client when the window is
minimized.
3. Select Context Sensitivity for Monitors if you want the context sensitive tab to
automatically become the active tab when you select a monitor.
NOTE: Monitor context sensitivity is enabled by default.
4. Select Context Sensitivity for Soft phone if you want the soft phone tab to automatically
become the active tab when a call is received.
If the Soft phone toolbar is floating, context sensitivity does not apply. Soft phone context
sensitivity is disabled by default.
5. Select the Display monitor device control option check box if you want to be able to see
the option for monitor control when you right-click cells in a real-time monitor.
NOTE: Monitor control enables you to simultaneously control all of the agents on a monitor
and is only available if you have appropriate permissions, are licensed for Interactive Contact
Center, and have extensions configured for your employees.
6. Configure Time format options.
The options you select will display in the real-time monitor cells.
7. Under Full name format, select how you want agent and employee first and last names to
display in real-time monitors.
8. Click OK.
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Figure 21: Contact Center Client options
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ADJUSTING THE CONTACT CENTER CLIENT VIEW
You can adjust the way you view Contact Center Client features on your desktop.
To adjust the view
1. Click View in the Contact Center Client ribbon.
The View options ribbon opens.
See Figure 22.

Figure 22: View options ribbon
2. To change the way monitors display inside Contact Center Client, select from the options in
the Window Docking column.
3. To adjust the position of the Contact Center Client window on your desktop, select from the
options in the Screen Docking column.
4. If you want Contact Center Client to always display on top of other applications on your
desktop, click Always on top.
5. Enable the Status Bar if you want the status bar to be visible at the bottom of the Contact
Center Client window.
See Figure 23.

Figure 23: Status bar
6. To open Voice, Email, or Chat legends, select from the options in the Legends column.

EMPLOYEE AND AGENT STATES
NOTE: If Contact Center Client becomes disconnected from the server, upon re-connection agent
states will automatically be synchronized with the server.
Table 12 lists the employee extensions states and their corresponding icons.
Table 13 lists the agent states and their corresponding icons.
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Table 12: Employee states
TERM

ICON

MEANING
An ACD voice contact ringing on the employee’s phone waiting to
be handled

Ringing

ACD

ACD Hold

A contact in an employee’s Multimedia Contact Center Inbox
waiting to be handled

An employee handling an ACD voice, email, or chat contact

An employee who had placed an ACD voice, email, or chat contact
on hold

Idle

An employee logged on and waiting to receive a voice, email, or
chat contact

Non ACD

An employee who has placed a non-ACD voice contact on hold

Non ACD
Hold

An employee who has placed a non-ACD voice contact on hold

Outbound

An employee on an outgoing voice contact

Outbound
Hold

An employee who has placed an outgoing voice contact on hold

Do Not
Disturb

Make Busy

An employee who has activated Do Not Disturb and is not available
to receive any ACD or non-ACD voice contacts
An employee who is not available to receive ACD voice, email, or
chat contacts but can receive voice contacts dialed directly to the
employee’s extension
This icon also displays when an employee’s external hot desk
agent is in the Reseize Timer state
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Table 12: Employee states (continued)
TERM

ICON

MEANING

System
Make Busy

If an employee has multimedia agent IDs and is logged on to two or
more media servers simultaneously, the system sends the agent
only one incoming communication at a time. For example, when the
agent answers a voice contact, the system places the agent ID(s)
for the other media server types in System Make Busy

Work Timer

An employee who is completing post-contact work, such as
paperwork, and is unavailable to receive voice contacts

Logged Off

An employee not currently logged in to any queue

System
Idle

An employee put into Idle by a supervisor

An employee who has not generated any activity since Contact
Center Solutions was started

Unavailable

Table 13: Agent states
TERM

VOICE

EMAIL

CHAT

MEANING
An ACD voice contact ringing on an agent’s
phone waiting to be handled

Ringing

ACD

ACD Hold

Idle

A contact in an agent's Multimedia Contact
Center Inbox waiting to be handled
An agent handling an ACD voice/email/chat
contact

An agent who has placed an ACD
voice/email/chat contact on hold

An agent logged on and waiting to receive a
voice, email, or chat contact
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Table 13: Agent states (continued)
TERM

EMAIL

CHAT

Non ACD

-

-

An agent involved in an incoming non-ACD
contact or agent-originated voice contact

Non
ACD Hold

-

-

An agent who has placed a non-ACD voice
contact on hold

Outbound

-

-

An agent on an outgoing voice contact

Outbound
Hold

-

-

An agent who has placed an outgoing voice
contact on hold

Do Not
Disturb

Make Busy

VOICE

MEANING

An agent who has activated Do Not Disturb
and is not available to receive any ACD or
non-ACD voice contacts
An agent who is not available to receive ACD
voice, email, or chat contacts but can receive
voice contacts dialed directly to the agent’s
extension
This icon also displays when an external hot
desk agent is in the Reseize Timer state
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System
Make Busy

If an agent is a multimedia agent and is
logged on to two or more media servers
simultaneously, the system sends the agent
only one incoming communication at a time.
For example, when the agent answers a
voice contact, the system places the agent
ID(s) for the other media server types in
System Make Busy.

Work
Timer

An agent who is completing paperwork and is
unavailable to receive voice contacts

Unknown

An agent who has not generated any activity
since Contact Center Solutions was started

Contact Center Client

Table 13: Agent states (continued)
TERM

VOICE

EMAIL

Logged Off

CHAT

MEANING

An agent not currently logged in to any queue

System
Idle

An agent put into Idle by a supervisor

EXTENSION STATES
NOTE: If your Contact Center Client becomes disconnected from the server, upon re-connection the
extension states will automatically by synchronized with the server.
Table 14 lists the extension states and their corresponding icons.
Table 14: Extension states

TERM

ICON

MEANING

Ringing

Call is ringing on the extension and waiting to be handled

Idle

Extension is waiting to receive a call

Non ACD

Extension is involved in an incoming call or an internal extensionoriginated call

Non ACD
Hold

Extension has placed an incoming call or an internal extensionoriginated call on hold

Outbound
Call

Extension is on an outgoing call

Outbound
Hold

Extension has placed an outgoing call on hold

Forwarded
to

Extension has set all incoming calls to be forwarded to an
alternate answer point
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Table 14: Extension states (continued)

TERM

MEANING

ICON

Camp on

Extension is on a call and an incoming call is camped on (waiting
to be answered)

Off Hook

Extension's phone is off the hook, so cannot receive calls

Do Not
Disturb

Extension has activated Do Not Disturb and is not available to
receive calls

Logged Off

Extension is not currently logged on and is unavailable to take
calls

System Idle

Unknown

An extension put into Idle by a supervisor

Extension has not generated any activity since Contact Center
Solutions was started

UNDERSTANDING CONTACT CENTER CLIENT FEATURES
Contact Center Client has agent, queue, queue chart, and call note monitors. For information on
adding and viewing call notes, see "Adding call notes to a call" on page 440.
You can perform the following tasks on the monitors by either right-clicking within the monitor or
selecting options via the Contact Center Client ribbon:
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l

Call recording

l

Open monitors

l

Dock monitors

l

Add and remove device IDs

l

Sort monitor devices

l

Rearrange cells

l

Set monitor dimensions

l

Freeze and unfreeze columns

l

Hide and show columns

l

Filter device variables

l

Set alarms

l

Clear alarms

l

Define monitor styles

Contact Center Client

l

Group data

l

Print monitors

l

Arrange windows

l

Modify the view

l

Build marquee monitors to broadcast statistics and messages

l

Chat online with agents and supervisors

Contact Center Client options
The following options apply to real-time monitors.
Call recording
On the Agent State by Time, Agent State by Position, Agent State by Queue by Time, and Extension
by Position monitors, the Call recording option enables you to start, stop, and restart call recording at
any time during a call. See "Recording calls" on page 452.
Clear alarms
The Clear alarms command clears any current performance variable threshold alarms.
Set alarms
The Set alarms command specifies performance thresholds for queues, agents, and extensions.
Add/Remove devices
The Add/Remove devices command adds or removes devices or device groups from the monitor. If
you add agents, they are added to the bottom of the monitor.
Set table dimensions
On the Agent State by Position, Employee State by Position, and Extension State by Position
monitors, the Set table dimensions command adds or deletes columns or rows. If you delete
devices, they are deleted them from the lower-right side of the monitor.
Size table to frame
On all monitors, the Size table to frame command adjusts the table to fit within the frame
Sort monitor
On the Agent State by Position, Employee State by Position, and Extension State by Position
monitors, the Sort monitor by Agent ID, name, state, or extension command sorts agents by Agent
ID, name, state and time in state, or extension.
Note that you cannot drag and drop devices between monitors.
Filter device variables
On the Agent Shift, Queue by Period, Queue Now, and Extension Now monitors, the Filter device
variables command filters the data based on conditions you specify and displays a subset of data on
the monitor.
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General
On all monitors, under Properties, the General option specifies the monitor name and enables the
horizontal and vertical scroll bars.
On the queue monitors, you can also enable grouping.
On the agent, employee, and extension monitors you can also display tool tips, display a pattern
upon failover, and display instant messaging online presence indicators.
On the Agent and Employee State by Time monitors, you can also sort logged off agents by the
longest logged off first.
Print monitor
The Print monitor command prints the current monitor.
Enable grouping
Under Properties, the Enable grouping option displays a grouping panel to which users can drag
columns. The grouping order determines the order in which the rows display. The Enable grouping
option affects all monitors that contain columns.
Row settings
Under Properties=>Layout, the Row settings option specifies the background color and font color of
rows, and the font type and text alignment.
Row alternate settings
Under Properties=>Layout, the Row alternate settings option specifies the background color and
font color of alternate rows, and the font type and text alignment.
Column settings
Under Properties=>Layout, the Column settings option specifies the background color and font color
of columns, and the font type and text alignment.
Column dimensions
Under Properties=>Layout, the Column dimensions option specifies the column height and width.
Column order
Under Properties=>Layout, the Column order option hides or displays individual columns, and
specifies the order of columns across the monitor.
Monitor style
Under Properties=>Layout, the Monitor style option specifies styles and skins (sets of styles) for the
monitor, and the Card design option specifies how information is displayed in the cells of agent,
employee, and extension monitors.
Cascade
When you right-click a monitor tab, under Windows, the Cascade command distributes active
monitors down and across the Contact Center Client window.
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Tile vertically
When you right-click a monitor tab, under Windows, the Tile vertically command distributes active
monitors across the Contact Center Client window.
Tile horizontally
When you right-click a monitor tab, under Windows, the Tile horizontally command distributes active
monitors down the Contact Center Client window.
Dock Contact Center Client
When you right-click a monitor tab, under Windows, the Dock Contact Center Client command
docks Contact Center Client at the top, bottom, left, or right of your desktop.
Always on top
When you right-click a monitor tab, under Windows, and select the Always on top command,
Contact Center Client always displays on your desktop on top of all other open applications.
View
The View command hides or displays the main menu, status bar, real-time monitors, and email,
chat, and voice legends.

DIAGNOSTICS MONITOR
The log and error monitors are accessed via Contact Center Client.
To access log and error monitors
1. Click Tools in the Contact Center Client ribbon.
2. Click either Log Monitor or Error Monitor, depending on what kind of log information you
want to review.
See Figure 24.

Figure 24: Diagnostics monitors

VIEWING AGENT AVAILABILITY
Contact Center Client provides instant messaging capabilities for both supervisors and agents and
is typically used by contact center employees. Contact Center Chat provides the online chat
presence of contact center employees, including Online, Offline, and Away. On the agent,
employee, and extension monitors, agents can view the availability and presence of other contact
center employees before they transfer calls or send online chat messages. (See Figure 25.) If an
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agent cell in a monitor is grayed out, the phone is not connected to the network and considered out of
service. The out of service state applies to phones that are not connected to the network, remote
agents and employees that have lost their Internet connection, phones that are physically
disconnected or malfunctioning, or employees that are not logged into their soft phone.

Figure 25: Agent State by Position - viewing agent availability and online presence
With the addition of Lync Server 2010 or 2013, agents and supervisors use Lync Client as their
default instant messaging client. The presence of all company employees is natively delivered in
Contact Center Client. Contact center employees can view the presence of both internal and
external contacts to determine if they are available to communicate. In addition to Available, Offline,
and Away, employees see In a Meeting, Busy, In a call, Do Not Disturb, Be Right Back, and other
presence indicators. (See Figure 26.)

Figure 26: Agent State by Position - viewing agent availability and enhanced presence
The following monitors display agent activities:
l

Agent State by Position

l

Employee State by Position

l

Extension State by Position

l

Agent State by Time

l

Employee State by Time

l

Agent Shift

Agent, Employee, and Extension State by Position
The Agent, Employee, and Extension State by Position monitors provide real-time information in
cells that you can arrange to mirror your floor plan: you can view agents, employees, or phone
extensions by their physical position in your contact center. In addition, these monitors enable you to
view the current status of general business extensions. Card designs enable you to customize the
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information displayed in the cells. See "Customizing the information displayed on position and time
monitors" on page 266.
When you first open an agent, employee, or extension monitor, you can select a card design:
l

l

l

The Classic card displays the agent state, time in the state, presence, agent/employee name,
agent login ID/employee ID, and extension number (or queue name for voice agents on ACD
or on ACD Hold).
The Caller ID card displays the caller name and number (ANI), the number the
caller/employee dials for incoming/outgoing calls, the state, time in the state, presence,
agent/employee name, agent login ID/employee ID, and extension number (or queue name for
voice agents on ACD or on ACD Hold).
Custom cards you create and share display customized agent/employee/extension and/or
caller information.

Caller ID information is displayed when
l

l

Agents, employees, and extensions are in the following real-time states: ACD, ACD Hold,
Ringing, Non ACD, Non ACD Hold, Out, and Out Hold Time
Extensions are in the following real-time states: Inbound and Outbound

You can set alarms for all real-time statistics and for caller ID information, such as the caller name
and number.
NOTE: Before you can select the Caller ID card on the Add devices window of agent, employee, and
extension monitors, you must make the card available. To do so, right-click an open monitor, select
the Caller ID card under Properties, Layout=>Card design and click Apply.
In a fault tolerant setup, if a network outage occurs the cells in the agent, employee, and extension
monitors display a crisscrossed pattern to identify agents who have homed to their secondary
controllers.
If an agent cell in a monitor is grayed out, the phone is not connected to the network and considered
out of service. The out of service state applies to phones that are not connected to the network,
remote agents and employees that have lost their Internet connection, phones that are physically
disconnected or malfunctioning, or employees that are not logged into their soft phone.

Viewing the activities of agents who can log on to multiple voice queues
In Figure 27, the Agent State by Position monitor shows three cells for Andre Bourque, each with a
different agent ID. The first two cells show Andre logged off of the telephone system. The third cell
shows Andre’s current state. Andre is logged on to Queue 151 using Agent ID 2013. He has been on
an ACD call for 12 minutes and 50 seconds.
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Figure 27: Agent State by Position - viewing multiple agent IDs
Agents can log on to the telephone system using only one agent ID at a time. If your agents have
multiple voice IDs (and therefore multiple cells) the Agent State by Position monitor becomes
cluttered.
If you have agents who are cross trained to answer calls for different departments (and log in and out
of various voice queues) the telephone system requires you assign the agents multiple IDs. You can
use the Agent State by Position monitor to view the activities of each department. You create an
Agent State by Position monitor for each department. When you arrange the cells for the agents in
the same order for each department, you can easily compare the activities of one department with
another.

Viewing the current logged on states of agents who log on to multiple
queues
If you have voice agents who are cross trained to answer calls for different departments (and log in
and out of several queues) the telephone system requires you assign the agents multiple IDs. If a
voice agent has multiple agent IDs and you want to view the agent’s current logged on state only,
you use the Employee State by Position monitor. For example, agent Andre Bourque answers calls
for English, French, and Spanish queues. In the YourSite database you assign him three agent IDs
(one for each queue for which he answers calls) and an employee ID.
To view the monitor, you open the Employee State by Position monitor and select employees to add
to the monitor. The monitor shows one cell for Andrew, listing his current state and agent ID. (See
Figure 28.)

Figure 28: Employee State by Position - viewing the ID to which the agent is logged on
Andrew is currently logged on to Extension 1564 using Agent ID 1559. Sometime later you notice
Andrew is logged on to Extension 1059 using Agent ID 1788. (See Figure 29.)
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Figure 29: Employee State by Position

Agent State and Employee State by Time
The Agent State by Time and Employee State by Time monitors provide real-time agent information
under ACD, Idle, Non ACD, Unavailable, and Logged Off column headings. They display the same
real-time information as that of the Agent State by Position, Employee State by Position, and
Extension State by Position monitors. See "Agent, Employee, and Extension State by Position" on
page 216.
If an agent is in an email or chat agent state, the monitors display the queue number to which the
agent is logged on. Each column lists agents in order of time in state. You can specify which
columns of agent statistics are displayed, and the order in which they are displayed. You can sort
logged off agents by the longest logged off first. (See Figure 30.)
If you have agents who are cross trained to answer calls for different departments (and log in and out
of various voice queues) the telephone system requires you assign the agents multiple IDs. You use
the Employee State by Time monitor to view the activities of voice agents with multiple agent IDs.
See "Viewing the current logged on states of agents who log on to multiple queues" on page 218.

Figure 30: Agent State by Time
Table 15 lists the Agent State by Time and Employee State by Time column headings and their
associated agent states.
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Table 15: Agent State by Time and Employee State by Time column headings
CATEGORY
ACD
Idle

ASSOCIATED AGENT STATES
includes agents in ACD and agents in ACD Hold
includes agents in the Idle state

Non ACD

includes agents in Non ACD, in Non ACD Hold, Outbound agents, and Outbound
Hold agents

Unavailable

includes agents in Do Not Disturb, Make Busy, Work Timer, Reseize Timer, and
Unknown

Logged Off

includes agents in the Logged Off state

Agent State by Time for Queue
The Agent State by Time for Queue monitor is a Contact Center Client real-time monitor designed
specifically for contact centers using Agent Group Presence functionality. However, the Agent State
by Time for Queue monitor is available for all media server types.
The Agent State by Time for Queue monitor is accessed from the Real Time tab in Contact Center
Client and displays all agents configured in a specific Queue and agents who are on ACD calls, idle,
on non-ACD calls, unavailable, logged on to the system (but not present in the queue being
monitored), and logged off. (See Figure 31).
NOTE:
l

l
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Virtual queue groups are shown under the Virtual queue groups section of the Agent State by
Time for Queue monitor. Any Agent State by Time for Queue monitors that are monitoring
virtual queues are marked in the title as (virtual).
The Agent State by Time for Queue monitor does not support viewing Ring Groups.

Contact Center Client

Figure 31: Agent State by Time for Queue
Table 16 lists the Agent State by Time and Employee State by Time column headings and their
associated agent states.
Table 16: Agent State by Time for Queue column headings
CATEGORY
ACD
Idle
Non ACD

ASSOCIATED AGENT STATES
includes agents in ACD and agents in ACD Hold
includes agents in the Idle state
includes agents in Non ACD, in Non ACD Hold, Outbound agents, and
Outbound Hold agents

Unavailable

includes agents in Do Not Disturb, Make Busy, Work Timer, and Reseize
Timer

Logged on to
system

includes agents who are logged on to the telephone system but not in the queue
being monitored

Logged Off

includes agents in the Logged Off and Unknown states

To view the Agent State by Time for Queue monitor
1. In the Contact Center Client ribbon, click the Real Time tab.
2. In the State by Time column on the ribbon, click Agent by Queue.
3. Select the queues to monitor. You can optionally sort members in either ascending or
descending order.
4. Click OK.
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Agent Shift
The Agent Shift monitor provides running totals of statistics on individual agents for the day. You can
specify which columns of statistics are displayed, rearrange columns, and sort individual columns in
ascending or descending order. (See Figure 32.)

Figure 32: Agent Shift

Agent Shift column heading definitions
Table 17 describes the Agent Shift column headings.
Table 17: Agent Shift column headings
TERM

ABBREVIATED
NAME

Agent State
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MEANING
The agent's media type and current state

Media Server

Media Server

The media server to which the agent is associated

Agent Shift Name

Name

Agent login ID

Agent login ID

Extension Number

Extn #

The extension where the agent logged in (voice
only)

Logged On

Log In

The most recent time the agent logged in

Last Event
Received

Last Event Recd

Shift Time

Shift Time

The name of the agent being monitored
The login ID of the agent being monitored

The most recent time an agent event occurred
The total elapsed time logged for the agent,
calculated based on the difference between log in
and last event received

Contact Center Client

Table 17: Agent Shift column headings (continued)
TERM

ABBREVIATED
NAME

ACD Time

ACD Time

ACD Hold Time

ACD Hold Time

The duration of time ACD contacts spent on hold

Non ACD Time

Non ACD Time

The duration of non-ACD contacts handled, from
agent pickup to completion (not including hold time)
(voice only)

Non ACD Hold
Time

Non ACD Hold Time

Outbound Time

Out Time

Outbound Hold
Time

Out Hold Time

The duration of time outbound calls spent on hold,
for agents (voice only)

Do Not Disturb
Time

DND Time

The duration of time the agent entered the Do Not
Disturb State

Make Busy Time

MKB Time

The number of times the agent entered the Make
Busy state

MEANING
The duration of ACD contacts handled, from agent
pickup to completion (not including hold time)

The duration of time non-ACD contacts spent on
hold
The duration of time agents spent handling
outbound calls (voice only)

Wrap Up Time

Wrap Up Time

The duration of time where Wrap Up Time was the
overriding state for the agent. Wrap up time does
not include any time spent making or taking
contacts during the wrap up timer.

Do Not Disturb
Count

DND Cnt

The number of times the agent entered the Do Not
Disturb state

Make Busy Count

MKB Cnt

The number of times the agent entered the Make
Busy state

ACD Count

ACD Cnt

The number of ACD contacts handled by the agent

Short ACD Count

Shrt ACD Cnt

The number of ACD contacts handled by the agent
where the handle time was less than the Short
Handle parameter

Non ACD Count

Non ACD Cnt

The number of non-ACD contacts handled by the
agent (voice only)

Hold ACD Count

Hold ACD Cnt

The number of times ACD contacts were placed on
hold (voice only)
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Table 17: Agent Shift column headings (continued)
TERM

ABBREVIATED
NAME

Non ACD Hold
Count

Non ACD Hold Cnt

Outbound Count

Out Cnt

Outbound Hold
Count

Out Hold Cnt

The number of times outbound calls were placed on
hold (voice only)

Contacts Per Hour

Contacts Per Hour

The total ACD contact count minus the ACD short
handle count, divided by the shift time for the agent

On Failover

On failover

Indicates whether the primary media server is
offline and has failed over to the secondary media
server (voice only)

Logged In Not
Present Time

Logged In Not
Present Time

The duration of time the agent was logged into but
not present in an agent group

Average Handle

Avg Hndl

Occupancy

Occp

MEANING
The number of times non-ACD contacts were
placed on hold
The number of outbound calls made by the agent
(voice only)

The average amount of time the agent spent
handling ACD contacts (ACD Time divided by ACD
Count, excluding ACD Hold Time)
The duration of time the agent spent processing
contacts, including ringing time

Viewing Agent and Extension Availability and Resiliency
Contact Center Client’s Agent, Employee, and Extension real-time monitors provide a visual
indication if agents fail over to a resilient media server. In an Agent monitor (Agent State by Position,
Agent State by Time, and Agent State by Queue by Time), if an agent fails over to the secondary
voice media server, a cross-hatch pattern displays in the agent’s cell in the monitor. (See Figure 33.)

Figure 33: Agent monitor with failed over agents
In an Employee monitor (Employee State by Position and Employee State by Time), if an
employee’s agent fails over to the secondary voice media server, a cross-hatch pattern displays in
the employee’s cell in the monitor. (See Figure 34.)
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Figure 34: Employee monitor with failed over agents
In an Extension monitor, if a logged in agent who is associated to an extension fails over to the
secondary voice media server, then a cross-hatch pattern is applied to the agent’s associated
extension in the extension monitor. (See Figure 35.)
NOTE: Extensions that fail over to the secondary voice media server do not have a cross-hatch
pattern applied to their cell.

Figure 35: Extension monitor with failed over agents

Modifying visual indicator settings for agents failing over
By default, monitors are configured to display a pattern if agents fail over to a secondary media
server. This setting is optional, however, and can be disabled on a monitor-by-monitor basis.
The following procedures explain how to
l

Disable visual indicators for agents failing over

l

Enable visual indicators for agents failing over

To disable visual indicators for agents failing over
1. Right-click in an open monitor and select Properties.
2. In the General tab, clear Display pattern when on failover.
3. Click OK.
To enable visual indicators for agents failing over
1. Right-click in an open monitor and select Properties.
2. In the General tab, select Display pattern when on failover.
3. Click OK.
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VIEWING EXTENSIONS
NOTE: Users who will use the Extension by Position monitor must have the Class of Service HCI
settings enabled.
In your business, you may be monitoring
l

l

l

Traditional or hot desking ACD agents who sit at different desks each day and who log on
using their agent ID
General business, traditional extensions (non-contact center employees) who sit at the same
desks each day, are assigned their own desk phone extensions, and do not log on to their
phones (their phones are programmed with their personal settings and are always active)
General business, hot desking extensions (non-contact center employees) who log on to any
phone in the enterprise with a virtual extension configured with their personal settings. When
the employee logs on the extension becomes active. When the employee logs off of the
extension it goes out of service.

The following monitors are available for viewing extensions:
l

Extension State by Position

l

Extension Now

You can set up your real-time monitor profile to include two or more Extension by Position monitors:
one with cells that are arranged to show the whereabouts of agents in your contact center, and
another that shows the status of general business extensions: active/inactive, inbound/outbound.
Extension Inbound
Extension Inbound refers to a general business extension on an inbound call.
Extension Outbound
Extension Outbound refers to a general business extension on an outbound call
General business active extension
General business active extension refers to a Mitel desk phone/Contact Center PhoneSet
Manager/Contact Center Softphone that is live with no ACD agents logged on (active extension), or
an extension to which a general business hot desking user is logged on. The user is an active
extension not logged on to any ACD queue.
General business inactive extension
General business inactive extension refers to a Mitel desk phone that has been unplugged or is
damaged, or a soft phone that is not running because the computer is turned off or Contact Center
Client is not running, or a hot desking extension to which nobody is logged on.

Traditional or hot desking ACD agents who sit at different desks each day
If you have traditional or hot desking ACD agents who sit at different desks each day, you use the
Extension State by Position monitor to view where they are sitting in the contact center. After you
add Registration Directory Numbers (RDNs)/desk phone extensions to the monitor, you can arrange
the cells to match the layout of your contact center.
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When nobody is logged on to a particular extension, the monitor cell displays the General business
active icon and the phone set RDN ID. When an agent logs on to the desk phone, the monitor cell
displays the ACD agent status, (which can include information such as the time in state, queue
reporting number, and Make Busy status), the agent ID, the agent name, and the RDN (at the bottom
of the cell). Depending on the agent’s current state you may see additional information, such as the
time in state, queue reporting number, or Make Busy status. If the Caller ID card design is selected,
you will also see the caller name and phone number. (See Figure 36.)
If you would prefer that Extension State by Position monitor cells be blank when there are no agents
logged on to the telephone system, you can right-click the monitor, select Properties, and clear the
Enable the general business view check box.
If an agent cell in a monitor is grayed out, the phone is not connected to the network and considered
out of service. The out of service state applies to phones that are not connected to the network,
remote agents or employees that have lost their Internet connection, phones that are physically
disconnected or malfunctioning, or employees that are not logged into their soft phone.

Figure 36: Extension State by Position
General business, traditional extensions who sit at the same desks each day
If you have general business, traditional extensions who sit at the same desks each day, you use
the Extension State by Position monitor to view where they are sitting in the contact center. After
you add their extensions to the monitor, you can arrange the cells to match the layout of your
business, or arrange them alphabetically or by department.
When a general business employees is in Idle, the cell for the employee’s phone extension in the
Extension State by Position monitor displays the employee’s name and extension number, and the
General business active icon. When the employee is on an incoming/outgoing call, the cell displays
the Extension Inbound/Extension Outbound icon, the employee’s name and extension number, and
the time in state. If the Caller ID card design is selected, you will also see the caller name and phone
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number. Either card enables you to readily determine the online and phone availability of general
business subject matter experts.
General business hot desking employees who sit at different desks each day
General business, hot desking extensions can log on to any phone in the enterprise and access their
personal settings. When adding extensions to the Extension State by Position monitor, you can
arrange them alphabetically or by department.
When an employee is logged on, the monitor cell displays the General business active icon, the
employee’s name and extension. When the employee is on an incoming/outgoing call, the cell
displays the Extension Inbound/Extension Outbound icon and the time in state. If the Caller ID card
design is selected, you will also see the caller name and phone number. When the employee logs
off, the monitor cell is grayed out (inactive). (See Figure 37.)

Figure 37: Extension State by Position

Extension Now
The Extension Now monitor enables supervisors to view extension statistics in real time. The
Extension Now monitor provides visibility to extensions. If an agent logs into an extension displayed
in this monitor, the extension will go out of service and will not be updated in real time. In the
Extension Now monitor, you can specify which columns of statistics are displayed, rearrange
columns, and sort individual columns in ascending or descending order. (See Figure 38.)
NOTE: Extensions must be licensed to display statistics.

Figure 38: Extension Now monitor

Extension Now column heading definitions
Table 18 describes the real-time and over-the-business-day Extension Now extension statistics.

228

Contact Center Client

Table 18: Extension Now extension statistic column headings
TERM
Ext Stat
Media Server
Name

MEANING
The current status of the extension
The extension’s media server
The extension name
The extension’s reporting number

Reporting
Last Event Recd
ACD Time

NOTE: The extension reporting number is also its dialable number.
The most recent time an extension event occurred
The duration of ACD (ring group) contacts handled, from extension pickup
to completion (not including hold time)

ACD Hold Time

The duration of time ACD (ring group) contacts spent on hold

Non ACD Time

The duration of non-ACD contacts handled, from extension pickup to
completion (not including hold time)

Non ACD Hold Time The total time for non-ACD calls put on hold
Out Time
Out Hold Time
DND Time
DND Count
ACD Cnt

The number of outbound calls made by the extension
The duration of time outbound calls spent on hold for extensions
The duration of time where Do Not Disturb was the overriding state for the
extension
The number of times the extension entered the Do Not Disturb state
The total number of ACD (ring group) calls answered by the extension

Shrt ACD Cnt

The total number of ACD (ring group) calls answered by the extension that
lasted less than the Short Handle parameter

Hold ACD Cnt

The number of times the extension put ACD (ring group) calls on hold

Non ACD Cnt

The total number of non-ACD calls answered by the extension

Non ACD Hold Cnt

The number of times non-ACD calls were put on hold

Out Cnt

The total number of outgoing calls the extension made

Out Hold Cnt
Calls Per Hour

The total number of times the extension put outgoing calls on hold
The average number of incoming ACD calls answered by the extension per
hour since the extension was logged in
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Table 18: Extension Now extension statistic column headings (continued)
TERM
On Failover

MEANING
Indicates whether or not the extension has failed over to the secondary
media server

Not Present Time

The duration of time the extension was in service but not present in a ring
group

Avg Handl

The average amount of time the extension spent handling ACD contacts
(ACD Time divided by ACD Count, excluding ACD Hold Time)

Occp

The total time the extension spent in an occupied state (occupied state
excludes idle time)

VIEWING QUEUE STATISTICS
NOTE:
l

l

You can see queue statistics during business hours as long as the business schedule you
configure in YourSite Explorer is consistent with your company’s hours of operation. You
assign business-hours schedules to queues W in YourSite Explorer=>Queues=>Business
Hours.
If an agent fails to answer an ACD call after X seconds or X rings, the telephone system either
logs out the agent or removes their presence from all agent groups (depending on telephone
system configuration). The telephone system then re-queues the call, in the same queue, and
offers it to the next available agent.

The following monitors display queue statistics:
l

Queue by Period

l

Queue Now

l

Queue Group Now

Queue by Period
The Queue by Period monitor collates queue statistics by 15-minute intervals over a 24-hour period.
The monitor refreshes each time there is a change in a statistic and each 15-minute interval. The
Queue by Period monitor always displays the current 15 minute interval at the top of the monitor. You
can specify which columns of statistics are displayed, rearrange columns, and sort individual
columns in ascending or descending order. (See Figure 39.)
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Figure 39: Queue by Period

Queue by Period column heading definitions
Table 19 describes the Queue by Period column headings.
NOTE:
l

l

l

l

l

l

If the overflow point for a ring group is an extension with a hot desking agent/user logged into
it, a call will not be pegged as interflowed.
External calls to ring groups that overflow to an ACD path voice queue and are then answered
by an agent are not counted as Unavailable in real-time monitors.
External calls to ring groups that overflow to an ACD path voice queue and are then answered
by an agent are not counted as interflowed in real-time monitors.
Internal calls to ring groups that overflow due to ring or queue timer are pegged as abandons in
real-time monitors, but are pegged as interflows in reports.
Internal calls to ring groups that overflow to an ACD path voice queue and are answered by an
agent are pegged as abandoned in real-time monitors. If you run Summarize, they will be
counted as interflowed.
Internal calls that are blind transferred to a ring group and then answered by a ring group are
not counted as an ACD call.
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Table 19: Queue by Period column headings
TERM

ABBREVIATED
NAME

Interval time

Interval

Offered

Offr

The total number of calls offered to the
queue during the 15-minute interval

Handled

Hndl

The total number of calls answered by
members during the 15-minute interval

MEANING
The 15 minute interval of time

Short Abandoned

Shrt Abn

During the 15-minute interval, the total
number of calls abandoned before the short
abandon time configured against the queue
in YourSite Explorer

Abandoned

Abn

The total number of calls abandoned during
the 15-minute interval before being
answered by members

Interflowed

Intrfl

The total number of calls interflowed during
the 15-minute interval
The total number of calls re-queued during
the 15- minute interval

Requeued

Re Q

NOTE: This statistic displays information
for ACD paths only. Statistics for Ring
Groups will display as '0'.
A count of all of the calls answered by the
first, second, third, and fourth answer
points during the 15-minute interval

% Handled by 1-4

% Hndl by 1-4

NOTE: This statistic displays information
for ACD paths only. Statistics for Ring
Groups will display as '0'.
The number of calls answered by the first,
second, third, and fourth answer points
during the 15-minute interval
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#Handled by 1-4

# Hndl by 1-4

Total Conversation Time

Ttl Conv Time

The total time members spent talking to
callers during the 15-minute interval

Average Conversation Time

Avg Conv time

The average time members spent talking to
callers during the 15-minute interval

NOTE: This statistic displays information
for ACD paths only. Statistics for Ring
Groups will display as '0'.
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Table 19: Queue by Period column headings (continued)
ABBREVIATED
NAME

MEANING

Average Time to Handle

Avg Time Hndl

The average amount of time callers waited
in queue before members answered their
calls during the 15-minute interval

Average Time to Abandon

Avg Time Abn

The average amount of time callers waited
in queue during the 15-minute interval
before they abandoned their calls

Average Time to Interflow

Avg Time Intrfl

The average amount of time callers waiting
in queue during the 15-minute interval
before being interflowed

Service Level % Today

Scv Lvl % Tday

During the 15-minute interval, the
percentage of calls answered within the
Service Level Time specified for the queue

% Hndl

During the 15-minute interval, the
percentage of calls answered compared to
the total number of calls offered to the ACD
queue for the day

TERM

% Handled

The total time the agent spent in the Work
Timer state during the 15-minute interval
Wrap Up

Wrap Up

NOTE: This statistic displays information
for ACD paths only. Statistics for Ring
Groups will display as '0'.
The total time the agent spent in the Make
Busy state during the 15-minute interval

Make Busy

Make Busy

Occupancy

Occp

NOTE: This statistic displays information
for ACD paths only. Statistics for Ring
Groups will display as '0'.
The total time the queue members spent in
an occupied state during the 15-minute
interval (occupied state excludes idle time)
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Queue Now and Queue Group Now
The Queue Now monitor enables supervisors to view queue statistics in real time, as well as expand
individual queues in the monitor to view statistics on each queue’s associated member agents or
extensions. When you expand the Queue Now monitor to display the Name column, the monitor also
displays member presence in the queue. Presence is indicated by a colored star in the Present
column. A green star indicates the member is present in the queue. A gray star indicates the member
is not present in the queue. A grey row indicates that the member is not logged in (for agents and hot
desk users) or out of service (for extensions).
The Queue Group Now monitor enables supervisors to view aggregated statistics for Reporting,
Virtual, and Unified queue groups in real-time, as well as expand individual queue groups in the
monitor to view statistics for the queue group’s associated queues.
On the Queue Now monitor, you can specify which columns of statistics are displayed, rearrange
columns, and sort individual columns in ascending or descending order. You can expand a queue
and view statistics on the members associated with the queue. (See Figure 40.)
NOTE: Prior to Version 7.1, Queue Now monitors displayed the agent groups belonging to the
queues with agent group statistics. As of Version 7.1, this functionality has been removed. Instead,
queue members are grouped by agent group.

Figure 40: Queue Now
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NOTE:
l

l

l

l

l

l

l

l

Virtual queue groups are shown under the Queue groups column in the Queue Now monitor so
that their individual queues can be selected in a single operation.
Contact Center Client updates Longest Waiting statistics every fifteen seconds, or more
frequently as records are received from the telephone system.
Contact Center Client obtains the Contacts Waiting, Longest Waiting, and Agents Available
statistics from the ACD data stream. If the telephone system has not updated Contact Center
Management with ACD real-time statistics within the last 90 seconds, question marks display
in place of these statistics.
Agents logged in and idle whose extensions are ringing are included in the Agent Available
statistic. Agents whose extensions are ringing are not included in the Unavailable statistic.
The Average Handling Time is the Average Conversation Time plus the Average Hold Time. If
an agent calls a supervisor in search of more information (while the caller is on hold) and/or
transfers or conferences the call, these times are added to the Average Handling Time value.
If an agent fails to answer an ACD call after X seconds or X rings, the telephone system either
logs out the agent or removes their presence from all agent groups (depending on telephone
system configuration). The telephone system then re-queues the call, in the same queue, and
offers it to the next available agent.
The abandoned media column in the Interactive Visual Queue monitor displays all abandoned
calls, whereas, the abandoned column in the Queue Now monitor does not peg short
abandons as abandoned calls. Because of this difference, you may notice discrepancies
between the abandoned call information in these two monitors.
Queue Now and Queue Group Now statistics that do not support Ring Groups will show ‘0’
instead.

Queue Now and Queue Group Now column heading definitions
Table 20 describes the real-time and over-the-business-day Queue Now and Queue Group Now
queue and queue group statistics.
NOTE:
l

l

l

l

l

l

If the overflow point for a ring group is an extension with a hotdesking agent/user logged into it,
a call will not be pegged as interflowed
External calls to ring groups that overflow to an ACD path voice queue and are then answered
by an agent are not counted as Unavailable in real-time monitors
External calls to ring groups that overflow to an ACD path voice queue and are then answered
by an agent are not counted as interflowed in real-time monitors
Internal calls to ring groups that overflow due to ring or queue timer are pegged as abandons in
real-time monitors, but are pegged as interflows in reports.
Internal calls to ring groups that overflow to an ACD path voice queue and are answered by an
agent are pegged as abandoned in real-time monitors. If you run Summarize, they will be
counted as interflow.
Internal calls that are blind transferred to a ring group and then answered by a ring group are
not counted as an ACD call.
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Table 20: Queue Now and Queue Group Now queue statistic column headings
TERM

ABBREVIATED
NAME

MEANING
The current status of the queue—either ACD or Do Not
Disturb

Queue Status

Queue Status

Queue Number

Queue #

Queue Group
Number

Queue Group #

Media Server

Media Server

Queue Name

Name

Contacts Waiting

Contacts Wtg

Longest Waiting

Long Wtg

Available (Queue
Now)
Agents Available
(Queue Group
Now)
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Avail
Agts Avail

If licensed for IVR Routing, an additional queue status,
Offline, is available. Offline indicates that IVR Routing
failed to receive a real-time status from the queue after
a set period of time.
The queue's reporting number
The queue group reporting number (Queue Group Now
only)
The queue’s media server
The queue or queue group name
The current number of contacts in queue waiting for a
member to become available, including those listening
to silence, music, or recorded announcements
The current duration, in minutes and seconds, of the
contact waiting the longest in queue or queue group

The total number of members logged in and not in Do
Not Disturb, Make Busy, Work Timer, Reseize Timer,
or Unknown

The current number of members handling ACD
contacts

ACD

ACD

Idle

Idle

Non ACD

Non ACD

Outbound

Out

The current number of members on outgoing calls
(voice only)

Unavailable

Unavail

The current number of members in Do Not Disturb,
Make Busy, Work Timer, Ringing, or Unknown

Offered

Off

The total number of contacts offered to the queue /
queue group

The current number of members logged on and ready to
receive contacts
The current number of members handling non-ACD
calls (voice only)

Contact Center Client

Table 20: Queue Now and Queue Group Now queue statistic column headings (continued)
TERM

ABBREVIATED
NAME

Handled

Hndl

MEANING
The total number of ACD contacts handled by
members
The total number of contacts abandoned before being
answered by members

Abandoned

Abn

NOTE: Abandoned does not peg short abandons as
abandoned contacts while the Abandoned column in
the Interactive Visual Queue monitor displays all
abandoned contacts. Because of this difference, you
may notice discrepancies between the abandoned call
information in these two monitors.
The total number of ACD contacts interflowed.
Interflow is a mechanism that directs a contact waiting
in queue to another answer point.

Interflowed

Intrfl

NOTE: If a contact waiting in queue is redirected before
the queue’s short abandon time has elapsed, the queue
is pegged with a Queue Unavailable count rather than
an Interflowed count. In order for the Interflowed peg to
occur, the redirection must occur after the short
abandon time has elapsed.
The total number of ACD contacts requeued
NOTE: This statistic displays information for ACD
paths only. Statistics for Ring Groups will display as
'0'.

Requeued

Re Q

Average Time to
Handle

Avg Time Hndl

The average time it takes for the contact to be taken
out of queue (answered or picked) by a member

Average Time to
Abandon

Avg Time Abn

The current average amount of time customers wait in
queue before abandoning contacts

Average
Conversation
Time

Avg Conv Time

The current average time members spent
communicating (talking, chatting, or replying) with
contacts
For a queue, this is the percentage of contacts handled
within the queue’s Service Level Time value over the
day

Service Level %

Svc Lvl %

For a queue group, this is the lowest percentage of
contacts handled within the queue’s Service Level
Time value over the day across all queues
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Table 20: Queue Now and Queue Group Now queue statistic column headings (continued)
TERM

ABBREVIATED
NAME

MEANING
For a queue, this is the percentage of contacts handled
compared to the total number of contacts offered to the
queue for the day

% Handled

% Hndl

For a queue group, this is the lowest percentage of
contacts handled compared to the total number of
contacts offered to the queue for the day across all
queues
For a queue, this is the percentage of all of the contacts
answered by the first, second, third, and fourth agent
groups

% Handled by 1-4

% Hndl by 1-4

For a queue group, this is the highest percentage of all
of the contacts answered by the first, second, third,
and fourth agent groups
NOTE: This statistic displays information for ACD
paths only. Statistics for Ring Groups will display as
'0'.

Total
Conversation
Time

Ttl Conv Time

The current total time members spend talking to callers

Total Queue
Unavailable

Ttl Q Unavail

The total number of times during the day that contacts
are rerouted because the queue is in Do Not Disturb or
has no members logged in

Current Queue
Unavailable

Curr Q Unavail

The current number of contacts are rerouted because
no members are logged in or the queue is in Do Not
Disturb. Once the queue becomes available, this value
resets to 0

Offered Last Hour

Offr Last Hour

The total number of contacts offered to the queue
during the last hour of business

Time to Handle
Last Hour

Time Hndl Last Hour

% Handled Last
Hour
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The time contacts waited in queue during the last hour
of business before being handled by a member
For a queue, this is the percentage of contacts handled
in the last hour of business, compared to the total
number of contacts offered to the ACD queue for the
day

% Hndl Last Hour

For a queue group, this is the lowest percentage of
contacts handled in the last hour of business,
compared to the total number of contacts offered to the
ACD queue for the day

Contact Center Client

Table 20: Queue Now and Queue Group Now queue statistic column headings (continued)
TERM

ABBREVIATED
NAME

MEANING
For a queue, this is the percentage of contacts
answered or picked within your Service Level Time
value in the last hour

Service Level %
Last Hour

Svc Lvl % Last Hour

Handled Last
Hour

Hndl Last Hour

The total number of contacts handled by members
during the last hour of business

Abandoned Last
Hour

Abn Last Hour

The total number of contacts abandoned during the last
hour of business

Interflowed Last
Hour

Intrfl Last Hour

The total number of contacts interflowed during the last
hour of business. Interflow is a mechanism that directs
a contact waiting in queue to another answer point

Unavailable Last
Hour

Unavail Last Hour

For a queue group, this is the lowest percentage of
contacts answered or picked within your Service Level
Time value in the last hour

The total number of times, in the last hour of business,
contacts were rerouted because the queue they tried to
access was in Do Not Disturb or had no members
logged in
See Current Queue Unavailable

Average Handling
Time Last Hour

Avg Hndl Last Hour

The average duration of contacts from member pick up
to client hang up (including hold time) during the last
hour of business

Offered Last 15
Minutes

Offr Last 15 Min

The total number of contacts offered to the queue in the
last 15 minutes of business

Time to Handle
Last 15 Minutes

Time Hndl Last 15
Min

The time contacts waited in queue during the last 15
minutes of business before being handled by a member

% Handled Last
15 Minutes

For a queue, the percentage of contacts answered in
the last 15 minutes of business, compared to the total
number of contacts offered to the ACD queue for the
day
% Hndl Last 15 Min

For a queue group, the lowest percentage of contacts
answered in the last 15 minutes of business, compared
to the total number of contents offered to the ACD
queue for the day
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Table 20: Queue Now and Queue Group Now queue statistic column headings (continued)
TERM

ABBREVIATED
NAME

MEANING
For a queue, this is the percentage of contacts
answered or picked within your Service Level Time
value in the last 15 minutes of business

Service Level %
Last 15 Minutes

Svc Last % Last 15
Min

Handled Last 15
Minutes

Hndl Last 15 Min

The total number of contacts handled by members
during the last 15 minutes of business

Abandoned Last
15 Minutes

Abn Last 15 Min

The total number of contacts abandoned during the last
15 minutes of business

Intrfl Last 15 Min

The total number of contacts interflowed during the last
15 minutes of business. Interflow is a mechanism that
directs a contact waiting in queue to another answer
point.

Interflowed Last
15 Minutes

Unavailable Last
15 Minutes

Unavail Last 15 Min

For a queue group, this is the lowest percentage of
contacts answered or picked within your Service Level
Time value in the last 15 minutes of business

The total number of times, in the last 15 minutes of
business, contacts were rerouted because the queue
they tried to access was in Do Not Disturb or had no
agents logged in
See Current Queue Unavailable

Average Handling
Time Last 15
Minutes

Avg Hndl Last 15
Min

The average handling duration of contacts from contact
pickup to contact completion, including hold time,
during the last 15 minutes of business
For a queue, this is the percentage of contacts that
were abandoned (% Abandoned = Contacts
Abandoned ÷ Contacts Offered)

% Abandoned

% Abandoned
Last Hour
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% Abn

For a queue group, this is the highest percentage of
contacts that were abandoned (% Abandoned =
Contacts Abandoned ÷ Contacts Offered)
For a queue, this is the percentage of contacts that
were abandoned in the last hour of business

% Abn Last Hour

For a queue group, this is the highest percentage of
contacts that were abandoned in the last hour of
business

Contact Center Client

Table 20: Queue Now and Queue Group Now queue statistic column headings (continued)
TERM

% Abandoned
Last 15 Minutes

ABBREVIATED
NAME

MEANING
For a queue, this is the percentage of contacts that
were abandoned in the last 15 minutes of business

% Abn Last 15 Min

For a queue group, this is the highest percentage of
contacts that were abandoned in the last 15 minutes of
business
The total time that agents spent in the Work Timer
state

Wrap Up

Wrap U

NOTE: This statistic displays information for ACD
paths only. Statistics for Ring Groups will display as
'0'.
The total time that agents spent in the Make Busy state

Make Busy

Make Busy

Occupancy

Occp

NOTE: This statistic displays information for ACD
paths only. Statistics for Ring Groups will display as
'0'.
The total time that members spent in an occupied state
(occupied state excludes idle time)
The number of contacts answered by the first, second,
third, and fourth agent groups

# Handled by 1-4

# Hndl by 1-4
NOTE: This statistic displays information for ACD
paths only. Statistics for Ring Groups will display as
'0'.
The number of members associated with the queue but
not logged in to the system

Logged Out

Members Not
Present

Logged out

Not Present

NOTE: For Ring Groups, this statistic displays either
the number of extensions out of service or hot desk
users logged out.
The number of members that are logged into the
telephone system, but not present in the queue being
monitored

Table 21 describes the real-time and over-the-business-day Queue Now and Queue Group Now
member statistics.
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Table 21: Queue Now and Queue Group Now member statistic column headings
TERM

MEANING

Name

The name of the member being monitored. The icon beside the name
indicates the media type the member handles
Indicates whether the member is present in the queue

Present

Media Server

Presence is indicated by a colored star. A green star indicates the agent or
extension is present in the queue. A gray star indicates the agent is not
present in the queue
The media server to which the member is associated

Reporting

The reporting number of the member being monitored. For agents and hot
desk users, this is the login ID. For extensions, this is the extension dialable.

Extn#

The base extension where the member logged in (voice agent or hot desk
user only)
The first login of the member’s shift.

Log In

Last Event
Received

NOTE: This statistic displays information for ACD path members only and is
not calculated for Ring Group members.
The most recent time an member event occurred
The total elapsed time logged for the member, calculated based on the
difference between log in and last event received

Shift Time

DND Time

NOTE: This statistic displays information for ACD path members only and is
not calculated for Ring Group members.
The duration of time where Do Not Disturb was the overriding state for the
member
The duration of time where Make Busy was the overriding state for the
member

MKB Time

Wrap Up Time

NOTE: This statistic displays information for ACD paths only. Statistics for
Ring Groups will display as '0'.
The duration of time where Wrap Up Time was the overriding state for the
member. Wrap up time does not include any time spent making or taking
contacts during the wrap up timer.
NOTE: This statistic displays information for ACD paths only. Statistics for
Ring Groups will display as '0'.

ACD Time
Hold ACD Time
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The duration of ACD contacts handled, from member pickup to completion
(not including hold time)
The duration of time ACD contacts spent on hold

Contact Center Client

Table 21: Queue Now and Queue Group Now member statistic column headings
(continued)
TERM

MEANING

Non ACD Time

The duration of non-ACD contacts handled, from member pickup to
completion (not including hold time) (voice only)

Hold Non ACD
Time

The duration of time non-ACD contacts spent on hold

Out Time
Out Hold Time
DND Cnt

The duration of time members spent handling outbound calls (voice only)
The duration of time outbound calls spent on hold, for members (voice only)
The number of times the member entered the Do Not Disturb state
The number of times the member entered the Make Busy state

MKB Cnt

NOTE: This statistic displays information for ACD paths only. Statistics for
Ring Groups will display as '0'.

ACD Cnt

The number of ACD contacts handled by the member

Shrt ACD Cnt

The number of ACD contacts handled by the member where the handle time
was less than the Short Handle parameter

Hold ACD Cnt

The number of times ACD contacts were placed on hold (voice only)

Non ACD Cnt

The number of non-ACD contacts handled by the member (voice only)

Hold Non ACD Cnt The number of times non-ACD contacts were placed on hold
Out Cnt
Out Hold Cnt
Avg Handl

The number of outbound calls made by the member (voice only)
The number of times outbound calls were placed on hold (voice only)
The average amount of time queue members spent handling ACD contacts
(ACD Time divided by ACD Count, excluding ACD Hold Time)
The agent group to which the agent belongs

Agt Grp

Occupancy

NOTE: This statistic displays information for ACD paths only. Statistics for
Ring Groups will display as '0'.
The duration of time the member spent processing contacts

Contacts per Hour

The total ACD contact count minus the ACD short handle count, divided by
the shift time for the member

On failover

Indicates whether the primary media server is offline and has failed over to
the secondary media server (voice only
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Table 21: Queue Now and Queue Group Now member statistic column headings
(continued)
TERM

MEANING

Unavail%

The percentage of time for the shift that the member was in Do Not Disturb,
Make Busy, and Work Timer states

Not Present Time

The duration of time the member was logged into but not present in an agent
group or ring group

External Handle
Duration
External Inbound
Count

External Outbound
Count

The duration of time the member spent handling external calls (voice only)
The number of incoming external calls (voice only)
NOTE: This statistic displays information for ACD paths only. Statistics for
Ring Groups will display as '0'.
The number of outgoing external calls (voice only)
NOTE: This statistic displays information for ACD paths only. Statistics for
Ring Groups will display as '0'.

VIEWING QUEUE CHART STATISTICS
NOTE:
l

You can see queue charts during business hours as long as the business schedule you
configure in YourSite=>Schedule or YourSite Explorer=>Schedules is consistent with your
company’s hours of operation. You assign business-hours schedules to queues in
YourSite=>Configuration=>Queue=>Queue or in YourSite Explorer=>Queues=>Business
Hours.

The following charts display queue statistics:
l

Queue Now

l

Queue Group Now

l

Queue Performance by Period

l

Queue Group Performance by Period

Queue Now and Queue Group Now
The Queue Now and Queue Group Now charts offer visual representation of Queue Now and Queue
Group Now real-time statistics, grouped by the type of statistics displayed. Three different series of
statistics are available to view in charts:
l

Integer—displays numerically-based real-time statistics

l

Percentage—displays percentage-based statistics

l

Time—displays time-based statistics

Users can specify which statistics display in their charts. Figure 41 shows an example of a Queue
Now chart displaying the Integer series with the default statistics selected.
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Figure 41: Queue Now (Integer) chart
The Integer chart shows:
l

Handled (Default)

l

Abandoned (Default)

l

Interflowed (Default)

l

Calls Waiting

l

Agents Available

l

ACD

l

Idle

l

Non ACD

l

Outbound

l

Unavailable

l

Offered

l

Requeue

l

Total Hour

l

Interflowed Last Hour

l

Unavailable Last Hour

l

Offered Last 15 Minutes

l

Handled Last 15 Minutes

l

Abandoned Last 15 Minutes

l

Interflowed Last 15 Minutes

l

Unavailable Last 15 Minutes
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l

Logged out

l

Logged in not present

l

# Handled by 1-4

The Percentage chart shows, by default:
l

Service Level %

l

Handled %

l

% Handled by 1-4

l

% Handled Last Hour

l

Service Level % last Hour

l

% Handled Last 15 Minutes

l

Service Level % Last 15 Minutes

l

%Abandoned

l

%Abandoned Last Hour

l

%Abandoned Last 15 Minutes.

Time charts show, by default:
l

Longest Waiting

l

Average Time to Handle

l

Average Time to Abandon Minutes

l

Average Talk Time

l

Ttl Talk Time

l

Time to Handle Last Hour

l

Average Time to Handle Last Hour

l

Hdnl Last 15 Min

l

Average Handling Time Last 15 Minutes

l

Total work timer minutes

l

Total make busy minutes

l

Total occupancy minutes

For descriptions of the statistics, see "Queue Now and Queue Group Now column heading
definitions" on page 235.
NOTE: The following statistics are for ACD path voice queues only and will not display information
for ring groups:
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l

Requeue

l

# Handled by 1, 2, 3, 4

l

% Handled by 1, 2, 3, 4

l

Total work timer minutes

l

Total make busy minutes

Contact Center Client

Queue Performance by Period and Queue Group Performance by
Period
The Queue Performance by Period and Queue Group Performance by Period charts offer visual
representations of Queue and Queue Group Performance by Period statistics, grouped by the type of
statistic displayed. Three different series of statistics are available to view in charts:
l

Integer—displays numerically-based real-time statistics

l

Percentage—displays percentage-based statistics

l

Time—displays time-based statistics

Figure 42 displays a Queue Performance by Period chat displaying the default statistics of the
Integer series.

Figure 42: Queue Performance by Period chart
The Integer series shows the following statistics across 15 minute intervals for queues or queue
groups:
l

Handled (Default)

l

Interflowed (Default)

l

Offered

l

Short Abandoned

l

Abandoned

l

Requeue

l

# Handled by 1-4
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The Percentage series shows the following statistics across 15 minute intervals for queues or queue
groups, by default:
l

% Handled by 1-4

l

Service Level % Today

l

% Handled

The Time series show the following statistics across 15 minute intervals for queues or queue groups,
by default:
l

Average Time to Handle

l

Average Time to Abandon

l

Average Time to Interflow

l

Ttl Talk Time

l

Average Talk Time

l

Total work timer minutes

l

Total make busy minutes

l

Total occupancy minutes

For more information for the definitions of these statistics, see "Queue by Period column heading
definitions" on page 231.
NOTE: The following statistics are for ACD path voice queues only and will not display information
for ring groups:
l

Requeue

l

# Handled by 1, 2, 3, 4

l

% Handled by 1, 2, 3, 4

l

Total work timer minutes

l

Total make busy minutes

Navigating charts
You can zoom in and out of charts to change how the data is displayed in the chart, expanding or
compressing the displayed data. If the range of data displayed exceeds the boundary of the chart
window in Contact Center Client, you can use the horizontal scroll bar to move back and forth across
the displayed data.
To zoom in on a chart
1. Hold your mouse over the edge of the horizontal scroll bar until the cursor turns into a doublearrow (<->) icon.
2. Click and drag the edge of the horizontal scroll bar towards the opposite side of the scroll bar.
The chart zooms in and the horizontal scroll bar shrinks in size.
NOTE: To undo the zoom function, click Zoom Out.
To zoom out of a chart
1. Hold your mouse over the edge of the horizontal scroll bar until the cursor turns into a doublearrow (<->) icon.
2. Click and drag the edge of the horizontal scroll bar and drag to zoom out.
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To show the entire chart in the window
l

If you are zoomed in, in the chart window click Show All.

To scroll across the chart
l

Click and drag the horizontal scroll bar in the direction you wish to scroll the chart.

VIEWING CALLBACK LISTS WITH THE GLOBAL CALLBACK
MONITOR
If you are licensed with the IVR Routing Advanced Starter Pack or greater, the Global callback
monitor enables system administrators to monitor callback states in real time and displays the
callbacks currently available. Using the Global callback monitor, you can requeue and delete
callbacks. (See Figure 43.)

Figure 43: Global callback monitor
To access the global callback monitor
1. Click the Real Time tab in the Contact Center Client ribbon.
2. Click the Callbacks icon.
The Monitor Callback List displays.
Table 22 describes the Global callback monitor column headings.
Table 22: Global callback column headings
COLUMN HEADING
Caller number
Caller name
Status

DEFINITION
the phone number provided by the caller
the name of the caller
the state of the callback — new request, in progress, requeued,
completed, unknown
the importance level of the callback.
Callback priority levels are:

Priority

Type
Reason

l

Voice — Normal

l

Web — Normal

l

Caller abandoned — Low

the type of callback — voice, web, or caller abandoned
lists why the callback is in a particular status
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Table 22: Global callback column headings (continued)
COLUMN HEADING
Attempted Calls to
Agent

DEFINITION
the number of times the callback was offered to an agent in queue

Last Time Agent
Attempted

the last time the agent attempted the callback

Request Time

the specific time the callback will be executed

Time Received

the specific time the caller submitted the callback request

Web IP Address

the IP address of the caller who submitted the callback request

Last Attempted Call to
Client
Attempted Calls to
Client
Client Available From
Client Available To
ANI
DNIS
Dialable

the specific time the last callback attempt to the caller was made

the number of times the callback was attempted
the earliest time the caller is available to receive the callback
the latest time the caller is available to receive the callback
the phone number of the caller
the phone number the caller dialed
the dialable number of the device that will handle the callback

Device Name

the name of the device that will handle the callback

Device Type

the type of device that will handle the callback — agent, queue, or
extension

Recorded Message

contains a hyperlink to the voice callback .wav file left by the caller

Area
Country
Port
Region

the province/state or other area the call originated from
the country the call originated from
the number of the port attempting to perform the callback
the region the call originated from

Managing callbacks in the Global Callback monitor
The Global callback monitor enables users to requeue, reject, and delete callbacks within the
monitor. Requeued callbacks are re-entered into their queue. Rejected callback are removed from
the queue are will not be offered to employees. Deleted callbacks are removed from the monitor, but
are not removed from the system.
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Users can also adjust a callback’s priority. Callback priority determines the order of which callbacks
will be offered to agents. Callbacks are offered to agents in order of their priority and then by the
longest waiting callback of that priority. For example, High priority callbacks are offered before
Normal priority callbacks, even if the Normal priority callbacks have been in queue longer.
The following procedures explain how to:
l

Requeue a callback

l

Reject a callback

l

Delete a callback

l

Change a callback’s priority

To requeue a callback
1. Right-click a callback and select Requeue.
2. Select Yes.
To reject a callback
1. Right-click a callback and select Reject.
2. Select Yes.
To delete a callback
1. Right-click a callback and select Delete.
2. Select Yes.
To change a callback’s priority
l

Right-click a callback and select Change priority=>[priority level].

VIEWING PORTS
NOTE:
l

You can monitor port states in real time and view currently executing workflows.

l

You can select the ports you want to monitor individually or by hunt group.

l

You can remove ports from Do Not Disturb.

The Port Status monitor displays port information.

Port status monitor
The Port Status monitor enables system administrators to monitor port states in real time and
displays the workflows that are currently executing on ports. Using the Port Status monitor, you can
take ports out of Do Not Disturb and playback historical port events in Auditor mode. (See Figure
44.)
To access the port status monitor
1. Click the Real Time tab in the Contact Center Client ribbon.
2. Click the Ports icon.
The Port status monitor displays.
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Figure 44: Port status monitor
Table 23 describes the Port Status monitor column headings.
Table 23: Port Status column headings
COLUMN
HEADING
Name
Dialable

DEFINITION
the name of the port
the port's dialable number

Extension Type the type the extension — RAD, messaging, callback, or UPiQ
Media Server

the media server to which the port is associated

Hunt Group
Name

the name of the hunt group the port is associated with. A port can be associated
with more than one hunt group

Hunt Group
Dialable

the dialable number of the hunt group

Phone state

the state of the phone — idle, dialing, talking, ringing, or unknown

Workflow name the name of the executing workflow
Phone Display
ANI
DNIS
Redirect
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displays the MiAUDIO state (that is displayed on the phone)
the phone number of the caller
the phone number dialed by the caller
the number of the device the call was directed from
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VIEWING WEBPAGES
While using Contact Center Client, you can view webpages using the Web browser monitor.
To view a webpage within Contact Center Client
1. Click the Real Time tab in the Contact Center Client ribbon.
2. Click the Web icon.
The Web Browser Properties window opens.
3. After Monitor title, type a name for the monitor.
4. After Start URL, type the address of the website to view.
NOTE: The website address must begin with http:// or you will not be able to view the monitor.
5. Optionally, select a value for the Web Browser Refresh Rate.
6. Click OK.

VIEWING AND CUSTOMIZING REAL-TIME MONITORS
NOTE:
l

l

Contact Center Client has a tabbed interface for managing and arranging windows. You can
dock the monitors, displaying them on overlapping tabbed panels to maximize real estate.
This enables you to readily navigate between monitors.
You can save threshold settings and display characteristics you define for monitors. When
you click File=>Save, Contact Center Client saves all open monitors under one profile name.
You can click File=>Open to open another profile, or File=>New to create a new profile.

Opening monitors
To open a monitor in Contact Center Client
1. In the Contact Center Client ribbon, click Real time to view the Contact Center Client monitor
icons.
2. In the State by Position column on the ribbon, click Agent.
This selects the Agent State by Position monitor and the Add/Remove device IDs window
opens.
See Figure 45.
3. Under Agent groups, select agent groups to monitor and/or under Agents, select agents to
monitor.
4. Under Card designs, select a card design.
Card designs specify the information displayed on agent, employee, and extension monitors.
5. Click OK.
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Figure 45: Add/Remove devices

Docking monitors
You can dock monitors and readily navigate between them. You can dock a monitor to the top,
bottom, left, or right of another monitor. Alternatively, you can dock a monitor on the top, bottom, left,
or right side of the Contact Center Client window. You can dock monitors on top of one another,
displaying them on overlapping tabbed panels to maximize real estate.
To dock a monitor on top of another monitor
1. Right-click the title bar of an open monitor and select Dock.
2. Repeat step 1 for all open monitors.
3. Click the title bar of a monitor and drag the monitor on top of a second monitor placing your
cursor in the center of the four-headed arrow that displays.
See Figure 46.
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Figure 46: Docking monitors
4. Release the mouse button.
Your monitors are displayed on overlapping tabbed panels.
See Figure 47.

Figure 47: Docked monitor
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Adding and removing devices
You can add and remove devices from all of the Contact Center Client monitors except for the chart
monitors.
To add devices to the bottom of a monitor
1. Right-click an open monitor and click Add/Remove devices.
2. Under Agent/Employee/Queue groups, select additional agent, employee, or queue groups
to add to the monitor, or under Agents/Employees/Queues, select additional agents,
employees, or queues to add to the monitor.
3. Click OK.
On the Agent State by Position, Employee State by Position, and Extension State by Position
monitors a blank row of cells separates the original agents from those you just added. To
remove the blank row you must sort the monitor.
See "Sorting monitor devices" on page 256.
To remove devices from a monitor
1. Right-click an open monitor and click Add/Remove devices.
2. Under Agents/Employees/Queues, clear the check boxes of the agents, employees, or
queues to be removed.
3. Click OK.
NOTE: You can alternatively add and remove devices via the Monitor Options tab in the Contact
Center Client ribbon for the Queue by Period, Queue Now, and Queue Group Now monitors.

Sorting monitor devices
When you select devices to display on a monitor, you can specify the devices be sorted by media
server (on agent monitors only), ID, or name (alphabetically) in ascending or descending order. When
the monitor opens, the devices display in the order you selected.
To sort the devices displayed on a monitor
l

In the left pane of the Add/Remove devices window, click Media server to sort the members
by media server, click Name to sort the members alphabetically, or click Reporting to sort
the members by ID, in either ascending or descending order.

You can sort information by state, name, agent ID, or extension on the Agent State by Position,
Employee State by Position, and Extension by Position monitors.
To sort agents or employees by state
l

Right-click a monitor and click Sort monitor=>By state.

If you sort agents by state, Contact Center Client displays the agents by state and time in state
across the monitor in the following order:
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l

Ringing

l

ACD

l

ACD Hold

l

Idle

l

Non ACD

Contact Center Client

l

Non ACD Hold

l

Outbound

l

Outbound Hold

l

Do Not Disturb

l

Make Busy

l

System Make Busy

l

Work Timer

l

Unknown

l

Logged Off

To sort agents or employees by name
l

Right-click a monitor and click Sort monitor=>By name.

To sort agents or employees by agent ID
l

Right-click a monitor and click Sort monitor=>By agent ID.

To sort agents or employees by extension
l

Right-click a monitor and click Sort monitor=>By extension.

Rearranging cells
You can rearrange cells on the Agent State by Position, Employee State by Position, and Extension
State by Position monitors.
To rearrange cells
l

On an open monitor, drag a cell to a different position on the monitor.

You can rearrange columns on the Agent Shift, Queue by Period, Queue Now, and Queue Group
Now monitors.
To rearrange columns
1. Right-click an open monitor and click Properties.
2. Click the Layout folder.
3. Click Column order.
4. Click a column header and click the up or down arrow key to change the position of the column
relative to other columns on the monitor.
NOTE: You can alternatively rearrange cells via the Monitor Options tab in the Contact Center Client
ribbon for the Queue by Period, Queue Now, and Queue Group Now monitors.

Setting monitor dimensions
You can specify the numbers of rows and columns of cells to display on the Agent State by Position,
Employee State by Position, and Extension by Position monitors. You can then adjust the table to fit
within the monitor frame.
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To set table dimensions
1. Right-click a monitor and click Set table dimensions.
2. After Columns, type a number.
3. After Rows, type a number.
4. Click OK.
Columns or rows are added or deleted from the monitor. You can redistribute the cells using a
drag-and-drop operation.
To size the table to fit the frame
l

Right-click in any real-time monitor and select Size table to frame.

Hiding monitor columns
On the Agent Shift, Queue by Period, Queue Now, and Queue Group Now monitors, you can hide
specific columns of statistics.
To hide columns
1. Right-click an open monitor and click Properties.
2. Click the Layout folder.
3. Click Column order.
4. In the Visible column, clear the check boxes of the columns you want to hide from view.
NOTE: You can alternatively hide monitor columns via the Monitor Options tab in the Contact Center
Client ribbon for the Queue by Period, Queue Now, and Queue Group Now monitors.

Configuring chart characteristics
Individual charts have a range of configurable characteristics and options that enable users to
customize their chart display.
You can right-click charts to access the following options or select them via the Chart Options tab:
l

Change the chart types

l

Configure the legend

l

Configure the color scheme

l

Enable points labels

l

Modify Properties

Changing chart type
Contact Center Client enables you to configure the type of chart, either column or line, used for your
Queue and Queue Group Performance by Period charts.
Queue and Queue Group Now charts display as bar charts.
1. Right-click on an open By Period chart and click Chart Type.
2. Select the type of chart you want your chart to display.
NOTE: Alternatively, you can change the chart type by selecting an open By Period chart, and
choosing Column or Line from the drop-down list beside Type in the Chart Options tab.
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Configuring the legend
You can choose if your chart has a legend, as well as configure where the legend displays.
To configure the legend
1. Right-click on an open queue chart and click Legend box.
2. Select or deselect Enabled to either display or remove the legend.
3. Right-click on an open queue chart and click Legend box.
4. Click Left, Top, Right, or Bottom to determine where you want the legend box to display.
NOTE: Alternatively, you can configure the legend by selecting an open queue monitor and
accessing options from the Legend section of the Chart Options ribbon.

Configuring the color scheme
You can select the color scheme for the chart.
To configure the color scheme for a chart
1. Right-click on an open queue chart and click Color.
2. Select the color scheme you want to apply to the chart from the list.
NOTE: Alternatively, you can configure the color scheme by selecting an open queue chart and
selecting color options from the drop-down list beside Color in the Chart Options ribbon.

Defining queue chart properties
Under Chart properties, you can select general chart characteristics, such as colors and stacked
effects. You can define series characteristics, such as the type of chart, the fill properties, and the
shape of the bars. In addition, you can define y axis characteristics.
To define queue chart properties
1. Right-click an open queue monitor and click Chart properties.
2. On the General tab, specify general chart characteristics (colors, effects, and 3D).
3. Click the Series tab.
4. Specify series characteristics (chart style, fill style, bar type, and border style).
5. Click the Y Axis tab.
6. Specify axis scale characteristics, label characteristics, and the width and color of the axis
line.
7. Click OK.
NOTE: Alternatively, you can configure queue chart properties by selecting an open queue monitor
and clicking Properties located in the Chart Options ribbon.
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Enabling point labels
You can enable labels for each point in your chart.
To enable point labels
l

Right-click on an open queue chart and click Points labels.

NOTE: Alternatively, you can enable point labels by selecting an open queue chart and clicking
Enabled in the Points Label section of the Chart Options ribbon.

Modifying Properties
Properties controls the way chart data displays. Under Properties, you can
l

Specify the queue chart title

l

Highlight statistics

l

Configure 2D and 3D statistics

l

Animate charts

l

Select call statistics to display

l

Create and modify constant lines

NOTE: You can either right-click an open queue chart to modify properties or select an open queue
chart and choose options via the Properties section of the Chart Options tab.
Specifying the queue chart title
Under Properties, you can specify the title of the queue chart.
To specify the queue chart title
1. Right-click on an open queue chart and click Properties.
2. After Monitor title, select and delete the old chart title and type a new name for the queue
chart.
3. Click OK.
Highlighting statistics
Under Properties, you can enable the highlight feature. When the highlight feature is enabled, and
when you move your cursor over a bar representing a specific call statistic, that bar is highlighted
and the other bars, representing other call statistics, are dimmed.
To highlight statistics
1. Right-click on an open queue chart and click Properties.
2. Expand the Chart properties tree and click General.
3. Select the Highlight check box.
4. Click OK.
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Configuring 2D or 3D chart displays
Under Properties, you can configure whether your chart displays bars in 2D or 3D. By default, your
charts display in 3D.
1. Right-click on an open queue chart and click Properties.
2. Expand the Chart properties tree and click General.
3. Select the 3D check box to enable or disable 3D charts.
4. Click OK.
Animating charts
Under Properties, you can enable the animated feature. When the animated feature is enabled,
changes to chart values actively display. The animated feature is disabled by default.
CAUTION: Enabling the animated feature will result in additional CPU load on the affected
workstation.
To animate charts
1. Right-click on an open queue chart and click Properties.
2. Expand the Chart properties tree and click General.
3. Select the Animated check box.
4. Click OK.
Selecting call statistics to display
Under Properties, you can select call statistics to display. For example, you can add Calls Waiting,
Agents Available, Idle, and Requeued statistics to the Queue Group Now (Integer) chart.
To select call statistics to display
1. Right-click on an open queue chart and click Properties.
2. Expand the Chart properties tree and click Series data.
3. Select the Series data type radio button to define the types of data visible in the chart.
l

Integer

l

Percentage

l

Time

4. If you are selecting call statistics for a Queue or Queue Group Performance by Period chart,
click Time Interval. Select the radio button for the interval you want to use and set the time.
5. Under Visible, select the check box of the data you want to add to the chart.
6. Alternatively, under Visible, clear the check box of the data you want to remove from the
chart.
7. Click OK.
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Creating and modifying Constant lines
Under Properties, you can configure Constant lines. Constant lines are horizontal lines you configure
to display across your chart at set values on the Y-axis, enabling you to clearly see how the data
being displayed in the chart meets with desired values.
To create Constant lines
1. Right-click on an open queue chart and click Properties.
2. Click Chart properties.
3. Click Constant lines.
4. Click Add.
5. Click in the Color box to choose a color.
NOTE: The default constant line color is red.
6. After Text, type the name you want to display beside the constant line in the chart.
7. After Value, type the value you want the constant line to mark.
8. After Width, select the thickness of the line.
9. Click OK.
The Constant line will be added to the list of active Constant lines.
To modify a Constant line
1. Select the Constant line you want to modify and click Edit.
2. After Text, type the name you want to display beside the Constant line in the chart.
3. After Value, type the value you want the Constant line to mark.
4. After Width, select the thickness of the line.
5. Click OK.
To delete a Constant line
l

Select the Constant line you want to delete and click Delete.

Filtering device variables
On the Queue Now, Agent Shift, Queue by Period, and Queue Group Now monitors, you can filter
specific device variables. For example, on the Queue by Period monitor, you could filter the Calls
Offered variable and display statistics for the intervals during which the queue was offered five or
more calls.
To filter variables
1. Right-click a monitor and click Filter device variables.
2. Click Filter data to show, select a variable, select an operand, and type a number.
3. Click OK.
A subset of the data is displayed based on the conditions defined in the filter.
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SETTING ALARMS
You can define alarms to alert you to significant changes in contact center activity. Using the
alarms, you specify performance thresholds for contact center elements, such as queues and
agents, and customize the visual, auditory, or email delivery of alarms. If any availability or
performance issues arise, your alarms deliver a notification enabling you to instantly change agent
and queue availability to adjust to unplanned call volumes.
Client alarms are specific to each computer. To notify you that performance thresholds are not being
met, you can configure alarms so that
l

Monitor cells and statistics change color.

l

A pop-up notification opens on your desktop.

l

A sound prompt, such as a beep or .wav file, plays.

l

You are notified by email.

l

Contact Center Client opens on top of all open applications.

To configure alarms for real-time monitors
1. Add performance thresholds.
2. Specify threshold colors.
3. Specify threshold notification.

Adding performance thresholds
To add performance thresholds so you can monitor alarms
1. Right-click a monitor and click Set alarms.
Alternatively, select an open monitor and click Set alarms in the Alarms column, found in the
Monitor or Chart Options tab in the Contact Center Client ribbon.
The Set alarms window open.
NOTE: You can select the Apply the alarm thresholds to all devices displayed on the
monitor check box to apply the threshold settings for performance variables across all
queues or agents. Alternatively, you can select Apply the alarm thresholds to a specific
list of devices to apply the threshold settings for a performance variable to a list of queues or
agents.
2. Under Devices, select one or more queues or agents or select the Select all check box to
select all queues or agents.
3. In the Performance variables list, select a variable.
4. Under Alarm Thresholds, click Add threshold and type a value for the upper boundary of
the threshold.
The lower boundary cannot be modified. The lower boundary of the next threshold is always
slightly greater than the upper boundary of the previous threshold.
5. Click OK.
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Specifying performance threshold colors
To configure performance threshold colors
1. For the alarm threshold for which you want to specify colors, under Background, click the
arrow.
A color palate opens.
2. Select a color.
3. Under Font color, click the arrow.
A color palate opens.
4. Select the font color for the alarm threshold.
5. Click OK.

Specifying threshold notification
To configure performance threshold sound notification
1. For the alarm threshold for which you want to be notified by a sound, under Sound, select the
check box.
The Sound window opens.
2. Specify the alarm triggering properties.
3. Specify the sound you want played when the alarm is triggered.
4. Click Save.
To configure performance threshold pop-up window notification
1. For the alarm threshold for which you want to be notified by a pop-up window, under Pop-up,
select the check box.
The Pop-up window opens.
2. After Duration, type the number of seconds you want the pop-up alarm to be displayed when
threshold conditions are satisfied.
3. If you want to display the pop-up alarm on top of all of the other applications, select the Keep
this message visible on mouse over check box.
4. Optionally, click the Format font button to specify font attributes for the pop-up alarm
message.
5. In the text box, type the message for the performance threshold and click the Add variable
button to insert performance variables. (for example, type CW P001 = <calls waiting
variable>).
6. Click Save.
To specify that Contact Center Client opens on top of all other applications when a performance
threshold is satisfied
l
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For the alarm threshold for which you want to be notified, under Bring to front, select the
check box.
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To configure performance threshold email notification
1. For the alarm threshold for which you want to be notified, or notify others by email, under
Email, select the check box.
The Email window opens.
2. After Distribution, specify which contacts are to be notified by email when threshold
conditions are satisfied.
See "Emailing reports" on page 314.
3. After Subject, type the subject of the email to be sent (for example, type Calls Wtg in Sales
Queue 1 >10!).
4. In the message box, type the body of the email.
5. Click Save.
Consider the threshold programming in Figure 48. When the number of agents available in the
technical support queue is between 0 and 2, the cell housing the Agents Available statistic is red.
When the number of agents available is between 3 and 4, the cell turns orange. When the number of
agents available is 5 or greater, the cell turns white. In addition, audible alarms and pop-up alarms
display.
To clear any current client alarms in Contact Center Client
l

Right-click the monitor and click Clear alarms.
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Figure 48: Set alarms window

CUSTOMIZING THE INFORMATION DISPLAYED ON
POSITION AND TIME MONITORS
On the agent, employee, and extension by position and by time monitors, real-time information is
displayed in cells (cards). You can select from available card designs, or customize cards to display
specific information.
When you first open an agent, employee, or extension monitor, you can select a card design on the
Add/Remove device IDs window:
l

l

l

266

The Classic card displays the agent state, time in the state, presence, agent/employee name,
agent login ID/employee ID, and extension number (or queue name for voice agents on ACD
or on ACD Hold).
The Caller ID card displays the caller name and number (ANI), the number the
caller/employee dials for incoming/outgoing calls, the state, time in the state, presence,
agent/employee name, agent login ID/employee ID, and extension number (or queue name for
voice agents on ACD or on ACD Hold.
Custom cards you create and share

Contact Center Client

The Caller ID card is the default card design. You can use this card design, or select the Classic
card or a customized card. You can create new card designs or copy existing card designs and
modify them. For example, you can add or remove text and variables from cards and rearrange the
information displayed. You can share card designs with other employees. When you select a card
design for an agent, employee, or extension monitor, it is applied to all monitors of that type.

Selecting and customizing card designs
To select a card design
1. Right-click an open position or time monitor and click Properties.
2. Click Layout=>Card design.
3. Under Design name, select a card design.
4. Click OK.
To customize cards for position and time monitors
1. Under Card design,
l

If you want to create a card design, click New.

l

If you want to edit an existing card design, select a card design and click Edit.

l

If you want to create a card design based on the Caller ID card or the Classic card,
select either card and click Copy.

2. On the New card design window, type the name of the new card design.
3. If you want to share the design with other agents, select Share design.
4. Click OK.
5. Select the card and click Edit.
See Figure 49.
6. After State, select a state for the card design.
You can use the same card design for all states or you can customize cards for specific
states, such as ACD, Idle, Make Busy, and Unknown.
7. Under Fields, select a field type and drag and drop it to the card design.
8. If you want to resize the field, click the field and use your pointer to move or resize the field.
9. If you want to change the properties for a field, click the field and change the properties in the
right pane of Card Designer.
10. If you want to change the size of the card design preview, after Zoom, select a different
magnification value from the list.
11. Add additional fields to the card.
12. Select Copy to if you want to copy the current design to the card of a different state.
13. Click OK.
The new card design displays on the Card design list.
14. Click OK.
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Figure 49: Card Designer window

Defining monitor styles
You can customize the appearance of individual monitor elements. For example, you can configure
the font size and color of column headings or apply a skin of predefined colors and font attributes to
the entire monitor.
To customize the appearance of monitor elements
1. Right-click an open monitor and click Properties.
2. Click General=>General settings.
3. If you want to change the title of the monitor, after Title, type a name.
4. If you want to scroll horizontally on the monitor, select the Enable horizontal scroll bars
check box.
5. If you want to scroll vertically on the monitor, select the Enable vertical scroll bars check
box.
6. If you want to group monitor headings, select the Enable grouping check box.
7. If you want to apply a skin to the monitor, click Layout=>Monitor style.
8. Click Load style and select a skin.
9. Otherwise, under Properties, manually configure the column settings, column font, row
settings, and row-alternate settings.
10. Click OK.
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Adding text to card designs
You can use a text box to add custom text to a card.
To edit text that you have added to a card
1. Select the text box.
Properties displays on the right.
2. Under Properties, in the box to the right of Text, type the text to be added to the card.
3. Click OK.
4. Click OK.

Grouping data
You can group rows of data in the Queue Now monitor, and other monitors that contain columns. For
example, you can group the data by the ACD count statistic and readily see which agents handled
the most calls, and which agents handled the least calls, as illustrated in Figure 50.

Figure 50: Enable grouping
The Enable grouping option displays a grouping panel to which users drag columns. The grouping
order determines the order in which the rows display.
To enable grouping
1. Right-click an open monitor and click Properties.
2. Select the Enable grouping check box.
3. Click OK.
The monitor displays a grouping panel.
4. Drag a column heading to the panel to group by the column heading.
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BUILDING MARQUEE MONITORS
You can build marquee monitors to broadcast real-time statistics and messages and alarm on realtime contact center performance statistics. With marquee monitors and wall-mounted marquee
displays, such as LCD monitors or LED reader boards, you can offer your supervisors and agents
access to important contact center performance metrics.
You can build a marquee monitor to broadcast statistics and messages. To do so, you must
l

Specify styles for the marquee monitor.

l

Configure marquee text and variables.

Configuring marquee monitor styles
To specify attributes for the marquee background
1. Click the Marquee icon.
The Configure marquee window opens.
2. Click Add a message.
The Add a message window opens.
3. Type a name for the message.
4. Under Position, select Top, Right, Left, Center, or Bottom to specify how the message is
to be displayed on the marquee.
5. Click Format marquee.
The Format marquee window opens.
6. After Background color, select a color for the background.
7. After Cell color, select a color for the marquee cells.
8. After Cell size, specify a value for the size of the marquee cells.
9. After Cell spacing, select a value for the space between marquee cells.
10. To specify the marquee text font type and color, click Format font.
The Font window opens.
11. Select font attributes.
12. Click OK.
13. If you want the message and the background of the message to be displayed using pixels,
select the Matrix style check box.
14. Click OK.
15. Click OK.
The marquee displays.
NOTE: You must configure marquee text and variables. See "Configuring marquee text and
variables" on page 271.
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Configuring marquee text and variables
To configure text and variables for the marquee
1. Right-click the marquee and click Configure marquee.
The Configure marquee window opens.
2. In the Message editor text box, type a message to display on the marquee (for example, type
Calls Wtg =).
3. Under Message editor, click the Add variable button.
The Add/Edit variable window displays.
4. Click Add.
The Configure variable window opens.
5. Under Variable types, click the monitor type to which the variable applies.
6. Under Variables, click a variable.
NOTE: The following queue variables will not supply information for ring groups:
l

% Handled by 1, 2, 3, 4

l

Dial Out of queue

l

Requeued

7. Under Devices, select the check box of a device.
8. Under Thresholds, click Add threshold and specify a value for the upper boundary of the
first threshold.
9. Click OK.
10. For the threshold, under Variable, select a color to be displayed in the marquee message
string.
11. For the threshold, under Message, select a color for the text that will precede the variable in
the marquee text string.
12. After Type a name for the variable, type a name.
13. Click OK.
14. On the Configure marquee window, in the Message editor text box, position your pointer
where you want to add the variable.
15. You can add variables at the beginning, middle, or end of message strings.
16. On the Add/Edit variable window, double-click the variable to add it to the message string.
Click the Add variable button.
The Add/Edit variable window opens.
17. Click the Configure transition effects button and select the check boxes for the transition
effects to be included.
18. Click OK.
The marquee displays, showing the text you typed and a real-time value for the performance
variable. You can define additional thresholds for the performance variable, and add additional
variables to the marquee.
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USING CONTACT CENTER CHAT
Contact Center Client provides instant messaging capabilities for both supervisors and agents and
is typically used by contact center employees only. Contact Center Chat provides the online chat
presence of contact center employees, including Online, Offline, and Away. Agents can view the
availability and presence of other contact center employees before they transfer calls or send online
chat messages.
Using Contact Center Chat, you can communicate essential information to one or more agents,
agent groups, or supervisors quickly and securely. You can coach agents and send timely
messages, such as asking an agent to delay going on break when it is busy.
NOTE:
l

You must have a security role that does not restrict you from gaining access to Contact
Center Chat.

l

You must log on to Contact Center Client in order to send and receive online messages.

l

When you receive a message it is displayed immediately on top of all open windows.

l

Contact Center Chat requires server to client hostname resolution to properly function.

Contact Center Chat is enabled by default. If you want to disable Contact Center Chat in YourSite
Explorer, you do so in YourSite=>Site=>Chat Settings. For more information, see "Adding sites" on
page 82.
NOTE:
l

l

l

In order to use Enterprise / Presence Chat integration, you must enable Contact Center Chat
and have Lync open and running.
To integrate Lync with Presence, ‘Synchronize my Lync presence with my ACD state’ must
be enabled in Soft phone configuration. For more information on configuring Soft Phone, see
"Opening the soft phone" on page 424.
If Contact Center Chat is disabled for a particular site all employees associated to that site
will be unable to communicate with each other using Contact Center Client.

Sending a Contact Center Chat message
On an agent, employee, or extension monitor, you can right-click an agent’s cell and click Send
instant message to send an online message to the agent.
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To send a chat message
1. Double-click your presence indicator in Contact Center Client’s Status Bar.
Contact Center Chat opens. (See Figure 51.)

Figure 51: Contact Center Chat
2. Right-click a contact and select Send an instant message.
Alternatively, double-click the contact.
The Conversation window opens.
3. Type a message.
4. Click Send.
To send a chat message while viewing agents on an agent, employee, or extension monitor
1. Right-click a cell in an open monitor and click Send instant message. Alternatively, doubleclick the presence indicator in the agent, employee, or extension`s cell in the monitor.
The Conversation window displays.
2. Type a message.
3. Click Send.
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Adding someone to a conversation
To add someone to a conversation
1. On the Conversation window, click the Add Participants button to join this conversation
icon.
2. Double-click a contact to add the contact to the conversation.
3. Click Send.

Responding to a Contact Center Chat message
Agents and supervisors can receive Contact Center Chat messages only if they are logged on to
Contact Center Client. When someone sends a Contact Center Chat message to you, the
Conversation window opens and a desktop notification appears in the bottom-right of your monitor.
The desktop notification shows the name and presence of the employee contacting you and their
message. Figure 52 illustrates a chat notification.

Figure 52: Desktop Chat notification
To respond to a chat message
1. Type a message.
2. Click Send.
Contact Center Chat sends your response to all chat session participants.

USING CONTACT CENTER CHAT WITH LYNC
NOTE: In order to use Contact Center Chat with Lync, an employee’s email address, as configured
in YourSite Explorer under Employee, must be the same as the SIP address configured in Lync
Server 2010 or Lync Server 2013.
With the addition of Lync Server 2010 or Lync Server 2013, agents and supervisors use Lync Client
as their default instant messaging client. The presence of all company employees is natively
delivered in Contact Center Client. Contact center employees can view the presence of both internal
and external contacts to determine if they are available to communicate. In addition to Available,
Offline, and Away, employees see In a Meeting, Busy, In a call, Do Not Disturb, Be Right Back, and
other Lync presence indicators.
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NOTE:
l

l

l

In order to use Contact Center Chat with Lync, an employee’s email address, as configured in
YourSite Explorer under Employee, must match their Lync client sign-in address.
In order to use Contact Center Chat with Lync, you must enable Contact Center Chat and
have Lync open and running.
To integrate Lync presence with ACD states 'Synchronize my Lync presence with my ACD
state" must be enabled in Soft phone configuration. When this option is selected an agent's
state changes in sync with Lync presence. For example, setting your presence in Lync to Do
Not Disturb will set the agent into a Do Not Disturb state in Contact Center Client. Setting the
Lync presence to Away will set the ACD agent state to Make Busy. For more information on
configuring Soft Phone, see "Opening the soft phone" on page 424.

If an agent views an employee on a real-time monitor and notes the employee is online, the agent
can right-click the employee and send an instant message.
Table 24 provides details on the presence indicators that are available when Contact Center Client is
used in conjunction with Lync Client and Mitel Enterprise Presence / Chat Integration.
Table 24: Lync presence indicator icons
2013
PRESENCE
ICON
(LARGE)

2013
PRESENCE
ICON
(SMALL)

STATUS
TEXT

DESCRIPTION

Available

The contact is online and can participate in
conversations. Users can manually set this status,
but the next automatic state change will override this
setting.
The contact is available, but is engaged by another
activity. Busy contacts will not be routed ACD calls,
but may receive non-ACD calls. Possible activities
include the following:

Busy

In a Call—the contact is in a phone, voice, or
video conversation.
In a Meeting—the Outlook calendar shows that
the contact has a scheduled meeting.
Users can manually set this status.

Do Not
Disturb

The contact is engaged by another activity and is
unavailable. Contacts in Do Not Disturb will neither
receive ACD or non-ACD calls. Users can manually
set this status.
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Table 24: Lync presence indicator icons (continued)
2013
PRESENCE
ICON
(LARGE)

2013
PRESENCE
ICON
(SMALL)

STATUS
TEXT

DESCRIPTION

The contact is likely unavailable. Possible reasons
include the following:
The contact’s computer has been idle for more
than the away time period setting (5 minutes by
default).
NOTE: By default, the transition from Available
to Inactive occurs after 5 minutes. Then, after
five more minutes, the status changes to Away if
there is still no activity on the computer.
Away /
Inactive

The contact’s Outlook calendar or Out of Office
Assistant indicates that they are out of the office.

Be Right
Back

The contact is temporarily unavailable

Off Work

NOTE: As soon as activity is detected on the
contact’s computer, Ignite automatically resets
the presence status to the appropriate state.
The contact has locked their computer.
The contact has manually set their presence to
Away or Be Right Back.
Users can manually set this status.
NOTE: When a user manually sets themselves as
Away, they are still available to receive calls, such as
from a transfer.
The contact is not available. Possible reasons for this
include the following:
The contact has manually set their presence
status to Appear Offline.

Offline

The contact has not signed into Lync.
The contact has blocked you from seeing their
presence status.
Lync is not running on the contact’s computer.

Presence
unknown
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Lync cannot determine the status of the contact. This
status is typically displayed because the contact’s
presence status is unavailable to Lync, such as for a
contact who is part of an organization that is not a
federated partner.

Contact Center Client

Sending an instant message
On an agent or employee monitor, you can right-click an agent or employee’s cell and click Send
instant message to send an online message to the agent or employee. You can also send instant
messages using Microsoft Lync. Using Lync, you can send instant messages to individuals or
multiple contacts. After initiating a conversation, you can invite additional contacts to the
conversation. For instruction in using Lync, consult your Lync documentation.
NOTE: Supervisors send instant messages to contacts or groups of contacts using Contact Center
Client.
To send an instant message while viewing agents on an agent, employee, or extension monitor
l

Right-click a cell in an open monitor and click Send instant message.
A Lync Conversation window opens.

HOT DESKING
When an agent is configured as a Mitel hot desking agent, the agent can sit at any extension on the
network and log on to the extension. After the agent is logged on, the agent takes control of the
extension. The agent's Contact Center Client and soft phone real-time profile settings are available.
Any previous associations with the extension are taken out of service. When an agent logs off, the
agent disconnects from the extension and the default settings for the extension are restored
automatically.

EXTERNAL HOT DESK AGENTS
External hot desk agents can work remotely using, for example, a standard PSTN analog telephone
or a cellular telephone. External hot desk agents are similar to regular hot desk agents with additional
configuration available to specify external number information. To access external hot desk agent
functionality you must configure the following options in the User and Device Configuration form for
the 3300 ICP:
l
l

l

External Hot Desking Enabled: Select 'Yes' to enable external hot desk agent functionality.
External Hot Desking Dialing Prefix: Type the prefix digit(s) required to dial out to the
external hot desk device.
External Hot Desking Number: Type the telephone number of the external hot desk device.
This number will be used by the telephone system to route ACD calls to the external hot desk
agent.
NOTE: The combined length of the external dialing prefix and external number cannot exceed
26 digits.

An agent ID can be associated to only one external dialing number. If an external hot desk agent will
use more than one external device for handling calls they must be associated to one agent ID for
each external dialing number.
An external hot desk agent can either log in externally or internally. When they log in internally
(locally) the telephone system recognizes them as a standard hot desk agent. When they log in
externally the telephone system recognizes them as an external hot desk agent.
WARNING: If an external hot desk agent is using a personal phone to handle calls, incoming calls
that are not answered could reach their personal voicemail.
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NOTE:
l
l

3300 ICP release MCD 5.0+ is required to access external hot desk agent capabilities.
External hot desk agent functionality is only supported for use with hot desk agents, not
traditional ACD agents.

The following options are available for external hot desk agent login:
l
l

l

Log in locally from a MiNET phone: agent displays as a regular hot desk agent
Log in locally from an analog, cellular, or MiNET phone and connect through a loopback trunk:
agent displays as an external hot desk agent
Log in externally from an analog or cellular phone: the agent ID is registered as an external
pivot device number and the external number dialing that has been configured in the telephone
system is overlaid on this external pivot device number. The external number is then used by
the telephone system to deliver ACD calls to the external hot desk agent. The agent displays
as an external hot desk agent.
NOTE: An external hot desk agent can also log in externally by directly contacting a specific
trunk configured for this purpose. In this case, the agent would not need to log in via Contact
Center Client. For more information, log into Mitel Edocs, open the Mitel Communications
Director System Administration Help Tool, and browse to 'External Hot Desking - Operation'.

WALLBOARDER
The WallBoarder application displays real-time performance statistics and text messages on one or
more Spectrum Light Emitting Diode (LED) reader boards (wall signs).

WALLBOARDER PARAMETERS
WallBoarder consists of site(s), sign groups, signs, sign variables, sign messages, and sign plans.

Site
At the Site level, you
l
l

l
l

Add sign groups to your site by clicking Add=>Sign group.
Specify the name of the computer on which the WallBoarder Service is installed on the Edit
WallBoarder Service for tab.
Enable priority messages on the Priority message tab.
View communications between the Enterprise Server Service and the WallBoarder Service on
the Database load log tab.

l

Verify the serial addresses of your wall signs on the Query signs tab.

l

Add sign variables to your site by clicking Add=>Sign variable.

l

Add sign messages to your site by clicking Add=>Sign message.

l

Add sign plans to your site by clicking Add=>Sign plan.

Edit WallBoarder Service for tab
The Edit WallBoarder Service for tab provides the following function:
l
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The WallBoarder Service is installed on the following computer specifies the computer on
which the WallBoarder Service is installed.
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Priority message tab
NOTE:
l

You create priority messages on the Add sign message tab.

l

Priority messages override all of the other messages.

The Priority message tab provides the following function:
l

Enable this priority message for this sign group immediately sends a message to all of the wall
signs in the sign group immediately, overriding any business hour, or scheduled messages.

Database load log tab
Under Diagnostics, the Database load log tab records communications between the Enterprise
Server Collector Service and the WallBoarder Service, and indicates if the WallBoarder Service has
loaded the sign plan configured by the Contact Center Management user.

Query signs tab
Under Diagnostics, the Query signs tab lists the wall signs the WallBoarder Service can locate, and
information relating to these signs. It displays the serial addresses of the wall signs. This can come
in handy.
For example, you have connected a wall sign to Com port 3, have configured the sign and specified
the com port value in WallBoarder, and have reset the wall sign, but it does not display the
messages in the sign plan. Most likely, the serial address of the sign is not the same as that
configured in WallBoarder. The Query signs tab displays the true serial address of the wall sign. You
can easily verify the address and amend the address on the Edit sign tab for the sign.

Sign groups
NOTE: You must create at least one sign group in order to register wall sign addresses. You can
include all of the wall signs under one sign group, or create additional sign groups. Sign groups
dictate which messages are displayed by particular wall signs.
At the Sign group level, you can
l

Edit sign groups on the Edit sign group tab.

l

Define the wall sign refresh interval and reset wall signs on the Advanced tab.

l

Add signs to your sign groups by clicking Add=>Sign.

Sign addresses distinguish wall signs for messaging purposes. Each wall sign has a unique sign
address. You add one or more signs to a sign group. For example, you could add Wall sign 1 to Sign
group 1, and Wall signs 2 to 4 to Sign group 2. You associate each sign group with a sign plan. Using
sign groups and sign plans you can display the same message on one or more wall signs, or display
unique messages on all wall signs.

Edit sign group tab
The Edit sign group tab provides the following functions:
l

Name lists the name of the sign group.

l

Site is the contact center site where WallBoarder is installed.
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Advanced tab
The Advanced tab provides the following functions:
Reinitialize all of the wall signs every x seconds
The Reinitialize all of the wall signs every x seconds field restarts all of the wall signs in the sign
group (clearing all of the sign memory) at the time interval you specify.
Refresh all of the sign messages every x seconds
The Refresh all of the sign messages every x seconds field resends all of the messages to all of the
wall signs in the sign group at the time interval you specify. If you see question marks [???] instead
of statistics on a wall sign, this means the Enterprise Service does not have a value for the variable.
There are two reasons why the Enterprise Service does not have a value for the variable: it is in the
process of loading the variable or the telephone system has not sent any real-time information yet.
Refresh all of the ACD sign variables every x seconds
The Refresh all of the ACD sign variables every x seconds field updates all of the variables on all of
the wall signs in the sign group at the time interval you specify.
Update wall signs in serial for sign messages
The Update wall signs in serial for sign messages check box updates the wall signs in a sign group
individually for sign messages, at the refresh time interval you specify.
Update wall signs in serial for sign variables
The Update wall signs in serial for sign variables check box updates the wall signs in the sign group
individually for sign variables, at the refresh time interval you specify.
Minimum pause time between wall sign updates is x seconds
After WallBoarder sends a message or variable update to a wall sign, the Minimum pause time
between wall sign updates is x seconds field suspends the transmission of subsequent information
to the wall sign for x seconds. Typically you select a value greater than zero only if you have a small
Spectrum reader board, such as the 251C reader board.
Minimum display time for a message is x seconds
After WallBoarder sends a message to a wall sign, the Minimum display time for a message is x
seconds field displays the message for a minimum of x seconds. This ensures you can view the
message for a sufficient amount of time before a subsequent message displays.
Minimum pause time after beep is sent is x seconds
If you select the Beep check box on the Add sign plan tab, the wall sign produces an audible beep
prior to displaying each message. It takes a few seconds for the beep to occur. Therefore, the wall
sign is delayed in receiving messages by a few seconds.
The Minimum pause time after beep is sent is x seconds field suspends the transmission of
messages to the wall sign for x seconds, to accommodate the beep.
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Reinitialize all of the wall signs in this sign group
The Reinitialize all of the wall signs in this sign group command restarts all of the wall signs in the
sign group instantly, clearing all of the sign memory.
Apply to all of the sign groups at this site
The Apply to all of the sign groups at this site command applies the configuration values on the
Advanced tab to all of the sign groups at the site.

Signs
At the Sign level, you
l

Configure sign information on the Add sign tab.

l

Configure sign connectivity information on the Connectivity tab.

l

Reset the wall sign and send a test message to the wall sign on the Tools tab.

l

Add signs to your sign groups by clicking Add=>Sign.

Diagnostics
Under Diagnostics, the following tabs list information pertaining to wall sign function and are used for
trouble shooting purposes:
l

General

l

Properties

l

Tool tab

l

Error reporting

l

Current message tabs

Tools tab
Under Diagnostics, the Tools tab displays wall sign settings and provides the following functions:
l

Reset sign restarts the wall sign and empties the sign memory.

l

Get status displays the latest sign diagnostics.

l

Send test message sends a message to the wall sign to test the connectivity.

Sign messages
At the Sign message level, you
l

l

Compose, test, and save message strings displayed on wall signs on the Add sign message
tab
Message strings indicate to the wall sign how messages are displayed. They are constructed
of
l

Text

l

Queue and queue group performance variables (Variables)

l

Display characteristics (Position, Color, Effects, Special, and Miscellaneous)

Add sign messages to your site by clicking Add.
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Add sign tab
The Add sign tab provides the following functions:
Name
The Name field specifies the name of the sign.
Sign address
The Sign address field specifies the address of the wall sign. Each wall sign has a unique address.
You use a keypad provided with the master sign to set the internal addresses of your signs. The
addresses distinguish wall signs for messaging purposes. If you have one wall sign only, its address
is 00. If you have more than one wall sign, then the address of the master sign is 01.
NOTE: When you assign serial addresses to your Spectrum wall signs using remote or software
spectrum tools, you must specify sign addresses greater than 9 as hexadecimal variants. For
example, the following decimals are converted to hexadecimal: 10 = a, 11 = b, 12 = c, 13 = d, 14 = e,
15 = f.
Sign group
The Sign group field specifies the sign group to which the sign belongs.
Connectivity tab
NOTE: The default data bits, parity bit, and stop bits Com port settings for newer Spectrum IP/Serial
wall signs are 8, None, 1. In the past, the default Com port settings were: 7, Even, 2. If you select
one set of Com port values and the wall sign does not display information, try selecting the other set
of Com port values, or refer to the Spectrum documentation to verify the correct default Com port
settings.
The Connectivity tab provides the following functions:
l

Com port or TCP/IP specifies the sign connectivity. The default value for Com port is 1.

l

The default value for Baud rate is 9600.

l

The default value for Data bits is 8.

l

The default value for Parity bit is None.

l

The default value for Stop bits is 1.

l

TCP specifies the TCP/IP address of the wall sign.

l

DNS specifies the name you assigned the wall sign on the network.

l

Port specifies the port number used by the wall sign.

l

Sign memory specifies the memory capacity of the sign (typically 32k).

l
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Reset this wall sign when it does not respond and at midnight resets the wall sign. When the
WallBoarder Service restarts, it queries the wall sign for the information listed on the sign
Diagnostics tabs. If it does not get an answer, it resets the wall sign.
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Add sign message tab
The Add message tab provides the following functions:
l

Name specifies the name of the message.

l

Site is the contact center site where WallBoarder is installed.

l

Test message sends the message to the wall sign so you can verify it works.

Variables
You associate a queue, queue group, or agent group, and a performance variable with the sign
variable on the Variable tab. You specify display characteristics and color-coded alarm thresholds.
When you incorporate a sign variable, such as Sign Variable 6, in a message string, the real-time
value of the associated performance variable is displayed.
Position
The Position tab specifies the vertical position of the message string on the wall sign. If you do not
specify the text position, the wall sign defaults to the fill mode. The message enters the wall sign
from the upper left corner and scrolls to fill up to three rows of text. If you specify the text position, do
so before you set other display features.
Color
The Color tab specifies the color of the text you type in the message string, and the color of any predefined text and graphics you select on the Special tab. You can specify different colors for each
word in the text string. If you specify text coloring, do so after specifying text positioning, but prior to
specifying other display features. Some Spectrum signs offer more color choices than other
Spectrum signs. Please refer to the Spectrum product brochure for more information.
Effect
The Effects tab specifies how messages move across wall signs. If you do not specify effects, the
wall sign defaults to the Automode option. Automode produces random message display formats,
such as message strings that flash or roll to the left.
Special
The Special tab provides display features and illustrations you can add to message strings.
Misc
The Misc (Miscellaneous) tab specifies the speed at which WallBoarder displays message strings,
the size of message string text, the display time and date, and other features.

Sign variables
At the Sign variable level, you
l

Associate a queue or queue group, and a performance variable with the sign variable on the
Add sign variable tab.

l

Define and save display characteristics for sign variables on the Advanced tab.

l

Add sign variables to your site by clicking Add.
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Add sign variable tab
The Add sign variable tab provides the following functions:
l

Name specifies the name of the sign variable.

l

Site is the contact center site where WallBoarder is installed.

l

l

l

Select a device type group specifies the device type (queue or queue group) you will associate
with the sign variable.
Select a device specifies the device you will associate with the sign variable (for example,
Queue Group 1).
Select a variable type specifies the performance variable you will associate with the sign
variable (for example, Agents on ACD).

Advanced tab
The Advanced tab provides the following functions:
l

l

Select display options for this variable specifies the number of characters reserved for a
performance variable in the message string. It centers, left-justifies, or right-justifies the
performance variable within the variable string position.
Enable variable color based on these thresholds defines color-coded alarms for performance
thresholds for the variable.

Sign plans
The WallBoarder Service displays messages in the following order:
1. Priority messages
2. Business-hour messages
3. Scheduled messages
4. Sign plan messages
5. Default sign plan message
At the Sign plan level, you
l

Create a sign plan.

l

Associate the sign plan with a sign group.

l

Specify up to five statements (conditions) for the sign plan on the Add sign plan tab.

l

Specify the hours of operation for your business on the Business hours tab.

l

Schedule messages to be displayed on the Scheduled messages tab.

When you configure a sign plan, you can configure up to five messages for a sign group. The
conditions, or values, of variables dictate which message strings WallBoarder displays, and the
priority in which WallBoarder displays them. If none of the conditions are satisfied, WallBoarder
displays the default message on all of the wall signs. The default message can be a message
congratulating agents, or informing them of an upcoming meeting or other need-to-know information.
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Add sign plan tab
The Add sign plan tab provides the following functions:
l

Name specifies the name of the sign plan.

l

Sign group specifies the sign group to which the sign plan applies.

l

l
l

l
l

l

If check boxes activate conditional messages. You can specify up to five statements
(conditions). Conditions dictate which message strings WallBoarder displays, and the priority
in which WallBoarder displays them.
Sign variable specifies the sign variable to display for the current (active) condition.
Evaluates to specifies the value, above or below which, WallBoarder displays the message
string associated with the sign variable for the current condition.
Play message specifies the sign message to display for the current (active) condition.
Beep programs the wall sign to produce an audible beep prior to displaying a message for a
satisfied condition.
Default message to play if no variables have triggered a message to play specifies a default
message to display on the wall sign. WallBoarder displays the message during periods when
the defined conditions ('If' statements) are not satisfied for the sign group. That is, when call
center performance objectives are being met.

Business hours tab
The Business hours tab provides the following functions:
l

Outside business hours display this message specifies which message is displayed on the
wall signs after business hours.

l

Business-hours schedule for this sign plan specifies the hours of the day for the sign plan

l

Manage schedule creates and edits business hour schedules.

l

Apply this business-hours schedule to all of the sign plans at this site applies the schedule to
all of the sign plans at your contact center site.

The Scheduled messages tab provides the following function:
l

Play this message during these hours specifies the message to be displayed and the
schedule for displaying the message.

NOTE: You create schedules under YourSite=>Schedule.

CONNECTING SPECTRUM WALL SIGNS
If you have multiple wall signs, you can daisy chain the wall signs together. Figure 53 illustrates the
connectivity between the Enterprise Server and the master sign (Wall sign 1). The Enterprise Server
connects to the master sign over an RS-232 25-pin cable, an RS-485 converter, and RS-485 RJ-11
cabling. The master sign connects to slave signs over RS-485 cabling. In this setup, one Enterprise
Server com port is dedicated to your wall signs.
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Figure 53: Setting up Spectrum wall signs
If you do not want to dedicate an Enterprise Server com port to your wall signs (or you simply need
another computer to connect to a wall sign), you can hook up your wall sign(s) to a client computer.
You click Help=>Software downloads/Installations=>Remote Server installation and install a
remote media server (data collection point) on a client computer. The computer connects to the
master wall sign over an RS-232 25-pin cable, an RS-485 converter, and RS-485 RJ-11 cabling, as
in the proceeding setup. In this setup, one client computer com port is dedicated to your wall sign(s).
The new Spectrum IP wall signs plug into a network jack on the wall, just like your network printer.
Each wall sign has a unique sign address. You add one or more signs to a sign group. For example,
you could add Wall sign 1 to Sign group 1, and Wall signs 2 to 4 to Sign group 2. Keep in mind that all
of the signs in the same sign group, display the same messages. You associate each sign group
with a sign plan. Using sign groups and sign plans, you can display the same message on one or
more wall signs, or display unique messages on all of the wall signs.

286

WallBoarder

CONFIGURING WALL SIGNS AND WALL SIGN MESSAGES
To configure wall signs and wall signs messages
1. For each site, select the computer on which the WallBoarder Service is installed.
See "Selecting the computer on which the WallBoarder Service is installed" on page 287.
2. Add sign group(s). (In the tree under Site, click Add=>Sign group.)
See "Creating sign groups" on page 288.
3. Add sign(s) to sign group(s) and send a test message to test the sign connectivity. (In the tree
under Sign group, click Add=>Sign.)
See "Adding signs to sign groups" on page 290.
4. Configure sign variables to use in sign plans. (In the tree under Site, click Add=>Sign
variable.)
See "Configuring sign variables" on page 291.
5. Configure sign messages to use in sign plans and test the messages. (In the tree under Site,
click Add=>Sign message.)
See "Configuring sign messages" on page 292.
6. Add and configure a sign plan for each sign group. (In the tree under Site, click Add=>Sign
plan.)
See "Creating sign plans" on page 293.
Optionally, users can
l

l

Activate priority messages
See "Activating priority messages" on page 296.
Schedule messages
See "Scheduling messages" on page 297.

Selecting the computer on which the WallBoarder Service is installed
To select the computer on which the WallBoarder Service is installed
1. Under Enterprise, click WallBoarder.
2. Expand the Enterprise tree and click the name of your site.
3. The Edit WallBoarder Service for tab opens.
See Figure 54.
4. Under Select the count down number, select the how often the WallBoarder service
queries the Wallboard for information.
5. After The WallBoarder Service is installed on this computer, select the computer on
which the WallBoarder Service is installed.
6. Click Save.
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Figure 54: Edit WallBoarder Service for Default Site Demo tab

Creating sign groups
NOTE: You must create at least one sign group in order to register wall sign addresses. You can
include all of the wall signs under one sign group or create additional sign groups. Keep in mind that
all of the signs in the same sign group display the same messages.
Sign addresses distinguish wall signs for messaging purposes. Each wall sign has a unique
address. You set the internal sign addresses using the keypad provided with the master sign and
register the sign addresses in WallBoarder on the Edit sign tab.
Each sign group has one or more signs. For example, you can specify that Sign group 1 provide realtime displays for Wall sign 1, Sign group 2 provide real-time displays for Wall signs 2 to 4, and so on.
You associate each sign group with a sign plan. Using sign groups and sign plans, you can display
the same message on one or more wall signs or display unique messages on all of the wall signs.
Sign groups dictate which messages are displayed by particular wall signs.
Sign groups dictate which messages are displayed by particular wall signs.
To add a sign group and specify sign group information
1. Under Enterprise, click Wallboarder.
2. Click the name of your site.
The Edit WallBoarder Service for tab opens.
3. Click Add=>Sign group. The Add sign group tab opens.
See Figure 55.
4. After Name, type the sign group name.
5. After Site, select the contact center site where WallBoarder resides.
6. Click the Advanced tab.
7. After Reinitialize all wall signs every, select a time interval for restarting all of the wall
signs in the sign group.
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8. After Refresh all sign messages every, select a time interval for resending all of the
messages to all of the wall signs in the sign group.
If you see question marks [???] instead of statistics on a wall sign, this means the Enterprise
Service does not have a value for the variable. The Enterprise Server does not have a value
for the variable because it is in the process of loading the variable, or the telephone system
has not sent any real-time information yet.
9. If you are using an older sign and want to send messages to signs in text format rather than
binary, select Send sign messages in uncompressed format.
10. After Refresh all ACD sign variables every, select a time interval for updating all of the
variables on all of the wall signs in the sign group.
11. If you are using an older sign and want to send ACD sign variables to signs in text format
rather than binary, select Send sign messages in uncompressed format.
12. After Minimum pause time between wall sign updates is, select a time interval for
pausing between wall sign updates.
13. After Minimum display time for a message is, select a time interval for displaying a wall
sign message.
14. After Minimum pause time after beep is sent in, select a time interval for pausing after a
beep is sent.
15. If you want to reinitialize all of the wall signs, click Reinitialize all wall signs in this sign
group.
16. Click Save.
To apply a sign group's settings to all sign groups at a single site
1. Under Enterprise, click Wallboarder.
2. Click the name of the site.
3. Click the sign group.
4. Click the Advanced tab.
5. Click Apply to all sign groups at this site.

Figure 55: Add sign group tab
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Adding signs to sign groups
NOTE: You can add one or more signs to a sign group. Keep in mind that all of the signs in the same
sign group, display the same messages.
To add signs and specify sign information
1. Under Enterprise, click Wallboarder.
2. Click a site.
3. Click a sign group.
4. Click Add=>Sign.
The Add sign tab opens.
5. After Name, type the sign name.
6. After Sign address, select the address for the sign (for example, type 1).
You set the internal sign addresses using the keypad provided with the master sign, and
register the sign addresses in WallBoarder in the Sign address field.
7. After Sign group, select the sign group to which the sign belongs.
8. Click the Connectivity tab.
NOTE: The default data bits, parity bit and stop bits Com port settings for newer Spectrum
IP/Serial wall signs are 8, None, 1. In the past, the default Com port settings were: 7, Even, 2.
If you select one set of Com port values and the wall sign does display information, try
selecting the other set of Com port values, or refer to the Spectrum documentation to verify
the correct default Com port settings.
9. If you click Com port, accept the default settings for Com port, baud rate, data bits, parity bit,
and stop bits.
10. If you click TCP/IP, click TCP and specify the TCP/IP address of the wall sign, or click DNS
and specify the name you assigned the wall sign on the network.
11. If you selected TCP/IP, after Port, specify the port number used by the wall sign.
12. After Sign memory, select the memory for the sign based on manufacturing specifications.
13. Optionally, select the Reset this wall sign when it does not respond and at midnight
check box.
14. Click the Diagnostics tab.
15. Click the Tools tab.
See Figure 56.
16. To restart the wall sign and empty the sign memory, click Reset sign.
17. To display the latest sign diagnostics, click Get status.
18. To verify the wall sign setup, type a message and click Send test message.
19. Click Add=>Sign and repeat steps 4 to 12 to add additional signs to the sign group.
20. Click Save.
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Figure 56: Diagnostics tab

Configuring sign variables
You define and save display characteristics for sign variables (performance variables associated
with a particular queue or queue group) on the Add sign variable tab.
To configure sign variables
1. Under Enterprise, click Wallboarder.
2. Click +, located beside local site.
3. Click Sign variables.
The Add sign variable tab opens.
See Figure 57.
4. After Name, type a meaningful name for the sign variable (for example, type Calls waiting P800).
The name will display in a list of sign variables on the Message tab.
5. After Site, select the contact center site where WallBoarder resides.
6. After Select a device type, click a device type.
7. After Select a device, select a device.
8. After Select a variable type, select a performance variable (for example, select Abandoned).
9. Click the Advanced tab.
NOTE: Some performance variables require a display width of eight characters. For example,
WallBoarder displays the Average Speed of Answer Today in hh:mm:ss. If you select a value
less than 8 for the width, the at symbol @ will display on the wall sign in place of the Average
Speed of Answer Today statistic.
10. After Select display options for this variable, click Left, Center, or Right to left-justify,
center, or right-justify the performance variable within the variable string position, and accept
the default value for the width of displayed characters.
11. After Width, select the width of displayed character.
12. To enable different colors to be displayed for different performance thresholds, select Active.

291

Contact Center Solutions User Guide

13. After If the value is less than, specify the threshold and select a color from the drop-down
list.
14. If a second threshold is wanted, after the second If the value is less than, specify the
threshold and select a color from the drop-down list.
15. After Otherwise use this color, select a color from the drop-down list for the variable when it
is not within the thresholds.
16. Click Save.

Figure 57: Add sign variable tab

Configuring sign messages
You compose, test, and save message strings displayed on wall signs on the Add sign message
tab. Message strings indicate to the wall sign how messages are displayed. They are constructed of
performance variables, text, display features, and optionally graphics.
Consider the message strings defined in Figure 58. WallBoarder displays the first message string on
the top line [PS02-Top Line] of the wall sign. It displays the Long Call Wtg = component of the
message string in red [C001-Red]. The message string flashes [MO03-Flash] across the sign at
display speed 2 [MI06-Display Speed 2]. It is comprised of text you type (Long Call Wtg =) and Sign
variable 1 [VA01-Calls], that displays the real-time value for the longest waiting caller performance
variable. The color of the sign variable statistic changes with the wait time of the longest waiting
caller, as per the threshold settings defined on the Variable tab.
To create sign messages
1. Under Enterprise, click Wallboarder.
2. Select a site.
3. Click Sign messages.
See Figure 58.
4. After Name, type the message name.
The name will display in a list of sign messages on the Plan tab.
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5. After Site, select the contact center site where WallBoarder resides.
NOTE: If you do not select display attributes, WallBoarder will post the message using default
display attributes.
6. Click the Position, Color, Effect, Special, and/or Misc tabs and double-click display
attributes to select them.
7. Type a message.
8. Click the Variables tab and double-click a variable to select it.
9. Click Send test message.
Confirm the message displays on the wall sign correctly.
10. Click Save.

Figure 58: Add Sign Message tab

Creating sign plans
You associate each sign group with a sign plan. Using sign groups and sign plans, you can display
the same message on one or more wall signs, or display unique messages on all of the wall signs.
All of the signs in a sign group display the same messages.
If you have two wall signs (that are not daisy chained together) and you want to display the same
messages on both signs, you create one sign group, add both signs to it, and associate the sign
group with a sign plan. The serial addresses do not need to be unique in this case, as you are
communicating with each sign on a dedicated connection (for example, one sign may be connected
to a comport, and the other sign to the network using IP).
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You dictate the messages displayed by particular wall signs on the Add sign plan tab. You can
specify up to five statements (conditions) using sign groups. Conditions dictate which message
strings WallBoarder displays and the priority in which WallBoarder displays them. If none of the
conditions are satisfied, WallBoarder displays the default message on all of the wall signs in the sign
group. The default message can be a message congratulating agents, or a message informing them
of an upcoming meeting or other need-to-know information.
Consider the conditions defined in Figure 59:
l

l

l

The first condition specifies 'If Sign variable 1 (the calls waiting in P800) exceeds 10, play
Sign message 01'.
The second condition specifies 'If Sign variable 2 (the agents logged on to P008) exceeds 45
seconds, play Sign message 02'.
The third condition specifies 'If Sign variable 3 (the longest waiting caller in P008) drops below
6, play Sign message 03.'

Figure 59: Add sign plan tab

Creating sign plans for daisy-chained signs
If your wall signs are daisy chained together and you want to display the same messages on all of
the wall signs, you create one sign group, add your signs to it, and associate the sign group with a
sign plan. The wall signs share the same com port, but have unique serial addresses.
If your wall signs are daisy chained together and you want to display unique messages on all of the
wall signs, you must create one sign group for each sign in the chain, and associate each sign group
with a unique sign plan. The wall signs share the same com port, but have unique serial addresses.
To create a sign plan
1. Under Enterprise, click Wallboarder.
2. Select a site.
3. Click Sign plan. The Add sign plan tab opens.
See Figure 60.
4. After Name, type the plan name.
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5. After Sign group, select the sign group to which you will apply the sign plan.
6. Select the If check box to define the first conditional message for the sign plan.
7. Under Sign variable, select a sign variable.
8. Under Evaluates to, specify the threshold, above or below which, a sign message is
displayed.
9. Under Play message, select a sign message.
10. If you want an audible alarm to accompany the message, select Beep.
11. If you want additional conditional messages for the sign plan, repeat steps 6-10.
12. Click the Business hours tab.
13. After Outside business hours display this message, select a message to be displayed on
the wall signs after business hours.
NOTE: Business-hour messages override scheduled messages.
14. After Business hours schedule for this sign plan, select a schedule that defines the hours
of operation for your business.
15. If you want to apply the schedule to all of the sign plans at your contact center site, select
Apply this business-hour schedule to all of the sign plans at this site.
16. Click Save.

Figure 60: Add sign plan tab
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Activating priority messages
NOTE:
l

You create priority messages on the Add sign message tab.

l

Priority messages override all of the other messages.

To activate a priority message
1. Under Enterprise, click Wallboarder.
2. Select a site.
3. Click the Priority message tab.
See Figure 61.
NOTE: When you enable a priority message, WallBoarder displays the message on all of the
wall signs until you manually clear the Enable this priority message check box.
4. To send a priority message, select Enable this priority message and select a priority
message from the drop-down list to display on all of the wall signs at the site.
5. If you want an audible alarm to accompany the priority message, select Beep when this
priority message is played.
6. Click Save.

Figure 61: Priority message tab
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Scheduling messages
NOTE:
l

You can create schedules under YourSite=>Schedule.

l

Business-hour messages override scheduled messages.

You can schedule specific messages to play according to schedules.
To schedule a message
1. Under Enterprise, click Wallboarder.
2. Select a site.
3. Select a sign plan.
4. Click the Scheduled messages tab.
See Figure 62.
5. Select a check box to activate a schedule.
6. Select Play this message to activate the message.
NOTE: When you enable a scheduled message, WallBoarder displays the message on all of
the wall signs in the sign group (associated with the sign plan) until you manually clear the
Play this message check box.
7. After Play this message, select a message from the drop-down list.
8. After according to this schedule, select a schedule.
9. Click Save.

Figure 62: Scheduled messages tab
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TROUBLESHOOTING REAL-TIME ISSUES
The following information pertains to Contact Center Client, Interactive Contact Center, and Contact
Center Chat with Lync.

INTERACTIVE CONTACT CENTER AND RESILIENCY
When the collector is started while the telephone system is in resilient fail-over mode, Interactive
Contact Center device control will not function. If this happens, the Do Not Disturb status of the
queue in the Queue Now monitor will not update.

ENABLING CONTACT CENTER CHAT WITH LYNC
If you want to use Lync as your default instant messaging client and view enhanced presence on
real-time monitors, you must enable Contact Center Chat with Lync.
To enable Contact Center Chat with Lync
1. In YourSite Explorer, click YourSite=>Site.
2. After Chat settings, select the Chat Enabled check box.
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REPORTS
The Reporter application provides detailed performance statistics on your enterprise. You can use
Reporter to produce on-demand reports and automated, scheduled reports. You can generate reports
for a variety of intervals, for example by day of the week or by 15, 30, or 60 minute intervals, and for
over-midnight shifts. You can create presentation-quality tables and charts in Microsoft Excel or
Adobe Acrobat .pdf format.
The raw media server data is analyzed with respect to the YourSite Explorer configuration. The
statistical data is then written to Structured Query Language (SQL). This statistical data populates
the reports.

UNDERSTANDING REPORTS
To create meaningful reports you must understand reporting concepts.
Service Level is the standard measurement of customer service because it provides the most
accurate representation of the customers’ experience. An appropriate Service Level objective is one
that
l

Satisfies customers’ expectations for service

l

Keeps abandonment in check (at less than five percent)

l

Minimizes expenses and maximizes revenue

l

Meets with the approval and support of queue members, supervisors, and senior management

Understanding the following terms will help you define your corporate Service Level objective.
Offered
Offered contacts are contacts received by the ACD queue, regardless of how they are handled or
routed. Offered contacts include handled contacts, abandoned (long) contacts, and interflowed (long)
contacts. However, ACD requeued contacts, queue unavailable contacts, and abandoned (short)
contacts are not considered to be offered contacts.
Handled
Handled contacts are contacts that have been opened or, in the case of calls, answered. Calls that
listen to in-queue RAD messages are not considered to be handled until a queue member connects.
If a queue member answers a call and then forwards it to another queue member or supervisor before
the Short Handle time threshold, the call is classified as an ACD Short Handle Call. You can define
the Short Handle time threshold for queues.
Abandoned
Abandoned contacts are contacts terminated before being answered. An abandoned chat is one that
does not reach an agent because the client ended the chat session before the agent opened it.
Abandoned (short) contacts are contacts abandoned before the Short Abandon time for the queue
expires. Abandoned (long) contacts are contacts abandoned after the Short Abandon time for the
queue expires. Abandoned statistics are not applicable to email.
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Interflowed
Interflow is a mechanism that directs a contact in queue to another answering point. For example, a
call sent from one queue to another queue or to voicemail is interflowed. Interflowed contacts
includes those transferred manually from the queue. Contacts routed from queues to other
answering points before the Short Abandon time are not included in Interflow statistics.
Service Level Time
Service Level Time is the time used in calculating the Queue Service Objective. For example, your
Queue Service Objective may require queue members to handle 80% of contacts within 120
seconds. 120 seconds is the Service Level Time. Queue Service Objectives, which includes
Service Level Time, are specified for individual queues.
Service Level Count
Service Level Count is the number of contacts sent to the queue that were either handled,
abandoned, or interflowed within the specified Service Level Time.
Service Level Percent
Service Level Percent is the Service Level Count ÷ ACD contacts offered
For calls and chats, the Service Level Percent is the number of contacts which are handled,
abandoned, and interflowed before the Service Level Time, compared to the total number of contacts
handled, abandoned, and interflowed. The Service Level Percent = (Handled + Abandoned (Long) +
Interflowed (Long)) within the Service Level time ÷ Total (Handled + Abandoned (Long) + Interflowed
(Long)).
For emails, the Service Level percent is the number of contacts handled and interflowed before the
Service Level Time, compared to the total number of contacts handled and interflowed. The Service
Level Percent = (Handled + Interflowed (Long)) within the Service Level Time ÷ Total (Handled +
Interflowed (Long)).
In Figure 63, the Service Level objective is to handle 80 percent of calls in less than 30 seconds.
Calls that wait in queue for 60 seconds are routed to voicemail.
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Figure 63: Service Level Percent

SETTING THE SERVICE LEVEL OBJECTIVE
An appropriate Service Level objective is one that
l

Satisfies customers’ expectations for service

l

Keeps abandonment in check (at less than five percent)

l

Minimizes expenses and maximizes revenue

l

Meets with the approval and support of queue members, supervisors, and senior management

Voice queue Service Level objective
You set the queue Service Level objective in YourSite Explorer=>YourSite=>Queues.
The voice statistics defaults are
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l

Service Level goal = 80%

l

Service Level time = 20 seconds

l

Short abandon threshold = 6 seconds

l

Short Handle threshold = 20 seconds
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l

Overflow is set at the telephone system switch and there is no default

l

Interflow is set at the telephone system switch and there is no default

l

Work Timer is set at either the telephone system switch (Class of Service Work Timer) or on
the queue. The default on the queue is 5 minutes.

Multimedia queue Service Level objective
You set the queue Service Level objective in YourSite Explorer=>YourSite=>Queues.
The multimedia statistics defaults are
l

Service Level goal = 80%

l

Service Level time = 2 minutes

l

Short abandon threshold (not applicable to email) = 6 seconds

l

Short Handle threshold = 20 seconds

l

l

l

Overflow is set in multimedia workflows, via the Offer to Agent Group activity. See the
Multimedia Contact Center Installation and Deployment Guide for more information.
Interflow is set in multimedia workflows, via the Interflow activity. See the Multimedia Contact
Center Installation and Deployment Guide for more information.
Work Timer = 5 minutes.

REPORT TYPES
For a complete description of report types and fields, see the reports guide appropriate to your edition
of Contact Center Solutions.
The Contact Center Management report types include Administrative, Voice, Lifecycle, Email, Chat,
Multimedia, Workforce Scheduling, IVR Routing, Traffic Analysis, and Workflow reports. Some
report availability depends on licensing.
Administrative reports
Administrative reports consists of the Employee Profile report. It provides configuration data and
contact information on each employee.
Voice reports
Voice reports provide detailed information about call performance. You can run the following voice
reports: Account Code, Agent/Agent Group, Queue/Queue Group, Extension, Trunk,
Employee/Employee Group, Team, DNIS, and Forecast.
Lifecycle reports
Lifecycle reports provide detailed information on all of the events related to the life of a specific call,
from the moment the call enters the telephone system to call termination. You can generate
Lifecycle reports on selected items and devices, and can filter Lifecycle reports by a number of
criteria. If you have clustered your enterprise into a single site, you can run a Lifecycle report on site
to report on your entire enterprise. Lifecycle reports also include call notes and links to call
recordings. For detailed information on configuring Lifecycle reports, see the Contact Center
Management Installation Guide.
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NOTE:
l

l

Lifecycle reports containing data for internal transferred ACD calls will not link data properly
unless the Call ID feature on the telephone system is enabled.
If you have a Network ACD environment with telephone systems in the same time zone, you
must synchronize telephone system clocks to ensure Lifecycle report accuracy.

Email reports
Email reports provide detailed information about email performance. Email reports can be generated
on the following devices: Agent, Agent Group, Queue, and Queue Group. Email reports are available
if you are licensed for Multimedia Contact Center.
Chat reports
Chat reports provide detailed information about chat performance. Chat reports can be generated on
the following devices: Agent, Agent Group, Queue, and Queue Group. Chat reports are available if
you are licensed for Multimedia Contact Center.
Multimedia reports
Multimedia reports provide detailed information across media types: voice, email, and chat.
Multimedia reports can be generated on the following devices: Agent Group, Employee Group, and
Queue Group. Multimedia reports are available if you are licensed for Multimedia Contact Center.
IVR Routing reports
IVR Routing reports provide historical data on devices key to IVR Routing. You can generate
IVR Routing Callback, Port, DNIS, and Hunt Group reports. Multimedia reports are available if you
are licensed for IVR Routing.
Traffic Analysis Reports
Traffic Analysis Reports provide detailed information about trunk traffic. You can generate Traffic
Attendant reports, Traffic DTMF Receiver Group reports, Traffic Route reports, and Traffic Trunk
reports.
Workflow reports
Workflow reports summarize data on IVR Routing and Multimedia Contact Center workflows.
Workflow reports can be generated for Workflow Conditions, if you are licensed for IVR Routing or
Multimedia Contact Center.
Workforce Scheduling reports
Workforce Scheduling reports provide detailed information about schedules, enabling supervisors to
schedule employees efficiently and cost-effectively. Schedules, Employee Portal, and Schedule
Adherence reports are available if you are licensed for Workforce Scheduling.
Business Reporter reports
Contact Center Management with Business Reporter reports provide detailed information about call
costing, extension, trunk, and queue statistics. Detailed information on the reports available is
contained in the Business Reporter Reports Guide.
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Custom Reports
Custom Reports are a collection of reports based on specific customer requests. Custom reports are
available if you are licensed for them.

TOP FIVE RECOMMENDED REPORTS
We recommend that every contact center use the following top-five reports:
Queue Performance by Period
The Queue Performance by Period report shows traffic level highs and lows and the Service Level
you provide at these times. Generate this report each day and watch for trends in the traffic level,
abandon rate, and Service Level %.
Queue Group Performance by Queue
The Queue Group Performance by Queue report compares the workload distribution across the
queues in a queue group for a specified period.
Queue Group (Answer, Handle, Abandon) Spectrum by Queue
The spectrum reports provide valuable information on how contacts are dispersed in your contact
center. You can configure answer, handle, and abandon thresholds, and describe the percent
breakdown by time for
l

l

l

Contacts Answered - Which contact waited in queue the longest before it was answered or
opened? How quickly are most contacts answered or opened?
Contacts Handled - How many contacts were handled for the queue? What was the greatest
duration for which a queue member interacted with a customer?
Contacts Abandoned - What was the number of contacts abandoned? How long did a
customer wait before abandoning the contact?

Agent Group Performance by Period
The Agent Group Performance by Period report enables you to identify trends in agent group
performance.
Agent Group Event by Period (hh:mm:ss)
The Agent Group Event by Period (hh:mm:ss) report enables you to compare the performance of
agents who perform similar jobs. This report provides the shift time by agent, and a variety of contact
counts and agent event counts, such as instances where agents were unavailable.
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USING REPORTS TO IDENTIFY PROBLEMS
The recommended top-five reports help you identify problems that affect your Service Level
objectives. Table 25 and Table 26 address frequently asked questions.
Table 25: Solving problems using queue reports
WHAT DO I
WATCH FOR IN
THE QUEUE
REPORTS?

HOW DO I FIND THE SOURCE OF THE PROBLEM AND RESOLVE
IT?
When does the Service Level drop during the day?
1. Check the Agent Group Performance by Period report to see
the distribution. How many agents were logged on throughout
the day?
2. Examine agent talk times. Do you have a chatterbox agent?
3. Use Auditor to re-run events during a time interval to see
exactly what each agent was doing.
4. Generate a Forecast report with your Service Level goals to
determine the number of agents required by period for the day.
Compare the forecast statistics to the Average Manned Agent
statistic in the Agent Group Performance by Period report.
Have you scheduled enough agents to meet your Service Level
objective?

A drop in Service
Level

Why are some queues not meeting their Service Level goals while others
are?
l

Check the Agent Group Performance by Queue report. Are some agent
groups overworked?
Why did the customers abandon their calls or sessions?
1. Check Average Delay to Abandon statistics. Did the
customers abandon because they were impatient? Did
customers wait a long time in queue? Were agent talk times
excessive during this time? If so, why?

High abandon
statistics

2. Use Auditor to re-run the interval to see exactly what each
agent was doing.
3. Generate the Queue Unavailable Trace report and then call
back the customers to determine why they abandoned their
contacts.

A high requeue count
(because it
decreases the
Average Speed of
Answer time and the
Service Level)
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Are agents forgetting to set themselves as Unavailable on their telephone
sets before they leave their desks?
l

Check the Agent Group Performance by Period report to see which
agents are experiencing requeues. Remind agents to use the
Unavailable option.
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Table 26: Solving problems using agent reports
WHAT DO I
WATCH FOR IN
THE AGENT
REPORTS?

HOW DO I FIND THE SOURCE OF THE PROBLEM AND RESOLVE
IT?
Do some agents perform 20-30% worse than other agents?
1. For voice, silent monitor agents periodically to ensure they are
properly trained to handle callers' needs, and are not chatting
unnecessarily.
2. For voice, check Outbound or non-ACD statistics for peg
counts and times. Generate an Agent Inbound or Outbound
Trace report to see a list of all calls. Are agents spending too
much time on personal calls?

Extremely high or low
performance
statistics

Do some agents perform 20-30% better than other agents?
1. High ACD/non-ACD/Outbound contact counts is not a problem
if agents are maintaining high Service Levels. For voice, silently
monitor agents periodically to ensure they are providing a high
quality of service, but not rushing callers.
2. For voice, check the ACD short handle call count (hh:mm:ss)
statistic in the Agent Event by Period (hh:mm:ss) report. Not
many voice transactions can occur in less than 20 seconds.
This could indicate that agents are 'padding' their ACD handle
statistics by prematurely terminating calls.
Are agents accumulating Unavailable time and Make Busy peg counts?

High Unavailable
statistics

1. Check the Agent Event by Period (hh:mm:ss) report to evaluate
individual statistics. Determine how much Make Busy and Do
Not Disturb (DND) time agents are logging. Be sure agents are
adhering to your contact center policies regarding when to use
Make Busy and Do Not Disturb. Check if your agents are using
Unavailable instead of logging out.
2. For agents who have high Make Busy peg counts, run Auditor
with an Agent by Time monitor for the agent group. Be sure
agents are not using Make Busy to avoid being the longest idle
agent or to avoid being sent the next ACD contact.
3. Implement Make Busy with Reason functionality. Assign
reasons with which agents go into Make Busy. Track Make
Busy use by generating agent reports displaying Make Busy
statistics by Code.
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Table 26: Solving problems using agent reports (continued)
WHAT DO I
WATCH FOR IN
THE AGENT
REPORTS?

HOW DO I FIND THE SOURCE OF THE PROBLEM AND RESOLVE
IT?
Are agents adhering to their schedules?

Long or short shift
time

1. Examine the Agent Event by Period (hh:mm:ss) report to
determine when agents are logging in and out. Check if they are
logging in late, leaving early, or forgetting to log out at the end of
the day.
2. Examine all of the login and logout times for the shift, and
determine if agents are adhering to your contact center policies
concerning when to log out and when to use Unavailable.
3. Use Workforce Scheduling to create agent schedules. Use
Schedule Adherence to ensure agents are performing their
scheduled duties.

REPORTER
Using the Reporter application, you can generate on-demand and scheduled reports.
NOTE: You can restrict access to any or all of the reports for which you are licensed using security
roles and lists. See "Creating and applying security roles" on page 190.

REPORTER OPTIONS
The complete list of Reporter options follows.
l
l

l

l
l

l
l

Start date and End date—specify the range of dates used in the report. You can pick any
calendar date as the start date and any date later in the calendar year as the end date.
Create one report for each day in the selected date range—creates an individual report
for each day in the selected range of days.
Start hour and End hour—specify the hours of the day included in the report.
Interval—specifies the report period: by 15-, 30-, or 60-minute intervals, by day of the week,
by day of the month, or by month.
Days to include—specifies the days of the week to include in the report.
Report mode—gives you the option of a default report that spans one day, or an overmidnight report that spans two days. (For example, an over-midnight report can cover from
10:00 P.M. on day one to 10:00 A.M. on day two. It cannot exceed a time span of 24 hours.)

l

Report output language—specify the output language of the report.

l

Render Type—specify whether the report generates as an Excel file or a PDF.

l

l
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Report type—specifies the report name.

Email the report to —emails the report spreadsheet and associated graph to the email
address selected in the email o list. You add contacts and contact groups to the email to list
under the My options menu.
Print the report—prints the report spreadsheet.
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SETTING UP CONTACTS AND CONTACT GROUPS
You can create a list of email contacts and email contact groups to whom you email reports. Contact
groups can contain both user-configured contacts from CCMWeb as well as all existing employees
from YourSite Explorer.
NOTE: You must configure SMTP settings in YourSite Explorer before you can configure email
contacts. See "Adding mail servers" on page 83.
Before you generate a report, if you want to email that report, you must set up
l
l

My email contacts, which includes personal email addresses
My email contact groups, which includes mailing lists comprised of employees and My email
contacts

Setting up email contacts for emailing reports
To add an email contact
1. In the My options tab menu, click My contacts=>My email contacts.
Alternatively, click My options. In the My contact tab, click My email contacts.
2. Click Add.
3. After First name, type the first name of your contact.
4. After Last name, type the last name of your contact.
5. After Email address, type the email address of your contact.
6. To save this contact, click Save.
7. To save this contact and add another contact, click Save & Add.

Setting up email contact groups for emailing reports
If you intend to email the report to more than one recipient you must add the recipients to a mailing
list and then associate the recipients with a group.
To set up groups for emailing reports
1. In the My options tab menu, click My contact=>My email contact groups.
Alternatively, click My options. In the My contact tab, click My email contact groups.
2. Click Add.
3. After Name, type the name of the contact group.
4. After Description, type the description of the contact group.
5. To share this contact group with other CCMWeb users, select Shared Contact Group.
A shared contact group can be viewed, used, and edited by other users.
6. To save this contact group, click Save.
7. To save this contact group and add another contact group, click Save & Add.

309

Contact Center Solutions User Guide

To add an email contact to a contact group
1. In the My options tab menu, click My contacts=>My email contact groups.
Alternatively, click My options. In the My contact tab, click My email contact groups.
2. Click Members for the contact group with which you want to associate agents.
3. If you want to add members from your contacts configured in Contact Center Management,
click Contacts.
4. If you want to add members from the employees configured in YourSite Explorer, click
Employees.
5. Under Available contacts, select the check boxes of the members you want to add to the
group and click Add >>.

GENERATING ON-DEMAND REPORTS
NOTE:
l

l

You can only report on extensions that are licensed for Business Reporter. The number of
extensions you license in YourSite Explorer must be consistent with your software license. .
Workforce Scheduling reports are generated differently from Contact Center Management
reports. See "Generating Workforce Scheduling reports" on page 312.

GENERATING REPORTS
You generate reports in the following manner. These steps explain how to run a Voice Queue Group
Performance by Member report.
NOTE:
l

l

Some reports are stored in SQL data tables as devices instead of intervals. Reports stored as
devices cannot be run for a specific time range and can only be run 24-hour periods. If the
Start Hour and End Hour options in CCMWeb are disabled, the report can be generated for 24hour periods only.
If you run a report that results with Data Limit Exceeded in the inbox, you must re-run the
report using a shorter time span.

To generate a report
1. Click Reporter=>Voice=>Queue reports.
The Basic tab opens.
See Figure 64.
2. After Report type, select the Queue Group Performance by Period report.
3. After Queue group, click one or more queue group.
Hold down the <Shift> key or <Ctrl> key to select more than one queue group.
4. After Start date and End date, specify the start and end dates for the report.
NOTE: If you want one report that spans two days (for example, from December 3 at 9 P.M. to
December 4 at 5 A.M.), then make the Start date and the End date the date the shift begins
(December 3). If you make the Start date the date the shift begins (December 3) and the End
date the date the shift ends (December 4), you will generate a report that spans three days
(December 3 from 9 P.M. to December 5, 5 A.M.). The time span for each shift cannot exceed
24 hours.
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5. If you want to create a separate report for each day in the date range you selected, select the
Create one report for each day in the selected date range check box.
6. After Start hour and End hour, specify the start and end hours for the report.
NOTE: If you are running reports with the Over midnight Report mode option, the time span
between the Start hour and the End hour cannot exceed 24 hours.
7. After Interval, specify the time interval in which the statistics will display in the report.
8. After Days to include, select the days of the week to include in the report.
9. If your contact center does not operate 24 hour a day, after Report mode, click Default.
10. If you want to run a report over midnight, after Report Mode, click Over midnight.
The Over midnight report mode is most appropriate for 24-hour contact centers.
11. After Report output language, select the language used in the report output.
12. After Render type, specify how you will view reports, either in Excel or .pdf format.
13. Click the Filter tab.
NOTE: The Filter tab is available with select reports only.
14. Specify the filtering options to include in the report. Separate multiple values with commas.
For example: Queue = P100,P200,P300.
15. Click the Distribution tab.
16. If you want to email the report, select the Email the report to check box and specify to whom
you will email the report:
l

A contact group, select the this contact group check box, and select a group

l

One contact only, select the this contact check box, and select a contact

l

One employee only, select the this employee check box and select an employee

A contact that is not listed, select the this email address check box, and type the
email address
You add contacts and contact groups to the Email to list under My options=>My contacts.
l

17. If you want to print the report, select the Print the report check box.
18. Click Submit.
The Report submitted screen opens.
19. Click View Report Inbox.
The Report Inbox window opens, listing all created reports.
20. Click View to open a report.
The report opens in the format you specified.
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Figure 64: Reporter: Basic Tab

Generating Workforce Scheduling reports
The following steps detail how to generate a Schedule by Employee by Time Off by Day of Week
report. All other Workforce Scheduling reports are generated by following a similar procedure.
NOTE: Some report features may be available or unavailable depending on the report type you want
to generate. For example, the Interval feature is unavailable (and will appear grayed out) for the
Schedule by Employee by Time Off by Day of Week report.
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To generate a Workforce Scheduling report
1. Click Reporter=>Workforce Scheduling=>Schedules.
See Figure 65.

Figure 65: Workforce Scheduling Basic tab
2. After Report type, select the Schedule by Employee by Time Off by Day of Week report.
3. After Device type, select one of the following:
l
l

l

l

Employee — only the employees selected will appear in the report
Supervisor — only the employees associated with the selected supervisor will appear
in the report
Employee group — only the employees who are members of the selected employee
group will appear in the report
Schedule — only the employees associated with the selected schedule will appear in
the report

4. Select one or more devices from the table.
5. After Start date and End date, specify the start and end dates for the report.
NOTE: If you want one report that spans two days (for example, from December 3 at 9 P.M. to
December 4 at 5 A.M.), then make the Start date and the End date the date the shift begins
(December 3). If you make the Start date the date the shift begins (December 3) and the End
date the date the shift ends (December 4), you will generate a report that spans three days
(December 3 from 9 P.M. to December 5, 5 A.M.). The time span for each shift cannot exceed
24 hours.
6. After Report output language, select the language used in the report output.
7. After Render type, specify how you will view reports, either in Excel or PDF format.
8. Click the Filter tab (if available for the report type selected).
9. Specify the filtering options to include in the report.
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10. Click the Distribution tab.
11. If you want to email the report, select the Email the report to check box and specify to whom
you will email the report:
l

A contact group — select the this contact group check box, and select a group

l

One contact only — select the this contact check box, and select a contact

l

One employee only — select the this employee check box, and select an employee

A contact that is not listed — select the this email address check box, and type the
email address
You add contacts and contact groups to the Email to list under My options=>My contacts.
l

12. If you want to print the report spreadsheet, select the Print the report check box.
13. Click Submit.
The Report submitted screen opens.
14. Click View Report Inbox.
The Report Inbox window opens, listing all created reports.
15. Click View to open a report.
The report opens in the format you specified in step 10.

Emailing reports
To email a report
1. In an active report, click the Distribution tab.
2. Select the Email the report to check box and specify to whom you will email the report:
l

A contact group, select the this contact group check box, and select a group

l

One contact only, select the this contact check box, and select a contact

l

One employee only, select the this employee check box, and select an employee

A contact that is not listed, select the this email address check box, and type the
email address
You add contacts and contact groups to the Email to list under My options=>My contacts.
l

3. Click Submit.
The Report submitted screen opens.
4. Click View Report Inbox.
5. When the email icon beside the report changes to Complete, the report has been emailed.

Printing reports
To print a report
1. In an active report, click the Distribution tab.
2. Select the Print the report check box.
3. Click Submit.
The Report submitted screen opens.
4. Click View Report Inbox.
5. When the print icon beside the report changes to Complete, the report has been emailed.
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SCHEDULED REPORTS
You use Scheduled Reports to automate the generation of reports. You can restrict user access to
any or all of the reports with advanced security roles. See "Creating and applying security roles" on
page 190.

SCHEDULED REPORTS OPTIONS
To create a scheduled report you must complete the following options on the properties and
distribution tabs.
l

Schedule name is a user defined name to describe the contents of the schedule.

l

Schedule will run specifies how often the schedule will be generated.

l

At defines when the scheduled report will be generated.

l

Reports time span defines the dates of report activity to appear in the report.

l

Email the report to defines the email contact group to which the report is sent.

l

Print the report indicates the scheduled report will be printed every time it is generated.

GENERATING SCHEDULED REPORTS
NOTE: You can generate reports on licensed employees only. The number of employees you license
in YourSite Explorer must be consistent with your software license.
To generate a scheduled report, you must follow these steps:
1. Create a report schedule.
2. Add reports to the schedule.

Creating report schedules
NOTE: If you select printing and mailing options, Reporting Service prints and emails all of the
reports included in the schedule on the date the system generates the reports.
You can create schedules for Contact Center Management Reports, Contact Center Management
User reports, and Workforce Scheduling Employee schedule mailer.
Using Contact Center Management Reports Schedules, you can
l

Generate reports on all contact center devices.

l

Distribute reports to yourself and to a contact, a contact group, or a specific email address.

Using Contact Center Management User reports schedules, you can
l
l

Generate reports on agents and employees.
Distribute reports automatically to yourself and to the individuals within the agent groups,
employee groups, and/or teams you select.

Using Workforce Scheduling Employee schedule mailer, you can
l
l

Generate reports on employee schedules.
Distribute agent/employee report schedules to yourself and to individual employees
associated with the schedules you select.
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Creating Contact Center Management Report schedules
To create a schedule for Contact Center Management reports
1. Click Reporter=>Scheduled Reports.
2. In the Report Schedules tab, click Next>>.
See Figure 66.

Figure 66: Scheduled Reports: Properties tab
3. After Schedule name, type a schedule name.
4. After Schedule will run, select the schedule frequency, for example, every day, every
Wednesday, or the start of month.
When you select the day, all of the reports associated with the schedule will be generated that
day, every week.
5. After at, click the time of day the schedule will be activated.
For example, if you select Wednesday at 14:30, all of the reports associated with the
schedule will be generated every Wednesday at 2:30 P.M.
NOTE: Reports are based on the data in the SQL database. We recommend you schedule
your reports for after the nightly maintenance routine runs, that is, after 2:00 A.M., to ensure
the reports are based on the entire day’s raw telephone system data.
6. After Reports time span, select a time span.
If you select Year to date, the report output includes all of the days from January 1 to the
present date. If you select From given start date to current date you will produce reports for
your fiscal year.
7. Click the Distribution tab.
See Figure 67.
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Figure 67: Scheduled Reports: Distribution tab
8. To email the report, select the corresponding Email the report to check box, and select the
email recipients.
NOTE: You add contacts and contact groups to the email to list under My options=>My
contacts.
9. If you want to print the report, select the Print the report check box.
10. Click Save.
The date of when the schedule will next run will appear after Schedule will run next on.
11. Add the reports you want to generate using the schedule you just created.
See "Adding Contact Center Management reports to schedules" on page 319.

Creating user report schedules
To create a schedule to automatically email agents/employees/teams their reports
1. Click Reporter=>Scheduled Reports.
2. Click the User report schedules tab.
3. Click Next>>.
The Properties tab opens.
4. After Schedule name, type a schedule name.
5. After Schedule will run, select the schedule frequency, for example, every day, every
Wednesday, or the start of month.
When you select the day, all of the reports associated with the schedule will be generated that
day, every week.
6. After at, click the time of day the schedule will be activated.
For example, if you select Wednesday at 14:30, all of the reports associated with the
schedule will be generated every Wednesday at 2:30 P.M.
NOTE: Reports are based on the data in the SQL database. We recommend you schedule
your reports for after the nightly maintenance routine runs, that is, after 2:00 A.M., to ensure
the reports are based on the entire day’s raw telephone system data.
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7. After Reports time span, select a time span.
If you select Year to date, the report output includes all of the days from January 1 to the
present date. If you select From given start date to current date you will produce reports for
your fiscal year.
8. Click the Distribution tab.
You can email reports to members of agent groups, employee groups, and teams.
9. Click the type of group(s) to which you want to email agent and employee reports.
10. Within each type of group, select the check boxes of the groups to which you will email
reports.
11. Click Save.
12. Add reports you want to automatically distribute to the agent group(s), employee group(s) and
teams you selected.
See "Adding agent and employee reports to User report schedules" on page 319.

Creating Employee schedule mailer schedules
To create a schedule to automatically email agents/employees/teams their report schedules
1. Click Reporter=>Scheduled Reports.
2. Click the Employee schedule mailer tab.
3. Click Next>>.
The Properties tab opens.
4. After Schedule name, type a schedule name.
5. After Schedule will run, select the schedule frequency, for example, every day, every
Wednesday, or the start of month.
When you select the day, all of the reports associated with this schedule will be generated
that day, every week.
6. After at, click the time of day the schedule will be activated.
For example, if you select Wednesday at 14:30, all of the reports associated with this
schedule will be generated every Wednesday at 2:30 P.M.
NOTE: Reports are based on the data in the SQL database. We recommend you schedule
your reports for after the nightly maintenance routine runs, that is, after 2:00 A.M., to ensure
the reports are based on the entire day’s raw telephone system data.
7. After Reports time span, select a time span.
If you select Year to date, the report output includes all of the days from January 1 to the
present date. If you select From given start date to current date you will produce reports for
your fiscal year.
8. Click the Distribution tab.
9. Select the check boxes of the schedules you want to email to employees.
10. Click Save.
11. Add reports.
See "Adding work schedules to an Employee schedule mailer schedule" on page 319.
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Adding Contact Center Management reports to schedules
NOTE: Before you can add reports to schedules, you must create and save the schedules.
To add a report to a Report Schedule
1. In Reporter=>Scheduled Reports, select the Report Schedules tab, select a schedule and
click Edit schedule.
2. Click Add a report.
3. Select a report category.
4. Select a report type.
5. Follow the steps in "Generating reports " on page 310 for the Basic tab to set up the report.
6. Click Submit to add the report to the schedule.

Adding agent and employee reports to User report schedules
NOTE: The report options available vary depending on the type of report being added.
To add agent and employee reports to a User report schedule
1. In Reporter=>Scheduled Reports, on the User report schedule tab, select a schedule and
click Manage schedule properties.
2. Click Add a report.
3. Select a report category, such as Agent reports.
4. Under Report type, select the report you want to add to the schedule.
5. After Start hour and End hour, select a start hour and end hour for the report.
6. After Interval, select the time interval for reporting.
7. After Days to include, select the days of the week to include in the report (for example, if you
select a date range of September 1 to 30, and select Wednesday and Friday as the days to
include, you will produce a report for the Wednesdays and Fridays that fall between
September 1 and September 30).
8. After Report mode, select either Default or Over midnight. .
9. After Shift Mode, select either Default or Agent Group Presence.
10. After Report Output language, select a language.
11. After Render type, specify how you will view reports, either in Excel or .pdf format.
12. Click Submit.

Adding work schedules to an Employee schedule mailer schedule
To add work schedules to an Employee schedule mailer schedule
1. In Reporter=>Scheduled Reports, on the Employee schedule mailer tab, select a
schedule and click Manage schedule properties.
2. Click Add a report.
3. Select a category of report, such as Workforce Scheduling reports.
4. Under Report type, select the work schedule you want to add to the schedule.
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5. After Report Output language, select a language.
6. After Render type, specify how you will view reports, either in Excel or .pdf format.
7. Click Submit.

Generating scheduled reports immediately
If you want to generate your scheduled reports at a specific time (other than immediately), you
specify the date and time they will be generated when you create the schedule. See "Creating report
schedules" on page 315.
To generate scheduled reports immediately
1. Click Reporter=>Scheduled Reports.
2. Click the tab of the report schedule type for which you want to generate a scheduled report.
3. Under Work with an existing schedule, select the schedule you want to generate.
4. Click Execute schedule now.
The Execute schedule now window opens.
5. In the Start date and End date calendars, select start and end dates for the report.
6. Click Submit.
The reports associated with the schedule are generated immediately and placed in your
Report Inbox.

REPORT INBOX
The Report Inbox application displays the on-demand, scheduled, and forecast reports generated
under your user name over the past 30 days. Inbox manager deletes reports from your Inbox by date
range.
NOTE:
l

l

In Report Inbox, if the report status is Pending for an extended period of time, start Client
Component Pack Manager and confirm the Enterprise Server IP address and your user name
and password are correct.
In Report Inbox, if Data Limit Exceeded opens, re-generate the report using a shorter time
span.

Report Inbox includes
l

Today's reports displays all of the reports generated today under your user name.

l

Yesterday's reports displays all of the reports generated yesterday under your user name.

l

l
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All of your reports displays all of the reports generated under your user name over the last 30
days.
Inbox Manager deletes reports from your Inbox by date range.

Report Inbox

REPORTER INBOX OPTIONS
Report Inbox has the following options.
l

Report type lists the report name.

l

Media server defines the media server used in reporting.

l

Name is the name of the device or device group.

l

Reporting number specifies the reporting number of the device or device group as configured
on the telephone system.

l

Start date is the starting date of the time period covered in the report

l

End date is the ending date of the time period covered in the report.

l

Start time is the starting time of day included in the report.

l

End time is the ending time of day included in the report.

l

Interval is the interval selected in the report

l

l

Status confirms if your report is ready. When a Complete icon appears in the status field the
report is waiting in your Report Inbox. When a Pending icon appears, the report is not ready. A
No data icon means no records are available for the parameters you specified. A Failed icon
means the report did not generate. If a report fails, the Reporting Service logs errors in the
NT Event log. Table 27 describes the status indicator icons.
View displays reports generated in Microsoft Excel.
Table 27: Report status indicators
STATUS

EXCEL ICON

PDF ICON

Complete
Pending
No Data
Failed
Email Complete
Email Pending
Email Failed
Printing Complete
Printing Pending
Printing Failed
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VIEWING REPORTS
To view report details
1. Click View Report Inbox (upon submitting a report) or click Report Inbox=>Today’s
reports.
2. Select the Automatically refresh this page every 10 seconds check box to automatically
update the Status column.
The Status column indicates if your reports are ready:
l

Complete: The report is waiting in your report Inbox.

l

Pending: The report is not ready.

l

No data: No records were available for the parameters you specified.

l

l

Data limit exceeded: The time span selected was too great. Select a shorter time span
and re-generate the report.
Failed: The report did not generate. If a report fails, Inbox Manager logs errors in the
event log. Clicking Re-submit regenerates the report.

3. Click View to view the report.

EDITING REPORTS IN EXCEL
You can graph specific data by highlighting one or more columns of data in the Excel spreadsheet
and using the Excel Chart Wizard. For more information, see Microsoft Excel Help.

DELETING REPORTS
The prairieFyre Maintenance Alarm Dispatcher service deletes any reports that are 30 days or older
from your Report Inbox. You must save any reports you want to retain beyond 30 days to your hard
drive or network directory.
Report Writer uses the following criteria to determine a report’s age. For on-demand reports, the
request date governs the report’s age. For scheduled reports, the date the system generates the
report governs the report’s age. Inbox manager does not delete reports you schedule to generate in
the future.
To delete all of the reports submitted on a given date
1. Click Report Inbox=>Inbox manager.
2. Select fixed dates or a date range for deleting reports.
3. Select the status type(s).
4. Click Delete.
The Inbox manager deletes all of the reports submitted on the dates you specified.
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CONFIGURING USER PRINTER SETTINGS
You can configure reports to print on either a network or a local printer, for each employee.
To configure user printer settings
1. In YourSite Explorer, click Employee.
2. Select an employee and click the User account tab.
3. Type the file path of the Network printer.
You must configure the network printer as the default printer on the Enterprise Server. The
printer path name is case sensitive.
4. If you want the employee’s reports to print from their desktop printer, select Send printed
report to the employee’s desktop printer.
5. If you want to use the employee’s email address for report distribution, select Use the
employee’s email address for report distribution.
6. Click Save.

EXCLUDING JUNK MAIL STATISTICS FROM EMAIL HANDLED
AND COMPLETED COUNTS
You can optionally configure multimedia reports to exclude junk mail from email Handled and
Completed counts. For more information, see the following Mitel Knowledge Base article
http://micc.mitel.com/kb//KnowledgebaseArticle52080.aspx.

TROUBLESHOOTING REPORTING ISSUES
Common reporting troubleshooting issues are described below.

Troubleshooting missing data
NOTE: You can run reports on licensed employees only.
If you run a report and notice that the data for a device is missing from the report output, verify the
device is programmed in the telephone system and in the YourSite database. If you determine the
device is missing from the database, add it to the database and use the Summarize Data command
(in the Management Console application) to update the prairieFyre Services and the SQL database
with the complete telephone system data stored on the local hard drive. You can then produce
reports on the device.
To summarize data
1. Open Contact Center Client
2. If prompted, type your user name and password.
3. Click Log on.
4. On the ribbon, Tools=>Management.
5. Click Maintenance=>Summarize data.
6. Follow the steps in the Summarize Data Wizard to summarize the data.
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Troubleshooting Reporting Service
Why is Reporting Service not emailing or printing my reports?
l

Ensure the SMTP connections are correctly configured.

l

Ensure the printer settings are correctly configured.

l
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View the log file for Reporting Service at <installation drive>:\Program Files (x86)\prairieFyre
Software Inc\CCM\Logs\Reporting.log to find out why reports are not being printed/emailed
the way you expect in the installation/Log file.

Chapter 9
FORECASTING
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Contact Center Solutions User Guide

FORECASTING
Forecasting is the basis of estimating required resources to handle a contact center’s workload.
Using historical data generated by Mitel contact center telephone systems and multimedia media
servers, forecasting allows you to adjust key modifiers to predict the number of agents required, by
interval, to handle the predicted workload.
The Forecasting tool available in Contact Center Client and Workforce Scheduling enables users to
quickly choose historical data from both voice and multimedia queues or queue groups to use in the
forecast, providing average transaction traffic by day of week, by media, as well as by historic
manned agents and handling statistics for user-selected intervals of time. Supervisors can create
forecasts based on historic contact center volumes and manually adjust various modifiers to
generate hypothetical or future anticipated traffic scenarios, optimizing the balance between the
agents required to handle the anticipated traffic with the expected handling time, wrap up time and
Service Level objectives. The Forecasting tool lets you adjust key statistics together with intra-day
contact volumes rather than only daily statistics which provides a much more accurate output of
agents required per interval. For example, you may have a situation where calls coming into your call
center are more complex earlier in the day and/or earlier in the week creating a higher demand for
agents to be available at these times. It is possible that handling time drops throughout the day and
the demand for agents reduces, allowing for alternate options for agents such as off line work, team
meetings or performance reviews.
Your ability to forecast is limited only by the available ACD data collected and available in your SQL
database. For example you may chose to take the last few weeks to help predict the next few weeks
or you could take the last year to help predict the average traffic per week, or you might want to only
take the period of time in the past where you ran a particular campaign/season to anticipate the
amount of traffic to expect for a similar upcoming campaign/season, etc. . After you run a forecast,
you could examine the data and make adjustments based on current or anticipated contact center
conditions. You could then tweak the forecast as required.
NOTE: Ring Groups are not supported with Forecasting, either as queues or as a member of a
reporting queue groups.

FORECASTING TERMS
Conducting a forecast involves accurately estimating Time to Handle, Wrap Up Time, and Contacts
Offered values. The following terms are used in forecasting resource requirements:
l

l

l

l
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Service Level percent
See "Understanding reports" on page 300.
Service Level time
See "Understanding reports" on page 300.
Wrap Up time
Wrap Up Time is a real-time and reporting statistic detailing the total time an agent spends in
the Work Timer state. The Wrap Up Time is a standardized period. If an agent requires
additional time to complete paperwork or online transactions, the agent can leave the ACD
queue temporarily for this purpose.
Agent Efficiency percent
Agent Efficiency percent is the percentage of time agents spend on ACD contacts relative to
the time agents are scheduled to work. Agent efficiency is calculated using a straight linear

Forecasting tool

relationship. For example, 50% agent efficiency means that two more agents are required to
handle the forecasted workload. An Agent efficiency percentage of 100 is unrealistic. Agents
routinely take breaks, perform other non-ACD duties, make outgoing calls, and place
themselves in Make Busy.
l

l

l

Contacts Offered
You can predict the queue member requirement for your Service Level percent and Service
Level time targets by applying the Erlang C equation to the estimated Call Load and average
ACD Handling Time.
Manned Agents
Manned Agents is the average number of agents who were logged on for the interval of time
being forecasted.
Average Handle Time
Average Handle Time is the average time queue members spend handling contacts, and is
determined by comparing the contact duration to the number of contacts offered.
NOTE:
l

l

l

l

l

The Average Handle Time in the Forecasting tool is calculated differently than the
Average Handling Time in CCMWeb reports, which is determined by comparing
contact duration to the number of contacts answered.
The Daily Average Handle Time in the Forecasting tool is calculated from the interval
rows in the forecast and may differ from the Average Handling Time for that day in
contained in a report.

Time to Handle
Time to Handle is the average time calls wait in queue before being handled.
ACD Handling Time
ACD Handling time is the talk time plus the hold time. If a queue member calls a supervisor in
search of more information (while the caller is on hold) and/or transfers or conferences the call,
the system adds these times to the ACD Handling Time value.
Call Load
The term Call Load is to the combined effect of the number of contacts received by the ACD
queue and their duration, or the calls offered x (average ACD Handling Time + average Wrap
Up Time).

FORECASTING TOOL
The Forecasting tool is accessed via Contact Center Client. If you are licensed for Workforce
Scheduling, you can also access it in that application under the Tools tab. In order to access the
Forecasting tool, your security role must have the 'May manage Forecasting' option enabled.
You use the Forecasting tool to create forecasts based on historical contact center traffic volumes.
After loading historical data into the tool, you can perform 'what-if' scenarios and optimize the
balance between the agents scheduled and your Service Level objectives.
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The Forecasting tool offers a tabbed interface for viewing and setting historical data for each day of
the week. If more than one media type has been included in the historical data, each day’s tab will
have a section for each media type included in the historic data. The forecast grid is divided into rows
based on the interval time selected when loading historical data, enabling users to adjust statistics
by 15, 30, or 60 minute intervals. The statistics have Historic and Current values, which display the
original values from the loaded historical data and the current values after user modification
respectively.
After a forecast has been performed, each day lists the agents required for each interval. Figure 68
shows the Forecasting tool.

Figure 68: Forecasting window
To forecast resource requirements you
1. Load historical data.
See "Loading historical data" on page 329.
2. Modify historical data if required.
See "Modifying historical data" on page 330.
3. Perform a forecast.
See "Performing forecasts" on page 334.
4. Export the forecast.
See "Exporting forecasts" on page 335.
To access the Forecasting tool
1. Click Tools in the Contact Center Client ribbon.
2. In the Data Mining section, click Forecasting.
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LOADING HISTORICAL DATA
When you load historical data, you include data from a queue or queue group over a historical period
that best represents the contact center activity for the time period for which you are trying to
forecast. You can select one or more specific dates and/or date ranges when loading historical data.
You can select sequential or non-sequential dates (for example, Monday, Wednesday, and Friday) to
use in the forecast. You can also exclude specific dates from within your date range.
NOTE:
l

l

l

Users should identify and exclude any outliers or extreme values from the time period they are
loading historical data from, as these may give artificially inflated or deflated values.
Historical data for agents can be validated by comparing it to the queue and queue group
period reports for the same periods.
Ring Groups are not supported with Forecasting, either as queues or as a member of a
reporting queue groups.

The following procedure takes place in an open Forecasting tool window.
To load historical data
1. Click Load historical data.
The Forecasting window opens.
2. Under Queues or Queue groups, click on the queue or queue groups you want to use as the
source of historical data.
NOTE: You can load historical data for a queue or queue group. If you are using the forecast to
build a schedule, select historical data from the same queue group with which the schedule is
associated. This data will best represent the agents required for your schedule.
3. If you want to include or exclude data from a specific date, under Historical date(s) for the
forecast, select Specific day and then select a date.
4. If you want to include or exclude data from a date range, click Date range and specify a range
of dates.
5. If you are including the data from the specified date(s), click Include dates.
6. If you are excluding the data from the specified date(s), click Exclude dates.
7. Repeat steps 3-6 until you have specified the date(s) or date range(s) from which you will
derive your historical data.
8. After Start hour and End hour, select the time frame for historical data.
9. After Interval, select the schedule interval: 15, 30, or 60 minutes.
The Interval value, in minutes, is the time increment by which the forecast will be displayed. It
is recommended that you select an interval that matches the increments in which you
schedule your employees. For example, if you schedule your employee shifts in 30 minute
increments, select 30 minutes as the Interval value.
10. Click Submit.
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MODIFYING HISTORICAL DATA
After loading your historical data, you can modify the values of Contacts Offered and Average
Handle Time to generate different forecast results based on the modified values. You can also
modify values after performing forecasts to obtain different forecasts of required agents. The
historical values for data are always displayed, regardless of modifications, for comparison

Modifying Average Handle Time
You can modify the Average Handle Time value for an interval, a day, or several days
simultaneously. When you select a modification to apply to a value, either the Historic or Current
value, it is applied as the new Current value. You cannot change the Daily Average Handle Time, but
you can use it to modify the Average Handle Time of other intervals.
The following procedures outline how to
l

Modify the Average Handle Time parameter on the forecast grid

l

Modify an interval’s Average Handle Time parameter

l

Modify the Average Handle Time parameter using the Historic Daily Average Handle Time
parameter

The following procedures take place in an active Forecasting tool window.
To modify the Average Handle Time parameter on the forecast grid
1. Click Modify...=>Average Handle Time.
Alternatively, select an interval row, click the cell for Current Average Handle Time, and click
the … button.
See Figure 69.
2. Under Specify the Average Handle Time value(s), specify how you want to modify
Average Handle Time:
l

Increase or decrease Average Handle Time by a specific number of seconds

l

Increase or decrease Average Handle Time by a specific percentage

l

Set the Average Handle Time to a specific number of seconds

3. Under Apply the changes to the following data source, specify if you want to have the
modification applied to the original value or the current grid value.
4. Under Apply to days, select the days for which you want to modify Average Handle Time.
5. Under Apply to media type, select the media types for which you want to modify Average
Handle Time.
6. Click Apply.
To modify an interval’s Average Handle Time parameter
1. Select an interval row, click the cell for Current Average Handle Time.
2. Set the Average Handle Time parameter for the interval.
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To modify the Average Handle Time parameter using the Historic Daily Average Handle Time
parameter
1. Click the … button after Historic Daily Average Handle Time.
2. Under Specify the Average Handle Time value(s), specify how you want to modify the
Historic Daily Average Handle Time:
l

Increase or decrease Average Handle Time by a specific number of seconds

l

Increase or decrease Average Handle Time by a specific percentage

l

Set the Average Handle Time to a specific number of seconds

3. Under Apply to days, select the interval(s) for which you want to apply the modified Historic
Daily Average Handle Time.
4. Click Apply.

Figure 69: Average Handle Time window

331

Contact Center Solutions User Guide

Modifying Contacts Offered
You can modify the Contacts Offered value for one or several time intervals simultaneously. When
you select to modify a value, either Historic or Current, it is applied as the new Current value.
This section explains how to:
l

Modify the Contacts Offered parameter on the forecast grid

l

Modify an interval’s Contact Offered parameter

The following procedures take place in an active Forecasting tool window.
To modify the Calls Offered parameter on the forecast grid
1. Click Modify...=>Calls Offered.
See Figure 70.
2. Under Specify how you want to change the Calls Offered value(s), specify how you want
to modify Calls Offered:
l

Increase or decrease Contacts Offered by a specific number of calls

l

Increase or decrease Contacts Offered by a specific percentage

l

Set the Contacts Offered to a specific number of call

3. Under Apply the changes to the following data source, specify if you want to modify the
original value or the current grid value.
4. Under Apply to times, select the days and time interval for which you want to modify
Contacts Offered.
5. Under Apply to media type, select the media types for which you want to modify Contacts
Offered.
6. Click Apply.
To modify an interval’s Contacts Offered parameter
1. Select an interval row, click the cell for Current Contacts Offered.
2. Set the Current Contacts parameter for the interval.
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Figure 70: Contacts Offered window

Modifying the weekly total for Contacts Offered
You can modify the Contacts Offered values for an entire week simultaneously. Modifying these
values changes the number of Contacts Offered while maintaining the same proportion of calls
across all time intervals. For example, if you increase the weekly total by 10 percent, an interval with
10 calls will change to 11. However, an interval with zero calls will remain zero.
The following procedure takes place in an active Forecasting tool window.
To modify the Contacts Offered parameter on the forecast grid
1. Click Modify...=>Weekly total.
See Figure 71.
2. Under Specify how you want to change the weekly total, specify how you want to modify
Contacts Offered over the week:
l

l

Increase or decrease the weekly total of Contacts Offered by a specific number of
contacts
Set the weekly total of Contacts Offered to a specific number of contacts

3. Under Apply to totals, specify if you want to modify the original values or the current grid
values.
4. Click Apply.
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Figure 71: Weekly total for Contacts Offered window

PERFORMING FORECASTS
When you perform a forecast, you receive the required agents based on both the historical and
current values. If you adjust any of the values in your historical data, you must perform the forecast
again.
NOTE: It is recommended that you save your forecast as an Excel file to preserve your settings to
use or compare with the next forecast you make.
To run a forecast
1. Specify the Service Level %, Service Level Time, Wrap Up Time, and Agent Efficiency % you
expect for the queue or queue group.
2. Click Perform forecast.
You can perform what-if scenarios on the historical data using different Service objectives
statistics until you are satisfied with the forecast.
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EXPORTING FORECASTS
After performing a forecast, you can export it as a Microsoft Excel spreadsheet or export the forecast
to Workforce Scheduling.

Saving forecasts as Excel files
After you generate forecast data you can export it to a Microsoft Excel .xlsx worksheet. If your
forecast has different media types, each media type will have its own worksheet in the .xlsx file.
To export a forecast as an Excel file
1. Click Export Forecast.
2. Click Microsoft Excel.
3. Click Export.
The forecast opens in a Microsoft Excel spreadsheet you can modify and save.

Exporting forecasts to Workforce Scheduling
If you are licensed for Workforce Scheduling, after you generate forecast data, you can export it into
a Workforce Scheduling schedule.
When scheduling for agents who handle a particular media type, it is recommended that you export
forecasts that use solely data from that media type. For example, if you are forecasting based on
historical data from an email queue, the forecast should be exported into a Workforce Scheduling
schedule that only handles email ACD contacts.
To export a forecast into a Workforce Scheduling schedule
1. Click Export Forecast.
2. Select Workforce.
3. For each media type, select the schedule for which to apply the forecast.
NOTE: Each media type must be exported to a different schedule.
4. Click Export.
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DATA MINING
The data-mining tools comprise
l

l

l

ACD Inspector
ACD Inspector searches for agent and ACD queue event records.
SMDR Inspector
SMDR Inspector searches through SMDR data to find specific contact center events.
Auditor
Using Auditor you can view the historical real-time events that occurred on a particular date, in
the sequence they occurred, at your own pace.

NOTE: For ACD Inspector and SMDR Inspector to function effectively when using Internet
Explorer, you must add Contact Center Management to the Internet Explorer Trusted Sites category
and set the Internet security to medium. See the Contact Center Management Installation Guide.
You access ACD and SMDR Inspectors via the Contact Center Client ribbon. In order to access the
ACD and SMDR Inspectors, your security role must have the 'May manage ACD Inspector' and
'May manage the SMDR Inspector' options enabled.
To access ACD and SMDR Inspectors
1. Click Tools in the Contact Center Client ribbon.
2. In the Data Mining column, click Inspectors to open the Data Inspectors tool. The Data
Inspectors window opens.
See Figure 72.
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Figure 72: Data Inspectors window

ACD INSPECTOR
ACD Inspector searches through telephone data obtained from the telephone system, for agent and
ACD queue event records. For example, using ACD Inspector, you can find the exact time an agent
logs off at lunch. You can run a search and examine the activities of individual agents or all of the
agents in a particular agent group or customer service queue during that time interval. You can also
search on specific agent states and other parameters, such as the number of calls waiting and the
number of active agents. The search follows a wild card format. Your specifications do not have to
be exact. You can make the search as inclusive or exclusive as you wish. The results are placed in
an easy-to-interpret grid that can be printed or saved to file. You can verify that your reports are valid
by conducting searches against raw telephone system data.
There are four types of search result tabs:
l

Agent events

l

Queue events

l

Date events

l

Exception events
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RUNNING SEARCHES IN ACD INSPECTOR
NOTE: When you run searches on queues in ACD Inspector, be sure to include a P preceding the
queue number.
When you run a search, ACD Inspector searches through the raw telephone system data on the
local hard drive. Each search requires the following information:
Select dates/Delete dates
The Select dates button specifies the date range within which you want to search. The Delete dates
button deletes days within the range you selected. The date is displayed month first, then day, then
year.
Select media servers
The Select media servers check boxes specify the origin of the data used in the search. Currently
you can search on voice media servers only.
In addition to the date and media server parameters, the ACD Inspector has the following search
criteria tabs:
l

Agent events

l

Queue events

l

Option events

You can use the Reset criteria button to reset all of the search parameters to their default settings.

Agent events criteria for searches
NOTE: When conducting a search, if you accept the default settings—all check boxes—the search
output will contain all of the event records. You can clear check boxes to narrow down your search.
For example, if you clear all of the agent states except for the Agent login and Agent logout check
boxes, the agent event search output will include log on and log off event records only.
When you click Tools=>Inspectors=>ACD Inspector, the Agent events tab opens. It displays the
agent event criteria used in the search. (See Figure 73.)
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Figure 73: ACD Inspector main window - Agent events tab
The Agent events tab has the following search criteria:
Agent information
The Agent information boxes specify the agent’s ID and extension number, and line numbers for one
or more telephone lines to which the agent connects. You can search for agent information records
for a particular agent, or for all of the agents. The agent information specifies the Agent ID for the
media server you have already selected. For example, if you selected the media server Phone,
ensure you select the Agent Login ID for the media server Phone. It is specified in YourSite
Explorer=>YourSite=>Agents.
Agent events
The Agent events criteria are listed and automatically selected.
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Idle event modifiers
The idle event modifier check boxes provide additional agent event searches. You can select one or
more check boxes to include records for agents who are in the following states: unknown, idle, DND,
Make Busy, and both DND and Make Busy.
NOTE: When conducting a search, if you accept the default settings the search output will contain
all of the event records. You can clear check boxes to narrow down your search.
ACD queue
The ACD queue specifies the queue to which your agent belongs. For example, if the agent belongs
to Tech Support, then you specify the Tech support queue. The agent’s queue is specified in
YourSite Explorer=>YourSite=>Queues. When you enter an ACD queue number and an agent
number (in the Agent ID box), the search results contain records for all of the calls the agent receives
from the queue.
Table 28 describes the ACD information provided by the Agent events tab.
Table 28: ACD information provided by Agent event tab
AGENT EVENTS
Agent Login

Agent Logout

DESCRIPTION
This record is produced whenever an agent successfully logs on.
This record is produced whenever an agent successfully logs off. If agent A
is currently logged on extension X and agent B logs on to extension X, a log
off record is automatically produced for A. This is followed by the log on
record for B. Make Busy is automatically enabled on the extension when
the agent logs out. No remove Make Busy record is produced. The
extension number is the prime line of the ACD set which an agent is logged
on.
A record is not produced when a hunt group is placed in DND. The records
do not differentiate between setting DND locally and remotely. The
extension number reported is always the prime line of the ACD extension.
A set DND record will be produced for the following conditions:

Agent Set Do Not
Disturb

l

Setting DND locally by using the DND access code

l

Setting DND remotely by using the remote DND access code

l

Setting DND remotely by using the attendant console features key

l
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Setting DND locally on a SUPERSET 4 telephone by pressing the select
features hardkey and dialing the digit 2 or setting it on a SUPERSET
4DN or SUPERSET 430 telephone by pressing the Do Not Disturb
Feature Key
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Table 28: ACD information provided by Agent event tab (continued)
AGENT EVENTS

DESCRIPTION
The extension number is always the prime line of the ACD extension. A
clear DND record will be produced for the following conditions:

Agent Remove Do
Not Disturb

l

Clearing DND locally by using an access code

l

Clearing DND remotely by using the Cancel Remote DND access code

l

Clearing DND remotely by using the attendant console feature key

l

Clearing DND by using the Cancel All Features access code

l

l

Clearing DND by using the Cancel All DND feature on the attendant
console
Agent logging in on an extension in DND

Agent Set Make
Busy

This record is produced whenever an extension is placed in the Make Busy
state. A record is not produced when an agent logs out because Set Make
Busy is implied when an agent log out record is received. The extension
number is always the prime line of the ACD extension.

Agent Remove
Make Busy

This is similar to Set Make Busy. No record is produced when the agent
logs on. The remove Make Busy is implied by the log in record. The
extension number is always the prime line of the ACD extension.

Agent Answer ACD

Agent Answer
Personal

Agent Make
Outbound

This record is produced whenever an agent answers a call that was
directed to the ACD hunt group. The event record contains the Agent ID
and extension number (hunt group pilot number to which the call was
placed). The ACD extension that answered the call can be determined by
using the last agent log in event for that extension. If the ACD set does not
have a logged in agent, the Agent ID area is blank and the extension
number is that extension’s prime line.
A record of all of the non-ACD hunt group calls are included in this
category. The extension number is always the prime line of the ACD
extension that answered.
This record is produced whenever an agent originates a call and enters a
conversation. A record is not produced under the following conditions:
entering a feature access code, dialing an invalid number, or hanging up
before the called party answers. An agent extension number is always the
prime line of the ACD set that originated the call.
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Table 28: ACD information provided by Agent event tab (continued)
AGENT EVENTS

DESCRIPTION
If Work Timer is in effect, the Agent Idle record is produced when the Work
Timer expires or when it is cancelled. If the agent enters Make Busy while
Work Timer is in effect, an Agent Idle record is produced followed
immediately by a set Make Busy record. A record is not produced to show
the end of the call or the start of the Work Timer. This entire period is
treated as part of the time to process the call.

Agent Idle

Agent Work Timer
Stat
Agent Remove
Work Timer

Agent Hold Active

Agent Hold Retrieve

If Work Timer is not in effect, the Agent Idle record is produced at the end of
a call, not when the agent hangs up. For example, if the agent presses the
HANG-UP softkey and remains off hook for 5 seconds, the record is
produced when the HANG-UP is pressed, not when the agent actually
goes on hook. The extension number is always the prime line of the ACD
set that is now idle.
This record is produced when an agent terminates an ACD call and the
Work Timer is started for that agent. If the Work Timer cannot be started,
an idle event record is produced instead.
This record is produced when the Work Timer expires for that agent.
When an agent places a call on hold, a record is produced. If the agent
places another call or answers a call on a second line, the second call will
be recorded independently of the first.
When the held call is retrieved, a record is produced, indicating that the
agent is now busy on that line.

Agent Hold Abandon When the held call is abandoned, a record is produced for that line.

Agent Answer
Remote ACD
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When an agent answers a remote ACD call, a record is produced. When
you have networked ACD (more than one telephone system networked
together), local calls are calls routed through the same telephone system
that the agent’s extension is located, remote calls are calls routed through
the other telephone system.

Agent Ringing ACD

This record is produced when the telephone rings with an ACD call.

Interactive Contact
Center Queue Set
DND Request

This record is produced when the agent set the queue in DND.

Interactive Contact
Center Queue Set
DND

A record is produced when the supervisor puts a queue in DND and when
the Contact Center Management system puts a queue in DND. In YourSite
Explorer=>Queues=>Business Hours tab, you set the hours of operation
for the business. The Contact Center Management system reads these
hours of operation and will put this queue in DND during off hours.

ACD Inspector

Table 28: ACD information provided by Agent event tab (continued)
AGENT EVENTS

DESCRIPTION

Interactive Contact
Center Queue
Remove DND
Request

This record is produced when the agent removed the queue from DND.

Interactive Contact
Center Queue
Remove DND

A record is produced when the supervisor removes the queue from DND
and when the Contact Center Management system removes the queue
from DND. In YourSite Explorer=>Queues=>Business Hours tab, you set
the hours of operation for the business. The Contact Center Management
system reads these hours of operation and will remove this queue from
DND during business hours.

Interactive Contact
Center Agent Login
Request

This record is produced when the agent logged on.

Interactive Contact
Center Agent Login

This record is produced when the supervisor logged on the agent.

Interactive Contact
Center Agent Logout This record is produced when the agent logged off.
Request
Interactive Contact
This record is produced when the supervisor logged off the agent.
Center Agent Logout
Interactive Contact
Center Set MKB
with Reason Code
Request

This record is produced when the agent sets himself as Make Busy.

Interactive Contact
Center Set MKB
with Reason Code

This record is produced when the supervisor sets the agent in Make Busy.

Interactive Contact
Center Remove
MKB Request

This record is produced when the agent sets himself in Make Busy.

Interactive Contact
Center Remove
MKB

This record is produced when the supervisor removes the agent from Make
Busy.

Interactive Contact
Center Set DND
Request

This record is produced when the agent sets himself as DND.
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Table 28: ACD information provided by Agent event tab (continued)
AGENT EVENTS

DESCRIPTION

Interactive Contact
Center Remove
DND

This record is produced when the supervisor removes the agent from DND.

Interactive Contact
Center Sync Queue

This record is produced when Interactive Contact Center queues are
synchronized to match the telephone system queues. In
YourSite=>Configuration=>Queue, under Interactive Contact Center
options, you can select this queue to be synchronized with the telephone
system data each night. That means that the information in Contact Center
Management will be changed to reflect what is programed on the telephone
system.

Interactive Contact
Center Sync Agent
Group

This record is produced when Interactive Contact Center agent groups are
synchronized to match the telephone system queues.

Interactive Contact
Center Sync Agent

This record is produced when Interactive Contact Center agents are
synchronized to match the telephone system queues.

Interactive Contact This record is produced when the synchronization between the Contact
Center Sync Started Center Management database and the telephone system is started.
Interactive Contact
Center Sync
Finished

This record is produced when the synchronization between the Contact
Center Management database and the telephone system is finished.

Queue events criteria for searches
When performing a queue events search, you can search on the following criteria:
l

Agent group statistics

l

Queue statistics

l

Date

The Queue events tab has the following search criteria:
Queue information
The Queue information box specifies the ACD queue or agent group used in the search. When you
type an ACD queue or agent group number, the search results contain records specific to that ACD
queue or agent group.
Queue event
When you select all three queue event check boxes (Agent Group statistics, Queue statistics,
Date), the search results contain records for all of the agent groups and queues, and all of the
telephone system refresh cycles. The telephone system performs a re-synchronization and
generates a refresh record every time it notices the date or hour has changed (once an hour).
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Agent information
The Agent information boxes specify the range of values for the Agents Available statistic used in
the search. For example, if you select a range of 5 to 10, the search results contain records for all of
the calls during periods when 5 to 10 agents were logged on to the ACD, but not in Make Busy or Do
Not Disturb.
Calls waiting/Longest waiting settings
The Calls waiting settings and Longest waiting settings boxes specify ranges of values for the Calls
waiting and Longest waiting statistics. For example, selecting a range from 10 to 999 in the Calls
waiting box produces all of the records for calls received during periods when more than 10 callers
waited in queue.
The Queue events tab displays the queue event criteria used in the search. (See Figure 74.)

Figure 74: ACD search criteria - Queue events tab
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Option events criteria for searches
The Option events tab displays the telephone system refresh records, error, and information criteria
used in the search. (See Figure 75.)
The Option events tab has the following search criteria:
Time ranges
The Time ranges boxes specify the time interval used for the search. The time interval applies to
searches on agent and queue events.
Exception records
Collector Service tags telephone system records that contain errors with an E (telephone system 1)
or e (telephone system 2). Under Exception records, you select the Error records check box to
include these records in the search output.
Collector Service writes a log record to the data stream upon start up. It tags the log record with an I
to indicate it is an information record. You select the Information records check box to include log
records in the search output. ACD Inspector displays the error and information search result records
on the Exception records tab.
In contact centers that have two telephone systems, Collector Service tags records from the second
telephone system with an S. The Com ports used by your telephone systems are specified in
YourSite Explorer under Media Servers=>Data collection.
Output record count
The Output record count specifies the maximum number of rows of records to display.
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Figure 75: ACD search criteria - Option events tab

RUNNING AGENT EVENTS SEARCHES
NOTE: When you run a search on Agent Answer ACD, type the Agent ID but do not type the agent’s
extension. Once answered, an ACD call is not pegged as an extension but is pegged as ACD. You
will get no data if you type the agent’s extension.
You can run an Agent events search to find all of the records of when agent 2005 was on ACD and
used Set Make Busy.
To run an Agent events search
1. In Contact Center Client, click Tools=>Inspectors=>ACD Inspector.
The Agent events tab of the ACD Inspector criteria tab opens.
2. Click Select dates and select March 3, 2003 to March 5, 2003.
3. Under Select media servers, Phone is preselected.
4. NOTE:
5. When you run a search on Agent answer ACD, type the Agent ID but do not type the agent’s
extension. Once answered, an ACD call is not pegged as an extension but is pegged as ACD.
You will get no data if you type the agent’s extension.
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6. You can find the Agent ID by selecting YourSite=>Configuration=>Agent login=>Agent login.
The Agent ID is located under the Agent login ID heading. Ensure you select the Agent ID
associated with the Phone media server.
7. Under Agent information, type the Agent ID, 2005.
8. Under Agent events, if you are not selecting all events, clear Select all.
9. Select the Agent event(s) you want to search on, in this case, Agent answer ACD, Set
Make Busy, and Remove Make Busy.
10. You can leave the ACD queue blank.
11. Click Start search.
12. The ACD Inspector results - Agent events tab opens.

Agent events search results
This section describes the records produced when you run searches in ACD Inspector. Table 29
describes the ACD information provided by the Agent events tab. The Agent events tab displays the
ACD activity and the Make Busy activity for agent 2005. (See Figure 76.)

Figure 76: ACD search results - Agent events tab
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Table 29: Agent events result information
COLUMN HEADING
Media server

Function/Event

DESCRIPTION
The Media server box identifies the telephone system (with or without
MiTAI) that produced the event record.
The Function/Event box displays the criteria for which you searched - in
this case Agent answer ACD, Agent set Make Busy, Agent remove
Make Busy.

Date

The Date box displays the date of the event record (month/day/year).

Time

The Time box displays the time the event occurred.

Extension Queue ID

The Extension Queue ID displays the Extension or ACD queue used for
the call. The Extension Agent ID column contains the extensions when
a search involves the extension (such as Make Busy). It contains Queue
IDs when no extension information is requested (such as Agent Answer
ACD).

Agent ID

The Agent ID box displays the agent number for the agent involved in the
call.

Line
Idle Event Modifier

The Line number box displays the telephone line the agent used to pick
up or originate the call.
The Idle Event Modifier box indicates when the agent is idle.

Narrowing an Agent events search
You can use the Options tab in conjunction with the Agent events search or the Queue events
search. Using the Options tab, you narrow down the time frame for either search.
You can run an Agent events search to find all of the records for a specific agent who was on ACD
and when that agent used Set Make Busy. Then you narrow the search with the Options tab to
search between 9:00 A.M. and 11:00 A.M. only. The ACD Inspector results on the Agent events tab
display the ACD activity and the Make Busy activity for agent 2005 between 9:00 A.M. and 11:00
A.M. (See Figure 77.)
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To run an Agent events/Options events search
1. In Contact Center Client, click Tools=>Inspectors=>ACD Inspector.
The Agent events tab of the ACD Inspector criteria tab opens.
2. Click Select dates and select March 3, 2007 to March 5, 2007.
3. Under Select media servers, Phone is preselected.
NOTE:
l

l

When you run a search on Agent answer ACD, type the Agent ID but do not type the
agent’s extension. Once answered, an ACD call is not pegged as an extension but is
pegged as ACD. You will get no data if you type the agent’s extension.
You can find the Agent ID by selecting YourSite=>Configuration=>Agent login=>Agent
login. The Agent ID is located under the Agent login ID heading. Ensure you select the
Agent ID associated with the Phone media server.

4. Under Agent information, type the Agent ID, 2005.
5. Under Agent events, if you will are not selecting all events, clear Select all.
6. Select the Agent event(s) you want to search on, in this case, Agent answer ACD, Set
Make Busy, and Remove Make Busy.
You can leave the ACD queue blank.
7. Click the Option tab.
8. Under Time ranges, select the Start at and End at times with which to narrow the Agent
events search.
In this example, the start time is 9:00 A.M. and the end time is 11:00 A.M.
9. Click Start search.
The ACD Inspector results - Agent events tab opens.
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Figure 77: ACD search results - Agent events tab

RUNNING QUEUE EVENTS SEARCHES
You can run a Queue events search to determine when you had too few agents available to answer
calls for a particular queue. You search for a maximum of two agents and local calls that waited
between one and three minutes.
To run a Queue events search
1. In Contact Center Client, click Tools=>Inspectors=>ACD Inspector.
The Agent events tab of the ACD Inspector criteria tab opens.
2. Click the Queue events tab.
3. Click Select dates and select March 1, 2003 and March 4, 2003.
4. Under Select media servers, Phone is preselected.
5. Under Queue information, type the ACD Queue, p280.
6. Under Queue event, select Queue stats.
7. Under Agent information, type 0-2 agents.
In this example, you want to know when you have only two agents scheduled to answer the
queue.
8. Under Calls waiting setting, select 0-999 Local calls waiting.
In this example, you want to know the number of calls waiting on the telephone system to
which your agent is connected. If you have only one telephone system, you do not have any
remote calls waiting.
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9. Under Longest waiting settings, select 1-3 minutes.
In this example, you want to know the number of local calls that waited between 1-3 minutes.
You think waiting up to a minute is acceptable, so you did not search for calls less than a
minute. If you have only one telephone system, you do not search for the remote longest
waiting.
10. Click Start search.
The ACD Inspector results - Agent events tab opens.
11. Click the Queue events tab.

Queue events search results
The Queue events tab displays the number of calls that waited between one and three minutes (one
call), when there were a maximum of two agents available, for the dates selected, for queue 280.
(See Figure 78.)

Figure 78: ACD search results - Queue events tab
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Table 30 describes the ACD information provided by the Queue events tab.
Table 30: Queue events result information
COLUMN HEADING
Media server

Function/Event

DESCRIPTION
The Media server box identifies the telephone system (with or without
MiTAI) application that produced the event record.
The Function/Event box indicates whether the event record is for a
queue or an agent group.

Date

The Date box displays the date of the event record (month/day/year).

Time

The Time box displays the time the event occurred (in seconds).

Queue/Agent group

The Queue/Agent group box displays the queue or agent group number.

Agents available

The Agents available box displays the current number of agents logged
on to the ACD system, who are not in Make Busy or Do Not Disturb.

CW (Number of local
calls waiting)

The CW box displays the number of local callers waiting for an
available agent.

LW (Longest local call
waiting)

The LW box displays the wait time for the caller waiting the longest in
queue for an available agent.

Rem CW (Number of
remote calls waiting)

When you have networked ACD (more than one telephone system
networked together), the Rem CW box displays the number of remote
callers waiting for an available agent.

Rem LW (Longest
remote call waiting)

When you have networked ACD (more than one telephone system
networked together), the Rem LW box displays the wait time for the
caller waiting the longest in a remote queue for an available agent.

Narrowing a Queue events search
You use the Options tab in conjunction with the Agent events search or the Queue events search.
Using the Options tab, you can narrow down the time frame for either search.
You can run a Queue events search to find when you have too few agents available to answer calls
for a particular queue. You search for a maximum of two agents and local calls that waited between
one and three minutes. Then you narrow the search with the Options tab to search between 9:00
A.M. and 11:00 A.M. only.
To run a Queue events/Options events search
1. In Contact Center Client, click Tools=>Inspectors=>ACD Inspector.
The Agent events tab of the ACD Inspector criteria tab opens.
2. Click the Queue events tab.
3. Click Select dates and select March 1, 2003 to March 4, 2003.
4. Under Select media servers, Phone is preselected.
5. Under Queue information, type the ACD Queue, p280.
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6. Under Queue event, select Queue stats.
7. Under Agent information, type 0-2 agents.
In this example, you want to know when you have only two agents scheduled to answer the
queue.
8. Under Calls waiting setting, select 0-999 Local calls waiting.
9. In this example, you want to know the number of calls waiting on the telephone system to
which your agent is connected. If you have only one telephone system, you do not have any
remote calls waiting.
10. Under Longest waiting settings, select 1-3 minutes.
11. In this example, you want to know the number of local calls that waited between 1-3 minutes.
You think waiting up to a minute is acceptable, so you did not search for calls less than a
minute. If you have only one telephone system, you do not search for the remote longest
waiting.
12. Click the Option tab.
13. Under Time ranges, select the Start at and End at times with which to narrow the Agent
events search.
14. In this example, the start time is 9:00 A.M. and the end time is 11:00 A.M.
15. Click Start search.
16. The ACD Inspector results - Agent events tab opens.
17. Click the Queue events tab.
The Queue events tab displays the number of calls that waited between one and three minutes,
when there were a maximum of two agents available, for the dates selected, between 9:00 A.M. and
11:00 A.M. for queue 280. There was only one call that waited between one and three minutes in the
selected time frame and queue. (See Figure 79.)
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Figure 79: ACD search results - Queue events tab

RUNNING WILD CARD QUEUE EVENTS SEARCHES
When performing searches on the Queue Events tab, you can enter a P800 under Queue information
and the search will produce records involving Queue 800 only. Alternatively, you can run wild card
searches. When you perform wild card searches, you use * to represent the wild card. For example,
if you enter '*00' under Queue information on the Queue events tab, the search will produce records
for all of the Queues or Agent groups that end in '00' (for example, 200, 300).
To run a wild card Queue events search, where all of the queues end in '00'.
1. In Contact Center Client, click Tools=>Inspectors=>ACD Inspector.
The Agent events tab of the ACD Inspector criteria tab opens.
2. Click the Queue events tab.
3. Click Select dates and select February 9, 2003 and February 10, 2003.
4. Under Select media servers, Phone is preselected.
5. Under Queue information, type *00.
6. In this example, you are searching for all of the queues that end in '00'.
7. Under Queue event, select Queue stats.
8. Under Agent information, type 0-2 agents.
9. In this example, you want to know when you have only two agents scheduled to answer the
queue.
10. Under Calls waiting setting, select 0-999 Local calls waiting.

356

Contact Center Solutions User Guide

11. In this example, you want to know the number of calls waiting on the telephone system to
which your agent is connected. If you have only one telephone system, you do not have any
remote calls waiting.
12. Under Longest waiting settings, select 1-3 minutes.
13. In this example, you want to know the number of local calls that waited between 1-3 minutes.
You think waiting up to a minute is acceptable, so you did not search for calls less than a
minute. If you have only one telephone system, you do not search for the remote longest
waiting.
14. Click Start search.
The ACD Inspector results - Agent events tab opens.
15. Click the Queue events tab.
See Figure 80.

Figure 80: ACD Wild card search results - Queue events tab
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Wild card queue events search results
The Queue events tab displays the Queue statistics when there were a maximum of two agents
available, for the dates selected, for all of the queues that end in '00'. The Queue statistic in this case
are the records of the telephone system performing re-synchronization. A refresh record is produced
every time the system notices the date or hour has changed (once an hour).

RUNNING SEARCHES FOR ERROR AND INFORMATION
RECORDS
Using the Options tab, you can run a search for error and information records. The error messages
are records of sequence errors. The information records are records of when the Collector restarts.
To run an exception events search
1. Click the ACD Inspector criteria tab.
2. Click the Options tab.
3. Click Select dates and select a date.
4. Under Select media servers, Phone is preselected.
5. Under Time ranges, type the Start at and End at times.
6. Under Exception records ensure the Error records and/or Information records check
boxes are selected.
7. Under Output record count, select the maximum number of records you want to display.
8. Click Start search.
The ACD Inspector results - Agent events tab opens.
9. Click the Exception events tab.

Exception events search results
Table 31 describes the ACD information provided by the Exception events tab.
Table 31: Exception event result information
COLUMN HEADING
Media server

Record

DESCRIPTION
The Media server box identifies the telephone system (with or without
MiTAI) application that produced the event record.
The Function/Event box displays refresh records. The refresh event
signifies the start of a new cycle of group and queue statistics.

358

Contact Center Solutions User Guide

SMDR INSPECTOR
SMDR Inspector searches through SMDR data to find specific contact center events. For example,
suppose you receive a complaint from a caller who waited 16 minutes in queue for a customer
service agent, sometime between 1:00 P.M. and 1:30 P.M. sometime last week. In a single session,
you can search through data from multiple days to find a specific event. The search follows a wild
card format. Your specifications do not have to be exact. You can make the search as inclusive or
exclusive as you wish. The results are placed in an easy-to-interpret grid that can be printed or saved
to file. You can verify that your reports are valid by conducting searches against raw telephone
system data.
Common SMDR Inspector searches include searches for all of the records on
l

Queue P001

l

Calls the telephone system sent to agent group 23

l

The queue for which agent 8000 answered calls

l

Outbound calls made by agent 2311 (internal and external)

l

Where Account Codes were entered

l

DNIS that start with 89

l

Calls transferred to trunks

The search result tabs consist of the following:
l

SMDR search results

l

Exception results

STARTING SMDR INSPECTOR
To start SMDR Inspector on the client computer
1. Click Tools in the Contact Center Client ribbon.
2. In the Data Mining column, click Inspectors to open the Data Inspectors tool.

RUNNING SEARCHES IN SMDR INSPECTOR
When you run a search, SMDR Inspector searches through the raw telephone system data on the
local hard drive. Each search requires the following information:
Select dates/Delete dates
The Select dates button specifies the date range within which you want to search. The Delete dates
button deletes days within the range you selected. The date is displayed month first, then day, then
year.
Select media servers
The Select media servers check boxes specify the origin of the data used in the search. Currently
you can search on telephone activity only. In the future, you will be able to search on email and chat
activity.
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In addition to the date and media server parameters, SMDR Inspector has the following search
criteria tabs:
l

Call parties

l

Call types

l

Options

Call parties criteria for searches
The Call parties criteria helps you to find call events such as, what calls an agent received (Called
party), what calls an agent made (Calling party), or what extension the call was transferred to (Third
party). (See Figure 81.)
The Call parties tab search options are as follows.
Digits dialed
The Digits dialed box specifies the queue number of the queue that picks up the call (for inbound
calls).
The ANI digits box specifies the area code and telephone number for an inbound call. The search
results contain records that match the data the user typed in the ANI field.
The DNIS digits box specifies the phone number the caller dialed. The DNIS could be product
specific, or it could specify demographic variables or marketing targets.
The Account Code box specifies the Account Code number used in the search. Agents enter
Account Code numbers to tag inbound and outbound calls.
Outbound calls
The Outbound calls box specifies telephone number the agent dials (for outbound calls).
Call parties
The Calling party box specifies the extension or agent number (for an outbound call), or the trunk
number (for an inbound call) used in the search.
The Called party box specifies the answering extension or the trunk number (for an outbound call)
used in the search.
The Third party box searches for call records on the extension number used in a transfer.
Call identification
The Call identification box specifies the Mitel call IDs assigned to a call segment.
The Sequence ID box specifies the sequence number assigned to the call record by the telephone
system.
The Associated ID box specifies the number attached to associated data records of the call
assigned by the telephone system.
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Figure 81: SMDR search criteria - Call parties tab

Call types criteria for searches
The Call types tab displays the types of calls the agent receives, for example, ACD or non-ACD,
abandoned, interflowed, requeued, unavailable, or outbound calls. (See Figure 82.)
The Call types tab search options are as follows.
Call types
The Call types check boxes specify one or more categories of calls used in the search. The
telephone system generates an Unavailable (Queue unavailable calls) event record when a caller
dials a queue and the queue is not available (in DND) or there are no agents logged on to handle the
call.
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Answer supervision
The Answer supervision check box searches for instances where calls were answered by the called
party. If you have answer supervision and you make an outbound call but the called party does not
answer (you hang up) then an SMDR record is generated with no duration. If you do not have answer
supervision then no SMDR record is generated at all.
Busy call
The Busy call check box searches for call records on queues or extensions the caller dials but finds
busy.
Error by caller
The Error by caller check box searches for call records on numbers the caller dials that are not
recognized by the telephone system.
TAFAS answered
The TAFAS Answered check box searches for call records that involve calls manually picked up by
agents at alternate extensions. In a TAFAS answered call, an employee hears another employee's
phone ring and dials a number to pick up the call.
Internal call
The Internal call check box searches for call records on calls between employees that do not involve
trunks.
Blank
The Blank check box searches for call records that have no data in the Call completion box. That is,
when the check box is selected, the search output contains records where there is nothing recorded
in the Call completion box.
Attendant involved
The Attendant involved options specify whether or not call records for calls involving an automated
attendant are used in the search.
Transfer/Conference
The Transfer/Conference check box searches for records on transferred or conferenced calls.
Speed call/Forward
The Speed call/Forward check boxes search for call records involving a speed dial and/or
conference function. When the Blank check box is selected, the search output contains records
where there is nothing recorded in the Speed or Fwd check boxes.
System ID
The System ID check box searches for call records that pertain to a specific telephone system. In a
multi-site enterprise, you program each telephone system with a 3-digit system ID number. You can
distinguish records by their system ID number. The telephone system appends it to all of the SMDR
records.
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Figure 82: SMDR search criteria - Call types tab

Options criteria for searches
When you click Tools=>Inspectors=>SMDR Inspector, the Options tab opens. The Option criteria
work in conjunction with the Call parties criteria and the Call types criteria to narrow down the
search. (See Figure 83.)
The Options tab search options are as follows.
Time ranges
The Time ranges boxes specify the time interval used for the search.
Call duration
The Call duration boxes specify a range of values for the Call duration statistic used in the search.
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Time to answer
The Time to answer boxes specify a range of values for the Time to answer statistic used in the
search. For example, if you select a time to answer of 240 to 999 seconds, the search records
include calls that were answered by an agent after waiting at least 240 seconds to be answered.
Exception records
The Collector Service tags telephone system records that contain errors with an E (telephone
system 1) or e (telephone system 2). You select the Error records check box to include these records
in the search output.
The Collector Service writes a log record to the data stream upon start up. It tags the log record with
an I to indicate it is an information record. You select the Information records check box to include
log records in the search output. ACD Inspector displays the error and information search result
records on the Exception Records tab.
In contact centers that have two telephone systems, the Collector Service tags records from the
second telephone system with an S. You specify the Com ports used by your telephone systems on
the Data collection tab in YourSite Configuration.
Output record count
The Output record count specifies the maximum number of rows of records to display.
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Figure 83: SMDR search criteria - Options tab

SMDR search results information
The SMDR Search results tab shows the search results for Call parties, Call types, and Options
searches. Table 32 describes the SMDR information provided by the SMDR Search results tab.
Table 32: SMDR search results information
COLUMN
HEADING
Media server

Start time
Date
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DESCRIPTION
The Media server box identifies the telephone system (with or without
MiTAI) that produced the event record.
The Start time of a call is reported in hours and minutes in either a 12- or 24hour format. If a 12-hour clock is used, the letter P indicates P.M. (hh:mmp)
The Date box displays the date of the event record (month/day/year).

SMDR Inspector

Table 32: SMDR search results information (continued)
COLUMN
HEADING

DESCRIPTION

Total duration

The duration of a call is reported in hours, minutes and seconds
(hh:mm:ss). Leading zeros are output (Maximum time = 99 hours, 59
minutes, 59 seconds). If the call duration exceeds 100 hours, a call duration
of 99 hours, 99 minutes, 99 seconds will be recorded.
The Calling party is the identity of the party that/who originated the call. It
may be a station, an attendant, or an incoming trunk, as described below:
(a) Station number as Calling party (cccc). A station number (extension
number or agent ID) may be one to four digits (0-9, *, #) which are leftjustified (that is, no leading zeros).

Calling party

(b) Attendant as Calling party (ATTm). Calls originated by an attendant that
do not involve a third party are reported as a calling party by ATT, followed
by the console number. When the console number is in the range of 10
through 99, the format is modified to be ATmm. If an attendant calls an
outside party on behalf of a station or trunk, that station or trunk is reported
as the caller but the attendant flag symbol [*] is shown in the Attendant was
Involved box.
(c) Trunk number as Calling party (Tnnn or Xnnn). When the originating
party is an incoming CO trunk, Tnnn is shown on the record, where nnn is
the number of the trunk. If the trunk number is less than three digits long, it
is left-padded with zeros. If the extended digit length option is enabled, the
trunk number nnnn may be up to four digits long, left-justified and without
leading zeros. When the originating party is an incoming non-CO trunk,
Xnnn is shown in the trunks record. The T or X ensures that CO trunks and
CO Attendant trunks can be distinguished from tie trunks. The trunk
number is the trunk ID specified during customer data entry in the Trunk
Assignment form.

Attendant flag

Time to answer
(Time to Ans)

This 1-digit box contains an asterisk [*] when a call is assisted by, or
initially answered by, an attendant. This flag will not be shown if a call is
transferred to an attendant.
This is the number of seconds from the time an incoming external call rings
the destination until the call is answered. If a call is never answered, this
box displays three asterisk [***]. Leading zeros are output and the box
remains at 999 when an overflow is reached. If the Call Distribution (MCD)
feature package is installed, and the MCD report transfers option is
enabled, this box contains the total time to answer regardless of the
number of times the call is rerouted. This box does not apply to Internal
SMDR.
NOTE: Time to answer does not include the duration the request waits in
queue outside of regular business hours.
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Table 32: SMDR search results information (continued)
COLUMN
HEADING

DESCRIPTION
External SMDR

Digits dialed

External SMDR records the digits dialed on the outgoing trunk. A maximum
of 26 digits is recorded. This number is reduced to 20 when the Report
Meter Pulses option is selected in CDE. This box does not include the
trunk group access code on outgoing calls. The digits recorded are the
actual digits outpulsed on the trunk after digit modification has been
performed. On incoming calls, the digits dialed in on the trunk are recorded.
The digits dialed field contains the digits the telephone system used to
route the call. For an incoming call this could be the extension or the path to
which the call is being routed. For outgoing calls this is the number the
caller dialed. When more than 26/20 digits are dialed, the remaining digits
are ignored.
If the MCD option is enabled, each device is listed whenever the call is
rerouted, rather than the last device as in non-MCD loads. To reflect the
MCD option, the Digits dialed on the Trunk box displays dd1 ddd2 ddd3.
Internal SMDR
Internal SMDR records the digits dialed on an internal line. Up to 26 digits
are recorded.
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Table 32: SMDR search results information (continued)
COLUMN
HEADING

DESCRIPTION
External SMDR (Outgoing calls)
This reports the completion status of an outgoing call in so far as the
telephone system is able to determine it. When an outgoing call fails tolldeny checking and is dropped, this box contains a T. When the trunk group
is programmed to receive Answer Supervision and a supervision is
received, an A is reported. When the trunk group is programmed for Toll
Reversal and a supervision is received, a T is reported.
External SMDR (Incoming calls)

Call completion flag

The telephone system can monitor the outcome of a call and can provide a
comprehensive report on call completion. When the station or hunt group to
which a call is directed is busy, a B is recorded. When an incoming trunk
accesses an invalid number and receives reorder tone, an E is reported. An
E is also reported for incomplete calls. A T is reported if the incoming trunk
is answered with Trunk Answer From Any Station (TAFAS) and if an
outgoing trunk call is toll denied, or if the call is Pickup answered.
When an incoming call is forwarded by an attendant to a busy station, a B
is shown in the call completion status box, the number called is shown as
the third party, and the Attendant is shown as the called party.
Internal SMDR
An I indicates that an internal call was completed.
Speed Call or Call forward flags (S or F)
This box contains an S when the number is speed dialed, and an F when an
external call is forwarded through the external call forward feature.
If Internal SMDR is enabled, an F is also recorded when an internal call is
forwarded through the call forward feature. However, for internal calls the
Third Party box does not contain the number of the station that initiated the
call forward feature. The Third Party box is left blank because the Digit
dialed box identifies the station that has call forward enabled.

Speed call forward

The Speed call/Forward check boxes search for call records involving a
speed dial and/or conference function. When the Blank check box is
selected, the search output contains records where there is nothing
recorded in the Speed or Fwd check boxes.
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Table 32: SMDR search results information (continued)
COLUMN
HEADING

DESCRIPTION

Called party

A Called party can be a station number, an attendant, or for outgoing calls,
the outgoing trunk number. The Called party output format is identical to
that used for the Calling party. See Calling party. For incoming calls to an
attendant, the called party is recorded as the attendant unless the attendant
transfers a call to a station. For direct-in-lines, it would be the station
number. On outgoing calls handled by an attendant, the called party would
be the outgoing trunk’s ID.

Transfer/Conference
call
(Trans Conf)

This box identifies calls involving three or more parties. It contains a T for
supervised transfers, X for unsupervised transfers (that is, transfer in to
busy reports a T, transfer in to ringing reports an X), and a C for 3-way
conversations or conferences.
The Third party box contains the number of the station to which a trunk call
has been transferred. When several transfers take place during a trunk call,
the first party is the only one reported, as long as MCD Report transfers =
No, and Record transfers = No.

Third party

Account Code

Enabling the report Account Codes option in the SMDR Options
Assignment form allows an Account Code of two to 12 digits to be recorded
here, if one is used to make a call. Leading zeros are reported if they are
entered.

Route optimization
flag

At the starting and end nodes of a network call a flag will be shown in this
box if route optimization has taken place. A route optimized call involves
two trunks to the same party: the pre-optimization trunk and the postoptimization trunk. An SMDR record will be produced for both trunks, which
will be distinguished by a lower case r for the pre-optimization trunk, and an
upper case R for the post-optimization trunk. Route optimization is
available with the MSDN/DPNSS Voice IV feature package only.

ANI/DNIS
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If an external call is made to a station whose call forwarding is set to an
external number, the Third party box contains the number of the station that
initiated the call forward feature. For internal calls, the Third Party box is left
blank because the Digit dialed box identifies the station that has external
call forward enabled.

ANI/DNIS digits are recorded in this box. ANI and DNIS numbers can be
up to 10 digits in length, and are recorded for incoming calls on ANI/DNIS
trunks. COS option ANI/DNIS reporting must be enabled.
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Table 32: SMDR search results information (continued)
COLUMN
HEADING

DESCRIPTION

System identifier

This optional 3-digit box may contain values from 000 to 999. 000 indicates
that no identifier has been entered. In the absence of a System identifier, a
Node identifier is printed (when programmed). When more than one node
identifier exists, the first one on the programmed list is printed. When both a
System ID and a Node ID are programmed, the System ID takes
precedence. Programming of System Identifiers and Node Identifiers is
described in the Customer data entry volume.

Call ID

The Call ID box specifies the call number to which the record relates.

Call ID seq

The Sequence ID box specifies the sequence number assigned to the call
record.

Assoc call ID

The Associated ID box specifies the number attached to associated data
records of the call.

System ID

Record

This optional 3-digit box may contain values from 000 to 999. 000 indicates
that no identifier has been entered. In the absence of a System identifier, a
Node identifier is printed (when programmed). When more than one node
identifier exists, the first one on the programmed list is printed. When both a
System ID and a Node ID are programmed, the System ID takes
precedence. Programming of System Identifiers and Node Identifiers is
described in the Customer data entry volume.
See "SMDR record boxes" on page 370.

SMDR record boxes
This section describes the SMDR search output records available.
The telephone system records SMDR data in table format. Table 33 provides information used to
interpret the SMDR Inspector search output. It summarizes the SMDR record boxes and provides
the meaning of the symbols used.
Table 33: Summary of boxes in SMDR records
NAME
Date

Start time

FORMAT
mm/dd

hh:mmp

DEFINITION

NOTES

mm = Month

mm = 01 - 12

dd = Day

dd = 01 - 31

hh = Hours

hh = 00 - 12 or 00 - 23

mm = Minutes

mm = 00 - 59

p = pm

p = P.M. (12-hour clock)
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Table 33: Summary of boxes in SMDR records (continued)
NAME

FORMAT

hh:mm:ss

DEFINITION

hh:mm:ss = duration in
hours:minutes:seconds

Duration of
call

NOTES

hh = 00 - 99
mm = 00 - 99
ss = 00 - 99

hhhh:mm:ss

hhhh:mm:ss = duration in
hours:minutes: seconds

hhhh = 0000 - 9999
mm = 00 - 99
ss = 00 - 99

cccc = Extension #
Tnnn = Trunk # (CO)
pppp

Xnnn = Trunk # (non-CO)

c = 0 - 9, *, #
nnn = 000 - 999

ATTm = Attendant
m = Console # (ATmm for

Calling party

Attendant 00 - 99)
ccccccc = Extension #
Tnnnn = Trunk # (CO)
ppppppp

* = Attendant

Time to
answer

f

ttt

-- = Attendant not involved
ttt = time in seconds (000 999) *** = Call unanswered

xx...x
x...x y...y
Digits dialed
on the trunk

or
Tx...x y...y
(Network
Format)
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nnnn = 0000 - 9999

Xnnnn = Trunk # (non-CO)
ATTmm = Attendant

Attendant

c = 0 - 9, *, #

mm = Console #
Attendant answered or
initiated the call, then
transferred it to an
extension
Leading zeros output.
Incoming calls only.
x = 0 - 9, *, #

Up to 26 (20 if metering) digits
dialed on the trunk
Network Format: up to 26 digits
(20 if metering) in total

y = 0 - 9, *, #
x...x = Node ID &
Extension # (up to 14 digits)
y...y = actual digits dialed
Tx...x = Node ID & Trunk #
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Table 33: Summary of boxes in SMDR records (continued)
NAME

FORMAT

DEFINITION

NOTES

A = Answer supervision
Call
completion
status

h

B = Called party busy

Outgoing

E = Caller error

Incoming Direct/Dial-in

I = Internal call

Incoming/Dial-in incoming

T = Toll-denied, TAFAS
answered, or Pickup answered

Incoming/Outgoing

S = Number was Speed
called
Speed call or
Call fwd flags

S or F

qqqq

Called party

qqqqqqq

F = External call forwarded
Outgoing
through External call fwd feature
or internal call forwarded
through Call forward feature
cccc = Extension #

c = 0 - 9, *, #

Tnnn = Trunk # (CO)

nnn = Range specified in
telephone system form
programming

Xnnn = Trunk # (non-CO)

ATTm = Attendant

m = Console # (ATmm for
Attendant 00 - 99)

ccccccc = Extension #

c = 0 - 9, *, #

Tnnnn = Trunk # (CO)

nnnn = 0000 - 9999

Xnnnn = Trunk # (non-CO)
ATTmm = Attendant

mm = Console #

T = Supervised transfer
X = Unsupervised transfer
Transfer/
Conference
call

C = 3-Way or Conference
K

R = re-queue call

U and I only apply to
ACD TELEMARKETER®
2000.

U = Path unavailable
I = Interflow
Third party
Account
Code (opt.)

rrrr

cccc = Extension #

c = 0 - 9, *, #

rrrrrrr

cccccccc = Extension #

c = 0 - 9, *, #

aa....a

Length of 2 to 12 digits

a = 0 - 9, space-filled
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Table 33: Summary of boxes in SMDR records (continued)
NAME

FORMAT

DEFINITION

NOTES

r = pre-optimization trunk
Route
optimization
flag (opt.)

s

R = post-optimization trunk
- = Space (no route
optimization)
i = 0-9
iii = 000 - 999

System
identifier
(optional)

000 = No code entered
iii

Entered by System ID

In the absence of a System
ID, a Node ID is printed (if
programmed). When both
System ID and Node ID are
programmed, System ID
takes precedence.

Format
-aaaaaaaaaa-dddddddddd
- = blank
ANI/DNIS

xx...xxxxxxx

a = ANIS digit
d = DNIS digit

For Extended digit length
format only the 7 right most
DNIS digits are recorded.

Extended digit length format
-aaaaaaaaaa-ddddddd

RUNNING CALL PARTIES SEARCHES
You can run a Call party search to find out who called agent 2005 on March 10, 2004.
To run a Call parties search
1. Click the SMDR Inspector criteria tab.
The Options tab opens.
2. Click the Call parties tab.
3. Click Select dates and select March 10, 2003.
4. Under Select media servers, Phone is preselected.
5. Under Call parties, type the Called party, agent ID 2005.
6. Click Start search.
The SMDR Inspector results - SMDR Search results window opens.

373

SMDR Inspector

Call parties search results
The SMDR Search results tab displays the results of who called agent 2005. The agent’s extension
is 1106. He answers calls that come to queue 280 and dial zeros (which is extension 1290). On line
one of the results, an outside call dialed the agent’s extension. On line two, the agent answered a
call from his queue (P280). On line three, we see that extension 1107 called the agent. On line four,
we see that extension 1112 called his extension. (See Figure 84.)

Figure 84: SMDR search results tab - Call parties search

RUNNING CALL TYPES SEARCHES
You run a Call types search when you want to narrow down the Call parties search. Previously, you
have completed a Call parties search for agent 2005 (Call parties tab). Now you want to narrow the
search to include only Answer non-ACD call types.
To run a Call types search
1. Click the SMDR Inspector criteria tab.
The Options tab opens.
2. Click the Call parties tab.
3. Click Select dates and select March 10, 2003.
4. Under Select media servers, Phone is preselected.
5. Under Call parties, type the Called party, agent ID 2005.
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6. Click the Call types tab.
7. Under Call types, clear the check boxes for all of the criteria but Answer non-ACD.
8. Click Start search.
The SMDR Inspector results - SMDR Search results window opens.

Call types search results
The SMDR search results tab displays the call parties/call type results. All of the non-ACD calls
received by agent 2005 on March 10, 2004 are displayed. They included external and internal calls
where the caller dialed the agent’s extension (1106), and all of the dial zero calls. (ACD calls are
calls that are sent through the queue.) (See Figure 85.)

Figure 85: SMDR search results - Call types search

RUNNING OPTION SEARCHES
You run Option searches to narrow down further, Call types and Call parties searches. Previously,
you ran a Call parties search for agent 2005, and then a Call types search to include only Answer
non-ACD calls. Now you want to search for Answer non-ACD calls for agent 2005 that occurred
between 9:00 A.M. and 1:00 P.M.
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To run an Options search
1. Click the SMDR Inspector criteria tab.
The Options tab opens.
2. Click the Call parties tab.
3. Click Select dates and select March 10, 2003.
4. Under Select media servers, Phone is preselected.
5. Under Call parties, type the Called party, agent ID 2005.
6. Click the Call types tab.
7. Under Call types, clear the check boxes for all of the criteria but Answer non-ACD.
8. Click the Options tab.
9. Under Time ranges, after the Start At time, type 9:00:00.
10. Under Time ranges, after the End At time, type 12:59:59.
11. Click Start search.
The SMDR Inspector results - SMDR Search results window opens.

Options search results
The SMDR search results tab displays the call parties/call type/options results. All of the non-ACD
calls received by agent 2005 on March 10, 2004 between 9:00 A.M. and 1:00 P.M. are displayed.
They included external and internal calls where the caller dialed the agent’s extension (1106), and all
of the dial zero calls. (ACD calls are calls that are sent through the queue.) (See Figure 86.)

Figure 86: SMDR Search result - Options search
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RUNNING SEARCHES FOR ERROR AND INFORMATION
RECORDS
Using the Option tab you can run a search for error and information records. The error messages are
records of sequence errors. The information records are records of when the Collector restarts.
Previously, you ran a Call parties search for agent 2005, and then a Call types to include Answer
non-ACD that occurred between 9:00 A.M. and 1:00 P.M.
To run an Exception event search
1. Click the SMDR Inspector criteria tab.
The Options tab opens.
2. Click the Call parties tab.
3. Click Select dates and select March 10, 2003.
4. Under Select media servers, Phone is preselected.
5. Under Call parties, type the Called party, agent ID 2005.
6. Click the Call types tab.
7. Under Call types, clear the check boxes for all of the criteria but Answer non-ACD.
8. Click the Options tab.
9. Under Time ranges, after the Start At time, type 9:00:00.
10. Under Time ranges, after the End At time, type 12:59:59.
11. Under Exceptions, select the Error records and Information records check boxes.
12. Click Start search.
The SMDR Inspector results - SMDR Search results window opens.

Exception search results
There was an information record produced every five minutes. Either the alarm is set incorrectly (the
system thinks it should be receiving data because the business hours indicate the business is open),
or the connection has died. The Exception results tab displays error and information records. (See
Figure 87.)
The Exception search has the following results information:
Media server
The Media server box identifies the telephone system (with or without MiTAI) that produced the
event record.
Record
The Data record box displays detailed information on the exception record.
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Figure 87: SMDR search results - Exception results tab

WILD CARD SEARCHES
NOTE:
l

l

To search for a string of numbers within a digits dialed string, enclose the string of numbers in
parenthesis, such as '8905'. The search will produce records that include 8905 only in the
digits dialed string.
To search for records where the calling, called or third party involved a trunk (BOTH T and X in
one search), put a C in the calling, called or third party box.

When performing searches on the Queue Events tab, you can enter a P800 under Queue information
and the search will produce records involving Queue 800 only. Alternatively, you can run wild card
searches. When you perform wild card searches, you use * to represent the wild card. For example,
if you enter '*00' under Queue information on the Queue events tab, the search will produce records
for all of the Queues or Agent groups that end in '00' (for example, 200, 300).

378

Contact Center Solutions User Guide

EXPORTING SEARCH RESULTS
You can save the ACD Inspector and SMDR Inspector search results in the following formats:
l

HTML

l

Microsoft Excel

l

XML

l

Text

To export the search results
1. Click Save search.
The Inspector Search Results Export window opens.
2. Select the format in which you want the search results saved: HTML, Microsoft Excel, XML,
or Text.
3. Click Next.
4. Click the ellipses to select the location where you want to save the file.
5. After File name, type the file name.
6. Click Save.
7. Click Next.
8. Click Next to confirm the format in which you want to save the file and the location of the file.
A window opens with the message 'Inspector Search Results export to [export type]
complete.'
9. Click OK.
10. Click Finish.
A window opens with the message 'Would you like to view/open this file now?'
11. If you want to view the file immediately, click Yes.
The file opens.

AUDITOR
Using Contact Center Auditor you can view historical, multimedia real-time events, at your own
pace. Auditor makes it easy for you to analyze when and why past service problems occurred. You
can see a series of events that led to a problem and analyze when and why it occurred. In the future,
you will be able to recognize when another problem is about to occur.
For example, you notice that on July 15 you have 12 contacts abandon between 10:00 AM and 10:15
AM. You can review the contacts and the agents’ actions on that date for that time period with
Auditor. Did all of the contacts arrive at the same time? Did all of the agents go on break at the same
time? If all of the contacts arrived at once, you need to schedule more people. If all of the agents
went on break at the same time, you need to adjust their break schedule.
Using Auditor you can also track when employees log on and log off the system. It is easy to
determine if any of the employees consistently start late or finish early.
With Auditor, you can use existing profiles, including alarm thresholds, when viewing past days run
in real-time.
In order to access Auditor, your security role must have the 'May manage Auditor' option enabled.
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Auditor

The first tool bar consists of real-time monitors that provide information on agent availability, queue
statistics, and graphic displays on queues. (See Figure 88.)

Figure 88: Auditor

AUDITOR ICONS
Using Auditor’s second toolbar you select the date of the historical real-time events that you want to
view and the speed at which to play the events. The icons are described in Table 34.
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Table 34: Auditor Icons
ICON

TERM
Calendar

MEANING
You can select the date of the historical real-time events that
you want to view by clicking the calendar.

The Speed of audit is expressed as a ratio of real-time to play
speed. You can select the speed from a list of ratios that opens
when you click the clock: 1:1, 1:2, 1:5, 1:10, 1:30, 1:60, and
Speed of audit
1:120. If you select the ratio1:1, it will take you one second to
view one second of the past day. If you select 1:60, it will take
you one second to view one minute of the past day.
Rewind

Stop

Pause

Play
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If you click Rewind when the play is stopped, you jump back to
the beginning of the day.
You can stop the real-time historical events from playing, and
jump back to the beginning of the day, by clicking Stop.
You can pause the real-time historical events by clicking
Pause.
You can play the real-time historical events by clicking Play.

Step forward

You can select the increment (in seconds) you will advance
from a list that opens when you click the down arrow to the
right of Step forward: 1 sec, 2 sec, 5 sec, 10 sec, 15 sec, 30
sec, and 45 sec. If you select 30 seconds, then when the play
is stopped, you can step forward in 30 second increments each
time you click Step forward. When you reach the end of data
for that day, you will automatically jump to the end of the day.

Jump forward

You can select the increment (in minutes) you will advance
from a list that opens when you click the down arrow to the
right of Jump forward: 1 min, 2 min, 5 min, 10 min, 15 min, 30
min, and 60 min. If you select 10 minutes, then when the play
is stopped, you can jump forward in 10 minute increments each
time you click Jump forward. When you reach the end of data
for that day, you will automatically jump to the end of the day.

Slider

As you view the events of the day, the slider indicates the time
at which the events occurred. The length of the slider
represents the length of the day for which you are viewing
historical real-time events.

Auditor

VIEWING HISTORICAL REAL-TIME EVENTS
You start Contact Center Client to gain access to Auditor functionality. For more information on
Contact Center Client real-time monitoring, see "Contact Center Client" on page 202.
To view historical real-time events, you must
1. Start Contact Center Client.
2. Open the grids in which you want to view historical events.
3. Start Auditor.

Starting and using Auditor
NOTE: If you are using the Contact Center Client marquee, Interactive Visual Queue, Contact
Center PhoneSet Manager, or Contact Center Softphone applications (which function in real time
only), open Auditor in another instance of Contact Center Client.
To start and use Auditor
1. In the Contact Center Client ribbon, click Auditor Controls.
2. Click Auditor Mode in the toolbar ribbon.
The Auditor toolbar displays.
See Figure 89.
3. Click the calendar icon and select a date.
The date displays on the left of the slider.
4. Click the speed icon and select the speed of the audit.
The speed of the audit, expressed as a ratio of real time to play speed, displays on the right of
the speed icon.
5. Move the slider to select the time of day at which you want to start monitoring.
6. Click the play button to play the real-time events of the selected date.
The historical real-time events play at the speed you selected.

Figure 89: Auditor toolbar
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DATA COLLECTION
The telephone system generates real-time and historical data used to manage your contact center.
You use real-time data to monitor the current Call Load and agent availability, and make minute-tominute adjustments. You use historical information for forecasting, staffing, and scheduling.
NOTE: A single collection point can collect ACD/SMDR data from up to 65 voice media servers. If
you are attempting to collect data from more than 65 PBXs with a single collection point, you must
contact Mitel Technical Support at 1-800-722-1301 (North American customers) or your approved
Mitel vendor (for customers residing in Latin America, Europe, the Middle East, Africa, and Asia
pacific) for guidance.
The Enterprise Server Collector Service writes SMDR and ACD data to text files. The text files are
located on the Enterprise Server in C:\Program Files (x86)\prairieFyre Software
Inc\CCM\DataDirectory\Node_x.

VERIFYING MEDIA SERVERS ARE RECEIVING
TELEPHONE SYSTEM DATA
The Data link window displays the following information
l

l

l

l

l

SMDR/ACD
SMDR/ACD displays SMDR/ACD records as they arrive from the telephone system.
Records today
Records today displays the total number of SMDR/ACD records received by Collector
Service for the day that were valid SMDR or ACD records.
Last received
Last received displays the date and time Collector Service received the SMDR/ACD record
last sent.
Clear records
The Clear records button clears the records displayed on the Data links window.
Reset SMDR link/Reset ACD link
The Reset SMDR link/Reset ACD link button resets the SMDR/ACD data link from the
telephone system to Collector Service when SMDR data stream/ACD data stream shows no
data is streaming. If you attempt to reset the link and data does not start streaming, check
your cabling connections from the telephone system to TCP/IP sockets.

To verify a media server is receiving telephone system data
l

In YourSite Explorer, select a 3300 ICP media server and click the Data link button in the
Tool tab of the ribbon to access the Data link window.
See Figure 90.

To reset the data links
l
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If no data is streaming in the SMDR or ACD panes, click the Reset SMDR/ACD link button.

Verifying media servers are receiving telephone system data

Figure 90: Data link window

TROUBLESHOOTING DATA COLLECTION ISSUES
There are several possible reasons why data does not stream. The following solutions address the
most common streaming problems:

SMDR data is not streaming
SMDR data records are generated at the end of calls. If SMDR data is not flowing through the
TCP/IP sockets, then the telephone system is not producing data records, your Class of Service
and/or SMDR Options Assignment forms are not configured correctly, you are unable to connect, or
no data is being sent from the TCP/IP sockets.
If SMDR data is not streaming
1. On the Data link window of the telephone system media server, click Reset SMDR Link to
restore the connection.
2. Wait 60 seconds.
3. If you have an ethernet connection, verify it is up and running.
4. If SMDR data is still not flowing, on the Enterprise Server, verify the SMDR Options and
Class of Service Options Assignment forms are configured correctly on the telephone
system.
See the Contact Center Management Installation Guide.
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5. If SMDR data is still not flowing, on the Enterprise Server, use a telnet client session to verify
data is flowing through the TCP/IP sockets.
6. Restart Collector Service.
7. If SMDR data is still not flowing, call Mitel customer support at 1-800-722-1301, Option 6
(North American customers) or your approved Mitel vendor (for customers residing in Latin
America, Europe, the Middle East, Africa, and Asia Pacific).

ACD DATA IS NOT STREAMING
ACD data records are generated with each agent event and with periodic refresh events produced by
the telephone system. If ACD data is not flowing through the TCP/IP sockets, then the telephone
system is not producing data records, you are unable to connect, or no data is being sent from the
TCP/IP sockets.
If ACD data is not streaming
1. On the Data link window of the telephone system media server, click Reset ACD Link to
restore the connection.
2. Wait 60 seconds.
3. If you have an ethernet connection, verify it is up and running.
4. If ACD data is still not flowing, on the Enterprise Server, use a telnet client session to verify
data is flowing through the TCP/IP sockets.
5. Restart Collector Service.
6. If ACD data is still not flowing, please call Mitel customer support at 1-800-722-1301, Option 6
(North American customers) or your approved Mitel vendor (for customers residing in Latin
America, Europe, the Middle East, Africa, and Asia Pacific).

Viewing the data collection TCP/IP ports
You can use your preferred telnet client to verify if data is flowing from the TCP/IP sockets.

Restarting Collector Service
You must restart Collector Service after you view the TCP/IP sockets with a telnet client.
To stop Collector Service
1. On the Enterprise Server, in Windows, navigate to Services.
2. Right-click prairieFyre Collector Service (v5) and click Stop.
3. Right-click prairieFyre Collector Service (v5) and click Start.
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INTERACTIVE CONTACT CENTER
Interactive Contact Center is an optional application that enables supervisors who have a 3300 ICP
telephone system to control the availability of agents, extensions, ACD queues, and ring groups.
Agents can control their own availability: they can log themselves on or off, and place themselves in
or remove themselves from Make Busy or Do Not Disturb.

USING INTERACTIVE CONTACT CENTER
Interactive Contact Center is designed for agents and supervisors.

SUPERVISORS AND INTERACTIVE CONTACT CENTER
Using Interactive Contact Center, supervisors can
l

Control the availability of agents and ACD queues

l

Log agents on and off of the telephone system

l

Have agents leave their agent groups and join other agent groups. Agent groups are assigned
to queues so, in this way, agents can be moved from one queue to another as needed

l

Have extensions leave their ring groups and join other ring groups

l

Place agents in Make Busy

l

Place agents in Do Not Disturb

l

Place extensions into Do Not Disturb

l

Place queues in Do Not Disturb

An employee's voice agent can be assigned to multiple agent groups, which can be associated to
multiple queues. In order to move the agent from one queue to another queue, the supervisor has the
agent leave one agent group and join another agent group.
You create associations between agent groups and queues in YourSite Explorer.
You can restrict individual supervisors from managing particular monitors and devices in YourSite
Explorer

AGENTS AND INTERACTIVE CONTACT CENTER
Using Interactive Contact Center, agents can
l
l

Log themselves on and off of the telephone system
Remove themselves from agent groups and place themselves into other agent groups. Agent
groups are assigned to queues so, in this way, agents can move themselves from one queue
to another as needed

l

Place themselves in Make Busy

l

Place themselves in Do Not Disturb

You can restrict individual agents from managing particular monitors and devices in Contact Center
Management using YourSite Security.
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Every time agents leave their desks they must set Make Busy or Do Not Disturb. There are many
reasons why agents leave their desks. You assign each of these reasons a Make Busy or Do Not
Disturb Reason Code and then agents can apply the codes. When you run an Agent Performance by
Make Busy / DND Code report, the report clearly indicates when an agent went in Make Busy or Do
Not Disturb, and why (which code the agent selected each time).

STARTING CONTACT CENTER CLIENT
You start Contact Center Client to access real-time functionality. Supervisors and agents can view
real-time voice statistics. In contact centers that have the optional Multimedia Contact Center
application, supervisors and agents can view real-time voice, email, and chat statistics. After
starting Contact Center Client, you can choose to minimize it to either the system tray or the
taskbar, depending on your operating system.
NOTE: Launching client-side applications from the task bar causes them to bypass the Updater
Service process. To ensure successful updates from the Enterprise Server, after an upgrade close
all client-side applications for 15 minutes or reopen them from the Start menu/Start screen
To start Contact Center Client
1. Open Contact Center Client.
2. If prompted, type your user name and password and verify the Enterprise Server IP address.
3. If you use Secure Socket Layer, select SSL.
4. Optionally, select the Remember my credentials check box.
5. Click Log in.

EMPLOYEE AND AGENT CONTROL
Using Interactive Contact Center and Contact Center Client, you can control agents on the following
monitors:
l

Agent State by Position and Employee State by Position

l

Agent State by Time and Employee State by Time

l

Agent Shift

Agent control gives you control over individual agents. Monitor control gives you control over all of
the agents on a monitor. All of the agents on the monitor are affected simultaneously by the action
you take.
If you have Context Sensitivity enabled for monitors, the Agent Control and Monitor Control tabs
display in the Contact Center Client ribbon when you have any of the above monitors open. You can
perform actions using either a right-click and select method within the monitor or by selecting an
agent or an empty cell (monitor control) and accessing the action menu in the Agent or Monitor
Control tab views. (See Figure 91.)
NOTE: Monitor control is available only if you configure extensions for your employees.
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Figure 91: Agent Shift - Agent Control tab options

Agents and Agent Group Presence
If you have a Mitel 3300 ICP (MCD 4.0 SP4 and 5.0 or greater) telephone system, you can add
agents to and remove agents from one or more agent groups using Interactive Contact Center.
Employee agents can be assigned to multiple agent groups, which are in turn are associated with
different queues. When agent groups are created, an employee’s agents are assigned a default
group presence, either Present or Absent. Employees whose agents’ default presence is Absent will
be set in the Logged In Not Present agent state when they log in. To handle calls, the employee
manually changes their agent presence in Contact Center Client. Employees whose agents default
presence is Present will be set in the Idle agent state when they log in. For details about Agent
states, see "Employee and Agent states" on page 207.
The Mitel 3300 ICP (MCD 4.0 SP4 and 5.0 or greater) enables agents to be placed in or removed
from multiple agent groups (up to 16 on the Mitel 3300 MXe II Controller and up to 30 on the Mitel
3300 MXe server). Agents can be added and removed from agent groups using Feature Access
Codes (FAC), a Feature Access Key (FAK) programmed on their set, or using Interactive Contact
Center.
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The agent group presence option is controlled by Class of Service. Once the appropriate Class of
Service has been set, the agent group presence status can be changed in the following ways.
l

l

Feature access keys can be programmed on a Mitel multiline phone set. One button would be
used to join or leave each agent group to which the agent is a member.
Supervisors and agents can dial a feature access code followed by the group number to
change their status for that group or to change their status for all groups to which they are a
member.

l

The desktop tool in the embedded system management can be used to make status changes.

l

MiTAI controls are also available to make status changes.

Agent Group Presence has several licensing and configuration prerequisites:
l

l

l

l

You must have purchased a Contact Center Standard Starter Pack license or greater to use
Interactive Contact Center. For more information on Contact Center Starter Packs, see the
Contact Center Solutions and Business Reporter System Engineering Guide.
For agents to use Agent Group Presence, Group Presence Control must be enabled for all
agents on the Class of Service Options Assignment form on the Mitel 3300 ICP.
For supervisors or system administrators to use Agent Group Presence, they must log into
Contact Center Client as a non-administrative user. They also require a valid employee
license and an associated device with Group Presence Control and Group Presence Third
Party Control enabled on the Class of Service Options Assignment form on the Mitel 3300
ICP.
Real-time monitoring must be enabled in YourSite Explorer for all agents. For supervisors to
control agent group presence in Interactive Contact Center, the agent and at least one of the
agent's dialable numbers must be enabled for Real-time monitoring. See "Adding agents" on
page 136.

Agent Group Presence also requires that specific security roles be enabled:
l

l

To control agent presence status in Interactive Contact Center, you must enable 'May change
the real-time presence states of agents in Interactive Contact Center'.
To control supervisor presence status in Interactive Contact Center, you must enable 'May
control my real-time presence status in Interactive Contact Center'.

For more information, see "Configuring security roles" on page 193.
If the ACD Logout Agent No Answer Timer Class of Service option is enabled on your Mitel 3300
telephone system, when an agent in an agent group fails to answer a call offered to them after the
logout time expires, the agent is logged out of their agent group. In an environment using MCD 5.0
SP2 or greater, however, agents who fail to answer an offered call before the logout time expires are
removed by the telephone system from their agent group.
Agent group presence best practices
It is important to note that agents may join or leave agent groups but not queues. Agents become
absent from a queue indirectly if they leave all agent groups associated with that queue. An agent
who is present in an agent group which is associated to all queues would be disassociated from all
queues simultaneously if they became absent in their agent group. Since the goal of agent group
presence is to provide a dynamic response to varying queue activity, allowing agents to become
absent from all queues simultaneously is counterproductive.
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As a best practice, we recommend you associate agent groups to queues based on business groups
within your organization. A unique agent group to business group queue(s) association allows agents
who leave an agent group associated to a particular business group to remain present in an agent
group(s) associated to other business group(s).

Hiding the Monitor control option
Interactive Contact Center enables you to manage the presence of all devices in a monitor using
Monitor Device Control. If you do not want to use monitor control, you can hide this option so it is not
accessible.
To hide the Monitor control option
1. In Contact Center Client, click the Contact Center Client icon tab=>Options.
2. Under Device control, clear the Display monitor device control option check box.
3. Click OK.

Logging on an agent
NOTE:
l

l

l

l

l

l

An ACD hot desking agent must enter an extension number each time the agents logs on to
the telephone system using Interactive Contact Center. The agent cannot rely on the
extension number last used when logging on. This is because the ACD data stream unifies
the agent ID and the extension. After a hot desking agent logs on or off of the telephone
system using Interactive Contact Center, sometimes the Interactive Contact Center agent
controls are not available to the agent for two to five minutes.
You will be unable to log in an agent to the ACD if there are no available 3300 ICP user
licenses.
If your contact center participates in the use of PINs, supervisors with the correct Class of
Service do not require an agent’s PIN to interactively log in a hot desking agent.
Supervisors marked as Advanced supervisor or System Administrator will not be prompted to
enter a PIN when logging into Interactive Contact Center, Softphone, or PhoneSet Manager
provided third party call control is configured under security in CCMWeb and on the telephone
switch.
If a hot desking agent logs into an extension that serves as the overflow point for a ring group,
calls to that ring group will not be offered to the extension and will remain queued or ringing
until abandoned or answered.
Hot desking users logging into a ring group extension must also be a member of the ring group
to ensure accurate reporting.

You log employee voice agents in and out in either an open Employee or Agent Monitor in Contact
Center Client.
To log in an agent in an open Employee monitor
l
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Right-click the cell of an employee and click Employee control=>Log in=>voice agent.
Alternatively, select the employee cell in an open monitor, click Log in from the Employee
Control tab on the Contact Center Client ribbon, and select the voice agent.
NOTE: When you log in an employee’s voice agent, you must enter the extension for the
agent. See the procedure below.

Using Interactive Contact Center

To log in an agent by extension in an open Employee monitor
1. Right-click the cell of an employee and click Employee control=>Log in=>By extension.
2. If the employee has multiple voice agents, select the agent to log in from the drop-down list.
3. Type the Agent’s extension.
4. Click OK.
To log in an agent in an open Agent monitor
l

Right-click the cell of a voice agent who is not logged into and click Agent Control=>Log
in=>voice agent. Alternatively, select the agent cell in an open monitor and click Log in from
the Contact Center Client ribbon.
NOTE: When you log in a voice agent, you must enter the extension for the agent. See the
procedure below.

To log in an agent by extension in an open Agent monitor
1. Right-click the cell of a voice agent and click Agent control=>Log in=>By extension.
2. If the employee has multiple voice agents, select the agent to log in from the drop-down list.
3. Type the Agent’s extension.
4. Click OK.

Logging off an agent
You can log off an employee from all media in an Employee monitor or Agent monitor, which logs off
all of the employee’s voice agents. If the employee is also logged into Softphone in Contact Center
Client, they will be logged out of Softphone as well. The following procedures take place in either an
open Employee monitor or an open Agent monitor in Contact Center Client.
To log off all of an employee's agents in an open Employee monitor
l

Right-click the cell of an employee and click Employee control=>Log off. Alternatively,
select the employee cell in an open monitor and click Log Off from the Employee Control
tab on the Contact Center Client ribbon.

To log off an agent in an open Agent monitor
l

Right-click the cell of an agent and click Agent control=>Log off. Alternatively, select the
agent cell in an open monitor and click Log Off from the Agent Control tab on the Contact
Center Client ribbon.

To log off all agents of employees in an open Employee monitor
1. Right-click the monitor and click Monitor control=>Log off.
Alternatively, click the Monitor Control tab in the Contact Center Client ribbon and select
Log Off.
2. Click Yes.
To log off all of agents in an open Agent monitor
1. Right-click the monitor and click Monitor control=>Log off.
Alternatively, click the Monitor Control tab in the Contact Center Client ribbon and select
Log Off.
2. Click Yes.
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Joining and leaving agent groups
After logging into Contact Center Client, agents use Interactive Contact Center to control their
presence status in agent groups. Optionally, supervisors can use Interactive Contact Center to
control the presence status of agents in specific agent groups.
NOTE:
l

l

l

Agents must be Standard or higher to control their own Agent Group Presence. Basic Agents
cannot control their own Agent Group Presence.
An agent's ACD hot desk line remains in service while they are logged in as an ACD hot desk
user even if they are not present in any ACD groups and not receiving ACD calls.
For information on the configuration, licensing, and security role prerequisites that must be
met in order to use Agent Group Presence, see "Agents and Agent Group Presence" on page
390.

To join an agent to or have an agent leave an agent group in an open Employee monitor
1. Right-click the cell of an employee and click Employee control=>Join/Leave agent
group=>[Agent].
Alternatively, select the cell of an employee and in the Employee Control tab of the Contact
Center Client ribbon, click Join/Leave agent group=>[Agent].
2. Select the agent group(s) to which you want the employee’s agent(s) to join or deselect the
agent group(s) to have the employee’s agent(s) leave the agent groups.
3. Click OK.
To join an agent to or have an agent leave an agent group in an open Agent monitor
1. Right-click the cell of an agent who is logged on and click Agent control=>Join/Leave agent
group.
Alternatively, select the cell of an agent and click Join/Leave agent group from the Agent
Control tab in the Contact Center Client ribbon.
2. Select the agent group(s) to which you want the agent(s) to join or deselect the agent group(s)
to have the agent(s) leave the agent groups.
3. Click OK.

Placing agents in Make Busy
Placing employees into Make Busy places both employees and all of their agents into Make Busy.
The following procedures take place in either an open Employee monitor or an open Agent monitor in
Contact Center Client.
To place an employee in Make Busy in an open Employee monitor
l
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Right-click the cell of an employee and click Employee control=>Set Make Busy=>reason
code. Alternatively, select an empty cell in an open monitor and click Set Employee Make
Busy=>reason code from the Employee Control tab in the Contact Center Client ribbon.

Using Interactive Contact Center

To place all employees in an open Employee monitor in Make Busy
1. Right-click the monitor and click Monitor control=>Set Make Busy=>reason code.
Alternatively, select an empty cell in an open monitor and click Set Make Busy=>reason
code from the Monitor Control tab in the Contact Center Client ribbon.
2. Click Yes.
To place all employees in Make Busy in an open Agent monitor
l

Right-click the cell of an agent and click Agent control=>Set Employee Make
Busy=>reason code. Alternatively, select the agent cell in an open monitor and click Set
Employee Make Busy=>reason code from the Agent Control tab in the Contact Center
Client ribbon.

To place all employees in an open Agent monitor in Make Busy
1. Right-click the monitor and click Monitor control=>Set Employee Make Busy=>reason
code. Alternatively, select an empty cell in an open monitor and click Set Make
Busy=>reason code from the Monitor Control tab in the Contact Center Client ribbon.
2. Click Yes.

Removing employees from Make Busy
Removing employees from Make Busy removes both employees and all of their agents from Make
Busy.
The following procedures take place in either an open Employee monitor or an open Agent monitor in
Contact Center Client.
To remove an employee in an open Employee monitor from Make Busy
l

Right-click the cell of an employee whose agents are in Make Busy and click Employee
control=>Remove Make Busy for all of the employee’s agent IDs. Alternatively, select an
empty cell in an open monitor and click Remove Make Busy from the Employee Control tab
in the Contact Center Client ribbon.

To remove employees in an open Employee monitor from Make Busy
l

Right-click the cell of an employee who is in Make Busy and click Monitor
control=>Remove Make Busy. Alternatively, select an empty cell in an open monitor and
click Remove Make Busy from the Monitor Control tab in the Contact Center Client ribbon.

To remove an employee in an open Agent monitor from Make Busy
l

Right-click the cell of an agent in Make Busy and click Agent control=>Remove Make
Busy. Alternatively, select the agent cell in an open monitor and click Remove Make Busy
from the Agent Control tab in the Contact Center Client ribbon.

To remove all employees in an open Agent Monitor from Make Busy
l

Right-click the cell of an employee and click Monitor control=>Remove Make Busy.
Alternatively, select an empty cell in an open monitor and click Remove Make Busy from the
Monitor Control tab in the Contact Center Client ribbon.
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Placing employees in Do Not Disturb
NOTE: If an agent in Make Busy sets and later removes Do Not Disturb on their extension, Work
Timer will not work until the agent either logs off the telephone system or until calls remove Make
Busy on the extension (even though the agent state is set to idle).
Placing employees into Do Not Disturb places both employees and all of their agents into Do Not
Disturb.
The following procedures take place in either an open Employee monitor or an open Agent monitor in
Contact Center Client.
To place an employee in an open Employee monitor in Do Not Disturb
l

Right-click the cell of an employee and click Employee control=>Set Do Not
Disturb=>reason code. Alternatively, select the employee cell in an open monitor and click
Set Employee Do Not Disturb=>reason code.

To place all employees in an open Employee Monitor in Do Not Disturb
l

Right-click the monitor and click Monitor control=>Set Do Not Disturb=>reason code.
Alternatively, select an empty cell in an open monitor and click Set Do Not Disturb from the
Monitor Control tab in the Contact Center Client ribbon.

To place an employee in an open Agent monitor in Do Not Disturb
l

Right-click the cell of an agent who is logged on and click Agent control=>Set Employee
Do Not Disturb=>reason code. Alternatively, select the agent cell in an open monitor and
click Set Do Not Disturb=>reason code from the Agent Control tab in the Contact Center
Client ribbon.

To place all employees in an open Agent monitor in Do Not Disturb
l

Right-click the monitor and click Monitor control=>Set Do Not Disturb=>reason code.
Alternatively, select an empty cell in an open monitor and click Set Do Not Disturb from the
Monitor Control tab in the Contact Center Client ribbon.

Removing employees from Do Not Disturb
Removing employees from Do Not Disturb places removes employees and all of their agents from
Do Not Disturb.
The following procedures take place in either an open Employee monitor or an open Agent monitor in
Contact Center Client.
To remove an employee and their multimedia agents from Do Not Disturb in an open Employee
monitor
l
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Right-click the cell of an employee who is in Do Not Disturb and click Employee
control=>Remove Do Not Disturb. Alternatively, select the employee cell in and click
Remove Do Not Disturb from the Employee Control tab in the Contact Center Client
ribbon.
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To remove all of a monitor’s employees and their multimedia agents from Do Not Disturb in an open
Employee monitor
l

Right-click the monitor and click Monitor control=>Remove Do Not Disturb. Alternatively,
select an empty cell in an open monitor and click Remove Do Not Disturb from the Monitor
Control tab in the Contact Center Client ribbon.

To remove an employee and their multimedia agents from Do Not Disturb in an open Agent monitor
l

Right-click the cell of an agent who is in Do Not Disturb and click Agent control=>Remove
Do Not Disturb. Alternatively, select the agent cell in an open monitor and click Remove Do
Not Disturb from the Agent Control tab in the Contact Center Client ribbon.

To remove all of a monitor’s employees and their multimedia agents from Do Not Disturb in an open
Agent monitor
l

Right-click the monitor and click Monitor control=>Remove Do Not Disturb. Alternatively,
select an empty cell in an open monitor and click Remove Do Not Disturb from the Monitor
Control tab in the Contact Center Client ribbon.

Canceling Work Timer for employees
In an Employee monitor or Agent monitor, you can cancel Work Timer for one or more employees.
The following procedures take place in either an open Employee monitor or an open Agent monitor in
Contact Center Client.
To cancel Work Timer in an open Employee monitor
l

Right-click the cell of an employee who is in Work Timer and click Employee
control=>Cancel Work Timer. Alternatively, select the employee cell in an open monitor
and click Cancel Work Timer in the appropriate media section of the Employee Control tab
in the Contact Center Client ribbon.

To cancel Work Timer for all employees in an open Employee monitor
l

Right-click the monitor and click Monitor control=>Cancel Work Timer. Alternatively,
select an empty cell in an open monitor and click Cancel Work Timer in the media type’s
section of the Monitor Control tab in the Contact Center Client ribbon.

To cancel Work Timer for an employee in an open Agent monitor
l

Right-click the cell of an agent who is in Work Timer and click Agent control=>Cancel Work
Timer. Alternatively, select the agent cell in an open monitor and click Cancel Work Timer
from the Agent Control tab in the Contact Center Client ribbon.

To cancel Work Timer for all employees in an open Agent monitor
l

Right-click the monitor and click Monitor control=>Cancel Work Timer. Alternatively,
select an empty cell in an open monitor and click Cancel Work Timer from the Monitor
Control tab in the Contact Center Client ribbon.
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Canceling the Reseize Timer for external hot desk agents
If an external hot desk user is unavailable (they are in a non-ACD call or off hook) and the ACD path
attempts to deliver a call to them the telephone system will initiate the Reseize Timer, preventing
further ACD call delivery attempts until the timer expires or is canceled by the agent or supervisor.
Value settings for reseize timers are a minimum of four seconds, a default of 180 seconds, and a
maximum of 60 minutes. These values are configured on the telephone system. When an agent is in
the Reseize Timer state, the applicable real-time monitors in Contact Center Client display the Make
Busy icon as well as text denoting the agent’s current state as 'Reseize Timer'.
The following procedures take place in either an open Employee monitor or an open Agent monitor in
Contact Center Client.
To cancel Reseize Timer for an employee’s voice agent in an open Employee monitor
l

Right-click the cell of an employee who is in Reseize Timer and click Employee
control=>Cancel Reseize Timer. Alternatively, select the employee cell in an open monitor
and click Cancel Reseize Timer in the appropriate media section of the Employee Control
tab in the Contact Center Client ribbon.

To cancel Reseize Timer for all employee voice agents in a monitor in an open Employee monitor
l

Right-click the monitor and click Monitor control=>Cancel Reseize Timer. Alternatively,
select an empty cell in an open monitor and click Cancel Reseize Timer from the Monitor
Control tab in the Contact Center Client ribbon.

To cancel Reseize Timer for an employee’s voice agent in an open Agent monitor
l

Right-click an agent who is in Reseize Timer and click Agent control=>Cancel Reseize
Timer. Alternatively, select the agent cell in an open monitor and click Cancel Reseize
Timer in the appropriate media section of the Agent Control tab in the Contact Center Client
ribbon.

To cancel all of the voice agents on a monitor in the Reseize Timer state in an open Agent monitor
l

Right-click the monitor and click Monitor control=>Cancel Reseize Timer. Alternatively,
select an empty cell in an open monitor and click Cancel Reseize Timer from the Monitor
Control tab in the Contact Center Client ribbon.

EXTENSION CONTROL
Using Interactive Contact Center and Contact Center Client, you can control extensions on the
following monitors:
l

Extension State by Position

l

Extension Now

Extension control gives you control over individual extensions. Monitor control gives you control over
all the extensions on a monitor. All of the extensions on the monitor are affected simultaneously by
the action you take. You can perform actions using either a right-click and select method within the
monitor or by selecting an extension or an empty cell (monitor control) and accessing the action
menu in the Extension or Monitor Control tabs in the ribbon. (See Figure 92.)
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Figure 92: Extension State by Position – Extension Control tab

Ring group presence
If you are licensed for ring groups, you can join extensions to and have extensions leave one or more
ring groups using Interactive Contact Center.
Extensions can be assigned to multiple ring groups. Within a ring group, an extension can be set to
Present, enabling it to receive calls, or Absent, ensuring that calls are not offered to the extension.
By default, extensions are set to Present. Supervisors can manually change the extension presence
in Contact Center Client.
The ring group presence option is controlled by Class of Service. Once the appropriate Class of
Service has been set, the ring group presence status can be changed in the following ways.
l

l

l

Supervisors and agents can dial a feature access code followed by the group number to
change the extension status for that group or to change their status for all groups to which they
are a member.
The desktop tool in the Embedded System Management can be used to make status
changes.
MiTAI controls are also available to make status changes.
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Ring Group Presence has several licensing and configuration prerequisites:
l

l

l

For extensions to use ring group presence, Group Presence Control must be enabled for all
extensions on the Class of Service Options Assignment form on the Mitel 3300 ICP.
Real-time monitoring must be enabled in YourSite Explorer for all extensions. For supervisors
to control ring group presence in Interactive Contact Center, the ring group and at least one of
the ring group’s extensions must be licensed for real-time monitoring. Extensions that have
the MCD option ‘ACD Enabled’ selected cannot be made present in a ring group. See "Adding
extensions" on page 158.
The ability to modify Ring Group Presence can also be controlled using HCI options on your
telephone system. It is recommended that your extension Class of Service conforms to the
Golden Rules document available from the MiCC Knowledge Base at
http://micc.mitel.com/kb/.

Ring Group Presence also requires that specific security roles be enabled:
l

l

To control agent presence status in Interactive Contact Center, you must enable 'May change
the realtime presence states of agents in Interactive Contact Center'.
To control supervisor presence status in Interactive Contact Center, you must enable 'May
control my real-time presence status in Interactive Contact Center'.

For more information, see "Configuring security roles" on page 193.

Joining and leaving ring groups
Interactive Contact Center can be used to control the presence of extensions in ring groups.
NOTE: An extension that has the MCD setting ‘‘ACD Enabled’ cannot join a ring group. Extensions
created in YourSite Explorer are ACD Enabled by default.
The following procedures take place in an open Extension monitor in Contact Center Client.
To join an extension to or remove an extension from a ring group
1. Right-click the cell of an extension and click Extension control=>Join/Leave.
Alternatively, select the cell of an extension and in the Extension Control tab of the Contact
Center Client ribbon, click Join/Leave.
2. Select the ring group(s) to which you want the extension to join or deselect the ring group(s) to
have the extension leave the ring group(s).
3. Click OK.

Placing an extension in Do Not Disturb
The following procedures take place in an open Extension monitor in Contact Center Client.
To place an extension in Do Not Disturb
l
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Right-click the cell of an extension and click Extension control=>Set Do Not
Disturb=>reason code. Alternatively, select the Extension Control tab and select Set Do
Not Disturb=>reason code.
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To place all extensions into Do Not Disturb in an open monitor
1. Right-click the cell of an extension and click Monitor control=>Set Do Not
Disturb=>reason code.
Alternatively, select the Monitor Control tab and select Set Do Not Disturb=>reason
code.
2. Click Yes.

Removing an extension from Do Not Disturb
The following procedures take place in an open Extension monitor in Contact Center Client.
To remove an extension from Do Not Disturb
l

Right-click the cell of an extension in Do Not Disturb and click Extension control=>Remove
Do Not Disturb.
Alternatively, select the Extension Control tab and select Remove Do Not Disturb.

To remove all extension from Do Not Disturb in an open monitor
l

Right-click the cell of an extension and click Monitor control=>Remove Do Not Disturb.
Alternatively, select the Extension Control tab and select Remove Do Not Disturb.

QUEUE CONTROL
Using Interactive Contact Center and Contact Center Client, you can control queues on the Queue
Now monitor.
You can control queues
l

Manually

l

Using a schedule

l

Using a queue control plan

Manually controlling queues
NOTE:
l

l

You can see queue statistics during business hours as long as the business schedule you
configure in YourSite=>Schedule or YourSite Explorer=>Schedules is consistent with your
company’s hours of operation. You assign business-hours schedules to queues in
YourSite=>Configuration=>Queue=>Queue or in YourSite Explorer=>Queues=>Business
Hours.
Manual queue control overrides queue schedules and queue control plans.

Interactive Contact Center Queue control enables you to control individual queues. Monitor control
enables you to control all of the queues on a monitor.
The Monitor Options tab displays in the ribbon for the Queue Now monitor. You can perform actions
using either a right-click and select method in the open monitor or by accessing the action menu in
the Monitor Options ribbon. (See Figure 93.)
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Figure 93: Queue Now monitor - Monitor Options tab

Hiding the Monitor control option
Interactive Contact Center enables you to manage the presence of all devices in a monitor using
Monitor Device Control. If you do not want to use monitor control, you can hide this option so it is not
accessible.
To hide the Monitor control option
1. In Contact Center Client, click the Contact Center Client icon tab=>Options.
2. Under Device control, clear the Display monitor device control option check box.
3. Click OK.

Placing queues in Do Not Disturb
Using manual queue control, you can place queues in and remove queues from Do Not Disturb on
the Queue Now monitor. A call will not enter a queue that is in Do Not Disturb. The call is sent to an
unavailable answer point programmed in the telephone system.
NOTE: Putting a ring group into Do Not Disturb removes the presence of all of its members.
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To place a queue in Do Not Disturb
l

Right-click the cell of an active queue and click Queue control=>Set Do Not Disturb.
Alternatively, select the queue in an open Queue Now monitor and click Set Do Not Disturb
from the Monitor Option tab in the Contact Center Client ribbon.
See Figure 94.

Figure 94: Placing a queue in Do Not Disturb
To place all of the queues on a monitor in Do Not Disturb
l

Right-click the monitor and click Monitor control=>Set Do Not Disturb. Alternatively,
select an open Queue Now monitor and click Set Do Not Disturb from the Monitor Option tab
in the Contact Center Client ribbon.

Removing queues from Do Not Disturb
To remove a queue from Do Not Disturb
l

Right-click the cell of a queue that is in Do Not Disturb and click Queue control=>Remove
Do Not Disturb. Alternatively, select the queue in an open Queue Now monitor and click
Remove Do Not Disturb from the Monitor Option tab in the Contact Center Client ribbon.

To remove all of the queues on a monitor from Do Not Disturb
l

Right-click the monitor and click Monitor control=>Remove Do Not Disturb. Alternatively,
select an open Queue Now monitor and click Remove Do Not Disturb from the Monitor
Option tab in the Contact Center Client ribbon.
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Controlling queues using a schedule
You can apply Business Hour schedules to queues to open queues during business hours and close
queues after business hours. For more information, see "Opening and closing queues with business
hour schedules" on page 153.

Scheduling queues to enter or leave Do Not Disturb
Using a schedule, you can place queues in and remove queues from Do Not Disturb on the Queue
Now monitor. For more information, see "Opening and closing queues with business hour
schedules" on page 153.

Controlling queues using queue control plans
NOTE: You must install Interactive Contact Center before you can use Interactive Contact Center
Queue control.
Using queue control plans, you can place queues in and remove queues from Do Not Disturb, and
close and re-open queues automatically based on predefined criteria. For more information, see
"Closing and re-opening queues with queue control plans" on page 153.

Creating Queue control plans
Queue control plans open and close queues based on plan parameters only during business hours.
Each queue is controlled by only one queue control plan at a time. You can apply the same queue
control plan to several queues. For information on creating queue control plans, see "Closing and reopening queues with queue control plans" on page 153.
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INTERACTIVE VISUAL QUEUE
Interactive Visual Queue is a Contact Center Client real-time monitor that works in conjunction with
Contact Center Management and Interactive Contact Center. Interactive Visual Queue comprises a
Queued media grid and an Abandoned media grid. In the Queued media grid, supervisors and agents
can view calls within queues and then use a drag-and-drop operation to move calls from busy queues
to less active queues. In the Abandoned media grid, supervisors can view abandoned call
information, including the caller name, phone number, and time of the abandoned call. Agents can
use the Abandoned media grid to call back abandoned callers.
Ring groups are not supported with Interactive Visual Queue and any queue groups displayed in
Interactive Visual Queue will not display calls in the ring group queues.

USING INTERACTIVE VISUAL QUEUE
Interactive Visual Queue works in conjunction with Contact Center Management. Before you use
Interactive Visual Queue you must configure queue options in YourSite Explorer so they mirror those
of the 3300 ICP telephone systems.
NOTE: In order to use Interactive Visual Queue, you must enable all HCI options on Class of
Service Assignment form 1 (COS 1).

CONFIGURING OPTIONS IN CONTACT CENTER
MANAGEMENT
In YourSite Configuration, for each queue you want to monitor, you must configure the priority level
and the method for handling interflowed calls. The values you configure must match the values
specified on the Path Assignment form of your telephone system.
NOTE: The YourSite Configuration settings for Interactive Visual Queue monitors do not affect call
flow activity on the actual queues. These settings only affect the way Interactive Visual Queue
displays the queue monitors in Contact Center Client. If you want to modify call flow on the actual
queues, you must change the telephone system settings.
If the telephone system settings and Interactive Visual Queue settings do not match, Interactive
Visual Queue will not display the correct call activity. For example, if Queue 1 is set to a priority of 10
on the telephone system and a priority of 20 in YourSite Configuration, Interactive Visual Queue will
display calls in Queue 1 as priority 20. However, the actual queue will handle the calls as priority 10.

STARTING CONTACT CENTER CLIENT
Interactive Visual Queue resides in Contact Center Client.
NOTE: Launching client-side applications from the task bar causes them to bypass the Updater
Service process. To ensure successful updates from the Enterprise Server, after an upgrade close
all client-side applications for 15 minutes or reopen them from the Start menu/Start screen
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To start Contact Center Client
1. Open Contact Center Client.
2. If prompted, type your user name and password and verify the Enterprise Server IP address.
3. If you use Secure Socket Layer, select the SSL check box.
4. Optionally, select the Remember my credentials check box.
5. Click Log in.

OPENING INTERACTIVE VISUAL QUEUE
You access Interactive Visual Queue by logging on to Contact Center Client and then opening the
Real-time toolbar.
To open an Interactive Visual Queue monitor
1. Log on to Contact Center Client.
2. In the Contact Center Client ribbon, click Real time.
3. Click Interactive Visual Queue.
The Add/Remove device IDs window opens.
4. Select a queue from the Queues list and click OK.
See Figure 95.
NOTE:
l
l

Virtual queue groups are shown in the Queue groups list.
To use Interactive Visual Queue effectively, you should open two or more queue
monitors.
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Figure 95: Interactive Visual Queue monitor

INTERACTIVE VISUAL QUEUE MONITOR GRIDS
The Interactive Visual Queue monitor comprises the Queued media grid and the Abandoned media
grid. The Queued media grid lists the calls that are currently in the selected queues or queue groups.
The Abandoned media grid lists abandoned calls. The calls are listed in order of priority and the
columns can be sorted. You can configure the column headings and specify which columns are
displayed. If you are licensed for IVR Routing Advanced Starter Pack or greater, Interactive Visual
Queue includes the Callback to be processed grid, which lists callbacks.
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NOTE: The abandoned calls column in the Interactive Visual Queue monitor displays all abandoned
calls except those abandoned while ringing an agent or extension. The abandoned column in the
Queue Now monitor does not peg short abandons as abandoned calls, but does peg calls that are
abandoned while ringing an agent or extension if they do not peg as a short abandon. Because of
these differences, you may notice discrepancies between the abandoned call information in these
two monitors.
The following list provides descriptions of the column headings available in the Queued media grid:
l

Position (#) displays the answer position relative to other contacts in the queue

l

Media icon displays the media type

l

Queue Name is the name of the queue

l

Queue Dialable displays:
l

Voice—the dialable number of the queue

l

Chat—Queue Auto Response User Name

l

Email—Email address of the queue

l

Priority is the priority of the contact in the queue (the lower the number, the higher the priority)

l

Time in Queue is the contact's total time in the current queue

l

Time Offered to System is the time the contact first entered the system

l

Time in System is the contact's total time in the system

l

Queue Hops is the number of times a contact has changed queues

l

ANI (Contact ID) displays:

l

l
l

l

l

Voice—caller # / ANI

l

Chat—Chat email address from pre-chat form

l

Email—From email address

Subject displays
l

Voice—blank

l

Chat—Chat subject from pre-chat form

l

Email—Email subject

Is Callback indicates if the queued media is a callback request (voice only)
Service level countdown provides a countdown in seconds when the conversation will exceed
the target time to meet the service level
Contact Name is the name associated with the contact (if available)
l

Voice—caller ID

l

Chat—Chat name from pre-chat form

l

Email—Email “From” name, if available

l

Time Offered to Queue is the time the contact entered the current queue

l

DNIS (To Address) displays
l

Voice—DNIS Number

l

Chat—blank

l

Email—receiver's email address
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l

To Name displays
l

l

l

Voice—DNIS Name, if configured in YourSite Explorer for the associated DNIS
number

l

Chat—blank

l

Email—Email “To” name, if available

Collected Information displays the single or series of collected results provided by IVR
Routing. Collected information requires IVR Routing, Verified Collected Digits and, optionally,
Remote Database Verification or CTI Developer Toolkit
Queue Reporting is the queue’s reporting number

The following list provides descriptions of the column headings available in the Abandoned media
grid:
l

ANI (Contact ID) displays caller # / ANI

l

Contact Name is the caller ID associated with the contact (if available)

l

Queue Name is the name of the queue

l

Queue Dialable displays the dialable number of the queue :

l

Time Abandoned is the time at which the contact abandoned the queue

l

Time Since Abandoned is the elapsed time since the contact abandoned the queue

l

l

Last Callback Time is the time at which the most recent callback was attempted

l

Time Since Last Callback is the elapsed time since the most recent callback attempt

l

Time Offered to Queue is the time the contact entered the current queue

l

Time in Queue is the contact's total time in the current queue

l

Time Offered to System is the time the contact first entered the system

l

Time in System is the contact's total time in the system

l

Queue Hops is the number of times a contact has changed queues

l

Is Callback indicates if the queued media is a callback request (voice only)

l

l
l

l
l
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Last Callback Employee is the employee name and employee ID associated with the most
recent callback attempt

Service level countdown provides a countdown in seconds when the conversation will exceed
the target time to meet the service level
DNIS (To Address) displays the DNIS number
To Name displays the DNIS name, if configured in YourSite Explorer for the associated DNIS
number
Subject displays DNIS
Collected Information displays the single or series of collected results provided by IVR
Routing. Collected information requires IVR Routing, Verified Collected Digits and, optionally,
Remote Database Verification or CTI Developer Toolkit

l

Queue Reporting is the queue’s reporting number

l

Media icon displays the media type
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The following list provides descriptions of the column headings available in the Callback grid:
l

Caller # displays the phone number provided by the contact

l

Caller Name displays the contact’s name

l

Status displays the state of the callback

l

l

l

New request

l

In progress

l

Requeued

l

Completed

l

Unknown

Priority the importance level of the callback.
l

Voice—Normal

l

Web—Normal

l

Abandoned—Low

Type displays the type of callback
l

Voice

l

Web

l

Abandoned

l

Reason displays the callback’s reason for its current status

l

Attempted Calls to Agent displays the number of times the agent attempted the callback

l

Last Time Agent Attempted displays the last time the agent attempted the callback

l

Request time displays the specific time the callback will be executed

l

Time Received displays the specific time the caller submitted the callback request

l

Web IP Address displays the IP address of the contact who submitted the callback request.

l

Last Attempted Call To Client displays the specific time the last callback attempt to the caller
was made

l

Attempted Calls To Client displays the number of times the callback was attempted

l

Client Available From displays the earliest time the contact is available to receive the callback

l

Client Available To displays the latest time the caller is available to receive the callback

l

ANI displays the phone number of the caller

l

DNIS displays the phone number the caller dialed

l

Dialable displays the number of the device that will handle the callback

l

Device Name displays the name of the device that will handle the callback

l

l

Device Type displays the type of device that will handle the callback – agent, queue, or
extension
Recorded Message displays a hyperlink to the voice callback request .wav file left by the
caller

l

Area displays the state, province, or other area the call originated f rom

l

Country displays the country the call originated from

l

Port displays the number of the port attempting to perform the callback

l

Region displays the region the call originated from
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Sorting contacts by columns
Monitor columns can be used to sort contacts in Interactive Visual Queue. You can only sort by one
column in a grid at a time. By default, the Queued media grid is sorted by Position number. Sort
preferences are preserved in your Contact Center Client profile.
To sort contacts by columns in the Interactive Visual Queue monitor
l

Click on the column heading by which you want to sort.
To reverse the sort order, click on the column again.

REDIRECTING CALLS
A call can move between queues automatically (interflow) or manually (redirection).
Interflow
You can configure queue settings on the telephone system to automatically move a call from one
queue to another after a specific duration. For example, you can configure your system to move a
call from Queue 1 to Queue 2 if the call has not been answered within 30 seconds. Interflow occurs
without any user interaction.
Redirection
Using Interactive Visual Queue, you can manually redirect a call from a queue to another queue or a
dialable number.
There are two ways a call can be removed from the system. If a call is moved more than 10 times,
either by redirection or by interflow, the call is dropped from the system. You can see the current
number of times a call has moved between queues in the Queue Hops column. A call will also be
automatically removed from the system if its total time in the system exceeds 24 hours. The Total
Time column lists the call’s duration in the system.
You can manually redirect a call in the Queued media grid using the following methods:
l

Drag and drop a call between queues.

l

Use the right-click menu to move a call between queues.

l

Use the right-click menu to send a call to a specific dialable number (for example, an
extension or voice mail port).

You may notice that the first two methods perform the same action. However, the second method is
convenient when queue monitor is maximized and you want to move a call without having to resize
one or more monitors.
NOTE: If you right-click a call and redirect it to a specific extension, the call will no longer be
considered an ACD call for reporting purposes. If you redirect a call using either of the other two
methods, the call remains an ACD call.
When you manually redirect (drag and drop) a call in Interactive Visual Queue, Contact Center
Management changes the way the call is pegged on the Queue Performance reports. If you redirect a
call before the short abandon time set for the queue, the call is pegged as Unavailable. If you redirect
a call after the short abandon time set for the queue, the call is pegged as Interflowed. An internal
ACD call is pegged as Abandoned if the call is redirected at any time.
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Redirecting calls between queues
To redirect a call from one queue to another queue using a drag-and-drop operation
1. In the Queued media grid, click anywhere in the row of the call you want to move.
2. Use a drag-and-drop operation to move the call from its original queue monitor to a new queue
monitor.
To redirect a call from one queue to another queue using the menu
1. In the Queued media grid, right-click the row of the call you want to redirect and click Send to.
A list of available queues appears.
NOTE: You can select multiple rows to move multiple calls to a new queue.
2. Click the name of the queue to which you want to move the call.

Redirecting voice contacts to specific agents
You can transfer voice contacts in queue directly to agents who are available or in Make
Busy/Overloaded states. Agents in Do Not Disturb cannot receive transferred contacts and will not
appear in the list of available agents.
To redirect voice contacts to agents
1. In the Queued media grid, right-click the row of the contact you want to redirect and click
Send to=>Agent.
A list of available agents who can handle the voice contact displays.
NOTE: You can use the search button to locate a specific agent, either by name or reporting
number.
2. Click the name of the agent to which you want to send the contact.
3. Click OK.

Redirecting calls to specific numbers
Using the Send to menu option, you can redirect calls in Interactive Visual Queue to any extension.
In addition, if you have Contact Center Softphone installed, you can send a call directly to your own
extension by selecting Send to=>Me.
To redirect a call to a dialable number
1. In the Queued media grid, right-click the row of the call you want to redirect and click Send
to=>[Extension].
When you click [Extension], it changes to a text box.
2. Type a number in the text box and press Enter.
See Figure 96.
NOTE: You cannot use the Extension option if you have multiple calls selected. Only one call
can be sent to a dialable number at a time.
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Figure 96: Redirecting a call to an extension
To redirect a call to your extension
1. In the Queued media grid, right-click the row of the call you want to redirect.
2. Click Send to=>Me
NOTE: This option is not available unless you have Contact Center Softphone installed and
configured on your computer.

Removing calls
To remove a call from Interactive Visual Queue
1. Right-click the row of the call you want to remove.
2. Click Delete.
The call is removed from Interactive Visual Queue.
NOTE: Deleting a call from an Interactive Visual Queue monitor will not remove it from the actual
queue. This will just cause Interactive Visual Queue to stop tracking the call.
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CALLING BACK ABANDONED CALLERS
The Abandoned media grid displays abandoned call information and enables agents to call back
abandoned callers.
NOTE:
l

l

l

If you want Interactive Visual Queue to automatically insert 1 when calling back long distance
phone numbers, you must program your telephone system ARS accordingly. For more
information, see the Mitel 3300 ICP System Administration Tool Help.
Abandoned call information is automatically deleted from the Abandoned media grid after 24
hours.
Abandoned calls cannot be transferred to agents.

To call back an abandoned caller
1. Right-click the row of the abandoned call you want to call back, and select Call to
automatically dial the abandoned caller.
NOTE: Each time an agent attempts to call back an abandoned caller, their name and ID are
attached to the call record and display in the Last callback employee column of the
Abandoned media grid.
2. After you have contacted the abandoned caller, right-click the row associated with that call,
and select Delete to remove the abandoned call record from the Abandoned media grid.

CONFIGURING ALARMS
You set alarms on Interactive Visual Queue monitors similar to the way you set alarms on Contact
Center Client monitors. The main difference is that some of the variables you can monitor, Caller
Number, Caller Name, DNIS Number, DNIS Name, Collected Digits, and Collected Information,
use a string for their value as opposed to a threshold boundary. For example, you can set an alarm
that is triggered when a specific name appears in the Caller Name column.
The value you type for Caller Number or Caller Name alarms is a wildcard, which means the alarm
will trigger if that value appears in any form. For example, if you configure a Caller Name alarm for
the value John, the alarm will trigger for the values John Smith, Johnathan, longjohn, and so on.
To configure alarms:
1. Right-click an Interactive Visual Queue monitor and click Set alarms.
The Set Alarms window appears.
2. Under Performance variables, select the variable you want to monitor.
3. Under Alarm thresholds, click Add value and select a boundary (or value) for the variable
you selected as well as the alarm type(s) that will indicate when the variable exceeds those
boundaries.
4. For more information on configuring monitor alarms, see "Setting alarms" on page 263.
5. If you want to add further alarms for the variable, repeat step 3.
6. Click OK to save the alarms.
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UNDERSTANDING CALL PRIORITY
Each queue has a default priority level. When a call enters the system for the first time, the call
adopts the default priority of whichever queue it enters. If all calls in a queue have the same priority,
the position of the calls are based on each call’s total time in the current queue. If a queue contains
calls that have multiple priority levels, higher priority calls will have a higher position in the queue
than lower priority calls.
As long as a call remains in a queue, it maintains its priority. However, if a call moves from one
queue to another queue, the call’s priority may change, based on the method used to move the call.
When you redirect a call manually, the call always adopts the default priority level of the destination
queue. For example, suppose Queue 1 has a priority of 1 and Queue 2 has a priority of 15. When a
call first enters Queue 1, it has a priority of 1. However, if you manually move that call to Queue 2,
using either a drag-and-drop operation or the right-click menu, the call priority lowers to 15. The rules
work the same in reverse. If you manually move a priority 15 call from Queue 2 to Queue 1, the call
priority increases to 1 when it enters Queue 1.
Calls interflowed automatically retain the original call priority, or adopt the priority of the new queue
based on telephone system settings. The interflow options you specify for a queue in YourSite
Explorer must be identical to those of the telephone system. For more information on configuring
interflowed calls, see "Adding queues" on page 142.

VIEWING CALLBACK INFORMATION IN INTERACTIVE VISUAL
QUEUE
When licensed with an IVR Routing Advanced Starter pack or greater, Interactive Visual Queue also
provides the Callbacks to be processed grid, which displays all callbacks in the displayed queues in
the Interactive Visual Queue monitor. Users can access the Callbacks to be processed grid to
manage callbacks in queue. For more information, see "Managing callbacks in Interactive Visual
Queue callback monitors" on page 417.
The following list provides descriptions of the column headings available in the Callbacks to be
processed grid and the Global Callback monitor:
l

Caller # displays the phone number provided by the contact

l

Caller Name displays the contact’s name

l

Status displays the state of the callback
•

New request

•

In progress

•

Requeued

•

Completed

•

Unknown
Priority the importance level of the callback.

l

l
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•

Voice—Normal

•

Web—Normal

•

Abandoned—Low
Type displays the type of callback
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•

Voice

•

Web

•

Abandoned

l

Reason displays the callback’s reason for its current status

l

Attempted Calls to Agent displays the number of times the agent attempted the callback

l

Last Time Agent Attempted displays the last time the agent attempted the callback

l

Request time displays the specific time the callback will be executed

l

Time Received displays the specific time the caller submitted the callback request

l

Web IP Address displays the IP address of the contact who submitted the callback request.

l

Last Attempted Call To Client displays the specific time the last callback attempt to the caller
was made

l

Attempted Calls To Client displays the number of times the callback was attempted

l

Client Available From displays the earliest time the contact is available to receive the callback

l

Client Available To displays the latest time the caller is available to receive the callback

l

ANI displays the phone number of the caller

l

DNIS displays the phone number the caller dialed

l

Dialable displays the number of the device that will handle the callback

l

Device Name displays the name of the device that will handle the callback

l

l

Device Type displays the type of device that will handle the callback – agent, queue, or
extension
Recorded Message displays a hyperlink to the voice callback request .wav file left by the
caller

l

Area displays the state, province, or other area the call originated f rom

l

Country displays the country the call originated from

l

Port displays the number of the port attempting to perform the callback

l

Region displays the region the call originated from

Managing callbacks in Interactive Visual Queue callback monitors
Using Interactive Visual Queue’s Callback to be processed grid, users can requeue, reject, and
delete callbacks from monitors. Requeued callbacks are re-entered into their queue. Rejected
callback are removed from the queue are will not be offered to employees. Deleted callbacks are
removed from the current monitor, but are not removed from the system.
Users can also adjust a callback’s priority. Callback priority determines the order of which callbacks
will be offered to agents. Callbacks are offered to agents in order of their priority and then by the
longest waiting callback of that priority. For example, High priority callbacks are offered before
Normal priority callbacks, even if the Normal priority callbacks have been in queue longer.
The following procedures explain how to:
l

Requeue a callback

l

Reject a callback

l

Delete a callback

l

Change a callback’s priority
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To requeue a callback
1. Right-click a callback and select Requeue.
2. Select Yes.
To reject a callback
1. Right-click a callback and select Reject.
2. Select Yes.
To delete a callback
1. Right-click a callback and select Delete.
2. Select Yes.
To change a callback’s priority
l
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Right-click a callback and select Change priority=>[priority level].

Chapter 14
CONTACT CENTER PHONESET
MANAGER AND CONTACT CENTER
SOFTPHONE
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and Contact Center Softphone
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CONTACT CENTER PHONESET MANAGER AND
CONTACT CENTER SOFTPHONE
The Contact Center PhoneSet Manager and Contact Center Softphone applications are designed for
the 3300 ICP telephone system. They provide ACD agent functions and enable agents to use their
desktop computers as IP-based phones.
NOTE:
l
l

l

Soft phone is not supported on the Enterprise Server.
Interactive Contact Center is required to control the availability of agents and ACD queues.
See "Interactive Contact Center" on page 388.
External hot desking agents are supported for use with Contact Center PhoneSet Manager
only.

USING CONTACT CENTER PHONESET MANAGER AND
CONTACT CENTER SOFTPHONE
Contact Center PhoneSet Manager and Contact Center Softphone enable agents to use their
desktop computers as IP-based phones. Contact Center PhoneSet Manager automates Mitel IP
phone sets from the computer desktop. An agent who uses Contact Center PhoneSet Manager has
a headset connected to a desk phone. Contact Center Softphone provides complete phone set
functionality from the computer desktop. A computer and wired or wireless USB headset deliver
calls to the agent.

STARTING CONTACT CENTER CLIENT
Contact Center Softphone and Contact Center PhoneSet Manager reside in Contact Center Client.
NOTE: Launching client-side applications from the task bar causes them to bypass the Updater
Service process. To ensure successful updates from the Enterprise Server, after an upgrade close
all client-side applications for 15 minutes or reopen them from the Start menu/Start screen
To start Contact Center Client
1. Open Contact Center Client.
2. If prompted, type your user name and password and verify the Enterprise Server IP address.
3. If you use Secure Socket Layer, select the SSL check box.
4. Optionally, select the Remember my credentials check box.
5. Click Log in.

420

Using Contact Center PhoneSet Manager and Contact Center Softphone

TESTED HEADSETS
The following headsets have been tested with Contact Center Softphone and are supported as audio
devices only:
Plantronics models:
l

Plantronics USB Headset – Savi D100/W430: Current

l

Plantronics USB Headset – Blackwire

l

C420

l

C600 family

l

Plantronics USB Headset – DA4

l

Plantronics USB Headset – BUA 100

Jabra models:
l

Jabra GN 9330e USB

l

Jabra GN 2000 USB

l

Jabra BIZ 2400 USB Duo MS

NOTE: In order for the Plantronics and GN Netcom headsets to work with Contact Center PhoneSet
Manager you must have the correct amplifier adaptor for the Mitel phones. In order for the Plantronics
and GN Netcom headsets to work with Contact Center Softphone you must have the correct USB
adaptor.

USB-TO-HEADSET ADAPTORS
For Contact Center Softphone, the Plantronics H251N and H261N and the GN Netcom GN 2110 ST
and GN 2115 ST headsets must be connected to your computer by a USB-to-headset adaptor. We
have tested the following USB-to-headset adaptors to confirm they work with Contact Center
Softphone:
l

Plantronics DA60 USB-to-Headset Adaptor (part number DA60)

l

GN Netcom USB-to-headset adaptor (part number GN 8110)

l

GN Netcom USB-to-headset adaptor (part number GN 8120)

You can integrate the GN 8120 with Contact Center Softphone and use the three different function
buttons on the GN 8120 to perform specific functions in Contact Center Soft phone. Table 35 shows
the GN 8120 button functions.

421

Contact Center Solutions User Guide

Table 35: GN 8120 button functions
BUTTON

STATE

ACTION

Blue volume
control

Any state

Increases or decreases the headset
speaker volume, which controls the
volume at which you can hear a
caller

White button

Any state

Turns the mute function on or off

Incoming call is ringing on one of your line
appearances
Green button

You are currently talking to someone and
you do not have anyone on consultation
hold
You are currently talking to someone and
you have someone on consultation hold
You are currently talking to someone, and
you do not have anyone on consultation
hold

Red button

You currently have someone on hold
You are currently talking to someone and
you have someone on consultation hold

Answers a call
Hangs up a call
Performs a swap with the party on
hold

Places the current call on hold
Retrieves the call on hold
Cancels the current call and returns
you to the party on hold

Table 36 shows situations where the LEDs will be lit or flashing based on the state of Contact Center
Softphone.
Table 36: GN 8120 LED displays
WHAT YOU ARE DOING
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GN 8120 LED DISPLAYS

All lines are idle, and the mute function is off

All LEDs are off

The mute function is on

Blue LED above the white button is on

A call is ringing

Green LED above green button is flashing

You are currently dialing, waiting for an answer,
or talking to someone, and you do not have
anyone on hold

Green LED above green button is on

You are currently talking to someone, and he
has put you on hold

Green LED above green button is flashing

You put someone on hold

Red LED above red button is on

You are currently talking to someone, and you
have someone on consultation hold

Green LED above green button is on
Red LED above red button is flashing
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Integrating the GN 8120 with Contact Center Softphone
To integrate the GN 8120 with Contact Center Softphone
1. Log on to Contact Center Client.
2. In the Contact Center Client ribbon, click Soft Phone
3. Click the Soft Phone icon in the toolbar ribbon.
The Soft phone configuration window opens.
4. After Input audio device, choose the GN 8120.
5. After Output audio device, choose the GN 8120.
6. Click OK.

SETTING UP THE SOFT PHONE
The functionality of Contact Center PhoneSet Manager and Contact Center Softphone is similar. For
simplicity, we will use soft phone when referring to features and functionality common to both
applications.
NOTE:
l

l

l

Before you set up the soft phone on your client computer, ensure your network administrator
has configured your soft phone as a 5020 IP phone on the telephone system.
Users who are upgrading to Contact Center Solutions Version 6.0 or greater must uninstall
MiAUDIO Desktop Edition before they use Contact Center Softphone. MiAUDIO is now
bundled in the Contact Center Solutions software and no longer runs as the IP Phone
Emulation Service.
Although Inter-Tel users can log in to multiple extensions simultaneously, this functionality is
not currently supported by Contact Center Solutions applications.

To set up a client computer to use the soft phone
1. Consult your network administrator to confirm your soft phone extension number.
2. Ensure your headphone is connected.
3. Configure sound and audio device properties.
See "Configuring sound and audio device properties" on page 423.
4. Run Client Component Pack.
See "Installing the latest version of Client Component Pack" on page 48.

CONFIGURING SOUND AND AUDIO DEVICE PROPERTIES
To configure sound and audio device properties for Windows operating systems, you must set the
PC speakers as the default audio device and adjust the volume of the PC speakers, headset
speakers, and headset microphone.
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OPENING THE SOFT PHONE
To open the soft phone
1. In the Contact Center Client ribbon, click Soft Phone
2. Click the Soft Phone icon in the toolbar ribbon.
The Soft phone configuration window opens.
See Figure 97.

Figure 97: Soft phone configuration window
3. Click Add Extensions to search and select from all internal standard extensions, hot desk
extensions, and external hot desk user extensions.
4. Click Add External Agents to search and select from all external hot desk agent extensions.
5. Select your phone extension from the list of extensions.
NOTE: Although Inter-Tel users can log in to multiple extensions simultaneously, this
functionality is not currently supported by Contact Center Solutions applications.
6. If you have Contact Center PhoneSet Manager, click Desk phone. If you have Contact
Center Softphone, click Soft phone.
7. If you want to log on automatically to the soft phone with your phone extension the next time
you open the current profile, select the Remember my extension check box.
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You must save the current profile before you quit the soft phone for this option to work.
If you are a hot desk user who participates in the use of PINs, the PIN login dialog box opens.
If you are a hot desk user who does not participate in the use of PINs, go to step 10.
NOTE: When logging in as an external hot desking agent or a hot desking user who is not set
up to use a PIN login, if the PIN entry window displays, do not enter a PIN; just click Login.
8. Type your Login PIN.
If you want Contact Center Client to remember your Login PIN, select the Remember your
credentials check box. This option is not available if your Contact Center Client profile is
shared.
9. Click Login.
NOTE:
l

l

If the Login PIN you entered is invalid the login will fail and you will be asked to enter a
valid Login PIN.
By default, users can attempt to log in 3 times before their PIN locks, requiring it be
reset with a new PIN. It is recommended that the default number of failed attempts
before the PIN is locked is increased on your telephone system to prevent locking. For
information on changing this setting, see the following Knowledge Base article:
http://micc.mitel.com/kb/KnowledgebaseArticle52108.aspx.
Advanced supervisor or System Administrator will not be prompted to enter a PIN
provided third party call control is configured under security in CCMWeb and on the
telephone switch.

10. If you want Contact Center Client to be the top-most window on ringing, select the Bring to
front on ringing check box.
11. If you want Contact Center Client to not display the screen pop window when calls are ringing
on the desktop, enable the Disable toaster on ringing check box.
12. If you selected Soft phone in step 6, under Soft phone settings, configure soft phone
options.
NOTE: For the relevant configuration information, contact your supervisor or system
administrator.
13. After Address book source for contacts, select YourSite contacts or Outlook contacts.
Contact Center PhoneSet Manager and Contact Center Softphone users can access
YourSite database phone extensions or Outlook Personal Contact or Global Address List
phone numbers when they handle calls.
14. To automatically log off the agent from the telephone system when closing the soft phone,
select the Automatically log off this ACD agent when closing the soft phone check box.
15. To automatically launch Ignite when logging into Contact Center Softphone or PhoneSet
Manager, select Automatically launch the Ignite Client on ACD login check box.
NOTE: This option only applies to voice agents who use Ignite to handle multimedia contacts.
16. If you want to synchronize online presence indicators with ACD agent states in real-time
monitors, select the Synchronize my Lync presence with my ACD state check box.
17. If you want to display call notes on the soft phone display and on the Call Notes monitor,
ensure the Display call notes check box is selected.
18. Click OK.
The Contact Center Client window displays the soft phone, Phone and Functions toolbars.
See Figure 98.
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Figure 98: Soft phone toolbars
19. If you want to be able to position the soft phone toolbar elsewhere on your desktop, enable the
Float check box.
20. To move the soft phone toolbar, hover the mouse over the perforated line on the left-side of the
toolbar until the four-headed arrow displays. Then click, drag, and drop it to the desired
position on your desktop. To reanchor the toolbar to the ribbon, drag and drop it into position
under the ribbon.
21. If you want to modify the soft phone configuration, click the Configuration icon in the toolbar
to reopen the Soft phone configuration window.

Changing soft phone IP addresses
If you are required to change the IP address for your soft phone, consult the following procedure.
1. In the Contact Center Client ribbon, click Soft Phone.
2. Click the Soft Phone icon in the toolbar ribbon.
3. In the Soft phone configuration window, click Soft phone settings.
4. After Use IP address: select the new IP address from the drop-down list and click OK.
NOTE: For information on what address to select, contact your supervisor or system
administrator.
5. In the Soft Phone configuration window, under ‘This extension is a’, click Desk phone
and then click Soft phone.
NOTE: Clicking ‘Desk phone’ is required to unbind your soft phone from the previous IP
address.
6. Click OK.
7. On the ribbon, click Save.

THUMBNAIL SOFT PHONE TOOLBAR
The thumbnail soft phone toolbar enables agents to quickly perform soft phone actions when other
applications are open on the desktop. The thumbnail toolbar gives agents access to Answer, Hang
up, Cancel, and Dial functions and is particularly helpful when the Contact Center Client application
is minimized and you want to perform a quick soft phone action. To see the toolbar options, hover
over it with your mouse. (Figure 99.)
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Figure 99: Thumbnail soft phone toolbar
NOTE:
l

l

The thumbnail soft phone toolbar is supported with Windows 7 or Windows 2008 operating
systems only.
Because of Windows limitations, this toolbar may not always display when Contact Center
Client has focus on the desktop.

LOGGING ON TO THE ACD
Agents can log on to the ACD a number of ways, such as selecting the Superkey button in Contact
Center Softphone, or using the agent control function in Interactive Contact Center. See "Contact
Center PhoneSet Manager and Contact Center Softphone" on page 420.
We recommend that soft phone users who are hot desking agents log on to the ACD using the soft
phone Actions menu. This enables the soft phone to identify agents.
NOTE: If you are an external hot desking agent or a hot desking user who logged in internally, logged
out, and then chose to log back in externally, you will not be able to log on with the soft phone
Actions menu. In order to access this functionality, you must first close and reopen the soft phone
toolbar (View=>Deselect and reselect the soft phone option).
To log a standard agent onto ACD
l

On the soft phone Functions toolbar, click Actions=>Log on=>Agents and select an agent
ID.

To log an external hot desking user onto ACD
l

On the soft phone Functions toolbar, click Actions=>Log on=>Hot Desking Users.

To log an external hot desking agent on to ACD
l

On the soft phone Functions toolbar, click Actions=>Log on=>Agent ID.

NOTE: When a hot desk agent logs in to the ACD a 3300 ICP user license is taken from the
available licensing pool and when the agent logs out the license is released back to the licensing
pool. Agents are notified upon login attempt if the number of concurrent logins exceeds the number of
available user licenses. If there are no available user licenses the login attempt will fail.
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PHONE AND FUNCTIONS TOOLBARS
The Phone toolbar displays your
l

Extensions (gray oval buttons)

l

Hold button (red oval button)

l

Superkey button (blue oval button, for Contact Center Softphone only)

l

Current phone state (Idle, Dialing, Talking) box with a down arrow that displays a call details
window

l

Dial box (field for dialing extensions or phone numbers)

l

Dial button (Contact Center PhoneSet Manager only)

l

Redial button (Contact Center Softphone only)

l

Cancel button (Contact Center Softphone only)

l

Message button (for retrieving voice mail messages, Contact Center Softphone only)

The Functions toolbar displays
l

Your current ACD state (Logged On/Off, in Make Busy, in Do Not Disturb)

l

The ACD actions currently available

l

Telephony buttons
See "Displaying, hiding, and retiring toolbar buttons" on page 431.

PHONE FUNCTIONS
You can readily answer calls or forward them to extensions or phone numbers using the soft phone.
You can select people from contact and speed dial lists, and perform the following actions: Redial
(Contact Center Soft phone only), Transfer, Conference, Mute, Forward, Request help, Hold,
Retrieve, Split, Swap, Camp on, Leave a message, Retrieve a message, Call me back, Hang up,
and Cancel.
NOTE: External hot desk agents access the 'Answer' and 'Hang up' functions using their external
device and not the soft phone toolbar.
Table 37 lists the soft phone telephony options and their corresponding meanings.
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Table 37: Agent actions
ICON

MEANING

Account Code

Answer

tags a call with an Account Code

answers a ringing call

Auto answer

if enabled, answers a ringing call without you having to click
Answer

Call me back

notifies you as soon as the extension number you are trying
to call is available

Camp on

notifies an employee you are attempting to call with a series
of audible beeps

Cancel

Conference

terminates your connection to a caller

connects three or more people together for a conversation

Dial pad

enables you to dial a number using a keypad

Forward

forwards a call to a phone number or extension

Hang up

terminates a call

Hold

places the current call on hold
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Table 37: Agent actions (continued)
ICON

MEANING

Leave a message

Mute

Request help

leaves a message waiting notification on an employee’s
extension
if you have Contact Center Softphone, disables your
microphone so you can consult privately with another
employee while on a call
calls an employee who can click Answer and listen to an inprogress call without the caller knowing

Retrieve

picks up a call that is held or camped on to your extension

Speed dial

enables you to make a call to a specified number with one
mouse click

Split

disconnects one person from a conference call

Swap

swaps between the current and the held party

Transfer

forwards an in-progress call to another answer point

Transfer/Conference places a caller on hold and makes a consultation call
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Volume

if you have Contact Center Softphone, adjusts the volume
of your speakers and/or microphone

Call Notes

enables you to view the notes associated with the current
call and add notes
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CUSTOMIZING THE SOFT PHONE
You can enhance productivity by configuring the following time-saving options in the soft phone:
l

Toolbar customization

l

Sounds and notifications

l

Call forward destinations

l

Speed dial contacts

l

Shortcut keys

l

Pre-announcement messages

Configuring soft phone settings
To specify soft phone settings
1. Right-click the Phone toolbar and click Configure.
2. After Input audio device, select an audio device for your microphone.
3. After Output audio device, select an audio device for your speakers or headset.
4. Click OK.

Specifying the address book source for contacts
To specify the address book the soft phone uses for contacts (Microsoft Outlook or the YourSite
database)
1. Right-click the Phone toolbar and click Configure.
2. After Address book source for contacts, select YourSite contacts or Outlook contacts.
3. Click OK.

Resizing toolbar buttons
To resize toolbar buttons
1. Right-click the Phone toolbar and click Configure.
2. Click the Toolbars tab.
3. After Functions toolbar, select a size for displaying the Functions toolbar buttons.
4. After Phone toolbar, select a size for displaying the Phone toolbar buttons.
5. Click OK.

Displaying, hiding, and retiring toolbar buttons
You can display telephony buttons, hide them so they appear on the Functions toolbar only when
required, and retire them for actions you rarely perform, such as Camp on and Request help.
To display telephony buttons
1. Right-click the Phone toolbar and click Configure.
2. Click the Toolbars tab.
3. Under Selected buttons, select the check boxes of the telephony buttons you want to
display.
4. Click OK.
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To hide telephony buttons
1. Right-click the Phone toolbar and click Configure.
2. Click the Toolbars tab.
3. Under Selected buttons, clear the check boxes of the telephony buttons you want to hide
from view.
4. Click OK.
To retire telephony buttons
1. Right-click the Phone toolbar and click Configure.
2. Click the Toolbars tab.
3. Under Selected buttons, select the telephony buttons you want to retire and click the left
arrow to add these buttons to the Available buttons list.
4. Click OK.
To restore telephony buttons
1. Right-click the Phone toolbar and click Configure.
2. Click the Toolbars tab.
3. Under Available buttons, select the telephony buttons you want to restore and click the right
arrow to add these buttons to the Selected buttons list.
4. Click OK.

Repositioning toolbar buttons
To specify the order in which telephony buttons appear
1. Right-click the Phone toolbar and click Configure.
2. Click the Toolbars tab.
3. Under Selected buttons, select a telephony button.
4. Click the up or down arrow to change the position of the button relative to other buttons on the
Functions toolbar.
5. Click OK.

Configuring sounds and notifications
You can configure sounds for individual phone events for incoming calls, secondary incoming calls,
and/or the digits dialed on your primary extension, or on all extensions. A primary incoming call is a
call you receive while you are in the idle state and are available to take the call. A secondary
incoming call is a call you receive while you are on a call on another extension and are not available
to take the call.
Every time you receive a call a pop-up window notifies you the call has arrived. You can disable the
pop-up notification.
To configure a sound for a phone event
1. Right-click the Phone toolbar and click Configure.
2. Click the Sounds tab.
3. Select the Incoming calls, Secondary incoming calls, and/or Play sounds when dialing
digits check boxes.
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4. After Phone events, select a phone event.
5. After Sound file name, click Browse and select a sound file.
6. If you want to play the sound file when the phone event occurs on any of your extensions,
click Apply to all lines.
7. Click OK.
To disable the call arrival pop-up notification
1. Right-click the Phone toolbar and click Configure.
2. Click the Sounds tab.
3. Under Phone events, click a phone line.
4. Clear the Display pop-up notification for incoming calls check box.
5. Click OK.

Making calls ring through your computer speakers
You can make calls ring through your computer speakers instead of your headset.
To make calls ring through your computer speakers
1. Right-click the Phone toolbar and click Configure.
2. Click the Sounds tab.
3. After Play the rings sounds on select the sound output device for your computer speakers.

Adjusting the volume of your speakers and microphone
If you have Contact Center Softphone, you can adjust the volume of your speakers and microphone.
To adjust the volume of your speakers
1. Right-click the Phone toolbar and click Configure.
2. Click the Sounds tab.
3. Adjust the volume by moving the speaker slider.
To adjust the volume of your microphone
1. Right-click the Phone toolbar and click Configure.
2. Click the Sounds tab.
3. Adjust the volume by moving the microphone slider.

Configuring call forward destinations
You can forward calls manually to pre-configured call forward destinations. In addition, you can
configure and enable call forwarding so the telephone systems forwards calls to other answer points
when you are temporarily unavailable or away from the office. For example, you could specify all
External call busy calls you receive be forwarded to a co-worker’s extension. Rather than directing
these call to voice mail, the telephone system would forward these calls to your co-worker.
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To configure call forward destinations for calls you will forward manually
1. Right-click the Phone toolbar and click Configure.
2. Click the Call forward tab.
3. Under Name, type the name of the person to whom you will forward calls.
4. Under Number, type an extension or phone number (preceded by a number you dial to access
an outside line).
5. Click OK.
To configure and enable call forward destinations for calls the telephone system will forward
1. Right-click the Phone toolbar and click Configure.
2. Click the Call forward tab.
3. Specify the source for call forwarding.
4. Specify destinations for the following call types:
l

All calls (all calls you receive)

l

External call busy (external calls to your extension when you are unavailable)

l

External call no answer (external calls to your extension that you do not answer)

l

Internal call busy (internal calls to your extension when you are unavailable)

l

Internal call no answer (internal calls to your extension that you do not answer)

5. If you want to activate the call forwarding rules immediately, select the Enabled check boxes
of the call forwarding types to be activated.
6. Click OK.

Configuring speed dial numbers
When you pre-configure speed dial numbers in Contact Center Softphone, these contacts are
available in drop-down lists adjacent to the Speed dial, Trans/Conf, and Request help buttons on the
Functions toolbar.
You can display a button for each speed dial number or display one button with a down arrow that
lists all of the speed dial numbers you have configured. You can speed dial calls manually to preconfigured extensions and phone numbers.
To configure a speed dial number
1. Right-click the Phone toolbar and click Configure.
2. Click the Speed dial tab.
3. Under Name, type the name of the person to whom you will speed dial calls.
4. Under Number, type an extension or phone number (preceded by a number you dial to access
an outside line).
5. Click OK.

Configuring shortcut keys
You can assign a shortcut key to a telephony function to perform it with a simple keystroke. This
enables you to perform telephony functions while the soft phone is minimized or another application
is currently selected.
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To configure a shortcut key for a telephony function
1. Right-click the Phone toolbar and click Configure.
2. Click the Shortcut keys tab.
3. Under Shortcut key, select a telephony function.
4. Click the down arrow, select Ctrl, Alt, Shift, or Win, and select a keyboard number, letter, or
function from the list.
5. Click OK.

Configuring pre-announcement messages
NOTE: For hardware and software specifications related to pre-announcement messages, see the
Contact Center Solutions and Business Reporter System Engineering Guide.
Agents who have Contact Center PhoneSet Manager or Contact Center Softphone can record
introductions that are played to callers (for example, 'Hi. This is Paul Jones in Customer Support.
Could you please tell me your customer site key?') The introduction that is played is based on the
queue the call arrives on and the time of day it is received. The recorded introduction provides
customers with a consistent greeting and gives the agent extra time to retrieve customer
information. You can stop pre-announcement messages at any time.
You can configure more than one pre-announcement rule. For each rule, you specify the conditions in
which the soft phone will play a particular pre-announcement message. If one or more conditions is
satisfied for a particular rule, the soft phone will play the associated pre-announcement message.
You can order the rules on the Pre-announcement rules table to establish their priority. Preannouncement rules are evaluated in the order shown in the table. If one pre-announcement rule is
satisfied, the associated sound file is played and no other rules are evaluated.
NOTE: To use pre-announcement messages with Contact Center PhoneSet Manager, you must
have a Mitel ACD desk phone (for example, 5212) and a PCTI adaptor. The PCTI adaptor enables
the audio being played from the agent PC and the audio from the agent desk phone to be mixed.
To connect a PCTI adapter to your computer for use with Contact Center PhoneSet Manager
1. Set the PCTI switch to Both.
2. Set the PCTI switch to HeadSet.
3. Plug the Mic/Audio cable of the headset into the appropriate Mic/Audio inputs on the
PCTI adapter.
4. Unplug the handset from the deskphone and plug it into the handset plug on the PCTI adapter.
5. Plug the telephone input cable of the PCTI adapter into the telephone base.
6. Plug the computer input of the PCTI adapter into the appropriate Mic/Speaker inputs on the
PC.
NOTE: Ensure the headset is turned on, on the deskphone base.
To configure a pre-announcement rule for Contact Center PhoneSet Manager
1. Right-click the Phone toolbar and click Configure.
2. Under This extension is a, select Desk phone.
3. To use audio devices for pre-announcements, select Use audio devices for preannouncements and specify the input and output audio device.
4. Click the Pre-announcement tab.
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5. Click Add rule.
The Add / Edit pre-announcement rule window opens.
6. Select the conditions that determine when the pre-announcement message will play.
7. Specify parameters for each condition.
8. Select or record a wave file to play when the above conditions are met.
9. Type a name for the pre-announcement rule.
10. If you want to hear ringing on your desk phone, select Enable ringing sound in desk phone.
11. Click OK.
To configure a pre-announcement rule for Contact Center Softphone
1. Right-click the Phone toolbar and click Configure.
2. Under This extension is a, select Soft phone.
3. Click the Pre-announcement tab.
4. Click Add rule.
The Add / Edit pre-announcement rule window opens.
5. Select the conditions that determine when the pre-announcement message will play.
6. Specify parameters for each condition.
7. Select or record a wave file to play when the above conditions are met.
8. Type a name for the pre-announcement rule.
9. Click OK.
To re-order pre-announcement rules
1. Select a rule.
2. Click the up or down arrow to change the priority of the rule.
3. Click OK.

MAKING AND TERMINATING CALLS USING CONTACT
CENTER PHONESET MANAGER
When you make calls, on the Functions toolbar you can readily select contacts you pre-configure in
Microsoft Outlook, or speed dial numbers you configure in Contact Center PhoneSet Manager. See
"Configuring speed dial numbers" on page 434 and "Displaying, hiding, and retiring toolbar buttons"
on page 431.
You can dial any extension number or phone number. Contact Center PhoneSet Manager typically
uses your primary extension to make calls. You can optionally select a different extension on the
Phone toolbar to make calls.
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Making calls
To dial by phone number or extension number using Contact Center PhoneSet Manager
1. In the dial box, type an extension or phone number (preceded by a number you dial to access
an outside line). Otherwise, click the down arrow adjacent to the dial box and type a number or
extension on the dial pad.
2. Click Dial.
3. If you want to view the call details window, click the down arrow adjacent to the box that
displays your current phone state.
See Figure 100.
To dial internally from a real-time monitor using Contact Center PhoneSet Manager
l

From any real-time monitor, right-click an agent, employee, or extension cell and click Call.

Figure 100: Making a call

Making calls to your contacts
To make a call to an extension in your contact list
1. Click the arrow adjacent to the dial box and click the Contacts tab.
2. Select a contact in the list.
3. Click Dial.

Making calls using speed dial
To dial using speed dial
l

Click Speed dial and select a name in the list.

Terminating calls
To terminate a call
l

Click Hang up.
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FORWARDING AND ANSWERING CALLS USING CONTACT
CENTER PHONESET MANAGER
You can forward calls manually to pre-configured call forward destinations without having to speak to
the caller first. In addition, you can configure and enable call forwarding so the telephone system
forwards calls to other answer points when you are temporarily unavailable or away from the office.
See "Configuring call forward destinations" on page 433.
If a call is ringing on your extension and you click the Forward button, the call will be forwarded to the
default call forward destination configured in the telephone system. If you click the down arrow
adjacent to the Forward button, you can select an extension or phone number for call forwarding.

Forwarding calls
When a call is ringing on your extension, to forward the call using Contact Center PhoneSet Manager
1. Click Forward.
2. In the dial box, type an extension or phone number (preceded by a number you dial to access
an outside line). Otherwise, click the down arrow adjacent to the Forward button and select a
contact.
3. Click Dial.

Answering calls
When an agent receives a call with Contact Center PhoneSet Manager detailed caller information is
displayed on the desktop. (See Figure 101.) Agents can choose to answer the call or forward it to
another agent. Additionally, the display can provide access to call notes, which are notes an agent
adds to the call before transferring it. See "Adding call notes to a call" on page 440.
If configured and available the following information is provided in the soft phone display
l

Caller name—name of the caller

l

ANI—telephone number of the caller

l

DNIS—telephone number the caller dials

l

DNIS name—the name associated to the DNIS number in YourSite database

l

Agent ID— agent who transferred the call

l

Extension—extension from which the call was transferred

l

Queue—queue from which the call originated

l

l

l

Collect Caller Entered Digits—digits the caller enters for identification purposes, such as a
customer site key
Customer Collected Information—information collected from a third party OBDC database.
Customer Collected Information requires and Verified Collected Digits, and optionally,
Remote Database Verification or CTI Developer Toolkit
Call notes—notes added by an agent

You can answer calls by right-clicking the Contact Center PhoneSet Manager system tray icon and
selecting Answer, or by clicking the Answer toolbar button.
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Figure 101: Contact Center PhoneSet Manager display
To answer a call using Contact Center PhoneSet Manager
l

Click Answer.

HANDLING CALLS USING CONTACT CENTER PHONESET
MANAGER
You can handle calls by right-clicking the Contact Center PhoneSet Manager system tray icon and
selecting telephony functions, or by selecting telephony buttons on the Functions toolbar. The
telephony buttons available depend on the action you last performed. You can configure the toolbar
buttons so they are always visible, or visible only when required. See "Displaying, hiding, and retiring
toolbar buttons" on page 431.
When you pre-configure speed dial numbers in Contact Center PhoneSet Manager, these contacts
are available in drop-down lists adjacent to the Speed dial, Trans/Conf, and Request help buttons on
the Functions toolbar. See "Configuring speed dial numbers" on page 434.

Placing calls on hold
To place a call on hold
l

Click Hold (red oval button).

Retrieving calls
You can retrieve a held call, or retrieve a call when a call is camped on to your extension.
When an agent is on a call and another caller camps on to their extension, the Retrieve button is
enabled. When the agent presses the Retrieve button, they can talk to the held party. From that point
on, the agent uses the Swap button to switch back and forth between the two callers (current and
held parties).
To retrieve a call
l

Click Retrieve.
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Adding call notes to a call
When agents are speaking with customers, they can add notes to calls to share with other contact
center employees involved in the call. This ensures agents and supervisors have context on calls
and know what information has been provided to customers upon call transfer.
When a call is being transferred to an agent or supervisor, the soft phone display shows the most
recent note associated with the call. When the agent answers the call, Contact Center Client
appears on top of all other open applications and displays the Call Notes monitor. The monitor
includes all of the call notes associated with the current call.
Agents can add notes each time a call is transferred, and agents on conference calls can add notes
simultaneously. Each set of notes includes the agent’s name and a date/time stamp. When an agent
completes a call and answers a new call or closes the Call Notes monitor, all call note information is
saved and appended to the Lifecycle reports. Call notes are not preserved when a call is parked.
NOTE:
l

l

l

On the Soft phone configuration window, you can clear the Enable call notes check box to
hide the Call Notes monitor and prevent call notes from being displayed. Optionally, you can
enable the Bring to front check box to ensure call notes display on top of all other windows
when calls are received.
You must have Contact Center PhoneSet Manager or Contact Center Softphone open in order
to view or add call notes.
Time stamps are based on the 3300 ICP telephone system clock.

To add a call note
1. As a call is ringing on your extension, on the soft phone display click Answer to answer the
call.
Contact Center Client appears on top of all open applications and displays the Call Notes
monitor.
2. After Enter a new call note, type a note.
Call notes can include a maximum of 100 characters.
3. Click Add.
The call note is added to the Call notes text box and is included in the soft phone display upon
call transfer.

Transferring calls
You can perform a blind transfer or a supervised transfer.
To perform a blind transfer using Contact Center PhoneSet Manager
1. While on a call, click Trans/Conf.
2. In the dial box, type an extension or phone number (preceded by a number you dial to access
an outside line if required). Otherwise, click the down arrow adjacent to the Trans/Conf button
and select a contact.
3. Click Dial.
4. Click Hang up.
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To perform a supervised transfer
1. While on a call, click Trans/Conf.
2. In the dial box, type an extension or phone number (preceded by a number you dial to access
an outside line). Otherwise, click the down arrow adjacent to the Trans/Conf button and select
a contact.
3. Click Dial.
The system places the caller on Hold.
4. Wait for the called party to answer. If you receive a busy signal or a voice mail greeting, click
Cancel to return to the initial party. Otherwise, speak to the agent and identify the caller.
5. Click Transfer to transfer the call.

Conferencing calls
You can include up to eight people in a conference call. The following example illustrates a three-way
conference call.
To set up a conference call
1. In the dial box, type an extension or phone number (preceded by a number you dial to access
an outside line).
2. Click Dial.
3. After you speak with the person who answers, click Trans/Conf to add a person to an inprogress call.
The system places the person on Hold.
4. In the dial box, type an extension or phone number (preceded by a number you dial to access
an outside line). Otherwise, click the down arrow adjacent to the Trans/Conf button and select
a contact.
5. Click Dial.
6. Speak to the person who answers.
7. Click Conference to initiate a three-way conference call.
To split a conference call
l

Click Split.
The last person you added to the conference call is placed on hold, and you can speak
privately with the first person.

Consulting with people while on calls
To consult with a person while on a call using Contact Center PhoneSet Manager
1. Click Trans/Conf to conference in the person.
The system places the initial party on Hold.
2. In the dial box, type an extension or phone number (preceded by a number you dial to access
an outside line). Otherwise, click the down arrow adjacent to the Trans/Conf button and select
a contact.
3. Click Dial.
4. After you consult with the person, either click Conference to conference in the person, click
Cancel to hang up on the person, click Transfer to transfer the call to the person, or click
Swap to talk to the initial party.
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Requesting help while on calls
To request help while on a call using Contact Center PhoneSet Manager
1. Click Request help.
2. On the dial pad, type the extension number of the employee you want to call. Otherwise, click
the down arrow adjacent to the Request help button and select a contact.
3. Click Dial.
The system calls the employee. The employee can click Answer and listen in on the call
without the caller knowing and can click Conference to join the conversation at any time.

Using Camp on
The Camp on feature is available when you make a call to an extension and receive a busy signal
because the employee is already on a call. Camp on notifies the employee you are attempting to call
with a series of audible beeps.
NOTE:
l

l

Callers cannot camp on to your extension if you have call forwarding or voice mail configured
on the extension.
You cannot camp on to an extension that is in Make Busy or Do Not Disturb.

To camp on to an extension
1. In the dial box, type an extension number.
2. Click Dial.
3. If you receive a busy signal, click Camp on.
The employee you called will hear a series of beeps and can click Retrieve to place the caller
on hold and speak with you. After speaking with you, the employee can click Swap to return to
the caller.

Leaving and retrieving messages
The Leave a message feature is available when you make a call to an extension that is idle or on a
call. You must use the dial pad to type a number when you are retrieving a message.
To leave a message
1. In the dial box, type an extension number.
2. Click Dial.
3. If the employee does not answer, click Leave a message.
The telephone system leaves a message waiting notification on the employee’s extension and
the Contact Center Client icon flashes red and white in the employee’s system tray.
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To retrieve a message
1. Click Dial pad and type the number configured in the telephone system for message retrieval.
2. Press Enter.
The automated attendant will ask you for your password.
3. Type your password on the dial pad.
4. Follow the instructions provided by the automated attendant to retrieve the message.
NOTE: If agents leave Call me back messages you must use your physical phone set to retrieve the
messages.

Using Call me back
The Call me back feature is available when you make a call to an extension that is idle or on a call.
When you select the Call me back button, the telephone system monitors the called employee’s
other extension. When the employee’s other extension returns to idle, your phone rings. If you pick
up the call, the employee’s phone will ring. If you do not pick up the call, the callback will expire.
To leave a callback message
1. In the dial box, type an extension number.
2. Click Dial.
3. If the employee does not answer, click Call me back.
The telephone system monitors the called employee’s extension. Your phone will rings when
the called employee’s other extension returns to the idle state.
4. When your phone rings, click Answer to pick up the call and speak with the employee.

Tagging calls with Account Codes
You can tag calls with Account Codes you pre-configure in Contact Center Client.
To tag an in-progress call with an Account Code or a Classification Account Code
l

Click the down arrow adjacent to the Account Code button and select a traditional Account
Code or a Classification Account Code.

After hanging up, while in Work Timer mode, you can tag calls with Classification Account Codes.
To tag a call, after hanging up, with a Classification Account Code
1. Click the down arrow adjacent to the Account Code button.
2. Select After Call Classification and select the appropriate Classification Account Code
from the drop-down list.

MAKING AND TERMINATING CALLS USING CONTACT
CENTER SOFTPHONE
When you make calls, on the Functions toolbar you can readily select from contacts you preconfigure in Microsoft Outlook, or speed dial numbers you configure in Contact Center Softphone.
See "Configuring speed dial numbers" on page 434 and "Displaying, hiding, and retiring toolbar
buttons" on page 431.
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You can dial any extension number or phone number. Contact Center Softphone typically uses your
primary extension to make calls. You can optionally select a different extension on the Phone toolbar
to make calls.
For information on how to use the superkey and phone book functionality of Contact Center
Softphone, refer to the 5220 IP Phone User Guide at http://edocs.mitel.com/UG/Index.html.

Making calls
To dial by phone number or extension number using Contact Center Softphone
1. In the dial box, type an extension or phone number (preceded by a number you dial to access
an outside line). Otherwise, click the down arrow adjacent to the dial box and type a number or
extension on the dial pad.
2. If you want to view the call details window, click the down arrow adjacent to the box that
displays your current phone state.
See Figure 102.
To dial internally from a real-time monitor using Contact Center Softphone
l

From any real-time monitor, right-click an agent, employee, or extension cell and click Call.

Figure 102: Making a call

Making calls to your contacts
To make a call to an extension in your contact list
1. Click the arrow adjacent to the dial box and click the Contacts tab.
2. Double-click a contact in the list.

Making calls to contacts who have called you recently
To make a call to a contact who has called you recently
1. Click the arrow adjacent to the dial box and click the Recent tab.
2. Double-click a contact in the list.
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Making calls using speed dial
To dial using speed dial
l

Click Speed dial and select a name in the list.

Redialing numbers
To dial the contact who last called you
l

Click Speed dial and select a name in the list.

Terminating calls
To terminate a call
l

Click Hang up.
Alternatively, on the Phone toolbar, click Cancel.

FORWARDING AND ANSWERING CALLS USING CONTACT
CENTER SOFTPHONE
You can forward calls manually to pre-configured call forward destinations without having to speak to
the caller first. In addition, you can configure and enable call forwarding so the telephone system
forwards calls to other answer points when you are temporarily unavailable or away from the office.
See "Configuring call forward destinations" on page 433.
If a call is ringing on your extension and you click the Forward button, the call will be forwarded to the
default call forward destination configured in the telephone system. If you click the down arrow
adjacent to the Forward button, you can select an extension or phone number for call forwarding.

Forwarding calls
When a call is ringing on your extension, to forward the call using Contact Center Softphone
1. Click Forward.
2. In the dial box, type an extension or phone number (preceded by a number you dial to access
an outside line). Otherwise, click the down arrow adjacent to the Forward button and select a
contact.

Answering calls
When an agent receives a call with Contact Center Softphone detailed caller information is displayed
on the desktop. (See Figure 103.) Agents can choose to answer the call or forward it to another
agent. Additionally, the display can provide access to call notes, which are notes an employee adds
to the call before transferring it. See "Adding call notes to a call" on page 440.
If configured and available the following information is provided in the soft phone display
l

Caller name—name of the caller

l

ANI—telephone number of the caller

l

DNIS—telephone number the caller dials

l

DNIS name—the name associated to the DNIS number in YourSite database

l

Agent ID— agent who transferred the call
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l

Extension—extension from which the call was transferred

l

Queue—queue from which the call originated

l

l

l

Collect Caller Entered Digits—digits the caller enters for identification purposes, such as a
customer site key
Customer Collected Information—information collected from a third party OBDC database.
Customer Collected Information requires and Verified Collected Digits, and optionally,
Remote Database Verification or CTI Developer Toolkit
Call notes—notes added by an agent

You can answer calls by right-clicking the Contact Center Softphone system tray icon and selecting
Answer, or by clicking the Answer toolbar button.

Figure 103: Contact Center Softphone display
To answer a call using Contact Center Softphone
l

Click Answer.

HANDLING CALLS USING CONTACT CENTER SOFTPHONE
You can handle calls by right-clicking the Contact Center Softphone system tray icon and selecting
telephony functions, or by selecting telephony buttons on the Functions toolbar. The telephony
buttons available depend on the action you last performed. You can configure the toolbar buttons so
they are always visible, or visible only when required. See "Displaying, hiding, and retiring toolbar
buttons" on page 431.
When you pre-configure speed dial numbers in Contact Center Softphone, these contacts are
available in drop-down lists adjacent to the Speed dial, Trans/Conf, and Request help buttons on the
Functions toolbar. See "Configuring speed dial numbers" on page 434.

Placing calls on hold
To place a call on hold
l
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Retrieving calls
You can retrieve a held call, or retrieve a call when a call is camped on to your extension.
When an agent is on a call and another caller camps on to their extension, the Retrieve button is
enabled. When the agent presses the Retrieve button, they can talk to the held party. From that point
on, the agent uses the Swap button to switch back and forth between the two callers (current and
held parties).
To retrieve a call
l

Click Retrieve.

Using Mute
To use Mute
1. Click Mute.
The system disables your microphone so you can consult privately with another employee.
2. To restore your microphone, click Resume.

Transferring calls
You can perform a blind transfer or a supervised transfer.
To perform a blind transfer using Contact Center Softphone
1. While on a call, click Trans/Conf.
2. In the dial box, type an extension or phone number (preceded by a number you dial to access
an outside line). Otherwise, click the down arrow adjacent to the Trans/Conf button and select
a contact.
3. Click Hang up.
To perform a supervised transfer
1. While on a call, click Trans/Conf.
2. In the dial box, type an extension or phone number (preceded by a number you dial to access
an outside line). Otherwise, click the down arrow adjacent to the Trans/Conf button and select
a contact.
The system places the caller on Hold.
3. Wait for the called party to answer. If you receive a busy signal or a voice mail greeting, click
Cancel to return to the initial party. Otherwise, speak to the agent and identify the caller.
4. Click Transfer to transfer the call.
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Conferencing calls
You can include up to eight people in a conference call. The following example illustrates a three-way
conference call.
To set up a conference call
1. In the dial box, type an extension or phone number (preceded by a number you dial to access
an outside line).
2. After you speak with the person who answers, click Trans/Conf to add a person to an inprogress call.
The system places the person on Hold.
3. In the dial box, type an extension or phone number (preceded by a number you dial to access
an outside line). Otherwise, click the down arrow adjacent to the Trans/Conf button and select
a contact.
4. Speak to the person who answers.
5. Click Conference to initiate a three-way conference call.
To split a conference call
l

Click Split.
The last person you added to the conference call is placed on hold, and you can speak
privately with the first person.

Consulting with people while on calls
To consult with a person while on a call using Contact Center Softphone
1. Click Trans/Conf to conference in the person.
The system places the initial party on Hold.
2. In the dial box, type an extension or phone number (preceded by a number you dial to access
an outside line). Otherwise, click the down arrow adjacent to the Trans/Conf button and select
a contact.
3. After you consult with the person, either click Conference to conference in the person, click
Cancel to hang up on the person, click Transfer to transfer the call to the person, or click
Swap to talk to the initial party.

Requesting help while on calls
To request help while on a call using Contact Center Softphone
1. Click Request help.
2. On the dial pad, type the extension number of the employee you want to call. Otherwise, click
the down arrow adjacent to the Request Help button and select an employee.
The system calls the employee. The employee can click Answer and listen in on the call
without the caller knowing and can click Conference to join the conversation at any time.
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Using Camp on
The Camp on feature is available when you make a call to an extension and receive a busy signal
because the employee is already on a call. Camp on notifies the employee you are attempting to call
with a series of audible beeps.
NOTE:
l

l

Callers cannot camp on to your extension if you have call forwarding or voice mail configured
on the extension.
You cannot camp on to an extension that is in Make Busy or Do Not Disturb.

To camp on to an extension
1. In the dial box, type an extension number.
2. If you receive a busy signal, click Camp on.
The employee you called will hear a series of beeps and can click Retrieve to place the caller
on hold and speak with you. After speaking with you, the employee can click Swap to return to
the caller.

Leaving and retrieving messages
The Leave a message feature is available when you make a call to an extension that is idle or on a
call.
To leave a message
1. In the dial box, type an extension number.
2. If the employee does not answer, click Leave a message.
The telephone system leaves a message waiting notification on the employee’s extension and
the Contact Center Client icon flashes red and white in the employee’s system tray
To retrieve a message
1. In the dial box, type your voice mail access number.
The automated attendant will ask you for your password.
2. In the daily box, type your password.
3. Follow the instructions provided by the automated attendant to retrieve the message.
NOTE: If agents leave Call me back messages for you to check your messages, your
Contact Center Client tray icon will not clear the messages once you have checked your
messages.
To clear a message
1. On the Phone toolbar, click Message.
2. After CALL ME BACK?, click Yes.
3. Click Erase.
The telephone image displays NO MORE MESSAGES.
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Using Call me back
The Call me back feature is available when you make a call to an extension that is idle or on a call.
When you select the Call me back button, the telephone system monitors the called employee’s
other extension. When the employee’s other extension returns to idle, your phone rings. If you pick
up the call, the employee’s phone will ring. If you do not pick up the call, the callback will expire.
To leave a callback message
1. In the dial box, type an extension number.
2. If the employee does not answer, click Call me back.
The telephone system monitors the called employee’s extension. Your phone will rings when
the called employee’s other extension returns to the idle state.
3. When your phone rings, click Answer to pick up the call and speak with the employee.

Tagging calls with Account Codes
You can tag calls with Account Codes you pre-configure in Contact Center Client.
To tag an in-progress call with an Account Code or a Classification Account Code
l

Click the down arrow adjacent to the Account Code button and select a traditional Account
Code or a Classification Account Code.

After hanging up, while in Work Timer mode, you can tag calls with Classification Account Codes.
To tag a call, after hanging up, with a Classification Account Code
1. Click the down arrow adjacent to the Account Code button.
2. Select After Call Classification and select the appropriate Classification Account Code
from the drop-down list.

CONTROLLING YOUR AVAILABILITY
You can log yourself on or off, cancel Work Timer, cancel Reseize Timer, and place yourself in or
remove yourself from Make Busy with reason or Do Not Disturb with reason using the soft phone.
To log on to the ACD
l

Click Actions=>Log on and select an agent ID.

To log off of the ACD
l

Click Actions=>Log off.

To set Make Busy with reason
l

Click Actions=>Set Make Busy and select a Make Busy Reason Code.

To remove Make Busy with reason
l

Click Actions=>Remove Make Busy.

To set Do Not Disturb with reason
l
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To remove Do Not Disturb
l

Click Actions=>Remove Do Not Disturb.

To cancel Work Timer
l

Click Actions=>Cancel Work Timer.

To cancel Reseize Timer
l

Click Actions=>Cancel Reseize Timer.

MAKING AND HANDLING CALLS USING CONTACT CENTER
CLIENT
You can open an agent, employee or extension monitor, or the Queue Now monitor and either rightclick an agent and select telephony functions or access telephony functions by selecting an agent
and accessing the options in the Contact Center Client ribbon. For example, when you are on a call
you can consult with an idle employee by right-clicking the employee’s cell and clicking
Transfer/Conference, or by sending the employee an instant message. (See Figure 104.)

Figure 104: Consulting with a person while on call

Making calls
To call an agent using Contact Center Client
l

Right-click the cell of an idle agent and click Call.

Alternatively:
1. Select an idle agent in an open monitor.
2. Click the Softphone button under the Agent Control tab in the Contact Center Client Real
Time ribbon.
3. Choose the Call menu item.
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Forwarding calls
If a call is ringing on your extension, to forward the call using Contact Center Client
l

Right-click the cell of an idle agent and click Forward.

Answering calls
If a call is ringing on another agent’s extension, to pick up the call using Contact Center Client
l

Right-click the cell of the agent and click Pick up.

Adding call notes
When agents are speaking with customers, they can add notes to calls to share with other contact
center employees involved in the call. This ensures agents and supervisors have context on calls
and know what information has been provided to customers upon call transfer. If the call is
transferred, call notes are preserved. Call notes are not preserved when calls are parked. See
"Adding call notes to a call" on page 440.
NOTE: Before adding call notes, ensure the 'Display call notes' option is enabled in the Softphone
configuration window. This option is disabled by default.
To add a call note
1. As a call is ringing on your extension, on the soft phone display click Answer to answer the
call.
Contact Center Client appears on top of all open applications and displays the Call Notes
monitor.
2. After Enter a new call note, type a note.
Call notes can include a maximum of 100 characters.
3. Click Add.
The call note is added to the Call notes text box and is included in the soft phone display upon
call transfer.

Recording calls
There are occasions when a user wants to temporarily stop recording a call for confidentiality
reasons, or, if the call is not currently being recorded, the user may want to start recording if the
conversation becomes hostile or sensitive in nature and a call record may be required. On the Agent
State by Time, Agent State by Position, Agent State by Queue by Time, and Extension Now
monitors, the Call recording option enables you to start, stop, and restart call recording at any time
during a call, using OAISYS call recording functionality. Requirements for this on-demand call
recording feature are Contact Center Management, Contact Center PhoneSet Manager or Contact
Center Softphone, and the OAISYS call recording connector.
To record a call
l

Right-click the associated cell of an agent or extension and select Call Recording=>Start
Recording.

To stop recording a call
l
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To stop recording, right-click the cell and select Call Recording=>Stop Recording.
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Alternatively:
1. Select the cell of an agent or extension in a monitor whose call you want to record.
2. In the Contact Center Client Real Time ribbon, under the Agent Control tab, select Start
Recording from the drop-down list in the Call Recording column.
3. To stop recording, select Stop Recording from the drop-down list in the Call Recording
column.
See Figure 105.

Figure 105: Call recording

Silent monitoring calls
Silent monitoring is the process of listening to the voice conversations of internal or external calls
between agents or extensions and callers. Silent monitoring enables you to track call handling
techniques and determine where improvements can be made in individual performance. If required,
supervisors can conference into the call they are silently monitoring to talk to the customer. For more
information, see "Conferencing calls" on page 441 for Contact Center Softphone and see
"Conferencing calls" on page 448 for Contact Center PhoneSet Manager.
Silent monitoring is an MCD feature leveraged by Contact Center Solutions. With MCD 7.0+,
supervisors can select an agent or extension for silent monitoring at any time, but the monitoring
does not begin until the agent or extension answers or makes a call. The monitoring is maintained so
long as the agent or extension remains on call. The supervisor hears everything the agent hears
during the course of the call, including conferences and voicemail. If the agent moves to a call on
another line, silent monitoring will follow the agent over to that line. Up to six supervisors can silently
monitor an agent or extension. MCD 7.0+ also enables supervisors to coach agents on call. For
more information, see "Coaching agents and extensions on a call with customers" on page 454.
Silent Monitor can be accessed through Contact Center Client or, if programmed on your 3300 media
server, through entering a Feature Access Code (FAC) on your phone. For more information about
silent monitor and its features and enhancements, consult your Mitel MiVoice Business
documentation.
Silent monitoring is supported for the 3300 ICP telephone system and requires Contact Center
Management, Contact Center PhoneSet Manager or Contact Center Softphone, and Interactive
Contact Center.
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NOTE:
l

l

l
l

The monitoring extension and the extension being monitored must coexist on the same
telephone system.
The monitoring extension must be permitted by security role to interactively control other
agents.
The monitoring extension’s soft phone tool bar must be open.
For instructions on activating Silent Monitor outside of Contact Center Solutions, as well as
how to use silent monitor with agent groups, hunt groups, and ACDX groups outside of
Contact Center Solutions, consult your Mitel MiVoice Business documentation.

The following procedures explain how to
l

Silently monitor a call using Contact Center Client

l

Silently monitor a call using Contact Center Client and a Feature Access Code

The following procedures take place in an open real-time agent or extension monitor
To silently monitor a call using Contact Center Client
l

Right-click the cell of an agent or extension and select Silent Monitor.

Alternatively:
1. Select the cell of an agent or extension in a monitor whose call you want to silent monitor.
2. In the Contact Center Client Real Time ribbon, under the Agent Control or Extension
Control tab, click the Softphone button and click Silent Monitor.
NOTE: If the telephone system settings are incorrect or the monitoring extension and the
extension being monitored are on separate telephone systems, you will be unable to Silent
monitor and will instead see 'Not Allowed' when you right-click the cell. See the Contact
Center Management Installation Guide for more information. If the extension you want to
monitor is not currently on a call, you will see 'Waiting' when you right-click the cell.
To silently monitor a call using Contact Center Client and a Feature Access Code
1. In the dial box, type the Feature Access Code followed by the agent or extension number.
2. Click Dial.

Coaching agents and extensions on a call with customers
Supervisors can communicate with agents or extensions they are silently monitoring while they are
on a call with a customer through Whisper Coach. Whisper Coach is a feature of silent monitor,
enabling supervisors monitoring agents to talk to the agent and coach them through their call, without
letting the customer hear what the supervisor is saying. Supervisors can also coach agents who are
not actively handling a call. If required, supervisors can conference into an active call while coaching
to talk to the customer. For more information, see "Conferencing calls" on page 441 for Contact
Center Softphone and see "Conferencing calls" on page 448 for Contact Center PhoneSet Manager.
NOTE: Whisper Coach requires MCD 7.0+ on a MiVoice Business for ISS platform, a
Multi Instance Platform, or VMWare for Virtual Appliance. Whisper Coach is not supported on Mxe
platforms
Once a supervisor starts silent monitoring an agent, they have the option of toggling coaching on and
off through their IP hardset or the Contact Center Softphone toolbar. Whisper Coach is not

454

Using Contact Center PhoneSet Manager and Contact Center Softphone

automatically disabled when the agent completes the call or switches to a different call. If the
supervisor does not stop coaching, the Whisper Coach feature automatically activates the next time
the agent makes or answers a call. Only one supervisor can whisper coach an agent at a time. A
supervisor can also whisper coach another supervisor, including supervisors actively whisper
coaching an agent. If a supervisor whisper coaches another supervisor who is coaching an agent,
the supervisor will hear the coached supervisor and the agent, but only the coached supervisor will
hear you.
If you want the Coach On display in the Contact Center Softphone toolbar to appear in another
language, you must configure the device on the telephone system to the display language. The
translation is driven by the telephone system rather than Contact Center Solutions.
For more information on Whisper Coach, consult your Mitel documentation.
NOTE:
l

Whisper Coach requires specific Class of Service options enabled for agents and supervisors
l

l

l

l

Agent COS
l

ACD Silent Monitor Accept

l

ACD Silent Monitor Accept Monitoring Non-Prime Line

l

ACD Silent Monitor Notification

l

HCI/CTI/TAPI Call Control Allowed

l

HCI/CTI/TAPI Call Monitor Allowed

Supervisor COS
l

ACD Silent Monitor Allowed

l

HCI/CTI/TAPI Call Control Allowed

l

HCI/CTI/TAPI Call Monitor Allowed

Whisper Coach is supported with External Hot Desking Agents, Hot Desking Agents, and
External Hot Desking Users
Only certain IP phones are supported with Whisper Coach. Consult your Mitel documentation
for supported IP phones.

The following procedures explain how to
l

l

l
l

Whisper to an agent or extension that you are silent monitoring with Contact Center PhoneSet
Manager
Stop whispering to an agent or extension that you are silent monitoring with Contact Center
PhoneSet Manager
Whisper to an agent or extension that you are silent monitoring with Contact Center Softphone
Stop whispering to an agent or extension that you are silent monitoring with Contact Center
Softphone

To whisper to an agent or extension that you are silent monitoring with Contact Center PhoneSet
Manager
l

On your hardset, press Coach On.

To stop whispering to an agent or extension that you are silent monitoring with Contact Center
PhoneSet Manager
l

On your hardset, press Coach Off.
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To whisper to an agent or extension that you are silent monitoring with Contact Center Softphone
l

In the Softphone toolbar, click Coach On.
See Figure 106.

Figure 106: Softphone coach on
To stop whispering to an agent or extension that you are silent monitoring with Contact Center
Softphone
l

In the Softphone toolbar, click Coach Off.

Transferring calls
To perform a blind transfer using Contact Center Client
l

While on a call, right-click the cell of an idle agent and click Transfer call.

Alternatively:
1. Select the cell of an idle agent in a monitor.
2. In the Contact Center Client Real Time ribbon, under the Agent Control tab, click the
Softphone button and click Transfer call.

Consulting with employees while on calls
To consult with an employee while on a call using Contact Center Client
1. Right-click the cell of an idle agent and click Transfer/Conference.
The system places the initial party on hold.
2. In the dial box, type an extension or phone number. Otherwise, click the down arrow adjacent
to the Transfer/Conference button and select a contact.
3. Click Dial.
4. After you consult with the employee, either click Conference to conference in that person,
click Transfer to transfer the call to the employee, click Swap to talk to the other party, or
click Cancel to end the consultation call.

Requesting help while on calls
To request help while on a call using Contact Center Client
l
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Right-click the cell of an idle agent and click Request help.
The system calls the employee. The employee can click Answer in the soft phone and listen
in on the call without the caller knowing. The employee can click Conference in the soft phone
to join the conversation at any time.
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CONTACT CENTER SCREEN POP
Contact Center Screen Pop is an optional application that requires Contact Center Management,
and Contact Center Softphone or Contact Center PhoneSet Manager. Optionally, if you want to
screen pop based on caller entered digits, you require IVR Routing with the Collect Digits activity.
Contact Center Screen Pop launches applications or webpages. In addition, it enables agents to
automatically receive caller and account information via pop-ups on their computer monitors every
time they receive calls. Contact Center Screen Pop provides agents with the caller name, caller
phone number (ANI), called number (DNIS), and the queue used in the call.
NOTE: Users must configure IVR ports and queues on the same telephone system for Contact
Center Screen Pop to function.

USING CONTACT CENTER SCREEN POP
When an agent receives a call, Contact Center Screen Pop can launch an application or webpage.
For example, when integrated with a Customer Relationship Management (CRM) database, Contact
Center Screen Pop can launch a customer account page from the CRM database based on call
information.
For contact centers that have Contact Center Screen Pop, the pop-up provides
l

Caller name—name of the caller

l

ANI—telephone number of the caller

l

DNIS—telephone number the caller dials

l

DNIS name—the name associated to the DNIS number in YourSite database

l

Agent ID— agent who transferred the call

l

Extension—extension from which the call was transferred

l

Queue—queue from which the call originated

l

l

l

Collect Caller Entered Digits—digits the caller enters for identification purposes, such as a
customer site key (IVR Routing required)
Customer Collected Information—information collected from a third party OBDC database.
Customer Collected Information requires IVR Routing and the Collect Digits activity, and,
optionally, Remote Database Verification or CTI Developer Toolkit.
Call notes—notes added by an agent

CONFIGURING OPTIONS IN YOURSITE EXPLORER
You configure Contact Center Screen Pop options in YourSite Explorer. You can specify which
information fields the pop-up displays and whether an application or Web page is launched when an
agent receives a call. See "Configuring Contact Center Screen Pop options" on page 459.
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Enabling Contact Center Screen Pop
To enable Contact Center Screen Pop
1. Start Contact Center Client.
See "Starting Contact Center Client" on page 204.
2. Right-click the Phone toolbar and click Configure.
3. Click the Screen pop tab.
4. Select the Display Contact Center Screen Pop check box.
5. Click OK.

Configuring Contact Center Screen Pop options
If you are licensed for ANI, DNIS, and/or Collect Caller Entered Digits and want to display these in
the pop-up you must configure the options for Contact Center Screen Pop.
To configure Contact Center Screen Pop options
1. Click YourSite=>Enterprise.
2. Click the Screen Pop tab.
3. To launch an application or webpage when calls are answered, select the Launch an
application or Web page when agents answer ACD calls check box. This option displays
the caller-specific Inbound trace report webpage, which lists the number of times the caller
has called in the last seven days and provides additional call details. (See Figure 107.) To
specify a different path or URL, see step 5, below. To specify an integrated custom screen
pop, see step 6, below.
NOTE: The ‘Contact Center Screen Pop will launch this application or Web page’ field is
automatically populated with the URL of the Inbound Trace report.
4. To launch a specific Web page or an application when calls are answered, ensure Display a
specific application or Web page is selected and, under Contact Center Screen Pop will
launch this application or Web page, type the path for the executable file or the URL of the
webpage and indicate any variables that the screen pop will contain.
NOTE: For important information on how to configure this field, click the ? button. For
information on variables used by Contact Center Screen Pop, see "Configuring Contact
Center Screen Pop display variables" on page 460.
5. If Mitel Professional Services has provided you with an integrated custom screen pop, select
Display this Professional Services custom executable file or Web page. Click Manage
to review the Professional Services custom screen pop options.
6. To enable screen pop on non-ACD calls select the Screen pop on non-ACD calls check
box.
7. Click Save.
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Figure 107: Inbound Customer Trace Report

Configuring Contact Center Screen Pop display variables
The variables described in Table 38 are used by Contact Center Screen Pop to determine the
application area or Web page that launches when an agent answers an ACD call. Ensure the
required IVR Routing activities are available in workflows to use these variables.
NOTE: The variable names are case-sensitive. For an application, variables must be in quotes and
separated by a space.
Table 38: Contact Center Screen Pop display variables
VARIABLE

IVR ROUTING
ACTIVITY REQUIRED

DESCRIPTION

%PFCALLERNAME%

ANI activity

Caller name as provided
by the telephone carrier.
For example, 'John Smith'

ANI activity

Caller number (ANI), the
telephone number of the
calling party. For example,
'6135990045'

DNIS activity

Dialed Number
Identification Service
(DNIS), numbers passed
from the public telephone
network to identify what
phone number the caller
dialed. This is typically
used to identify different 1800 or 1-900 numbers. For
example, '9875'

Collect Digits activity

The digits entered by the
user during the call. For
example, account number
'78831'

%PFANI%

%PFDNIS%

%PFVERIFIEDCOLLECTEDDIGITS%
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Table 38: Contact Center Screen Pop display variables (continued)
VARIABLE

IVR ROUTING
ACTIVITY REQUIRED

DESCRIPTION

ANI and DNIS activities

Name of the queue from
which the call is
answered. For example,
'Sales'

%ReceivingAgent%

N/A

Contains the Agent ID for
the agent receiving the
current call

%ReceivingExtension%

N/A

Contains the Extension ID
for the extension receiving
the current call

N/A

Contains the Agent ID for
the agent sending or
transferring the call to the
current recipient

N/A

Contains the Extension ID
for the extension sending
or transferring the call to
the current recipient

%Queue%

%SendingAgent%

%SendingExtension%

To launch an application
l

Type the URL of the executable file followed by the required variables.
For example, C:\MyProgram\CustomerManagement.exe "%PFCALLERNAME%"
"%PFANI%""%PFDNIS%""%PFVERIFIEDCOLLECTEDDIGITS%""%Queue%"
NOTE: Variables must be in quotes and be separated by a space.

If John Smith calls 1-800-266-9875 from 613-599-0045, is prompted to enter his account number
(78831), and is then routed to the Sales queue, the executable file will use the actual values of the
call, for example, C:\MyProgram\CustomerManagement.exe "John
Smith""6135990045""9875""78831""Sales".
To launch a Web page
l

Type the URL of the Web page followed by the required variables, as per standard HTTP
protocol.
For example,
http://myintranetsite.business.com?CALLERNAME=%PFCALLERNAME%&ANI=%
PFANI%&DNIS=%PFDNIS%&COLLECTEDDIGITS=%PFVERIFIEDCOLLECTEDDIGIT
S%=%
PFVERIFIEDCOLLECTEDDIGITS%&QUEUE=%Queue%

If John Smith calls 1-800-266-9875 from 613-599-0045, is prompted to enter his account number
(78831), and is then routed to the Sales queue, the Web page will use the actual values of the call,
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for example,
http://myintranetsite.business.com?CALLERNAME=John%20Smith&ANI=6135990045&DNIS=98
75&COLLECTEDDIGITS=78831&QUEUE=Sales.

Enabling MiTAI event logging
The prairieFyre Enterprise service receives MiTAI events from the Collector Service and stores
these events in a log file located in the DataDirectory\ CallControlEventLog sub-folder under the
main installation directory. The Enterprise service logs all events across all nodes in one file and
time stamps events based on arrival time, providing insight when troubleshooting MiTAI linking
issues. Additionally, ANI, DNIS, collected digits, and other custom variables arriving from IVR
Routing are logged.
Incorrectly configured devices and monitors will result in missing MiTAI events and IVR Routing port
events, causing lost data and screen pop failures.
To enable MiTAI event logging
1. Browse to <drive>:\Program Files (x86)\prairieFyre Software
Inc\CCM\Services\EnterpriseServer.
2. Open prairieFyre.Services.EnterpriseServer.exe.config in Notepad.
3. Click Edit=>Find.
4. In the Find what field, enter LogCallTrackingMiTAIEvents and click Find Next.
NOTE: If the LogCallTrackingMiTAIEvents key does not exist, you must create one. Enter
<add key=" LogCallTrackingMiTAIEvents " value="true" />
5. Save the file.
6. Browse to the DataDirectory\CallControlEventLog folder.
7. Verify that MiTAIEvents*.txt is present in the folder.
8. Open MiTAIEvents*.txt and verify that the file contains MiTAI events. (See Figure 108.)

Figure 108: MiTAI events example
Additionally, you must ensure that
l

l
l
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All relevant devices including queues and extensions (or hot desking agents in a hot desking
resilient environment) have been synchronized or manually programmed successfully.
The Advanced Real time option is turned on.
The prairieFyre Collector Service log monitors were correctly set and there are no MiTAI errors
(MiTAI errors will be shown as SXERR_*).
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l

l

IVR Routing ports are configured and monitored correctly.
IVR Routing monitoring problems are demonstrated by call flow failure.
IVR Routing ports are not programmed as 5020 IP ports.
The IVR Routing messaging service automatically writes IVR Routing ports into the Contact
Center Solutions database. If the IVR Routing ports have been manually programmed and
enabled for real-time and advanced real-time monitoring, screen pop will not display correct
results.

Ignoring MiTAI events on UPiQ and callback capture ports
MiTAI events arriving on UPiQ ports and callback capture ports should be ignored to reduce MiTAI
linking overhead.
To ignore MiTAI events on UPiQ and callback capture ports
1. Browse to <drive>:\Program Files\prairieFyre Software
Inc\CCM\Services\EnterpriseServer.
2. Open prairieFyre.Services.EnterpriseServer.exe.config in Notepad.
3. Click Edit=>Find.
4. In the Find what field, enter MitaiLinkerPortIgnoreList and click Find Next.
NOTE: If the MitaiLinkerPortIgnoreList key does not exist, you must create one. Enter <add
key="MitaiLinkerPortIgnoreList" value="2230 , 2250-2260, 2270" />
5. Save the file.

Configuring DNIS linkage
We recommend you configure the DNIS in YourSite Explorer. In many situations, for example, in a
Network ACD environment, MiTAI events that arrive on the path and on the end device may not
contain the originally dialed digits. Capturing dialed digits at the IVR Routing port allows the system
to preserve them for use in the screen pop DNIS field.

Configuring time spent in IVR
We recommend you configure the MiTAI linker to dispose of old (stale) calls immediately. In a high
load environment where the system processes thousands of calls per hour, MiTAI call IDs can
recycle in minutes. To dispose of stale calls, we recommend you configure the time a call spends in
IVR Routing before it gets transferred to a path or end device. For example, if callers typically spend
two minutes or less in the IVR workflow before they are transferred, the MiTAI linker should be
configured to dispose of stale calls within three minutes.
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To dispose of stale calls
1. Browse to <drive>:\Program Files (x86)\prairieFyre Software
Inc\CCM\Services\EnterpriseServer.
2. Open prairieFyre.Services.EnterpriseServer.exe.config in Notepad.
3. Click Edit=>Find.
4. In the Find what field, enter MitaiLinkerMaxTimeInSecsInIVRBeforeRouting and click
Find Next.
NOTE: If the MitaiLinkerMaxTimeInSecsInIVRBeforeRouting key does not exist, you must
create one. Enter <add key=" MitaiLinkerMaxTimeInSecsInIVRBeforeRouting " value="180"
/> and replace 180 with the time threshold (in seconds) to dispose of stale calls.
5. Save the file.

Deleting completed calls from memory
Configuring the MiTAI linker to delete completed calls from memory allows the system to recycle
calls faster. If no special components tap into the call after it finishes, there is no need for the system
to track calls for longer than 15 seconds after they have completed.
To delete completed calls from memory
1. Browse to <drive>:\Program Files (x86)\prairieFyre Software
Inc\CCM\Services\EnterpriseServer.
2. Open prairieFyre.Services.EnterpriseServer.exe.config in Notepad.
3. Click Edit=>Find.
4. In the Find what field, enter MitaiLinkerMaxTimeInSecsToRecycleAfterCallCleared and click
Find Next.
NOTE: If the MitaiLinkerMaxTimeInSecsToRecycleAfterCallCleared key does not exist, you
must create one. Enter <add key=" MitaiLinkerMaxTimeInSecsToRecycleAfterCallCleared"
value="15" />.
5. Save the file.

Preventing blank or duplicate pop-ups
In a scenario where screen pop is configured to display on more than one field, for example, in a
clustered network environment, the client may invoke screen pop with incomplete or blank pop-ups.
In this case, the client receives the data in more than one batch due to
l

l

The speed that the telephone switch delivers events.
Agent controllers are typically faster than queuing gateways.
The order that the events arrive.
The MiTAI linker may not have received and linked all required events at the time when a call
rings at an end device.

You must configure a list of required fields in the ContactCenterClient.exe.config file to prevent
blank or duplicate pop-ups.
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To prevent blank or duplicate pop-ups
1. On the client computer, browse to Client Installation directory
Applications\ContactCenterClient.
2. Open ContactCenterClient.exe.config in Notepad.
3. Click Edit=>Find.
4. In the Find what field, enter WebPopRequires and click Find Next.
NOTE: If the WebPopRequires key does not exist, you must create one. Enter <add
key="WebPopRequires" value="PFDNIS, PFVERIFIEDCOLLECTEDDIGITS"/>
5. Save the file.

Testing Contact Center Screen Pop search functions
This test will confirm that Contact Center Screen Pop will function with the software you selected.
To test the search function in Contact Center Screen Pop
1. Start Contact Center Client.
2. Right-click the Phone toolbar and click Configure.
3. Click the Screen pop tab.
4. Click Test.
5. Type the variables using the described format.
PFCALLERNAME—first name followed by last name, separated by a space (for example,
John Smith)
PFANI—phone number (including area code if relevant) with no spaces, dashes, or brackets
(for example, 6135558769)
PFDNIS—phone number (including area code if relevant) with no spaces, dashes, or brackets
(for example, 8005556598)
PFVERIFIEDCOLLECTEDDIGITS—all digits the caller has entered since entering the
telephone system, with no spaces, dashes or brackets (for example, 1113)
Queue—queue that the caller first entered (for example, P500)
6. Click OK.
A screen pop that contains the test parameters you specified will display. The outcome of the
Contact Center Screen Pop test will change depending on the type of screen pop you have
configured and the test parameters you entered.

Disabling Contact Center Screen Pop
If you prefer some client computers do not use Contact Center Screen Pop, you can disable it on one
or more computers. This procedure affects one agent profile only.
To disable Contact Center Screen Pop on a client computer
1. Start Contact Center Client.
2. Right-click the Phone toolbar and click Configure.
3. Click the Screen pop tab.
4. Clear the Display Contact Center Screen Pop check box.
5. Click OK.

465

Chapter 16
MiCOLLAB CLIENT AND IGNITE
INTEGRATION

Basic MiCollab Client and Ignite
integration
MiCollab Client and Ignite integration user
interface
Before handling voice contact with
MiCollab Client and Ignite integration
Handling voice contacts with the MiCollab
Client and Ignite integration
MiCollab Client
Ignite

Contact Center Solutions User Guide

MiCOLLAB AND IGNITE INTEGRATION
Ignite is a flexible, intuitive, and efficient tool for handling email and chat contacts and for performing
basic ACD call handling. Ignite enables agents to handle multiple contacts simultaneously, see the
agent groups of which they are members, receive screen pop notifications of incoming contacts, set
Account Codes and Classification Codes, view personal performance statistics and those of the
queues and queue groups for which they answer, affect personal state indicators, and be advised of
the presence of other agents in their agent group(s).
In this integration, Ignite can be used for basic call handling (answer, hold, hang up, blind transfer).
See "Handling calls in Ignite" on page 484. More sophisticated scenarios, such as supervised
transfers and conferencing, require MiCollab Client. For instructions related to the voice handling
abilities of the MiCollab Client application, refer to the Unified Communicator Advanced
documentation available on Mitel Online or via the Webhelp within the MiCollab Client.
The MiCollab Client and Ignite integration offers Enterprise presence (non-ACD), extended ACD
presence, and Enterprise Instant Messaging (IM) presence indicators, informing co-workers of your
real-time availability.
Contact Center Client is used as a supervisory tool in this integration, enabling real-time monitoring
and alarming, forecasting, data mining, agent and ACD queue control, abandoned caller callbacks,
and efficient call handling by moving items from busy to less active queues.
This chapter describes voice handling using Ignite and MiCollab Client. For information regarding
handling email and chat contacts using Ignite, see the Multimedia Contact Center Installation and
Deployment Guide.

BASIC MiCOLLAB CLIENT AND IGNITE INTEGRATION
There are some features described in this chapter that do not apply for customers running the Basic
MiCollab Client application. Refer to the following list of exceptions:
l
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Agents must use their deskphone for hot desking and cannot hot desk log in from
MiCollab Client.

l

Instant messaging is not supported.

l

Extended ACD presence is not supported.

MiCollab Client and Ignite user interface

MiCOLLAB CLIENT AND IGNITE USER INTERFACE
Ignite, when started, automatically docks to the MiCollab Client application, creating one client
interface for voice and multimedia. See Figure 109.

Figure 109: MiCollab Client and Ignite integration
The MiCollab and Ignite integration offers you the flexibility to access as much or as little of the
interface as needed in order to optimize desktop real estate.
For example, you can choose to collapse the main Ignite window and only access the Ignite Sidebar
and MiCollab Client (recommended for voice-only agents) or expand the Ignite panes if you will also
handle non-voice media. If you are transferring a call, it is beneficial to expand the Ignite Preview
pane to check recipient agent instant messaging availability before transferring. This enables you to
send an instant message advising them of the incoming transfer. (See Figure 110).
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Figure 110: Accessing agent availability in the Ignite Preview pane when transferring a call

BEFORE HANDLING VOICE CONTACTS WITH THE
MiCOLLAB CLIENT AND IGNITE INTEGRATION
Please read the following notes and recommendations before installing and running the MiCollab
Client and Ignite integration.
To enable MiCollab Client and Ignite integration functionality:
l

l

l

l
l

l
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When setting up the 'Feature Profile Details' in MiCollab Client Service, you must select the
'Desktop Client SDK' and 'Presence' check boxes.
Choose ‘Custom Install’ and then select ‘MiCollab Client SDK’ in the Custom Setup window
during the MiCollab Client installation process. You must be licensed for the MiCollab Client
Desktop/Softphone. Basic MiCollab Client does not support full MiCollab Client and Ignite
functionality and does not require the installation of the MiCollab Client SDK. See "Basic
MiCollab Client and Ignite integration" on page 467.
Agents' first and last names must match between YourSite Explorer and MiCollab Client. If
there are two agents with identical first and last names, ensure they have unique email
addresses in both YourSite Explorer and MiCollab Client.
MiCollab Client must be Version 6.0 SP3 or greater to support this integration.
When running this integration in a Windows 8 environment, ensure the UCA process always
runs as an administrator by selecting the ‘Run this program as an administrator’ option in the
MiCollab Client properties settings.
When running this integration, the MiCollab Client toaster notification ('Show Call Popup
Window' setting) should be manually disabled, to prevent duplicate toasters from displaying
on the desktop. If, at any point, Ignite is shut down and MiCollab Client is running as a
standalone application, its toaster notification must be manually re-enabled. Refer to MiCollab
Client documentation for Call Notification configuration instructions.

Handling voice contacts with the MiCollab Client and Ignite integration

l

Ignite includes a toaster with basic call information but a more advanced screen pop can be
configured using the workflow variable ‘ScreenPopOnRinging’ (available when licensed for
IVR Routing or Multimedia Contact Center). See "Populating screen pops with workflow
variables" on page 626.

HANDLING VOICE CONTACTS WITH THE MiCOLLAB
CLIENT AND IGNITE INTEGRATION
The following table lists agent actions and the application in which they are performed.
Table 39: Agent actions by application
AGENT ACTION

MiCOLLAB CLIENT

IGNITE

Log on and Log off

x

x

Set or remove Make
Busy with Reason
Code

x

Set or remove Do Not
Disturb with Reason
Code

x

Cancel Work Timer

x

Chat (IM)

MiCOLLAB CLIENT
OR IGNITE

x

Join/Leave Agent
Group

x

Answer

x

Hang Up

x

Conference

x

Cancel

x

Account Code

x

Classification Code

x

Call me back

x

Call forwarding

x

Camp on

x

Forward

x

Leave a message

x
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Table 39: Agent actions by application (continued)
AGENT ACTION

MiCOLLAB CLIENT

Mute

x

Retrieve

x

Split

x

Transfer (blind)

IGNITE

MiCOLLAB CLIENT
OR IGNITE

x

Transfer (supervised)

x

Transfer/Conf

x

Volume

x

Dial Pad

x

Dial Contacts

x
x

ACD Hot desk login
(with MCD 6.0 SP3+)
The following features continue to be available in Contact Center Client (Contact Center Softphone
or Contact Center PhoneSet Manager) but are not currently supported in the MiCollab Client and
Ignite integration:
l

Pre-announce

l

Custom ring tones

l

Request help

l

Speed Dial

l

Call notes

l

External hot desking agents

If these features are necessary to your business, you can continue to use Contact Center Softphone
or Contact Center PhoneSet Manager but these applications do not support an integration with
Ignite.
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Handling voice contacts with the MiCollab Client and Ignite integration

AGENT PRESENCE INDICATORS
MiCollab Client displays Enterprise presence (non-ACD), extended ACD presence, and Enterprise
Instant Messaging (IM) presence indicators.
Extended ACD presence displays in MiCollab Client for all agents who are members of the same
agent group(s) as the logged in employee. These states are:
l

Logged out

l

Not available for ACD (not present in any agent groups)

l

Available for ACD (logged in and idle)

l

Busy <reason> (logged in and busy)
l

Busy – Outbound (making an outbound call)

l

Busy – ACD (receiving an ACD call)

l

Busy <Make Busy reason code name> (in MKB, including system MKB)

l

Busy – Non-ACD (receiving a non-ACD call, such as a consultation call (pre-transfer)
or a direct call to their agent DN)

l

Do Not Disturb - <DND reason code name> (logged in and in DND)

l

Unknown – this indicator may display following an Enterprise service restart

Enterprise IM presence indicators are available in MiCollab Client and in Ignite (in the Preview pane
when transferring a call). Knowing agent IM availability is beneficial when transferring calls as it
enables the transferring agent to notify the receiving agent before completing the transfer. IM
presence indicators include:
l

Online – green

l

Offline – red

l

Away - orange

Ignite displays the agent’s overriding state (indicated by a bar of color at the top of the Ignite Sidebar)
and the time spent in that state, directly below the colored bar indicator. If the time spent in a state
exceeds 24 hours, it displays by days:hours. See "Getting started with Ignite" on page 473 for an
example of the Ignite Sidebar interface.
Overriding state information also displays in the Status bar. See "Viewing agent state and statistics
in the Status bar" on page 483.
Overriding states and their associated colors are:
l

Idle – Green

l

Make Busy – Yellow

l

DND – Yellow

l

Work Timer – Yellow

l

Not present in any agent group – Yellow

l

ACD – Red

l

ACD Hold – Red

l

Ringing – Red

l

Non-ACD/Outbound - Blue
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MiCOLLAB CLIENT
Voice handling instructions for MiCollab Client are described in the Unified Communicator Advanced
documentation available on Mitel Online or via the Webhelp within the MiCollab Client.

LOGGING INTO MiCOLLAB CLIENT
MiCollab Client, if installed, will automatically launch, by default, when Ignite is started. You can
alter this configuration in Ignite if desired. See "Configuring profiles" on page 482.
If you start Ignite before logging into MiCollab Client, you will be prompted to register and log in your
voice agents in MiCollab Client before signing into Ignite. We recommend you start and log into
MiCollab Client before starting and logging into Ignite.
To log into MiCollab Client as a hot desking agent
1. Right click on the Agent in the Active Calls window.
2. Select Hot-Desk In.
A new dialog window opens.
3. In the Base DN text box, enter your base extension.
4. If your business uses PINs, enter your PIN.
5. Click Hot-Desk In. Your hot desk agent is now logged in and your base extension is out of
service.
NOTE: By default, Ignite is configured to detect voice agent logout. If you are running Ignite
and you exit MiCollab Client the employee is signed out of Ignite. The following text displays:
‘One of your agents was logged out outside of Ignite. Your remaining agents are now being
logged out’. If you click 'Continue', Ignite will close immediately.

IGNITE
Ignite is used by agents to handle all types of media, including voice, email, chats, and fax. In this
chapter we discuss Ignite as a voice handling system in conjunction with MiCollab Client and, as
such, suggest you refer to the Multimedia Contact Center Installation and Deployment Guide if you
want to access detailed Ignite instructions related to media other than voice.

GETTING STARTED WITH IGNITE
The following sections describe the Ignite interface from the perspective of a voice agent using
MiCollab Client for handling all voice calls. Ignite provides the MiCollab Client agent with the ability
to:
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l

View and adjust Agent Group Presence

l

Set and remove Make Busy and Do Not Disturb

l

Tag calls with Account Codes and Classification Codes

l

Remove Work Timer

l

Access agent handling statistics

Ignite

l

Configure personal Ignite profiles

l

Perform call handling actions (as an alternative to using MiCollab Client for the same actions)

l

Access caller information via screen pop

l

View agent status

See "MiCollab Client and Ignite user interface" on page 468 for a view of the overall Ignite user
interface for voice agents and refer to Figure 111 for a detailed view of the Ignite Sidebar, where the
majority of voice agent actions take place.

Figure 111: Ignite sidebar

OPENING AND CLOSING IGNITE
To open Ignite
l

Ignite can be opened from Windows’ Start menu, Programs menu, Taskbar, or from a Desktop
shortcut.
NOTE: If Contact Center Solutions applications are configured to use Windows
Authentication, opening Ignite also logs agents into the program.
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To close Ignite
l

In the Sidebar, click the Sign Out or Exit button and select Exit Application.
NOTE: You can also close Ignite from the Sign In screen by clicking the Exit Application
button.

LOGGING INTO AND OUT OF IGNITE
We recommend that agents using Ignite in conjunction with MiCollab Client log into their voice agent
in MiCollab Client before logging into Ignite. If you choose to log into Ignite prior to logging into
MiCollab Client, you will be prompted during the Ignite login process to register your voice agent in
MiCollab Client.
Agents may find that, after logging into their phone and into Ignite, they are placed in Make Busy
across all agent capabilities. This is an administrative configuration on the PBX that is
recommended for Version 7.1. After logging into Ignite the agent can remove Make Busy and
become available to receive ACD calls.
To log into Ignite
1. Start Ignite.
2. Enter your Username and password.
NOTE: If your system uses Windows Authentication, you will be logged in automatically.
3. To have the system remember your login credentials, click Remember Me.
4. Click Sign In.
To log out of Ignite and restart the program to the login screen
l

In the Sidebar, click the Sign Out or Exit button and select Sign Out.
The agent is logged out of Ignite, and Ignite restarts to the login screen.

To log out Ignite and close the application
l

In the Sidebar, click the Sign Out or Exit button and select Exit Application.
NOTE: You can also close Ignite from the Sign In screen by clicking the Exit Application
button.
The agent is logged out of Ignite, and the application closes.

PERFORMING AGENT ACTIONS IN THE SIDEBAR AND THE
ACTION BAR
Ignite’s Sidebar displays the following:
l

Agent Group Presence - viewing and adjusting Agent Group Presence

l

Make Busy - adding and removing Make Busy

l

Do Not Disturb - adding and removing Do Not Disturb

l

Account Code - setting Account Code(s) (displays during active call)

l
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Classification Code - setting Classification Code(s) (displays after call ends, until Work
Timer is removed)

Ignite

l

Remove Work Timer - removing Work Timer (displays only when Work Timer is active)

l

Agent handling statistics - viewing statistics by selected media type

l

Settings - configuring Ignite profile options

l

Collapse Ignite or Expand Ignite - expanding or collapsing the main Ignite window

Viewing and adjusting Agent Group Presence
Agents can view the agent groups of which they are members. Viewing Agent Group Presence helps
agents verify that they are able to handle contacts for the appropriate queues.
Agents can view Agent Group Presence on a group-by-group basis across media types. If
administrative configurations permit, agents may also make themselves present to and absent from
agent groups and the media types that the group handles.
If agents are present to an agent group, a check mark displays beside the group. If agents are
present to handle media types in the group, these icons display a blue background.
If agents have the required permissions, they can make themselves present to, or absent from,
select agent groups or they can make themselves available or unavailable to all agent groups of
which they are members, in one motion.
When agents are not present to any of their agent groups, Ignite’s Status bar displays a ‘Time
Logged in Not Present’ status.
NOTE: Agents may be made automatically present to their agent groups upon logging into Ignite.
This is an administrative configuration and is not controlled by the agent. However, without this
administrative configuration, agents must make themselves present to agent groups in order to be
offered contacts.
To view Agent Group Presence
l

In the Sidebar, click the Agent Group Presence button.

To become present to an agent group
1. In the Sidebar, click the Agent Group Presence button.
2. Select the group or groups from the Agent Group Presence screen and click Apply.
To become absent from an agent group
1. In the Sidebar, click the Agent Group Presence button.
2. Deselect the group or groups from the Agent Group Presence screen and click Apply.
To become either present or absent from all agent groups
1. In the Sidebar, click the Agent Group Presence button.
2. To become present to all agent groups, click Select All.
3. Click Apply.
You become present to all agent groups and media types within the group.
4. To become absent from all agent groups, click Clear All.
5. Click Apply.
You become absent from all agent groups and media types within the group.
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To apply default Agent Group Presence settings
1. On the Agent Group Presence screen, click Defaults.
2. Click Apply.

Setting and removing Make Busy
When agents must become temporarily unavailable for inbound ACD contacts, they can put
themselves into Make Busy (MKB) and choose a code indicating why they are unavailable. MKB is
used, for example, when agents take breaks or go on lunch.
Setting MKB for one agent capability applies a MKB status across all of the employee’s media
capabilities. However, agents in MKB can receive transferred contacts and non-ACD voice
contacts.
Agents can enter MKB while handling contacts to ensure that, once they are finished, they are not
offered another contact. Existing voice contacts continue until one of the parties ends the
conversation.
Agents also enter Make Busy when they decline a contact, fail to answer a ringing contact within the
allotted time, and place an item on hold for longer than is permitted. In each instance, the contact is
requeued as the longest waiting (depending on ‘Requeue on Logout’ settings configured in YourSite
Explorer). The agent is automatically put into MKB across all media capabilities, and a System Make
Busy is registered for the employee.
To set MKB and change MKB codes
1. In the Sidebar, click the Make Busy button.
2. Select either a MKB code or No Make Busy Code, and click Apply.
NOTE: Agents cannot program MKB codes and can only select from the list provided.
3. To change a MKB code assigned to you, follow steps 1 and 2.
To remove MKB
NOTE: Agents must remove MKB to become available to receive inbound contacts.
1. In the Sidebar, click the Make Busy button.
2. Click Remove: <active MKB code>.
If you have the main Ignite window open, you can alternatively click the X button in the Status
bar.
To change to a DND state while in MKB
NOTE: DND and MKB states layer. If an agent in MKB changes their state to DND, the agent will
remain in MKB once DND is removed. This prevents agents from receiving contacts when switching
states between MKB and DND.
1. While in MKB, in the Sidebar, click the Do Not Disturb button.
2. Select either a DND code or No DND Reason Code, and click Apply.
NOTE: Agents cannot program DND codes and can only select from the list provided.
3. To remove DND and revert to MKB, in the Sidebar, click the Do Not Disturb button.
4. Click Remove: <active DND code>.
If you have the main Ignite window open, you can alternatively click the X button in the Status
bar.
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Setting and removing Do Not Disturb
When agents must become temporarily unavailable for inbound calls, they can put themselves into
Do Not Disturb (DND) and choose a code indicating why they are unavailable.
Setting DND for one agent capability applies a DND status across all of the employee’s media
capabilities. While in DND, agents cannot receive inbound contacts or internal transfers but can
receive external non-ACD voice contacts. They are also unable to pick and reply from queues while
in DND. Existing voice contacts continue until one of the parties ends the conversation.
To set DND and change DND codes
1. In the Sidebar, click the Do Not Disturb button.
2. Select either a DND code or No DND Reason Code, and click Apply.
NOTE: Agents cannot program DND codes and can only select from the list provided.
3. To change a DND code, follow steps 1 and 2.
To remove DND
NOTE: Agents must remove DND to become available to receive inbound or internal voice contacts.
1. In the Sidebar, click the Do Not Disturb button.
2. Click Remove: <active DND code>.
If you have the main Ignite window open, you can alternatively click the X button in the Status
bar.
To change to a MKB state while in DND
NOTE: If an agent changes their DND state to MKB, the agent remains in DND until this state is
removed.
1. While in DND, in the Sidebar, click the Make Busy button.
2. Select either a MKB code or No Make Busy Code, and click Apply.
3. In the Sidebar, click the Do Not Disturb button.
4. Click Remove: <active DND code>.
If you have the main Ignite window open, you can alternatively click the X button in the Status
bar to remove yourself from DND and enter MKB.

Tagging calls with Account Codes
Account Codes are used for reporting purposes. They are numbers identifying services,
departments, or other elements of the contact center. Agents can tag calls with Account Codes in
Ignite to indicate in reports what the conversation was about.
For example, an agent handling calls for three catalog companies enters an Account Code of ‘01’ to
indicate the customer is inquiring about Company A. Later in the conversation, the agent enters an
Account Code of ‘06’ to indicate that the customer is now inquiring about Company A’s mail-out
services.
Agents can tag calls with multiple Account Codes. Account Codes must be entered during the call
and cannot be entered after the call has ended.
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NOTE: Account Codes can also be tagged using the ‘History and Account Codes’ button found in
the Preview pane. Account Code group configuration is not supported in the ‘Set Account Code’
rolling panel but is supported in the Account Code list accessible via the History and Account Codes
button.
To tag a call with an Account Code
1. In the Sidebar, click the Account Code icon to open the Set Account Code rolling panel.
When a call is offered to an agent, indicated by the toaster displaying on the agent desktop,
the Account Code icon will display in the Ignite Sidebar. You must apply Account Codes
during the call. They cannot be applied after the call has completed.
2. Select the applicable Account Code from the list that displays and click Apply.
NOTE: If you are handling more than one item in the Inbox, for example, one email and one
call, and you apply an Account Code, it is applied to the item that is currently selected in the
Ignite Inbox.

Tagging calls with Classification Codes
Classification Codes are a type of Account Code, but differ in the following ways:
l

l

l

You can apply multiple Classification Codes to different, applicable sections of a call. All
Classification Codes applied to a call are pegged with the full call duration, from the time the
call arrives until the call ends. This includes transfer time, time calls were handled at other
extensions, and Work Timer durations if configured for the queue. If the same code is entered
twice, it is not double pegged in reporting statistics.
Classification Codes can be configured as ‘forced’, meaning the agent must enter a
Classification Code either during the call or when in Work Timer, after the call ends, to remain
within compliance.
Account Codes can only be entered during a call but Classification Codes can be entered
during or after a call (while in Work Timer). During a call, you enter Classification Codes via
the Account Code icon (the Classification Codes will display with other Account Codes in the
‘Set Account Code’ rolling panel list or in the ‘History and Account Code’ section of the
Preview pane). There are often scenarios within which an agent sets single or multiple
Account Codes during a call and then sets a Classification Code when the call terminates.

Work Timer must be enabled on the queue and Classification Codes must be configured in YourSite
Explorer for calls to be tagged with Classification Codes. If you require forced Classification Codes,
you must configure this as a setting in YourSite Explorer. See "Adding voice queues (ACD path)" on
page 142 and "Adding Account Codes" on page 163 for more information regarding Work Timer and
Classification Code configuration.
NOTE:
l
l
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Classification Code group configuration is not supported.
Classification Codes are supported when handling voice contacts only. Multimedia support
will be added in a future release.
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The following instructions describe tagging calls with Classification Codes after a call ends. You can
also apply Classification Codes during a call in the same way you apply Account Codes.
Classification Codes are included in the list of Account Codes in the ‘Set Account Code’ rolling
panel. See "Tagging calls with Account Codes" on page 478.
To tag a call with a Classification Code
1. In the Sidebar, click the Classification Code icon to open the Classify rolling panel.
When the call ends, the Classification Code displays (and flashes if forced Classification
Codes are enabled) and Work Timer is activated.
2. Select the applicable Classification Code from the list that displays and click Apply.
NOTE: If you are handling more than one item in the Inbox, for example, one email and one
call, and you apply a Classification Code during the call, it is applied to the item that is
currently selected in the Inbox. If you apply a Classification Code after the call, when in Work
Timer, the voice contact is no longer in your inbox and you will need to use the ‘Classify’ icon
in the Sidebar to apply a Classification Code to the voice contact.
3. If Work Timer has not been configured to automatically cancel after entering a Classification
Code, cancel Work Timer by clicking the Remove Work Timer button in the Sidebar.
NOTE: If you use forced Classification Codes, you cannot cancel Work Timer until you have
entered a Classification Code. If you do not enter a Classification Code before the Work Timer
expires, a default Classification Code of ‘-1 Non-Compliant’ is entered automatically.

Removing Work Timer
Agents use the time spent in Work Timer to complete post-call work, such as consulting with a
supervisor, without having this downtime affect their performance statistics.
When Work Timer is the overriding state in Ignite, agents can remove Work Timer and put
themselves back into an overriding state across all media capabilities. Once agents have removed
Work Timer, they cannot put themselves back into this state.
According to queue configuration settings, agents can be placed in a Work Timer state for a set
period of time after completing a call. The Work Timer can optionally be configured to cancel
automatically after a Classification Code has been entered. If the Work Timer is not set to cancel
automatically, you must cancel it manually after entering a Classification Code.
If Work Timer is not configured to cancel automatically when a Classification Code has been entered
and you end the call and do not manually cancel it you will be unable to receive calls until the Work
Timer duration, as configured on the queue, has expired.
If you are handling other media contacts and calls simultaneously and Work Timer is not configured
to cancel after entering a Classification Code and the call ends, you must either wait for Work Timer
to expire or finish handling your other active media types, for example, an active email, before you
will be able to receive another call.
To remove Work Timer
l

In the Sidebar, click the Remove Work Timer button.
NOTE: If you are handling non-voice contacts and the Sidebar is collapsed, you can remove
the Work Timer via the Action bar instead.
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Accessing agent handling statistics by media type
Agents can access statistics related to their performance via the Sidebar. If you are enabled for
media types other than voice, you can toggle between media-specific statistics using the icon
directly above the statistical displays. Select the headphone icon for voice, the envelope icon for
email, or the conversation icon for chat statistics.
By default, the Sidebar displays Shift Time, DND Time, and MKB Time. However, using the
Settings button in the Sidebar, you can select any three agent shift statistics from the following list
for display:
l

Shift Time

l

ACD Time

l

ACD Hold Time

l

Non ACD Time

l

Non ACD Hold Time

l

Out Time

l

Out Hold Time

l

DND Time

l

MKB Time

l

Wrap Up Time

l

DND Cnt

l

MKB Cnt

l

ACD Cnt

l

Shrt ACD Cnt

l

Non ACD Cnt

l

Hold ACD Cnt

l

Non ACD Hold Cnt

l

Out Cnt

l

Out Hold Cnt

l

On failover

l

Logged In Not Present Time

l

Avg Hndl

l

Occp

If the statistical name is too long to fully display, you can either hover over the statistic and read the
tooltip or left-click the statistic and the fly-out menu will display the full name.
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Configuring profiles
When you make manual adjustments to Ignite, they are remembered as part of your profile. When
you close Ignite, your profile is automatically saved. When you reopen Ignite with your username,
Ignite loads your most recent profile settings. If Ignite shuts down suddenly, for example, due to a
power outage and subsequent computer restart, Ignite will use your last saved profile when
restarted.
In addition to auto-settings, Ignite offers the following configuration options via the Settings button in
the Sidebar.

General settings
By clicking the Settings icon in the Sidebar and then clicking the General settings tab, you can
customize Ignite display and behavior.
l

l

l

l

l

l

Launch MiCollab Client if installed but not running when signing into Ignite: This
setting is selected by default and automatically opens MiCollab Client, if not currently running,
when an agent signs into Ignite.
NOTE: You will be prompted to log in your voice agents in MiCollab Client before signing into
Ignite.
Always show Sidebar: This setting is checked by default. If unchecked, you will not have
access to the options listed below and you will need to use the arrow icon to show or hide the
Sidebar.
Expand Ignite when a multimedia item is accepted: This setting is checked by default.
When selected, if the main Ignite window is collapsed and an email or chat is accepted via the
toaster, the main Ignite window automatically expands. If not selected, Ignite will not
automatically expand when an email or chat is accepted and the agent must expand it
manually by clicking the arrow at the bottom of the Sidebar.
Expand Ignite when a voice item is accepted: This setting is not checked by default and if
the main Ignite window is collapsed and a call is accepted via the toaster, Ignite does not
automatically expand. We recommend you do not check this setting as the main Ignite
window is not essential for handling voice contacts. If selected, if the main Ignite window is
collapsed and a call is accepted via the toaster, Ignite automatically expands.
Collapse Ignite on startup: This setting is not checked by default. When you start Ignite, the
main window will not collapse. If this check box is selected, only the Ignite Sidebar displays at
startup. You can use the arrow icon at the bottom of the Sidebar to expand the main Ignite
window. If this setting is not selected, when you start Ignite the main window and the Sidebar
will display.
Collapse Ignite when inbox is emptied: This setting is checked by default. When selected,
and your inbox empties, the main Ignite window collapses. If not selected, the main Ignite
window does not collapse when your inbox has been emptied.

Sidebar Stats settings
By clicking the Settings icon in the Sidebar and then clicking the Sidebar Stats settings tab, you can
select which three agent handling statistics you want to display in the Ignite Sidebar. See
"Accessing agent handling statistics by media type" on page 481 for a list of available statistics.
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Call handling using the Action bar
Agents can optionally perform call handling activities, such as transferring a call, placing a call on
hold, and hanging up a call, from the Ignite Action bar instead of using the MiCollab Client call control
window. They can also remove Work Timer from the Action bar instead of the Sidebar, which may be
preferable for multimedia agents who do not use voice and, as a result, benefit more from the Ignite
main window than from the Sidebar. Multimedia agents may choose to collapse the Sidebar and
expand Ignite’s main window to more efficiently handle emails and chats.

VIEWING AGENT STATE AND STATISTICS IN THE STATUS
BAR
The Status bar displays the employee’s overriding state, including:
l

Time in Ringing – Displays when an employee has contacts ringing in the Inbox

l

Time in ACD – Displays when an employee has placed ACD contacts in reply mode

l

Time in ACD Hold – Displays when an employee has placed ACD contacts on hold

l

Time in Non ACD – Displays when an employee is handling non-ACD contacts

l

l

Time in Non ACD Hold – Displays when an employee has placed non-ACD contacts on
hold
Time in Work Timer – Displays after the employee has handled a contact, provided none of
the employee’s agents are in an ACD, Make Busy, or Do Not Disturb state

l

Time in Do Not Disturb – Displays when the employee is in a Do Not Disturb state

l

Time in Make Busy – Displays when an employee is in a Make Busy state

l

l

Time Logged in Not Present – Displays when an employee is not present to any of their
agent groups
Time in Idle – Displays when the employee does not have contacts in the Inbox

An overriding state is one that ‘trumps’ another state. States higher in the list override the states
appearing lower in the list. Note that all of the employee’s agents are considered when the system
calculates overriding state.
The oldest state for a state ‘trumps’ other times for the same state if an agent is handling multiple
contacts. For example, if an employee had two emails in ACD, the displayed value in the status bar
would be the time of the oldest email. When the oldest email is completed, the displayed value in the
status bar would switch to the other email’s Time in ACD.
Ignite’s Status bar also contains statistics on agent performance as it relates to handling multimedia
contacts. See the Multimedia Contact Center Installation and Deployment Guide for more
information.
Agent handling statistics can be displayed by clicking the ^ button on the right-hand side of the
Status bar.
NOTE: The Status bar is only visible to employees with associated voice, email, or chat agents.

483

Ignite

HANDLING CALLS IN IGNITE
Agents can perform basic call handling in Ignite.
The following procedures explain how to
l

View call information

l

Answer and end calls in Ignite

l

Pick calls out of queue

l

Blind transfer calls to internal and external destinations

l

Put calls on hold and retrieve calls from hold

MiCollab Client is recommended for performing more advanced call handling functions such as
conferencing and supervised transfers.
NOTE:
l

l

Ignite’s phone functionality does not support multiple lines and is used to handle inbound voice
contacts only.
Ignite’s phone controls are not supported for External Hot Desking Agents.

Viewing call information
Agents can view basic call information in the Preview Pane before picking a call out of queue or
handling it from the Inbox. Note that information displaying may vary based on administrative
configuration.
Agents can view
l

From Name: Caller ID (if supported by the caller)

l

From Phone Number: The caller’s ANI

l

To Phone Number: The call’s DNIS. This is the number the caller dialed

l

To Name: The name associated to the call’s DNIS

l

Queue Name: The name of the queue from which the call originated

l

Queue Dialable: The dialable number of the queue from which the call originated

l

Queue Reporting: The reporting number of the queue from which the call originated

l

l

Time Offered to Agent: The time at which the call reached the agent’s Inbox
NOTE: Applies only to ACD conversations
Collected Information: Digits collected from the caller, for example an account number

The following explains how to
l

View information for calls in queue

l

View information for calls in the Inbox

To view information for calls in queue
1. In the Folders pane, select a queue.
2. In the List pane, select a call.
Call information displays in the Preview pane.
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To view information for calls in the Inbox
1. In the Folders pane, click Inbox.
2. In the List pane, select a call.
Call information displays in the Preview pane.

Answering and ending calls
Agents can answer calls ringing in the Inbox. Note that agents cannot decline a ringing call.
The following explains how to
l

Answer a call

l

End a call

To answer a call
1. In the Folders pane, click Inbox.
2. In the List pane, select a call and, in the Action bar, click Reply.
To end a call
l

In the Action bar, click Hang Up.

Picking calls out of queue
Agents can pick calls out of queue and send them to the Inbox. Once ringing in the Inbox, the call
can be answered.
NOTE:
l

l

Agents cannot pick or pick and reply to contacts from the queue if they are in Do Not Disturb.
Your Pick and Pick & Reply buttons are disabled when you are in Do Not Disturb.
Agents may only pick or pick and reply to contacts from the queue if they have the appropriate
permissions. This is an administrative configuration and is not controlled by the agent. If your
Pick and Pick & Reply buttons are disabled, you do not have permission to pick contacts from
the queue

The following procedures explain how to pick a call from the queue.
To pick a call from the queue
1. From the Folders pane, select the queue from which a call will be picked.
2. From the List pane, select a call from the queue and, from the Action bar, click the Pick
button.
The call is transferred to your Inbox.
3. To answer the call, select Inbox and, in the List pane, select the call and click Reply.
NOTE: Additional handling options display in the Action bar. For more information, see the
appropriate procedures in this section.
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Blind transferring calls to internal and external destinations
Agents can transfer calls to internal and external destinations. Internal transfer destinations include
destinations programmed in the 3300 ICP media server or in a cluster of 3300 ICP media servers.
External transfer destinations include dialable numbers not programmed in the 3300 ICP media
server or in the cluster of 3300 ICP media servers. For example, agents in the Support queue
receiving calls concerning account renewals can transfer these calls internally to the Sales queue, or
agents can transfer calls externally to a supervisor’s cell phone.
Agents who are logged out, in Do Not Disturb, or whose presence is unknown cannot receive
transferred calls and do not display in the transfer list. Agents who are either in Make Busy or at their
call Workload limit can receive transferred calls and will display in the transfer list.
At this time, agents are only able to perform blind transfers in Ignite. In blind transfers, there is no
communicating with transfer destinations before sending calls. Calls are transferred immediately
and the system does not monitor the outcome
NOTE:
l
l

Calls on hold may not be transferred until hold is removed.
Agents may only transfer contacts if they have the appropriate permissions. This is an
administrative configuration and is not controlled by the agent. If your Transfer button is
disabled, you do not have permission to transfer contacts. You may request that a supervisor
transfer the contact to you instead.

The following explains how to
l

Transfer calls to an agent or queue

l

Transfer calls to a dialable number

To transfer a call to an agent or queue
1. In the Folders pane, click Inbox.
NOTE: To transfer directly from the queue, select the call from the queue and, in the Action
bar, click ‘Transfer’. Follow steps 4 onward.
2. In the List pane, select a call and, in the Action bar, click Reply.
3. In the Action bar, click Transfer.
4. Select the Internal Transfer radio button and select an agent or queue. Expand the device list
if necessary. You can search for an internal transfer destination by typing the name of an
agent or queue in the ‘Search’ field.
5. Click Transfer.
To transfer a call to a dialable number
1. In the Folders pane, click Inbox.
NOTE: To transfer directly from the queue, select the call from the queue and, in the Action
bar, click ‘Transfer’. Follow steps 4 onward.
2. In the List pane, select a call and, in the Action bar, click Reply.
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3. In the Action bar, click Transfer.
4. Select the External Transfer radio button and, in the Transfer To: field, type a dialable
number. Enter this number as you would on a phone, including any digits required for outbound
dialing.
NOTE: Invalid entries return an error message. Re-type a valid entry and click ‘Transfer’.
5. Click Transfer.

Putting calls on hold and retrieving calls from hold
At times, agents may have to put a call on hold. When on hold, the List pane displays a paused icon
over the voice contact.
NOTE: Calls on hold may not be transferred until hold is removed.
The following explains how to
l

Put a call on hold

l

Retrieve a call from hold

To put a call on hold
1. In the Folders pane, click Inbox.
2. In the List pane, select the active call.
3. In the Action bar, click the Hold button.
To retrieve a call from hold
1. In the Folders pane, click Inbox.
2. In the List pane, select the call on hold.
3. In the Action bar, click Remove Hold.
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FLEXIBLE REPORTING
Flexible Reporting is an application that works with Contact Center Management Enterprise Edition.
In addition to the over 425 reports provided by Contact Center Solutions and Business Reporter,
Flexible Reporting enables you to design your own reports.
To install Flexible Reporting on a client computer, select the Flexible Reporting option in the Client
Role Selector.
To access Flexible Reporting, employees must be associated with a security role that allows them
to manage reporting (the May manage reporting check box must be selected).
With Flexible Reporting you can:
l

Use a wizard interface to create customized reports with existing statistics (column headings)

l

Create custom calculations using expressions

l

Select column headings to build custom reports

l

Select only the columns you want to view

l

Select like data for two or more device types and combine them in one report

l

Arrange the columns in the order in which you want to view them

l

l

Customize the names of statistics (column headings) so they are meaningful to your
department, business, and industry
Save the reports in Excel and .pdf formats

USING FLEXIBLE REPORTING
In Flexible Reporting you can
l

Create new reports

l

Modify standard Contact Center Management report templates

l

Modify existing Flexible Reporting report templates

l

Design reports

l

Manage your Flexible Reporting reports

l

Run reports

STARTING FLEXIBLE REPORTING
NOTE: Launching client-side applications from the task bar causes them to bypass the Updater
Service process. To ensure successful updates from the Enterprise Server, after an upgrade close
all client-side applications for 15 minutes or reopen them from the Start menu/Start screen
To start Flexible Reporting
1. Open Flexible Reporting.
2. If prompted, type your user name and password and verify the Enterprise Server IP address.
3. If you use Secure Socket Layer, select the SSL check box.
4. Optionally, select the Remember my credentials check box.
The Welcome to Flexible Reporting dialog box opens.
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5. Select from: Run a report, Create a new report, Redesign a standard report, Modify an
existing report, or Do not show this dialog box again.
NOTE: The Created Language column for existing reports displays your current language
preference.
6. If you want to initiate a procedure, click OK and see the associated section in this chapter.
Otherwise, close the dialog box.

VIEWING THE FLEXIBLE REPORTING USER INTERFACE
The Flexible Reporting user interface comprises the following. (See Figure 112.):
l

Report Designer wizard

l

Layout designer window

l

Flexible Reporting button

l

Ribbon

l

Toolbox window

Figure 112: Flexible Reporting user interface
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You can customize the position of the windows in the following ways:
l

Dock to the left, right, top, or bottom of the user interface

l

Float

l

Hide

l

Auto-hide

Report Designer wizard
Whether you are building a new report or modifying an existing Contact Center Management report,
the Report Designer wizard leads you through the following steps to select data for the report:
l
l

Create a new report based on an existing one, or design a new report
Select a report type (Performance reports, Answering points, Make Busy, and Account Code
reports, or Summarized/Detailed Agent Event reports)

l

Select the device types

l

Select the statistics (column headings), and the order in which you want them displayed

l

Specify the time frame options

Layout designer window
The layout designer window comprises two tabs: design and preview. The window displays the
report header and data grid. You can perform the following functions in the layout designer window.
On the Design tab you can
l

Add images to report headers

l

Edit the report header titles

l

Adjust the placement of the report header titles and values

l

Remove report header titles and values

l

Add existing or custom columns

l

Move columns

l

Delete columns

l

Edit column heading names

l

Specify column width and row height

l

Specify row colors

l

Freeze and unfreeze columns

l

Save report templates

On the Preview tab you can
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l

Run and preview reports

l

Save reports

l

Export reports

l

Print reports
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The File tab
The File tab is a tab located in the upper left corner of the window. The following options are available
from the Flexible Reporting button: New, Open, Save, Save As, Close, Feedback, About, Log Out,
Exit, and Exit and Log Out.

Ribbon
The ribbon provides the same functionality as traditional toolbars. Use the tools on the ribbon to help
you design your reports. The ribbon comprises the Home, Insert, and View tabs.
On the Home tab of the ribbon, you will find the tools to help you
l

Change the font type, size, and style

l

Select text justification

l

Specify column width, auto-fit column width, and row height

l

Change row colors

On the Insert tab of the ribbon, you will find the tools to help you
l

Insert and remove images from the report header

l

Select the report header titles to open in the report header

l

Add existing or custom columns

l

Remove columns

l

Freeze and unfreeze columns

l

View or modify expressions

On the View tab of the ribbon, you will find the tools to help you
l

Show and hide the Toolbox window

l

Manage reports

Toolbox window
The Toolbox window contains the following:
l

l

Report header
Report header is a list of report header titles that are currently not included in the report header.
If the Report Header list is empty, all of the report header titles will be applied to the report.
When report header titles are removed from a report they are shown in the Report headers list.
Column heading
Column heading displays a list of all of the column headings (for only those devices selected
for the report) that are not currently included in the report grid. When you add a column heading
to the report, it is removed from the list. Similarly, if you remove a column heading from the
report, it displays in the Column headings list.
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CREATING NEW REPORTS
Using the Report Designer wizard you can build new reports with existing column headings. Use the
Report Designer wizard to select the data for the report.
NOTE: Reports generate in the language they were created in, regardless of the current employee
language setting.
The Report Designer wizard guides you through the following steps:
l

Select how you want to display the report data
l

l

l

Performance reports display data for agents, queues, trunks, DNIS, or extensions by
interval. Each row in the report represents a specific period. The supported periods are:
15 minutes, 30 minutes, 60 minutes, day of week, day of month, and month.
Answering points, Make Busy, and Account Code reports display data for a single
device per row (including employee, agent, queue, ANI, DNIS, Account Code, Make
Busy code, Trunk busy minutes, agent ID, and devices associated with device groups).
Each row in the report represents a device. Examples of by device reports are
Employee Group by Employee, Queue Group by Queue, Queue by Agent, or Queue
ANI by Area Code.
Summarized/Detailed Agent Event reports display ACD-based agent activity data. The
data can be grouped by login/logout pair or can be viewed as a trace of all login/logout
pairs. For example, Detailed Agent Event Data reports show the agent state activity for
each login/logout pair performed by the agent. Summarized Agent Event Data reports
group the data and show one line representing the agent’s total activity.

l

Select the device(s) on which you want to report

l

Select the statistics (column headers) that will be shown in the report

l

Select the time frames over which you want to run the report

To create a new report
1. Click File=>New to launch the Report Designer wizard.
2. Click Next.
3. Click Create a new report and follow the steps in the wizard.
At the end of the Report Designer wizard, the new report opens automatically on the Design
tab.
4. Design the report.
See "Designing reports" on page 496.
5. Click File=>Save.
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MODIFYING STANDARD CONTACT CENTER MANAGEMENT
REPORT TEMPLATES
Using the Report Designer wizard you can modify standard Contact Center Management voice
report templates. In the wizard, you can remove data (column headings) and add new data
(additional devices and column headings).
The Report Designer wizard guides you through the following steps:
l

l

Select the report you want to modify from a list of standard Contact Center Management
reports
Select the time frames over which you want to be able to run the report
Choosing options on this page enables you to select time frames when submitting or
previewing reports. The start and end times enable you to run the report for a specific time
frame for each day in the report. For example, you can run the report for your hours of
operation only, 8 A.M. to 6 P.M.
The days of the week time frame enables you to run the report for specific days. For example,
every Friday over the last two months.

Table 40 lists the standard Contact Center Management report templates.
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Table 40: Standard Contact Center Management report templates
Agent report templates
l

Agent by Make Busy Code

l

Agent Group by Make Busy Code

l

Agent Group Performance by Period

l

Agent Performance by Account Code

l

Agent Performance by Period

l

Agent Shift by Period

DNIS report templates
l

DNIS Group Performance by Period

l

DNIS Performance by Period

l

Employee report templates

l

Employee Group Performance by Employee

l

Employee Performance by Agent ID

Extension report templates
l

Extension Group Performance by Period

l

Extension Performance by Period

Queue report templates
l

Queue ANI by Area Code

l

Queue Group Performance by Queue

l

Queue Performance by Account Code

l

Queue Performance by Member

l

Queue Performance by Period

Trunk report templates
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l

Trunk Group Performance by Period

l

Trunk Performance by Period
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To modify a standard Contact Center Management report template
1. Click File=>New.
2. Click Next.
3. Select the Redesign a standard report option and follow the steps in the wizard.
At the end of the Report Designer wizard, the new report template opens automatically on the
Design tab.
NOTE: On the Select an existing report template page of the wizard, under Filter by device
type, select All devices if you want to see all available reports for all devices.
4. Design the report.
See "Designing reports" on page 496.
5. Click File=>Save.

MODIFYING EXISTING FLEXIBLE REPORTING REPORT
TEMPLATES
To modify an existing Flexible Reporting report template
1. Click File=>Open.
The Reports List window opens, giving you access to all personal and shared Flexible
Reporting reports.
2. Select the report you want to modify.
3. Click Open.
NOTE: If ‘Do not show this dialog box again’ was selected on the Welcome to Flexible
Reporting dialog box, the report will open to whichever tab, Design or Preview, was open last.
4. Modify the report.
See "Designing reports" on page 496.
5. Click File=>Save to save the changes to the report template.
Click File=>Save As to save the report as a new template.
6. If you want to run the report, click the Preview tab.

DESIGNING REPORTS
Using the options available on the ribbon, design the report by modifying the report header, columns,
and rows.
NOTE:
l
l

You can open and edit report templates you previously created in Flexible Reporting.
When right-clicking a column to bring up the column’s context menu, do not right-click the
column header cell. This is an editable field and will not bring up the column context menu.

Adding images to report headers
To add an image to a report header
1. On the Insert tab of the ribbon, click the Insert button.
2. Select an image file and click Open.
The image displays on the report header.
3. Drag the image to where you want it to be shown on the report header.
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Deleting images on report headers
To delete an image
1. Select an image on the report header.
2. On the Insert tab of the ribbon, click the Remove button.

Editing report header titles
Report headers comprise titles and values. Edit the report header titles to customize the look of your
reports.
You can edit the font type, size, and style of report header titles.
You can edit the titles of the following report headers:
l

Report

l

Site

l

Device

l

Date range

l

Date created

l

Created by
NOTE: You cannot edit the report header values as these are driven by the options selected
when the report is submitted.

To edit a report header title
1. Click a report header title.
2. Edit the text in the box.

Moving report header titles and values
You can drag and drop report header titles and values independently.
To move a report header title or value
l

Drag and drop the report header title or value to where you want it to be shown on the report
header.

Removing report header titles and values
All report header titles and values are shown on a report when it is first created. If you remove a
report header title, the corresponding value will also be removed from the header. For example, if you
remove the Date range title, the date range will not be shown on the report.
To remove a report header title and value
l
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On the Insert tab of the ribbon, click the Header button and deselect the check box of the
report header title you want to remove. You can optionally drag and drop the report header title
from the report to the Report header list.
Report header titles removed from the report are shown in the Report header list in the Toolbox
window.
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Adding report header titles and values
To add a report header title and value to a report
l

On the Insert tab of the ribbon, click the Header button and select the check box of the report
header title you want to add. You can optionally drag and drop the report header title from the
Report header list to the report.

Adding existing columns
To add an existing column
1. On the Insert tab of the ribbon, click Add=>Existing.
Optionally, right-click the report and select Insert column=>Existing from the drop-down list.
The Add columns window opens.
NOTE: You can also drag and drop items from the Column heading list in the Toolbox window
to add existing columns to your report.
2. Select the columns you want to add to the report.
3. Click OK.

Adding custom columns
You can add custom columns to create custom calculations using expressions or blank columns.
The ability to create custom calculations using expressions enables you to further customize report
data to suit your specific business needs. Blank columns can be used as spacers to make reports
easier to read, or as placeholders for importing third-party data after a Flexible Reporting report has
been generated.
NOTE:
l

l

Adding columns containing custom calculations requires a thorough understanding of
Microsoft Excel and regular expressions.
We recommend you preview reports containing custom calculations in Flexible Reporting
before saving the changes and generating the report in CCMWeb.

To add a column containing custom calculations
1. On the Insert tab of the ribbon, click Add=>Custom.
Optionally, right-click the report and select Insert column=>Custom from the drop-down list.
A blank column displays in the report.
2. Right-click a cell in the blank column and select Expression.
The Edit expression window opens.
NOTE: You cannot create calculations using expressions in a header cell.
3. Select an option in the Options list to view the associated Item list.
4. Select an item in the Item list to view the associated item Description and expression
Example.
5. Double-click the item in the Item list to insert its expression into the Expression box.
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6. Repeat steps 3 to 5 until the complete calculation is entered in the Expression box and click
OK.
The expression displays in row two of the blank column in the report.
7. If you want to edit the expression you created, right-click the cell and select Expression to
return to the Edit expression window.
After adding a column containing custom calculations you can choose to view or modify the
expression.
To view or modify an expression
1. Select the cell in the report, for which you want to view or modify the expression.
2. On the Insert tab of the ribbon, click Expression.
Optionally, right-click the column and select Expression from the drop-down list.
The Edit expression window opens.
3. Select an option in the Options list to view the associated Item list.
4. Select an item in the Item list to view the associated item Description and Expression
example.
5. Double-click the item in the Item list to insert its expression into the Expression box.
6. Repeat steps 3 to 5 until the complete calculation is entered in the Expression box and click
OK.
The expression displays in row two of the blank column in the report.
You can restrict the number of decimal places that will display for results. As an example, setting the
number of decimal places that will display for the Average Manned Agent statistic is described
below.
To set the number of decimal places that display for results
1. In the Design view, right-click the Average Manned Agent column in the report and select
Expression from the drop-down list.
2. Change the current value of =Fields!AgentGroupEventAvgMannedAgents.Value to
=FormatNumber(Fields!AgentGroupEventAvgMannedAgents.Value,1).
3. Click OK.
4. Click Save.
The column is formatted to display one decimal place. To alter the number of decimal places
displayed, enter the appropriate number in place of 1.
To add a blank column
1. On the Insert tab of the ribbon, click Add=>Custom.
Optionally, right-click the report and select Insert column=>Custom from the drop-down list.
A blank column displays in the report.
2. Optionally, click the header cell of the blank column and type a name for the column.

Moving columns
To move a column
l
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On the report grid, drag and drop the column to where you want it on the grid.
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Deleting columns
NOTE: Some statistics require specific columns to ensure a report is meaningful. These statistics
are associated with the required columns and cannot be deleted on their own. For example, in by
period reports, you cannot delete the interval; in by device reports, the reporting number cannot be
deleted.
To delete a column
1. Click a column on the report grid.
2. On the Insert tab of the ribbon, click the Remove button.
Optionally, right-click the column and select Delete column from the drop-down list.

Editing column heading names
You can edit the names of column headings so they are meaningful to your department, business,
and industry. You can change the font type, size, and style as well as edit the text.
To edit a column heading name
1. Click a column heading on the report grid.
2. On the Home tab of the ribbon, use the font options to change
l

the font type, size, and style

l

the justification

3. Optionally, edit the name of the column heading.
If, after renaming a column heading, you want to see the original column heading name, hover
over the column heading. The original column heading name displays after Name.

Specifying column width
To specify the column width
1. Click a column.
2. On the Home tab of the ribbon, after Column width, type the width (in pixels).
Optionally, right-click the column and select Column width from the drop-down list.
To auto-fit the column width
1. Click a column.
2. On the Home tab of the ribbon, after Scale to fit, click Auto.
Optionally, right-click the column and select Auto-fit Column width from the drop-down list.

Specifying row height
You can specify a different row height for the header row than the body rows.
To specify the header row height
1. Click the header row.
2. On the Home tab of the ribbon, after Row height, type the height (in pixels).
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To specify the body row height
1. Click a body row.
2. On the Home tab of the ribbon, after Row height, type the height (in pixels).
Optionally, right-click the body row and select Row height from the drop-down list.
All of the body rows will be the same height.

Specifying row colors
You can alternate row colors to make report data easier to read.
1. On the Home tab of the ribbon, select the primary and alternate colors.
2. After Alt row count, type the number of rows for each color.

Freezing columns
Frozen columns remain stationary when you scroll to view columns to the right.
To freeze a column heading
1. On the report grid, click the column to the right of the ones you want to freeze.
2. On the Insert tab of the ribbon, click the Freeze column button.
Optionally, right-click the column and select Freeze column from the drop-down list.

Unfreezing columns
To unfreeze a column heading
1. On the report grid, click the column to the left of the frozen column.
2. On the Insert tab of the ribbon, click the Unfreeze column button.
Optionally, right-click the column and select Unfreeze column from the drop-down list.

MANAGING YOUR FLEXIBLE REPORTING REPORTS
You manage your Flexible Reporting reports on the My Reports window. My Reports gives you
access to all of the reports you have created.
NOTE: You can access all the reports you have created and all shared reports created by others, by
clicking the File=>Open.
In the My Reports window you can
l

Change access properties: Shared or not Shared

l

Rename reports

l

Delete reports

Changing access properties
To change the access properties of a report
1. On the View tab of the ribbon, click My reports.
2. Select the report(s).
3. If you want to share the report(s), under Shared, select the check box. Otherwise, clear the
check box and the report(s) will be available to you only.
4. Click OK.
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Renaming reports
To rename a report
1. On the View tab of the ribbon, click My reports.
2. Select a report and click Rename.
3. Edit the name.
4. Click OK.

Deleting reports
You can only delete the reports you create.
To delete a report
1. On the View tab of the ribbon, click My reports.
NOTE: You cannot delete a report that is open in Flexible Reporting.
2. Select the report(s) you want to delete and click Delete.
3. Click Yes to delete the selected report(s).
4. Click OK.

RUNNING FLEXIBLE REPORTS
You can run Flexible Reporting reports in CCMWeb or in Flexible Reporting. However, you can
schedule reports in CCMWeb only.
From CCMWeb, you can run Flexible Reporting reports on demand, or schedule them, the same
way you run standard reports. See "Reporter" on page 308 and "Scheduled Reports" on page 315.
In Flexible Reporting you can run, save, and print reports on the Preview tab. After you run a report,
printing options enable you to view the print layout, and configure page setup and printer properties.
NOTE:
l
l

l

Flexible Reporting will run reports only when there is data to generate the report.
If you run a report on the Preview tab and the report data is all zeros, ensure you selected a
device on which to run the report. If you selected a device, ensure the selected time period is
one that would have incurred activity.
Custom reports created in Flexible Reporting can only be generated in the language that was
used when they were created and saved.

Running reports in the Contact Center Management website
To run an on-demand report in the Contact Center Management website
l

Click Reporter=>Flexible Reporting and select and run the report.
You will have access to all Flexible Reporting reports created by you and shared Flexible
Reporting reports created by others.

NOTE: When a report supports more than one device type, click on each tab to select the devices on
which you want to report.
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To schedule a report on the Contact Center Management website
1. On the Contact Center Management website, click Reporter=>Scheduled reports.
2. If you want to create a new schedule, click Next. Otherwise, select an existing schedule and
click Manage schedule properties.
3. Configure the schedule properties and distribution attributes.
For more information, see "Creating Contact Center Management Report schedules" on page
316.
4. Click Add a report.
5. Click Flexible Reporting and select a report to add to the schedule.

Running reports in Flexible Reporting
To run reports in Flexible Reporting
1. On the Preview tab, under Devices, select the device(s).
2. Specify the date and time parameters.
3. Click Run report.
Flexible Reporting generates the report and displays it in the preview pane.

Saving templates and reports
In Flexible Reporting you can save
l

Templates
The report templates you create in Flexible Reporting are saved on the Enterprise Server so
you can run them from Flexible Reporting and CCMWeb.
NOTE: Report templates are not saved automatically. You must save your report template
before you exit Flexible Reporting if you want to use it to run reports or modify the template
later.

l

Reports
After you run a report in Flexible Reporting, you can save the output (report) on your computer
or elsewhere on your network. Reports can be saved or, optionally, exported in Excel (.xsl and
.xslx), Word (.doc), or .pdf formats.

To save a report template as a new document
1. Click the File=>Save As.
2. After File name, type the name of the new template.
NOTE: Only you can run and view reports you have created and designated as not shared.
Shared reports can be run and viewed by others.
3. If you want to allow others to run the report, select the Shared check box.
4. Click Save.
To save modifications to a report template
l
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Click File=>Save.
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To export a report in Excel (.xsl or .xslx) format
l

In the Preview window, above the generated report, click the Save button, select Excel, and
specify the location to save the report in Excel (.xsl) format.
Optionally, in the View tab of the ribbon, click the Export report button, select Excel (.xsl) or
Excel 2007 (.xslx) and specify the location to save the report in an Excel format.

To export a report in Word (.doc) format
l

In the Preview window, above the generated report, click the Save button, select Word, and
specify the location to save the report in Word (.doc) format.

To export a report in .pdf format
l

In the Preview window, above the generated report, click the Save button, select PDF, and
specify the location to save the report in .pdf format.
Optionally, click the Export report button on the View tab of the ribbon, and select PDF, and
specify the location to save the report in .pdf format.

Printing reports
To print a report you ran on the Preview tab
l

On the Preview window toolbar, click the Print button.
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IVR ROUTING
An IVR Routing license includes IVR Routing ports and IVR Routing. Mitel IVR Routing is an all-inone, scalable, integrated voice processing solution that works in conjunction with Contact Center
Management.
IVR Routing enables you to rapidly and intuitively
l

Build workflows in a drag-and-drop graphical interface

l

Create and relay static, dynamic, and custom recorded prompts to callers in queue

l

Provide callers with Updated Position in Queue (UPiQ) messaging

l

Guide callers to the destination that best meets their needs

l

Allow customers to request a queued callback by leaving a voice message or using the Web

l

l

Provide workflow branching based off multiple conditions including ANI, DNIS, schedules,
and queue conditions
Report on IVR activity

IVR Routing is activated during the Contact Center Management installation process. For
information on installing Contact Center Management, see the Contact Center Management
Installation Guide. For information on installing IVR Routing on a Remote Server, see the Contact
Center Management Installation Guide.
IVR Routing is supported with Microsoft Lync and MiContact Center for Lync. For information about
integrating with Microsoft Lync or MiContact Center for Lync, consult the MiContact Center for
Microsoft Lync User Guide.
NOTE:
l

l

l
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To support IVR Routing resiliency and redundancy, you must have at least one non-resilient
extension programmed on the queuing gateway and configured in the Contact Center
Management database (either manually or via synchronization). In addition, there must be a
MiTAI monitor set on this extension. This is done in YourSite Explorer by ensuring the
'Disable real-time monitoring, data collection and call handling on this device' check box is not
selected. (Note: This check box is deselected by default.) Having the MiTAI monitor set on
the extension enables our software to recognize when the connection to the queuing gateway
is restored following a network outage.
As a limitation of the telephone system, dual-tone multi-frequency signaling (DTMF) digits are
only detected if the SIP trunks are configured to send via DTMF 2833. If your SIP trunks are
configured to send DTMF digits in-band, IVR Routing will not detect any DTMF digits.
Call record data generated on remote instances of IVR Routing when the main IVR Routing
server is offline will not be reported on.

IVR Routing enhancements

IVR ROUTING ENHANCEMENTS
IVR Routing offers enhancements to navigation, workspace customizing, and existing functionality
including
l

l

l

l

l

l

l

l

An Outline pane
See "Viewing workflows at a glance: The Outline pane" on page 507.
Focusing and breadcrumbs
See "Viewing specific portions of a workflow: Focusing and the Breadcrumb view" on page
508.
A MiniMap window and a Pan mode
See "Navigating the Workflows Canvas: The MiniMap window and the Pan mode" on page
509.
A Zoom feature
See "Resizing workflows: The Zoom feature" on page 509.
Expand All, Collapse All, and Restore buttons
See "Manipulating all activities in a workflow: The Expand All, Collapse All, and Restore
buttons" on page 509.
The ability to save and copy workflows as images
See "Saving and copying workflows as images" on page 528.
The ability to annotate activities and workflows
See "Annotating activities in workflows and subroutines" on page 568.
Expanded troubleshooting for workflow configuration
See "Troubleshooting workflow configuration with the Validation button" on page 568.

WORKFLOW NAVIGATION IN IVR ROUTING
IVR Routing now makes it easier to view and navigate large workflows through several functionality
enhancements, including
l

The Outline pane

l

Focusing and breadcrumbs

l

The MiniMap window and Pan mode

l

The Zoom feature

l

The Expand All, Collapse All, and Restore buttons

Viewing workflows at a glance: The Outline pane
The Outline pane displays your workflow in a binary search tree format. You can selectively view the
workflow and the parent-child relationships of activities and conditions by expanding or minimizing
individual items in the tree. By providing an overview of the workflow in a compact space, the Outline
pane enables you to efficiently view complex workflows and the relationships between activities.
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You can configure activities or branches directly from the Outline pane by right-clicking in the search
tree. Right-clicking also highlights the activity in the workflow, providing a clear means of referencing
the specific activity you are configuring. If, for example, you have several similar activities in your
workflow, highlighting minimizes errors by helping you confirm you are configuring the correct
activity.
Double-clicking an item in the Outline pane brings that item into focus, enabling you to quickly
identify and update nested activities in complex workflows.

Viewing specific portions of a workflow: Focusing and the Breadcrumb
view
You can devote the entire Workflows Canvas to viewing specific portions of a workflow by doubleclicking activities or branches on the Canvas. This feature enables you to focus on precise elements
of complicated workflows and minimizes the need to use subroutines to conserve viewing space.
When you focus on an activity or branch, the Canvas opens in breadcrumb view. Breadcrumbs at
the top of the Canvas indicate the portion of the workflow you are viewing and the parent elements of
those portions. After focusing on a specific portion of the workflow, you can incrementally expand
your view of the workflow by tracing back through parent relationships using breadcrumbs. You can
also right-click an activity and select 'Go To Parent'. The Breadcrumb view provides an ordered way
of redirecting your focus in the workflow from precise elements to the bigger picture.
Note that when working in the Breadcrumb view, only the items in focus can be configured. In order
to configure other items in the workflow, select the breadcrumb that brings the item into focus. (See
Figure 113.)

Figure 113: Focusing and the Breadcrumb view
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Navigating the Workflows Canvas: The MiniMap window and the Pan
mode
The MiniMap window and the Pan mode enable you to navigate to sections of a workflow without
manipulating the horizontal and vertical scroll bars. The MiniMap window displays the workflow in a
pop out that you can use to navigate the Workflows Canvas. The Pan mode enables you to 'grab' the
Canvas and, using the mouse, choose what portion of the workflow is centered on the Canvas.
This feature enables you to navigate to specific sections of the workflow without manipulating the
horizontal and vertical scroll bars.
The following procedures explain how to
l

Navigate the Workflows Canvas using the MiniMap window

l

Navigate the Workflows Canvas using the Pan mode

To navigate the Workflows Canvas using the MiniMap window
1. Click IVR Routing=>Workflows, and select a workflow.
2. Click the MiniMap button, located to the right of the plus sign at the bottom of the workflow.
3. Click and drag the highlighted section over the workflow, as it appears in the MiniMap window.
4. To exit out of the MiniMap window, click the MiniMap button.
To navigate the Workflows Canvas using the Pan mode
1. Click IVR Routing=>Workflows, and select a workflow.
2. Click the Toggle Pan Mode button, located to the left of the '100%' at the bottom of the
workflow.
The cursor displays as a hand icon.
3. Click anywhere on the Canvas to 'grab', and move the mouse to re-center the workflow.
4. To exit out of Pan mode, click the Toggle Pan Mode button.

Resizing workflows: The Zoom feature
You can adjust how large or small your workflow appears in the Workflows Canvas by manipulating
the slider bar or the plus/minus buttons at the bottom of the Canvas. Using these features, you can
zoom in to focus on precise elements of your workflow, or zoom out to get a bird’s eye view.
Expressed as a percentage, the Zoom feature also determines the size of the highlighted section of
the Overview window. For more information, see "Navigating the Workflows Canvas: The MiniMap
window and the Pan mode" on page 509.

Manipulating all activities in a workflow: The Expand All, Collapse All,
and Restore buttons
You can expand or collapse every activity and its corresponding branches in a single operation by
clicking the Expand All or Collapse All buttons. Clicking the Restore button will return your workflow
to the condition it was in before you expanded or collapsed the activities, enabling you to resume
your work efficiently.
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CUSTOMIZING YOUR IVR ROUTING WORKSPACE
Several enhancements in IVR Routing offer additional options for customizing your workspace. New
workflows open as separate tabs in IVR Routing, freeing up visual space and showcasing individual
workflows on screen. You can open an existing workflow in a tab by double-clicking the workflow, by
right-clicking the workflow and selecting 'Open', or by selecting a workflow and clicking 'Edit'.
The Toolbar, Properties, and Outline panes can be minimized, expanded, or pinned to the
workspace. This enables you to choose how much of your screen is comprised of the workflow
versus configuration panes. These enhancements enable you to customize your workspace and
manage your screen space to better facilitate your work.

CONFIGURING IVR ROUTING
You configure all aspects of IVR Routing in YourSite Explorer.
We recommend you provision your IVR Routing environment in the following order:
1. Media servers - select the media server type and set the media server settings and options.
See "Configuring media servers for IVR Routing" on page 511.
2. Ports and extensions - select the extension type and set extension settings and options.
See "Configuring extensions" on page 512.
3. Hunt groups - select the phone lines associated to each hunt group and configure the
destination point for each hunt group.
See "Configuring hunt groups" on page 516.
4. Workflows - add various activities and configure their properties and order of execution for
incoming calls.
See "Building workflows" on page 522.

VIEWING IVR ROUTING
You can view IVR Routing in two formats: Horizontal and Vertical.
To select a view type
1. Click IVR Routing.
2. In the ribbon, click View.
3. In the Page layout pane, select Horizontal or Vertical.

USING THE IMPORT WIZARD
The Import Wizard enables you to import a .csv file containing ANI, DNIS, Redirect, or Hunt Group
conditions. The .csv file must have individual pieces of information separated by commas or by tabs.
You can prepare a .csv file using Microsoft Notepad or Excel.
For information on importing .csv files using the Import tool, see "Importing a range of devices using
a .csv file" on page 119.

510

Configuring IVR Routing

CHANGING MULTIPLE IVR ROUTING ITEMS AT A TIME
You can change multiple IVR Routing items at a time using the multi-select feature. This feature
saves you from having to make the same change to multiple devices of the same type. If items do
not support the multi-select feature, a notification displays in the UI.
NOTE: Only information common across devices of the same type can be changed in one action.
To change multiple IVR Routing items at a time
1. Click IVR Routing and select an item.
For example, 'Queues'.
2. Select multiple items by holding Ctrl or Shift and clicking the individual items. Clicking 'Ctrl'
enables you to select items one at a time and omit items from selection. Clicking 'Shift'
selects a span of items.
3. Make any changes.
4. Click Save.

Viewing IVR Routing devices by category or type
You can selectively view IVR Routing devices by category or type by applying filters to the device
page. For example, you can view only the contact center’s RAD hunt groups by applying the RAD
filter to the Hunt Groups page.
Multiple filters can be applied at a time, enabling you to selectively view devices by multiple
categories or types. For example, you can view only RAD and Outbound rules by applying these
filters to the Rules page.
The following devices may be viewed by category or type
l

Extensions

l

Hunt Groups

l

Queues

l

Rules

l

Subroutines

l

Variables

l

Workflows

To view variables by category or type
1. Click IVR Routing and select the device.
2. After Filter, select a device category or type from the drop-down list.
NOTE: Filters remain in place until a category is deselected. Selecting ‘None’ removes all
filters.

CONFIGURING MEDIA SERVERS FOR IVR ROUTING
IVR Routing supports 3300 ICP media servers. For more information, see "Adding 3300 ICP media
servers" on page 85.
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CONFIGURING EXTENSIONS
An extension is a telephone system answer point that handles calls. Each extension has a specific
extension number. A caller to your contact center is presented with options to dial various answering
points. The caller can dial an individual agent at an extension through a queue number.
Following is a list of the four extension types specific to IVR Routing and their functions:
l

RAD port 5020 IP: is used to play RAD (Recorded Announcement Device) messages for
queue announcements.

l

Messaging port 5020 IP: is used to process inbound workflows

l

Outbound port 5020 IP: is used to process Outbound workflows, including Callbacks

l

UPiQ port 5020 IP: is used to process UPiQ (Updated Position in Queue) messages

NOTE:
l

l

l

Any extensions configured on the telephone switch are retrieved during synchronization and
are shown in the extensions list.
IVR Routing uses 5020 IP port as its port type. APPSERVER ports that were used with
Intelligent Queue cannot be transitioned over to IVR Routing. When you install IVR Routing,
you need to create new ports. You cannot reuse ports that were previously used for Intelligent
Queue, but you can delete these ports and reuse the dialable numbers. You can also reuse
existing hunt groups.
The Outbound extension option is only available to clients with IVR Routing Advanced
licensing.

Adding extensions for IVR Routing
To add an extension
1. Click IVR Routing=>Extensions, and click Add.
2. Complete the following fields:
l

Name—type a name for the extension.

l

Reporting/Dialable number—enter a dialable number for the extension.

l

l

Extension type—select the extension use type from the drop-down list.
NOTE: Ensure you select the correct extension type for the port. For example, if you
want the extension to be a messaging port, select Messaging port 5020 IP.
Media server—select a media server from the media server list.
NOTE:
l

l

l

l
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RAD 5020 IP ports and UPiQ 5020 IP ports must be assigned to the same media
server as the queues receiving the RAD and UPiQ messages, respectively.
We recommend you assign Outbound ports to the same media server(s) as the
queues to which callbacks are directed, if the queues are enabled for RAD.

Failover media server–select a failover media server to handle the call load in the
event the primary media server goes offline.
Class of Service–automatically populated based on the Class of Service set earlier in
the Media servers section, if there is a default Class of Service selected for the type of
port you are creating.
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3. Optionally, select Disable real-time monitoring, data collection and call handling on
this device.
NOTE: This option is only used to unlicense the port and discontinue its use. Unlicensed
extensions can be assigned to a workflow but will not go into service or be visible in Contact
Center Client.
4. Configure the Port Options as follows:
l

l

l

l
l

l

l

After Workflow, click the Browse button and select the workflow to associate to the
extension.
NOTE: UPiQ ports do not allow you to select a workflow. Instead, you engage UPiQ
ports by assigning an UPiQ subroutine to the Connect to Caller activity. See
"Configuring the Connect to Caller activity" on page 579.
After Port State, select either Normal or Emergency from the drop-down list.
Select 'Emergency' as the port state only if this port is associated to a workflow that is
configured to have an emergency path. You can configure a port state as 'Emergency'
when applicable either within YourSite Explorer directly or by using a Management Plan
remotely.
Select the Trusted Service Level check box to set the service level for the 5020 IP
port to 'trusted'. This step is necessary if you are using MCD 5.0 or greater; otherwise,
do not select this check box.
NOTE: In order to set the trusted service level in YourSite Explorer, you must have
already enabled write-back functionality on the media server. (See "Enabling write-back
functionality" on page 89). If you do not have write-back enabled, you must set the
trusted service level on the telephone system, instead of in YourSite Explorer, by
logging in to the 3300 ICP, navigating to 'User and Device Configuration', clicking the
extension for which you want to set the service level, and, on the Profile tab, selecting
'Trusted' from the drop-down list beside Service Level.
Select the This is a remote port check box if applicable.
After Remote Server, if this is a remote port, click the Browse button and select the
remote media server on which IVR Routing is configured.
After MiTAI / MiAudio Local Binding IP Address, select the appropriate IP address
from the drop-down list.
NOTE: This option is used if you have more than one NIC and want to specify which
one is used for MiTAI/MiAudio, for example, if you have a voice and data network split.
The Port License area details how many IVR Routing port licenses remain and the
total number of primary and redundant ports for which you are licensed.

5. Click Save.
NOTE: If, after you configure and save the extension, it does not come in to service, check to
see if the appropriate services are installed and running. For Inbound and RAD ports, the
appropriate service is the prairieFyre Routing Inbound Service. For UPiQ ports, the
appropriate service is the prairieFyre UPiQ Routing Service. For Outbound ports, the
appropriate service is the prairieFyre Routing Outbound Service. If you discover the service is
not installed, it may be that you were not licensed for IVR Routing at the time of installation. If
that is the case, re-run the Mitel Contact Center Configuration Wizard to reinstall the required
Routing services.
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Deleting extensions
NOTE: You cannot delete an extension if it is associated to a hunt group.
To delete an extension
1. Click IVR Routing=>Extensions.
2. Select the extension and click Delete.
3. When prompted, click OK.

Using Extension Quick Setup
The Extension Quick Setup enables you to import extensions into YourSite Explorer from the
telephone switch. If Read/Write is enabled in 'YourSite=>Media servers=>Telephone system', the
extensions are written back to the 3300 ICP.
To use quick setup to create extensions
1. Click IVR Routing=>Extensions, and click Quick Setup.
2. After Active number from, specify the first dialable number of the extension range.
3. After Active number to, specify the last dialable number of the extension range.
4. After Name prefix, enter the text you want prefixed to the name of the port.
5. After Name postfix, enter the text you want postfixed to the name of the port.
6. On the General tab, configure the Media server options as follows:
l

l

l

l

l

Extension type: Select the extension type from the drop-down list.
NOTE: Ensure you select the correct extension type for the port. For example, if you
want the extension to be a messaging port, select Messaging port 5020 IP.
Associate the devices to this media server: If you want to configure your ports to be
resilient, click the Browse button, select a failover media server from the list, and click
OK.
Associate the devices to this failover media server: Click the Browse button,
select a failover media server from the list, and click OK.
NOTE: The failover media server will be used to handle the call load in the event the
primary media server goes offline (only for voice extensions).
Class of service: This field is automatically populated based on the Class of Service
set during media server configuration, if there is a default Class of Service selected for
the type of port you are creating.
Disable real-time monitoring, data collection and call handling on this device: If
you want to disable real-time monitoring, data collection, and call handling for this
extension, select this check box.
NOTE:
l

l

Selecting this option unlicenses the port and discontinues its use. Unlicensed
extensions can be assigned to a workflow but will not go into service or be visible
in Contact Center Client.
Any ports created after you become overlicensed will have this option enabled

7. Configure the Port Options as follows:
l
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After Workflow, click the Browse button and select the workflow to associate to the
extension.
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NOTE: UPiQ ports do not allow you to select a workflow. Instead, you engage UPiQ
ports by assigning an UPiQ subroutine to the Connect to Caller activity. See
"Configuring the Connect to Caller activity" on page 579.
l

l

l
l

l

l

After Port State, select either Normal or Emergency from the drop-down list.
Select 'Emergency' as the port state only if this port is associated to a workflow that is
configured to have an emergency path. You can configure a port state as 'Emergency'
when applicable either within YourSite Explorer directly or by using a Management Plan
remotely.
Select the Trusted Service Level check box to set the service level for the 5020 IP
port to 'trusted'. This step is necessary if you are using MCD 5.0 or greater; otherwise,
do not select this check box.
NOTE: In order to set the trusted service level in YourSite Explorer, you must have
already enabled write-back functionality on the media server. (See "Enabling write-back
functionality" on page 89). If you do not have write-back enabled, you must set the
trusted service level on the telephone system, instead of in YourSite Explorer, by
logging in to the 3300 ICP, navigating to 'User and Device Configuration', clicking the
extension for which you want to set the service level, and, on the Profile tab, selecting
'Trusted' from the drop-down list beside Service Level.
Select the This is a remote port check box, if applicable.
After Remote Server, if this is a remote port, click the Browse button and select the
remote media server on which IVR Routing is configured.
After MiTAI / MiAudio Local Binding IP Address, select the appropriate IP address.
NOTE: This option is used if you have more than one NIC and want to specify which
one is used for MiTAI/MiAudio, for example, if you have a voice and data network split.
The Port License area details how many IVR Routing port licenses remain and the
total number of primary and redundant ports for which you are licensed.

8. To create an employee for each extension, on the Employee associations tab, select the
Create an employee ID for each extension check box.
9. After Start the employee IDs at, type the first employee ID to associate to this extension.
10. After Increment the employee IDs by, type the increment by which the employee IDs will
increase.
11. Click Run.
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CONFIGURING HUNT GROUPS
A hunt group is a collection of extensions. When a call enters the system and is routed to a hunt
group, the hunt group searches its members for an available extension and directs the call to that
number. Calls are rotated through the hunt group until an available extension is found and the caller
can be connected. Hunt groups can be configured to be resilient, using a failover media server if the
primary server fails.
NOTE:
l

l

l

Any hunt groups configured on the telephone switch are retrieved during synchronization and
are shown in the hunt group list.
IVR Routing does not support the configuration of Network Hunt Groups. To use Network
Hunt Groups, create the hunt group on your telephone system and synchronize YourSite
Explorer. The Network Hunt Group will be available in YourSite Explorer after
synchronization. The Network Hunt Group can then be associated to a workflow. Support for
configuring Network Hunt Groups is scheduled to be added in a later release.
For information on enabling ports shared by hunt groups to play different messages to different
queues, see "Dynamic RAD messages" on page 530.

Adding hunt groups
To add a hunt group
1. Click IVR Routing=>Hunt Groups=>Add.
2. Complete the following fields:
l

Name–Type a name for the hunt group.

l

Dialable–Type a dialable number for the hunt group.

l

l

l

l

Media Server–Click the Browse button, select a media server from the list, and click
OK.
Failover media server—Click the Browse button, select a failover media server from
the list, and click OK.
Class of Service– This field is not mandatory. However, the field may be automatically
populated based on the class of service for the selected media server.
Hunt Group Type–Select the type of extensions for this hunt group:
l

Voice– handles messaging type extensions

l

RAD – handles RAD type extensions

l

Phantom – performs modified DND rerouting

l

Voice Mail – handles voice mail type ports

l

HCI Reroute – enables external applications to tell the system how to route calls

l

Recorder – handles groups of devices using the Record-A-Call feature

l

Emergency – identifies the group as an Emergency Call notification hunt group

l

l
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Name Tag – identifies the group as using destination-based name tags for
display on the ringing sets

Hunt Group Mode–Select Terminal if you want the first line in the hunt group list to
always be used, Select Circular if you want the next line in the hunt group to be used.
NOTE: RAD hunt groups must be terminal.
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l

l

l

Priority–Specify the hunt group priority level. The priority level ranges from 1 (highest)
to 64 (lowest).
Phase timer ring– This option is only configured if you are using a RAD hunt group
type and determines the delay required between successive recorded announcements
If no delay is required, select '0'.
Optionally, select Disable real-time monitoring, data collection and call handling
on this device.
NOTE: If selected, this option disables the hunt group. Deselecting the check box
enables the hunt group.

3. Click Save.

Adding extensions to hunt groups
Hunt group members are extensions. To be a member of a hunt group, the extension and the hunt
group must be of the same type. For example, you can only add RAD extensions to RAD hunt
groups.
To add an extension to a hunt group
1. Click IVR Routing=>Hunt Groups, and select a hunt group.
2. On the Membership tab, under Available members, select the extension to add to the hunt
group.
NOTE: The Available members pane only displays extensions belonging to the same media
server as the hunt group. Available members are also filtered by hunt group type.
3. Click the > button.
The extension displays in the Selected members window and is now part of the hunt group.
NOTE:
l

l

If you have assigned the hunt group a Terminal Mode, extensions are searched in
chronological order and the first available extension is selected first. See "Adding hunt
groups" on page 516. If you have assigned the hunt group a Circular Mode, extensions
are searched in the order in which they appear in the Selected members pane.
If your workflow uses Dynamic RAD messages, configure each hunt group to begin its
search starting on different extensions. You do this by changing the order in which
extensions appear in the Selected members pane for each hunt group. For more
information on Dynamic RAD messages, see "Dynamic RAD messages" on page 530.

4. Repeat these steps for all additional extensions you want to add to the hunt group.
5. If your contact center uses a remote configuration, click the Interleave button to distribute the
hunt group members equally throughout your servers.
6. Click Save.
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Configuring hunt group IVR settings
Configuring hunt group IVR settings enables you to associate hunt groups to workflows and set the
state of ports associated to the hunt group.
To configure hunt group IVR settings
1. Click IVR Routing=>Hunt Groups, and select a hunt group.
2. Click the Options tab.
3. To associate the hunt group to a workflow, after Workflow click the Browse button, select a
workflow, and click OK.
4. To set the state of the port associated to the hunt group, after Port State, select either
Normal or Emergency from the drop-down list.
NOTE: If ports are dialed directly, the port's state (Normal or Emergency) is executed. If the
port is associated to a hunt group and the hunt groups is dialed directly, the port takes on the
state configured here.

Deleting hunt groups
To delete a hunt group
1. Click IVR Routing=>Hunt Groups.
2. Select the hunt group and click Delete.
3. When prompted, click OK.

CONFIGURING QUEUES
A queue consists of a group of agents or extensions responsible for answering calls pertaining to a
specific product, service, department, or functional area within your organization. Agents and
extensions can be members of multiple queues, handling calls for multiple departments, services
etc., depending on agent or extension availability. For information on adding queues, see "Adding
queues" on page 142.
IVR Routing adds the ability to configure callbacks, associate UPiQ workflows, and configure
RAD messages for queues. For information, see "Configuring callbacks" on page 535, "Configuring
UPiQ options" on page 520, and "Configuring RAD messages for queues" on page 520.
NOTE: Any queues configured on the telephone switch are retrieved during synchronization and are
shown in the queues list.

Configuring Inqueue routing
You can select Inqueue workflows, such as the Default UPiQ Inqueue workflow, to run when a call
enters into a queue. You can build your own workflow in the Workflows Canvas or you can associate
an Inqueue workflow to the queue. For information on building workflows, see "Building workflows"
on page 522.
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Inqueue workflows containing Connect to Caller activities require UPiQ ports provisioned for the
system. Associating these workflows to queues without having UPiQ ports returns a validation error
when saving the workflow or queue. To provision UPiQ ports for the system, see "Adding extensions
for IVR Routing" on page 512.
For information on the Default Inqueue and Callback workflows, see "IVR Routing default workflows
and subroutines" on page 627.
NOTE: Inqueue workflows cannot be associated to ring groups.
The following procedures explain how to:
l

Add and associate a new Inqueue workflow to a new queue

l

Add and associate a new Inqueue workflow to an existing queue

l

Associate an existing Inqueue workflow

l

Remove an association to an Inqueue workflow

To add and associate a new Inqueue workflow to a new queue
1. Select a voice queue and click Routing.
2. Click the Add button.
The default Inqueue workflow is added to the queue.
3. Configure the Inqueue workflow.
For procedures, see "Building workflows" on page 522.
4. Click Save.
To add and associate a new Inqueue workflow to an existing queue
1. Select a voice queue and click Routing.
2. Click the Browse button and click Add.
3. Configure the Inqueue workflow.
For procedures, see "Building workflows" on page 522.
4. Click Save.
To associate an existing Inqueue workflow
1. Select a voice queue and click Routing.
2. Click the Browse button.
3. Select a workflow and click OK.
4. Click Save.
To remove an association to an Inqueue workflow
1. Select a voice queue and click Routing.
2. Click the Clear button.
3. Click Save.
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Configuring UPiQ options
Updated Position in Queue (UPiQ) messages inform customers of their initial queue position and
dynamically continue to inform them of their position in queue and estimated wait time.
NOTE: UPiQ is not available for ring groups.
In Version 7.1, UPiQ messages are configured via the default UPiQ subroutine and a default Inqueue
workflow. We recommend you configure UPiQ messages by reconfiguring the default workflow and
subroutine. See "IVR Routing default workflows and subroutines" on page 627. For information on
adding Expected Wait Time announcements to UPiQ subroutines, see "Playing Expected Wait Time
announcements" on page 520

Playing Expected Wait Time announcements
By default, the Default UPiQ subroutine only provides Updated Position in Queue announcements.
Expected Wait Time announcements can be added to UPiQ subroutines through the addition of a
Play activity with the Expected Wait Time prompt to an UPiQ subroutine.
The following procedures take place in an open UPiQ subroutine.
To add an Expected Wait Time announcement to a UPiQ subroutine
1. Add a Play activity to the subroutine.
2. Select the Play activity and click Properties.
3. After Greeting Prompts, click the ▼ button and select Select from an existing prompt.
4. Select Expected wait time and click OK.
5. Click Save.

Configuring RAD messages for queues
RAD messages are associated to queues and can broadcast to up to 50 callers in the queue. After a
call is received and has traveled through a workflow to a queue, RAD messages can be configured
to play at programmed intervals for all callers in that queue. Up to four RAD messages can be
associated to each queue. A typical RAD message may greet the caller and thank them for holding.
RADs have been optimized in Contact Center Solutions to minimize the number of RAD devices
that IVR Routing requires. Previously, RADs were mapped to a specific queue and its position.
RAD optimization enables you to reduce the number of ports your system uses by configuring one
port to play a message simultaneously to multiple queues.
Note that UPiQ and RAD messages are both played to callers in queue. If an UPiQ message plays,
the RAD timers reset to prevent both types of messages playing at once.
NOTE:
l

A minimum of MCD 5.0 is required for RAD optimization to function.

l

Ring groups cannot have RAD messages configured through IVR Routing.

To configure RAD messages for a queue
1. Click IVR Routing=>Queues, and select a queue from the list.
2. Click the 3300 ICP options tab.
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3. Under Recording announcement options, specify the following RAD messaging options:
l

l

l

l

l

l

Dialable— click the Browse button and enter the dialable number of the port or hunt
group you want to use to play the RAD message
Start delay—specify the time that must pass after a caller enters the queue or from
when the last message finished playing before playing the RAD message
Interflow dialing list—select the interflow dialing list you have configured on the
telephone system
Release digit receiver after recording—select to limit callers to entering digits only
while the RAD message is playing. If this option is not selected, the caller may still
enter digits as prompted by the RAD after the RAD completes.
Embedded music source—select the in-queue music list you have configured on the
telephone system
Alternative dialable—enter a secondary port or hunt group you want to use to play the
RAD message

4. If you want to repeatedly play the RAD message, select Repeat recording enabled and
specify the repetition interval.
5. After Repeat recording interval, specify the intervals at which the RAD message repeats.
6. After DTMF Receiver Unavailable Action, specify the action when a dial out from a RAD is
programmed but no DTMF receiver can be seized to enable that functionality.
l

l
l

Play recording—plays a RAD message. The caller may be prompted with the option
to dial out
Skip—does not play a RAD message but leaves the caller in the queue
Divert—transfers the caller to the number programmed in the DTMF Receiver
Unavailable Answer Point Directory Number field

7. After DTMF Receiver Unavailable Answer Point Dialable, enter the desired directory
number. For numbers longer than seven digits, program this field as a speed call.
NOTE: To use the DTMF Receiver Unavailable Answer Point Dialable option, the DTMF
Receiver Unavailable Action field must be set to 'Divert'.
8. Click Save.

CONFIGURING QUEUE GROUPS
IVR Routing can use virtual queue groups to provide resiliency to destinations within workflows. For
activities with queue destinations such as Transfer, virtual queue groups can be used as well. When
a virtual queue group is used with an activity, any time IVR Routing attempts to route to the virtual
queue group, it will route to the queue located on the same media server as IVR Routing. In the event
that queue is unavailable, the least busy queue in the virtual queue group is used.
For IVR Routing devices or activities that use queue conditions, both reporting queue groups and
virtual queue groups can be used. For queue conditions, a virtual queue group will be treated as a
single queue. Reporting queue groups will use a sum of their stats when used for queue conditions.
For more information on how each type of queue group handles real-time queue statistics, see "Realtime queue conditions and queue groups" on page 607.
For more information on configuring queue groups, see "Adding queue groups" on page 155.

521

Contact Center Solutions User Guide

BUILDING WORKFLOWS
Workflows are the pathways callers use to reach areas and individuals in your organization.
Workflows dictate the prompts callers hear, the inputs requested by the system, and the available
routing options. Workflows can identify customers and determine their service needs by phone
number, numbers dialed, and the digits entered to reach specific areas of your organization. Proper
workflow configuration is necessary to direct callers to the agents, departments, and employees
best qualified to handle their requests.
The following sections explain workflows available in IVR Routing, and general workflow
configuration procedures.
NOTE:
l

l

l

The functions performed when a caller contacts your organization depend on the activities
included in the workflow and how the activities are configured. For more information, see
"Activities" on page 555.
If your contact center routinely handles a high volume of calls, for optimal traffic handling, we
recommend using subroutines in your workflows or increasing the number of available ports
for your workflows. For more information on subroutines, see "Building subroutines" on page
534.
Workflows must be associated to an extension, hunt group, or queue in order to go live in the
system. For more information, see "Associating workflows to devices" on page 529.

Workflow types
Workflows are categorized into four types.
l

l

l
l

Inbound—directs incoming calls to the agents, departments, and employees best qualified to
handle their requests.
Outbound—makes outgoing calls to external and internal numbers. Once connected, an
Outbound workflow can play the connected party a greeting or ask them to enter information
into IVR Routing. Outbound workflows can also transfer a connected party to a queue, agent,
or extension automatically or based on responses to an option menu.
NOTE: Outbound workflow and extension options in YourSite Explorer are only available with
IVR Routing Advanced licensing.
RAD—plays RAD messages to all callers in their associated queues
Inqueue—determines the conditions for routing calls in queue to agents. Examples include
when to overflow calls to different queues, when to requeue a call, when to interflow calls to
different agent groups, and when to transfer calls to available agents. Inqueue workflows are
executed once calls have been delivered from the Inbound workflow to their queue
destinations.

Each workflow type offers a specific selection of IVR Routing activities with which to build the
workflow. For more information, see "Activities" on page 555.

522

Configuring IVR Routing

Workflow examples
The following workflow examples illustrate common call routing scenarios.
Example 1 — ANI routing
The ANI routing example shows a workflow that routes calls based on the phone number of the
customer contacting your company. Incoming calls are answered and, based on configured
telephone routing rules, routed to the Sales department in the incoming call's country of origin. (See
Figure 114.)

Figure 114: ANI routing workflow example
Example 2 — DNIS routing
The DNIS routing example shows a workflow that routes calls to separate product lines based on the
toll-free line dialed by the customer. Incoming calls are answered and, based on the toll-free number
dialed, routed to the queue responsible for handling call requests for that product line. (See Figure
115.)
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Figure 115: DNIS routing workflow example
Example 3 — Schedules and Menus
The schedules and menus routing example shows a workflow that first routes calls through a
schedule. This determines the system's action based on the date and time that the call arrived. If
within business hours, the workflow provides a user menu to the caller. If outside business hours,
the caller hears an after hours greeting, after which the system terminates the call. (See Figure 116.)

Figure 116: Schedules and menus workflow example
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Example 4 — Collected Digits
The premium collected digits workflow example shows a workflow that routes calls based on the
extension number inputted by the caller. The call is answered and the caller is prompted to enter the
extension number of the party they want to reach. The call is routed based on the digits collected.
(See Figure 117.)

Figure 117: Collected digits workflow example

Adding new Inbound, Outbound, RAD, and Inqueue workflows
The following explains the procedure for adding new workflows to IVR Routing. For examples of
workflows that ship with IVR Routing, see "IVR Routing workflow samples" on page 639, and "IVR
Routing default workflows and subroutines" on page 627.
For information on using Dynamic RAD messages in workflows, see "Dynamic RAD messages" on
page 530.
To create a workflow
1. Click IVR Routing=>Workflows.
2. Click Add=>Mitel Voice, and select either Inbound, Outbound, RAD, or Inqueue.
3. In the Properties pane, type a Name for the workflow. The Name must be unique.
4. Type a System Name for the workflow. The System Name must be unique.
5. To disable validation, enabling you to save a workflow with configuration errors, deselect the
Validate workflow check box.
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6. Select the Designer tab and, from the Toolbox, drag and drop activities to the Workflows
Canvas.
NOTE: Inbound and RAD workflows must begin with an Answer activity if you intend to play a
message or collect digits. Inbound, Outbound, and RAD workflows must end with a Hang Up
activity if they do not end with a Transfer activity.
7. To assign the workflow to an extension, hunt group, or queue, see "Associating workflows to
devices" on page 529.
NOTE: All workflow configuration errors must be corrected before workflows can be assigned
to devices. For more information, see "Troubleshooting workflow configuration with the
Validation button" on page 568.
8. Click Save.

Naming workflows
For administrative and reporting purposes, you must give workflows unique names and system
names. A system name is used by IVR Routing to identify the workflow and is used in reporting. A
name labels the workflow for the user.
To name a workflow
1. Click IVR Routing=>Workflows.
2. Select the workflow and click Properties.
3. Type a Name for the workflow. The Name must be unique.
4. Type a System Name for the workflow. The System Name must be unique.
5. Click Save.

Copying workflows
You can reuse existing workflows as templates by copying them. A copied workflow retains all of the
actions, menus, and conditions of the original workflow, but is not assigned to any device.
To copy a workflow
1. Click IVR Routing=>Workflows.
2. Right-click the workflow and select Copy.
3. Right-click anywhere in the workflow list and select Paste.
4. Click Save.

Cutting, pasting, and copying workflow items
You can cut, paste, and copy activities and branches via the right-click menu, within and between
workflows. This functionality enables you to create and edit workflows efficiently by duplicating, or
removing, activities and branches and their configuration.
NOTE: Some activities are specific to workflow types. For example, an ANI activity is used in
Inbound workflows but not Inqueue workflows. Some branches are specific to activity types. For
example, the Record activity has a Discard branch, but the ANI activity does not. Only cut and paste
activities and branches into the appropriate workflow and activity types.
To cut an activity or branch from a workflow
l
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To paste an activity inside a workflow
1. Right-click the activity and select either Copy or Cut.
2. Right-click the activity that will precede the pasted activity, and select Paste.
To paste a branch inside an activity
1. Right-click the branch and select either Copy or Cut.
2. Right click a different branch inside the activity and select Paste.
The copied branch is inserted to the right.

Deleting workflows
To delete a workflow
1. Click IVR Routing=>Workflows.
2. Select the workflow and click Delete.
3. When prompted, click OK.

Importing and exporting subroutines and workflows
IVR Routing enables you to import and export subroutines and workflows from, and to, machines
and networks. Imported subroutines and workflows are automatically converted to IVR Routing's
latest version. Exported subroutines and workflows can be saved to local hard drives and copied to
computers and networks.
After importing a subroutine or workflow, please note the following
l

l

Subroutines and workflows must be validated and any configuration errors corrected in order
to go live
See "Troubleshooting workflow configuration with the Validation button" on page 568.
Workflows must be connected to devices specific to your system in order to go live
See "Associating workflows to devices" on page 529.

In addition, please see "Recommended practices for importing workflows and subroutines" on page
528.
To import a workflow
1. Click IVR Routing=>Workflows.
2. Click the Import button, browse to the workflow .xaml file and click Open.
3. Click Save.
To export a workflow
1. Click IVR Routing=>Workflows.
2. Click the Export button, browse to the workflow .xaml file and select it.
3. Browse to the workflow save location and click Save.
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Recommended practices for importing workflows and subroutines
Activity availability varies by workflow and subroutine type. However, YourSite Explorer does not
currently restrict where users import workflows and subroutines.
To ensure workflows and subroutines execute as expected, users should adhere to the following
guidelines.
l

l

Only import IVR Routing subroutines into 'IVR Routing=>Subroutines'. Do not import
subroutines into 'IVR Routing=>Workflows'.
If your contact center uses IVR Routing and Multimedia Contact Center, only import IVR
Routing workflows and subroutines into 'IVR Routing=>Workflows' and 'IVR
Routing=>Subroutines', respectively. Do not import IVR Routing workflows into
'Multimedia=>Workflows', and do not import IVR Routing subroutines into
'Multimedia=>Subroutines'.

Please review the list of workflows in IVR Routing to ensure subroutines are not listed. Please
review the list of workflows in 'IVR Routing' in YourSite Explorer and, if applicable, 'Multimedia' to
ensure each pane displays application-appropriate workflows.

Saving and copying workflows as images
You can save snapshots of workflows as images in JPG, PNG, GIF, and XPS formats. You can
also copy and paste workflow images onto the clipboard, to paste into other programs. Saving or
copying workflows enables you to easily reference, share, and print your workflow designs.
Once saved, some portions of large workflows may not display clearly in the image
To save and copy a workflow as an image
1. To save a workflow as an image, right-click on the active portion of the Workflows Canvas
and select Save As Image....
2. Select a location and a format for saving the image.
3. To copy a workflow as an image, right-click on the active portion of the Workflows Canvas
and select Copy as Image.
4. You can paste this image into a word-processing or image editing program.

Locating workflow items with the Search field
You can locate specific activities and branches in workflows using the Outline pane’s Search field.
The Search field returns results based on workflow items’ names and system names.
Searches can be performed based on complete or partial search terms. For example, searching
‘sched’ will return results for all workflow items containing ‘Schedule’ in the name or system name.
After locating an item in the Search field, you can edit the item either by right-clicking it, toggling to
the Properties pane, or right-clicking the item on the Canvas.
To locate workflow items using the Search field
1. Click IVR Routing=>Workflows.
2. Select a workflow and click Outline.
3. In Search Outline, type the search term and click the Search icon.
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Associating workflows to devices
Workflows must be associated to a device in order to go live in the system. Workflows can,
depending on their type, be associated to extensions, hunt groups, or queues.
You can only associate workflows to extensions or hunt groups that are of the same type as the
workflow. For example, you cannot associate a RAD workflow to an Outbound extension type.
After associating Outbound and Inqueue workflows to a device, the ‘Always run' check box in the
Workflows and Properties pane enables and disables workflow execution.
The following workflow types may be associated to the following devices. (See Table 41.)
Table 41: Workflows and associated devices, by type
WORKFLOW TYPE

DEVICE TYPE

Inbound

Extension or Hunt Group

Outbound

Extension

RAD

Extension or Hunt Group

Inqueue

Queue

NOTE: Inbound and RAD workflows may be assigned to an extension and a hunt group. We
recommend you use one or the other.
The following procedures explain how to
l

Associate a workflow to an extension

l

Associate a workflow to a hunt group

l

Associate a workflow to one or more queues

To associate a workflow to an extension
1. Click IVR Routing=>Extensions, and select an extension to associate to the workflow.
NOTE: For IVR Routing sample workflows, you must select an extension with a Messaging
port 5020 IP extension type.
2. Under Port Options, after Workflow, click the Browse button.
3. Select the workflow to associate to the extension and click OK.
NOTE: The 'Select a workflow' window displays workflows of the same type as the
extension, without validation errors.
4. After Port State, select either Normal or Emergency from the drop-down list. Select
Emergency only if this port is associated to a workflow that is configured to have an
emergency path.
5. Click Save.
To associate a workflow to a hunt group
1. Click IVR Routing=>Hunt Groups, and select a hunt group to associate to the workflow.
2. Select the Options tab.
3. Under IVR Settings, after Workflow, click the Browse button.
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4. Select a workflow and click OK.
5. After Port State, select either Normal or Emergency from the drop-down list. Select
Emergency only if this port is associated to a workflow that is configured to have an
emergency path.
6. Click Save.
To associate a workflow to one or more queues
NOTE: Inqueue workflows containing Connect to Caller activities require UPiQ ports provisioned for
the system. Associating these workflows to queues without having UPiQ ports returns a validation
error when saving the workflow or queue. To provision UPiQ ports for the system, see "Adding
extensions for IVR Routing" on page 512.
1. Select IVR Routing=>Workflows, and select an Inqueue workflow.
2. Select the Queue Membership tab.
3. Under Available members, select the queue to associate the workflow to and click >. You
can associate multiple queues to a single workflow.
4. To associate all queues to the workflow, click >>.
5. Click Save.

Dynamic RAD messages
Dynamic RAD messages enable a group of IVR Routing ports, shared by multiple hunt groups, to
play different RAD messages to callers waiting in queue. For example, if hunt groups for a Sales
queue and a Customer Service queue share a port, a workflow using Dynamic RAD messages
enables the shared port to play a Sales greeting to the Sales queue and a Customer Service greeting
to the Customer Service queue. Because Dynamic RAD messaging reduces the number of ports
required to play messages, it is a cost-effective means of tailoring greetings to queues. For more
information on configuring RAD messages for playback, see "Configuring RAD messages for
queues" on page 520.
NOTE:
l

l

To ensure the expected Dynamic RAD functionality, we recommend that you configure each
hunt group to begin its search starting on different extensions. See "Adding extensions to hunt
groups" on page 517.
Dynamic RAD messages can only be used within RAD workflows.

To use Dynamic RAD messages in workflows, you must ensure that
l

l

l

l
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Media server configuration is complete. Dynamic RADs require that all hunt groups,
extensions, and Class of Service options are populated with data from the 3300 ICP. For more
information on configuring media servers, see "Adding 3300 ICP media servers" on page 85.
The Class of Service provisioned in the PBX for Dynamic RADs must have Do Not Disturb
set to Yes. See "Editing Class of Service options" on page 110.
Full Synchronization is completed. For information, see "Performing synchronization" on page
105.
Extension configuration is complete. Dynamic RAD messages require that each IVR Routing
port playing the messages is set to RAD port 5020 IP. You must also enable Trusted Service
Level for the relevant extensions. See "Configuring extensions" on page 512.
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l

l

l

l

l

Hunt group configuration is complete. Dynamic RADs require hunt groups to be configured as
RAD hunt group types and that the appropriate RAD extensions have been added to the hunt
groups you will use in your workflow. See "Configuring hunt groups" on page 516.
If you using are an IVR Routing instance on a Remote Server, ensure that remote
configuration is complete. Dynamic RAD messages require that the relevant ports are
specified as remote ports and assigned to the Remote Server. See "Configuring extensions"
on page 512.
You have configured the necessary prompts for your RAD messages. See "Configuring
prompts" on page 532.
You have associated the workflow to the ports (extensions) that will play the RAD messages
and to the appropriate hunt groups. See "Associating workflows to devices" on page 529.
If you are using multiple, un-teamed NICs, you have selected the appropriate MiTAI Binding
IP address. See "Configuring extensions" on page 512.

For a demonstration on how to build a workflow that uses Dynamic RAD messages, please see the
following Mitel Knowledge Base article:
http://micc.mitel.com/kb/KnowledgebaseArticle51476.aspx.

Building resilient workflows
Many of IVR Routing’s workflow activities and configurations are dynamic, relying upon statistics
and information from the Enterprise Server. In situations where the Enterprise Server is unavailable,
such as during a reboot, the functionality of dynamic workflows is affected. IVR Routing enables
contact centers to build resilient workflows that respond to disruptions in service to the Enterprise
Server, routing calls to alternate branches that are not reliant upon statistics from the Enterprise
Server. Resilient workflows rely on the queue condition statistic Last Queue Update Received and
the system variable CCMOnlineStatus.
The Last Queue Update Received queue condition statistic is available in the Queue Condition
builder for the Queue activity and Rules. In the Queue Condition builder, Last Queue Update
Received is assigned a duration of time (with a minimum duration limit of 30 seconds) that defines
the time that may pass between updates from the Enterprise Server before the statistics are
considered to be stale. This real-time statistic is particularly useful for contact centers that consider
a limited amount of stale statistic data to be acceptable, such as during the length of time it takes the
Enterprise Server to reboot, but may want calls to be routed using the Queue activity to different
workflow paths if the real-time data from the Enterprise Server remains unavailable beyond that
timeframe. For information on configuring rules and Queue activity, see "Configuring rules" on page
546 and "Configuring the Queue activity" on page 604.
The CCMOnlineStatus is a system variable that detects whether or not any real-time data is coming
from the Enterprise Server to the Routing services for IVR Routing. If data is available from the
Enterprise Server, it is set to True. If the Enterprise Server’s real-time data is unavailable, it is set to
False. In conjunction with the Variable Compare activity, calls can be routed down the appropriate
True and False branches immediately if the availability of data from the Enterprise Server changes.
For information on the Variable Compare activity, see "Configuring the Variable Compare activity" on
page 624.
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CONFIGURING PROMPTS
Prompts are audio clips that provide callers with information during a call. Associated with activities,
prompts play messages when callers reach the associated activity in a workflow. Prompts can be
individual wave files or multiple wave files joined together to form custom messages. To see a list of
pre-configured prompts, go to 'IVR Routing=>Prompts'.
The default language for prompts will be taken from the site language and workflows will be executed
in that language unless a Language activity has been included in the workflow. Individual prompts
can be configured to handle multiple languages, working with the Language activity to support
multiple languages in a single workflow. This reduces the number of prompts that must be created
and allows for the same set of ports to be used for multiple languages. For more information on the
Language activity, see "Configuring the Language Activity" on page 591.
If you want to use your own custom prompts with a callback, you must add your wave files by
importing the files or recording wave files using a microphone on your computer or your telephone
using a Record activity in a workflow. You must then associate your custom wave files to your
callback workflow. See "Configuring callbacks" on page 535 for more information.
NOTE: Agent prompts cannot be configured to play in a language that is different than the language
selected as a preference in Contact Center Management. Agent language preference settings
override agent prompt language choices as IVR Routing aligns with agent language settings.

Adding prompts
NOTE: If you are adding prompts in a new language, you must add audio files that correspond to the
existing audio files in IVR Routing's default language. Otherwise, the caller will not hear anything
when the prompts are supposed to be playing.
To add a prompt
1. Click IVR Routing=>Prompts=>Add.
2. After Language, select the primary language from the drop-down list.
NOTE: By default, the language is set to your default site language.
3. Type a Name for the prompt.
4. Type a Description for the prompt.
5. After Category, select one of the following categories from the drop-down list:
l

Callback

l

Management

l

Samples

l

UPiQ

l
Custom
Prompt categories are an organizational tool to help keep your prompts sorted and easily
accessible. To create your own category, after Category, type a name for the new category.
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6. Click one of the following tabs:
l

l

l
l

l

System wave files—lists the system wave files callers hear while in the system or
while waiting on hold. This pane displays the wave files that are available in your
selected language.
Custom wave files—lists imported and wave files you have recorded. To import or
record a custom wave file, click Add. Select Existing wave file to import the file, or
Record wave file to use your computer's microphone to record the file.
NOTE: Wave files must be 8khz, Mono, or ULAW format.
Queue stats—lists up-to-date queue statistics that can be used in prompts
Variables—lists variables that can be used in prompts
NOTE: Read back on variables is based on the type of variable. Number variables read
back the whole number, while digit variables read back individual numbers. For
example, number variables would read 123 as 'one hundred and twenty-three', while
digit variables would read 123 as 'one, two, three'.
Prompts used in workflows and subroutines—lists all prompts used in workflows
and subroutines

7. In the All system wave files, All custom wave files, All queue stats, All variables, or
Prompts used in workflows and subroutines pane, select the file(s) you want to add to the
prompt.
8. Click > to add the file to the prompt.
NOTE: The wave files play in the order they are added to the prompt. To change the order in
which the wave files are played, select the wave file and click the up or down arrow buttons on
the right-hand side of the dialog box.
9. Click Save.

Adding files, queue statistics, or variables to prompts
NOTE: Variable readback is only available for numerical variables.
To add files, queue statistics, or variables to a prompt
1. Click IVR Routing=>Prompts, and select the prompt.
2. Click either the System wave files, Custom wave files, Queue stats, or Variables tab.
3. Select either the file, queue stat, or variable to add to the prompt and click >.
4. Click Save.

Deleting prompts
To delete a prompt
1. Click IVR Routing=>Prompts.
2. Select the prompt and click Delete.
3. When prompted, click OK.

Playing prompts
The following explains how to
l

Play a prompt

l

Play an individual or selection of wave file in a prompt
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To play a prompt
1. Click IVR Routing=>Prompts, and select the prompt to play.
2. Click Play.
To play an individual or selection of wave file in a prompt
1. Select the prompt you want to play from the prompt list.
2. Select the System save files or Custom wave files tab.
3. Select the wave file(s) to play.
4. Click Play.

Using Prompts Quick Setup
Quick setup enables you to import previously created wave files.
To use quick setup to import prompts
1. Click IVR Routing=>Prompts=>Quick Setup.
2. After Folder Path, click Browse....
3. Browse to the folder containing the wave files and click OK.
4. After Language, select the primary language from the drop-down list.
NOTE: By default, the language is set to your default site language.
5. Click Run.

BUILDING SUBROUTINES
Subroutines are portions of workflows that can be reused in multiple workflows. Subroutines create
common workflow activity groups that can be easily reused, encapsulating common activity groups
in one single activity. Subroutines can be reused across workflows or within a single workflow,
which helps keep workflows manageable and enables rapid workflow creation. They also facilitate
workflow updates by requiring only one change to affect all workflows that use the subroutine.
With a few exceptions, subroutines and workflows function almost identically. Subroutines are
configured as Inbound, Outbound, RAD, Management, UPiQ, and Callback Inbound. Subroutines
are configured using activities, with specific activities available to each type of subroutine. This
enables you to use subroutines to access activities not normally available to your workflow type.
While all workflows are associated to ports or hunt groups, however, subroutines are contained
within workflows and are not associated to ports or hunt groups.
To build a subroutine
1. Click IVR Routing=>Subroutines.
2. Click Add=>Mitel Voice, and select either Inbound, Outbound, RAD, Management, UPiQ
or Callback Inbound.
3. In the Properties pane, type a Name for the subroutine. The Name must be unique.
4. Type a System Name for the subroutine. The System Name must be unique.
5. Select the Designer tab and, from the Toolbox, drag and drop activities to the Workflows
Canvas.
6. Click Save.
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Adding subroutines to workflows
You can add subroutines you have built or default subroutines to Inbound, Outbound, RAD, and
Inqueue workflows. For more information on the default subroutines that ship with IVR Routing, see
"IVR Routing default workflows and subroutines" on page 627.
To add a subroutine to a workflow
1. Click IVR Routing=>Workflows, and select the workflow to which you want to add a
subroutine.
2. Click Toolbox, and drag and drop a Subroutine activity onto the Workflows Canvas.
3. Right-click the Subroutine and select Assign Subroutine.
4. Select a subroutine from the list and click OK.
5. Click Save.

Deleting subroutines
NOTE: You cannot delete a subroutine that is added to a workflow. Remove the subroutine from any
workflow to which it is added, then delete the subroutine.
To delete a subroutine
1. Click IVR Routing=>Subroutines.
2. Select the subroutine and click Delete.
3. When prompted, click OK.

CONFIGURING CALLBACKS
Callbacks are specialized workflows and subroutines that enable customers to leave a request for a
return call (callback) from the contact center. These requests sit in queue like a call and offer the
agents the ability to call back the customer. For more information about the workflows and
subroutines that enable your contact center to offer callbacks, see "Default callback workflow and
subroutines" on page 631.
For callbacks to function correctly, you must have configured location settings for your media server.
If location settings are not configured, your callbacks will not be able to contact your customers. See
"Configuring location settings for 3300 ICP media servers" on page 87.
Three kinds of callbacks are available with IVR Routing.
l

l

l

Abandon—Abandon callbacks are automatically generated when a customer hangs up while
still in a queue, enabling contact centers to contact callers who might have otherwise been
missed. Abandon callback subroutine workflows are enabled system-wide. For information
about adding abandon callbacks to queues, see "Enabling abandon callbacks" on page 537.
Voice—Voice callbacks are initiated by the customer. The customer’s call is removed from
the queue and a callback request is resubmitted to the queue. This option can be provided by
including a Callback Request in a workflow. For an overview of the default inbound voice
subroutine workflow, see "Default Inbound Voice Callback subroutine" on page 636.
Web—Web callbacks enable customers to submit callback requests using a website,
removing the need for customers to call the contact center in order to be placed in queue to
speak to an agent. For information about enabling web callbacks, see "Enabling web
callbacks" on page 539.
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Supervisors can monitor and requeue, reject, or delete callbacks using the Global callback monitor in
Contact Center Client and the Callbacks to be processed grid in Interactive Visual Queue. For more
information, see "Viewing callback lists with the Global callback monitor" on page 249 and "Viewing
callback information in Interactive Visual Queue" on page 416.
NOTE: Ring groups do not support handling callbacks. Ring group queues will not be available when
configuring callbacks or their associated workflows. Any callback that is routed to a ring group will
fail.

Enabling callbacks
Voice, Abandon, and Web callbacks are enabled in different ways. Voice callbacks are enabled by
placing a Callback Request activity into a workflow and configuring the activity’s inbound and
outbound workflows and then making the workflow available to a queue through a dial out option. For
more information on the Callback Request activity, see "Configuring the Callback Request activity"
on page 573. For more information about the Default Inbound Voice Callback subroutine, see
"Default Inbound Voice Callback subroutine" on page 636. For more information about the Default
Outbound Callback workflow and the Default Outbound Voice callback subroutine, see "Default
Outbound Callback workflow" on page 631 and "Default Outbound Callback subroutines" on page
632.
Abandon callbacks are disabled by default and must be enabled. Once they are enabled, the
abandon callback settings are applied to all workflows. Individual queues may be configured to use
different abandon callback workflows and queues. For more information on enabling abandon
callbacks, see "Enabling abandon callbacks" on page 537. For more information about the Default
Outbound Callback workflow and the Default Outbound Abandon callback subroutine, see "Default
Outbound Callback workflow" on page 631 and "Default Outbound Callback subroutines" on page
632.
Web callbacks require a webpage to be set up to submit callbacks. IVR Routing includes a template
to use as your web callback submission page. For details of the template and configuring the
template for use, see "Configuring the web callback template" on page 540. After configuring your
web callback submission pages, queues must be enabled to receive web callbacks. "Enabling web
callbacks" on page 539. For more information about the Default Outbound Callback workflow and the
Default Outbound Web callback subroutine, see "Default Outbound Callback workflow" on page 631
and "Default Outbound Callback subroutines" on page 632.
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Enabling abandon callbacks
Abandon callbacks are applied to all queues when enabled. Unless configured with different abandon
callback workflows and destination queues, all queues will use the default abandon callback options.
If no default queue is selected when abandon callbacks is enabled, abandon callbacks will only be
generated for queues that have queue destinations set for their abandon callbacks. By default,
abandon callback requests are only applied to calls that abandon with a time greater than the 'Short
abandon less than' time specified in individual queues, but short abandon callbacks can be enabled
for all queues.
NOTE:
l

l

To duplicate the functionality of the Version 6.0 queue condition builder, place a Queue
activity into your Outbound abandon callback workflow before the Make Call activity, with a
Save Callback activity placed in the No Match branch to requeue the callback request. See
"Default Outbound Callback subroutines" on page 632.
Ring groups do not support abandon callbacks and are not available to be selected for
abandon callback default queues.

The following procedures explain how to:
l

Enable abandon callbacks

l

Change the default Outbound abandon callback workflow

l

Select the default queue

l

Clear the default queue

l

Change the default Outbound abandon callback workflow for a queue

l

Change the abandon callback destination for a queue

l

Clear the abandon callback destination for a queue

l

Disable abandon callbacks

To enable abandon callbacks
1. Click IVR Routing=>Workflows.
2. In the Abandon Callbacks section of the ribbon’s Configuration tab, click the Disabled
button.
3. If there is no default workflow selected, after Default Workflow, click …, select an Outbound
subroutine, and click OK
4. If there is no default queue enabled, after Default Queue, click …, select a queue to be the
default queue, and click OK.
5. If you want to enable Short Abandon Callbacks, select Allow Short Abandon Callbacks.
To change the default Outbound abandon callback workflow
1. Click IVR Routing=>Workflows.
2. In the Abandon Callbacks section of the ribbon’s Configuration tab, after Default
Workflow, click the … button.
3. Select a subroutine and click OK.
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To change the default queue
1. Click IVR Routing=>Workflows.
2. In the Abandon Callbacks section of the ribbon’s Configuration tab, after Default Queue,
click the … button.
3. Select a queue and click OK.
To clear the default queue
1. Click IVR Routing=>Workflows.
2. In the Abandon Callbacks section of the ribbon’s Configuration tab, after Default Queue,
click the Clear button.
To change the default Outbound abandon callback workflow for a queue
1. Click IVR Routing=>Queues.
2. Select a queue and click the General tab.
3. Under Abandon Callback Options, after Workflow Plan, click the Browse button.
4. Select a subroutine and click OK.
5. Click Save.
To change the abandon callback destination for a queue
1. Click IVR Routing=>Queues.
2. Select a queue and click the General tab.
3. Under Abandon Callback Options, after Queue Destination, click the Browse button.
4. Select a queue and click OK.
5. Click Save.
To clear the abandon callback destination for a queue
1. Click IVR Routing=>Queues.
2. Select a queue and click the General tab.
3. Under Abandon Callback Options, after Queue Destination, click the Clear button.
4. Click Save.
To disable abandon callbacks
1. Click IVR Routing=>Workflows.
2. In the Abandon Callbacks section of the ribbon’s Configuration tab, click the Enabled
button.
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Enabling web callbacks
Web callback require both queues enabled to receive web callbacks and a webpage configured to
allow customers to submit callback requests to a contact center.
1. Enable queues to handle web callbacks and set the maximum number of web callbacks an IP
address can submit per hour.
See "Enabling queues for web callbacks" on page 539.
2. Configure an Outbound Web Callback subroutine
3. IVR Routing includes the Default Outbound Web Callback subroutine. You can configure your
own if you so choose. For more information on the Default Outbound Web Callback
subroutine, see "Default Outbound Callback subroutines" on page 632.
4. Configure a web callback request page for your contact center.
See "Configuring the web callback template" on page 540.
5. Enable the web callback page for callbacks
See "Enabling the web callback template for callbacks" on page 543.
If you are running Windows 8, you must ensure that certain .NET Framework 4.5 Advanced
Services are running. For more information, see "Enabling web callbacks for Windows 8 and
Windows 8.1 users" on page 540.

Enabling queues for web callbacks
You must enable queues to handle web callbacks and specify the maximum number of web callback
requests that can be generated by a single IP address per hour. Ring groups do not support handling
web callbacks.
To enable a queue to handle web callbacks
1. Click IVR Routing=>Queues.
2. Select a queue and click the General tab.
3. Select Enable queue for web callbacks.
4. Click Save.
To configure the maximum number of web callback requests that can be generated by a single IP
address per hour
1. Click IVR Routing=>Workflows.
2. In the Abandon Callbacks section of the ribbon’s Configuration tab, under Max Per Hour
Per IP Address, select the number of callbacks that can be submitted from a single IP
address in an hour
3. Click Save.
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Enabling web callbacks for Windows 8 and Windows 8.1 users
If you are running IVR Routing on Windows 8 or Windows 8.1, you must have certain .NET
Framework 4.5 Advanced Services enabled for web callbacks to function.
To enable web callbacks for Windows 8 and 8.1 users
1. In Windows, navigate to the Control Panel.
2. Click Programs and Features=>Turn Windows features on or off.
3. Select the following check boxes:
l

.NET Framework 4.5 Advanced Services
l

WCF Services

l

HTTP Activation

4. Click OK.

Configuring the web callback template
Web callback enables callers to submit callback requests using a callback request page accessed
through a contact center’s website. Callers submit a telephone number, name, and time frame within
which their call should be returned, as well as other optional information, which is then routed to the
contact center.
IVR Routing includes a web callback template for use as the callback request page for your contact
center. Figure 118 shows the web callback template. The web callback template must be manually
configured as a part of your contact center’s corporate website. Experienced web developers can
also use the template to construct their own web callback page.

Figure 118: Template - Default.html
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Viewing the web callback template
The web callback template is stored in a zip file in <installation drive>\Program Files (x86)
\prairieFyre Software Inc\CCM\Websites\CCMWa\WebCallbackTemplate.zip.

Customizing the web callback templates
You can edit elements of the web callback template to meet your contact center’s needs, changing
headers, customizing Cascading Style Sheets (CSS), customizing the available countries for the
template, or even customizing the web callback template content.
Customizing the header
In the templates, Default.html has a header consisting of the text 'Get in touch with us' where you
may insert a company logo or change the text. You can customize these headers for your contact
center.
To customize the header
1. Open Default.html in a text editor.
2. Replace the text with your own text or an image.
NOTE: If you are using Notepad with Default.html, press CTRL+F and type <h1> to locate
the header in the HTML.
3. Save and close the HTML editor.
Customizing the Cascading Style Sheet
The Cascading Style Sheet (CCS) defines how HTML elements are displayed. CCS enables you to
control the style and layout of multiple Web pages all at once.
To customize the CSS
1. Open main.css in a text editor.
2. Edit the heading and body font sizes and styles, or spacing.
3. Click Save.
Customizing the content of the web callback template
You can change the content of the web callback template to reflect your business, however, we do
not recommend changing fields as improper changes will result in a non-functioning webpage. If you
have the experience, expertise, and resources to edit HTML, you can use the templates to build the
webpage you desire, however
Customizing the available countries in the template
By default, the web callback template imports available countries from a web service and populates
them in the web callback template. Contact centers can customize their web callback page to
include only the countries they intend to support callbacks from. To do this, you must obtain the
country GUIDs of the relevant countries from SQL and then add them to Config.js
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To obtain country GUIDs from SQL
1. Open SQL Server Management Studio or another SQL Management program.
2. Query the following select statement:
SELECT [Pkey], [Name] FROM [CCMData].[dbo].[tblConfig_Country]
3. Record the country GUIDs you require.
To customize the available countries in the template
1. Open Config.js in a text editor.
2. Locate the following line of text:
var AutoPopulateCountries = true;
3. Replace true with false
4. To add a country, add the country GUID from the SQL database and the Country name you
want to appear in the drop down in the following format:
<option value=”countryGUID” selected>Country Name in Dropdown</option>
5. If you do not intend to offer web callbacks to Canada, delete <option value="A0A5E01E-13044893-840B-CFC30B65983F" selected>Canada</option>
6. Save and close the text editor.
Customizing the available queues in the template
By default, the web callback template is auto-populated with all the voice queues available for web
callbacks. Contact centers can limit which queues enabled for web callbacks appear in may want to
limit customers to accessing certain queues from a given callback webpage. To do this, you must
obtain the queues’ GUIDs and add them to Config.js.
To obtain a queue GUID from YourSite Explorer
1. In YourSite Explorer, click IVR Routing=>Queues.
2. Select a queue.
3. In the ribbon, click Queue Tools.
4. Click Copy queue ID.
The queue GUID is copied to your clipboard.
To obtain queue GUIDs from SQL
1. Open SQL Server Management Studio or another SQL Management program.
2. Query the following select statement:
SELECT [Pkey], [Name] FROM [CCMData].[dbo].[tblConfig_Queue]
3. Record the country GUIDs you require.
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To customize the available queues in the template
1. Open config.js in a text editor.
2. Locate the following line of text: var AutoPopulateQueues = true;
3. Replace true with false.
4. To add a queue, add the queue GUID and the queue name you want to appear in the drop
down in the following format:
<select name="queue" class="form-control" id="queue">
<option value="queue guid" selected>queue name</option>
</select>
5. Save and close the text editor.

Enabling the web callback template for callbacks
After you create a web callback request page, you need to enable your web callback page to
generate callback requests for your queues. This is done by adding an application pool for web
callbacks and adding web callbacks as an application for your website in IIS and specifying in
config.js which web callback workflow to use. Optionally, the default messages contact receive
after successfully submitting a callback or if their callback request fails to submit can be changed.
Before the procedure, you must have
l

Configured a web callback request page using the template

l

Added the web callback template files into the desired directory

To enable the web callback template for callbacks
1. Add the web callback application pool and configure the application settings
2. Add the web callback as an application to your website
3. Set the Enterprise Server for callbacks
4. (Optional) Change the default web callback subroutine
5. (Optional) Change the default success and failure messages
To add the web callback application pool and configure the application settings
1. Start IIS Manager.
2. Under Connections, select Application Pools.
3. In the Actions pane, select Add Application Pool….
4. Under Name, add a name for the pool.
5. Under .NET Framework version, select the most recent version of .NET Framework 4.5.
6. Under Managed pipeline mode, select Classic.
7. Click OK.
8. Select the Application Pool and in the Actions pane, select Advanced Settings….
9. Configure the settings to match the figure below.

543

Contact Center Solutions User Guide

Figure 119: Web callback Application Pools Advanced Settings
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10. Click OK.
To add the web callback as an application to your website
1. Start IIS Manager.
2. In the Connections pane, navigate to Default Web Site.
3. In the Actions pane, click View Applications.
4. In the Actions pane, click Add Application….
5. Under Alias, provide an alias.
6. Click Select….
7. Select the web callback application pool and click OK.
8. Under Physical path, click … and navigate to the folder containing web.config and click OK.
9. Click OK.
To set the Enterprise Server IP address for callbacks
1. Navigate to config.js and open in a text editor.
2. Locate the following line of text:
var Config.EnterpriseServerAddress = "localhost";
3. Replace localhost with your Enterprise Server's IP address.
4. If the Enterprise Server was configured to use SSL during installation, locate the following line
of text:
var Config.EnterpriseUsingSSL = false;
5. Replace false with true.
6. Save and close the text editor.
To change the default web callback subroutine
1. Navigate to config.js and open in a text editor.
2. Locate the following line of text:
var Config.OutboundCallbackSubroutineID = "B0AA4E0E-A97D-461E-A7F9E32026C1FA40";
3. Replace the value with the GUID of the subroutine from SQL.
The GUID can be obtained from tblConfig_VWM_Subroutine in SQL. See the procedure
below for instructions on how to obtain this information.
4. Save and close the text editor.
To obtain web callback subroutine information from SQL
1. Open SQL Server Management Studio or another SQL Management program.
2. Query the following select statement:
select Pkey,Name from tblConfig_VWM_Subroutine
3. Find your value for your web callback subroutine.
To change the default success and failure message for the web callbacks
1. Navigate to config.js and open in a text editor.
2. Locate the following lines of text:
var Config.SuccessMessage = "Thanks, we will get in touch with you shortly.";
var Config.FailureMessage = "Sorry, we are having difficulties right now. Please try again.";
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3. Replace "Thanks, we will get in touch with your shortly." with the desired message for a
successful callback submission.
4. Replace "Sorry, we are having difficulties right now. Please try again." with the desired
message for a failed callback submission.
5. Save and close the text editor.

CONFIGURING RULES
Rules provide call conditions that are evaluated at the runtime of the workflow. They enable you to
compare against a broad range of conditions in a single workflow activity, reducing workflow clutter
and enabling more precise routing.
In a workflow, rules are assigned to a Rules activity. When an incoming call enters a workflow and
encounters a Rules activity, the call is evaluated against the activity’s associated rules and is
branched based on whether or not the call meets the rule’s routing rules’ conditions. Routing rules
can be based on a number of different conditions:
l

ANI (Inbound, Inqueue)

l

DNIS (Inbound, Outbound, Inqueue)

l

Emergency (Inbound, RAD, Outbound, Inqueue)

l

Hunt Group (Inbound, RAD, Outbound, Inqueue)

l

Queue (Inbound, RAD, Outbound, Inqueue)
NOTE: Ring groups are supported for queue routing rules

l

Redirect (Inbound, Outbound, Inqueue)

l

Schedule (Inbound, RAD, Outbound, Inqueue)

If the call meets the routing rules’ conditions, then it is routed through the Success branch and has
variables set to specific values based on the pre-configured variable options in the rule. If it does not
meet the rule’s routing conditions, then the call is routed through the Failure branch. If the call is
comparing against many routing rules in a single Rules activity, the variables will only be set once,
by the first routing rule matched.
Rules are best used when you want to route calls based on multiple conditions. A site that has a
Monday to Friday, 9 am to 5 pm French language queue and a 24-hour English queue could, using
ANI and Schedule routing rules in a single rule, route calls from French area codes that are calling
within business hours to the French queues and all other calls to the 24-hour English queue.
For more information on the Rules activity for workflows, see "Configuring the Rules activity" on
page 613.
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Adding rules
Routing rules' conditions vary by rules type. See "Configuring rules" on page 546. Note that you
cannot save routing rules until after you add variables to your rules. See "Adding variables to rules"
on page 550.
To add a rule
1. Click IVR Routing=>Rules=>Add.
2. Select either Voice, RAD, or Outbound.
3. Type a Name for the rule.
NOTE: The Expression field is automatically populated when routing rules have been
configured. See "Adding routing conditions to rules" on page 547.

Adding routing conditions to rules
NOTE:
l

l

You cannot save routing rules until after you add variables to your rules. See "Adding variables
to rules" on page 550.
For instructions on grouping rule conditions, see "Grouping expressions" on page 570.

The following procedures explain how to
l

Add an ANI, DNIS, Hunt Group, or Redirect routing condition to a rule

l

Add a Schedule routing condition to a rule

l

Add a Queue routing condition to a rule

l

Add an Emergency routing condition to a rule

To add an ANI, DNIS, Hunt Group, or Redirect routing condition to a rule
1. Under Routing Rules, click Add.
2. From the second column, select one of the following routing rule types from the drop-down list:
l

ANI

l

DNIS

l

Hunt Group

l

Redirect

3. From the third column, click the - button.
4. To add a value, click Add and enter a value for the routing rule.
5. Click the Add button.
6. Repeat the above steps to add additional values to the routing rule.
7. To test values, after Test, type the values. 'Pass' or 'Fail' displays depending on whether the
test is successful.
8. Click OK.
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To add a Schedule routing condition to a rule
1. Under Routing Rules, click Add.
2. From the second column, select Schedule from the drop-down list.
3. From the third column, click the - button.
4. Click Add.
5. Select one of the following conditions from the drop-down list:
l

Date

l

DOW (Day of Week)

l

Holiday

l

Schedule

l

Time

6. Select a value for the condition and click OK.
7. To add more schedule conditions, click Add and repeat the above steps.
8. To test the conditions, under Utilities, enter time and date information and click Test. 'Pass'
or 'Fail' displays depending on whether the test is successful.
9. Click OK.
To add a Queue routing condition to a rule
1. Under Routing Rules, click Add.
2. From the second column, select Queue from the drop-down list.
3. From the third column, click the - button.
4. After Queue, click the ... button.
5. Select either the Queue or the Queue Group tab.
NOTE: For information on how queue groups use queue real-time statistics, see "Real-time
queue conditions and queue groups" on page 607.
6. Select a queue or queue group to add to the condition and click OK.
7. To add a new queue, see "Configuring queues" on page 518.
NOTE: To configure a new queue for web callbacks, see "Enabling web callbacks" on page
539.
8. To add a new queue group, select the Queue Group pane and click Add.
l

After Name, type a name for the queue group.

l

After Reporting number, type a reporting number for the queue group.

l

In the Available members pane, select a queue group and click the > button.

9. Click Save.
10. To add conditions, at the top of the Queue Conditions dialog box, click Add.
11. From second the column, select one of the following real-time statistics from the drop-down
list:
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l

Agents Idle

l

Agents Available

l

Agent Unavailable

l

Avg Time To Abandon
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l

Avg Time To Answer

l

Avg Waiting Contacts per Agent

l

Expected Wait Time

l

Last Queue Update Received

l

Longest Wait Time

l

Number of Contacts Waiting

l

Queue DND

l
Service Level
NOTE: Expected Wait Time requires at least one call waiting in queue for IVR Routing to
calculate an Expected Wait Time value.

12. From the third column, select one of the following operators from the drop-down list. Options
vary according to the realtime statistic selected:
l

! = Not Equal to

l

< Less than

l

<= Equal to or less than

l

= Equal to

l

> Greater than

l

>= Equal to or greater than

13. In the third column, from the drop-down list select either the Value, Queue Stats, or the
Variable tab.
14. Under Value, type in a numeric value or enable the check box for the value.
15. Under Queue Stats, select a queue stat from the drop-down list.
16. Under Variable, select a variable from the drop-down list.
17. Click OK.
18. If you want to add another condition, at the top of the dialog box, click Add.
19. Repeat the above steps for each additional condition to add to the Queue Condition builder.
20. To import queue conditions, click the Import button and navigate to a *.csv file.
21. To export queue conditions, click the Export button and navigate to a *.csv file.
NOTE:
l
l

Conditions on a single line and separated by a comma will be added to a single branch.
Conditions on multiple lines and separated by a comma will be added to multiple
branches.

22. To test the conditions, under Test Parameters, enter a value in the relevant fields and click
Test. 'Pass' or 'Fail' displays depending on whether the test is successful.
23. To delete a queue condition, from the drop-down list to the left of the condition select Delete.
24. Click OK.
To add an Emergency routing condition to a rule
1. Under Routing Rules, click Add.
2. From the second column, select Emergency.
3. From the third column, select Yes or No.
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Adding variables to rules
To add a variable to a rule
1. Under Variables, click Add.
2. From the second column, select a variable from the drop-down list and click OK.
3. In the third column, select either Value or Variable.
4. If you selected 'Value', type the value.
5. If you selected 'Variable, select a variable from the list.
6. Click OK.
7. Click Save.

Deleting rules
To delete a rule
1. Under IVR Routing=>Rules, select the rule from the list provided.
2. Click Delete.
3. When prompted, click OK.

CONFIGURING HOLIDAYS
Holidays can be configured for dates that affect your contact center functionality. For information on
configuring holidays, see "Configuring holidays" on page 173.

CONFIGURING DATA PROVIDERS
You can create a connection to a data provider located on a local or an external server to access
information about incoming callers. For example, the data providers query can be configured to
retrieve customer information based on ANI, DNIS, collected digits, or variables. IVR Routing can
add Microsoft Excel worksheets, Microsoft SQL servers, and Lightweight Directory Access Protocol
(LDAP) as data providers to query for data. IVR Routing can also import ODBC connections
configured using the Windows ODBC Data Source Administrator.
IVR Routing supports the following reference platforms for ODBC connections:
l

IBM DB2

l

Oracle Database

l

MySQL

l

Microsoft Access

l

PostgreSQL

Adding a Microsoft SQL server as a data provider
To add a Microsoft SQL server as a data provider
1. Click IVR Routing=>Data providers.
2. Click Add and select Microsoft SQL Server from the drop down list.
3. Type a Name for the data provider.
4. Type the Server Name.
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5. Under Log on credentials, select Windows Authentication or SQL Server
Authentication.
6. If you select SQL Server Authentication, enter a Username and Password.
7. Click Test Connection.
8. After Database Name, select a database name from the drop down list.
9. Click Save.

Adding a Microsoft Excel worksheet as a data provider
To add a Microsoft Excel worksheet as a data provider
1. Click IVR Routing=>Data providers.
2. Click Add and select Excel from the drop-down list.
3. Type a Name for the data provider.
4. After Workbook, click Select File and browse to the Excel worksheet you want to use as a
data provider.
NOTE: The Excel worksheet must be shared as a workbook and located on a UNC (Universal
Naming Convention) path, also known as a shared network path. The syntax for a UNC path
is \\ComputerName\SharedFolder\Resource. The IVR folder in <installation drive>\Program
Files (x86)\prairiefyre Software Inc\CCM is set up to be shared during the installation process
and is called ivrdirectory. An example of the syntax format is
\\IVRMACHINE\IVRDIRECTORY\WORKSHEET.xls. Locating the worksheet on a UNC
enables IVR Routing to access the data provider remotely.
5. Click Open.
6. Click Test Connection.
7. Click Save.

Adding a LDAP as a data provider
To add a LDAP as a data provider
1. Click IVR Routing=>Data providers.
2. Click Add and select LDAP from the drop down list.
3. Type a Name for the data provider.
4. Type the Domain of the LDAP.
5. Type the Username for the LDAP.
6. Type the Password for the LDAP.
7. Click Test Connection.
8. Click Save.
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Adding an ODBC as a data provider
ODBC connections can be added as a data provider through the Windows ODBC Data Source
Administrator. After adding an ODBC using ODBC Data Source Administrator, the ODBC will
automatically appear in data source providers and will be made available for the Query activity.
You cannot edit an ODBC data provider in IVR Routing.
NOTE: When adding an ODBC connection for IVR Routing, you must use the 32-bit Windows
Server tool. For more information, see the following Mitel Knowledge Base article:
http://micc.mitel.com/kb/KnowledgebaseArticle52125.aspx

Deleting data providers
NOTE: You cannot delete ODBC data providers from the data providers list.
To delete a data providers
1. Click IVR Routing=>Data providers.
2. Select the data provider and click Delete.
3. When prompted, click OK.

CONFIGURING VARIABLES
Variables are used in multiple activities and to perform various tasks, including
l

Storing information for later use

l

Collecting user data

l

Performing database queries

l

Building simple or complex conditions

Variables can be used for different activities such as:
l

Transferring a call to a different queue based on customer class

l

Playing different prompts based on account balance

l

Holding collected digits for use later in a database query

Some variables can also be passed to agents in the form of a desk top screen pop, providing agents
with call information generated in the workflow. For more information, see "Passing agents call
information in screen pops" on page 626, and "Populating screen pops with workflow variables" on
page 626.
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Variables may be configured to mask their contents, enabling variables to be delivered either entirely
masked or partially masked with a user-specified number of characters left unmasked. This limits
the exposure of potentially sensitive information, such as credit card or SIN numbers, in logs, call
notes, databases, and screen pops. Masked variables cannot be used with the Set Variable activity,
but can be used with the Variable Compare and Collect Digits activities. Variables that contain file
paths to .wav files will also mask the .wav file. System variables cannot be masked. Masking is
available to the following types of variables:
l

Unspecified

l

Digits

l

Number

l

Dollars

l

Euros

l

Pounds

l

DateTime

Masked variables are a component of building workflows in support of PCI compliant systems. For
an example of a PCI compliant workflow, see "Workflow for PCI Compliant systems" on page 652.
IVR Routing includes built-in variables that you can use in your workflows. To view these variables
and to see a description of each, open YourSite Explorer and select IVR Routing=>Variables.
Custom variables can be populated through queries and activities such as Set Variable and Execute.
See "Configuring the Query activity" on page 600, "Configuring the Set Variables activity" on page
620, and "Configuring the Execute activity" on page 584.

Adding variables
To add a variable
1. Click IVR Routing=>Variables=>Add.
2. Type a Name for the new variable.
NOTE:
l

The Name must be unique and cannot contain any spaces.

l

A variable's name cannot be changed after you save.

3. After Description, provide a brief explanation of the variable function.
4. After Variable Type, select the type of variable from the drop-down list.
NOTE: A variable's type cannot be changed after you save.
5. If Mask Type is available to this type of variable, select the variable’s mask from the dropdown list.
l

l

l

l

NoMask– The variable will not be masked within IVR Routing and associated screen
pops, databases, etc
FullMask– The entire variable will be masked within IVR Routing and associated
screen pops, databases, etc
MaskAllExceptLastX– The variable will be masked except for the specified number of
final characters
MaskAllExceptFirstX– The variable will be masked except for the specified number of
first characters
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6. If you selected MaskAllExceptLastX or MaskAllExceptFirstX, specify the number of
characters to be left unmasked.
7. To enable this variable to display in a toaster notification or screen pop select the Send to
agent desktop check box.
8. After Display Name, type the name this variable has when it appears in a toaster notification
or screen pop.
9. If you selected Dollars, Euros, or Pounds as the variable type, after Currency Format, select
the format from the drop-down list.
10. If you selected Date Time as the variable type, after Date Format, select the date format from
the drop-down list. After Time Format, select the time format from the drop-down list.
11. Click Save.

Deleting variables
NOTE: Default variables are grayed out and cannot be deleted.
To delete a variable
1. Click IVR Routing=>Variables.
2. Select the variable and click Delete.
3. When prompted, click OK.

CONFIGURING MUSIC ON HOLD
IVR Routing provides music on hold for your telephone system using a PC sound card with a
connection to your telephone system. IVR Routing plays music through the sound card using a
rotating (loop) playlist.
Music sources for playlists include any or all of the following: audio CD, stored .wma, stored .wav
file, and stored .mp3 file. Playlists can include music or prerecorded information messages.
You can start or stop the music engine from the user interface. Once started, the music engine loops
through the playlist, playing continuously until stopped.

Adding music on hold
To add a music on hold playlist
1. Click IVR Routing=>Music on hold=>Add.
2. Type a Name and Description for the playlist.
3. Click the Songs tab.
4. To add a song to the list of songs available to IVR Routing, under Available songs, click
Add.
5. Browse to the song you want to add and click Open.
6. To add a song to a playlist, select the song you want to add and click >.
7. Click Associate Servers.
8. Under Available members, select the computer that the playlist will be played from and click
>.
9. Click Save.
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Deleting music on hold
To delete a music on hold playlist
1. Click IVR Routing=>Music on hold.
2. Select the playlist and click Delete.
3. When prompted, click OK.

CONFIGURING SECURITY
You can configure IVR Routing security settings in YourSite Explorer to allow or prevent users from
making changes to workflows, devices, and prompts, and to the runtime operations of your
business. See "Configuring security roles" on page 193.

ACTIVITIES
You use IVR Routing's activities to build workflows and subroutines and configure the routing
conditions that send customers to queues. Activities perform a range of functions, such as
answering, transferring, and redirecting calls, collecting caller-entered digits, playing customized
prompts, and running database queries to retrieve caller information. The following sections explain
the activities available in IVR Routing and how you can configure activities to build workflows,
subroutines, and routing conditions.
This section on Activities begins with Table 42, which lists IVR Routing's activities, displays the
activities' icons, and lists activity availability by workflow and subroutine types. The section then
explains how different activities are categorized based on the functions they perform and how they
instruct IVR Routing to manage call routing. This Activities section concludes by explaining how to
configure activities in order to build workflows, subroutines, and ultimately routing conditions. It
provides procedures for configurations that are common to many activities and concludes with
procedures for configuring individual activities.
NOTE: The following sections explain activities and their configuration, but do not explain how to
use activities to create an entire workflow or subroutine. For information on how activities can be
used to create workflows and subroutines, see "Workflow examples" on page 523, "IVR Routing
workflow samples" on page 639, "IVR Routing complex workflow configuration" on page 655, and
"IVR Routing default workflows and subroutines" on page 627.

Activities available in IVR Routing
Table 42 lists the activities used to create IVR Routing workflows and subroutines. The table lists
the activity, shows the activity's icon, and lists the activities' availability according to workflow and
subroutine type. The table also contains links to the configuration procedures for each activity.
Activity availability may vary by IVR Routing licensing level. For information, see the Contact
Center Solutions and Business Reporter System Engineering Guide.
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Table 42: Activities available in IVR Routing
ACTIVITY
NAME

ICON

DETAILS
Available in Inbound and Inqueue workflows

ANI

Available in Inbound, Management, and Callback
Inbound subroutines
For configuration procedures, see "Configuring
the ANI activity" on page 571.
Available in Inbound and RAD workflows

Answer

Available in Inbound, RAD, Management, UPiQ,
and Callback Inbound subroutines
For configuration procedures, see "Configuring
the Answer activity" on page 572.
Available in Inbound workflows

Callback
Request

Available in Inbound and UPiQ subroutines
For configuration procedures, see "Configuring
the Callback Request activity" on page 573.
Available in Inbound and Outbound workflows

Collect Digits

Available in Inbound, Outbound, Management,
UPiQ, and Callback Inbound subroutines
For configuration procedures, see "Configuring
the Collect Digits activity" on page 575.
Available in Outbound workflows

Conference

Available in Outbound subroutines
For configuration procedures, see "Configuring
the Conference activity" on page 577.

Connect to
Caller

Date Time
Validation

556

Available in Inqueue workflows
For configuration procedures, see "Configuring
the Connect to Caller activity" on page 579.
Available in Callback Inbound subroutines
For configuration procedures, see "Configuring
the Date Time Validation activity" on page 580.
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Table 42: Activities available in IVR Routing (continued)
ACTIVITY
NAME

ICON

DETAILS
Available in Inbound, Outbound, RAD, and
Inqueue workflows

Delay

Available in Inbound, Outbound,
RAD, Management, and UPiQ, and Callback
Inbound subroutines
For configuration procedures, see "Configuring
the Delay activity" on page 580.
Available in Inbound, Outbound, and Inqueue
workflows

DNIS

Available in Inbound, Outbound,
Management, UPiQ, and Callback Inbound
subroutines
For configuration procedures, see "Configuring
the DNIS activity" on page 580.
Available in Inbound, Outbound, RAD, and
Inqueue workflows

Email

Available in Inbound, Outbound, RAD,
Management, UPiQ, and Callback Inbound
subroutines
For configuration procedures, see "Configuring
the Email activity" on page 582.
Available in Inbound, Outbound, RAD, and
Inqueue workflows

Execute

Available in Inbound, Outbound, RAD,
Management, UPiQ, and Callback Inbound
subroutines
For configuration procedures, see "Configuring
the Execute activity" on page 584.
Available in Inbound, Outbound, and Inqueue
workflows

Go To

Available in Inbound, Outbound,
Management, UPiQ, and Callback Inbound
subroutines
For configuration procedures, see "Configuring
the Go To activity" on page 588.
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Table 42: Activities available in IVR Routing (continued)
ACTIVITY
NAME

ICON

DETAILS
Available in Inbound, Outbound, and RAD
workflows

Hang Up

Available in Inbound, Outbound, RAD,
Management, UPiQ, and Callback Inbound
subroutines
For configuration procedures, see "Configuring
the Hang Up activity" on page 588.
Available in Inbound workflows

Hold State

Available in Inbound subroutines
For configuration information, see "Configuring
the Hold State activity" on page 589.
Available in Inbound, RAD, and Inqueue
workflows

Hunt Group

Available in Inbound, RAD, and Callback Inbound
subroutines
For configuration procedures, see "Configuring
the Hunt Group activity" on page 589.
Available in Inbound, Outbound, and
RAD workflows

Language

Available in Inbound, Outbound, RAD,
Management, UPiQ, and Callback Inbound
subroutines
For configuration procedures, see "Configuring
the Language Activity" on page 591.
Available in Outbound workflows.

Make Call

Available in Outbound subroutines
For configuration procedures, see "Configuring
the Make Call activity" on page 592.
Available in Inbound workflows

Management

Available in Inbound, Management, and Callback
Inbound subroutines
For configuration procedures, see "Configuring
the Management activity" on page 594.
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Table 42: Activities available in IVR Routing (continued)
ACTIVITY
NAME

ICON

DETAILS
Available in Inbound and Outbound workflows

Menu

Available in Inbound, Outbound,
Management, UPiQ, and Callback Inbound
subroutines
For configuration procedures, see "Configuring
the Menu activity" on page 595.
Available in Inbound workflows

Mode of
Operation

Available in Inbound and Management
subroutines
For configuration procedures, see "Configuring
the Mode of Operation activity" on page 597.
Available in Inbound, Outbound, and RAD
workflows

Play

Available in Inbound, Outbound, RAD,
Management, UPiQ, and Callback Inbound
subroutines
For configuration procedures, see "Configuring
the Play activity" on page 598.
Available in Inbound, Outbound, RAD, and
Inqueue workflows

Query

Available in Inbound, Outbound, RAD,
Management, UPiQ, and Callback Inbound
subroutines
For configuration procedures, see "Configuring
the Query activity" on page 600.
Available in Inbound, Outbound, RAD, and
Inqueue workflows

Queue

Available in Inbound, Outbound, RAD, UPiQ, and
Callback Inbound subroutines
For configuration procedures, see "Configuring
the Queue activity" on page 604.
Available in Inbound workflows

Record

Available in Inbound, Management, UPiQ, and
Callback Inbound subroutines
For configuration procedures, see "Configuring
the Record activity" on page 609.
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Table 42: Activities available in IVR Routing (continued)
ACTIVITY
NAME

ICON

DETAILS
Available in Inbound and Inqueue workflows

Redirect

Available in Inbound, Management, and Callback
Inbound subroutines
For configuration procedures, see "Configuring
the Redirect activity" on page 612.
Available in Outbound workflows

Retrieve
Callback

Available in Outbound subroutines
For configuration procedures, see "Configuring
the Retrieve Callback activity" on page 613.
Available in Inbound, Outbound, RAD, and
Inqueue workflows

Rules

Available in Inbound, Outbound, RAD,
Management, UPiQ, and Callback Inbound
subroutines
For configuration procedures, see "Configuring
the Rules activity" on page 613.
Available in Outbound workflows

Save Callback

Available in Outbound and Callback Inbound
subroutines
For configuration procedures, see "Configuring
the Save Callback activity" on page 614.
Available in Inbound, Outbound, RAD, and
Inqueue workflows

Schedule

Available in Inbound, Outbound, RAD, UPiQ, and
Callback Inbound subroutines
For configuration procedures, see "Configuring
the Schedule activity" on page 615.

Set Device
Mode of
Operation
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Available in Management subroutines
For configuration procedures, see "Configuring
the Set Device Mode of Operation activity" on
page 618.
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Table 42: Activities available in IVR Routing (continued)
ACTIVITY
NAME
Set System
Mode of
Operation

ICON

DETAILS
Available in Management subroutines
For configuration procedures, see "Configuring
the Set System Mode of Operation activity" on
page 619.
Available in Inbound, Outbound, RAD, and
Inqueue workflows

Set Variables

Available in Inbound, Outbound, RAD,
Management, UPiQ, and Callback Inbound
subroutines
For configuration procedures, see "Configuring
the Set Variables activity" on page 620.
Available in Inbound, Outbound, and RAD
workflows

Subroutine

Available in Inbound, Outbound, RAD,
Management, UPiQ, and Callback Inbound
subroutines
For configuration procedures, see "Configuring
the Subroutine activity" on page 620.
Available in Management subroutines

Swap Prompt

For configuration procedures, see "Configuring
the Swap Prompt activity" on page 621.
Available in Inbound, Outbound, and Inqueue
workflows

Transfer

Available in Inbound, Outbound,
Management, and Callback Inbound subroutines
For configuration procedures, see "Configuring
the Transfer activity" on page 622.
Available in Inbound, Outbound, and Inqueue
workflows

Variable
Compare

Available in Inbound, Outbound, RAD,
Management, UPiQ, and Callback Inbound
subroutines
For configuration procedures, see "Configuring
the Variable Compare activity" on page 624.
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Understanding activity categories
Activities fall into three categories: conditional, action, and conditional action. Conditional activities
check a condition and branch calls based on that condition. For example, an ANI activity will check
the number from which a customer is calling and branch the call accordingly. Action activities
perform actions within a workflow or subroutine, but do not branch calls. For example, the Play
activity plays callers a prompt. Conditional action activities perform actions and branch the call
based on the result. For example, a Query activity can retrieve a caller’s account balance and then
branch the call to a Play activity that will recount that information.
Conditions include the following Activities:
l

ANI

l

Variable Compare

l

DNIS

l

Hunt Groups

l

Queue

l

Redirect

l

Rules

l

Schedule

Actions include the following Activities:
l

Answer

l

Callback Request

l

Delay

l

Email

l

Go To

l

Hang up

l

Hold State

l

Language

l

Management

l

Play

l

Set Variables

l

Subroutine

l

Swap Prompt

Conditional actions include the following Activities:
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l

Collect Digits

l

Conference

l

Connect to Caller

l

Date Time Validation

l

Execute

l

Make Call

l

Menu

Configuring IVR Routing

l

Mode of Operation

l

Record

l

Retrieve Callback

l

Query

l

Save Callback

l

Set Device Mode of Operation

l

Set System Mode of Operation

l

Transfer

Configuring common activity options
Several of IVR Routing's activities share configuration procedures. This section explains procedures
for configurations that are common to many activities, branches, and branching conditions.
NOTE: Branches route callers to different portions of the workflow. Branching conditions represent
the circumstances a call must match in order to be sent to a particular branch.

Adding activities to workflows or subroutines
NOTE: The availability of activities varies depending on
l

l

The workflow or subroutine type you select. For example, you cannot use a Menu Activity in a
RAD workflow. However, you can use subroutines to access activities from other workflow
types. Table 42 lists the workflows and subroutines to which different activities are available.
Your licensing level. See the Contact Center Solutions and Business Reporter System
Engineering Guide for more information regarding licensing and activity availability.

To add an activity to a workflow or subroutine
1. Click either IVR Routing=>Workflows or IVR Routing=>Subroutines, and select the
workflow or subroutine.
2. Select the Designer tab and, from the Toolbox, drag and drop activities to the Workflows
Canvas.
3. Click Save.
NOTE: A red exclamation mark icon shown in the top right corner of an activity signals a
configuration error or missing information. You must correct any errors and add all required
information before the workflow can be associated to a device and go live in the system. For
more information, see "Troubleshooting workflow configuration with the Validation button" on
page 568.

Deleting activities or branches from workflows
To delete an activity or branch from a workflow
1. Right-click the activity or branch and select Delete.
2. Click Save.
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Naming activities, activity configurations, and branches
For administrative and reporting purposes, we recommend you give activities, configuration settings
within an activity, and branches unique names and system names. A system name is used by
IVR Routing to identify an activity, activity condition, or branch and is used in reporting. A name
labels an activity, activity condition, or branch for the user to see.
To name an activity, activity configuration, or branches
1. Select the activity, activity configuration or branch and click Properties.
2. Type a Name for the activity, activity configuration, or branch.
3. Type a System Name for the activity, activity configuration, or branching condition.
4. Click Save.

Configuring activities and branches for reporting
By configuring activities or branches for reporting, you can run reports on them. This enables you to
analyze workflow traffic and see how callers are moving through your workflows.
NOTE: You must select ‘Child Reporting Enabled’ for any branches and conditions on which you
want to run Workflow Condition reports. For more information on Workflow Condition reports, see
the reports guide appropriate to your Edition of Contact Center Solutions.
To configure an activity and branch for reporting
1. Select the activity or branch to configure for reporting and click Properties.
2. Select the Reportable or the Child Reporting Enabled check box.
NOTE: Selecting 'Child Reporting Enabled' on parent activities selects all child activities.
3. Click Save.

Configuring an activity’s prompts
Many IVR Routing activities use prompts to play messages at specified points in the workflow or
subroutine. Some activities are pre-configured with prompts, while others require prompts to be
specified. If an activity has configurable prompts, it will have a prompt section in its Properties pane.
Prompts can be configured in a number of different ways for activities. You can:
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l

Add a new prompt

l

Add a variable to a prompt

l

Add a new variable to a prompt

l

Clear a prompt

l

Add a prompt using Quick Add Prompt

l

Change a prompt to an existing prompt

Configuring IVR Routing

To add a new prompt
1. Select the activity in the workflow or subroutine.
2. In the Properties pane, after the prompt you want to change, click the ▼ button and select
Add a new prompt.
3. After Language, select the primary language from the drop-down list.
NOTE:
l

The language you select determines the system wave files available to you.

l

By default, the language is set to the default site language.

4. Type a Name for the prompt.
5. Type a Description for the prompt.
6. Select a Category for the prompt from the drop-down list:
l

Callback

l

Custom

l

Management

l

Samples

l

UPiQ

7. To create your own category, after Category, type a name for the new category.
NOTE: Prompt categories are an organizational tool to help keep prompts sorted and easily
accessible.
8. Select one of the following tabs:
l

l

l
l

l

System wave files–lists the system wave files callers hear while in the IVR system or
while waiting on hold. This pane will only show the wave files that are available in the
language you have selected.
Custom wave files–lists imported and recorded wave files. To import or record a
custom wave file, click 'Add' and select 'Existing wave file' to import the file or 'Record
wave file' to use the microphone on your computer to record the file.
NOTE: Wave files must be 8khz, Mono, or ULAW format.
Queue stats–lists up-to-date queue statistics for use in prompts
Variables–lists all variables available for use in prompts
NOTE: Read back on variables is based on the type of variable. Number variables read
back the whole number, while digit variables read back individual numbers. For
example, number variables would read 123 as 'one hundred and twenty-three', while
digit variables would read 123 as 'one, two, three'.
Prompts used in workflows and subroutines–lists all prompts used in workflows
and subroutines

9. In the All system wave files, All custom wave files, All queue stats, All variables, or
Prompts used in workflows and subroutines pane, select the files to add to the prompt.
10. Click > to add the file to the prompt.
NOTE: The wave files play in the order they are added to the prompt. To change the order in
which the wave files will be played, select the wave file and click the up or down arrow buttons
on the right-hand side of the dialog box.
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11. Click Save.
NOTE: If you are adding prompts in a new language, you must add audio files that correspond
to the existing audio files in IVR Routing’s default language. Otherwise, the caller will not hear
anything when the prompts are supposed to be playing.
To add a variable to a prompt
1. Select an activity in the workflow.
2. In the Properties pane, after the prompt you want to change, click the ▼ button and select
Add a variable to a prompt.
3. Select the variable and click OK.
4. Click Save.
To add a new variable to a prompt
1. In the Properties pane, after the prompt you want to change, click the ▼ button and select
Add a variable to a prompt.
2. Click the Add button.
3. Type a Name for the variable. The name must be unique and cannot contain spaces.
4. Type a Description for the variable.
5. After Variable Type, select a type from the drop-down list.
NOTE: A variable's type cannot be changed after you save.
6. If Mask Type is available to this type of variable, select the variable’s mask from the dropdown list.
l

l

l

l

NoMask– The variable will not be masked within IVR Routing and associated screen
pops, databases, etc
FullMask– The entire variable will be masked within IVR Routing and associated
screen pops, databases, etc
MaskAllExceptLastX– The variable will be masked except for the specified number of
final characters
MaskAllExceptFirstX– The variable will be masked except for the specified number of
first characters

7. If you selected MaskAllExceptLastX or MaskAllExceptFirstX, specify the number of
characters to be left unmasked.
8. To enable this variable to display in a toaster notification or screen pop, select the Send to
agent desktop check box.
9. Type the Display Name that this variable has when it appears in a toaster notification or
screen pop.
10. If you selected Dollars, Euros, or Pounds as the variable type, after Currency Format, select
the format from the drop-down list.
11. If you selected Date Time as the variable type, after Date Format, select the date format from
the drop-down list. After Time Format, select the time format from the drop-down list.
12. Click Save.
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To clear a prompt
1. Select an activity in the workflow or subroutine.
2. In the Properties pane, after the prompt you want to change, click the ▼ button and select
Clear Prompt.
3. Click Save.
To add a prompt using Quick Add Prompt
1. Select an activity in the workflow or subroutine.
2. In the Properties pane, after the prompt you want to change, click the ▼ button and select
Quick Add Prompt.
3. Navigate to the .wav file and click Open.
4. Click Save.
To change a prompt to an existing prompt
1. Select an activity in the workflow or subroutine.
2. In the Properties pane, after the prompt you want to change, click the ▼ button and select
Select from an existing prompt.
3. Select a prompt and click OK.
4. Click Save.

Finding activities in a workflow or subroutine
IVR Routing enables you to search for specific activities and branches within a workflow or
subroutine using Find Activity. Located in the ribbon, this tool searches the active workflow or
subroutine for all instances of the term entered in the Find Activity search field and displays each
result within the workflow or subroutine. Find Activity is only available in the ribbon when working
with workflows or subroutines.
To find an activity in a workflow or subroutine
1. Select the workflow or subroutine in which you want to search for an activity or branch.
2. In the Find Activity section of the ribbon, type the name of the activity or branch.
3. Click the Search button. The total number of results displays beneath the search field.
4. Use the Next Result and Previous Result buttons to navigate the results.

Editing branches
You can edit branches by editing the conditions determining when calls follow the branch.
NOTE: You cannot add branches to the workflow from the edit menu. However, you can use the edit
menu to add multiple conditions to an existing branch.
To edit a branch
1. Expand the relevant activity.
2. Right-click the branch to edit and select Edit Condition.
3. Select the value to edit and type the new value.
4. Click Add.
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5. To add another value to the condition, at the top of the pane, click Add and type the value or
range of values.
6. To delete a value, select the value and click Delete.
7. Click OK.
8. Click Save.

Annotating activities in workflows and subroutines
You can tag activities and branches with visible notes using the annotation field. Similar to a sticky
note, annotations enable you to mark workflows and subroutines with descriptive information. For
example, you can annotate a Timeout branch to indicate, at a glance, how long before the system
times out and where customers are directed in the workflow or subroutine once a timeout occurs.
You annotate an activity and open annotations by clicking the notepad icon on an activity or branch.
To hide an individual, open annotation, click the notepad icon. You can right-click an activity to edit,
delete, show all, and hide all annotations to provide custom descriptions of your workflow or
subroutine.
To add an annotation
l

Click the notepad icon on the activity or branch and type text in the annotation field.

To delete an annotation
l

Right-click the activity or branch and select Annotations...=>Delete.

To expand an individual annotation
l

Click the notepad icon on the activity or branch.

To hide an individual annotation
l

On an open annotation, click the notepad icon.

To expand all annotations
l

Right-click the workflow and select Annotations…=>Show All.

To hide all annotations
l

Right-click the workflow and select Annotations...=>Hide All.

Troubleshooting workflow configuration with the Validation button
IVR Routing validates workflows to ensure they do not contain programming or configuration errors
before going live in your system. IVR Routing also warns you of configurations that are not
recommended.
Red exclamation marks on activities indicate configuration errors to be corrected. Yellow
exclamation marks on activities indicate warnings. Clicking the ‘Validation’ button opens a pane
explaining your workflow’s Errors and Warnings.
The pane lists the number of Errors and Warnings, the activity to which the Error or Warning is
associated, and what is required to fix the problem. Double-clicking the Error and Warning
information in the Validation pane brings the specific activity into focus, for ease of identification. For
more information on focusing, see "Viewing specific portions of a workflow: Focusing and the
Breadcrumb view" on page 508.
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You can disable the validation function by deselecting the 'Validate workflow' check box in the
Workflows pane
NOTE:
l

l

Workflows containing validation errors, or that have validation disabled, cannot be assigned to
a device. This prevents improperly configured workflows from going live.
Workflows that are already assigned to a device but become invalidated cannot be saved until
the error is corrected.

Changing the order in which branches are evaluated
Administrators change the order in which they system evaluates branches by places the branches in
sequence. The highest priority branch should be in the left-most position, as IVR Routing evaluates
branches in the order of left to right.
To change the order in which branches are evaluated
1. Expand the relevant activity.
2. Drag and drop the branches into the desired position.
3. Click Save.

Building conditions in IVR Routing
Several features in IVR Routing, including activities, require users to build conditions. For example,
users may build schedule conditions, queue conditions, and variable compare conditions. These
conditions help determine how calls are routed through a workflow.
While the individual types of expressions that can be added to conditions may vary, the interface for
adding, deleting, and grouping expressions remains consistent throughout IVR Routing.

Adding and removing expressions
To add an expression
l

When in a condition designer window, click the Add button.
NOTE: Expressions highlighted in red require additional configuration.

To remove an expression
l

When in a condition designer window, select the expression you want to delete and click the
Delete button.
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Understanding operators
IVR Routing offers a number of different operators to use when building conditions. Table 43 outlines
the operators available with IVR Routing.
Table 43: Operators
OPERATOR

USE

!=

With this operator the expression will only look for value that do not match the
exact value entered. This operator is case-sensitive.

=

With this operator the expression will looks only for the exact value entered in
the expression. This operator is case-sensitive. If this operator is being used in a
comparison, then the expression will look for an exact string match between the
2 items being compared.

Contains

Length

Starts With

With this operator, the expression matches values that contain the entered
string. It is not case-sensitive.
With this operator the expression will look for a value with the specified number
of characters.
With this operator, the expression will look for any value that starts with the
entered value.

Selecting expressions
To select an expression
1. Click the expression's drop-down menu button.
2. Choose Select/Deselect Row.
Alternatively,
l

Click the expression's selector column on the left side of the expression's row.

Grouping expressions
IVR Routing enables users to group expressions, facilitating the easy construction of detailed and
specific conditions. Expressions within a group may also be grouped together to create nested levels
of sub-groups within a single group. While grouping is associated with a number of different
activities, configurations, and dialogs, the grouping clauses are consistent throughout IVR Routing.
NOTE: We recommend you do not exceed eight levels of grouping within a group of expressions
even though IVR Routing is capable of handling greater than eight levels of grouping.
Expressions may be grouped by one of two clauses:
l

l
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AND: Expressions grouped by the AND clause require that all the expressions in a group be
met to successfully meet the condition.
NOTE: If no grouping is selected, the AND clause is applied by default.
OR: Expressions grouped by the OR clause require that only one of the expressions in a group
be met to successfully meet the condition.

Configuring IVR Routing

To group expressions
1. Press the Ctrl or Shift key and select the expressions you want to group. Clicking 'Ctrl'
enables you to select items one at a time and omit items from selection. Clicking 'Shift'
selects a span of items.
2. Click either the Group AND or Group OR buttons.
NOTE: You can change the grouping clause by selecting the drop-down beside 'And' or 'Or',
and changing your selection.
To ungroup grouped expressions
1. Click the group’s drop-down menu button.
2. Select Ungroup.
To add a new expression to a group
1. Click the group’s drop-down menu button.
2. Select Add.
NOTE: If you cannot add an expression to an existing group, ungroup the expression and then
regroup it with the expression you want to add.
To remove a single expression from a group
1. Click the expression’s drop-down menu button.
2. Select Ungroup.

Configuring the ANI activity
The ANI activity branches workflows based on all or part of a customer’s ANI. For example, you can
configure an ANI activity to identify the area codes for callers from French-speaking locations and
route all applicable calls to queues with French-speaking agents. The ANI activity enables
customers to be efficiently routed to the agents best suited to serve them.
You can add branching conditions to ANI activities to determine how IVR Routing directs callers
through the workflow. You can also import and export ANI conditions in .csv files.
The ANI activity is available in
l

Inbound and Inqueue workflows

l

Inbound, Management, and Callback Inbound subroutines

Adding branching conditions to ANI activities
Branching conditions represent the criteria by which IVR Routing directs calls.
To add a branching condition to an ANI activity
1. Right-click the ANI activity and select Add Condition.
2. Click Add and type a value or range of values for the ANI condition.
NOTE:
l

l

To branch all calls from a specified area code, city exchange, or other number
identification, include an 'x' at the end of the numeric value. 'x' indicates multiple
wildcard characters.
To indicate individual digits or to set branching conditions to match any ANI, include
question marks instead of numeric values.
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3. Click the Add icon.
4. To add more ANI conditions, at the top of the ANI dialog box, click Add.
5. If you want all ANI conditions in the same branch, deselect the Add each row in a separate
branch check box.
6. Optionally, select the Enable reporting for the Branch check box.
7. To test the ANI conditions, under Utilities, enter a value.
If the test is successful, 'Pass' displays.
If the test is unsuccessful, 'Fail' displays.
NOTE: You cannot test a range of values.
8. Click OK to create the branch or click Add to add the current branch to the workflow while
leaving the dialog box open to create new branches.
9. Click Save.
To import and export ANI conditions
1. Right-click the ANI activity and select Add Condition.
2. To import ANI conditions in *.csv format, click Import and navigate to the file name you want
to import.
3. To export ANI conditions in *.csv format, click Export and navigate to the file name you want
to export.
NOTE:
l
l

Conditions on a single line and separated by a comma will be added to a single branch.
Conditions on multiple lines and separated by a comma will be added to multiple
branches.

4. Optionally, select the Enable reporting for the Branch check box.
5. To test the ANI conditions, under Utilities, enter a value.
If the test is successful, 'Pass' displays.
If the test is unsuccessful, 'Fail' displays.
NOTE: You cannot test a range of values.
6. Click OK to create the branch or click Add to add the current branch to the workflow while
leaving the dialog box open to create new branches.
7. Click Save.

Configuring the Answer activity
The Answer activity prompts a port to answer a ringing line and begin the workflow.
An internal timeout of 10 seconds determines how long the Answer activity has to answer the line.
Once the timeout is reached, the workflow is terminated.
NOTE: Inbound and RAD workflows must begin with an Answer activity if you intend to play a
message or collect digits.
The Answer activity is available in
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l

Inbound and RAD workflows

l

Inbound, RAD, Management, UPiQ, and Callback Inbound subroutines
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Configuring the Callback Request activity
The Callback Request activity offers customers the ability to leave a callback request. For example,
you can use the Callback Request activity to enable callers experiencing longer than average wait
times to request a callback from an agent. Callback Request helps you meet your service level goals
by reducing abandoned calls.
You can assign callback subroutines and destinations to Callback Request activities. You can also
add devices to Callback Request destinations.
The Callback Request activity is available in
l

Inbound workflows

l

Inbound and UPiQ subroutines

NOTE: For callbacks to function correctly, you must have configured location settings for your
media server. If location settings are not configured, your callbacks will not be able to contact your
customers. See "Configuring location settings for 3300 ICP media servers" on page 87.

Assigning callback subroutines to Callback Request activities
The subroutines assigned to Callback Request activities tells the system which Callback Inbound
subroutine to offer the caller and which Outbound subroutine offers callback requests to agents.
NOTE:
l

l
l

IVR Routing provides a default callback subroutines. For information on these default
subroutines, see "Default Inbound Voice Callback subroutine" on page 636 and "Default
Outbound Callback subroutines" on page 632.
You must assign both Inbound and Outbound subroutines to Callback Request activities.
You can only save Callback Request activities once you have assigned them both
subroutines and destinations.

The following procedures explain how to
l

Assign a Callback Inbound subroutine

l

Assign a Callback Outbound subroutine

l

View associated Callback Inbound subroutine

l

View associated callback Outbound subroutine

To assign a Callback Inbound subroutine
1. Right-click the Callback Request activity and select Inbound Callback Workflow....
2. Select a subroutine and click OK.
To assign a Callback Outbound subroutine
1. Right-click the Callback Request activity and select Outbound Callback Workflow....
2. Select a subroutine and click OK.
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To view the associated Callback Inbound subroutine
l

Right-click the Callback Request activity and select Open Inbound Workflow.

To view the associated Callback Outbound subroutine
l

Right-click the Callback Request activity and select Open Outbound Workflow.

Assigning destinations to Callback Request activities
The callback destination represents the agent groups responsible for answering callbacks.
NOTE: Ring groups are not supported for handling callback requests.
To assign a destination to a Callback Request activity
1. Right-click the Callback Request activity and select Destination....
2. Select a destination from one of the following devices:
l

Queue

l

Queue group

l

Variable

l

Extensions

l

Agent

3. Click OK.
4. Click Save.

Adding new devices to Callback Request destinations
The following procedures explain how to
l

Add a new queue, queue group, extension, variable, or agent device to a Callback Request
destination

To add a new queue, queue group, variable, extension, or agent device to a Callback Request
destination
1. Right-click the Callback Request activity and select Destination....
2. Select one of the following tabs:
l

Queue

l

Queue Group

l

Variable

l

Extensions

l

Agent

3. In the Queue, Queue Group, Extension, or Agent tabs, at the top of the dialog box, click
Add.
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4. To add a new queue, in the Queue pane, follow the steps under "Adding queues" on page 142.
NOTE:
l

l

l

To configure a new queue for web callbacks, see "Enabling web callbacks" on page
539.
To configure a new queue for abandon callbacks, see "Enabling abandon callbacks" on
page 537.
To associate a queue to an UPiQ workflow, see "Configuring Inqueue routing" on page
518. For information on setting up UPiQ workflows, see "Default Inqueue UPiQ
workflow and subroutine" on page 629.

5. To add a new queue group, follow the corresponding steps in "Adding queue groups" on page
155.
6. To add a new variable, follow the corresponding steps in "Adding variables" on page 553.
7. To add a new extension, see "Adding extensions for IVR Routing" on page 512.
8. To add a new agent, follow the corresponding steps in "Adding agents" on page 136.
9. When you have configured the new device, click Save.
10. Click Save.

Configuring the Collect Digits activity
The Collect Digits activity prompts callers to enter, through their dial pad, information that can then
be stored in a variable. For example, Collect Digits could enable a caller to enter their membership
number when they enter the workflow. If stored in a custom variable, this information can be sent to
an agent to provide additional information about the customer.
You can configure options and collection settings for Collect Digits activities to determine how IVR
Routing directs callers through the workflow.
The Collect Digits activity is available in
l

Inbound and Outbound workflows

l

Inbound, Outbound, Management, UPiQ, and Callback Inbound subroutines

NOTE: Information acquired by a Collect Digits activity is stored within the
<<LastCollectedDigits>> system variable. Subsequent Collect Digits actions overwrite this system
variable. You can also select a variable to in which to store customer-entered digits.

Configuring options for Collect Digits activities
To configure options for a Collect Digits activity
1. Select the Collect Digits activity and click Properties.
2. After Confirm Digit, select a confirmation digit from the drop-down list. This is the digit a
caller presses to confirm that their input is correct.
3. After Confirm Input, click the ▼ button and follow the applicable steps under "Configuring an
activity’s prompts" on page 564. This sets the prompts callers hear asking them to confirm the
digits they have entered.
4. To enable callers to skip the system's readback of the collected digits, select the Barge In
check box.
5. To enable reporting, select the Child Reporting Enabled check box.
6. After Invalid Attempts, type the number of times a caller can try to enter information.
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7. After Multi Digit Delay, type how long a caller has to enter another digit.
NOTE: Callers who take longer to enter a digit will be prompted again to enter their digits. After
the maximum number of attempts is reached, the call follows the Failure branch.
8. After No digit timeout (sec), type how long the system waits for the caller to enter a digit
before timing out.
9. Click Save.

Configuring collection settings for Collect Digit activities
Collection settings assign
l

The variable in which collected digits are stored, if you do not want to use <<Last Collected
Digits>>

l

The greeting callers hear when prompted to input digits

l

The digit callers enter when finished inputting digits

l

The maximum and minimum number of digits a caller can input

To configure a collection setting for a Collect Digits activity
1. Select the Collect Digits activity and select Properties.
2. After Collection Settings, click the … button.
3. To store customer-entered digits in a variable other than <<Last Collected Digits>>, after
Variable, click the … button.
4. Under Variable, click the ... button, select a variable and click OK.
5. To add a new variable, click Add and follow the applicable steps under "Adding variables" on
page 553.
NOTE: The following variables are available to Collect Digits: Dollars, Euros, Pounds, Digits,
Number, and Date and Time.
6. Under Greeting, click the … button and select the greeting callers hear.
7. Click OK.
8. To add a new greeting, click Add and follow the corresponding steps in "Configuring prompts"
on page 532.
9. Under Terminating Digit, type the digit that callers enter when they are finished inputting
digits.
10. Under Min. digits to collect, type the minimum number of digits a caller can input.
11. Under Max digits to collect, type the maximum number of digits a caller can input.
NOTE: When a caller reaches the maximum number of digits, IVR Routing will not wait for the
terminating digit.
12. To configure another collection setting, click Add.
13. To delete a collection setting, select the setting and click Delete.
14. Click OK.
15. Click Save.

576

Configuring IVR Routing

Configuring the Conference activity
The Conference activity connects a call already in progress to a specified destination. For example,
you can use the Conference activity as part of an outbound workflow to enable an agent, who has
been offered a callback request from the queue, to connect to the customer who left the contact
request. The Conference activity’s destination can be retrieved from a data source, including a SQL
database, an Excel file, a Web Service call, or a custom variable.
The Conference activity has seven branches: Success, Client Disconnected, Agent Disconnected,
No Answer, Destination Busy, Invalid Destination, and Failure. Client Disconnected and Agent
Disconnected enable workflow behavior to be configured when the client (the party called by the
Conference activity) or the agent (the party who initiated the Conference) disconnects while the
Conference activity is playing its prompts to both conference parties.
The Conference activity uses three prompts:
l

l

l

Pre connect—This prompt plays to the conference initiator, informing them that the call is
being established. The default prompt is PromptName_Callback Agent Pre-Connect.
Connecting to customer—This message indicates that the conference is being connected.
The default prompt is PromptName_Callback Agent Connecting.
Greeting message to customer—This prompt plays to the destination (typically a customer)
before the agent connects indicating that they are being connected to an agent. The default
prompt is PromptName_Callback Agent Callers Message.

Administrators can change the prompts if they want to use a Conference activity for something other
than callbacks. For instructions on changing an activity’s prompts, see "Configuring an activity’s
prompts" on page 564.
The Conference activity is available in
l

Outbound workflows

l

Outbound subroutines

NOTE: As part of Outbound workflows, the Conference activity is only available with IVR Routing
Premium Licensing.

Setting the Conference activity’s destination and call behavior
You must set the Conference activity's destination. This destination can be internal or external, and
may be set from an extension, a queue, a queue group, or a variable. A new extension, queue, queue
group, or variable may be created to serve as the destination.
By default, the Conference activity’s call to the destination is defined as an external call using the
outbound digits defined on the media server. This option can be disabled if the Conference activity is
used to reach internal destinations.
The Conference activity will ring for a designated time (configurable but one minute by default) before
routing down the No Answer branch.

577

Contact Center Solutions User Guide

The following procedures explain how to:
l

Specify a destination for the Conference activity

l

Specify a new extension, queue, or queue group as a destination

l

Specify a new variable as a destination

l

Configure the Conference activity for internal calls

l

Set how long the Conference activity will ring a destination

To specify a destination for a Conference activity
1. Select the Conference activity and click Properties.
2. After Destination, click the … button.
3. Select one of the following from the drop-down list:
l

Extension

l

Queue

l

Queue group

l

Variable

4. Click OK.
5. If the call to the destination will use the outbound digits defined on the media server, ensure
External Call is selected.
6. Click Save.
To specify a new extension, queue, or queue group as a Conference activity’s destination
1. Select the Conference activity and click Properties.
2. After Destination, click the … button.
3. Select one of the following from the drop-down list:
l

Extension

l

Queue

l

Queue group

l

Variable

4. In the Extension, Queue, Queue Group, Variable tabs, at the top of the dialog box, click
Add.
5. To add a new extension, see "Adding extensions for IVR Routing" on page 512.
6. To add a new queue, in the Queue pane, follow the steps under "Adding queues" on page 142.
NOTE:
l

l

l

To configure a new queue for web callbacks, see "Enabling web callbacks" on page
539.
To configure a new queue for abandon callbacks, see "Enabling abandon callbacks" on
page 537.
To associate a queue to an UPiQ workflow, see "Configuring Inqueue routing" on page
518. For information on setting up UPiQ workflows, see "Default Inqueue UPiQ
workflow and subroutine" on page 629.

7. To add a new queue group, follow the corresponding steps in "Adding queue groups" on page
155.
8. To add a new variable, follow the corresponding steps in "Adding variables" on page 553.
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9. Click Save.
10. If the call to the destination will use the outbound digits defined on the media server, ensure
External Call is selected.
11. Click Save.
To configure the Conference activity for internal calls
1. Select the Conference activity and click Properties.
2. Clear the External Call check box.
3. Click Save.
To set the amount of time the Conference activity will ring a destination
1. Select the Conference activity and click Properties.
2. After Timeout Duration, set the number of seconds the Conference will ring a destination.
3. Click Save.

Configuring the Connect to Caller activity
When a caller is waiting in queue, the Connect to Caller activity finds an available UPiQ port and
enables the port to connect to the caller. The activity then executes a subroutine that plays UPiQ
messages to callers waiting in queue, based on criteria you specify.
To specify this criteria, you can assign the Connect to Caller activity the default UPiQ subroutine, or
a reconfigured version of the default UPiQ subroutine. If the caller hangs up or if the activity is not
able to connect to the caller, the Failure branch is followed. If no available UPiQ port is found, the No
Port Available branch is followed.
For information on configuring the Connect to Caller activity in UPiQ workflows, including the Failure
and No Port Available branches, see "Default Inqueue UPiQ workflow and subroutine" on page 629.
The Connect to Caller activity is available in Inqueue workflows.
NOTE: Inqueue workflows containing Connect to Caller activities require UPiQ ports provisioned for
the system. Associating these workflows to queues without having UPiQ ports returns a validation
error when saving the workflow or queue. To provision UPiQ ports for the system, see "Adding
extensions for IVR Routing" on page 512.

Assigning subroutines to the Connect to Caller activity
Assigning subroutines to the Connect to Caller activity enables callers to hear UPiQ messages
while waiting in queue. You can only assign an UPiQ subroutine to the Connect to Caller activity.
NOTE: If you want to create a subroutine for the Connect to Caller activity, we recommend you do
so by reconfiguring the default subroutine shipped with IVR Routing. To access the subroutine,
select IVR Routing=>Subroutines=>Default UPiQ.
To assign a subroutine to the Connect to Caller activity
1. Right-click the Connect to Caller activity and select Assign.
2. Select a subroutine and click OK.
3. Click Save.
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Configuring the Date Time Validation activity
The Date Time Validation activity is used in Callback Inbound subroutines to validate date and time
information stored in the <<CallbackPreferredDateTime>>. The activity checks that the date and
time entered in a previous Collect Digits activity (and collected in the
<<CallbackPreferredDateTime>> variable) is accurate and displays in the day/month/year/time of
day format of DDMMYYYYTTTTXX, where XX is either ‘26’ for AM or ’76’ for PM.
The Date Time Validation activity is available in:
l

Callback Inbound subroutines

Configuring the Delay activity
The Delay activity suspends a workflow for a predetermined time. For example, a customer calling
the system will hear a welcome menu that lasts a certain number of seconds. To test your workflow
and simulate the customer’s experience, you can insert a Delay activity suspending the workflow for
a duration that matches the length of the prompt. The Delay activity also enables third-party
applications to process a command before continuing to a step that requires the processing be
complete.
You can set the duration of a Delay activity to determine for how long the IVR Routing will suspend
the workflow.
The Delay activity is available in
l

Inbound, Outbound, RAD, and Inqueue workflows

l

Inbound, Outbound, RAD, Management, UPiQ, and Callback Inbound subroutines

Setting the duration of Delay activities
To set the duration of a Delay activity
1. Select the Delay activity and click Properties.
2. Set the Duration of the delay.
3. Click Save.

Configuring the DNIS activity
The DNIS activity branches workflows based on the number a customer has dialed. For example,
you can configure DNIS activities to branch calls to a 'Service' section of the workflow as opposed
to a 'Sales' section of the workflow. DNIS activities enable the use of a single workflow and port set
for calls to multiple business lines.
You can add branching conditions to DNIS activities to determine how IVR Routing directs callers
through the workflow. You can also import DNIS conditions from a .csv file or from a DNIS table.
The DNIS activity is available in

580

l

Inbound, Outbound, and Inqueue workflows

l

Inbound, Outbound, Management, UPiQ, and Callback Inbound subroutines
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Adding branching conditions to DNIS activities
To add a branching condition to a DNIS activity
1. Right-click the DNIS activity and select Add Condition.
2. Click Add and type a value or range of values for the DNIS condition.
3. Click the Add icon.
4. To add more DNIS conditions, at the top of the dialog box, click Add.
5. If you want all DNIS conditions in the same branch, deselect the Add each row in a
separate branch check box.
6. Optionally, select the Enable reporting for the Branch check box.
7. To test the DNIS conditions, under Utilities, enter a value or range of values.
If the test is successful, 'Pass' displays.
If the test is unsuccessful, 'Fail' displays.
NOTE: You cannot test a range of values.
8. Click OK to create the branch or click Add to add the current branch to the workflow while
leaving the dialog box open to create new branches.
9. Click Save.
To import and export DNIS conditions
1. Right-click the DNIS activity and select Add Condition.
2. To import DNIS conditions in .csv format click Import =>Import from file and navigate to
the file name.
NOTE:
l
l

Conditions on a single line and separated by a comma will be added to a single branch.
Conditions on multiple lines and separated by a comma will be added to multiple
branches.

3. To import DNIS conditions from a DNIS table, click Import =>Import from DNIS table.
4. Select the DNIS conditions to import and click OK.
5. If you want all DNIS conditions in the same branch, deselect the Add each row in a
separate branch check box.
6. To export DNIS conditions, click Export and navigate to the file name.
7. Optionally, select the Enable reporting for the Branch check box.
8. To test the DNIS conditions, under Utilities, enter a value.
If the test is successful, 'Pass' displays.
If the test is unsuccessful, 'Fail' displays.
NOTE: You cannot test a range of values.
9. Click OK to create the branch or click Add to add the current branch to the workflow while
leaving the dialog box open to create new branches.
10. Click Save.
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Configuring the Email activity
The Email activity enables IVR Routing to send emails, with or without attachments, to recipients
via the SMTP connection configured in YourSite Explorer. You can populate Email fields with
variables, and you can populate email attachments with variables or files. For example, you can use
the Email activity to enable automated emailing of purchase orders and reports from within a
workflow. The Email activity allows electronic information to be sent from within a workflow
efficiently and accurately.
Email activity templates support HTML and text-based content. Template fields can be populated
with variables, and attachments can be populated with variables or files.
You can configure Email activity templates and add and edit SMTP mail server connections to the
Email activity.
You can set email properties to avoid sending multiple auto- response emails when an incoming
email is requeued or transferred.
The Email activity is available in
l

Inbound, Outbound, RAD, and Inqueue workflows

l

Inbound, Outbound, RAD, Management, UPiQ, and Callback Inbound subroutines

NOTE: To configure the SMTP connection in YourSite Explorer, see "Configuring
SMTP connections to Contact Center Solutions" on page 83. To configure email recipients, see
"Configuring email contacts" on page 58.

Configuring Email activity templates
The following explains how to
l

Populate Email templates with text or variables

l

Populate Email templates with images and other web-based media

NOTE:
l

You can populate fields in an Email activity template with a variable by typing the name of the
variable between double-angle brackets. The text between the angle brackets will be replaced
with the value of the variable currently executing in the workflow.
For example, <<ANI>>. In this variable, ANI will be replaced with the number from which the
caller is phoning.
You can also right-click any field in the email template and select a variable from the dropdown list.

l

Variables must be either populated with a value that points to a file path or populated by an
activity within the workflow.

To populate an Email template with text or variables
1. Right-click the Email activity and select Edit Email Template.
2. Configure all email fields as applicable.
NOTE: In the To:, Cc:, and Bcc: fields, separate multiple addresses with a semi-colon.
3. In the body of the email, type the template's text.
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4. To populate fields and attachments with variables, right-click the field and select the variable
from the drop-down list. You can also type the name of the variable between double angle
brackets. For example, <<ANI>>.
5. Click OK.
6. Click Save.
To populate Email templates with images and other web-based media
1. Right-click the Email activity and select Edit Email Template.
2. After Format, select HTML from the drop-down list and click OK.
3. Configure all email fields as applicable.
4. Click Save.

Adding and editing SMTP mail server connections to Email activities
To add and edit SMTP mail server connections to an Email activity
1. Right-click the Email activity and select Edit SMTP Server.
2. Select an SMTP mail server connection and click OK.
3. To add a new SMTP mail server, click the Add button and follow the steps in "Configuring
SMTP connections to Contact Center Solutions" on page 83.
4. To edit an SMTP mail server, select the mail server connection and click the Edit button.
5. Follow the steps in "Configuring SMTP connections to Contact Center Solutions" on page 83.
6. Click OK.
7. Click Save.

Configuring auto-response email settings
The following procedure explains how to configure auto-response email settings.
To configure auto-response email settings
1. Select the Email activity and click Properties.
2. Select the Only Send One Auto Response check box to avoid sending more than one autoresponse.
NOTE: Customers will continue to receive an auto-response for each new email they send but
will not receive multiple, identical auto-responses for emails that are requeued or transferred.
3. Click Save.
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Configuring the Execute activity
The Execute activity enables IVR Routing to interact with external systems by running the following
four processes:
l

l

Executable/Script – Runs an *.EXE file or *.BAT script on the server and delivers return
values or parameters if the script executes successfully.
NOTE: The Execute activity requires *.EXE files and *BAT scripts to be on a UNC path.
PowerShell – Runs a PowerShell script on the server and delivers return values or
parameters if the script executes successfully.
NOTE:
l
l

l

l

The Execute activity requires PowerShell scripts to be on a UNC path.
The Execution Policy for PowerShell scripts must be set in the command prompt
window of PowerShell to Set-ExecutionPolicy RemoteSigned.

Web Service – Enables the Execute activity to retrieve a JSON or XML response from an
external web service using SOAP or REST and delivers return values if the script executes
successfully.
NOTE: The data being returned must be valid XML characters. Any invalid characters (such
as &, <, or >) will not return successfully and the workflow will route down the Failure branch.
The XMLNode object type is not supported.
CRM Service – Sends user-defined queries to a Microsoft CRM 2011, Microsoft CRM 2013,
or Microsoft CRM Online system and delivers return values if the script executes
successfully.

For example, you can use the Execute activity to retrieve customer information from a Web Service
database and store this information in a custom variable for use within the workflow or to pass on to
agents in a screen pop for enhanced customer service. You could also use the Execute activity to
run a PowerShell script enabling an authorized caller to run remote maintenance on the IVR Routing
server. You can configure the options and the process types for Execute activities.
For an example of an IVR Routing workflow that uses the Execute activity to execute PowerShell
and perform a web service SOAP call to a publicly accessible web service, see the following Mitel
Knowledge Base article: http://micc.mitel.com/kb/KnowledgebaseArticle52022.aspx.
The Execute activity is available in
l

Inbound, Outbound, RAD, and Inqueue workflows

l

Inbound, Outbound, RAD, Management, UPiQ, and Callback Inbound subroutines

NOTE: A success return value indicates the process executed without errors, and the Success
branch is followed. A failure return value indicates the process exited with errors and did not
complete as expected, and the Failure branch is followed.
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Configuring options for Execute activities
To configure the options for an Execute activity
1. Select the Execute activity and click Properties.
2. To set waiting prompts to always play to completion before allowing the workflow to proceed,
regardless of whether the process has completed executing, deselect the Barge Prompt
check box.
NOTE: The waiting prompt is what callers hear while they wait for the Execute activity
process to complete. Barge Prompt signifies that the prompt will stop playing once the
process has completed executing.
3. To set the Execute activity to route to the Success branch without waiting for a process to
complete, deselect the Wait for completion check box.
NOTE:
l

l

We recommend you deselect 'Wait for completion' only if you do not require the
Execute activity to retrieve information and return a result. For example, deselect Wait
for completion if you are using the Execute activity to run maintenance.
If the process fails to start, the activity will route to the Failure branch regardless of
whether 'Wait for completion' is deselected.

4. After Waiting Prompt, click the ▼ button and follow the steps under "Adding prompts to Play
activities" on page 598.
NOTE:
l

l

Waiting prompts help keep callers engaged on the line during processes that take
longer than usual to complete.
If the Wait for completion check box is deselected, it is not necessary to configure a
waiting prompt.

5. Optionally, select the Child Reporting Enabled check box.
6. After Timeout (sec), specify how long an associated process has to complete successfully
before executing to the Failure branch.
7. Click Save.

Specifying the external processes to execute in workflows
The following procedures explain how to instruct the Execute activity to run
l

Executable/Script processes

l

PowerShell processes

l

Web Service processes

l

CRM Service processes

To set an Executable/Script or PowerShell process
1. Right-click the Execute activity and select New Process=>Executable/Script or
PowerShell script.
2. For Executable/Script processes, after Path, click the Browse button and navigate to the
*.EXE or *BAT script. The script must be on a UNC path.
3. For Executable/Script processes, select the Separator required by the .exe file. The
separator is the character separating the parameters in the process’ command line statement.
4. For PowerShell processes, navigate to the PowerShell script.
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5. To add a set of Input Parameters, click Add and select the Parameter the process uses to
execute.
NOTE: If batch files or Executable/Script processes require delimiters, they must be entered
manually in the Parameter column.
6. Under Value, select a variable or type a static value.
NOTE:
l
l

The variable is replaced when a call progresses through the workflow.
To configure the process to use a value not linked to a parameter, select a variable from
the Value field and leave the Parameter field blank.

7. Repeat steps 5 and 6 for each set of input parameters the process uses. To delete a set of
parameters, click the arrow to the left of Parameter and click Remove.
8. Under Test Value, enter values to test the process and click Execute.
NOTE: For Executable/Script processes, the Results dialog box lists return values and output
pipeline values.
l

l

For Executable/Script processes, the Results dialog box lists return values and output
pipeline values.
For PowerShell processes, the Results dialog box lists return values and PSObject[X]
values.

9. Click OK to auto-populate the Output Mappings pane with Output values.
10. Leave the Process Setup window open and complete the steps under "Storing retrieved data
as variables" on page 588.
To set a SOAP Web Service process
1. Right-click the Execute activity and select New Process=>Web Service.
2. Type the Web Service URI and, for the Web Service Type, select SOAP.
CAUTION: If you are using the Execute activity with a web service as a part of a PCI
compliant workflow, ensure that you
l

Use an HTTP Secure (https) address.

If the return or input fields of the SOAP call contain sensitive information, use masked
variables in the Input and Output parameters of the Execute activity.
Failure to do so could invalidate your PCI compliance.
l

3. If using a SOAP Web Service, click the Scan button to verify the Web Service.
4. Select a Web Method from the drop-down list. The Web Method populates the Parameters
field.
NOTE: SOAP Web Services populate the Web Methods field with a drop-down list of
available functions.
5. Under Value, select a variable or type a static value.
6. Under Test Value, enter values to test the process and click Execute.
7. On the results dialog box, click OK.
8. Click OK to auto-populate the Output Mappings pane with Output values.
9. Leave the Process Setup window open and complete the steps under "Storing retrieved data
as variables" on page 588.
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To set a REST Web Service process
1. Right-click the Execute activity and select New Process=>Web Service.
2. Type the Web Service URI and, for the Web Service Type, select REST.
CAUTION: If you are using the Execute activity with a web service as a part of a PCI
compliant workflow, ensure that you
l

Use an HTTP Secure (https) address.

If the return or input fields of the REST call contain sensitive information, use masked
variables in the Input and Output parameters of the Execute activity.
Failure to do so could invalidate your PCI compliance.
l

3. Type the Username and Password for the Web Service. Login credentials might not be
necessary depending on the Web Service used.
4. To add a set of Input Parameters, click Add and select the Parameter the process uses to
execute.
5. Under Value, select a variable or type a static Value.
6. Repeat steps 4 and 5 for each set of input parameters the REST Web Service process uses.
To delete a set of parameters, click the arrow to the left of Parameter and click Remove.
7. Under Test Value, enter values to test the process and click Execute.
8. In the XML Output pane of the Results dialog box, select the node containing the information
the Execute activity retrieves.
9. After Selected Node, click the Show Results button.
10. Click OK to auto-populate the Output Mappings pane with Output values.
11. Leave the Process Setup window open and complete the steps under "Storing retrieved data
as variables" on page 588.
To set a CRM Service process
1. Right-click the Execute activity and select New Process=>Microsoft CRM.
2. Type the CRM URI used to communicate with the CRM system.
3. Select the CRM Version.
4. Complete the following fields:
l

Domain – Type the domain name of the CRM site
NOTE: Domain name is only required for CRM 2011 or 2013

l

Username – Type the username for the CRM site login

l

Password – Type the password for the CRM site login

l

Entity Name – Select the name of the CRM entity that the Execute activity queries

5. To add a set of Input Parameters, click Add and select the Parameter the process uses to
execute.
The parameters depend on the Entity Name selected.
6. Under Value, select a variable or type a static Value.
7. Repeat steps 5 and 6 for each set of input parameters the CRM Service process uses. To
delete a set of parameters, click the arrow to the left of Parameter and click Remove.
8. Under Test Value, enter values to test the process and click Execute.
The results dialog shows mappings of the parameters to values.
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9. Click OK.
10. Click Mapping to assign the output to variables, and click OK to store the data as variables.
11. Click Save.

Storing retrieved data as variables
The following procedure explains how to store data retrieved by the Execute activity as a variable.
These variables can be used later in the workflow.
To store retrieved data as a variable
1. In the Process Setup window, under Mapping, select a variable from the drop-down list to
correspond to each Output value.
2. Click OK.
When a call progresses through the workflow, each variable in the Mapping field is assigned
the value indicated in the Output field.
3. Click Save.

Configuring the Go To activity
The Go To activity sends calls to an alternate point in the workflow.
For example, if a customer enters an invalid account number, the Go To activity sends them back
through the workflow so they can enter their digits again. The Go To activity helps minimize the
number of customers routed to the failure branch and helps callers route to the queues best able to
help them.
You can configure destinations for Go To activities, determining the activities to which the Go To
sends callers.
The Go To activity is available in
l

Inbound, Outbound, and Inqueue workflows

l

Inbound, Outbound, Management, UPiQ, and Callback Inbound subroutines

Configuring destinations for Go To activities
To configure a destination for a Go To activity
1. Right-click the Go To activity and select Target...
2. Select the activity to which the Go To returns callers and click OK.
3. If you do not want to increase the repeat count of your workflow, for example if your workflow
uses embedded menus or the Collect Digits activity, in the Properties pane, select the Reset
Repeat Count check box to give callers an unlimited number of attempts to enter information.
4. Click Save.

Configuring the Hang Up activity
The Hang Up activity instructs IVR Routing to end the workflow, preventing callers from waiting on a
dead line and freeing up ports to take new calls. Hang Up activities are inserted at the end of a
workflow or branch. For example, you can insert a Hang Up activity at the end of a 'Closed' branch in
a Schedule activity to terminate the call after a customer hears that the contact center is closed.
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The Hang Up activity is available in
l

Inbound, Outbound, and RAD workflows

l

Inbound, Outbound, RAD, Management, UPiQ, and Callback Inbound subroutines

NOTE: We recommend you insert a Hang Up activity any place where the call could potentially end.
This ensures the call is terminated correctly and the port is freed to accept a new call. Inbound,
Outbound, and RAD workflows must end with a Hang Up activity if they do not end with a Transfer
activity. UPiQ subroutines should end with a Hang Up activity to free the UPiQ port.

Configuring the Hold State activity
The Hold State activity places an agent on hold. In interactions between caller and agent, caller
privacy can be ensured for private or sensitive activities, such as entering credit card information,
without the agent monitoring them. The activity searches for the Agent ID and then places the
corresponding extension on hold. While Hold State activity’s enforced Hold state is active, agents
cannot remove themselves from hold. Hold is only removed when the call finishes routing through
the Success branch of the Hold State activity. The Hold State activity requires no configuration.
Only agents configured in your contact center can be affected by the Hold State activity. Other
callers in your workflows will not be affected.
For an example of how to use the Hold State activity in a workflow in support of PCI compliant
systems, see "Workflow for PCI Compliant systems" on page 652.
The Hold State activity is available in
l

Inbound workflows

l

Inbound subroutines

Configuring the Hunt Group activity
The Hunt Group activity branches workflows based on the hunt group to which a call has been
directed. For example, you can configure a Hunt Group activity to route a call towards 'Technical
Assistance' telephone lines and the queues that use these lines to provide technical support. The
workflow will search the Technical Assistance hunt groups for the first available line and switch the
call onto the line when one is found. The Hunt Group activity enables customers to be efficiently
routed to the services they need. You can add branching conditions to Hunt Group activities to
determine how IVR Routing directs callers through the workflow.
The Hunt Group activity is available in
l

Inbound, RAD, and Inqueue workflows

l

Inbound, RAD, and Callback Inbound subroutines
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Adding branching conditions to Hunt Group activities
Branching conditions represent the criteria by which IVR Routing directs calls.
The following procedures explain how to
l

Add a branching conditions to a Hunt Group activity

l

Import branching conditions from a .csv file

l

Export branching conditions into a .csv file

To add a branching condition to a Hunt Group activity
1. Right-click the Hunt Group activity and select Add condition.
The Hunt Group dialog box opens.
2. To add a hunt group value, click Add and type a value or range of values for the hunt group
condition.
3. Click the Add icon.
l

l

To branch all calls from a specified area code, city exchange, or other number
identification, include an 'x' at the end of the numeric value. 'x' indicates multiple
wildcard characters.
To indicate individual digits or to set branching conditions to match any Hunt Group,
include question marks instead of numeric values.

4. To import hunt group conditions in .csv format, click Import, navigate to the file name, and
click Open.
5. To export the hunt group conditions in .csv format, click Export, select a file location and file
name and click Save.
NOTE:
l
l

Conditions on a single line and separated by a comma will be added to a single branch.
Conditions on multiple lines and separated by a comma will be added to multiple
branches.

6. To add more hunt group conditions, at the top of the Hunt Group dialog box, click Add.
7. If you want all Hunt Group conditions in the same branch, clear the Add each row in a
separate branch check box.
By default, separate branches are added for each condition.
8. To enable reporting for the branch, select the Enable reporting for this Branch check box.
9. To test the hunt group conditions, under Utilities, enter a value or range of values.
If the test is successful, 'Pass' displays.
If the test is unsuccessful, 'Fail' displays.
NOTE: You cannot test a range of values.
10. Click OK to create the branch or click Add to add the current branch to the workflow while
leaving the dialog box open to create new branches.
11. Click Save.
To import branching conditions from a .csv file
1. Right-click the Hunt Group activity and select Import Conditions.
2. Navigate to the .csv file and click Open.
3. Click Save.
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To export branching conditions into a .csv file
1. Right-click the Hunt Group activity and select Export Conditions.
2. Navigate to the .csv file and click Save.

Configuring the Language Activity
The Language activity changes IVR Routing’s system language, enabling the IVR to provide an
identical workflow in different languages. When the Language activity is reached in the workflow, all
subsequent prompts play in the set language. For example, you can insert a Language activity into a
menu to allow customers to choose the language in which they receive service. By supporting
multiple languages in a single workflow, the Language activity reduces the number of prompts you
must create and the number of duplicate activities in your workflow. The Language activity also
reduces the number of ports that IVR Routing uses by allowing the same set of ports to be used for
multiple languages. You can set and edit the languages for Language activities.
The Language activity is available in
l

Inbound, Outbound, and RAD workflows

l

Inbound, Outbound, RAD, Management, UPiQ, and Callback Inbound subroutines

NOTE: The language value is stored within the <<Language>> system variable. Each subsequent
Language action overwrites the value in the system variable.

Setting and editing languages for Language activities
The following procedures explain how to:
l

Set the language for a Language activity

l

Edit the language for a Language Activity

To set the language for a Language activity
1. Right-click the Language activity and select Select Language.
2. Select one of the following languages for the workflow
l

Chinese Simplified

l

Dutch

l

English United Kingdom

l

English United States

l

French Canada

l

French France

l

German

l

Italian

l

Portuguese Brazil

l

Russian

l

Spanish Latin America

l

Spanish Spain

3. Click Save.
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To edit the language
1. Right-click the Language activity and select Select Language.
2. Select a different language for the workflow.
3. Click Save.

Configuring the Make Call activity
The Make Call activity prompts an associated port to process an outbound call to a specified
destination. This destination can be retrieved from a data source including a SQL database, an Excel
file, a Web Service call, or custom variable. For example, you can use the Make Call activity as part
of an outbound workflow designed to contact customers during an advertising campaign. You can
assign the Make Call activity a destination, set the amount of time the port has to make the call
before IVR Routing terminates the action, and add new devices to Make Call activity destinations.
Calls route through the Success branch of Make Call if the activity calls the destination and the
destination answers. Calls route through the No Answer branch if the Make Call activity calls the
destination, but the call to the destination times out. Calls route through the Destination Busy branch
if the Make Call activity calls the destination, but the destination is busy. Calls route through the
Invalid Destination ranch if the Make Call activity calls the destination, but the destination does not
correspond to an existing phone number. Calls route through the Failure branch if the destination fails
and the Make Call activity does not make a call.
The Make Call activity is available in
l

Outbound workflows

l

Outbound subroutines

NOTE: As part of Outbound workflows, the Make Call activity is only available with IVR Routing
Premium Licensing.

Configuring options for Make Call activities
The following procedures explain how to:
l

Specify a destination for a Make Call activity

l

Configure the Make Call activity for internal calls

l

Set how long a Make Call activity will ring a destination

To specify a destination for a Make Call activity
1. Select the Make Call activity.
2. In the Properties pane, after Destination click the … button.
3. Select one of the following from the drop-down list:
l

Extension

l

Queue

l

Queue group

l

Variable

4. Click OK.
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5. If the call to the destination will use the outbound digits defined on the media server, ensure
External Call is selected.
6. Click Save.
To configure the Make Call activity for internal calls
1. Select the Make Call activity.
2. Clear the External Call checkbox.
3. Click Save.
To set how long a Make Call activity will ring a destination
1. Select the Make Call activity.
2. After Timeout Duration, set the number of seconds the Make Call will ring a destination.
3. Click Save.

Adding new devices to Make Call destinations
To specify a new extension, queue, or queue group as a destination
1. Select the Make Call activity.
2. In the Properties pane, after Destination click the … button.
3. Select one of the following from the drop-down list:
l

Extension

l

Queue

l

Queue group

l

Variable

4. At the top of the dialog box, click Add.
5. To add a new extension, see "Adding extensions for IVR Routing" on page 512.
6. To add a new queue, in the Queue pane, follow the steps under "Adding queues" on page 142.
NOTE:
l

l

l

To configure a new queue for web callbacks, see "Enabling web callbacks" on page
539.
To configure a new queue for abandon callbacks, see "Enabling abandon callbacks" on
page 537.
To associate a queue to an UPiQ workflow, see "Configuring Inqueue routing" on page
518. For information on setting up UPiQ workflows, see "Default Inqueue UPiQ
workflow and subroutine" on page 629.

7. To add a new queue group, follow the applicable steps in "Adding queue groups" on page 155.
8. Click Save.
9. If the call to the destination will use the outbound digits defined on the media server, ensure
External Call is selected.
10. Click Save.
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Configuring the Management activity
The Management activity represents a management plan that is available to authorized callers,
enabling them to manage the state of IVR Routing and its prompts over the phone. For example, if
the contact center is unexpectedly closed due to severe weather, a manager working from home can
use the Management activity to set the IVR to Emergency mode and record a prompt informing
callers of the center’s closure. You assign subroutines to Management activities and if you are using
the Default Management Subroutine, configure remote access options for authorized callers.
The Management activity is available in
l

Inbound workflows

l

Inbound, Management, and Callback Inbound subroutines

Assigning subroutines to Management activities
IVR Routing provides a default Management subroutine. For information on building subroutines to
assign to Management activities, see "Building subroutines" on page 534.
To assign a subroutine to a Management activity
1. Select the Management activity.
2. In the Properties pane, after Management Subroutine, click the ...button.
3. Click either the Subroutines or Variables tab and select a subroutine or a variable to assign
to the activity.
4. If you want to assign a new variable, under the Variables tab, click Add and follow the
corresponding steps in "Configuring variables" on page 552.
5. Click OK.
6. Click Save.
To view the assigned subroutine or variable
l

Right-click the Management activity and click Open.
The assigned subroutine or variable opens.

Configuring properties for remote access to the Default Management
Subroutine
To configure properties for remote access to the Default Management Subroutine
1. Right-click on the Management activity and select Open.
2. Select the 'Enter Management Password' Menu activity.
3. To enable callers to skip instructions using a digit entry, select the Barge In check box.
4. After In Between Digit Delay, set time taken to reset each digit after it is pressed.
NOTE: Between 1 to 5 seconds is recommended.
5. After Invalid Attempts, set the number of times a caller can enter incorrect digits before being
routed down the Failure branch.
6. After No digit timeout (sec), set the amount of time that IVR Routing will wait for a caller to
enter digits before routing the call to the Timeout branch.
NOTE: If this time elapses, IVR Routing will send the caller back through the workflow.
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7. After Timeout Attempts, set the number of times the No digit timeout (sec) can expire before
routing the call through the Failure branch.
8. After Instructions, click the ▼ button and follow the steps under "Configuring an activity’s
prompts" on page 564.
NOTE: Instructions play prompts and menu options to an authorized caller.
9. To enable reporting, select the Child Reporting Enabled check box.
10. Right-click the Menu condition branch '1234' and click Edit Condition.
11. Click the condition '1234' and enter the new management password.
12. Click the Add icon.
13. Click OK.
14. Click Save.

Configuring the Menu activity
The Menu activity prompts callers with messages and manages routing based on caller input. For
example, you can configure the Menu activity to ask customers to press '1' on their dial pad to reach
Technical Support and '2' if they want to reach Sales. IVR Routing then directs callers to the
appropriate queue based on the number they pressed. The Menu activity enables efficient routing to
the appropriate queue. You can configure the prompts callers hear, input options, and digit options for
Menu activities.
The Menu activity is available in
l

Inbound and Outbound workflows

l

Inbound, Outbound, Management, UPiQ, and Callback Inbound subroutines

NOTE: Due to the inability to use Set Variable for specifying a masked variables value, the Menu
activity cannot be used with a wildcard branch and a Set Variable activity with masked variables as
the masked variables will be exposed in the LastMenuCollectedDigits variable in the query string.

Configuring options for Menu activities
The following procedures explain how to:
l

Configure options for the Menu activity

l

Configure instructions for the Menu activity

l

Configure reporting for the Menu activity

To configure options for the Menu activity
1. Select the Menu activity.
2. To enable callers to skip instructions using a digit entry, select the Barge In check box.
3. After In Between Digit Delay, set the time taken to reset each digit after it is pressed
NOTE: Between 1 to 5 seconds is recommended.
4. After Invalid Attempts, set the number of times callers can try to enter information.
NOTE: If this number is exceeded, IVR Routing sends the call to the Failure branch.
5. After No digit timeout (sec), set the time to wait if the user does not enter any digits.
NOTE: If this time elapses, IVR Routing will send the call to the Timeout branch
6. After Timeout Attempts, set the number of times users can timeout before being routed down
the Failure branch.
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To configure instructions for the Menu activity
1. Select the Menu activity.
2. After Instructions, click the ▼ button and follow the steps under "Configuring an activity’s
prompts" on page 564.
NOTE: Instructions play prompts and menu options to callers.
3. Click Save.
To configure reporting for the Menu activity
1. Select the Menu activity.
2. To enable reporting for this branch, select the Child Reporting Enabled check box.
3. Click Save.

Configuring Menu activity branches
Menu branches are the numbers callers select to navigate the IVR Routing menu.
To configure digit options
1. Right-click the Menu activity and select Add branch.
The Menu dialog box opens.
2. To add a digit option, at the top of the dialog box, click Add and type a value or range of
values.
NOTE:
l

l

Adding question marks to a dig it option enables callers to enter customer-specific
information, of a set length, into IVR Routing. For example, you may have a menu
asking callers who are members to enter their 10-digit membership number. Adding a
digit option of '??????????' will route all callers entering a 10-digit number to the
appropriate queue.
Adding the letter 'x' to a digit option enables callers to enter customer-specific
information of an unspecified length. For example, you may have a menu asking callers
to enter their telephone number, including extensions. Adding a digit option of '613x' will
route all callers phoning from a 613 area code to the appropriate queue.

3. Click the Add icon.
4. To import hunt group conditions in .csv format, click Import, navigate to the file name, and
click Open.
5. To export the hunt group conditions in .csv format, click Export, select a file location and file
name and click Save.
NOTE:
l

l

Digit options on a single line and separated by a comma will be added to a single
branch.
Digit options on multiple lines and separated by a comma will be added to multiple
branches.

6. To add more digit options, at the top of the Menu dialog box, click Add.
7. If you want all digit option conditions in the same branch, clear the Add each row in a
separate branch check box.
By default, separate branches are added for each condition.
8. To enable reporting, select the Enable reporting for this Branch check box.
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9. To test the digit options, under Utilities, enter a value or range of values.
If the test is successful, 'Pass' displays.
If the test is unsuccessful, 'Fail' displays.
10. Click OK to create the branch or click Add to add the current branch to the workflow while
leaving the dialog box open to create new branches.
11. Click Save.

Configuring the Mode of Operation activity
The Mode of Operation activity branches workflows to a secondary type of operation when the
contact center is temporarily out of service. It can also change IVR Routing back to the Normal
mode. For example, you can use the Mode of Operation activity to route calls to an Emergency
branch if the contact center is closed due to severe weather. You can add activities to the Mode of
Operation activity’s branches to determine how IVR Routing directs callers through the workflow in
the event of an Emergency or in the case of Normal operations.
The Mode of Operation activity is available in
l

Inbound workflows

l

Inbound and Management subroutines

NOTE: For more information on setting IVR Routing to Emergency mode, see "Configuring the Set
Device Mode of Operation activity" on page 618 and "Configuring the Set System Mode of Operation
activity" on page 619.

Configuring Mode of Operation activities for Emergency and Normal
modes
Configure the Mode of Operation activity by specifying the actions a workflow will take in
Emergency and Normal modes.
To configure a Mode of Operation activity for Emergency and Normal modes
1. In the Workflow Canvas, expand the Mode of Operation activity.
2. From the Toolbox pane, drag activities to the Emergency or Normal branch.
3. To enable reporting on the activity's branches, select the Child Reporting Enabled check
box.
4. To enable reporting on a single branch, select the branch and select the Reportable check
box.
5. Click Save.
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Configuring the Play activity
The Play activity enables IVR Routing to play messages or read back the contents of variables to
callers. The Play activity can play a prompt or a single wave file to customers. For example, you can
use a Play activity to greet callers and ask them to hold for the next available agent. You can add a
new prompt to a Play activity, add a prompt that you have previously recorded, or add a variable to a
prompt. For more information on configuring prompts in workflows, see "Configuring prompts" on
page 532.
The Play activity is available in
l

Inbound, Outbound, and RAD workflows

l

Inbound, Outbound, RAD, Management, UPiQ, and Callback Inbound subroutines

NOTE: The duration of a prompt is stored within the <<LastWavePlayedDuration>> system
variable. This value will be overwritten any time a wave file is played in the workflow.

Adding prompts to Play activities
Prompts are the messages callers hear at specified points in the workflow.
To enable callers to skip prompts using a digit entry
1. Select the Play activity and click Properties. .
2. Select the Barge Enable check box.
3. Click Save.
To add an existing prompt to a Play activity
1. Select the Play activity and click Properties.
2. After Greeting Prompts, click the ▼ button and select Select from an existing prompt.
3. Select a prompt and click OK.
4. Click Save.
To add a new prompt
1. Select the Play activity and click Properties.
2. After Greeting Prompts, click the ▼ button and select Add a new prompt.
3. After Language, select the primary language from the drop-down list.
NOTE:
l

The language you select determines the system wave files available to you.

l

By default, the language is set to the default site language.

4. Type a Name for the prompt.
5. Type a Description for the prompt.
6. Select a Category for the prompt from the drop-down list:
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Callback

l

Custom

l

Management

l

Samples

l

UPiQ
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7. To create your own category, after Category, type a name for the new category.
NOTE: Prompt categories are an organizational tool to help keep prompts sorted and easily
accessible.
8. Select one of the following tabs:
l

l

l
l

l

System wave files–lists the system wave files callers hear while in the IVR or while
waiting on hold. This pane will only show the wave files that are available in the
language you have selected.
Custom wave files–lists imported and recorded wave files. To import or record a
custom wave file, click 'Add' and select 'Existing wave file' to import the file or 'Record
wave file' to use the microphone on your computer to record the file.
NOTE: Wave files must be 8khz, Mono, or ULAW format.
Queue stats–lists up-to-date queue statistics for use in prompts
Variables–lists all variables available for use in prompts
NOTE: Read back on variables is based on the type of variable. Number variables read
back the whole number, while digit variables read back individual numbers. For
example, number variables would read 123 as 'one hundred and twenty-three', while
digit variables would read 123 as 'one, two, three'.
Prompts used in workflows and subroutines–lists all prompts used in workflows
and subroutines

9. In the All system wave files, All custom wave files, All queue stats, All variables, or
Prompts used in workflows and subroutines pane, select the files to add to the prompt.
10. Click > to add the file to the prompt.
NOTE: The wave files play in the order they are added to the prompt. To change the order in
which the wave files will be played, select the wave file and click the up or down arrow buttons
on the right-hand side of the dialog box.
11. Click Save.
NOTE: If you are adding prompts in a new language, you must add audio files that correspond
to the existing audio files in IVR Routing’s default language. Otherwise, the caller will not hear
anything when the prompts are supposed to be playing.
To add a variable to a prompt
1. Select the Play activity and click Properties.
2. After Greeting Prompts, click the ▼ button and select Add a variable to a prompt.
3. Select the variable and click OK.
4. Click Save.
To add a new variable to a prompt
1. Select the Play activity and click Properties.
2. After Greeting Prompts, click the ▼ button and select Add a variable to a prompt.
3. Click the Add button.
4. Type a Name for the variable. The name must be unique and cannot contain spaces.
5. Type a Description for the variable.
6. After Variable Type, select a type from the drop-down list.
NOTE: A variable's type cannot be changed after you save.
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7. If Mask Type is available to this type of variable, select the variable’s mask from the dropdown list.
l

l

l

l

NoMask– The variable will not be masked within IVR Routing and associated screen
pops, databases, etc
FullMask– The entire variable will be masked within IVR Routing and associated
screen pops, databases, etc
MaskAllExceptLastX– The variable will be masked except for the specified number of
final characters
MaskAllExceptFirstX– The variable will be masked except for the specified number of
first characters

8. If you selected MaskAllExceptLastX or MaskAllExceptFirstX, specify the number of
characters to be left unmasked.
9. To enable this variable to display in a toaster notification or screen pop, select the Send to
agent desktop check box.
10. Type the Display Name that this variable has when it appears in a toaster notification or
screen pop.
11. If you selected Dollars, Euros, or Pounds as the variable type, after Currency Format, select
the format from the drop-down list.
12. If you selected Date Time as the variable type, after Date Format, select the date format from
the drop-down list. After Time Format, select the time format from the drop-down list.
13. Click Save.
To clear a prompt
1. Select the Play activity and click Properties.
2. After Greeting Prompts, click the ▼ button and select Clear Prompt.
3. Click Save.
To add a prompt to a Play activity using Quick Add Prompt
1. Select the Play activity and click Properties.
2. After Greeting Prompts, click the ▼ button and select Quick Add Prompt.
3. Navigate to the .wav file and click Open.
4. Click Save.

Configuring the Query activity
The Query activity reads and writes information through an MS SQL connection, ODBC connection,
Excel sheet, or LDAP provider. Administrators can use the Query activity to retrieve information and
store it in custom variables for use within workflows. Advanced queries return multiple records of
information that can be stored in multiple variables.
For example, you can use the Query activity to retrieve customer account balances for the past year.
Callers can then have their account history read back to them from within the workflow. You can
configure the data providers for Query activities, configure simple or advanced queries, and define
simple or advanced write statements for Query activities.
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The Query activity is available in
l

Inbound, Outbound, RAD, and Inqueue workflow

l

Inbound, Outbound, RAD, Management, UPiQ, and Callback Inbound subroutines

CAUTION: IVR Routing can mask variables to protect information used in queries but customers
are responsible for implementing appropriate network security to encrypt information passing
between IVR Routing and data providers.
NOTE:
l

l

By default, the query result is stored within the <<LastQueryResult>> system variable. Each
subsequent Query action overwrites this variable. It is not recommended to use the
LastQueryResult variable when expecting protected information to be contained within this
variable.
For more information on configuring data providers, see "Configuring data providers" on page
550.

Connecting Query activities to data providers
Connecting Query activities to data providers enables the Query activity to access data and use this
information to route contacts. For more information on creating data providers, "Configuring data
providers" on page 550.
To assign a data provider to a Query activity
1. Select the Query activity.
2. In the Properties pane, after Data Provider, click the … button.
The Select Connection window opens.
3. Select the data provider for the query and click OK.
NOTE: The Query activity cannot be saved without a query or write statement configured.

Running simple queries in workflows
Running simple queries enables administrators to retrieve information from a database and store it in
a variable.
To run a simple query in a workflow
1. Select the Query activity and click Properties.
2. After Query statement, click the Browse button and, under Query Type, select Simple
Query.
3. After Database Table Name, from the drop-down list, select the table to query.
'Database table names' refer to the tables in the data source from which the Query activity
retrieves information.
4. After Column Return Name, from the drop-down list, select the column of data to query.
'Column return names' refer to the columns in the selected table, from which the Query
activity retrieves information.
5. After Variable Return Name, from the drop-down list, select the variable to populate with the
return value.
'Variable return names' refer to the variables populated as a result of the query.
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6. After Column Where Name, from the drop-down list, select the name of the column of data
to compare against.
'Column where names' refer to the columns in the data source against which the Query
activity compares information.
7. After Variable Where Name, from the drop-down list, select the variable to use for
comparison.
'Variable where names' refer to the variables against which the Query activity compares.
8. To enable the activity to convert digits into text values, select the Dialpad Compare
checkbox.
For example, if a caller is trying to reach an employee’s telephone extension, dialpad compare
enables the caller to enter the letters of the employee’s name into their dialpad instead of
entering an extension number.
9. To test the query, after Test with a value equal to, enter an existing value from the data
provider and click Test Query.
The Raw SQL window displays the SQL statement based on the selections from the dropdown lists.
10. To clear all fields and return to the Canvas, click Clear. To accept the query, click OK.
11. Click Save.

Configuring Query activities with advanced queries
Advanced queries enable administrators with knowledge of SQL to write SQL statements retrieving
information from a database provider. Advanced queries also support LDAP syntax for LDAP
providers, and advanced queries for MS SQL Server and ODBC data providers support stored
procedures.
To run an advanced query in a workflow
1. Select the Query activity and click Properties.
2. After Query statement, click the Browse button, and under Query Type, select Advanced
Query.
3. Under Query, type the SQL statements to be run directly against the data provider and click
Execute.
The Execute window opens displaying a list of detected input and output parameters.
4. Under Value, type the numbers corresponding to the values contained in the data provider.
5. To enable the activity to convert digits into text values, select the Use Dialpad Compare
check box.
6. Click Run.
7. To assign variables to store information returned by the SQL statements, click the Variable
Assignment tab.
Return Column will be populated with the column names in the data provider.
8. Under Variable Name, select the variables to store information returned by the SQL
statements.
9. To assign values to the parameters filled by the SQL statements, click the Parameter
Assignment tab.
Parameter Name will be populated with the SQL parameters used to query the data provider.
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10. After Variable Name, select a variable from the drop-down list to store the information
retrieved by the SQL parameter.
11. To translate parameters from a dial-pad digit, select the Dialpad checkbox.
12. To view the values returned from the query, click the Test Results tab.
13. To clear the variables and their parameters, click Clear. To accept the query, click OK.
14. Click Save.

Defining write statements
Write statements define a delete, insert, or update statement against a specified data provider. Write
statements enable administrators to delete, insert, or update column values in a data provider from
within a workflow.
The following procedures explain how to configure simple and advanced write statements
NOTE: Advanced write statements enable users with knowledge of SQL to write insert, update, or
delete SQL statements.
To define a simple write statement
1. Select the Query activity, click Properties and, after Write statement, click the Browse
button.
2. Select Simple Write and select a Write Type from the drop-down list. Options vary by data
provider.
3. After Table Name, select the table in the data provider against which the write statement is
defined.
4. Under Column Name, select a column in the data provider against which the write statement
is defined.
5. Under Value, select the data to be inserted into Excel or SQL data provider.
6. Under Where, select a column name.
NOTE:
l

‘Where’ statements display only if Delete or Update is selected

l

The column names displaying in the list derive from the Table Name selected.

7. Select an operator from the drop-down list
l

=

l

<>

l

>

l

<

l

>=

l

<=

8. From the third drop-down list, select or type the variables used to evaluate the information
selected from the first column
9. To test the write statement, click Test Syntax.
10. To empty column values, click Clear. To accept the write statement, click OK.
11. Click Save.
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To define an advanced write statement
1. Select the Query activity, click Properties.
2. After Write statement, click the Browse button and select the Advanced Write button.
3. Under Query, type the insert, update, or delete SQL statements to be run against the data
provider and click Execute.
4. The Parameter name column will be populated with the column names in the data provider.
5. Under Variable Name, from the drop-down list, select the variables used to evaluate the
information you selected from the first column.
6. To test the write statement, click Test Syntax.
7. To empty column values, click Clear. To accept the write statement, click OK.
8. Click Save.

Returning multiple results with queries
The Query activity supports returning multiple results from a query. When a Query activity returns
multiple results from a query, the call is looped through the Success branch for each result unless it
is interrupted by a caller-activated activity, such as Go To or Transfer. When there are no more
results for the Success branch to loop, the call exits the Success branch of the Query activity and
continues along the workflow.
Multiple result returning Query activities enable contact centers to build more complex workflow
functions, such as providing callers access to an employee directory.
For more information on returning multiple results with queries, see the following Mitel Knowledge
Base article: http://micc.mitel.com/kb/KnowledgebaseArticle51935.aspx.

Configuring the Queue activity
The Queue activity branches workflows based on real-time queue conditions, enabling you to route
calls based on emerging queue conditions. The Queue activity supports ring group queue conditions.
For example, you can configure a Queue activity to check queue conditions and offer a Callback
Request activity to callers experiencing long wait times. The Queue activity can help to lessen
abandoned calls and manage Service Level objectives by routing calls based on emerging queue
conditions.
You can add and edit branching conditions for queue activities and group queue conditions to
determine how IVR Routing directs callers through the workflow. Queue group real-time condition
definitions vary depending on the type of queue group. For more information, see "Real-time queue
conditions and queue groups" on page 607.
The Queue activity is available in
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l

Inbound, Outbound, RAD, and Inqueue workflows.

l

Inbound, Outbound, RAD, UPiQ, and Callback Inbound subroutines
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Applying queue conditions to the Queue activity
The following explains how to
l

Associate queue conditions to a queue, queue group, or variable

l

Associate queue conditions to a variable

l

Edit and delete queue conditions

l

Import and export queue conditions

l

Group queue conditions

NOTE:
l

l

The actions that IVR Routing takes when queue conditions are met are determined by
activities you insert into the Drop Activities Here section of the Workflows Canvas for that
Queue condition.
The workflow evaluates Queue conditions from left to right. For information on how to change
the order of Queue conditions, see "Changing the order in which branches are evaluated" on
page 569.

To associate queue conditions to a queue or queue group
1. Right-click the Queue activity and select Add.
2. Type a Name for the queue condition and, after Queue, click the ...button.
3. Select either Queue or Queue Group, select the queue or queue group; and click OK.
NOTE: For information on how queue groups use queue real-time statistics, see "Real-time
queue conditions and queue groups" on page 607.
4. Click Add and, from the second column, select a real-time statistic from the drop-down list.
NOTE: Expected Wait Time requires at least one call waiting in queue for IVR Routing to
calculate an Expected Wait Time value.
5. In the third column, select an operator from the drop-down list. Options vary according to the
variable chosen.
6. Click the fourth column and select either Value, Queue Stats, or Variable.
7. For Value, type in a numeric value or enable the check box for the value.
8. For Queue Stats, select a queue stat from the drop-down list.
9. For Variable, select a variable from the drop-down list.
10. To test the conditions, click Test Parameters, enter a value in the relevant fields and click
Test.
11. Click OK.
12. To add another condition, click Add and repeat steps 4-11.
13. Click OK to create the branch or click Add to add the current branch to the workflow while
leaving the dialog box open to create new branches.
14. Click Save
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Associate queue conditions to a variable
NOTE: Associating queue conditions to a variable requires first inserting and configuring an activity
on the Canvas capable of populating the Queue activity’s destination variable.
1. Right-click the Queue activity and select Add.
2. Type a Name for the queue condition and, after Queue, click the ...button.
3. Select the Variable tab, select a variable, and click OK.
Only Numbers, Digits, Queue, and Unspecified variable types are available.
4. Click Add and, from the second column, select a real-time statistic from the drop-down list.
5. In the third column, select an operator from the drop-down list. Options vary according to the
variable chosen.
6. Click the fourth column and select either Value, Queue Stats, or Variable.
7. For Value, type in a numeric value or enable the check box for the value.
8. For Queue Stats, select a queue stat from the drop-down list.
9. For Variable, select a variable from the drop-down list.
10. To test the conditions, click Test Parameters, enter a value in the relevant fields and click
Test.
11. Click OK.
12. To add another condition, click Add and repeat steps 4-11.
13. Click OK to create the branch or click Add to add the current branch to the workflow while
leaving the dialog box open to create new branches.
14. Click Save
To edit and delete queue conditions
1. To edit queue conditions, right-click the relevant branch in the Queue activity and select Edit
Condition.
2. To delete a queue condition, select the row for the condition and click Delete.
To import and export queue conditions
1. To import queue conditions, click the Import button and navigate to a *.csv file.
NOTE:
l
l

Conditions on a single line and separated by a comma will be added to a single branch.
Conditions on multiple lines and separated by a comma will be added to multiple
branches.

2. To export queue conditions, click the Export button and navigate to a *.csv file.
3. To test the conditions, click Test Parameters, enter a value in the relevant fields and click
Test.
To group conditions being compared
l
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Real-time queue conditions and queue groups
IVR Routing supports both queue conditions with queue group conditions. Queue group queue
conditions are defined differently than queue conditions. Between reporting queue groups and virtual
queue groups, however, there are some differences between how the queue conditions stats are
calculated. Table 44 outlines how queue condition statistics are applied to reporting and virtual queue
groups.
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Table 44: Queue Groups Queue Condition statistics definitions
QUEUE
CONDITION
STATISTIC
Agents Available

REPORTING QUEUE GROUP
DEFINITION

VIRTUAL QUEUE GROUP
DEFINITION

The sum of the available agents in all
member queues

The number of available agents found in
the first Online queue

Agents Idle

The sum of the idle agents in all member The number of idle agents found in the
queues
first Online queue

Agents
Unavailable

The sum of the unavailable agents in all
member queues

The number of unavailable agents found
in the first Online queue

Average Time to
Abandon

The sum of the duration of the abandons divided by the sum of the abandons from
all queues in the group

Average Time to
Answer

The sum of the answer duration of the calls divided by the sum of the calls
answered from all queues in the group

Call Load

Expected Wait
Time

The sum of Calls Waiting in all queues
in the group divided by the sum of
Agents Available in all queues in the
group

The sum of the Calls Waiting in all
queues in the group divided by the
number of Agents Available in the first
Online queue

If there are agents available, the
Expected Wait Time is the Average
Talk Time for the queues in the group
multiplied by Calls Waiting in all Queues
in the group, divided by all Available
Agents in the group

If there are agents available, the
Expected Wait Time is the Average
Talk Time for the queues in the group
multiplied by Calls Waiting in all queues
in the group, divided by the Available
Agents in the first Online queue in the
group

If there are no agents available, the
Expected Wait Time is the sum of the
answer duration of the calls divided by
the sum of the calls answered from all
queues in the group

If there are no agents available, the
Expected Wait Time is the sum of the
answer duration of the calls divided by
the sum of the calls answered from all
queues in the group

Last Queue
The last queue update received from any queue in the queue group
Update Received
Longest Wait
Time
Number of Calls
Waiting
Path DND
Service Level
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The longest time that a call has been waiting in all of the queues in the queue group

The sum of the number of calls waiting in each member queue of the queue group
Checks if any member of the group is in Do Not Disturb
The service level of the queue group
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Configuring the Record activity
The Record activity enables authorized callers to record a wave file over the phone as opposed to
using a microphone in a computer. For example, a manager can call into IVR Routing from home and
use the Record activity to record a wave file to populate a custom prompt for Play activities. The
Default Management Subroutine that ships with IVR Routing includes a Record activity for this
purpose. You can use the Default Management Subroutine to record prompts for Play activities in
your workflow. The Record activity is also used by callers to record a message to accompany their
callback request in the Default Inbound Voice Callback subroutine. The Record activity increases
the flexibility with which you can create custom prompts for your workflow and respond to afterhours conditions affecting the call center’s operations.
You can configure Record activities with prompts to determine the message authorized callers hear
when they dial the IVR Routing system, and configure recording options for authorized users
phoning into the system. You can also set the options by which an authorized caller reviews,
accepts, or rejects a message they recorded.
The Record activity is available in
l

Inbound workflows

l

Inbound, Management, UPiQ, and Callback Inbound subroutines

Configuring Record activities with prompts
By default, the Record activity is automatically assigned an instruction prompt. This prompt can be
changed to another prompt, but the Record activity must have an instruction prompt assigned to it.
Optionally, a confirmation prompt can be assigned to the Record activity to inform callers that their
recording is complete. If no confirmation prompt is assigned to a Record activity, users are directed
to the Save branch.
To change the Record activity's Instruction prompt
1. Select the Record activity and click Properties.
2. To configure recording instructions for authorized callers, after Instructions, click the dropdown list and select from the following:
l

Add a new prompt

l

Quick Add Prompt

l

Clear prompt

l

Select from an existing prompt

3. If you are adding a new prompt, follow the appropriate steps under "Configuring an activity’s
prompts" on page 564.
NOTE: Adding a prompt requires you to select a wave file in IVR Routing, which will be added
to the system as a prompt.
4. If you are Quick Adding a prompt, follow the appropriate steps under "Configuring an activity’s
prompts" on page 564.
NOTE: Quick Adding a prompt enables you to populate the recording instructions with a wave
file saved on your machine. The prompt is created in IVR Routing and is given the file name.
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5. If you are selecting an existing prompt, select the prompt from the list offered to you and click
OK.
6. To remove a prompt from recording instructions, after Instructions, click the drop-down list
and select Clear prompt.
7. Click Save.
To configure a Record activity with a confirmation prompt
1. Select the Record activity and click Properties.
2. To configure recording instructions for authorized callers, after Confirmation Prompt, click
the drop-down list and select from the following:
l

Add a newprompt

l

Quick Add Prompt

l

Clear prompt

l

Select from an existing prompt

3. If you are adding a new prompt, follow the appropriate steps under "Configuring an activity’s
prompts" on page 564.
NOTE: Adding a prompt requires you to select a wave file in IVR Routing, which will be added
to the system as a prompt.
4. If you are Quick Adding a prompt, follow the appropriate steps under "Configuring an activity’s
prompts" on page 564.
NOTE: Quick Adding a prompt enables you to populate the recording instructions with a wave
file saved on your machine. The prompt is created in IVR Routing and is given the file name.
5. If you are selecting an existing prompt, select the prompt from the list offered to you and click
OK.
6. To remove a prompt from recording instructions, after Confirmation Prompt, click the dropdown list and select Clear prompt.
7. Click Save.

Clearing prompts from Record activities
The following explains how to remove prompts from Record activities.
To clear a prompt from the Record activity
l

Right-click the Record activity and select either Edit Instruction Prompt=>Clear prompt
or Edit Confirmation Prompt=>Clear prompt.

Configuring recording options
You can configure the recording options for authorized users phoning in to the system.
1. Select the Record activity and click Properties.
2. To remove a date and time stamp from the wave file name, deselect the Append Date Time
Stamp check box.
3. After Output Name, type a name for the wave file being recorded.
NOTE: The output name must be a valid file name but may contain variables enclosed
between double angle brackets. For example: <<ANI>>. The text between the angle brackets
will be replaced with the value of the variable currently executing in the workflow.
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4. After Recording Timeout (sec), type the number of seconds an authorized caller has to
record a message.
NOTE: This figure determines the amount of time before the Timeout branch is followed.
5. After Termination Digit, from the drop-down list, select a number that an authorized caller
enters to end the recording.

Configuring the Save, Discard, and Review branches of the Record
activity
The Record activity contains an embedded menu with three options. After recording a message,
authorized callers are presented with the option of pressing one to save their message, pressing two
to discard and re-record their message, and pressing three to review their message before deciding
to save or discard it.
You can reconfigure the digit options for the Save and Discard branches, configure options for the
Review branch, and add additional branches to the Record activity’s Menu.
NOTE: Go To activities in the Review branch direct authorized callers to the Save or Discard
branches depending on the caller’s selection. If authorized callers choose Save, they hear a prompt
confirming that their message has been saved. If they choose Discard, they are taken back to the
Record activity.
The following procedures explain how to
l

Reconfigure the digit options for the Save and Discard branches

l

Configure user options for reviewing messages

l

Add branches to the Record activity’s Menu

To reconfigure the digit options for the Save and Discard branches
1. In the Record activity, select the branch in the Menu activity.
2. In the Properties pane, after Condition, click the … button.
3. Select the existing digit option.
4. Enter the new digit option and click the Add button.
5. Click OK.
NOTE: The Save and Discard branches in the Record activity’s Menu are named ‘1’ and ‘2’.
You can change these names using the Properties pane, after selecting the relevant branch.
To configure user options for reviewing messages
1. Select the Menu activity and click Properties.
2. To enable users to enter digits before a prompt completes, select the Barge In check box.
3. After In Between Digit Delay, type the number of seconds a user has between digit entries.
NOTE: Taking longer than this time between digit entries constitutes a timeout and counts
against the system’s configured Timeout Attempts.
4. After Invalid Attempts, type the number of times an authorized caller can select an invalid
menu option before the system follows the Failure branch.
NOTE: If users select invalid menu options but do not exceed this number, the system
follows the Invalid branch.
5. After No digit timeout (sec), type the number of seconds a user has to make their first digit
entry.
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6. After Timeout Attempts, type the number of times the system can timeout before following
the Failure branch.
7. To change the menu instructions an authorized caller hears, after Instructions, click the dropdown list and follow the appropriate steps under "Adding prompts to Play activities" on page
598.
NOTE: These instructions are preprogrammed in IVR Routing. You must change these
instructions if you reconfigure digit options or add branches to the Menu.
8. To enable reporting on all branches in this activity, select the Child Reporting Enabled
check box.
9. Click Save.

Configuring the Redirect activity
The Redirect activity branches workflows based off a redirect value received in a call record and the
number of the device from which the call was redirected. The Redirect activity provides an additional
means of branching workflows so that calls can reach the appropriate queue. You can add branching
conditions to Redirect activities to determine how IVR Routing directs callers through the workflow.
The Redirect activity is available in
l

Inbound and Inqueue workflows.

l

Inbound, Management, and Callback Inbound subroutines

NOTE: Redirects are achieved using the telephone system’s HCIRedirect or Name Tag hunt
groups.

Adding branching conditions to Redirect activities
To add a branching condition to a Redirect activity
1. Right-click the Redirect activity and select Add condition.
2. To add a Redirect value, at the top of the dialog box, click Add and type the value or range of
values for the Redirect condition.
3. Click the Add icon.
4. To import Redirect conditions in .csv format, click Import and navigate to the file name.
5. To export Redirect conditions, click Export and navigate to the file name.
NOTE:
l
l

Conditions on a single line and separated by a comma will be added to a single branch.
Conditions on multiple lines and separated by a comma will be added to multiple
branches.

6. To add more Redirect conditions, at the top of the dialog box, click Add.
7. If you want all Redirect conditions in the same branch, clear the Add each row in a separate
branch check box.
By default, separate branches are added for each condition.
8. To enable reporting for the branch, select the Enable reporting for this Branch check box.
9. To test the Redirect conditions, under Utilities, enter a value or range of values.
If the test is successful, 'Pass' displays.
If the test is unsuccessful, 'Fail' displays.
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10. Click OK to create the branch, or click Add to add the current branch to the workflow while
leaving the dialog box open to create new branches.
11. Click Save.

Configuring the Retrieve Callback activity
The Retrieve callback activity enables a workflow to retrieve the next available callback request
from the SQL database for use in the current workflow. The Retrieve Callback activity prioritizes
callback requests by time, whether the request is new or if it was requeued. To route down the
Success branch, there must be an active callback request in the SQL database. To see how the
Retrieve Callback activity functions within a workflow, see "Default Outbound Callback workflow"
on page 631.
The Retrieve Callback activity requires no configuration. You can optionally provide the activity with
a name and system name.
The Retrieve Callback activity is available in
l

Outbound workflows

l

Outbound subroutines

Configuring the Rules activity
The Rules activity enables workflows to be branched according to multiple conditions, or routing
rules, nested within a single activity. When an incoming call enters a workflow and encounters a
Rules activity, the call is evaluated against the activity’s preconfigured routing rules. Calls will be
directed through the workflow based on whether the call meets the activity’s routing rules. If a call
meets the activity’s routing rules, it is routed to the Success branch and the activity will populate
variables for the call based on pre-configured options in the rule. These variable values will determine
the queue to which the call is directed. For example, you can assign a rule to a Rules activity that
specifies the hours of operation and the ANI condition for a French-language queue. If a call enters
IVR Routing and matches the ANI of a French-speaking region during the French queue’s hours of
operation, that call will have an ANI variable populated with the French area code and will be routed
to the appropriate branch. You can assign and edit rules for Rules activities to determine how IVR
Routing directs callers through the workflow.
The Rules activity is available in
l

Inbound, Outbound, RAD, and Inqueue workflows

l

Inbound, Outbound, RAD, Management, UPiQ, and Callback Inbound subroutines

NOTE:
l

l

Before creating a Success branch, configure a rule that will contain the conditions for a
successful match. For information on rules and configuring rules, see "Configuring rules" on
page 546.
If the call is evaluated against multiple routing rules, first routing rule to be matched will set the
variable values.
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Adding and editing rules for Rules activities
To assign a rule to a Rules activity:
1. Right-click the Rules activity and select Configure....
2. From the Available members pane, select the rule to assign to the Rule activity and click the
> button.
3. Click OK.
NOTE:
l

l

Rules are evaluated in the order they appear in the selected list. IVR Routing will
evaluate all rules in order to find a match. It will not stop at the first match.
You can only configure one Success branch per Rules activity.

4. To edit a rule assigned to a Rules activity, right-click the activity and select Configure....
5. Change the rule assigned to the branch.
6. To enable reporting for this branch, in the Properties pane, select the Child Reporting
Enabled check box.
7. Click OK.
8. Click Save.

Configuring the Save Callback activity
The Save Callback activity saves a callback request to the SQL database. This activity can be used
to both save the information collected in the callback variables as a new callback request or save an
existing callback request back to the SQL database with a reason of completed or requeued. The
Global Callback monitor in Contact Center Client informs the supervisor which callback requests
were saved and why.
Following are the reasons associated to saving callback requests and their expected behavior:
l

l

l

l

New Request—collects the information from the callback variables and throughout the
workflow and compiles it as a callback request with the type specified
In Progress—saves the callback request to the SQL database with an update on its
progress, but does not remove it from the workflow.
Completed—saves the callback request to the SQL database with the indicated reason and
prevents it from being retrieved and offered to the queues and agents again.
Requeued—saves the callback request back to the SQL database to be retrieved later. The
callback handling count is modified based on the reason for requeue. In outbound callback
subroutine workflows, callback requests may no longer be offered if they have been requeued
a specified number of times without being completed. If there is a customer-based reason for
the requeue (no answer, customer hang up, etc), the handling count is increased. If the reason
for requeue is due to an agent or other factor outside a client’s control, then the handling count
is not modified.

The Save Callback activity has a Success and Pending branch. The activity routes down Pending
when network issues prevent the callback from being submitted. When the network issues are
resolved, the callback will be saved.
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NOTE: Using a Save Callback activity in a workflow that routes callback requests enables the SQL
records for callback requests to be updated when they leave the workflow. Otherwise, IVR Routing
will treat the callback request as a callback request with the highest priority, potentially creating a
loop.
For an example of how the Save Callback activity functions within a workflow, see "Default
Outbound Callback subroutines" on page 632.
The Save Callback activity is available in
l

Outbound workflows

l

Outbound and Callback Inbound subroutines.

To set the Save Callback request reason
1. Select a Save Callback activity.
2. Select a Request Reason from the drop-down menu.
3. Click Save.

Configuring the Schedule activity
The Schedule activity branches workflows based on date and time conditions, enabling a workflow
to respond to a business’ hours of operation.
For example, you can use the Schedule activity to route customers calling after hours to an afterhours voicemail and menu. The Schedule activity reduces workflow clutter by providing 'Open' and
'Closed' branching conditions within a single workflow.
NOTE: The Schedule activity applies schedules based on the local time of the IVR Routing server. If
the IVR Routing server is located remotely in a different time zone than the contact center to which it
is routing calls, the schedules for the Schedule activity should include offset time to compensate for
time zone differences.
The Schedule activity is available to
l

Inbound, Outbound, RAD, and Inqueue workflows

l

Inbound, Outbound, RAD, UPiQ, and Callback Inbound subroutines

Adding and modifying business hour Schedule conditions
The business hour schedule conditions determine when IVR Routing executes business hours
workflows and after hours workflows. These include the default Monday to Friday, 9:00 AM to 5:00
PM schedule and the default 24/7 schedule, as well as other user-created schedules. You can add
these default Schedule conditions as is, or modify them to suit your contact center’s hours of
operation.
To add a Business Hour Schedule condition
1. Right-click the Schedule activity and select Add a schedule condition.
2. Type the Name of the schedule condition.
3. Click Add and select Schedule from the second drop-down list.
4. From the third drop-down list, select a schedule.
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5. Click OK.
6. To test the conditions, under Testing, select a date and time and click Test.
Pass or Fail displays, indicating whether the test was successful.
7. To enable reporting, select the Enable Reporting check box.
8. Click OK to create the branch, or click Add to add the current branch to the workflow while
leaving the dialog box open to create new branches.
9. To edit schedule conditions, on the Workflows Canvas, right-click a branch and select Edit.
10. Click Save.
To modify a Business Hour Schedule condition
1. Select YourSite=>Schedules and select the default schedule you wish to modify.
2. Type a new Name for the schedule. For example, ‘Monday to Friday 8:00 AM to 6:00 PM’.
3. After Schedule exclusion list, click the Browse button.
4. Select a schedule exclusion list to apply to the schedule and click OK.
NOTE: The Schedule exclusion list specifies days to be omitted from the schedule. To create
a schedule exclusion list, or to edit an existing schedule exclusion list, see "Managing
schedule exclusion lists" on page 177.
5. After Start time, type the business day start time for each day of the week.
6. After End time, type the business day end time for each day of the week.
7. After Disable for day, select the check box for each day your business is closed.
8. Click Save.

Adding and modifying time and day of the week conditions for Schedule
activities
Adding time and day of week conditions to a Schedule activity specifies when calls are routed to
queues based on a call center’s business hours.
To add or modify a time and day of the week condition for a Schedule activity
1. Right-click the Schedule activity and select Add a schedule condition.
The Schedule Dialog box opens.
2. After Name, type the name of the schedule condition.
3. At the top of the dialog box, click Add and select Time from the second drop-down list.
4. Using the third drop-down list, type your contact center’s Start time (hh/mm/ss) and End
Time (hh/mm/ss) and click OK.
5. To add more time conditions follow steps 3-4.
6. To add a day of the week condition, at the top of the dialog box, click Add and select DOW
from the first drop-down list.
7. Under <Value>, specify the days of the week your contact center is open by selecting the
checkboxes for those days, and click OK.
8. To add more Day of the Week conditions follow steps 6-7.
9. To import schedule conditions, click the Import button and navigate to a *.csv file.
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10. To export schedule conditions, click the Export button and navigate to a *.csv file.
NOTE:
l

Conditions on a single line and separated by a comma are added to a single branch.

l

Conditions on multiple lines and separated by a comma are added to multiple branches.

11. To test the conditions, under Utilities, enter time and date information and click Test.
If the test is successful, 'Pass' displays beside the Test button.
If the test is not successful, 'Fail' displays beside the Test button.
12. To enable reporting, select the Enable reporting check box.
13. To delete a schedule condition, from the drop-down list to the left of the condition, select
Delete.
14. Click OK to create the branch or click Add to add the current branch to the workflow while
leaving the dialog box open to create new branches.
15. To edit schedule conditions, on the Workflows Canvas, right-click the branch and select Edit
Schedule condition.
16. Click Save.

Adding and modifying date or holiday conditions for Schedule activities
Adding date and holiday conditions to a Schedule activity specifies when calls are routed to a branch
designed to handle calls when the contact center is closed. Use date conditions to specify
exceptional days your contact center is closed. Add holiday conditions to specify Holiday closures.
To add and modify a date or holiday condition for a Schedule activity
1. Right-click the Schedule activity and select Add a schedule condition.
The Schedule Condition Designer opens.
2. After Name, type the name of the schedule condition.
3. At the top of the dialog box, click Add and select Date from the first drop-down list.
4. Using the second drop-down list, specify the date the contact center is closed and click OK.
If your contact center is regularly closed on this date, select the Reoccur every year
checkbox.
5. To add more dates the contact center is closed, follow steps 3-4.
6. To add a holiday condition, click the Add button and select Holiday from the first drop-down
list.
7. After <Select a holiday>, select the check box beside the holiday and click OK.
8. To add more holidays follow steps 6-7.
9. To import schedule conditions, click the Import button and navigate to a *.csv file.
10. To export schedule conditions, click the Export button and navigate to a *.csv file.
NOTE:
l
l

Conditions on a single line and separated by a comma will be added to a single branch.
Conditions on multiple lines and separated by a comma will be added to multiple
branches.

11. To test the conditions, under Utilities, enter the dates and click Test.
If the test is successful, 'Pass' displays beside the Test button.
If the test is not successful, 'Fail' displays beside the Test button.
12. To enable reporting, select the Enable reporting check box.
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13. To delete a schedule condition, from the drop-down list to the left of the condition select
Delete.
14. Click OK to create the branch or click Add to add the current branch to the workflow while
leaving the dialog box open to create new branches.
15. To edit schedule conditions, right-click the branch and select Edit Schedule.
16. Click Save.

Importing and exporting Schedule conditions
The following explains how to import and export Schedule conditions from *.csv files
To import and export Schedule conditions
1. Right-click the Schedule activity and select Add a schedule condition.
2. Type a Name for the schedule condition.
3. To import schedule conditions, click the Import button, navigate to a *.csv file, and click
Open.
4. To export schedule conditions, click the Export button, navigate to a *.csv file, and click
Open.
NOTE:
l

Conditions on a single line and separated by a comma are added to a single branch.

l

Conditions on multiple lines and separated by a comma are added to multiple branches.

5. To test the conditions, under Testing, select a date and time and click Test.
6. Click OK to create the branch, or click Add to add the current branch to the workflow while
leaving the dialog box open to create new branches.
7. Click Save.

Grouping schedule conditions in Schedule activities
You can group conditions in Schedule activities using the 'Group AND' or 'Group OR' buttons in the
Schedule Condition Designer. Grouping conditions by 'Group AND' means that every queue
condition specified must be met to route the call to the Success branch. Grouping conditions by
'Group OR' means that only one of the queue conditions specified must be met to route the call to the
Success branch.
NOTE:
l

l

The 'Group AND' and 'Group OR' buttons will be disabled unless you have at least two
conditions to group.
'Group AND' is the default grouping for the Schedule activity.

To group Schedule conditions
l

See "Grouping expressions" on page 570.

Configuring the Set Device Mode of Operation activity
The Set Device Mode of Operation activity changes the mode of operation for a specific device from
Normal to Emergency or vice-versa. These devices include
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l

Hunt Groups

l

Extensions
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For example, if only one of the IVR Routing’s extensions is experiencing emergency conditions, you
can use the Set Device Mode of Operation to put that port into Emergency mode without affecting
the entire system’s operations.
The Set Device Mode of Operations activity is available in
l

Management subroutines

Configuring properties for Set Device Mode of Operation activities
To configure the properties for a Set Device Mode of Operation activity
1. Select the Set Device Mode of Operation activity.
2. In the Properties pane, after Device Type, select a device type from the drop-down list.
NOTE:
l
l

Device type refers to the type of device checked when searching a dialable number.
Dialable number refers to the digit or series of digits a caller dials to reach an agent at an
extension.

3. To set the variable containing the device dialable number, after Input Variable, click the …
button.
The Select a variable dialog box opens.
4. Select an input variable and click OK.
5. After Mode of operation, select either Normal or Emergency from the drop-down list.
6. To enable reporting on the activity or a branch, select the activity or branch and select the
Child Reporting Enabled or Reportable check box.
7. Click Save.

Configuring the Set System Mode of Operation activity
The Set System Mode of Operation activity changes the mode of operation for IVR Routing from
Normal to Emergency and vice-versa. For example, if the contact center is closed due to weather
you can use the Set System Mode of Operation Activity to change IVR Routing to Emergency mode
and route all workflows in accordance with an emergency plan.
The Set System Mode of Operation activity is available in
l

Management subroutines

Configuring properties for Set System Mode of Operation activities
To configure properties for a Set System Mode of Operation activity
1. Select the Set System Mode of Operation activity.
2. In the Properties pane, after Mode of Operation, select either Normal or Emergency from
the drop-down list.
3. To enable reporting on the activity or a branch, select the activity or branch and select the
Child Reporting Enabled or Reportable check box.
4. Click Save.
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Configuring the Set Variables activity
The Set Variables activity enables IVR Routing to take values generated within a workflow or static,
predefined values and use them to populate variables for use later in the same workflow. For
example, you can use the Set Variables activity to populate a variable with a caller’s choice of
service language. IVR Routing can use this information later in the workflow to direct callers to a
queue with service in the appropriate language. You can determine the variables to be populated in
Set Variables activities.
For security and privacy reasons, variables that use any masking cannot be used with the Set
Variables activity.
The Set Variables activity is available in
l

Inbound, Outbound, RAD, and Inqueue workflows

l

Inbound, Outbound, RAD, Management, UPiQ, and Callback Inbound subroutines

Populating the Set Variables activity with workflow data
The following explains how to retrieve workflow data and use it to populate Set Variables activities
To populate the Set Variables activity with workflow data
1. Right-click the Set Variables activity and select Edit Variable Settings.
2. Type a Name for the activity and click Add.
3. Select a variable from the drop-down list and click OK.
To see a list of IVR Routing variables and their descriptions, go to 'IVR Routing=>Variables'.
4. In the third column, either type a Value, an expression in Advanced Text, or select Variable
and select a variable from the drop-down list. If selecting a value, note that options vary
according to the variable selected.
5. Click OK.
6. To add a variable row, click Add. To delete a variable row, select the row and click Delete.
7. Click Save.

Configuring the Subroutine activity
The Subroutine activity represents a set of workflow steps that can be inserted at any point in a
workflow or in multiple workflows. Editing the subroutine changes all instances of that subroutine in
workflows, enabling you to edit multiple workflows using a single point of configuration. The
Subroutine activity is an efficient means of replicating and configuring workflow segments. For
information on subroutines, see "Building subroutines" on page 534.
You can assign IVR Routing’s default Management or Callback subroutines to the activity, or build a
subroutine to assign to the activity.
The Subroutine activity is available in
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l

Inbound, Outbound, and RAD workflows

l

Inbound, Outbound, RAD, Management, UPiQ, and Callback Inbound subroutines

Configuring IVR Routing

Assigning subroutines and variables to Subroutine activities
IVR Routing provides default Management and UPiQ subroutines. To build other subroutines see
"Building subroutines" on page 534.
The following section explains how to
l

Assign subroutines to the Subroutine activity

l

Assign variables to the Subroutine activity

l

Expand subroutines in workflows

To assign a subroutine to a Subroutine activity
1. Right-click the Subroutine activity and click Assign…
2. Click the Subroutines tab, select a subroutine to assign and click OK.
3. Click Save.
To assign a variable to the Subroutine activity
NOTE: Assigning a variable to the Subroutine activity requires first inserting and configuring an
activity on the Canvas capable of populating the variable.
1. Right-click the Subroutine activity and click Assign…
2. Click the Variable tab, select a variable to assign and click OK.
To see a list of IVR Routing variables and their descriptions, go to 'IVR Routing=>Variables'.
3. Click Save.
To expand a subroutine in a workflow
l

Right-click the Subroutine activity and click Open...

Configuring the Swap Prompt activity
The Swap Prompt activity enables you to swap the contents of one prompt with the contents of
another prompt in IVR Routing. For example, if an emergency greeting informs customers that the
contact center is closed due to bad weather, in the event of an earthquake you can use Swap Prompt
to change the contents of the emergency greeting. The Swap Prompt activity enables you to provide
specialized prompts within a single workflow without inserting additional activities. You can set the
prompts to be exchanged in Swap Prompt activities from existing prompts in IVR Routing or from
prompts that you create.
The Swap Prompt activity is available in
l

Management subroutines

NOTE: If you have switched the contents of one prompt with another, you may eventually need to
switch the contents of prompts back again.
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Setting prompts to be exchanged in Swap Prompt activities
To set the prompts to be exchanged in a Swap Prompt activity
1. Select the Swap Prompt activity.
2. After Source Prompt, click the ▼ button.
The Select a prompt dialog box opens.
NOTE: The source prompt is the prompt that will be used to replace the target prompt.
3. Select a prompt and click OK.
4. After Target prompt, click the ▼ button.
NOTE: The target prompt is the prompt that will be swapped with the source prompt.
5. Select a prompt and click OK.
6. To add a source or target prompt, click the Add a new prompt button and follow the steps
under "Configuring an activity’s prompts" on page 564.
7. Click Save.

Configuring the Transfer activity
The Transfer activity transfers a caller to a specified destination, enabling you to send callers to a
queue, queue group, variable, or other specified destination. For example, you can use a Transfer
activity to route calls across queues.
Transfers can be blind or supervised. Both types of transfer place the caller on hold and transfer the
call to the activity’s destination. Blind transfers are considered completed when the destination
begins ringing, while supervised transfers are considered completed when the destination answers.
Callers cannot hear the phone ringing during the transfer unless the transfer time exceeds the
timeout.
The Transfer activity contains three branches, which determine how the call is handled in the
workflow after the attempted transfer. The three branches are:
l

l

l
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Success—This branch determines how the workflow handles the call after the caller is
transferred to the transfer destination. By default, the Success branch contains a Hang Up
activity. A call routed through the Success branch is separated from the caller, who starts a
new call at the transfer destination. The Hang Up activity ends the call remaining in the current
workflow and clears the port for a new call.
NOTE: Removing the Hang Up activity from the Success branch is not recommended as it
may result in unnecessary port use.
Abandon—This branch determines how the workflow handles the call when the original caller
hangs up before a supervised transfer is completed. By default, the Abandon branch contains
a Hang Up activity. A call routed through the Abandon branch is separated from the caller,
who abandoned it when they hung up. The Hang Up activity ends the call remaining in the
current workflow and clears the port for a new call.
NOTE: Removing the Hang Up activity from the Abandon branch is not recommended as it
may result in unnecessary port use.
Failure—This branch determines how the workflow handles the call when the Transfer
activity fails to connect to the destination. By default, the Failure branch contains a Hang Up
activity. A call routed through the Failure branch is not separated from its caller and may
continue in the workflow. By default, this branch contains a Hang Up activity that ends the call
in the current workflow and clears the port for a new call.

Configuring IVR Routing

You can configure the options for how and where a call is transferred, and add new devices to
Transfer activities.
The Transfer activity is available in
l

Inbound, Outbound, and Inqueue workflows

l

Inbound, Outbound, Management, and Callback Inbound subroutines.

Configuring options and adding devices to Transfer activities
The following procedures tell you how to:
l

Set a destination

l

Add a new device as the destination

l

Set the dialing properties

l

Set the reporting and timeout options

To set a destination
1. Select the Transfer activity.
2. In the Properties pane, after Destination, click ....
3. Select a destination from one of the following tabs and click OK.
l
l

l

l

Extension
Queue
NOTE: Ring groups can be set as destinations, but the workflow’s port must be located
on the same media server as the ring groups.
Queue Group
NOTE: When transferring to a virtual queue group, the Transfer activity will route to the
first queue on the same media server as the IVR port. If the status of this queue is
Offline, it will route to the next local queue configured in the queue group. If all local
queues are Offline, it will route to the first remote queue. Queues in Do Not Disturb are
considered Online.
Variable

4. Click Save.
To add a new device as the destination
1. Select the Transfer activity.
2. In the Properties pane, after Destination, click ....
3. Click Add.
4. Select one of the following from the drop-down list:
l

Extension

l

Queue

l

Queue group

l

Variable

5. In the Extension, Queue, Queue Group, Variable tabs, at the top of the dialog box, click
Add.
6. To add a new extension, see "Adding extensions for IVR Routing" on page 512.
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7. To add a new queue, in the Queue pane, follow the steps under "Adding queues" on page 142.
NOTE:
l

l

l

l

A new ring group can be used as a destination, but only if the workflow’s port is on the
same media server as the ring group.
To configure a new queue for web callbacks, see "Enabling web callbacks" on page
539.
To configure a new queue for abandon callbacks, see "Enabling abandon callbacks" on
page 537.
To associate a queue to an UPiQ workflow, see "Configuring Inqueue routing" on page
518. For information on setting up UPiQ workflows, see "Default Inqueue UPiQ
workflow and subroutine" on page 629.

8. To add a new queue group, follow the corresponding steps in "Adding queue groups" on page
155.
9. To add a new variable, follow the corresponding steps in "Adding variables" on page 553.
10. Click Save.
To set the dialing properties
1. Select the Transfer activity.
2. In the Properties pane, after Transfer Type, to instruct the activity to hold calls transferred to
busy lines, in the Properties pane, select the Camp On Busy check box.
3. To append outbound calls with a prefix digit, select the External Transfer check box.
The prefix digits appended to external transfers are defined on the media server.
4. Select Blind or Supervised from the drop-down list.
5. Click Save.
To configure the reporting and timeout options
1. Select the Transfer activity.
2. To enable reporting, select the Child Reporting Enabled check box.
3. To set the duration that a call is put on hold during a transfer, after Timeout Duration, enter
the time allotted for the transfer.
4. Click Save.

Configuring the Variable Compare activity
The Variable Compare activity routes calls through workflow branches by comparing information,
stored in either custom or system variables, against specified conditions.
For example, you can use Variable Compare to create a priority branch for customers with Gold
membership. The Variable Compare activity compares a variable for Gold membership against a
customer’s actual membership level. If the customer’s membership information compares positively
against the criteria for the Gold branch then the caller is routed to the priority branch. Customers
whose membership information does not match the criteria for the Gold branch are routed to the No
Match branch.
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You can applying branching conditions to Variable Compare activities, and you can group variable
conditions to determine how IVR Routing directs callers through the workflow.
The Variable Compare activity is available in
l

Inbound, Outbound, and Inqueue workflows

l

Inbound, Outbound, RAD, Management, UPiQ, and Callback Inbound subroutines

Applying branching conditions to Variable Compare activities
The following procedures explain how to
l

Add conditions to be compared against workflow data

l

Edit conditions being compared

l

Delete conditions being compared

To add a condition to be compared against workflow data
1. Right-click the Variable Compare activity and select Add Variable Compare condition.
2. Type a Name for the condition and click Add.
3. Select a variable from the drop-down list and click OK.
To see a list of IVR Routing variables and their descriptions, go to 'IVR Routing=>Variables'.
4. Select an operator from the second drop-down list. Options vary according to the variable
chosen.
5. In the third column, type or select a value for the variable. If selecting a value, note that
options vary according to the variable selected.
NOTE: " means 'No Value'.
6. Click OK to create the branch or click Add to add the current branch to the workflow while
leaving the dialog box open to create new branches.
7. Click Save.
To edit a Variable Compare condition
1. Right-click the condition’s branch and select Edit.
2. Edit the condition, and click OK to create the branch or click Add to add the current branch to
the workflow while leaving the dialog box open to create new branches.
3. Click Save.
To delete a Variable Compare condition
l

Right-click the condition's branch and select Delete.
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Grouping variable compare conditions
You can group variables to be compared in the Variable Compare activity using the 'Group AND' or
'Group OR' buttons in the Variable Compare Condition Designer. Grouping variables by Group AND
means that every variable condition specified must be met to route the call to the Success branch.
Grouping variables by Group OR means that only one of the variable conditions specified must be
met to route the call to the Success branch.
NOTE:
l

l

The 'Group AND' and 'Group OR' buttons will be disabled unless you have at least two
conditions to group.
Group AND is the default grouping for the Variable Compare activity.

To group variable compare conditions
l

See "Grouping expressions" on page 570.

PASSING AGENTS CALL INFORMATION IN SCREEN POPS
Screen pops pass call information to agent desktops. When the system routes a call, information
can be passed to agents in one of two ways. First, you can configure Contact Center Screen Pop.
Contact Center Screen Pop is applied uniformly across queues, providing all agents the same type
of call information. For more information, see "Contact Center Screen Pop" on page 458.
Second, you can configure screen pops within an Inqueue workflow, programmed on a queue-byqueue basis. See "Populating screen pops with workflow variables" on page 626.
NOTE:
l
l

Contact Center Screen Pop is hidden unless you are licensed for it.
If Contact Center Screen Pop and screen pops configured via Inqueue workflows are both
active, the workflow screen pop overrides Contact Center Screen Pop.

Populating screen pops with workflow variables
When a call is processed through a workflow, you can populate URLs or executable files with
variables detected for the call. These URL and executable files, and the variable information they
contain, can be passed to agents in the form of a screen pop.
Screen pops display when a contact is ringing on the agent’s extension. Variables available to the
workflow’s media type, which also contain the ‘Send to Agent’s desktop’ checkbox, can populate a
screen pop with information. Populating URLs and executable files with workflow variables enables
you to customize screen pops on a queue-by-queue basis.
For example, you can configure a workflow to query a database and retrieve a customer’s name and
account number. When the call rings on an agent’s extension, a screen pop opens a web page
delivering the customer information to the agent. The agent is immediately able to provide
personalized, informed service.
Administrators must provide webcodes and servers for URLs and the executable codes behind
executable files. URLs must include 'http://' in the URL string.
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Executable files may prompt a Windows security warning on client desktops before popping.
Administrators may disable this security setting in Internet Explorer. For more information, consult
Microsoft documentation.
NOTE: If Contact Center Screen Pop and screen pops populated with workflow variables are both
active, the workflow variable screen pop overrides Contact Center Screen Pop.
To populate a screen pop with a workflow variable
1. Click IVR Routing=>Variables, and select the ScreenPopOnRinging variable.
2. Select Send to agent desktop.
3. In an Inbound workflow, place a Set Variables activity on the Workflows Canvas.
NOTE: We recommend placing the Set Variables activity quite close to the activity offering
the call to an agent’s extension. This helps prevent the screen pop’s value from being
overwritten by another variable query.
4. Right-click the Set Variables activity and select Edit Variable Settings.
5. Click Add and, from the <Select a variable> drop-down list, select ScreenPopOnRinging.
6. Click <Value> and, in the Value tab, enter a URL string or the path to an executable file.
NOTE: The paths to executable files must be accessible to any clients who require its use.
For example, administrators can place the file on a network share.
7. To populate a web page screen pop with variable information, insert the variable’s name
between double angle brackets where applicable in the URL string.
For example, <<DNIS>>.
8. Click OK to close the variable dialog box and click OK to return to the workflow.
9. Click Save.

IVR ROUTING DEFAULT WORKFLOWS AND
SUBROUTINES
Version 7.1 includes a number of default workflows and subroutines. The workflows and subroutines
are based on common scenarios and demonstrate IVR Routing’s enhanced functionality. They can
be configured according to your business needs.
IVR Routing includes the following default workflows
l

Default UPiQ Inqueue workflow
l

l

Includes default UPiQ subroutine

Default Callback Outbound workflow
Includes the following subroutines
l

Default Outbound Abandon Callback subroutine

l

Default Outbound Voice Callback subroutine

l

Default Outbound Web Callback subroutine

In addition, IVR Routing includes the following default Callback Inbound subroutine:
l

Default Inbound Voice Callback subroutine
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The following sections summarize the default workflows and subroutines and explain how they
operate. For ease of understanding, we also recommend you expand the entire workflow and all
annotations.
To expand the workflow
l

Click the Expand All button

To expand all annotations
l

Right-click the workflow and select Annotations...=>Show All.

CHANGES TO CALLBACKS AND UPIQ
Version 7.0 introduced important changes to how callbacks and UPiQ are configured.
Prior to Version 7.0, callbacks and UPiQ were configured directly on the queue. Callbacks were
configured via callback plans, and UPiQ was configured by selecting from a set of predetermined
options. In Version 7.0 and greater, callbacks and UPiQ are configured using default workflows and
subroutines included with IVR Routing. These default workflows and subroutines replicate the
functionality of callbacks and UPiQ prior to Version 7.0 while enabling you to configure and
customize the callback and UPiQ processes. This new configuration ensures that callbacks and
UPiQ can be as simple or sophisticated as you require.
Upgrading to Contact Center Solutions Version 7.1 seamlessly migrates your existing Callback and
UPiQ configuration from the Version 6.x configuration options into Version 7.1 workflows. This
includes custom .wav files and any changes to the default options. For more information on how
Callback and UPiQ function in workflows, see "Default callback workflow and subroutines" on page
631, and "Default Inqueue UPiQ workflow and subroutine" on page 629.
Note that UPiQ Inqueue and Callback Outbound workflows are now enabled or disabled by selecting
the ‘Always run’ check box on the Workflows pane.
NOTE: Callback ports have been deprecated and are converted to Outbound ports during the
migration process.

CUSTOMIZING THE DEFAULT WORKFLOWS AND
SUBROUTINES
If you want to create your own versions of IVR Routing’s default workflows, we recommend you do
so by reconfiguring the default workflows. To create multiple workflows of the same type, you can
make multiple copies of the default workflows and reconfigure them. For more information, see
"Copying workflows" on page 526 and "Cutting, pasting, and copying workflow items" on page 526.
Each default workflow requires additional configuration to get them up and running for your business.
For information on configuring the workflow activities to suit your contact center, follow the crossreferences throughout each summary.
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The following requirements are shared among default workflow. You must
l

l

l

Validate the workflow and activity configuration and correct any errors detected. See
"Troubleshooting workflow configuration with the Validation button" on page 568.
Associate Inbound workflows to an extension or hunt group, and associate Outbound
workflows to an extension. See "Associating workflows to devices" on page 529.
Associate Inqueue workflows to at least one queue. See "Associating workflows to devices"
on page 529.

DEFAULT INQUEUE UPIQ WORKFLOW AND SUBROUTINE
This workflow instructs IVR Routing to obtain callers’ position in queue and executes a subroutine to
play callers different UPiQ messages based on their position. Previously, UPiQ was turned on or off
on a queue-by-queue basis and contained pre-programmed options from which to choose. UPiQ is
now comprised of a configurable subroutine referenced within a dedicated Inqueue workflow. You
can use the subroutine to choose how many customers on hold are updated, the frequency with
which they are updated, and the specific messages they hear based on their queue position. You can
assign the workflow to any Voice queue in your enterprise. This UPiQ Inqueue workflow enables you
to create a customized, dynamic UPiQ experience for customers waiting in queue, helping you to
meet your service level objectives by reducing abandoned calls.
Expected Wait Time announcements are not included in the Default UPiQ subroutine, but can be
added to the Default UPiQ subroutine. For more information, see "Playing Expected Wait Time
announcements" on page 520
To further illustrate the workflow’s activities and their operations, we recommend you expand the
entire workflow and all annotations.
To expand the workflow
l

Click the Expand All button.

To expand all annotations
l

Right-click the workflow and select Annotations…=>Show All.

Description
The first step in this workflow is a Delay activity. The Delay activity determines the time until callers
in queue hear the first UPiQ message. By default, the Delay activity is set to 10 seconds. To
reconfigure this time, see "Configuring the Delay activity" on page 580.
Next in the workflow is a Variable Compare activity, in this example named ‘Check Position’. This
activity determines the range of positions hearing UPiQ messages and compares it to a caller’s
actual position in queue and expected wait time. If a caller is in position one through eight, and if their
expected wait time is less than the last expected wait time reported, the Check UPiQ settings
branch is followed. To reconfigure the criteria determining whether callers hear UPiQ messages, edit
the Variable Compare activity. See "Configuring the Variable Compare activity" on page 624.
NOTE: Any additional position you configure in the Variable Compare activity must have a branch
associated to it in the UPiQ subroutine’s Variable Compare activity (see below).
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If callers do not meet this criteria, the No Match branch is followed and the system is continuously
prompted to recheck queue positions against the UPiQ criteria. This enables callers moving into the
range of UPiQ positions to hear their updated position. The frequency with which the system
rechecks positions and estimated wait time is determined by a second Delay activity (see below). A
Go To activity loops back to the Variable Compare activity to begin the process again (see below).
For callers within the range of UPiQ positions, a Connect to Caller activity, embedded within the
Variable Compare activity and labeled ‘Default UPiQ’ in this example, prompts the UPiQ port to
engage callers and executes the subroutine determining the messages different positions hear (see
below).
If the Connect to Caller activity cannot find an available UPiQ port, the No Port Available branch is
followed. If the Connect to Caller action fails, the Failure branch is followed. In each case, after an
initial delay determined by the Delay activity (see below), a Go To activity loops back to the Variable
Compare activity to begin the process again. A Set Variables activity, in this example named
‘Update Last Position and Wait time reported’, is configured so callers whose position has not
changed do not hear their position read to them repeatedly. If you delete the Variable Compare
activity, delete this activity also.
The subroutine contains activities enabling you to customize the experience of a caller waiting in
queue.
To see the subroutine, go to IVR Routing=>Subroutines=>Default UPiQ.
The first step in the subroutine is an Answer activity. The Answer activity tells the UPiQ port to
answer the call. The next step in the subroutine is a Language activity, which enables the prompt
language to change, based on options previously selected by the customer. To change this language
from English, see "Configuring the Language Activity" on page 591. If the system language will
remain English only, you can delete this activity.
Next is a Set Variables activity, configured to determine if the estimated wait time a caller hears
should be rounded to the nearest minute. The default setting for this variable is ‘False’, meaning that
the estimated wait time is not rounded to the nearest minute. To round the estimated wait time to the
nearest minute, you must reconfigure the setting to ‘True’. For more information, see "Configuring
the Set Variables activity" on page 620.
Next is a Variable Compare activity. This activity compares a caller’s position in queue to those
hearing UPiQ messages. If callers are in position one, the ‘UPiQ Position Equal 1’ branch is
followed. Additional branches are followed for other caller positions. These branches contain Play
activities informing callers of their position in queue. To alter the messages callers hear, see
"Configuring the Play activity" on page 598.
If callers are outside the range of UPiQ positions, the No Match branch is followed. We recommend
you configure this branch with activities to determine how the system behaves when the branch is
followed. A Hang Up activity ends the subroutine. To reconfigure the Variable Compare activity, for
example to add branches to incorporate additional queue positions, see "Configuring the Variable
Compare activity" on page 624.
NOTE: Callers are directed to the No Match branch in the subroutine only if you have not
programmed a branch to incorporate their position in queue. If callers are being directed to the No
Match branch, ensure you adjust the subroutine so these callers hear a message and stay in queue.
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Following the subroutine is a Delay activity. The Delay activity determines how frequently the
system compares queue positions to the range of callers hearing UPiQ messages. This Delay
activity also determines how frequently the script to check position in queue is rerun after a Timeout
or if the enterprise is down. By default the Delay activity is set to 20 seconds. To reconfigure this
time, see "Configuring the Delay activity" on page 580.
A Go To activity at the end of the workflow loops back to the ‘Check Position’ Variable Compare
activity. This ensures the UPiQ messages run continuously, adjust to shifting caller position in
queue, and incorporate new callers.

DEFAULT CALLBACK WORKFLOW AND SUBROUTINES
IVR Routing includes the following default callback workflows:
l

Default Callback Outbound workflow
Includes the following subroutines:
l

Default Outbound Abandon Callback subroutine

l

Default Outbound Voice Callback subroutine

l

Default Outbound Web Callback subroutine

In addition, IVR Routing includes the following Callback Inbound subroutine:
l

Default Inbound Voice Callback subroutine

Default Outbound Callback workflow
This workflow manages retrieving callback queues and offering them to agents. This workflow runs
continuously, searching SQL for submitted callback requests and offering them to queues.
Depending on the kind of callback submitted, this workflow leverages the appropriate Outbound
callback subroutine so that the callback type is handled correctly and offers the agent relevant
options.
This callback must be associated to an Outbound port. See "Associating workflows to devices" on
page 529.
To further illustrate the workflow’s activity and operations, we recommend you expand the entire
workflow and all annotations.
To expand the workflow
l

Click the Expand All button.

To show all annotations
l

Right-click the workflow and select Annotations…=>Show all.

Description
The first step of this workflow is the Retrieve Callback activity. This activity looks in SQL for
submitted callback request that are ready to be delivered to the queue. Retrieve Callback has three
branches: Success, Timeout, and Failure. If the Retrieve Callback activity times out during retrieval
or fails to retrieve a callback, for example, if there are no submitted callback requests, it continues in
the workflow to the Delay activity. If a callback request is detected, it is retrieved and routed to the
Success branch.
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The Success branch contains a Subroutine activity, which checks the
<<CallbackOutboundWorkflowId>> variable in the callback request for the appropriate subroutine
and then routes the request through the appropriate subroutine workflow. For an overview of the
subroutines, see "Default Outbound Callback subroutines" on page 632.
The final activity in the workflow is a Delay activity, which is configured with a five-second delay.
This activity creates a buffer of time between each offering of a callback request. For information on
modifying the Delay activity, see "Configuring the Delay activity" on page 580.

Default Outbound Callback subroutines
IVR Routing includes the following three subroutines for Outbound callbacks:
l

Default Outbound Abandon Callback subroutine

l

Default Outbound Voice Callback subroutine

l

Default Outbound Web Callback subroutine

These subroutines are used by the Default Callback Outbound subroutine to offer callback requests
to agents and manage outbound calls to customers. The three subroutines manage the state of the
callback request, setting the frequency and number of times a callback request is offered to a queue.
This prevents an unsuccessful callback request from being offered repeatedly. Using the Save
Callback activities located throughout the subroutine at the various endpoints, callback requests are
saved back to the SQL database with reason codes that inform the system whether or not the
callback request is complete or if it needs to be requeued.
The subroutines handle the offering of the callback request to agents as well as managing the
outbound call to the customer.
The subroutines are functionally identically with the exception of the Menu option for Branch 1. The
voice callback enables the agent to listen to any message left by the customer when they made their
voice callback request. The web callback enables the contact center agent to hear a text-to-speech
reading of the customer’s submitted name. The abandon callback has no option for Branch 1.
If you are migrating from Version 6.0.x to Version 7.1, the Default Outbound Callback subroutines
replace the voice, web, and abandon Callback Plan’s Routing Rules and Agent options. For
guidance as to which activities replace which elements of the callback plans, consult the notes
placed throughout the following description.
Description
The first step in this subroutine is a Set Variable activity. This activity is configured with the
maximum number of callback attempts and the interval for the next attempt at making this callback
request, enabling you to control the frequency and number of times a callback will be offered to
agents. The number of attempts is added to the callback request’s SQL record, depending upon
which Save Callback activity reasons are applied to the callback request as it is routed through the
subroutine. For information on configuring the Set Variable activity, see "Configuring the Set
Variables activity" on page 620.
NOTE: If you are migrating from Version 6.0.x to Version 7.1, the Set Variable activity replaces the
‘Number of attempts to contact client’ and the ‘Retry interval between attempts’ field from the
‘Routing Rules’ tab of the Callback Plans.
Next in the subroutine sequence is a Schedule activity. This activity confirms that callback requests
arriving outside of business hours are not offered to queues while there are no agents to handle them.
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Instead, they are queued in the order they arrive, to be handled when business hours resume. This
activity has two branches: Business Hour and After Hours. Callback requests are routed to the After
Hours branch if they arrive outside business hours. This branch contains a Save Callback activity
that saves the callback to SQL with the reason ‘Requeued – Schedule conditions did not pass’,
requeuing it to be offered at the beginning of the next business day. Callback requests are routed
down the Business Hour branch if the contact center is currently open and there are ports available.
By default, this branch uses the Default 24/7 - 1 schedule. For details on configuring the Schedule
Activity, see "Configuring the Schedule activity" on page 615.
NOTE: If you are migrating from Version 6.0.x to Version 7.1, the Schedule activity replaces the
‘Allow Schedule’ and ‘Schedule Plan’ options from the ‘Routing Rules’ tab of the Callback Plans.
The first activity in the Business Hours branch is the Queue activity. This activity routes callbacks
depending on whether or not there are any agents present to handle callback requests in this queue.
The condition for this activity branches callbacks depending whether there are one or more agents
available or if there are no agents available. This activity has two branches: 1 or More Agents are
Logged In and No Agents are Logged In. If no agents are available, callbacks are routed to the No
Agents are Logged In branch. This branch contains a Save Callback activity that saves the callback
to SQL with the reason ‘Requeued – No agents available’, requeuing it to be offered later.
Callback requests route down the ‘1 or More Agents are Logged In’ if there are agents available to
handle callbacks in the queue. The first activity of this branch is a Save Callback activity that
updates the callback request’s progress to SQL with the ‘In Progress – Dialing Agent’ reason.
The branch continues to a Make Call activity. This submits the callback request to the destination
set in the <<CallbackDestination>> variable, usually the queue from which the caller made the
callback request. Calls submitted to the queue remain in the queue for the time set in the Timeout
duration property before following the Timeout branch. By default, the Timeout duration is set to 1
minute. For details on configuring Make Call activity, see "Configuring the Make Call activity" on
page 592.
NOTE: The destination of the Make Call activity can be changed if there is an alternate destination,
other than the queue of origin, from which you want to handle callback requests. For information on
configuring the Make Call activity’s destinations, see "Configuring the Make Call activity" on page
592.
The Make Call activity has four branches: Agent Receives the Callback, No Answer Timeout,
Destination Busy, Invalid Destination, and Failure. No Answer Timeout, Destination Busy, Invalid
Destination, and Failure each contain a Save Callback Request activity.
Callback requests are routed to the No Answer Timeout branch when the timeout duration expires,
where the Save Callback Request activity saves the callback request to SQL with the reason
‘Requeued – Agent did not answer’. This enables the outbound ports to re-offer it to the queue. If the
destination that the callback request was routed to is busy, the callback request is sent to the
Destination Busy branch. This branch’s Save Callback Request activity saves the callback request
to SQL with the reason ‘Requeued – Agent was Busy’, which enables the outbound ports to re-offer it
to the queue. If the destination in the <<CallbackDestination>> variable is invalid, the callback
request is routed to the Invalid Destination branch. This branch’s Save Callback Request saves the
callback request to SQL with the reason ‘Completed – Invalid Agent Destination’, which prevents the
callback from being re-offered to the queue. If there is a failure to queue the callback request, the
callback request is routed to the Failure branch. This branch’s Save Callback Request saves the
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callback request to SQL with the reason ‘Requeued – PBX Connection was lost.’, which enables the
outbound ports to re-offer it to the queue.
NOTE: If you are migrating from Version 6.0.x to Version 7.1, the Make Call activity’s timeout
duration corresponds to ‘No answer timeout (secs)’ field from the ‘Agent Options’ tab of the Callback
Plans.
If the destination is valid and the callback request does not timeout, the request is routed through the
Agent Receives the Callback branch and offered to the queue. The Agent Receives the Callback
branch contains a Menu activity. When the contact center agent answers the callback request, they
are connected to the Menu activity in the subroutine.
In the Voice and Web callback subroutines, the Menu activity plays an instruction prompt that tells
the agent 'To listen to the caller’s message, press 1. To place this call, press 2. To requeue this
request, press 3. To reject this request, press 4. To hear these options again, press 5.' In the
Abandon callback subroutine, the Menu activity plays an instruction prompt that tells the agent 'To
place this call, press 2. To requeue this request, press 3. To reject this request, press 4. To hear
these options again, press 5.' The Menu activity has one branch for each menu option, as well as
branches for Timeout, No Match, and Failure.
NOTE: If you are migrating from Version 6.0.x to Version 7.1, the Menu activity’s prompts and
branches correspond to the options in the ‘Digit Menu’ section of the ‘Agent Options’ tab of the
Callback Plans.
In the Voice callback subroutine, 1 – Play Customers Message enables the employee handling the
callback request to listen to the recorded message the customer left. The first activity of 1 – Play
Customers Message is a Play activity that is configured to play to the agent the .wav file of the
message the customer recorded with their callback request, stored in the
<<CallbackClientRecording>> variable. The next activity in this branch is a Go To activity that
returns the agent to the start of the Menu activity.
In the Web callback subroutine, 1 – Play Customers Message enables the employee handling the
callback request to listen to a text-to-speech reading of the customer’s name. The first activity of 1 –
Play Customers Message is a Play activity that is configured to play a text-to-speech reading of the
customer’s name. After playing this, the branch continues to a Go To activity that returns the agent
to the start of the Menu activity.
NOTE: In the Abandon callback subroutine, there is no option for 1 – Play Customers Message.
The 2 – Call the Customer Back enables the employee to callback the customer who made the
callback request. This branch contains a Conference activity that is configured to call the number the
customer left when making their callback request, stored in the <<CallbackClientNumber>>
variable. This activity has seven branches Success, Client Disconnect, Agent Disconnect,
Destination Busy, Timeout, Invalid, and Failure.
NOTE: If you are migrating from Version 6.0.x to Version 7.1, the Conference activity’s timeout
duration corresponds with the ‘No answer client timeout (secs)’ field in the ‘Routing Rules’ tab of the
Callback Plans.
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If the agent’s call is successful, it is routed to the Success branch of the Conference activity where a
Play activity plays the following message 'Please wait while the call is established.' The agent is
then connected to the caller. When the agent is finished with the callback, the subroutine continues
to a Save Callback activity that saves the reason 'Completed', indicating that the request is
complete and should no longer be offered to the queue.
If the customer hangs up on the callback attempt from the agent, the callback request is routed to the
Client Disconnect branch of the Conference activity. This branch contains a Play activity that
informs the agent that the conference has failed and the customer is not available and a Save
Callback activity that saves the callback request with the reason ‘Requeued – Client did not
answer’, which enables the outbound ports to re-offer it to the queue. The client disconnect is
counted as an attempt for a callback, increasing the saved number of attempts for the callback by 1.
If the agent hangs up on the callback attempt, the callback request is routed to the Agent Disconnect
branch of the Conference activity. The Agent Disconnect branch contains a Save Callback activity
that saves the callback request with the reason ‘Requeued – Agent did not answer’. This sets the
callback request to be requeued to be tried again later and does not count as a callback attempt in
the callback request’s record.
If the callback request rings on the customer’s phone for the configured Timeout duration, it is routed
down the Timeout branch of the Conference activity. The Timeout branch contains a Play activity
that informs the agent that the conference has failed and the customer is not available and a Save
Callback activity that saves the callback request with the reason ‘Requeued – Agent did not
answer’. This sets the callback request to be requeued again later and does not count as a callback
attempt in the callback request’s record.
If the customer’s phone is busy, the callback request is routed down the Destination Busy branch of
the Conference activity. This branch contains a Play activity that informs the agent that the
conference has failed and the customer is not available and a Save Callback activity saves the
callback request with the reason ‘Requeued – Client was busy.’, which is counted as a callback
attempt.
If the callback request included an invalid phone number for the customer, the callback request is
routed to the Invalid branch of the Conference activity. This branch contains a Play activity that
informs the agent that the conference has failed and the customer is not available and a Save
Callback activity saves the callback request with the reason ‘Completed – Invalid Client
Destination’, which resolves the callback request and ensures it will no longer be offered to the
queue.
If a failure occurs, the callback request is routed to the Failure branch of the Conference activity.
This branch contains a Play activity that informs the agent that the conference has failed and the
customer is not available and a Save Callback activity saves the callback request with the reason
‘Requeued – Failed to connect to agent/queue’, which does not count as a callback attempt.
The 3 - Requeue the Callback branch of the Menu activity requeues the callback request, offering it
to the queue again after the retry interval duration expires. This branch contains a Save Callback
activity that saves the callback request with the reason ‘Requeued – By an Agent.’, which ensures it
is re-offered to the queue.
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The 4 – Reject the Callback branch of the Menu activity rejects the callback and marks it as
completed so it is no longer offered to the queue. This branch contains a Save Callback activity that
saves the callback request with the reason ‘Completed – Rejected by agent.’, which completes the
callback request.
The 5 – Hear the Options Again branch enables the agent to listen to the Menu options again. This
branch contains a Go To activity that sends the agent back to the start of the Menu activity in the
subroutine.
If the agent does not choose an option after 10 seconds, they are routed down the Timeout branch.
This branch contains a Go To activity that sends the agent back to the start of the Menu activity in
the subroutine.
If an agent pushes a number that is not programmed in the menu, they are routed down the No Match
branch. This branch contains a Go To activity that routes the agent back to the start of the Menu
activity in the subroutine.
The Failure branch of the Menu activity contains a Hang Up activity. The agent is routed to this
branch if the Menu activity times out three times. If the agent is routed to this branch, the callback
attempt is deleted from the system.
The final activity of the subroutine is a Hang Up activity, which ends the subroutine.

Default Inbound Voice Callback subroutine
This subroutine workflow is the default workflow for customers in queue to submit voice callbacks.
Callers who leave queue when presented with the option from the Callback Request activity can use
this workflow to leave a message and set a time to be contacted later.
NOTE:
l

l

l

If you change any of the activities in the workflow, ensure that the prompts used are still
accurate and reflect the options offered to the callers.
To further illustrate the workflow’s activity and their operations, we recommend you expand
the entire workflow and all annotations.
As of Version 7.0 and greater, this callback subroutine workflow replaces the Voice Callback
Plan’s Callers Options tab.

To expand the workflow
l

Click the Expand All button.

To show all annotations
l

Right-click the workflow and select Annotations…=>Show all.

Description
The first step in the workflow is a Collect Digits activity. This activity prompts callers to enter the
phone number they would like to be reached at, which the workflow then stores in the
<<CallbackClientNumber>> variable. By default, callers must enter between seven and ten digits
and press # as the terminating digit, but these defaults may be altered. For information on changing
the defaults, see "Configuring the Collect Digits activity" on page 575.
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NOTE:
l

l

If you are migrating from 6.0.x to Version 7.1, the options in this activity correspond to the
General options in the Callers Option tab for Voice Callback Plans.
This activity is mandatory, but another activity that can obtain and store the caller’s number in
the CallbackClientNumber variable could be used instead of collect digits.

The Collect Digits activity has four branches: Phone Number Collected, Timeout, Invalid, and
Failure. Callers are routed to the Timeout Branch if they do not enter anything after 12 seconds. This
branch contains a Play activity, whose prompt informs callers that there was no input, and a Go To
activity, which returns callers to this Collect Digits activity. Callers are routed to the Invalid branch if
the phone number goes over or under the specified minimum and maximum number of digits. This
branch is identical to the Timeout branch. Callers are routed to the Failure branch when their
timeouts or invalid digit entries exceed the set number of Invalid attempts, which by default is 3. The
Failure branch contains a Hang Up activity that terminates the workflow. For information on
configuring Collect Digits activity options, see "Configuring the Collect Digits activity" on page 575.
If a caller successfully enters their phone number, they are routed into the Phone Number Collected
branch. This branch validates the caller’s phone number against a phone number exclusion list,
ensuring contact center agents are only handling valid callback requests. The first activity of this
branch is a Variable Compare activity, which compares the <<CallbackClientNumber>> variable to
a series of conditions in the activity’s Invalid Numbers condition. These numbers can be changed
and additional numbers can be added to the exclusion list. For information on configuring the Variable
Compare activity, see "Configuring the Variable Compare activity" on page 624.
NOTE: If you are migrating from 6.0.x to Version 7.1, the Variable Compare activity and its branches
correspond to the ‘Exclusion Phone List’ from the ‘Callers Option’ tab for Voice Callback Plans.
The Variable Compare activity contains two branches: Invalid Numbers and No Match. If the phone
number collected in <<CallbackClientNumber>> matches any of the conditions of the exclusion list,
then the caller is routed into the Invalid Numbers branch. This branch contains a Play activity, which
informs callers they have input an invalid phone number. Next in this branch is a Go To activity,
which returns the caller to the Collected Digits activity. If the phone number in the
<<CallbackClientNumber>> does not match anything in the exclusion list, the caller is routed
through the No Match branch to the next activity in the workflow.
The workflow’s next step is to capture the customer’s preferred date and time for the callback in the
<<CallbackPreferredDateTime>> variable. The workflow continues with a Collect Digits activity,
which prompts the caller to enter the requested date and time for their callback. The format for this is
The format for this is DDMMYYYYTTTTXX, where XX is either ‘26’ for AM or ’76’ for PM. IVR
Routing will not offer the caller’s callback request to a queue until this date and time.
NOTE:
l

l

If you are migrating from 6.0.x to Version 7.1, this activity and its branches correspond to the
options under ‘Capture Preferred Time’ options in the ‘Callers Option’ tab for Voice Callback
Plans. A 12-hour date-time format is used exclusively and can only be entered as
DDMMYYYYTTTTXX, where XX is either ‘26’ for AM or ’76’ for PM..
This activity and its branches are not mandatory and may be removed from the workflow if you
do not want to enable callers to specify a date and time for a callback.

This activity has four branches: Success, Timeout, Invalid, and Failure. The Timeout and Invalid
branches are standard Collect Digits branches. Callers are routed to the Timeout Branch if they do
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not enter anything after 12 seconds, while callers are routed to the Invalid branch if they enter too few
digits or too many digits. Callers are routed to the Failure branch when their timeouts or invalid digit
entries exceed the set number of Invalid attempts, which by default is 3. The Failure branch contains
a Hang Up activity that terminates the workflow. For information on modifying the timeout duration of
the Collect Digits activity, see "Configuring the Collect Digits activity" on page 575.
If they enter valid digits, the caller is routed to the Success branch, where the Collect Digit activity
reads back the date and time entered. The branch contains a Date Time Validation activity. This
activity validates the entered date to ensure that the date and time are formatted correctly for use in
the Outbound Callback workflow. This activity contains three branches: Success, Timeout, and
Failure. Callers are routed to the Failure branch if the format of the date is not recognized as valid.
This branch contains a Go To activity that returns the caller to this Collect Digits activity. The
Success branch routes callers to the next activity in the workflow.
The Success branch contains a Set Variables activity that defines the window of opportunity the
system has to offer a callback to a caller. By default it is configured to 30 minutes, so if the system is
unable to contact the customer within 30 minutes of their preferred date and time, it will not try again.
The time may be customized to match contact center requirements for callbacks. For information on
modifying the Set Variables activity, see "Configuring the Set Variables activity" on page 620.
Once the date and time have been saved, the workflow continues to a Record activity, so callers can
leave a message with their callback request. The Record activity contains three branches: Save,
Discard, and Review. Discard and Review branches are standard Record activity branches. The
Record activity’s Save branch contains a Play activity, which informs callers that the recording has
been saved. The branch continues to a Set Variables activity that links the .wav file to the submitted
callback in SQL, ensuring that it is available to the agent when they receive this callback request.
For information on configuring the Record activity and its branches, see "Configuring the Record
activity" on page 609.
NOTE:
l

l

If you are migrating from 6.0.x to Version 7.1, the Record activity and its options correspond to
the ‘Capture Recording’ section from Voice Callback Plans.
This activity and its branches are not mandatory and may be removed from the workflow if you
do not want to offer callers the ability to record a message.

The workflow continues with a Menu activity. This activity is the final step in the workflow for the
caller, requesting that they either confirm or cancel their callback request. The instruction prompt
informs the caller 'To submit this callback request, Press 1. To cancel this request and exit this
system, please press the * key.' The Menu activity has five branches: 1. Confirm, *. Cancel,
Timeout, No Match, and Failure. The Timeout and No Match branches are standard Menu branches
with no additional configuration. The Failure branch contains no activities and routes callers through
to the Save Callback to Requeue Activity, the *. Cancel branch, which contains a Play activity
informing callers that their callback has been cancelled, and a Hang Up activity, which ends the
workflow. The Confirm Branch contains no activities and routes the callers through to the Save
Callback activity.
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NOTE:
l

l

If you are migrating from 6.0.x to Version 7.1, the Menu activity and its options correspond to
the ‘Capture Confirmation’ section from Voice Callback Plans.
This activity and its branches are not mandatory and may be removed from the workflow if you
do not want to offer callers to ability to confirm or cancel their callback request.

The final activity in this workflow is a Save Callback activity. This activity saves the callback
request to the SQL database with the reason ‘New Request – Voice’, which enables the outbound
port to detect it and offer it to the queue. This activity contains two branches: Success and Failure.
The Success branch contains a Play activity that informs the caller that the callback has been
submitted and routes the caller out of the workflow. The Failure branch has a Play activity that
informs callers that the callback request submission failed, followed by a Go To activity that returns
the callers to the Menu activity to attempt callback resubmission.

IVR ROUTING WORKFLOW SAMPLES
Version 7.1 includes a variety of sample workflows. These workflow samples are based on common
business scenarios. They not only demonstrate how IVR Routing can be used to efficiently direct
calls to appropriate queues but, because they can be imported directly into your IVR Routing
application, they save you the time of creating your own introductory workflows.
The sample workflows create a basis upon which you add elements to fully customize your IVR
Routing solution. For example, if you want to be able to access a database of customer phone
numbers, you will need to create the database and make it available to your workflow. Each sample
workflow description below includes recommendations for workflow configuration optimization.
Generic prompt messages are included for applicable workflow samples.
Version 7.1 gives you access to the following six sample workflows:
l

Schedule with Mode of Operation and Menu

l

ANI and DNIS condition with unique menus and a callback option

l

Schedule condition followed by DNIS and Language with menus

l

Management Plan subroutine

l

Outbound workflow with Excel

l

Workflow for PCI Compliant systems
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Some sample workflow contain Menu activities. The Menu activity prompts callers with messages
and manages routing based on caller input. Besides the options you configure and add in the Menu,
there are three default branches included in all Menu activities: Timeout, Invalid, and Failure. These
branches cannot be deleted and function as follows:
l

l

l

Timeout: Calls are routed to this option if the caller does not respond to a request within the
time limit allowed, as configured for the Main Menu in the Properties pane, under Options. A
default timeout message plays and the caller is returned to the Main Menu. You configure the
number of times the call is returned to the Main Menu, after failing to respond to a request
within the set time limit. If the caller exceeds the number of attempts, the call proceeds to the
Failure branch.
Invalid: This branch works similarly to the Timeout branch except that it channels callers that
have entered invalid response digits. There is a default Invalid number message that plays.
Failure: Calls are routed to this branch if the maximum Timeout or Invalid attempts are
reached. Calls that enter the Failure branch are, in most samples, transferred to the Operator.
If the Operator is unavailable, the call proceeds to the Hang up activity. If you want a message
to play in this branch, you must configure and add one.

NOTE: After importing the sample workflows and assigning them to ports they will be 'live' in your
system. Any modifications to the workflows will affect your IVR Routing system. For example, if
you put a port into Emergency Mode using the Sample Management Plan workflow that port will
indeed go into Emergency Mode.

IMPORTING IVR ROUTING SAMPLE WORKFLOWS
In order to have access to the sample workflows you must import them from the folder in which they
are stored when you download our software.
To import IVR Routing sample workflows
1. Click IVR Routing=>Workflows.
2. Click the Import button.
3. Navigate to the .xaml file you want to import and click Open.
NOTE: The sample workflows are located in C:\Program Files (x86)\prairieFyre Software
Inc\CCM\Ivr\Sample Callflows.
4. Click Save.
NOTE: After importing a workflow, you must configure your own prompts and connect the workflow
to devices that are specific to your system. If the prompts you configure or the connections you
make to devices are invalid, a red exclamation mark icon displays on the Workflows Canvas
indicating a validation error. For more information, see "Troubleshooting workflow configuration with
the Validation button" on page 568.

Associating sample workflows to extensions or hunt groups
After you import a sample IVR Routing workflow, you must associate it to extensions or hunt groups
in order to make the workflow go 'live' in your system. For more information, see "Associating
workflows to devices" on page 529.
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SAMPLE SCHEDULE WITH MODE OF OPERATION AND MENU
This workflow instructs IVR Routing to direct calls that arrive during business hours, in normal
conditions, to the appropriate queues based on the caller’s selection of menu options. Calls arriving
during business hours when the contact center is closed due to emergency conditions are routed to
an Emergency branch where they hear an emergency message explaining why the contact center is
closed. Calls arriving outside business hours are routed to a Closed branch where they hear a
prompt informing them that the contact center is closed.
This workflow:
l
l

l

Makes customers aware of business hours and channels their calls as applicable
Enables calls to be routed during emergency closures, for example, in extreme weather
conditions
Routes callers to the appropriate queues, based on customer digit selection

Figure 120 displays this workflow as it appears when first imported.

Figure 120: Schedule with Mode of Operation and Menu
Description
The first step in this workflow is an Answer activity. The Answer activity tells the port to answer the
call. Until this condition is met, the caller hears ringing.
Next in the workflow sequence is the Schedule condition (Mon-Fri, 9-5). There are two branches,
Open and Closed, each containing activities, within the Schedule. A check is done to confirm that
the date and time of the call falls within business hours (set as Monday – Friday, 9 AM – 5 PM).
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If the call arrives outside of business hours, then the call is routed to the Closed branch, a Closed
Message plays, and the call proceeds to the Hang up activity. The Hang up activity ends the
workflow and disconnects the call. If you do not have a Hang up activity, the call will continue
through the workflow until it reaches the end of all possible actions, at which point it will wait in
silence until the port resets.
If the call arrives within business hours, then the call is routed to the Open branch and the Mode of
Operation activity is confirmed. The system checks if the ports or hunt groups assigned to the
workflow are in Normal mode or Emergency mode. If they are found to be in Emergency mode, the
Emergency Message plays and the call is directed to the Hang Up activity. If they are found to be in
Normal mode, the call proceeds to the Main Menu activity.
The Main Menu activity prompts callers with messages and manages routing based on caller input.
In this example, the Main Menu activity has been configured with three options and customers are
prompted to press whichever option suits their needs. IVR Routing then directs the caller to the
appropriate queue based on the number they pressed.
The three numbered options in the Main Menu activity were added manually to this sample workflow
and complete the following actions:
l

Option 1: Transfers the caller directly to the Support Queue

l

Option 2: Transfers the caller directly to the Sales Queue

l

Option 3: Plays the Hours of Operation Message

Options 1 and 2 have a Failure branch. If the transfer destination is unavailable, the caller is routed to
the Operator. We recommend you set up the Failure branch to redirect calls to a dependable,
available endpoint.
The last step in this workflow is the Hang Up activity. We recommend you end workflows with a
Hang Up activity to prevent errant calls from resting at the end of the workflow and tying up the port
until it can reset and disconnect the call.
Additional configuration required
To get your workflow sample up and running, you must:
l

l

l
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Associate the workflow to a port (extension) or a hunt group. See "Associating workflows to
devices" on page 529.
Configure Properties for Transfer Activities. In this sample, the Operator and the Sales and
Support queue destination information needs to be added. To do this, simply right-click the
Transfer activity in the workflow and specify the Destination in the Properties pane
Create prompts (messages) as needed. For example, in this workflow, generic prompts are
included for the Greeting Message, Closed Message, Emergency Message, and Hours of
Operation Message. If you want to customize these messages, you will need to create your
own and add them to the workflow.
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SAMPLE ANI AND DNIS CONDITION WITH UNIQUE MENUS
AND A CALLBACK OPTION
This workflow instructs IVR Routing to direct calls to appropriate queues based on the caller’s
telephone number (ANI), the number the caller dialed to reach the contact center (DNIS), and callerentered responses to menu options. The menu options are unique to each branch, meaning that
callers are presented with different menu options based on where their call originated or the number
they dialed to reach the contact center. In addition, the customer is offered the option of requesting a
callback rather than waiting in queue for an agent. In this example, callers are routed based on their
customer status (derived from their ANI) or based on the number they called to reach your contact
center, either the Enterprise Business Level or Entry Level Business Software contact number.
This workflow:
l

l

l

l

Shows you how to channel callers to queues based on the area from which they are calling.
This type of call routing could be beneficial if, for example, you have a sales promotion that is
targeted toward particular geographical markets, callers from those areas would be directed to
a queue with promotional RADs and agents who have been trained to sell products
specifically related to the current promotion. Another useful application for this workflow could
be for companies who offer services that are specific to a certain area. For example, a flooring
installation company with offices in cities across the country could direct callers based on the
city from which they are calling to agents who book in-home flooring consultations.
Demonstrates how you can set up your IVR Routing system using ANIs to help route
customers with specific needs to the agents most suited to assist them. In this sample, a VIP
customer calls in and is recognized as such by their ANI, which you have added to the ANI
list. They are automatically transferred to an experienced agent with advanced customer
relation skills.
Allows you to send callers to queues based on the number they dialed to access your contact
center. This enables callers to be more accurately routed to the services in which they are
most interested. In this sample, callers are channeled to either the Enterprise Business Level
or Entry Level Business Software queue based on the number they called to reach you.
Gives callers the option of leaving a message and receiving a callback rather than waiting in
queue. Customer satisfaction is improved when callers are offered this enhanced level of
control. In addition, the call center operates more smoothly as some calls are diverted during
busier periods to be handled during less busy hours

Figure 121 displays this workflow as it appears when first imported.
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Figure 121: Sample ANI and DNIS Condition with unique Menus and Callback option
Description
The first step in this workflow is an Answer activity. The Answer activity tells the port to answer the
call. Until this condition is met, the caller hears ringing.
Following the Answer activity, is an ANI condition that checks the caller’s phone number. We
recommend placing the ANI condition near the beginning of the workflow as you can use this activity
to initially filter calls based on whatever parameters work best for you, for example, you could filter
based on VIP status or, conversely, based on a list of customers with a heightened need for
immediate support, such as those with a recent history of dissatisfaction with your product. By
filtering these calls based on ANI, you can configure the subsequent workflow sequence to channel
these calls to queues that are best suited to their needs.
Within the ANI condition, there are three branches that evaluate the ANI and branch the call based
on the results. In this example, the caller is branched, based on ANI, either to the Elevated Support
Line branch, VIP Customers branch, or a No Match branch. The Elevated Support Line branch (in
this example, used for customers that are in need of immediate, skilled support, as they are currently
experiencing difficulties with your product) and the VIP Customers branch each contain a Failure
branch which routes the caller to the Operator if the transfer destination is unavailable. We
recommend you set up the Failure branch to redirect calls to a dependable, available endpoint.
If the ANI is unrecognized (No Match), the system moves on to check the DNIS (the number the
customer called to reach the contact center).
Within the DNIS condition, there are three branches that evaluate the DNIS and branch the call
based on the results. In this example, the caller is branched, based on DNIS, either to the Enterprise
Business Level Menu, the Entry Level Business Software Menu, or a No Match branch.
The Enterprise Business Level Menu prompts callers with messages and manages routing based on
caller input. In this example, it has been configured with two options and customers are prompted to
press whichever option suits their needs. IVR Routing then directs the caller to the appropriate
queue based on the number they pressed.
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The two numbered options in the Enterprise Business Level Menu activity were added manually to
this sample workflow and complete the following actions:
l

Option 1: Transfers the caller directly to the Support Queue

l

Option 2: Transfers the caller directly to the Sales Queue

Options 1 and 2 have a Failure branch. If the transfer destination is unavailable, the call goes to the
Hang Up activity.
The Entry Level Business Software Menu activity prompts callers with messages and manages
routing based on caller input. In this example, it has been configured with two options and customers
are prompted to press whichever option suits their needs. IVR Routing then directs the caller to the
appropriate queue based on the number they pressed.
A Queue Condition has been added to this branch to enable the callback request option. In this case,
the Queue Condition checks if more than five calls are waiting in queue and if this is the case, the
caller is offered the option of requesting a callback rather than waiting in queue. You can alter this
Queue Condition as needed.
In the Offer Callback Menu, you configure a message that informs the customer about current call
volume and wait times, based on the queue condition you set. There is a sample Default Callback
Inbound Voice subroutine included with IVR Routing. You can either use this subroutine with the
Callback Request activity or create your own callback subroutine to use with this workflow. For
more information about callback plans, see "Configuring callbacks" on page 535.
If the customer declines the request for a callback, the workflow progresses to the Entry Level
Business Software Menu.
The two numbered options in the Entry Level Business Software Menu were added manually to this
sample workflow and complete the following actions:
l

Option 1: Transfers the caller directly to the Support Queue

l

Option 2: Transfers the caller directly to the Sales Queue

Options 1 and 2 have a Failure branch. If the transfer destination is unavailable, the call goes to the
Hang Up activity.
If the DNIS is unrecognized, the caller is routed down the No Match branch and, subsequently, the
Operator.
The last step in this workflow is the Hang Up activity. We recommend you end workflows with a
Hang Up activity to prevent errant calls from resting at the end of the workflow and tying up the port
until it can reset and disconnect the call.
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Additional configuration required
To get your workflow sample up and running, you must:
l

l

l

l

Associate the workflow to a port (extension) or a hunt group. See "Associating workflows to
devices" on page 529.
Configure properties for all Transfer activities. For example, the Operator and the Sales and
Support queue destination information needs to be added. To do this, simply right-click the
Transfer activity in the workflow and specify the Destination in the Properties pane.
In addition, for the Default Outbound Callback, you must designate ports that you want to use
for callbacks as Outbound ports (extension type: Outbound port 5020 IP).
Create prompts (messages) as needed. Generic prompts are included in this workflow but if
you want to customize these messages, you will need to create your own and add them to the
workflow.

SAMPLE SCHEDULE CONDITION FOLLOWED BY DNIS AND
LANGUAGE WITH MENUS
This workflow instructs IVR Routing to direct calls that arrive on standard work days, during
business hours, to language-specific queues based on the number the caller dialed. Callers are
routed to a single menu, which presents prompts in the appropriate language.
This workflow enables you to:
l
l

l

Configure schedule conditions to route calls based on predefined holidays
Offer services in more than one language based on the number dialed to reach your contact
center
Use the same Prompt but make it available to all configured languages

Figure 122 displays this workflow as it appears when first imported.

Figure 122: Schedule condition followed by DNIS and Language with Menus
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Description
The first step in this workflow is an Answer activity. The Answer activity tells the port to answer the
call. Until this condition is met, the caller hears ringing.
Next in the workflow sequence is the Schedule condition. There are three branches, Holidays, MonFri, 8-5, and No Match. Placing the Holiday branch on the far-left of the workflow ensures that this
branch is checked first. If it is determined that the call is being received on a predefined holiday, a
Closed Message plays and the call proceeds to the Hang Up activity.
NOTE: You must configure the workflow to check whether it is a holiday before checking whether it
is within business hours. If a call enters the system between 8 AM and 5 PM on a Monday that is a
statutory holiday and you check the business hour schedule first, the system will erroneously
determine that the call center is open and the call will proceed through the workflow, even though
your office is closed.
If it is not a holiday, a check is done to confirm if the date and time of the call falls within business
hours (set as Monday – Friday, 8 AM – 5 PM). If the call arrives within business hours, the call is
routed to the DNIS check. If the call arrives outside of business hours, it is routed to the No Match
branch and a Closed Message plays. The call then proceeds to the Hang Up activity. The Hang Up
activity ends the workflow and disconnects the call. If you do not have a Hang Up activity, the call
will continue through the workflow until it reaches the end of all possible actions, at which point it will
wait in silence until the port resets.
If the call passes the Schedule criteria, it continues to the DNIS activity. This workflow sample
contains three DNIS, each one representing a different language (French, English, and German, in
this case). According to the DNIS, the call is routed through the appropriate Language activity to a
Menu. The Menu is the same for each DNIS and has the same Prompt. The Prompt contains .wav
files that are specific to each language. Depending on which language activity the call was
channeled through, the matching language .wav file will play. This enables reuse of the same Prompt
regardless of the number of language activities that are configured. If there is no DNIS match, the
workflows to the No Match branch and is transferred to the Operator.
As noted above, the Menu options are the same for each DNIS – only the Language is different. The
two numbered options in the Menu activity (Main Menu) were added manually to this sample
workflow and complete the following actions:
l

Option 1: Transfers the caller directly to the Support Queue

l

Option 2: Plays the Shipping Instructions Message

Option 1 has a Failure branch. If the transfer destination is unavailable, the call goes to the Hang Up
activity.
The last step in this workflow is the Hang Up activity. We recommend you end workflows with a
Hang Up activity to prevent errant calls from resting at the end of the workflow and tying up the port
until it can reset and disconnect the call.
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Additional configuration required
To get your workflow sample up and running, you must:
l

l

l

Associate the workflow to a port (extension) or a hunt group. See "Associating workflows to
devices" on page 529.
Configure properties for all Transfer activities. For example, the Support queue destination
information needs to be added. To do this, simply right-click the Transfer activity in the
workflow and specify the Properties in the Properties pane.
Create prompts (messages) as needed. Generic prompts are included in this workflow but if
you want to customize these messages, you will need to create your own and add them to the
workflow.

SAMPLE MANAGEMENT PLAN WORKFLOW
When assigned to a Management activity in a workflow, the Default Management Plan subroutine
enables authorized callers to remotely perform management operations on their IVR Routing
application. For example, authorized callers can switch the IVR Routing Mode of Operation between
Normal and Emergency mode and modify the prompts that callers hear.
This subroutine:
l

l

Enables you to change over from Normal to Emergency mode if extreme weather conditions
or other events force the temporary, unforeseen closure of your contact center. In such
conditions, it is often desirable and sometimes necessary to make such changes from a
remote location.
Enables authorized users to make changes to the IVR Routing system remotely. You can
modify incoming caller options and record new prompts using a phone. This is useful when a
commute to the site is either inconvenient or not possible.

Figure 123 displays the Management Subroutine.

Figure 123: Management Plan workflow
Description
The first step in this subroutine is a Menu activity, which prompts you to enter the Management
Password. Authorized users enter their password (in this sample, 1234) in order to access the
Management subroutine.
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The next step in the subroutine is the Record Prompts or Set Mode of Operation Menu. Within this
Menu activity there are two, numbered options that were added manually and complete the following
actions:
l

Option 1: Record prompts or record new greeting

l

Option 2: Select 1 for System; 2 for Device

If you press Option 1 in the Record Prompts or Set Mode of Operation Menu, you can record new
prompts or record new greetings and swap prompts from one position to another within a workflow or
subroutine.
Press Option 1 to record a Prompt. If, after recording a Prompt, you want to continue recording
Prompts, press 1 to record, press 2 to exit, or press any other key to return to the Record prompts or
record new greeting Menu activity (activityMenu7 in the subroutine) through a Go To activity.
If you press Option 2, you can record a new Greeting or swap a Prompt. For example, you can record
an Emergency Closed Message during an emergency situation and then swap it for a traditional
Open Message once the emergency has been resolved.
If you press Option 2 in the Record Prompts or Set Mode of Operation Menu, you can set the System
Mode of Operation to either Emergency or Normal mode. If you select 1 (for system) you are
affecting the Mode of Operation for all hunt groups and ports. If you select 2 (for device) you are
affecting only the devices for which you enter a reporting number (individual hunt groups or ports).
Additional configuration required
This subroutine must be associated to a Management activity in an Inbound workflow or an Inbound,
Management, or Callback Inbound subroutine.
It is recommended that you incorporate access to the Default Management Plan subroutine into your
main workflows. There are various ways to do this. For example, you could use an ANI condition
that refers to a list of authorized user numbers and gives them the option, when they call in, of
accessing the Management activity configured with the Default Management Plan subroutine. You
could alternatively add a DNIS condition and give users the appropriate number to call in to access
the Default Management Plan. If your workflow has an ANI or DNIS branch, you can add the Default
Management Plan ANI or DNIS branch as an additional branch in that location of the workflow. The
menu option for accessing the Default Management Plan should be hidden (unadvertised) meaning
that it is not mentioned in your greeting message. The authorized user would input a set code to
access the Default Management Plan.
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SAMPLE OUTBOUND WORKFLOW WITH EXCEL
This workflow queries a data provider, in this case an Excel spreadsheet, to retrieve customer
contact information. The workflow then uses the contact information to make outbound calls to
customers. If a call is not answered by the customer or if the line is busy, IVR Routing continues to
attempt the call until it is connected. If the customer answers the ringing line or the call goes to the
customer’s voicemail the workflow updates the call status as 'Completed' and the customer will not
be called again. Customers who answer the outbound call are directed to a menu presenting them
with routing options
This workflow enables:
l

Contact centers to make outbound calls to customers by accessing an internal database

Figure 124 displays this workflow as it appears when first imported.

Figure 124: Outbound workflow with Excel
Description
This sample workflow uses an Excel spreadsheet, called OutboundSample.xlsx. This file is located
in the IVR folder on the Enterprise Server. You populate the Excel sheet with customer phone
numbers that you access while making outbound calls.
The first step in this workflow is the Schedule condition. There are two branches, Open Hours 9-5
and No Match. If calls are executed during business hours, they progress to the Query. If calls are
executed outside of configured business hours the workflow routes to the No Match branch and then
to the Hang Up activity.
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If during business hours, the workflow progresses to the Query. The Query references the Data
Provider (in this case, Default Outbound Provider). In this sample, the Data Provider refers to the
Excel sheet of customer phone numbers that is mentioned above. This Excel sheet has two
columns – one for the customer’s phone number and one for the customer’s status. The Excel sheet
and the Query can be modified as needed.
The first Query action is to run a Select statement to pull the first number with an 'Incomplete' status
to call. The Select Query either goes to the Success branch (if it successfully finds/selects a
customer phone number) or to the Failure branch if no customer phone number is found. When the
call enters the Failure branch an email is sent to managers advising them that no 'Incomplete' calls
remain in the database Excel sheet. Access to this functionality requires you to first configure the
SMTP Server and the email template used for this example.
If an 'Incomplete' status call is selected, the workflow progresses to the Success branch and the
Write statement executes, which changes the customer’s status from 'Incomplete' to 'In Progress',
preventing other ports from simultaneously calling the same customer.
When the Query successfully pulls a customer phone number, it proceeds to the Make Call activity.
The Make Call activity has a destination set for LastQueryResult, meaning it will dial the phone
number that the Query pulled from the Excel spreadsheet.
The Make Call activity has several branches. When you successfully connect to a customer, the
call goes down the Success branch, a query is executed and the customer status is updated to
'Completed', ensuring that number is not called again. Following this action, the customer is
presented with two options. They can choose to either be transferred to a queue to speak to an agent
or listen to a message for more information. For example, you could record a message with details
about a current sales promotion.
If there is no answer, a Query is executed and the customer status is updated to 'No Answer',
meaning that when this number is selected from the list the next time, the system will attempt to call
it again.
If there is a busy signal (Destination Busy), a Query is executed and the customer status is updated
to 'Busy', meaning that when this number is selected from the list the next time, the system will
attempt to call it again.
If the number is not in service (Invalid Destination), a Query is executed and the customer status is
updated to 'Invalid', meaning that when this number is selected from the list the next time, the
system will not attempt to call it again.
If the Make Call fails due to an issue with the telephone system, an email is sent to the manager(s)
advising them of the communication failure. Access to this functionality requires you to first
configure the SMTP Server and the email template used for this example.
The last step in this workflow is the Hang Up activity. We recommend you end workflows with a
Hang Up activity to prevent errant calls from resting at the end of the workflow and tying up the port
until it can reset and disconnect the call.
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Additional configuration required
To get your workflow sample up and running, you must:
l

l

l

l

l

l

Associate the workflow to a port (extension). This workflow type cannot be assigned to a hunt
group. See "Associating workflows to devices" on page 529.
Configure properties for all Transfer activities. For example, the Transfer to queue destination
information needs to be added. To do this, simply right-click the Transfer activity in the
workflow and specify the Properties in the Properties pane
Create prompts (messages) as needed. Generic prompts are included in this workflow but if
you want to customize these messages, you will need to create your own and add them to the
workflow.
In order to make the workflow active, you must select 'Always Run' in the Properties Pane,
under Workflow. If you want to end the workflow activity, deselect this option.
We recommend adding a queue condition in the Success branch of this workflow so callers
are directed to the queue only if, for example, a sufficient number of agents are available to
take their call or the number of calls waiting in the queue is not excessive. Rather than making
the caller wait to speak to an agent in this situation, it might be preferable to instead play the
'Play more information on offer' message.
We suggest adding a queue condition following the Schedule condition that sets calling times
for the optimum times of the day, for example, you might only want to make outbound calls
between 3 PM and 7 PM. By setting a condition in this way, you can ensure that you have
sufficient agents available during that time to handle calls.

WORKFLOW FOR PCI COMPLIANT SYSTEMS
The PCI Compliant workflow is an example of how contact centers can use IVR Routing to collect
sensitive information, such as credit card numbers, from contacts while ensuring their privacy. While
handling a contact, agents need the ability to collect sensitive information without being able to
interact with that information. The PCI Compliant workflow offers a demonstration workflow
configuration that leverages the Hold State activity to enable a contact to enter private information
while on call with an agent.
NOTE: The PCI Compliant workflow itself is not PCI compliant but it implements PCI security
requirements to protect the privacy of collected data. You are responsible for ensuring that your
configuration, including its associated variables, queries, and web services, meets the standards of
PCI Compliance.
In this workflow, the agent dials the port associated with this PCI Compliant workflow, starting a
conference call with the workflow. The workflow puts the agent on hold and prompts the caller to
enter their private information, which is stored in a masked variable. The information is routed to a
Query activity, which uses it to perform a query transaction. The agent is then returned from hold and
both contact and agent are informed via a Play activity if the PCI Compliant transaction was
completed correctly. The workflow then hangs up, returning the agent and contact to a two party call.
To further illustrate the workflow’s activities and their operations, we recommend you expand the
entire workflow and all annotations.
To expand the workflow
l
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Click the Expand All button.
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To expand all annotations
l

Right-click the workflow and select Annotations…=>Show All.

Requirements
The workflow provides a framework and as such requires several devices be configured before the
workflow can be used:
l

Prompts

l

Variables

l

Data provider

l

Extension

This workflow uses a number of prompts. You require the following prompts containing the following
messages:
l

l

l

l

l

l

Agent Notification: A message indicating to caller and agent that the agent is being placed
on hold
Collect Digits instructions: A message indicating to the caller what information they must
enter
Unable to Hold: a message indicating to caller and agent that the system was unable to
place the agent on hold
Request is being processed: A message informing the customer that their information has
been entered and is being processed.
Successful transaction: A message informing the caller and the agent that the caller’s
information has been entered and processed correctly
Failed transaction: A message informing the caller and the agent that the caller’s information
was not entered correctly

For instructions on configuring prompts, see "Configuring prompts" on page 532.
You require two variables configured for this workflow: a Secure Information variable and a
Validation variable. The Secure Information Variable is used to store the private information entered
by the caller. This variable must be set to FullMask to prevent the collected data from being viewed
by others. The Validation variable is used by a Query activity to store the confirmation that the
caller’s information was entered correctly and is used by a Variable Compare activity to inform both
the caller and the agent that the transaction was completed successfully. For instructions on
configuring variables, see "Configuring variables" on page 552.
This workflow requires that you have a data provider added to IVR Routing for use with this
workflow’s Query activity that contains the information that the caller enters.
For instructions on configuring data providers, see "Configuring data providers" on page 550.
This workflow also requires you to have a specific transaction that you want to perform using a
Query or an Execute activity. The workflow includes a Query activity, but you must configure a
query relevant to your business needs. The Query should use the information entered in the Secure
Information variable and return any relevant information in other variables, as determined by your
transaction’s function. At a minimum, the Query activity’s query must be configured to store a value
in the Validation variable that will be used to confirm to both the agent and the caller that the caller’s
private information was entered successfully.
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The PCI Compliant workflow requires a port with which to be associated, so an agent can dial it
while handling a caller.
Description
The first activity in this workflow is the Answer activity. The agent and contact are next routed to a
Play activity. The purpose of this Play activity is to provide a message to the agent that they are
being placed on hold. This activity should be configured with your ‘Agent Notification’ prompt. For
more information, see "Configuring the Play activity" on page 598.
After the workflow answers, the caller and agent are routed to the Hold State activity. This activity
places the agent on hold for the duration of the Success Branch of the Hold State activity, preventing
them from hearing the caller’s interaction as they enter their credit card information. This activity
must not be removed or modified, otherwise PCI Compliance will be compromised. This activity has
two branches: Success and Failure. If the agent is successfully placed on hold, the workflow routes
down the Success branch. The agent remains on hold for the entirety of the Success branch. If the
agent is not placed on hold, the workflow routes down the Failure branch.
The Failure branch contains a Play activity. The purpose of this Play activity is to provide a message
informing the agent and caller that the system was unable to place the agent on hold. This activity
should be configured with your ‘Unable to Hold' prompt. For more information, see "Configuring the
Play activity" on page 598.
The first activity of the Success branch is a Collect Digits activity. This activity, when configured,
prompts the caller to enter the private information, which is stored in the Secure Information variable.
By default, this activity has no preset configuration. Under the Variable Collection Settings, set the
Variable as the Secure Information variable and set the Greeting as the ‘Collect Digits instruction’
prompt. You must also set the Minimum and Maximum digits to collect for the caller’s information.
This activity can be configured with a Confirmation prompt to inform customers that their information
has been entered. For more information, see "Configuring the Collect Digits activity" on page 575.
The Collect Digits activity has four branches: Success, Timeout, Invalid, and Failure. Callers are
routed to the Timeout branch if they do not enter anything after 5 seconds. This branch contains a
Play activity, whose prompt informs callers that there was no input, and a Go To activity, which
returns callers to this Collect Digits activity. Callers are routed to the Invalid branch if the callerentered information goes over or under the specified minimum or maximum digits specified during
this activity’s configuration. This branch is identical to the Timeout branch. Callers are routed to the
Failure branch when their timeouts or invalid digit entries exceed the set number of Invalid attempts,
which by default is 3.
The Success branch contains a Play activity. The purpose of this Play activity is to provide a
message informing callers that their information is being processed. This activity should be
configured with your ‘Request is being processed’ prompt. For more information, see "Configuring
the Play activity" on page 598.
The next activity in the Success branch is a Query activity. This activity’s purpose is to query a
customer database with the information from the Secure Information variable. The Query activity
requires a database provider and a Query statement so that the Secure Information variable can be
used to retrieve confirmation information to populate the Validation variable. For more information on
configuring a Query activity, see "Configuring the Query activity" on page 600.
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NOTE:
l

l

Depending on the complexity of your transaction logic you may need to add additional Query
or Execute activities to complete your transaction and retrieve the desired information.
This activity can be replaced with an Execute activity if you need to communicate with an
external source, such as a web service. If executing a web service, ensure that you use
HTTP Secure (https). The Execute activity must populate your Validation variable. For more
information, see "Configuring the Execute activity" on page 584.

The activity next continues to a Variable Compare activity, which should be configured to check if
the Validation variable has the correct value stored. For more information, see "Configuring the
Variable Compare activity" on page 624.
The Variable Compare activity has two branches: Successful Transaction Condition and No Match.
If the variable compare matches your configured conditions, the workflow routes down the
Successful Transaction Condition branch. This branch contains a Play activity, which should be
configured with the ‘Successful Transaction’ prompt, informing caller and agent that the transaction
was completed successfully. If the variable does not match your configured conditions, the workflow
routes down the No Match branch. This branch contains a Play activity, which should be configured
with the ‘Failed transaction’ prompt, informing caller and agent that the transaction was not
completed.
The workflow continues to a Hang Up activity, ending the conference call with the workflow and
returning the caller and the agent to a two party call.

IVR ROUTING COMPLEX WORKFLOW
CONFIGURATION
The following section describes how to configure two intricate workflows. You can use these
instructions to create the workflows as described or as an educational exercise from which you can
learn to build your own customized, unique workflows. Before attempting to configure these
workflows you must be familiar with IVR Routing and able to proficiently configure intermediate to
advanced level workflows using IVR Routing.
This document shows you how to construct:
l

l

Outbound workflow: An outbound workflow that returns abandoned calls on a priority basis
according to customer status
Dial Active Directory workflow: A workflow that uses a LDAP connection to a Windows
Active Directory domain to retrieve phone numbers and transfer the caller to the retrieved
extension

OUTBOUND WORKFLOW CONFIGURATION
This example demonstrates how to build an outbound workflow that returns abandoned calls on a
priority basis according to customer status. This workflow makes use of the delay activity,
populates custom variables with a specific format type, demonstrates enhanced email activity by
adding attachments, and sends custom variable information to agents via enhanced screen pop.
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Consider the following scenario:
Problem: A busy order desk is having trouble keeping up with customer requests. As a result, they
are dealing with a high number of abandoned calls. Their customers are sorted into three priority
levels: gold, silver, and bronze. Gold member callers are considered the highest priority and the order
desk is obligated to return their calls expediently in order to meet service level agreements. Each day
a SQL table is populated with all of the abandoned calls from the previous day including the
customer’s priority levels. All gold customers must be called back.
Solution: The following outbound workflow is configured to search for customer numbers based on
priority level, thus ensuring gold-level customer calls are returned expediently. In addition,
customers are given options that can expedite call handling, resulting in a more efficient use of agent
resources. For example, if callers are offered choices, besides the option of connecting with an
agent, of being sent a PDF of their order status or listening to a message describing their balance
and due date, some caller’s needs would be satisfied without having to speak to an agent. If callers
choose to speak to an agent, specific caller information, for example, their status is delivered to the
agent via a screen pop display when the agent connects to the call.
Figure 125 depicts the final, post-configuration version of the Outbound workflow example described
here.

Figure 125: Outbound workflow

Configuring a database provider
The first step in creating this workflow is to determine the source from where you will retrieve the
numbers to call back. Typically the outbound call list is stored in a SQL database or an Excel
spreadsheet. In this example, the following table was created in a SQL database. The example SQL
database used in this sample workflow is named abandoned_caller. (See Table 45.)
NOTE: We recommend following standard database design practices when setting up your
database. The example database referred to in this document is for demonstration purposes only.
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Table 45: SQL database example for abandoned caller list
ID

[LEVEL]

CALLERID

USERNAME

BALANCE

EMAIL

100

Gold

3001

Dave

21.32

dave@prairiefyre.com

101

Silver

6132221212

James

201.55

james@prairiefyre.com

102

Bronze

6135990000

Curtis

30

curtis@praireifyre.com

ID

LASTBILL

DUEDATE

PROCESSING CONTACTED

FAILEDATTEMPT

100

\\share\bills\
100bill.docx

April 20, 2012

0

false

NULL

101

\\share\bills\
100bill.docx

September 1,
2012

0

false

NULL

102

\\share\bills\
100bill.docx

Dec 12, 2012

0

false

NULL

The SQL data types used for this example are shown in Figure 126.

Figure 126: SQL data types
The columns Processing and Contacted are added to the table to assist with call processing, as
follows. The outbound workflow executes in an always-run fashion. If there are records present in
the database and outbound ports are available, calls will be executed constantly. The processing
column is used to flag a call as in progress. When a call is in progress, it means that the outbound
port is currently calling that number. After the outbound workflow has completed, the contacted
column is set to true. This process ensures callers, once contacted, are not called back.
A FailedAttempt column is added to indicate the reason the attempt to call failed, for example, due
to No Answer, Destination Busy, or Invalid Destination. Figure 127 displays an example of failed
attempts as they display in the workflow.
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Figure 127: Failed attempt example

You must configure a database provider to supply outbound call records to the Outbound workflow.
This example uses a Microsoft SQL server as a data provider and names the data provider Abandon
DB. See "Adding a Microsoft SQL server as a data provider" on page 550.

Creating outbound ports
Outbound workflows and IVR Routing callbacks are both executed by the existing prairieFyre
Routing Outbound Service. Outbound port 5020 IP are used to process outbound workflows and IVR
Routing callbacks.
Refer to the procedure "Adding extensions for IVR Routing" on page 512 and add the appropriate
number of outbound ports. If you have any questions regarding the number of ports you require,
contact the Systems Engineering Team.

Defining variables
Before creating the workflow, define the variables that it will use. For this example, we have created
the following variables from the above SQL database example table. Ensure the 'Send to Agent’s
Desktop' check box is selected if you want customer-relevant database information to be available
in a screen pop display for agents upon call receipt. (See Figure 128.)
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Figure 128: Suggested variable configuration

Creating an outbound workflow
Now that you have populated the table in the SQL database with abandoned contact information,
added a database provider and outbound ports, and created applicable variables, you can create the
outbound workflow
To create an outbound workflow
1. Click IVR Routing=>Workflows.
2. Click Add and select Mitel Voice=>Outbound as the workflow type from the drop-down list.
3. In the Properties pane, configure the workflow properties as needed.
NOTE: To make the workflow active, select the Always run check box. When you no longer
want the workflow to be active, deselect this option.
4. Click Save.
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Configuring the outbound workflow for abandoned contacts
The first steps in configuring the outbound workflow for use with abandoned contacts are to add a
Query activity, a Make Call activity, and a Hang Up activity. The Make Call activity is used to place
calls to external phone numbers that are typically stored in a data source, such as a SQL database or
an Excel spreadsheet. The Query activity is used to retrieve the numbers from the database that are
then stored in a variable which is accessed by the Make Call activity when dialing. The Make Call
activity determines the location of the media server and provides the correct formatting for the
external phone number before placing the call. In this example, the query looks for gold-level
customers that require a return call.
To configure the outbound workflow for abandoned contacts
1. Add a Query activity and a Hang Up activity into the Workflows Canvas.
2. Right-click the Query activity and select Edit Database Provider.
3. Select the Abandon DB database provider created earlier.
4. Click OK.
5. Right-click the Query activity and select Edit Query Definition.
6. Under Query type, select Advanced Query and, under Settings, enter the following SQL
query(1):
SELECT top 1 * from dbo.abandoned_caller where level = ‘gold’ and processing = ‘0’ and
contacted = ‘False’
UPDATE dbo.abandoned_caller set processing = 1 where id in (select top 1 id from
dbo.abandoned_caller where level = ‘gold’ and processing = ‘0’)
7. On the Variable Assignment tab, assign the appropriate variables to the parameters returned
from the query(2).
Figure 129 displays steps 5-7.
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Figure 129: Creating the advanced SQL query
8. In the Success branch of the Query activity, add a Make Call activity.
See Figure 130.

Figure 130: Make Call activity
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9. Select the Make Call activity and configure the properties in the Properties pane.
10. For this example, beside Destination, select the variable <<OB_CallerID>> and click OK.
11. Select the External Call check box to indicate that these calls are external to the PBX.
Outbound dialing digits are appended when dialing externally.
NOTE: Outbound dialing digits must be programmed in YourSite Explorer for the media server
upon which the outbound ports reside. This is configured in YourSite=>Media
servers=>Location tab.

Configuring the branches of the Make Call activity
If the query is successful, the outbound number variable will populate. The caller is then offered the
option to speak with an agent, receive an email with account details, or listen to a message that
includes their account balance and due date. If the query is unsuccessful, for example, if you are set
up to call back gold-level callers and there are none available in the SQL database table, the failure
branch is followed
In the Success branch of the Make Call activity three actions are performed: Delay, Menu, and
Query. See Figure 131.

Figure 131: Branches of the Make Call activity
To configure the success branch of the Make Call activity
1. In the Success branch of the Make Call activity, add and configure properties for a Delay
activity.
The Delay action is used to give the customer time to answer the phone and greet the caller.
The delay value is set in seconds.
2. Following the Delay activity, add a Menu activity.
3. Right-click the Menu activity and add the three digit options as follows: 1. Speak with Agent,
2. Mail Last Record, and 3. Listen to balance and due date.
The customer will be able to select 1 to speak to an agent, 2 to receive an email containing
their most recent account information, or 3 to hear a message regarding their account balance
and due date.
See Figure 132.
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Figure 132: Menu activity options
4. Add a Transfer activity under option 1, an Email activity under option 2, and a Play activity
under option 3.
5. Configure the Properties for the Transfer activity. Be sure to set the Destination to an ACD
path.
6. Configure the Properties for the Email activity. Select the SMTP Server address from the
SMTP servers that were configured in YourSite Explorer during the software installation
process.
For more information, see "Configuring SMTP connections to Contact Center Solutions" on
page 83.
7. Right-click the Email activity and select Edit Email Template.
8. Right-click in the Configure email template window to see a list of available variables.
NOTE: To ensure the email is sent to the customer, use the variables that were populated
previously with the query action.
See Figure 133.
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Figure 133: Configuring the email template
9. Configure the Properties for the Play activity.
10. Right-click the Play activity and select Greeting prompts=>Add a new prompt.
The Prompt window opens.
You will configure the activity to play two custom .wav files and two prompts. The customer
will hear their account balance and due date, based on the variables you associate with the
prompts.
11. Select the Variables tab.
See Figure 134.

Figure 134: Configuring the Play activity
In this example, the OB_Balance variable is set as type ‘Date Time’ and the variable OB_
Balance is set as type ‘Dollars’. These variables have an associated format type. The variable
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type ‘Date Time’ must be formatted to suit the variable populated from the database query.
The available options display in Figure 135.

Figure 135: Date format options

12. Select MMDDYYY as the Date Format for the due date variable (OB_DueDate).
NOTE: The balance due variable (OB_Balance) can have either Currency Format selected.
The currency format is only used when writing data to a database.
13. Configure the exception branches, Timeout, Invalid, and Failure, as needed.
14. As a final step in configuring the success branch of the Make Call activity, under the Menu
activity, add a Query activity.
This query updates the SQL table to indicate that the call has been completed, ensuring that
number is not called again.
To configure the failure branch of the Make Call activity
1. Under No Answer, add and configure a Query activity that updates the customer status in
the database to 'No Answer' when the customer does not answer the call. The next time this
number is selected from the list, the system will attempt to call it again.
2. Under Destination Busy, add and configure a Query activity that updates the customer
status in the database to 'Destination Busy' when the busy signal is encountered. The next
time this number is selected from the list, the system will attempt to call it again
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3. Under Invalid Destination, add and configure a Query activity that updates the customer
status in the database to 'Invalid' when the number called is out of service. The next time this
number is selected from the list, the system will not attempt to call it.
4. Under Failure, add and configure a Subroutine activity that advises the Administrator when
there are problems with the workflow.
Adding this subroutine is recommended in order to help error proof the workflow.
After configuring the outbound workflow, associate it to a port. An outbound workflow cannot be
associated to a hunt group. See "Associating workflows to devices" on page 529.

DIAL ACTIVE DIRECTORY WORKFLOW CONFIGURATION
This section demonstrates how to build a workflow that uses an LDAP connection to a Windows
Active Directory domain to retrieve phone numbers and transfer the caller to the retrieved extension.
This example is composed of a main workflow and a subroutine that contains an LDAP query. The
caller is presented with a menu that prompts them to enter the extension of the party they wish to
reach. If they know the extension they can dial it at any time or they can dial by name (by pressing 1)
or choose to speak to the operator (by pressing 0). When the caller chooses option 1, the workflow is
directed to the Dial By Active Directory (DialByAD) subroutine. Subroutines are recommended when
a call process contains many activities or repeating tasks. In this case, the DialByAD subroutine
contains several activities. Segregating it from the main workflow simplifies the process.
Figure 136 depicts the final, post-configuration version of the Dial Active Directory workflow.

Figure 136: Dial Active Directory workflow
Figure 137 depicts the final, post-configuration version of the DialByAD subroutine.
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Figure 137: DialByAD subroutine

Preliminary configuration
Before creating the workflow, you must configure the required variables and prompts.
Create the following list of variables along with their associated variable type. (See Figure 138.)

Figure 138: Required variables
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After creating the variables, configure applicable prompts as shown in Table 46.
Table 46: Required prompts
PROMPT NAME

SCRIPT

DialAD – Main Menu

Thank you for calling. If you know the extension of the party you
wish to reach, dial it now. To dial by name, press 1. For operator
assistance, press 0.

DialAD – Name from
Dialpad

Using your touchtone keypad, please type the last name of the
person you wish to reach, followed by the pound (#) sign.

DialAD – Did you mean ...
NOTE: This prompt
references the variable
DAD_TempWav created
earlier

<DAD_TempWav> If this is the person you want to reach, press 1.
If not, press star (*).

Creating the main Dial Active Directory workflow
Now that you have created the variables and prompts, you can create the main Dial Active Directory
workflow.
1. Click IVR Routing=>Workflows.
2. Click Add and select Mitel Voice=>Inbound as the workflow type from the drop-down list.
3. In the Properties pane, configure the workflow properties as needed.
4. Add an Answer activity and a Hang Up activity onto the Workflows canvas.
5. After the Answer activity, add a Menu activity.
6. Click Save.
The next step in creating the Dial Active Directory workflow is configuring the Menu activity.
To configure the Menu activity
1. Select the Menu activity on the Workflows Canvas and, in the Properties pane, configure the
Menu properties.
2. Enter an appropriate Name for the menu and add a Prompt to play a greeting message to the
caller (DialAD – Main Menu, as shown in Table 46).
See Figure 139 for suggested configuration settings.
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Figure 139: Main Menu activity properties configuration

3. Right-click the Menu activity and add the three digit options as follows: 1 - Dial by AD, 0 Operator, and Any Characters.
NOTE: The In Between Digit Delay function allows the system to wait for one second (default
value) after hearing the first DTMF tone from the caller to see if another digit will be pressed
before processing the call.
4. In the Properties pane, configure the Menu options.
NOTE: It is important to give each menu option branch an appropriate name as doing so
simplifies the troubleshooting process when interpreting log files.
See Figure 140.
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Figure 140: Menu option configuration

5. In the 0 – Operator and the Any Characters branches of the menu options, add a Transfer
activity.
6. Right-click the Transfer activity that follows 0 – Operator and select Destination.
7. In the Properties pane, after Destination, type the extension that reaches the operator in
your organization.
8. Right-click the Transfer activity that follows Any Characters and select Destination.
9. Configure the Destination as the variable <<LastMenuCollectedDigits>>.
This sets the entry that is received by the Menu activity as the transfer point.
10. Name the Timeout, Invalid, and Failure branches of the Menu activity according to best
practices. Use the nomenclature br<PARENT_MENU><OPT>.
Following this naming convention simplifies the troubleshooting process when searching
through log files. See Table 47 for an example of best practice naming conventions.
11. Click Save.
Table 47: Best practice naming convention example
MENU BRANCH

NAMING CONVENTION

Timeout

brmnMain1OPTTIME

Invalid

brmnMain1OPTINV

Failure

brmnMain1OPTFAIL

Now that the main Dial Active Directory workflow has been configured, the DialByAD subroutine
must be configured and added to the overall workflow.
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Configuring the DialByAD subroutine
If the caller knows the last name of the person they are trying to reach, they enter the matching digits
in their dial pad. The dial pad compare feature is used to support this search function. The first step in
being able to access this functionality is to collect the digits. This is done via a Collect Digits activity
within the subroutine.
To configure the DialByAD subroutine
1. Click Subroutines=>Add=>Mitel Voice=>Inbound.
2. In the Properties pane, after Name, type DialByAD.
3. Add a Collect Digits activity to the subroutine.
4. Select the Collect Digits activity and, in the Properties pane, after Name, type Get Last
Name and after System Name, type cdGetLastName.
5. Configure the Go To activities in the Timeout and Invalid branches to return to the Get Last
Name Collect Digits activity.
See Figure 141.

Figure 141: Collect Digits activity
6. Name the Success, Timeout, Invalid, and Failure branches according to best practices, as
shown in Table 48.
Table 48: Best practice naming convention example
MENU BRANCH

NAMING CONVENTION

Success

brcdGetLastNameSUCC

Timeout

brcdGetLastNameTIME

Invalid

brcdGetLastNameINV

Failure

brcdGetLastNameFAIL
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7. Right-click the Get Last Name Collect Digits activity and select Edit Variable Settings.
The Collect Digits settings window opens.
8. Select the appropriate options for each value in the Collect Digits settings window.
The Variable should be unique to this workflow and be of the Variable Type Number. In this
case, the variable <<DAD_Ext-Lookup>> is used.
NOTE: This example uses a greeting that asks the caller to enter the last name of the person
they are trying to reach by using their dial pad and pressing pound (#) when finished. The
settings and greeting verbiage you choose are dependent on your environment and needs.
9. Click OK.
10. Click Save to save the subroutine.
This example performs a lookup based on the last name of the employee in Active Directory.
However, the procedure can easily be converted to use the first name or a different value altogether.
When a caller successfully enters digits they are branched down the Success branch in the Collect
Digits activity. In the Success branch, a Query to Active Directory is inserted to search for the
requested employee. Prior to this action, a new data provider must be created.

Configuring the LDAP data provider
To configure the LDAP data provider
1. Click Data providers=>Add and select LDAP from the drop-down list.
2. Enter the appropriate settings for the Active Directory domain, including a user with read
access.
3. Click Test Connection to attempt to connect to the domain.
This example connects to a local domain labeled 'PFSE Domain'.
4. Click Save.

Configuring the Active Directory LDAP query
This example queries based on the employee’s last name and returns their extension to which the
call is then transferred. The Last Name, Display name, and Telephone number fields from the user
object in Active Directory are accessed. In addition, the objects will return a .wav file so the names
can be read back to the caller. It is suggested that each employee record their name to use as a
customized .wav file. In this example, the customized employee name .wav files are stored in the
Telephones tab in Active Directory. Note that this location must be accessible from the IVR Routing
instance performing the query and readback. See Figure 142.
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Figure 142: Customized .wav file storage in Active Directory
To configure the Active Directory LDAP query
1. Add a Query activity to the Success branch of the Get Last Name Collect Digits activity.
2. Select the Query activity and, in the Properties pane, enter an appropriate Name and
System Name.
This example uses 'Get User from AD – PFSE.LOCAL' and 'qrPFSEAD' respectively.
3. Name the Success and Failure branches in adherence with best practices. In this case,
Success: brqPFSEADSUCC and Failure: brqrPFSEADFAIL.
4. Right-click the Query activity and select Edit Database Provider.
5. In the Select Connection window, choose the appropriate provider.
This example uses PFSE Domain.
6. Right-click the Query activity and select Edit Query Definition.
7. Under Query Type, select Advanced Query and, under Settings, enter the following query:
select info,telephoneNumber,CN from 'LDAP://PFSE.LOCAL where
objectClass='user' AND sn = '@LastName'.
An advanced query is necessary in this example to enable the return of multiple variables. If
there was only a need for a single variable, a simple query would suffice.
8. Click Execute.
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9. In the Parameters window, select the Value of ‘76’ for @LastName and select the Use
Dialpad Compare check box.
The value of ‘76’ is translated into the following when using the dialpad compare feature: p, pn,
Po, Q, Qm, Qn, Qo, R, Rm, Rn, Ro, S, Sm, Sn, So.
10. Click Run.
The command runs and the Database Lookup window for the Advanced Query opens.
11. Confirm correct configuration by clicking the Test Results tab and checking the info column
to ensure the expected result(s) were returned.
12. In the Variable Assignment tab, select appropriate variables for the returned values.
In this example, CN is used for the common name of the Active Directory object (display
name in Active Directory) and telephoneNumber for the extension of the user being queried.
The information from the Telephones tab is also returned as it contains the location of the .wav
file to be played. (See Figure 143.)

Figure 143: Variable assignment
13. In the Parameter Assignment tab, select the variable that was populated in the Collect
Digits activity, ‘cdGetLastName’. In this case, DAD_Ext-Lookup.
Configuring the parameter assignment with a variable replaces the query with the appropriate
run-time information. (See Figure 144.)

Figure 144: Parameter Assignment

Configuring the Success branch of the query
Now that information has been retrieved via the LDAP query, the process loops through the results
until the correct one is found. The customized employee name .wav file is played and the caller is
asked if that is the individual they want to reach. Once the correct name is found, the caller is
transferred to that destination and the workflow is terminated.
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To configure the Success branch of the query
1. Add a Menu activity into the Success branch of the Query activity (Get User from AD –
PFSE.LOCAL).
2. Select the Menu activity and, in the Properties pane, enter appropriate information for the
Name and System Name.
This example uses 'Did you mean…?' and 'mnDidYouMeanQ', respectively.
3. Under Prompt, in the Properties pane, select Existing Prompt from the drop-down list and
choose the prompt called DialAD – Did you mean …
4. Right-click the Menu activity and add a digit option for 1.
5. Name the Menu branches in accordance with best practices, as shown in Table 49.
Table 49: Best practice naming convention example
MENU BRANCH

NAMING CONVENTION

1

brmnDidYouMeanQOPT1

Timeout

brmnDidYouMeanQTIME

Invalid

brmnDidYouMeanQINV

Failure

brmnDidYouMeanQFAIL

6. In the Failure branch, add Hang Up activity
7. In the Timeout and Invalid branches, remove the default Play and Go To activities.
8. Removing these activities ensures that if the returned employee extension is not the correct
one, the parent Query activity will move on to the next result found and offer it to the caller
instead.
9. In the Digit option 1 branch, add a Play activity, a Transfer activity, and a Hang Up activity.
10. Name the activities, according to best practices, as shown in Table 50.
Table 50: Option 1 activity naming example
ACTIVITY

NAME

SYSTEM NAME

Play

Transferring your call

pfTransferring

Transfer

Xfr To Extension

xfrToExt

Transfer Branch

Failure

brxfrToExtFAIL

Hang Up

Hangup After Transfer

hgTransfer
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11. Choose an applicable prompt for the Play activity.
This example uses a prompt called 'DAD – Transferring' that plays a .wav file that says:
'Transferring your call now.'
12. Right-click the Transfer activity and select Destination.
13. In the Select a device window, select Variable and choose the appropriate variable assigned
in the LDAP query.
14. Click Save.

SYNCHRONIZING IVR ROUTING SERVERS
IVR Routing servers across your enterprise are synchronized so that saved changes made to one or
more remote servers are automatically applied to other servers. The IVR Sync status column in
YourSite Explorer enables you to monitor synchronization across servers after saving changes to
media servers, workflows, and subroutines. Prompts show synchronization status directly on the
Prompts page.
All synchronization information displays in real-time. If synchronization is unsuccessful, a message
displays in all applicable IVR Sync Status columns and in the device page header. Detailed
information also displays in YourSite Explorer’s RSS feed. For more information on alarms in
Contact Center Solutions, see "Monitoring and alarming subsystem" on page 178. For information on
specific alarm messages, consult the following Mitel Knowledge Base article:
http://micc.mitel.com/kb/KnowledgebaseArticle51286.aspx.
Only one set of pending changes to a specific device can be saved at any time. If another user saves
changes to the same device you are updating, before you save your changes, you will see the
synchronization in YourSite Explorer and will receive an error message when attempting to save
your changes. In these instances you must refresh YourSite Explorer after the other user’s changes
have been saved and synchronized. You may then re-enter and save your changes. We recommend
you save changes to IVR Routing devices frequently, in order to avoid losing work.
Table 51 lists the IVR Routing synchronization states and the corresponding messages in each
device’s IVR Sync Status column. The same information displays in the device page header.
NOTE:
l

l
l
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If synchronization does not complete in one minute's time, you receive the synchronization
failure message as listed in Table 51.
Only media servers running IVR Routing display the IVR Sync Status column.
Prompts show synchronization status only when you add a new custom .wav file to an
existing prompt. Otherwise, the synchronization status on the Prompts page displays as
'Sync Completed'.

Synchronizing IVR Routing Servers

Table 51: Synchronization state and IVR Sync Status messages by device
SYNCHRONIZATION STATE
No synchronization taking
place

Currently synchronizing

All servers are synchronized

Synchronization failure

IVR Routing Service disruption

IVR SYNC STATUS MESSAGE

DEVICE

Sync Completed

All

Syncing IVRs X/Y Completed

Workflow, prompt,
subroutine

Synching <device name>

Server

Sync Completed

All

Failed <device name>

Server

'Sync Incomplete. See the Server page
to view the Status of Remove Servers.

Workflow, prompt,
subroutine

IVR services are stopped or the server is
offline

All
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WORKFORCE SCHEDULING
Workforce Scheduling is an optional application that works in conjunction with Contact Center
Management and the Mitel 3300 ICP. You configure employees in YourSite Explorer and schedule
them with Workforce Scheduling. Using historical data from Contact Center Management,
Workforce Scheduling forecasts the number of employees required to meet your contact center's
Service Level objectives. Using Workforce Scheduling, you can build schedules with forecast
information. If you enter employee payroll information in YourSite Explorer, Workforce Scheduling
can use this information for scheduling and budgeting purposes.
To install Workforce Scheduling, select the Workforce Scheduling option in Client Role Selector.
NOTE: In order to access Workforce Scheduling, you require the May manage Workforce
Scheduling security role. For more information on configuring security roles, see "Creating and
applying security roles" on page 190.
Using Workforce Scheduling in conjunction with Contact Center Management, you can
l

Customize schedules

l

Forecast scheduling requirements

l

Match an employee’s skills to those skills required for jobs in each schedule

l

View the distribution of employees across each schedule

l

Print schedule reports

There are two optional applications that work in conjunction with Workforce Scheduling: Schedule
Adherence and Employee Portal. For more information on these applications, see "Schedule
Adherence" on page 722 and "Employee Portal" on page 727.

BEFORE INSTALLING WORKFORCE SCHEDULING
Before you install and run Workforce Scheduling or view Schedule Adherence monitors in Contact
Center Client, you must enable remote SQL Server connections and grant SQL Server permissions
to Workforce Scheduling users.

ENABLING REMOTE SQL SERVER CONNECTIONS
To enable remote SQL Server 2008, remote SQL Server 2012, or remote SQL Server 2014
connections
1. On the Enterprise Server, in the Microsoft SQL Server 2008, the Microsoft SQL Server
2012 or the Microsoft SQL Server 2014 program folder, navigate to the SQL Server
Configuration Manager.
2. Under SQL Server Configuration Manager (Local), expand SQL Server Network Configuration
and click Protocols for <SQL Server instance name>.
3. In the right pane, right-click Named Pipes and click Enable.
4. In the right pane, right-click TCP/IP and click Enable.
5. Under SQL Server Configuration Manager (Local), click SQL Server Services.
6. In the right pane, right-click SQL Server (<SQL Server instance name>) and click Restart.
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7. In the right pane, right-click SQL Server Browser and click Properties.
8. Click the Service tab and after Start Mode, select Automatic.
9. Click Apply.
10. Click OK.
11. In the right pane, right-click SQL Server Browser and click Start.

GRANTING SQL SERVER PERMISSIONS
NOTE:
l

l

If your enterprise uses remote SQL and SQL Authentication, you can skip this step, because
the required credentials are provided during the configuration of Contact Center Management
If you do not currently have a copy of Microsoft SQL Server Management Studio installed, you
can download a free copy from Microsoft: http://www.microsoft.com/enca/download/default.aspx.

To grant SQL Server 2008, SQL Server 2012, or SQL Server 2014 permissions
1. In Windows, open the Microsoft SQL Server 2008, Microsoft SQL Server 2012, or
Microsoft SQL Server 2014 program folder and go to SQL Server Management Studio.
2. Connect to the desired SQL Server.
3. In the left pane, expand the Security tree and select Logins.
4. If the desired user is not listed, right-click Logins and select New Login.
5. After Login name, type the name of the new user.
Optionally, click Search to search for the user name.
6. If you have users configured in groups on your domain, you can optionally add the group to add
all users at once.
If you want to grant SQL Server permissions to a domain group, you must click Search, click
Object Types, and select the Groups check box.
7. Click User Mapping.
8. Under Users Mapped to this login, select CCMData.
9. Click OK.
10. Under Database role membership for: CCMData, select db_owner.
11. Click OK.
12. Repeat steps 5-11 for all Workforce Scheduling users.

INSTALLING WORKFORCE SCHEDULING
NOTE: Workforce Scheduling can only be installed on client computers that are part of the same
Windows domain as the SQL Server.
To use Workforce Scheduling, you must first install Contact Center Management Version 7.1
Workforce Scheduling is installed during the installation of Contact Center Management Version 7.1.
To install Workforce Scheduling on a client computer, you must install Client Component Pack. You
then install Workforce Scheduling and can then begin configuring scheduling options.
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To install Workforce Scheduling
1. In Contact Center Management, click Help=>Software downloads/Installations.
2. To install Client Component Pack, click Client Component Pack.
3. Follow the steps in the wizard to install Client Component Pack.
4. On a client computer, open the Client Role Selector.
5. Using a Supervisor or Power User role, install Workforce Scheduling.

USING WORKFORCE SCHEDULING
Before you start using Workforce Scheduling read the following sections on how to
l

View the Workforce Scheduling user interface

l

Understand forecasting concepts

l

Understand the Workforce Scheduling process

VIEWING THE WORKFORCE SCHEDULING USER INTERFACE
Figure 145 displays scheduling information, such as the employees who are scheduled, employee
shift start and end times, the time interval shift totals, and the shift details for each employee.
NOTE: The Scheduling and Forecasting buttons in the Tools>Administration window are used to
toggle between these two views.
The Workforce Scheduling user interface is comprised of the following panes:
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l

People pane

l

Time bar pane

l

Totals pane

l

Schedule details pane

Using Workforce Scheduling

Figure 145: Scheduler window

People pane
The people pane is located in the upper-left portion of the scheduler window. The people pane lists
the employees included in the schedules you are viewing. (See Figure 146.)

Figure 146: People pane

Time bar pane
The time bar pane is located in the upper-right portion of the scheduler window. The time bar pane
displays a time bar for each scheduled employee. Time bars display the shifts, breaks, jobs, time
off, and unavailable periods for employees listed in the people pane. You can view the time bar pane
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in the following time intervals: 6 hours, 12 hours, 1 day, 2 days, 1 week, 2 weeks, and 1 month. (See
Figure 147.)
You can view previous or upcoming dates using the horizontal scroll bar under the time bar pane. If
you reach the end of the month and want to view dates for the next month, you can click the arrow on
the scroll bar to load the schedule for the next month (as indicated by the red square in the following
image).

Figure 147: Time bar pane

Totals pane
The totals pane appears when you select event totals to view. The totals pane is located in the
center of the scheduler window. Each value represents the total number of employees scheduled for
an event. (See Figure 148.)

Figure 148: Totals pane
You can view the following event totals:
Forecasted
The Forecasted total displays after you apply a forecast to the schedule. This total represents the
forecasted number of employees required to handle contact requests and meet the Service Level
objectives you specify. You can optionally adjust the Forecasted total in the totals pane. See
"Modifying forecast totals in the event totals pane" on page 716.
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Scheduled
The Scheduled total represents the number of employees scheduled for the time you are viewing.
On break
The On break total represents the number of employees scheduled for a break at a specific time.
On ACD Job
The On ACD Job total represents the number of employees scheduled to perform ACD work.
On Non ACD Job
The On Non ACD Job total represents the number of employees scheduled to perform non-ACD
work.
At work
The At work total represents the number of employees scheduled to handle contact requests.
Over/Under
The Over/Under total represents the difference between the number of employees at work compared
to the number of employees forecasted. A value of 4 means 4 additional employees are working
compared to the forecasted requirement. A value of (4) means 4 fewer employees are working
compared to the forecasted requirement. When you book annual leave for employees, you can
preview the result on shift coverage by using the over / under function, before updating changes.
Overtime
The Overtime total represents the number of employees scheduled to perform overtime work.

Schedule details pane
The schedule details pane is located at the bottom of the scheduler window. It displays details on
scheduled employees. You can modify the start and end times of scheduled events in the schedule
details pane. For example, you can adjust the length of a scheduled break. See "Modifying event
times and notes in the schedule details pane" on page 716. (See Figure 149.)

Figure 149: Schedule details pane
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You can sort the information in the schedule details pane by organizing the headings. The schedule
details column headings are as follows:
l

Employee name—the employee to which the specified time event is scheduled

l

Schedule—the schedule to which the specified time event is scheduled

l

Event type—the events to which the specified time event is scheduled

l

l

l

Start date—the start date of each scheduled event. You can modify this parameter in the
schedule details pane. Changes are immediately reflected in the time bar pane
Start time—the start time of each scheduled event. You can modify this parameter in the
schedule details pane. Changes are immediately reflected in the time bar pane
End time—the end time of each scheduled event. You can modify this parameter in the
schedule details pane. Changes are immediately reflected in the time bar pane

l

Paid hours—the total number of paid hours for the scheduled shift

l

Budget—the total cost of the scheduled shift

l

Notes—the notes on scheduled events you enter in this field

UNDERSTANDING FORECASTING CONCEPTS
Workforce Scheduling assists you in scheduling employees for work and holiday periods. It offers an
integrated forecasting component that uses historical data to partially automate the scheduling
process. Scheduling is not entirely automated. You may have to modify employee schedules and
enter shift and employee variables manually after creating a schedule based on forecasted data.
You schedule employees so the number of incoming calls at any given time typically exceeds the
number of employees currently available. This ensures callers experience a slight delay before
employees answer their calls. The expected number of incoming calls forecasted for the time of day
and day of the week influence scheduling decisions when trying to find the right balance between call
volume and available staff.
For detailed information on forecasting variables and how to improve forecasting accuracy, see
"Step #3 Forecast the Call Load" on page 33.
For detailed information on Service Level variables and how to calculate the Service Level Percent,
see "Understanding the Service Level" on page 26.

UNDERSTANDING THE WORKFORCE SCHEDULING
PROCESS
The flowchart in Figure 150 provides an overview of how to schedule employees with Workforce
Scheduling, such as adding employees to a schedule, configuring schedule parameters, and building
a schedule.
You configure employees, agent IDs, agent groups, queues, queue groups, overtime types, time off
types, holidays, and skills in YourSite Explorer. After you configure these devices, you must decide
if you will use forecasted data to build your schedules. When you build a schedule in Workforce
Scheduling using forecasted data, we recommend you associate the schedule with the queue group
you will use to perform the forecast. You must ensure that the employees you want to schedule are
associated with the queue group you associate to the schedule. In YourSite Explorer, you must
associate the agents with agent groups, associate the agent groups to queues, and associate the
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queues to the queue group associated with the schedule. This is recommended so employees in the
schedule align with forecasted data. You can optionally associate a schedule to a queue group with
different employees, which can be useful for scheduling a new group of employees based on the
forecasted data of other employees.
As soon as you start Workforce Scheduling, you can begin creating your schedules. After you log in,
you are asked to create or select a schedule. You create a schedule by assigning it a name. If you
are using a forecast to build the schedule, you associate the schedule with a queue group.
After you create the schedule, you configure schedule parameters, such as shifts, breaks, jobs, and
scheduling preferences/options for each employee.
You can automate the schedule building process with the Schedule Builder tool. It helps you quickly
build a schedule, with or without a forecast. If you build schedules using forecasted data, we
recommend you use Schedule Builder. Alternately, you can build a schedule manually. This involves
inserting or removing events (shifts, breaks, jobs, time off, unavailable periods) and making events
recur. You can manually build a schedule based on forecast totals in the Totals pane. After you build
a schedule using Schedule Builder, you may need to make a few adjustments.
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Figure 150: Scheduling with Workforce Scheduling

687

Workforce Scheduling and your contact center

WORKFORCE SCHEDULING AND YOUR CONTACT
CENTER
Using Workforce Scheduling, you can schedule your employees to best suit your contact center
needs. You can
l

Customize schedules for your contact center groups

l

Forecast scheduling requirements

l

Match employee skills to the skills required for each schedule

l

View the distribution of employees across schedules

l

Print schedule reports

For information on scheduling considerations, and how to calculate the Shrinkage Factor and
optimize scheduling, see "Step #5 Schedule agents" on page 38.
Using Workforce Scheduling, you can create schedules for your contact center using a variety of
options. Depending on your contact center, some options may be more suitable than others. To help
your company use Workforce Scheduling most effectively, we have created configuration scenarios
that describe how to implement Workforce Scheduling, based on the type of scheduling used in your
contact center.
Each Workforce Scheduling configuration scenario provides a description of the scheduling method
and an example of contact centers that typically use that method. Each scenario also provides some
tips on how to configure Workforce Scheduling for each style of scheduling. The scenarios include
the following scheduling configurations:
l

Assigned shift

l

Availability

l

Rotational

l

Forecast

ASSIGNED SHIFT-BASED SCHEDULING CONFIGURATION
SCENARIO
The assigned shift scheduling method uses fixed shifts staffed by employees who are permanently
assigned to specific shifts. Contact centers that use assigned shift scheduling have consistent call
volumes. Employees are primarily full-time staff and are guaranteed a specific number of hours of
employment per week. Typically, you plan a schedule three to six months in advance with assigned
shift scheduling.
Contact centers ideal for assigned shift scheduling
Assigned shift scheduling is best suited to contact centers that have a steady and predictable call
volume, such as a contact center that runs a conventional nine to five operation. Examples of
contact centers that use assigned shift scheduling include banks and government offices.
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To configure Workforce Scheduling for an assigned shift scheduling environment
l

Create fixed shifts

l

Use shift names that describe a shift's purpose, such as '9 to 5 shift' or '1st shift'

l

Use mass recurrence to repeat scheduled events for multiple weeks

l

Configure employee hours using shift assignment by day of week

AVAILABILITY-BASED SCHEDULING CONFIGURATION
SCENARIO
The availability scheduling method uses fixed shifts, but unlike assigned shift scheduling, the
employees that work a given shift are not permanently attached to that shift. Contact centers that
use availability scheduling fill shifts using a pool of employees.
A contact center supervisor sets staff availability based on day of week and time of day. When
staffing a shift, the supervisor can assign any employee who is listed as available for that date and
time to the shift. Typically, you plan a schedule two to four weeks in advance when you use
availability scheduling.
Contact centers ideal for availability scheduling
Availability scheduling is best suited to contact centers driven by shifts, such as hotels or
companies that focus on catalog sales. These contact centers have a specific number of shifts that
can be filled by any qualified employees who are available. This type of schedule is frequently used
with contact centers that operate 24/7.
To configure Workforce Scheduling for an availability scheduling environment
l

Primarily use fixed shifts, but do not assign employees to specific shifts

l

Assign employees all of the possible shifts they can work

l

Set employee availability by day of week and time of day

l

Use filters to assign the best employee available for a shift, based on skill set, seniority, or
personal priority number

ROTATIONAL-BASED SCHEDULING CONFIGURATION
SCENARIO
The rotational scheduling method consists of two or more unique schedules that recur at defined
intervals. For example, if a contact center rotates four schedules, the week one schedule repeats in
week five, week nine, and so on. The rotational scheduling method enables contact center
schedules to be consistent in the long-term, while allowing shifts to vary from week to week.
Contact centers ideal for rotational scheduling
Rotational scheduling is best suited to contact centers that require specific employees to cover
unique periods of time, such as medical clinics that are open on weekends. If each contact center
employee is required to work one weekend a month, a rotational schedule can ensure an even
distribution of weekend work for each employee.
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To configure Workforce Scheduling for a rotational scheduling environment
l

l
l

l

Primarily use assigned shifts with defined employees. The staff changes from one schedule
rotation to the next ensure fair coverage on nights, weekends, and holidays
Recur the shifts multiple times based on the number of rotations
Manually track and adjust which employees are assigned to each rotation; Workforce
Scheduling does not create a balanced schedule so you will need to make changes if you
want to ensure the schedule is fair
Optionally use rotational scheduling in conjunction with other schedule types. For example,
create a schedule that uses the assigned shift method to cover Monday to Friday shifts and a
second schedule that uses the rotational shift method to cover shifts such as weekends or
holidays

FORECAST-BASED SCHEDULING CONFIGURATION
SCENARIO
The forecast scheduling method references historical data to create schedules. Contact centers that
use forecast scheduling have call volumes that can change considerably over relatively short
periods of time, resulting in inconsistent scheduling.
Forecast scheduling provides more flexibility than other scheduling methods since shifts are not
defined. A contact center that uses forecast scheduling does not have a fixed staff or fixed hours, as
both change based on the expected call volume. Typically, you plan a schedule one to two weeks in
advance with forecast scheduling.
Contact centers ideal for forecast scheduling
Forecast scheduling is best suited to contact centers driven by call volume, such as companies that
focus on sales campaigns, promotions, or seasonal sales.
To configure Workforce Scheduling for a forecast scheduling environment
l

l

l

l

l

Generate historical data specific to the type of event you are scheduling (for example, to
create a schedule for a winter sales campaign, use historical data from a previous winter
campaign)
Create shifts with flexible start and end times to provide Schedule Builder with the greatest
number of options when populating the shifts with employees
Remember that shift variables, such as start/end times and breaks, will vary for employees on
a day-to-day basis
Due to the variety of shift start and end times, create breaks based on the Time to qualify
variable
Do not configure availability or shift assignment

690

Contact Center Solutions User Guide

BEFORE YOU START SCHEDULING
You use Workforce Scheduling in conjunction with YourSite Explorer. Before you can schedule
employees with Workforce Scheduling, you must add and configure them in YourSite Explorer.
To configure employee information for scheduling
1. Select the employee or employees you want to configure.
2. Specify the employee role.
See "Configuring employee roles" on page 169.
3. Specify employee work hours.
See "Configuring employee work hours" on page 170.
4. Specify employment status.
See "Configuring employment status" on page 170.
5. Specify employee payroll information.
See "Configuring employee payroll information" on page 170.
6. Assign shifts to the employee.
See "Assigning shifts to employees" on page 703.
7. Specify employee availability.
See "Configuring employee availability" on page 171.
8. Specify time off information
See "Configuring employee time off" on page 171.
9. Specify employee skills
See "Configuring employee skills" on page 172.
Before you can make schedules in Workforce Scheduling, you must configure the following
scheduling options in YourSite Explorer
1. Holidays
See "Configuring holidays" on page 173.
2. Overtime types
See "Configuring overtime types" on page 173.
3. Time off types
See "Configuring time off types" on page 174.
4. Skills
See "Configuring skills" on page 175.

SELECTING A SCHEDULING METHOD
You can build schedules in Workforce Scheduling:
l

Using a forecast

l

Manually

The setup you require depends on the scheduling method you choose. If you incorporate forecast
data when you build a schedule, you must build the schedule using Schedule Builder.
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Scheduling using forecast data
When you use forecast data to build a schedule, you can apply historical data from any queue or
queue group to the schedule. It is recommended to use historical data from the queue group with
which the schedule is associated. Forecast data is simply the number of required agents. It can be
used in schedules which are not associated with a queue or queue group.
Before you build a schedule using a forecast, as a best practice, we recommend you associate your
schedule with a queue group. You should also ensure that the employees to be scheduled are
associated with this queue group.
In YourSite Explorer, you
1. Associate the agent IDs with an agent group.
See "Managing agent group membership, presence, and skill level" on page 139.
2. Associate the agent group with a queue.
See "Configuring voice queue membership" on page 145.
3. Associate the queue with the queue group (that you will associate with the schedule).
See "Adding queue groups" on page 155.

Scheduling manually
You have the most flexibility when you build a schedule manually. However, this can be time
consuming if you must schedule a large number of employees or if you must create a schedule
covering a long time period where shift assignments do not recur. You can also use manual
scheduling to tweak schedules you build with Schedule Builder. See "Creating and adjusting
schedules manually" on page 713.

SCHEDULE SETUP AND CUSTOMIZATION
NOTE: In order to access Workforce Scheduling, you require the May manage Workforce
Scheduling security role. For more information on configuring security roles, see "Creating and
applying security roles" on page 190.
In order to build a schedule in Workforce Scheduling, whether you build your schedule with
forecasting or you build it manually, you must perform the following tasks to set up and customize
your schedule:
1. Start YourSite Explorer.
2. Configure employees, overtime types, time off types, holidays, and skills.
3. Start Workforce Scheduling.
4. Configure schedule options.
5. Configure shifts, breaks, and jobs.
6. Assign shifts to schedules.
7. Assign shifts to employees.
8. Specify scheduling preferences/options for each employee in the schedule.
9. Specify schedule warnings.
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STARTING WORKFORCE SCHEDULING ON A CLIENT
COMPUTER
NOTE: Launching client-side applications from the task bar causes them to bypass the Updater
Service process. To ensure successful updates from the Enterprise Server, after an upgrade close
all client-side applications for 15 minutes or reopen them from the Start menu/Start screen
To log on to Workforce Scheduling
1. Open Workforce Scheduling.
The Login window appears.
2. If prompted, type your user name and password and verify the Enterprise Server IP address
3. Optionally, select the Remember my credentials check box.
4. Click Login.
The first time you log on, or if you have not created any schedules, the scheduler window
appears. See "Configuring schedule options" on page 693.
Otherwise, if schedules exist, the Load schedule window appears.
See "Loading schedules" on page 713.

CONFIGURING SCHEDULE OPTIONS
NOTE:
l

l

If you associate a schedule with a queue group, only those employees included in the
selected queue group can be configured in the schedule. (Agents are members of agent
groups, which are associated with queues that are members of queue groups.)
If you do not associate a schedule with a queue group, you can schedule any employee
whose profile enables you to schedule them in Workforce Scheduling. See "Adding
employees" on page 121.

Before you can build a schedule, either manually or using Schedule Builder, you must create a new
schedule.
On the New Schedule window, you must:
l

Name the schedule

l

Associate the schedule with a queue or queue group (optional)

l

Add employees to the schedule

l

Configure business hours for the schedule

l

Activate/Deactivate the schedule

You can create new schedules and configure all Workforce Scheduling options using the Schedule
wizard. Optionally, use the Schedule tool to add, delete, rename, and activate/deactivate schedules.
Within the Schedule configuration window, you can click Apply at any time to apply changes to the
schedule without closing the Schedule configuration window.

693

Schedule setup and customization

Configuring scheduling options using the Schedule wizard
You can create new schedules and configure all Workforce Scheduling options using the Schedule
wizard.
To configure scheduling options using the Schedule wizard
1. Click the Configuration tab.
2. In the Schedules group, click Schedule wizard.
3. Follow the steps in the Schedule wizard to configure schedules, business hours, employees,
fixed/variable shifts, fixed/variable breaks and jobs, and fixed/variable shift assignments.
4. Click Finish.

Creating schedules
To create a schedule
1. On the Application menu or ribbon, click New schedule.
2. After Schedule name, type a name for the schedule.
3. Under Employee association, select either All employees, Employees associated with
this queue group only, or Employees associated with this queue only.
l

l

If you select Employees associated with this queue group, select a queue group from
the list.
If you select Employees associated with this queue, select a queue from the list.

4. If this schedule will be an active schedule, select the This schedule is active check box.
Otherwise, select the This schedule is used for planning purposes only check box.
5. Click OK.
6. Select the check boxes of the employees to add to the schedule.
7. Click OK.

Adding employees to schedules
Schedules that contain fewer than 100 employees are easiest to manage. Each employee should
belong to one active schedule only. However, if employees belong to more than one schedule, you
can still view the shifts for which they are scheduled.
To add an employee to a schedule
1. Click the Configuration tab.
2. In the Schedules group, click Select employees.
3. After Schedule, select a schedule.
4. If you want to group employees in the list by supervisor, select the Group by supervisor
check box.
5. Select the check boxes of the employees to add to the schedule.
6. Click OK.
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Configuring business hours for schedules
You can specify different business hours for each schedule. By default, you are warned if you try to
schedule shifts outside business hours.
To configure the business hours of a schedule
1. Click the Configuration tab.
2. In the Schedules group, click Schedule.
3. In the left pane, select Schedules.
4. Under Schedules, select the schedule to modify.
5. After First day of the schedule week, specify the day that the schedule will begin.
6. After Annual calendar start date, specify the date the calendar year begins.
The information in this field is used to calculate annual minimum and maximum hours for
employees. January 1st is the default date.
7. Specify business hours for the schedule.
l

If you want to schedule employees 24 hours a day, seven days a week, under Business
hours, click Open 24/7.

l

After Open, select the check boxes of the days of the week to schedule.

l

After From, specify the start times for each day of the week to schedule.

l

After To, specify the end times for each day of the week to schedule.

8. Click OK.

Renaming schedules
You can rename a schedule without losing any information associated with the schedule.
To rename a schedule
1. Click the Configuration tab.
2. In the Schedules group, click Schedule.
3. Under Schedules, select the schedule to rename.
4. Click Rename.
5. After Name, type a new name for the schedule.
6. Click Rename.
7. Click OK.

Deleting schedules
CAUTION: Deleting a schedule deletes all of the information associated with that schedule. This
cannot be undone.
To delete a schedule
1. Click the Configuration tab.
2. In the Schedules group, click Schedule.
3. Under Schedules, select the schedule to delete.
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4. Click Delete.
5. Click Yes.
6. Click OK.

Activating / De-activating schedules
You can activate or deactivate a schedule at any time. Deactivating schedules is useful for
performing 'what-if' scenarios, for seasonal schedules, and for retaining schedules to be used at a
later time.
To activate or deactivate a schedule
1. Click File=>Activate.
The Activate / Deactivate Schedule dialog box opens.
2. Select the schedule that you want to activate / deactivate.
You can load multiple active schedules. However, if you load an inactive schedule, all other
schedules close.
3. Click Activate to activate an inactive schedule or Deactivate to deactivate an active
schedule.
4. Click Close.

CONFIGURING SHIFTS
A shift represents work hours on a given day for an employee. You can assign shifts to specific
employees for any day of the week. You can create several shifts for one or more schedules. There
are two types of shifts: fixed shifts and variable shifts. Fixed shifts have a fixed start time and
duration. Variable shifts are based on the following shift variables:
l

Typical hours—the number of work hours for the shift

l

Minimum hours—the minimum number of hours for the shift

l

Maximum hours—the maximum number of hours for the shift

l

Minimum start—the time of day after which the shift must start

l

Maximum start—the time of day by which the shift must start

l

Color—the color in which the shift appears in the time bar pane

You configure the following shift options using the Schedule tool:
l

Add fixed shifts

l

Add variable shifts

l

Rename shifts

l

Delete shifts

Adding fixed shifts
To add a fixed shift
1. Click the Configuration tab.
2. In the Schedules group, click Schedule.
3. In the left pane, click Shifts.
4. In the right pane, click the Fixed Shifts tab.
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5. In the right pane, click Add.
6. After Name, type a name for the fixed shift.
7. Click Create.
8. Under Start time, type the start time of the fixed shift.
9. Under Duration, type the duration of the fixed shift.
10. Under Color, select a color for the fixed shift.
11. Click OK.

Adding variable shifts
To add a variable shift
1. Click the Configuration tab.
2. In the Schedules group, click Schedule.
3. In the left pane, click Shifts.
4. In the right pane, click the Variable Shifts tab.
5. In the right pane, click Add.
6. After Name, type a name for the variable shift.
7. Click Create.
8. Under Minimum hours, type the minimum number of hours in a day you can schedule the
shift.
9. Under Typical hours, type the typical number of hours in a day you can schedule the shift.
10. Under Maximum hours, type the maximum number of hours in a day you can schedule the
shift.
11. Under Minimum start, type the time of day after which the shift must start.
12. Under Maximum start, type the time of day by which the shift must start.
13. Under Color, select a color for the variable shift.
14. Click OK.

Renaming shifts
You can rename fixed/variable shifts without losing any information associated with the shifts.
To rename a shift
1. Click the Configuration tab.
2. In the Schedules group, click Schedule.
3. Click the Shifts tab.
4. If you want to rename a fixed shift, click the Fixed shifts tab. Otherwise, to rename a variable
shift, click the Variable shifts tab.
5. Under Name, click the name of the shift to rename.
6. Type a new name for the shift.
7. Click OK.
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Deleting shifts
CAUTION: Deleting a shift deletes all of the instances of that shift, including those inserted in
schedules.
To delete a shift
1. Click the Configuration tab.
2. In the Schedules group, click Schedule.
3. Click the Shifts tab.
4. If you want to delete a fixed shift, click the Fixed shifts tab. Otherwise, to delete a variable
shift, click the Variable shifts tab.
5. Under Name, select the shift to delete.
6. Click Delete.
7. Click Yes.

CONFIGURING BREAKS
You configure the following break options using the Schedule tool:
l

Add fixed breaks

l

Add variable breaks

l

Rename breaks

l

Delete breaks

Examples of common breaks are morning break, lunch, afternoon break, and dinner break.

Adding fixed breaks
To add a fixed break
1. Click the Configuration tab.
2. In the Schedules group, click Schedule.
3. In the left pane, click Breaks.
4. In the right pane, click the Fixed Breaks tab.
5. Click Add.
6. After Name, type a name for the break.
7. Click Create.
8. If the break is a paid break, enable the check box under Is paid.
9. Under Start time, type the time at which the break must start.
10. Under Duration, type the amount of time allotted for the break.
11. Under Color, select a color for the break.
12. Click Ok.
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Adding variable breaks
To add a variable break
1. Click the Configuration tab.
2. In the Schedules group, click Schedule.
3. In the left pane, click Breaks.
4. In the right pane, click the Variable Breaks tab.
5. Click Add.
6. After Name, type a name for the variable break.
7. Click Create.
8. Under Duration, type the amount of time allotted for the break.
9. If the break is a paid break, select the check box under Paid.
10. Under Time to qualify, type the minimum duration of a shift before you can schedule the
break.
11. Under Must start time, type the amount of time from the beginning of the shift that employees
must work before they are entitled to the break.
12. Under Must end time, type the amount of time from the beginning of the shift by which
employees must complete the break.
13. Under Minimum time before end of shift, type the amount of time before the end of the shift
that the break must end.
14. Under Color, select a color for the shift.
15. Click OK.

Renaming breaks
You can rename a break without losing any information associated with the break.
To rename a break
1. Click the Configuration tab.
2. In the Schedules group, click Schedule.
3. In the left pane, click Breaks.
4. If you want to rename a fixed break, in the left pane, click the Fixed Breaks tab. Otherwise, to
rename a variable break, click the Variable Breaks tab.
5. Under Name, click the name of the break to rename.
6. Type a new name for the break.
7. Click OK.
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Deleting breaks
CAUTION: Deleting a break deletes all of the instances of the break, including those inserted in
schedules.
To delete a break
1. Click the Configuration tab.
2. In the Schedules group, click Schedule.
3. If you want to delete a fixed break, in the left pane, click Fixed shifts. Otherwise, to delete a
variable break, click Variable shifts.
4. Click the Breaks tab.
5. Under Name, select the name of the break to delete.
6. Click Delete.
7. Click Yes.
8. Click OK.

CONFIGURING JOBS
Use jobs in a schedule to differentiate the non-ACD tasks that employees perform. You create jobs
for a specific shift. If the job requires a specific set of skills, you can associate skills to jobs. After
you associate skills to jobs, you can compare the skill (and skill level) of the employees to the skill
required to perform a job. This will ensure the employees you schedule have the appropriate skills for
their assigned jobs.
You configure the following job options using the Schedule tool:
l

Add fixed jobs

l

Add variable jobs

l

Rename jobs

l

Delete jobs

Adding fixed jobs
To add a job for a fixed shift
1. Click the Configuration tab.
2. In the Schedules group, click Schedule.
3. In the left pane, click Jobs.
4. In the right pane, click the Fixed Jobs tab.
5. Click Add.
6. After Name, type the name of the job.
7. Click Create.
8. If the job involves work on ACD calls, ensure the check box under Is ACD is selected.
9. Under Start time, type the time at which the job must start.
10. Under Duration, type the duration of the job.
11. Under Color, select a color for the job.
12. Click OK.
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Adding variable jobs
To add a job for a variable shift
1. Click the Configuration tab.
2. In the Schedules group, click Schedule.
3. In the left pane, click Jobs.
4. In the right pane, click the Variable Jobs tab.
5. Click Add.
6. After Name, type the name of the job.
7. Click Create.
8. If the job involves work on ACD calls, ensure the check box under Is ACD is selected.
9. Under Color, select a color for the job.
10. Click OK.

Renaming jobs
You can rename a job without losing any information associated with the job.
To rename a job
1. Click the Configuration tab.
2. In the Schedules group, click Schedule.
3. In the left pane, click Jobs.
4. If you want to rename a fixed job, click the Fixed Jobs. Otherwise, to rename a variable job,
click the Variable Jobs tab.
5. Under Name, click the name of the job to rename.
6. Type a new name for the job.
7. Click OK.

Deleting jobs
CAUTION: Deleting a job deletes all of the instances of the job, including where it is inserted in
schedules.
To delete a job
1. Click the Configuration tab.
2. In the Schedules group, click Schedule.
3. In the left pane, click Jobs.
4. If you want to delete a fixed job, click the Fixed Jobs. Otherwise, to delete a variable job,
click the Variable Jobs tab.
5. Under Name, select the name of the job to delete.
6. Click Delete.
7. Click Yes.
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Adding breaks or jobs to shifts
To add a break or a job to a shift
1. Click the Configuration tab.
2. In the Schedules group, click Schedule.
3. Click Assignments.
4. In the right pane, click the Breaks and Jobs tab.
5. Under Shifts, select the shift for which you will add shifts to.
6. Under Breaks, select the break to add to a shift.
7. Click > to assign the break to the shift.
8. Under Jobs, select the job to add to a shift.
9. Click > to assign the job to the shift.
10. Click OK.

Removing breaks and jobs from shifts
To remove a break or a job from a shift
1. Click the Configuration tab.
2. In the Schedules group, click Schedule.
3. Click Assignments.
4. In the right pane, click the Breaks and Jobs tab.
5. Under Shifts, select the shift for which you will remove breaks/jobs from.
6. Under Breaks, select the break to remove from the shift.
7. Click < to remove the break from the shift.
8. Under Jobs, select the job to remove from the shift.
9. Click < to remove the job from the shift.
10. Repeat steps 5-9 to remove additional breaks and/or jobs from shifts.
11. Click OK.

ASSIGNING SHIFTS TO SCHEDULES
NOTE: Schedule Builder uses the shifts you assign, combined with the employees’ availability and
shift assignment, to schedule shifts (or variations of them).
To assign shifts to schedules
1. Click the Configuration tab.
2. In the Schedules group, click Schedule.
3. In the left pane, click Assignments.
4. In the right pane, click the Shifts tab.
5. Under Schedules, select the schedule to which you will add shifts.
6. Under Fixed Shifts, select the fixed shift to add to the schedule.
7. Click > to assign the shift to the schedule.
8. Under Variable Shifts, select the variable shift to add to the schedule.
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9. Click > to assign the shift to the schedule.
10. Repeat steps 6-9 for each shift you want to add to a schedule.
11. Click OK.

ASSIGNING SHIFTS TO EMPLOYEES
To assign a shift to an employee
1. Click the Configuration tab.
2. In the Schedules group, click Configure employees.
3. In the left pane, under Schedules, select the schedule containing the employee(s) to which
you will assign shifts.
4. Under Employees, select the employee to which you will add shifts.
5. Under Shift Assignment, select the check boxes of the shifts that will be available to this
employee.
6. Repeat steps 4-6 for each employee to which you will assign shifts.
7. Click OK.

CONFIGURING EVENT DISPLAY PREFERENCES
To make events easy to identify at a glance, you can specify how you want to display the scheduled
events.
You can specify the following event display preferences:
l

l

l

l

l

l

l
l

l
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Time bar content display—provides descriptions, notes, or icons for scheduled events in
the time bar pane
Smallest scheduling interval—the smallest increment with which you insert events into the
time bar pane
Default shift color—the color for all of the shifts in the time bar pane. To override the default
shift color, see "Configuring shifts" on page 696.
Default break color—the color for all of the breaks in the time bar pane. To override the
default break color, see "Renaming breaks" on page 699.
Default job color—the color for all of the jobs in the time bar pane. To override the default job
color, see "Configuring jobs" on page 700.
Default time off color—the color for all of the time off types in the time bar pane. To override
the default job color, see "Configuring time off types" on page 174.
Unavailable color—the color for unavailable periods in the time bar pane
Tool tip display—provides event information in tool tips on the time bar pane. The tool tip
appears as a series of brackets depending on the information criteria you select
Time display—the time format of the time bar pane. For example, 3 o’clock in the afternoon
appears as 3 P.M. if you select 12 Hours, or 15 if you select 24 Hours
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Configuring the time bar display
You can select from the following three time bar display options:
l

Icon—refers to the icons of the scheduled shifts, time off events, and unavailable periods in
the time bar pane

l

Type name—refers to the names of the scheduled jobs in the time bar pane

l

Type notes—refers to the notes of the scheduled jobs in the time bar pane

To specify how events display in the time bar
1. On the application menu, click Preferences.
2. Click the Display tab.
3. Under Time bar content, select the time bar content to display for Shifts, Jobs, Breaks, Time
off, and Unavailable periods.
4. Click OK to save and close the Preferences window.

Configuring the smallest scheduling time interval
By default, events are snapped to the time bar grid in 30 minute increments. However, you can
adjust the snap-to-grid interval to 5, 15, 30, or 60 minutes. Set the smallest scheduling time interval
to the minimum number of minutes you want to insert events into a schedule. For example, if you
select 15 minutes as the smallest scheduling interval, you cannot insert events for an employee in
increments smaller than 15 minutes.
The default scheduling interval is 15 minutes, which we recommend, as changing this to a smaller
interval will increase the amount of time it takes for Schedule Builder to build schedules.
To configure the smallest scheduling time interval
1. On the application menu, click Preferences.
2. Click the General tab.
3. Under Scheduling preferences, after Smallest scheduling interval, select the snap-to-grid
time interval.
4. If you want to prevent the user from manually making any change that would trigger a warning,
select the Warnings are hard limits for the user check box.
5. Click OK to save and close the Preferences window.

Preventing users from manually making changes that trigger warnings
You can configure Workforce Scheduling to prevent users from making changes that trigger
warnings.
To prevent users from manually making changes that trigger warnings
1. On the application menu, click Preferences.
2. Click the General tab.
3. Select the Warnings are hard limits for the user check box.
4. Click OK to save and close the Preferences window.
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Configuring the default colors on the time bar
To configure the default colors used for events on the time bar
1. On the application menu, click Preferences.
2. Click the Display tab.
3. Under Default Timebar Colors, after Default Shift Color, select a color.
4. Repeat step 3 for Default Break Color, Default Job Color, Default Time Off Color, and
Unavailable Color.
5. Click OK to save and close Preferences window.

Configuring the time format
There are two time formats you can select from: the 24 hour international format or the 12 hour format
which uses A.M. and P.M. to indicate morning and afternoon. For example, 3 o’clock in the afternoon
appears as 15 if you select the 24 hour time format or 3 P.M. if you select the 12 hour time format.
To configure the time format
1. On the application menu, click Preferences.
2. Click the General tab.
3. After Hour Format, select either 12 Hours or 24 Hours.
4. Click OK.

Configuring tool tip display
You can specify the following information in tool tips for shifts, jobs, breaks, time off events,
unavailable periods, and shadow events:
l

Schedule name—provides the name of the schedule in which the event appears.

l

Is recurring—displays if the event recurs.

l

Type—provides the name of the event.

l

Type name—states if the event is a shift, job, break, time off event, unavailable period, or
shadow event.

l

Start/End Time—provides the start and end time of the event.

l

Event Notes—provides any notes from the detail grid for the event.

To configure the tool tip display
1. On the application menu, click Preferences.
2. Click the Display tab.
3. Under Tooltip Display, select the check boxes for the tool tips to display.
4. Click OK.
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CONFIGURING WARNINGS
Warnings notify you when you try to schedule events outside of your scheduling parameters.
You can set the following warnings:
l

Schedule warnings

l

Shift warnings

l

Break warnings

l

Job warnings

l

Overtime warnings

l

Time Off warnings

l

Employee scheduling warnings

l

Schedule Builder warnings

l

Employee selection warnings

To configure warnings
1. On the application menu, click Preferences.
2. Click the Warnings tab.
3. Ensure the check boxes of the warnings you want to configure are selected.
See Table 52.
4. Click OK.
Table 52: Warnings
WARNING

DESCRIPTION

Scheduling work on company
holidays

notifies you when events are scheduled on company
holidays

Scheduling work outside business
hours

notifies you when you try to schedule events outside of your
contact center’s business hours

When scheduling outside
employee's availability

notifies you when you try to schedule employees who are not
available at the specified time

Violates Length of Service
Qualifications

notifies you when an employee has worked fewer or more
months required to qualify for a specific type of time off

Exceeds accrued hours

notifies you when an employee is scheduled for more time
off hours than is available to that employee at that time

Exceeds Maximum Scheduling
Limit

notifies you when an employee is scheduled for more time
off hours than specified for that type of time off

Less than Minimum Scheduling
Limit

notifies you when an employee is scheduled for fewer time
off hours than specified for that type of time off
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Table 52: Warnings (continued)
WARNING
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DESCRIPTION

Employee does not have required
skills

notifies you when an employee does not have the required
skills for the job for which they are scheduled

Exceeds Daily Maximum Work
Hours

notifies you when an employee is scheduled for more hours
in a day than defined by the parameter for that shift

Below Daily Minimum Work Hours

notifies you when an employee is scheduled for fewer hours
in a day than defined by the parameter for that shift

Exceeds Weekly Maximum Work
Hours

notifies you when an employee is scheduled for more hours
in a week than defined by the parameter for that shift

Below Weekly Minimum Work
Hours

notifies you when an employee is scheduled for fewer hours
in a week than defined by the parameter for that shift

Exceeds Yearly Maximum Work
Hours

notifies when an employee is scheduled for more than the
annual maximum hours required

Below Yearly Minimum Work
Hours

notifies you when an employee is scheduled for less than the
annual minimum hours required

Start time outside of specified
range

notifies you when an employee’s shift is scheduled to start
before (minimum) or after (maximum) the parameters defined
for that shift

Within Minimum Time Between
Shifts

notifies you when an employee is scheduled to start another
shift too soon following the one previously completed

Below hours worked to qualify

notifies you when an employee is scheduled for a break
before working enough hours after the last break in that shift
to qualify for another break

Starting before earliest start time

notifies you when an employee is scheduled for the first
break in a shift before a break can be taken

Ending after latest end time

notifies you when an employee is scheduled for the last
break in a shift after a break can be taken

Removing an employee from a
schedule

notifies you when you attempt to delete an employee from
the schedule

Accepting a generated schedule

notifies you when you attempt to save a schedule you have
built

Scheduled shift will cause
overtime

notifies you when a shift qualifies an employee for overtime

Forecasting data for schedules

FORECASTING DATA FOR SCHEDULES
After setting up and customizing your schedule, if you are building a schedule from forecasted data,
you must run the Forecasting tool and export the forecast into your schedule before you can select
this option in the schedule builder or schedule builder wizard.
For information on the Forecasting tool, see "Forecasting tool" on page 327.
To access the Forecasting tool
1. Click Tools in the Workforce Scheduling ribbon.
2. In the Data Mining section, click Forecasting.

SCHEDULE CREATION
You can create and customize schedules in Workforce Scheduling using specific parameters that
suit the needs of your contact center. You can build schedules manually or with the Schedule Builder
tool. Schedule Builder automates the schedule building process. It uses pre-defined employee and
schedule options to create schedules. See "Schedule setup and customization" on page 692.
Schedule Builder helps you build a schedule with or without forecast data. If you are building a
schedule with forecast data, you must export the forecast data into your schedule before running the
Schedule Builder if you want to build a schedule with forecast data. See "Forecasting data for
schedules" on page 708.
You can also use manual scheduling to modify schedules you build with Schedule Builder. See
"Creating and adjusting schedules manually" on page 713.
NOTE: After you generate a schedule with Schedule Builder, you must accept or reject schedule
changes before you can generate another schedule.
Schedule Builder uses the following parameters to create a schedule automatically:
l

Date/time range

l

Shifts

l

Breaks

l

Forecast data

l

Business hours

l

Employees

l

Employee scheduling preferences

l

Scheduling options

l

Shift options

l

Schedule algorithm options
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BUILDING SCHEDULES WITH SCHEDULE BUILDER
NOTE: After you generate a schedule with Schedule Builder, you must accept or reject schedule
changes before you can generate another schedule.
To build a schedule with Schedule Builder
1. Click the Tools tab
2. In the Schedule Builder group, click Manual.
3. Under Schedule name, select a schedule.
4. Specify the scheduling parameters on each tab of the Schedule Builder tool.
5. Click Build.
A dialog box appears reminding you that changes to the schedule will not be committed to the
database until you click Accept Schedule.
6. Click OK.
The Accept Schedule and Reject Schedule buttons appear in the toolbar.
7. Verify the schedule.
8. Make any required modifications manually.
9. Click Accept schedule to save the new schedule.
NOTE:
l

l

After you click Accept Schedule, the schedule is live in the database and the Accept
Schedule button disappears. If you click Reject Schedule, the automatically generated
schedule and any manual modifications are deleted from the schedule. See "Creating
and adjusting schedules manually" on page 713.
If there are any conflicts, a dialog box appears stating the number of conflicts. You
cannot save a schedule with conflicts. Click Yes to delete the conflicts and accept the
schedule, or click No to adjust the schedule. When you have resolved the conflicts,
click Accept Schedule again to save the schedule.

Configuring the date and time range
To configure the date and time range for a schedule using Schedule Builder
1. In Schedule Builder, click the General tab.
2. Under Dates and times, on the Date / Time tab, select the date range of the schedule.
3. Under Time, select either Use business hours, 24/7, or Custom.
4. If you selected Custom in the previous step, select the time the schedule starts and ends
each day.
5. If you want to exclude dates from the schedule, click the Exclusion tab.
6. Hold down CTRL and then click the dates to exclude.

Scheduling shifts
To schedule shifts using Schedule Builder
1. In Schedule Builder, click the General tab.
2. Under Schedule/Optimize, select the Shifts check box.
3. Under Event selection, on the Shift selection tab, select the check boxes of the shifts to
add to the schedule.
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4. Click the Shift, Break, & Job options tab.
5. Under Shift options, specify how shifts will be distributed.
l

l

l

l

l

If you want to count existing shifts when determining the number of employees to be
scheduled, select the The Schedule Builder counts existing shifts when
determining the number of employees which must be scheduled check box.
If you want to optimize existing unlocked shifts, select the Allow Schedule Builder to
optimize existing unlocked shifts check box.
If you want to optimize existing locked shifts, select the Allow Schedule Builder to
optimize existing locked shifts check box.
If you want to schedule unassigned shifts for times when there are not enough
employees available to satisfy the scheduling requirements, select the Generate
unassigned shifts when not enough employees are available to satisfy the
schedule requirements check box.
If you want to ignore employee shifts assignments when building the schedule, select
the Ignore employee shift assignments check box.

Scheduling breaks
To schedule breaks using Schedule Builder
1. In Schedule Builder, click the General tab.
2. Under Schedule/Optimize, select the Breaks check box.
3. Under Event selection, on the Break selection tab, select the check boxes of the break
types to add to the schedule.
4. Click the Shift, Break, & Job options tab.
5. Under Schedule/Optimize breaks, select the check boxes of the shift types to apply breaks.

Scheduling jobs
To schedule jobs using Schedule Builder
1. In Schedule Builder, click the General tab.
2. Under Schedule/Optimize, select the Fixed Jobs check box.
3. Under Event selection, on the Fixed Job selection tab, select the check boxes of the job
types to add to the schedule.
4. Click the Shift, Break, & Job options tab.
5. Under Schedule fixed jobs on, select the check boxes of the job types to apply shifts.
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Generating schedules with forecast data
To build a schedule with forecast data using Schedule Builder
1. In Schedule Builder, click the General tab.
2. Under Schedule Builder method, after Method, select Forecasted data.
3. If you want fewer employees scheduled than are forecasted, move the slider towards
Underschedule.
4. If you want more employees scheduled than are forecasted, move the slider towards
Overschedule.
5. If you want to adjust the number of forecasted employees, next to Increase/decrease the
number of forecasted employees by, enter a number.

Generating schedules without forecast data
To build a schedule without forecast data using Schedule Builder
1. In Schedule Builder, click the General tab.
2. Under Schedule Builder method, after Method, select Explicit requirements.
3. After Number of employees to schedule, enter a number.
4. If you want fewer employees scheduled than are forecasted, move the slider towards
Underschedule.
5. If you want more employees scheduled than are forecasted, move the slider towards
Overschedule.

Generating schedules for your entire workforce
To build a schedule for your entire workforce using Schedule Builder, regardless of employee
availability
1. In Schedule Builder, click the General tab.
2. Under Schedule Builder method, after Method, select Entire workforce.
3. If you want to enable employee filtering, select the Enable employee filtering check box.

Selecting employees
To select the employees you want to schedule using Schedule Builder
1. In Schedule Builder, click the Employee filtering tab.
2. If you want to filter employees by agent group, under Agent group, select the check boxes of
the agent groups to schedule.
3. If you want to filter employees by their skills, under Skill, select the check boxes of the
required skills. Otherwise, skip to step 6.
4. Under the list of available skills, select an operand.
l

l

l
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If the employees must have a skill level greater or equal to the skill level required, select
>=.
If the employees must have a skill level lower or equal to the skill level required, select
<=.
If the employees must have a skill level exactly equal to the skill level required, select
=.
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5. If you want to filter employees by name, under Select employees with this name, type an
employee’s name.
6. If you want to select specific employees, under Selected employees, select the check boxes
of the employees to schedule.
7. Click the Employee sorting tab.
NOTE: You must configure the employee payroll information in order to select the seniority
and pay rate parameters.
8. If you want to prioritize how shifts are distributed to employees, select the Use employee
sorting check box, and select the criteria with which to sort employees.
9. If you want to assign or edit employee priority numbers, under Employee priority, select an
employee.
10. Under Priority, type a personal priority number.
11. Click the Overrides tab.
12. If you want to override employee work hour preferences, under Work hours, select the check
boxes to override daily work hours, weekly work hours, and the minimum time between shifts.
13. If you want to override employee availability, under Availability, select the check boxes to
override employee availability and unavailable events currently applied to the schedule.
14. If you want to override scheduled time off, under Time off, select the Override time off
events currently applied to the schedule check box.
15. If you want to override an employee's skills required to do the fixed job, under Fixed Jobs,
select the Override an employee's skills required to do the fixed job.

Configuring scheduling options
To configure schedule options Schedule Builder uses to create a schedule
1. In Schedule Builder, click the Advanced options tab.
2. Under Schedule algorithm performance, specify the settings Schedule Builder will use to
build the schedule.
3. If you want to optimize break distribution, under Optimization types, select the Optimize
break distribution check box.
4. If you want to optimize shift placement, select the Optimize shift placement check box.
5. If you want to optimize shift size, select the Optimize shift size check box.
6. If you want to balance the distribution of employee shifts over the week, select the Balance
over the week check box.
Selecting this option ensures that Schedule Builder does not completely fill the requirements
of the first few days of the schedule and understaff employee requirements by the end of the
week.
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CREATING AND ADJUSTING SCHEDULES MANUALLY
You can create entire schedules manually. However, if you must schedule a large number of
employees it can be quite complicated and time consuming. Schedule Builder automates the
process and builds schedules for you. You can manually adjust schedules created with Schedule
Builder. You can create and adjust schedules manually in the following ways:
l

Load a schedule

l

Populate a schedule with events

l

Drop insert an event

l

Drag insert an event

l

Recur an event

l

Mass recur an event

l

Mass delete an event

l

Mass apply time off

l

Modify a forecast total

l

Modify event times or notes

Loading schedules
NOTE: Your access rights determine which schedules you can view, modify, or manage.
To load a schedule
1. Click File=>Load schedules.
2. Select the schedule(s) to load.
3. If you want to load all active schedules, select the Select all active schedules check box.
4. Click Load.

Populating schedules with events
NOTE:
l
l

Your access rights determine which schedules you can view, modify, or manage.
For ease of use and accuracy when inserting events, select a schedule view of less than 1
week (View=>Schedule View) prior to insertion.

You can manually insert the following events into a schedule:
l

Shifts

l

Breaks

l

Jobs

l

Time off

l

Unavailable periods

You can insert events in a schedule by either dropping or dragging them on an employee’s time line
on the time bar pane. You can optionally drop insert breaks or jobs into already existing fixed shifts.
Drop inserting events is most useful for fixed events, as the duration of the shift is predefined. Drag
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inserting events is most useful for variable shifts, as the duration can vary depending on the defined
parameters for a specific event.
NOTE: To accommodate for last minute scheduling changes, you can optionally schedule time off
and unavailable events in the middle of scheduled shifts or schedule a shift in the middle of time off
and unavailable events.

Drop inserting events
To drop insert an event
1. Click the Insert tab.
2. Click Drop.
3. Under Event, select the event to add to the schedule.
4. Under Schedule, select the schedule to add events to.
5. Under Event name, select the name of the event to add to the schedule.
6. On the time bar pane, click the employee’s time line to insert the event.
The event is added to the schedule.
7. Repeat steps 3-6 for every event to add to the schedule.

Drag inserting events
NOTE: Drag insert is not available in the 1 month schedule view.
To drag insert an event
1. Click the Insert tab.
2. Click Drag.
3. Under Event, select the event to add to the schedule.
4. Under Schedule, select the schedule to add events to.
5. Under Event name, select the name of the event to add to the schedule.
6. On the time bar pane, click the employee’s time line and drag the cursor from the start time to
the end of the event.
7. Repeat steps 3-6 for every event to add to the schedule.

Recurring events
You can recur shifts, time off, and unavailable events.
To make an event recur
1. On the time bar pane, on the employee’s time line, right-click the event to recur.
2. Click Recurring.
3. Click Daily, Weekly, or Monthly recurring.
4. Specify the pattern and range of the recurrence.
5. Click OK.
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Mass recurring events
You can use the Mass recurrence wizard to create multiple recurrences for several events
automatically. The wizard allows you to mass recur shifts, time off, and unavailable periods based
on either a daily or weekly template.
NOTE: Manual or mass deletion is required to remove the generated events.
To mass recur events
1. Click the Tools tab.
2. In the Bulk operations group, click Recurrence.
The Mass Recurrence wizard opens.
3. Click Next.
4. Follow the steps in the wizard to specify the parameters of the events to mass recur.
5. Click Finish.
6. Click Yes.

Mass deleting events
You can delete one or more scheduled events (shifts, time off periods, unavailable periods, breaks,
and jobs) at a time with the Mass delete option. Only the selected events are deleted from the
schedules.
To mass delete scheduled events
1. Click the Tools tab.
2. In the Bulk operations group, click Delete.
3. Specify the date range affected, event types to delete, and the schedules to delete events
from.
4. Click OK.

Mass applying time off
You can apply time off to any or all agents in a schedule simultaneously.
To mass apply time off
1. Click the Tools tab.
2. In the Bulk Operations group, click Time Off.
The Timeoff Mass Insert dialog box opens.
3. Select a schedule from the Schedules drop-down list.
4. Hold down CTRL and then click the agents to which you want to apply the time off type. If you
want to select all agents, click Select All.
5. Under Time off, select the time off type from the list.
6. Select the start and end dates, days of the week, and start and end times for the time off type.
7. After selecting the time off time, select Mark remaining periods of the day as unavailable
if you want the hours outside of the start and end times to be unavailable for scheduling.
8. Click OK.
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Modifying forecast totals in the event totals pane
If you build schedules with forecast data, you can adjust the forecast totals on the event totals pane.
On the events totals pane, you can change forecast totals in time intervals as small as 15 minutes.
The schedule view you select determines the time interval of the forecast totals. See "Changing the
time interval of the time bar pane" on page 718.
For example, if you select the 8 hour schedule view, you can change the forecast data in 15 minute
intervals. However, if you select the 1 day schedule view, you can change the forecast data in 1 hour
time intervals. When you change the forecast data in an interval larger than 15 minutes and then
change the view to smaller intervals, you will notice that the change applies to each of the smaller
intervals.
NOTE: Schedule Builder uses the latest forecast data to calculate the number of employees
required.
To change the forecast totals in the events totals pane
1. After Totals, click +.
2. Select the Forecast check box and the check boxes of any other event totals to view.
3. Click -.
4. Click the View tab.
5. Under Schedule view, select a time interval.
See Table 53.
6. Click the + before Forecasted to expand the forecast tree.
The event totals for the loaded schedules appear.
NOTE: You can use the Tab key to select cells to the right, and the Shift+Tab keys to select
cells to the left.
7. Click a cell in the forecast event total grid and type the new forecast total for this time interval.

Modifying event times and notes in the schedule details pane
The changes you make to event start times and end times in the schedule details pane are
immediately reflected in the time bar pane.
To modify the start and end times of events in the schedule details pane
1. On the schedule Details pane, click the Start Time or End Time of an event.
2. Type the new time.
The new time is immediately reflected in the time bar pane.
3. Repeat for any other event times to modify.
To modify the start and end times of events in the time bar pane
1. Click the Insert tab.
2. Click Select.
3. On the time bar pane, select the event to modify.
4. Drag and drop the event to adjust its start and end times.
The new time is immediately reflected in the time bar pane.
5. Repeat for any other event times to modify.
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To add/edit a note for a scheduled employee
1. On the schedule Details pane, click the note field for an employee.
2. Click the ... button.
The Notes editor appears.
3. Type/edit a note.
4. Click OK.

SCHEDULE DISTRIBUTION
You can specify viewing preferences, specify access rights to schedules, and run and print reports.

VIEWING SCHEDULES
You can specify how you view the time bar pane. Use the scroll bar to view other days and times in
the schedule. If you reach the end of the month and want to view dates for the next month, you can
click the arrow on the scroll bar to load the schedule for the next month. By default, events you insert
into a schedule are snapped to the grid in 30 minute increments.
To view a specific date
1. From any tab in Workforce Scheduling, click Select date.
2. Click the date to view.
The time bar will display the date you selected to view.

Viewing scheduled events
NOTE: If employees belong to more than one schedule and you are viewing only one of the
schedules to which the employees belong, any events scheduled in the other schedule will appear
as a shadow event (gray bar) in the time bar view.
You select how event time bars appear in Configuration=>Preferences. You can isolate shifts,
time off, and unavailability to view them separately in the time bar pane. You must view breaks and
jobs with shifts. You cannot isolate breaks and jobs in the time bar pane. See "Configuring event
display preferences" on page 703.
To view shifts
l

On the View tab, in the Show/Hide group, select the Shift check box.

To view jobs
l

On the View tab, in the Show/Hide group, select the Job check box.

To view breaks
l

On the View tab, in the Show/Hide group, select the Break check box.

To view time off
l

On the View tab, in the Show/Hide group, select the Time off check box.

To view unavailable periods
l
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On the View tab, in the Show/Hide group, select the Unavailable check box.

Schedule distribution

To view shadow events
l

On the View tab, in the Show/Hide group, select the Shadow check box.

Changing the time interval of the time bar pane
You can view schedules in the time bar pane over 8 hour, 12 hour, 1 day, 2 day, 1 week, 2 week, or 1
month time intervals. The default view is the 12 hour view.
To change the time interval in the time bar pane to one week
1. Click the View tab.
2. In the View options group, under Schedule view, select the interval to view.
3. Optionally, under Group view, select Supervisor to group employees in the time bar pane by
schedule.

Viewing event totals
Event totals represent the total number of employees for an event. You can view event totals in 15
minute, 30 minute, 1 hour, 4 hour, or 1 day time intervals. Table 53 displays the event total time
intervals that correspond to the schedule views.
Table 53: Schedule views and corresponding event total
time intervals
SCHEDULE VIEW

EVENT TOTALS TIME INTERVAL

8 hour

15 minute

12 hour

30 minute

1 day

1 hour

2 day

4 hour

1 week

1 day

2 week

1 day

1 month

1 day

You can select from the following event totals:
Forecast—appears only after you have applied a forecast to a schedule. This total represents the
number of employees required to meet your specified Service Level objectives.
Scheduled—represents the number of employees scheduled at that time
Over/Under—represents the excess (over) or inadequate (under) number of employees scheduled
when compared to the number of employees forecasted.
On Break—represents the number of employees scheduled for a break at a certain time
ACD Jobs—represents the number of employees scheduled to perform ACD jobs
Non ACD Jobs—represents the number of employees scheduled to perform non-ACD jobs
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At work—represents the number of employees scheduled to handle contact requests
Overtime—represents the number of employees scheduled for overtime
To view event totals
1. In the Totals pane, click +.
2. Select the check boxes of the event totals to view.
3. Click -.
The totals pane appears with the event totals you selected.

Viewing schedule details
To group information in the schedule details pane
l

On the schedule details pane, drag and drop the column header to organize to the Drag a
column header here to group by that column area on the window.

To sort information in the schedule details pane alphabetically
l

On the schedule details pane, click the header of the column to sort alphabetically.

To filter information in the schedule details pane
1. On the schedule details pane, click the arrow on a column header.
2. Select the filter criteria.

Synchronizing views
You can synchronize the people pane, time bar pane, and totals pane with the order of the
information in the schedule details pane. Once you have organized the details of your schedules
(sorting, filtering, and grouping) in the schedule details pane, synchronize views to reflect the order
you have selected. For information on how to sort, filter, or group schedule details, see "Viewing
schedule details" on page 719.
To synchronize views
1. Click the View tab.
2. Select the Synchronize time bar view with details view check box.
3. Optionally, select the Vertical scrolling check box.

RUNNING SCHEDULE REPORTS
The Workforce Scheduling reports are produced in Microsoft Excel format. You must run and print
the following Workforce Scheduling reports from CCMWeb. See either the Contact Center Solutions
Enterprise Edition Reports Guide, or the Mitel Contact Center Solutions Workgroup Edition Reports
Guide for more information.
You can produce on-demand reports and scheduled reports for the following reports:
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l

Detailed Schedule by Employee with Totals

l

Schedule by Employee by Time Off by Day of Week

l

Employee Configuration

Schedule distribution

l

Summary Schedule by Employee

l

Schedule Coverage Totals by Type

l

Work Hours Summary Schedule by Employee

Running on-demand reports
To run an on-demand report
1. In CCMWeb, click Reporter=>Workforce Scheduling=>Schedules.
2. Under Report type, select a report.
3. After Device type, select one of the following:
l
l

l

l

Employee — only the employees selected will appear in the report
Supervisor — only the employees associated with the selected supervisor will appear
in the report
Employee group — only the employees who are members of the selected employee
group will appear in the report
Schedule — only the employees associated with the selected schedule will appear in
the report

4. Select one or more devices from the table.
5. Under Start date, select the start date of the report.
6. Under End date, select the end date of the report.
7. After Report output language, select the language for the report.
8. After Reader type, select either Excel or PDF.
9. Click the Filter tab (if available for the report type selected).
10. Specify the filtering options to include in the report.
11. Click the Distribution tab.
12. If you want to email the report, select the Email the report to check box and specify the
contact group, contact, employee, and/or email address.
13. If you want to print the report, select the Print the report check box.
14. Click Submit.

Running scheduled reports
If you need the same reports at the same time on a regular basis, you can schedule Workforce
Scheduling reports to run at a specific time of day, such as:
l

Every day

l

On a specific day of the week

l

On the first or last day of the month

l

Each weekday

You can run scheduled reports to span the following time frames:
l

Current or previous day

l

Previous five or seven days, including or excluding the run day

l

Current month to date

l

Previous month
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l

Current year to date

l

From a given start date to the current date

l

Next five days to six months, including the run day

NOTE: You must create a report schedule before you can add reports to it.

Creating report schedules
To create a report schedule
1. In CCMWeb, click Reporter=>Scheduled reports.
2. Click the Workforce Scheduling report schedules tab.
3. Click Next.
4. After Schedule name, type the name of the report schedule.
5. After Schedule will run, select when the schedule will run.
6. After at, select the time of day.
7. After Reports time span, select the time frame the report will cover.
8. Click the Distribution tab.
9. Select the groups to which you will email scheduling reports.
10. Click Save.
11. Click Add a report.
12. Click the Workforce Scheduling tab.
13. Click Workforce Scheduling scheduled reports.
14. After Report type, select a report.
15. After Schedule, select a schedule.
16. After Employee select an employee.
17. Optionally, click the Filter tab and specify the report filters options for the Workforce
Scheduling report.
18. Click the Distribution tab.
19. After Output language, select the language for the report.
20. Click Save or Execute now.

Modifying report schedules
To modify a report schedule (for example, add a report)
1. In CCMWeb, click Reporter=>Scheduled reports.
2. After Select a schedule, select a schedule.
3. Click Manage schedule properties.
4. Click the Properties tab and modify when the schedule runs the reports.
5. Click the Distribution tab and modify how the reports are distributed.
6. Click the Reports tab and modify the reports included in the schedule.
7. Click Save.
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SCHEDULE ADHERENCE
Mitel Schedule Adherence is an optional application that works in conjunction with Contact Center
Management and Workforce Scheduling. Schedule Adherence resides in the Contact Center Client
real-time monitors and enables you to view the real-time state of contact center employees
scheduled in Workforce Scheduling. Schedule Adherence compares the current activities of
employees to the configured schedule and alerts you in real time when employees are out of
adherence. Employees are considered out of adherence if they are early or late for their scheduled
events or if they are not performing scheduled activities.
Schedule Adherence is made available in Workforce Scheduling and Contact Center Client when
you are licensed for Contact Center Management, Workforce Scheduling, and Schedule Adherence.
Once you have configured a schedule in Workforce Scheduling, you
l

Configure adherence preferences in Workforce Scheduling

l

View adherence monitors in Contact Center Client

l

Set adherence alarms on the Employee State by Position/Time monitors (optional)

l

Run reports on employee adherence to scheduled activities

CONFIGURING ADHERENCE PREFERENCE
You can configure adherence thresholds for shifts, breaks, and jobs. You can set parameters for
each event type to suit the needs of your business. You select employee states and assign them to
relevant events and specify event time tolerance levels. You can optionally configure groups of
employee states and then associate them to relevant employee events.
NOTE:
l

l

Schedule Adherence will handle two or more overlapping adherence thresholds in one of the
following ways. If only one of the events is valid for the current employee state, that event will
be used. If more than one event is valid for the current employee state, the first event, using
start time, will be used.
If no states are specified for an event type, all states will be considered in adherence.

Configuring adherence parameters
To configure adherence parameters
1. In Workforce Scheduling, click the Configuration tab.
2. In the Adherence group, click Adherence Configuration.
The Adherence Parameters window opens.
3. In the left pane, expand the event type list and select the event to which you want to add
relevant adherence states.
4. Under Event start tolerance (hh:mm), specify the times before and after which an employee
state will be reported on as out of adherence.
5. Under Event end tolerance (hh:mm), specify the times before and after which an employee
state will be reported on as out of adherence.
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6. Under Available states, select the states which are relevant for the specified event type and
click > to move the state to the Assigned states list.
7. Repeat steps 2-6 for each event type for which you want to configure adherence parameters.
8. Click OK.

Configuring state groups
To configure a state group
1. In Workforce Scheduling, click the Configuration tab.
2. In the Adherence group, click State groups.
The State groups window opens.
3. Click Add.
4. Type a name for the state group and click Create.
5. Under Available states, select the states that are relevant for the state group and click > to
move the state to the Assigned states list.
6. Repeat steps 2-5 for each state group you want to configure.
7. Click OK.

VIEWING ADHERENCE MONITORS IN CONTACT CENTER
CLIENT
Schedule Adherence includes two Contact Center Client monitors that enable you to monitor
employee adherence to schedules in real time. The Schedule Adherence monitors alarm on
employees who are not adhering to schedules based on the thresholds you specify in Workforce
Scheduling and the alarms you configure in Contact Center Client. You can optionally set adherence
alarms on the Employee State by Position/Time monitors.

Adherence Detail Grid monitor
The Adherence Detail Grid monitor provides a drill-down view of employee scheduled activities,
expected states, and event totals. It enables you to easily compare expected employee states and
actual employee states in real time.
There are three levels to the Adherence Detail Grid monitor. The first level provides a high level
overview of employee adherence. The second level has two grids. The first lists all of the embedded
events (breaks and jobs) for the shift and the associated adherence information. The second grid
lists the out of adherence record for the shift. The final level has only one grid, which represents the
out of adherence record for the embedded events.
You can set Adherence Detail Grid alarms based on the following variables:
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l

Out of adherence

l

Scheduled

l

Expected states

l

Actual state

l

Actual start

l

Current out of adherence

Schedule Adherence

l

Total out of adherence

l

Shift time

l

% out of adherence

Table 54 details provides column heading definitions for the Adherence Detail Grid monitor.
Table 54: Adherence Detail Grid monitor headings
HEADING
Employee
Is in Adherence

Scheduled

Expected States

DEFINITION
the name of the employee being monitored
the check box is enabled when the employee is adhering to the
schedule
the type of event (shift, break, or job) the employee is performing,
whether in or out of adherence
the employee states that are relevant for the type of scheduled
activity the employee is scheduled to perform

Actual State

the current employee state. If this is one of the expected states, the
employee is adhering to the schedule

Scheduled Start

the time at which the employee is scheduled to start the scheduled
activity

Actual Start

the time at which the employee started the scheduled activity. This
column may be blank if the employee has not come into adherence
for the scheduled event

Scheduled End

the time at which the scheduled event is to end

Current Out Of Adherence

the amount of time the employee has been out of adherence for the
scheduled activity. This column will be blank if the employee is
adhering to the schedule

Total Out Of Adherence

the total amount of time the employee has been out of adherence for
all scheduled activities for the current shift

Shift Time

the duration of time the employee has been working the current shift

% Out Of Adherence

the percent of time the employee has been out of adherence for the
elapsed portion of the scheduled shift

Shift
Embedded

the name of the shift for which the employee is scheduled
the name of the embedded event type (break or job)

Start

the time at which the employee went out of adherence

End

the time at which the employee came back into adherence
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To open the Adherence Detail Grid monitor
1. Click the Real Time tab in the Contact Center Client ribbon.
2. From the drop-down arrow in the Adherence column, select Detail Grid.
The Add/Remove device IDs window opens.
3. Select the Employees or Schedules for which you want to review Adherence.
4. Click OK.
The Adherence Details monitor opens.
See Figure 151.

Figure 151: Adherence Detail Grid monitor
To set an Adherence Detail Grid monitor alarm
1. Right-click the Adherence Detail Grid monitor and click Set Alarms.
NOTE: You can select the Apply the alarm thresholds to all devices displayed on the monitor
option to apply the threshold settings for performance variables across all employees.
Alternatively, you can select Apply the alarm thresholds to a specific list of devices to apply
the threshold settings for performance variables to a list of employees.
2. If you selected Apply the alarm thresholds to a specific list of devices, under Devices,
select the employee(s) to which you want to apply the alarm thresholds.
3. Under Performance variables, select the performance variable to which you want to set an
alarm.
4. Under Alarm threshold, click Add a threshold and specify the font color, background,
sound, pop-up, bring to front, and email alarm options you want to apply to the alarm threshold.
5. Click OK.
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Adherence Timebars monitor
The Adherence Timebars monitor provides a schedule time bar, based on the employee time bar and
event colors configured in Workforce Scheduling, for each employee's scheduled activities. The
current time is identified by a green line on the employee time bar and past events are shaded purple.
You can set Adherence Timebar alarms based on the following variables:
l

Shift out of adherence

l

Break out of adherence

l

Job out of adherence

To open the Adherence Timebar monitor
1. Click the Real Time tab in the Contact Center Client ribbon.
2. From the drop-down arrow in the Adherence column, select Timebars.
The Add/Remove device IDs window opens.
3. Under Schedules, select a schedule to include in the monitor or under Employees, select the
employees to monitor.
4. Click OK.
The Adherence Timebars monitor opens.
See Figure 152.

Figure 152: Adherence Timebars monitor
To set an Adherence Timebar monitor alarm
1. Right-click the Adherence Timebar monitor and click Set Alarms.
NOTE: You can select the Apply the alarm thresholds to all devices displayed on the monitor
option to apply the threshold settings for performance variables across all employees.
Alternatively, you can select Apply the alarm thresholds to a specific list of devices to apply
the threshold settings for performance variables to a list of employees.
2. If you selected Apply the alarm thresholds to a specific list of devices, under Devices,
select the employee(s) to which you want to apply the alarm thresholds.
3. Under Performance variables, select the performance variable to which you want to set an
alarm.
4. Under Alarm threshold, click Add a threshold and specify the background, sound, pop-up,
bring to front, and email alarm options you want to apply to the alarm threshold.
5. Click OK.
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Employee State by Position/Time monitors
You can now optionally alarm on employees who are not adhering to schedules on the Employee
State by Position/Time monitors.
To set an adherence alarm on the Employee State by Position/Time monitors
1. Right-click an Employee State by Position/Time monitor and click Set Alarms.
NOTE: You can select the Apply the alarm thresholds to all devices displayed on the monitor
option to apply the threshold settings for performance variables across all employees.
Alternatively, you can select Apply the alarm thresholds to a specific list of devices to apply
the threshold settings for performance variables to a list of employees.
2. If you selected Apply the alarm thresholds to a specific list of devices, under Devices,
select the employee(s) to which you want to apply the alarm thresholds.
3. Under Performance variables, select the performance variable to which you want to set an
alarm.
4. Under Alarm threshold, click Add a threshold and specify the background, sound, pop-up,
bring to front, and email alarm options you want to apply to the alarm threshold.
5. Click OK.

RUNNING ADHERENCE REPORTS
The Schedule Adherence reports are produced in Microsoft Excel format. You must run and print the
following Schedule Adherence reports from CCMWeb. See either the Contact Center Solutions
Enterprise Edition Reports Guide or the Contact Center Solutions Workgroup Edition Reports Guide
for more information.
You can produce on-demand reports and scheduled reports for the following reports:
l

Employee and Employee Group Adherence Trace

l

Employee Group Time Out of Adherence by Employee by Day of Week

l

Employee Group Time Out of Adherence by Day of Month

l

Employee Group Adherence by Period

You run Schedule Adherence reports in CCMWeb, under Reporter=>Schedule Adherence.

EMPLOYEE PORTAL
Mitel Employee Portal enables employees to view and trade shifts online and request changes to
schedules for time off, shifts, and availability. Employee Portal enables schedulers to view
employee requests, perform what-if scenarios, quickly approve or deny requests, and automatically
update schedules.
Employee Portal is made available in Workforce Scheduling and the web-based user interface when
you are licensed for Contact Center Management, Workforce Scheduling, and Employee Portal.
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Employee Portal is available only to employees who have the correct permissions configured in
YourSite Security. The following permissions currently exist:
l

May access Employee Portal

l

May trade shifts

l

May trade time off

l

May request changes to availability

For specific details on configuring employee roles and security options, see "Security roles" on page
189.

EMPLOYEE FUNCTIONALITY
Using Employee Portal, employees can
l

l

View their currently scheduled shifts and the shifts of other employees who share their
schedule
View messages from supervisors and employees and receive updates about the status of
their requests on the home page

l

Offer shifts to the bulletin board for other employees to take or trade

l

Remove shifts from the bulletin board

l

Propose to take shifts from the bulletin board

l

Propose to trade shifts from the bulletin board

l

Accept or reject employee proposals to take or trade your shift

l

Request time off

l

Request changes to your availability

The Employee Portal home page provides links to the bulletin board, view and offer your scheduled
shifts for take or trade, view your pending offers, request time off, and request availability changes.
Any Employee Portal alerts that require your attention also display on the home page. These include
l

You have approved shift requests

l

You have denied shift requests

l

You have shift requests pending supervisor approval

l

You have shift proposals pending your acceptance

l

You have shift proposals pending acceptance or that have been rejected

l

You have time off requests pending supervisor approval

l

You have notes regarding your availability

If a home page alert is red, it requires your attention. Click View to view the alert and any employee
or supervisor notes in detail.

Starting Employee Portal
To start Employee Portal
1. Open Employee Portal.
2. Type your username and password.
3. Click Log on.
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Creating a desktop shortcut to Employee Portal
To create a desktop shortcut to Employee Portal
1. Open Employee Portal.
2. Enter your login credentials and click Log on.
3. Drag and drop the Employee Portal web address from the address bar to your computer
desktop.

Viewing currently scheduled shifts
To view your currently scheduled shifts
1. In Employee Portal, click My shifts.
2. If you want to view shifts starting on a specific calendar day, select the start date from the
calendar.
3. Optionally, to view the break and job details for a specific shift, under Details, click Select.

Viewing the shifts of other employees in your schedule
You can view the shifts for other employees in your schedule to help you determine potential shift
swaps.
To view the shifts of other employees in your schedule
1. Click My Schedules.
2. To view shifts starting on a specific day, select the start date from the calendar.
3. Click Select next to the employee for which you want to view the shift.
The break and job details for the shift display below.

Offering shifts for other employees to take or trade
You can offer shifts to the bulletin board for other employees to take or trade. You can remove shifts
from the bulletin board at any time as long as no employees have proposed to take or trade the shift.
Shifts that have already begun cannot be posted to the bulletin board for other employees to take or
trade.
To offer a shift for other employees to take or trade
1. Click Offer my shifts.
2. Next to the shift you want to offer for other employees to take or trade, click Select.
The shift details display.
3. Click Continue.
4. Optionally, type a note to accompany your offer.
5. Click Submit.

Removing shifts from the bulletin board
You can remove shifts from the bulletin board at any time as long as no employees have proposed to
take or trade the shift. If a proposal has been made, you will need to reject it first before you can
remove the shift from the bulletin board.
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To remove a shift from the bulletin board
1. Click My pending offers.
2. Next to the shift you want to remove from the bulletin board, click Select.
The shift details display.
3. Click Continue.
The shift offer is removed from the bulletin board.

Proposing to take shifts
To propose to take a shift
1. Click Bulletin board.
2. Next to the shift you want to take, click Select.
The shift details display.
3. Click Continue.
4. Click Next.
5. Optionally, add a note to accompany your proposal.
6. Click Next.
7. Click Submit.

Proposing to trade shifts
To propose to trade a shift
1. Click Bulletin board.
2. Next to the shift you want to take, click Select.
The shift details display.
3. Next to the shift you want to propose for trade, click Select.
4. Optionally, add a note to accompany your proposal.
5. Click Next.
6. Click Submit.

Accept or reject an employee proposal to take or trade your shift
To accept or reject an employee proposal to take or trade your shift
1. On the Employee Portal home page, next to You have <#> shift proposals pending your
acceptance, click View.
The Proposals window displays.
2. Next to the proposal you want to view, click Select.
The proposal details display with any relevant employee notes.
3. Click Accept to accept the proposed shift change. Otherwise, click Reject to reject the
proposed shift change.
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Requesting time off
To request time off
1. Click Request time off.
The Request time off window displays, including a list of any time off you have already
scheduled.
2. Click Request time off.
3. Select a time off type from the list.
4. Click Next.
5. Specify the time off start and end times.
6. Click Next.
7. Optionally, add a note to accompany the time off request.
8. Click Next.
The time off request summary displays.
9. Click Submit.

Requesting availability changes
NOTE: You can click Clear request at any time to reset the Request availability change window to
your currently configured availability.
To request an availability change
1. Click Request availability change.
The Request availability change window displays with your current availability.
2. If you need to change existing availability, under Update current availability, select a day of
the week and click Remove. Otherwise, continue to step 3.
3. Under Change availability, specify the dates and times you are available to work.
•

After Day of week, specify the day of week you are available.

•

If you are only available during certain hours, select Part of the day, and specify the times
at which you are available.

•

If you are available to work at any time during the day, select Full day.

4. Click Add to add the new availability to the request.
5. You can optionally select a currently configured availability day or time in the Update current
availability list and click Remove to remove it from the list.
NOTE: The Add button is for adding new availability to the Update current availability list only
and not for replacing specific dates and times from the currently configured availability list.
6. Optionally, under Employee note, add a note to accompany your request.
7. Click Accept.
The Confirm availability change window displays.
8. Specify the date that your requested availability will take effect.
9. Click Submit.
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SUPERVISOR FUNCTIONALITY
Using Employee Portal, supervisors can
l

View employee scheduling requests

l

Preview the effect of approving or denying employee shift change requests

l

Approve or deny employee proposals to take or trade shifts

l

Approve or deny employee requests for time off

l

Approve or deny employee requests for availability changes

Handling employee scheduling requests
NOTE: If you attempt to approve an employee's request for time off for a period where a schedule
has yet to be built, time off will not be decremented properly and the time off will be entered as an
unavailable event in the schedule.
To view, approve, or deny employee scheduling requests
1. Open Workforce Scheduling.
2. Log on to Workforce Scheduling.
3. Load an active schedule.
4. Click the Employee Portal tab.
5. Click the Request mode icon.
6. In the details pane, click the Shift changes, Time off, and Availability tabs to view any
employee scheduling requests pending your approval.
7. Next to Approve, click the + to view the scheduling request details.
8. If you are viewing the Shift change tab, click View timebar to view the scheduled shift.
9. In the Employee requests group, click Preview to view the effect of approving the request.
10. In the Employee requests group,
l

Click Approve to approve the request.

l
Click Deny to deny the request.
The schedule is automatically updated and employees are notified of the schedule request
status.

EMPLOYEE PORTAL REPORTS
The Employee Portal reports are produced in Microsoft Excel format. You must run and print the
following Employee Portal reports from CCMWeb. See either the Contact Center Solutions
Enterprise Edition Reports Guide or the Contact Center Solutions Workgroup Edition Reports Guide
for more information.
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The following reports are available with Employee Portal:
l

l

l

l

Employee Portal Availability Requests
Provides a detailed summary of employee requests for availability changes
Employee Portal Time Off Requests
Provides a detailed summary of employee requests for time off
Employee Portal Shift Requests
Provides a detailed summary of employee requests to take or trade shifts
Employee Portal Shift Change Status
Provides a detailed summary employee requests that have been approved or denied

You run Employee Portal reports in the CCMWeb, under Reporter=>Workforce
Scheduling=>Employee Portal.

733

Chapter 20
TRAFFIC ANALYSIS

Using Traffic Analysis

Contact Center Solutions User Guide

TRAFFIC ANALYSIS
Traffic Analysis is an optional application that works with Business Reporter and Contact Center
Solutions. Traffic Analysis works in conjunction with the 3300 ICP telephone system.
In order to have summarized data for Traffic Analysis reports you must wait until the nightly
maintenance routine runs the summary (at midnight each night). The data for these reports is derived
from the traffic stream. Traffic Analysis reports are not available in real-time.
For detailed information about traffic reports, refer to the reports guide appropriate to your edition of
Contact Center Solutions. Traffic reports provide call statistics on DTMF receivers, route lists, route
plans, routes, and trunks. You can create the following on-demand and scheduled traffic reports:
l

Attendant Console Traffic by Interval report

l

Attendant Traffic by Interval

l

Attendant Group Traffic by Interval

l

DTMF Receiver Group Traffic by Interval

l

Route List Traffic by Interval

l

Route Plan Traffic by Interval

l

Route Traffic by Interval

l

Trunk Traffic by Interval

l

Trunk Busy Hour Traffic by Day of the Week

l

Trunk and Trunk Group Traffic Usage by Day of the Week

l

Trunk Group Outgoing Traffic by Interval

l

Trunk Group Outgoing Traffic Usage by Day of the Week

l

Trunk Group Outgoing Busy Hour Traffic by Day of the Week

USING TRAFFIC ANALYSIS
Before you generate Traffic Analysis reports you must configure data collection for Traffic Analysis.
To configure data collection for Traffic Analysis
1. Set up the telephone systems to collect traffic data
2. Configure the media servers in Contact Center Management for traffic data collection
(YourSite=>Enterprise).
3. Set up Traffic Analysis reporting

SETTING UP TELEPHONE SYSTEMS TO COLLECT TRAFFIC
DATA
You can collect traffic data from a 3300 ICP telephone system over TCP/IP.
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Setting up the 3300 ICP
You must specify traffic data options on the 3300 ICP Traffic Options Assignment form in order to
collect traffic data and produce reports with the Traffic Analysis application.
The Traffic Options Assignment form is a form-driven method to obtain time-based traffic reports on
telephone system usage. You can generate reports that cover attendant usage, channel utilization,
system activity, data station usage, delay to dial tone, extension-to-extension calls, feature usage,
and trunk use.
NOTE:
l
l

l

l

You can define up to six different time slots.
If the start and stop time are blank while the time slot is active, an error message is displayed
when the commit operation is attempted; in this case, the changes will not be committed.
No two traffic slot stops should be less than 5 minutes apart. This time is required for the
system time to generate the previous report.
Making changes to the data in this form and recommitting interrupts a traffic report that is
running.

Programming the Traffic Options Assignment form
To program the Traffic Options Assignment form
1. Log onto the 3300 ICP telephone system.
2. Browse to the Traffic Options Assignment form.
3. Click Change.
4. Configure the traffic options as described in Table 55.
Table 55: 3300 ICP Traffic Options Assignment form
OPTION

Time Slot Active

Start Time
(-Hours, -Minutes)

Stop Time
(-Hours, -Minutes)

VALUE
Select Yes to start a traffic session at the time specified in Start Time
field and finish at the Stop Time field for each of up to six different slots.
The report is resumed the next day at the same time. Select No to
suspend the traffic report for the associated time slot. The traffic report
will not run until Yes is entered and the form recommitted. Default is No.
There can be no overlapping of ACTIVE time slots. Select: Yes
Select the time the traffic report is to start running. Default is blank. The
start time must be assigned for active time slots; it can be blank for
inactive time slots. If the start time equals the stop time then the time
period is 24 hours. Select: 00:00
Select the stop time for the report. If the session is to run for 24 hours,
enter the same time as the start time. Default is Blank. The stop time
must be assigned for active time slots; it can be blank for inactive time
slots. If the start time equals the stop time then the time period is 24
hours. Select: 24:00
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Table 55: 3300 ICP Traffic Options Assignment form (continued)
OPTION

VALUE

Period Length

Select the length of time (15, 30, or 60 minutes) that data is to be
collected for the session before a traffic report is formatted and output.
Default is 60 minutes. Select: 15

Usage Units

Select the type of units the report will use. Default is Erlangs. Select:
Erlangs

Autoprint

Select Yes to spool the traffic report to the printer assigned to this
function in the Application Logical Port Assignment form. Default is No.
We will be using the LPR1 Port 1754 to output traffic.
Select: Yes

Maximum Number of
Traffic Files

Enter the maximum number of traffic reports to be stored in disk. Default
is 10. Select: 10
Select Yes to enable the collection of data for each resource group you
want to include in the traffic report. The default is No.

Sections to include in
Traffic Report
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Route Plans

Yes

Route Lists

Yes

Routes

Yes

Trunk Groups

Yes

Trunks

Yes

Links

No

Groups of Links

No

Channels

No

DTMF Receivers

Yes

Data Transceivers

No

Modem Groups

No

Data Station Groups

No

Attendant Groups

Yes

Attendant Consoles

Yes

Attendants

Yes

Using Traffic Analysis

Assigning ports
You must assign a port to the 3300 ICP to output traffic data.
To enable traffic data output
1. Log on to the 3300 ICP telephone system.
2. Browse to Application Logical Port Assignment.
3. Select Traffic Report Port.
4. Click Change.
5. Under Port Physical Name, type LPR1.
6. Click Save.

Verifying the traffic output
Before you configure traffic collection settings for the 3300 ICP, verify traffic data is being output
through port 1754. Using your preferred telnet client, monitor port 1754 and wait the 15 minute
interval time selected in the Traffic Options Assignment. The traffic should then output to your telnet
client.

CONFIGURING MEDIA SERVERS
You must configure traffic collection settings in YourSite for the media servers from which you
collect traffic data.
3300 ICP
You do not require a dataset to collect traffic data from a 3300 ICP. The traffic data is directed to the
printer port, 1754, on the 3300 ICP telephone system. See "Configuring data collection settings for a
3300 ICP" on page 88.

Verifying traffic data is saved on the Enterprise Server
To verify the traffic collection for the 3300 ICP
1. Double click the Contact Center Management Enterprise Server icon on your desktop.
2. Using an administrative username and password, log on to CCMWeb
3. Click YourSite=>Enterprise.
4. Expand the tree of the site for which you want to configure traffic options.
5. Click a 3300 ICP media server.
6. Click the Data Collection tab.
7. Verify the Traffic Analysis check box is selected and the port is 1754.
8. Wait the interval time you selected in the Traffic Options Assignment, for example 15, 30 or 60
minutes.
9. On the Enterprise Server, browse to <drive letter:>\Program Files (x86)\prairieFyre
Software Inc\CCM\Data Directory\Node_0X.
This is the directory of the media server for which you configured traffic options.
You should see a new file with the following naming convention, TYYYYMMDD.txt. For
example, T20050127.txt, where YYYY is the year, MM is the month, and DD is the day.
10. Double-click the file to open it and view the traffic data.
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Setting up Traffic Analysis reporting
After setting up the telephone system to collect traffic data and configuring the media servers for
traffic data collection, you can assign reporting numbers and names to the traffic devices you are
reporting on with your Traffic reports.
To configure traffic
1. Type the Name of the Traffic.
2. Type the Reporting number of the Traffic.
3. Select the Traffic Type from the drop-down menu.
4. After Media Server, click the Browse button.
5. Select a media server and click OK.
6. Click Save.
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CONTACT CENTER MANAGEMENT REMOTE
SERVERS
A Remote Server enables you to perform many of the functions of the Enterprise Server without
having to install an additional Enterprise Server or upgrade your licensing. You can configure and
administer Remote Servers in YourSite Explorer.
Remote Servers enable you to
l

l

Collect, stream, and buffer ACD/SMDR data to the Enterprise Server. This enables
enterprise-wide reporting while protecting data from loss if the link between the Enterprise and
Remote Servers goes down.
Create a remote IVR Routing instance. This enables IVR Routing instances to continue to
function if they lose access to the primary database or site.

l

Monitor prairieFyre services activity and collect data on alarms

l

View the status of data collection on the Remote Server.

l

Update Remote Servers automatically following the upgrade of the Enterprise Server.

l

Display real-time performance statistics and text messages from the Remote Server on LED
wall signs.

For information on installing Remote Servers, see the Contact Center Management Installation
Guide. For information on Remote Server hardware and software requirements, see the Contact
Center Solutions and Business Reporter System Engineering Guide.

COLLECTING DATA WITH REMOTE SERVERS
Remote Servers enable you to collect and stream ACD/SMDR data from media servers, facilitating
enterprise-wide monitoring and reporting. A Remote Server’s ability to buffer data prevents data loss
should the link to Enterprise Server go down.
Remote Servers collect and stream ACD/SMDR data from media servers to the Enterprise Server
over TCP/IP. The Enterprise Server gathers, summarizes, and writes the data to a SQL database for
monitoring and reporting purposes.
Should the link to the Enterprise Server go down, Remote Servers will buffer ACD/SMDR data until
communication is restored and the data can be streamed. Note that if the link between the Enterprise
Server and a Remote Server goes down, the managers and supervisors cannot view real-time data
from the Remote Server until the connection is restored.
NOTE:
l

l

741

You require a Contact Center Network License to collect data using a Remote Server. For
more information, see the Contact Center Solutions and Business Reporter System
Engineering Guide.
A single Remote Server can collect ACD/SMDR data from up to 65 voice media servers. If
you are attempting to collect data from more than 65 PBXs with a single Remote Server, you
must contact Mitel Technical Support at 1-800-722-1301 (North American customers) or your
approved Mitel vendor (for customers residing in Latin America, Europe, the Middle East,
Africa, and Asia pacific) for guidance.

Creating remote IVR Routing instances

CREATING REMOTE IVR ROUTING INSTANCES
Creating remote IVR Routing instances enables workflows to continue to operate if the connection
to the Enterprise Server goes down, minimizing call disruption.
For information on how to install IVR Routing on Remote Servers, see the Contact Center
Management Installation Guide.
NOTE: If the connection from Remote Servers to the Enterprise Server goes down, loss of real-time
connectivity affects all workflow components that depend on data derived from real-time queue
statistics including queue condition activities, Updated Position in Queue (UPiQ) messages, and
prompts based on real-time statistics.

MONITORING ACTIVITY AND VIEWING ALARMS
The Remote Server can monitor its performance and notify the Enterprise Server when server states
surpass configured alarm thresholds. You configure alarm thresholds and view alarms for Remote
Servers in YourSite Explorer. For more information on server-side alarms, see "Monitoring and
alarming subsystem" on page 178.

VIEWING ACD/SMDR DATA COLLECTION
You can view real-time ACD and SMDR data collection by clicking the Data Link button, located in
the YourSite Explorer ribbon when a 3300 ICP media server has been selected. For more
information, see "Verifying media servers are receiving telephone system data" on page 384.

UPDATING REMOTE SERVERS
Remote Servers will automatically update when the Enterprise Server is upgraded, if you have
configured the Enterprise Server accordingly. For more information, see "Configuring the Enterprise
Server settings" on page 80.

DISPLAYING ENTERPRISE-WIDE STATISTICS
WallBoarder is an application that displays real-time performance statistics and text messages from
the Enterprise Server on one or more LED reader boards. You can run WallBoarder on Remote
Servers to keep agents and employees throughout your contact center aware of enterprise-wide
statistics and key messages. For more information, see "WallBoarder" on page 278.
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CTI DEVELOPER TOOLKIT
NOTE:
l
l

l

CTI Developer Toolkit is currently supported for use with the 3300 ICP only.
If you require the calculations used to populate Contact Center Management and Business
Reporter reports to use in your custom application built with the CTI Developer Toolkit, you
can download these applications from Mitel Online under
Support=>Software Downloads=>Contact Center Enterprise Edition or Contact Center
Business Edition.
In Version 7.0 and greater, the CTI toolkit application uses .NET Framework 4.5. Upon
upgrade to Version 7.1, any third-party products that use the CTI Toolkit will need to be
recompiled using the latest CTI Toolkit dlls.

Mitel Computer Telephony Integration (CTI) Developer Toolkit is a programmable .NET C#
Dynamic-link library (DLL) that can be used in any .NET Framework 4.5 application or website. The
CTI Developer Toolkit completes the migration from Mitel Agent Portal to Mitel Contact Center
Screen Pop.
The CTI Developer Toolkit is offered in two forms: server side and client side license. The server
side license provides the ability to insert custom real-time IVR collected data to each incoming call.
It also uses the Contact Center Screen Pop infrastructure to deliver third-party data to agent
desktops (using either the client side license or Contact Center PhoneSet Manager). The client side
license provides basic telephony functions (answer, hang up, transfer, and hold), provides agent
control (such as set/remove Make Busy) and delivers caller information such as ANI, DNIS,
Collected Digits, and call notes in real time as calls arrive. The client side license may be used to
display information in CRM, Microsoft Outlook, or custom applications.
If you want to route or screen pop on digits or other data sets collected from a third-party IVR, you
must adhere to the following conditions:
l
l

l

You must have a CTI Developer Toolkit Server license
The third-party vendor must be a Mitel MSA Development partner. As a Mitel
MSA Development partner, they must have completed a MiTAI (API) integration that allows
them to pass the collected digits or other data set, along with a unique call ID provided by this
API, enabling Mitel's Contact Center software to associate the collected digits to a particular
call with unique call ID matching.
If you want to route or screen pop on ANI or DNIS or on digits collected within the Mitel IVR,
the above are not required.

For installation information and procedures, see the Contact Center Management Installation Guide.
NOTE: Once you have installed the CTI Developer Toolkit, typically to <installation_
drive>:\Program Files (x86)\prairieFyre Software Inc\CTI Developer Toolkit, you can access the
DLLs required to create customized applications in the CTI Developer Toolkit\Redist folder. You
must include the entire Redist folder with your final compiled custom application or it will not function
properly.
The CTI Developer Toolkit includes a number of sample applications, including source code, that
can be used to test CTI Developer Toolkit functionality. For a complete overview of the sample
applications included, see "CTI Developer Toolkit sample applications" on page 749.
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The CTI Developer Toolkit is currently available with the following functionality:
l

l

l

l

Connect and disconnect from the Contact Center Management Enterprise Server with user
authentication
Retrieve devices from the Contact Center Management configuration database, based on all
l

All agent devices for the user currently logged on to the system

l

All agent devices associated with employees

l

All extensions

l

All queues

Set real-time monitors on agents, extensions, and queues to receive notification when
l

A call is received (including call detail information)

l

A device state changes (for example, idle, ACD, and hold)

Set phone monitors on agents and extensions to receive notification when
l

A call is received (including call detail notification)

l

A call is made

l

A call is cleared

l

A call is transferred

l

A call is conferenced

l

A call is established

l

A call fails

l

Control a device (for example, set/remove Do Not Disturb or Make Busy)

l

Make calls from agent or extension devices

l

Place calls on hold

l

Retrieve calls that are on hold

l

Remove calls from queues

l

Redirect calls from queues to agents/extensions

l

Transfer or conference calls between agent and extension devices

l

Clear calls for agent and extension devices

l

Add call detail information from third-party IVRs and dialers. This information is available to
client applications in the Call Received event

Table 56 lists the major areas of functionality exposed with each version of the CTI Developer
Toolkit. The version specified indicates the most recent version, including any service packs
available to customers.
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Table 56: Supported functionality by version
VERSION 5.8

VERSION
6.0.2

VERSION
7.0

VERSION
7.1

Connection state
changes

x

x

x

x

Configuration loaded

x

x

x

x

FUNCTIONAL AREA
Application events
l

l

Device Information
l

Get all devices

x

x

x

x

l

Get all extension

x

x

x

x

l

Get all agents

x

x

x

x

l

Get all queues

x

x

x

x

l

Get agents by login

x

x

x

x

Get agents for all
employees

x

x

x

x

x

x

x

x

l

Device events1
l

Device state changed

l

Voice events2

l

Call info received

x

x

x

x

l

Call delivered

x

x

x

x

l

Call received

x

x

x

x

l

Call cleared

x

x

x

x

l

Call transferred

x

x

x

x

l

Call established

x

x

x

x

l

Call failed

x

x

x

x

l

Call diverted

x

x

x

x

l

Call originated

x

x

x

x

l

Call retrieved

x

x

x

x

Extension events
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Table 56: Supported functionality by version (continued)
FUNCTIONAL AREA
l

Extension state changed

VERSION 5.8

VERSION
6.0.2

VERSION
7.0

VERSION
7.1

x

x

x

x

x

x

x

x

Agent events
l

Agent state changed

Queue events
l

Queue Now statistics

x

x

x

x

l

Queue totals statistics

x

x

x

x

Interactive Visual Queue
delta

x

x

x

x

Interactive Visual Queue
snapshots

x

x

x

x

l

l

Voice control3
l

Make call

x

x

x

x

l

Clear call

x

x

x

x

l

Answer call

x

x

x

x

l

Hold call

x

x

x

x

l

Retrieve held call

x

x

x

x

l

Conference call

x

x

x

x

l

Transfer call

x

x

x

x

l

Make consultation call

x

x

x

x

l

Transfer consultation call

x

x

x

x

l

Cancel consultation call

x

x

x

x

l

Trade call

x

x

x

Agent control
l

Login

x

x5

x5

x5

l

Logout

x

x5

x5

x5

l

Set Make Busy

x

x

x

x
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Table 56: Supported functionality by version (continued)
FUNCTIONAL AREA

VERSION 5.8

VERSION
6.0.2

VERSION
7.0

VERSION
7.1

l

Remove Make Busy

x

x

x

x

l

Set Do Not Disturb

x

x

x

x

l

Remove Do Not Disturb

x

x

x

x

l

Cancel Work Timer

x

x

x

x

l

Cancel reseize timer

x6

x6

x6

l

Conference call

x

x

x

x

Queue control
l

Redirect call

x

x

x

x

l

Remove call

x

x

x

x

l

IVR integration

l

Add call detail7

x

x

x

x

1 Device events are supported by all device types.
2 Voice events are supported by extension and agent devices
3 Voice control is supported by extension and agent devices.
4 Both hot desking and traditional agent logins are supported with Version 5.5 SP1 or greater.
5 Supports External hot desk agent and External hot desk user functionality.
6 The Cancel reseize timer agent control function requires External hot desk agent functionality.
7 The AddCallDetail method requires a CTI Developer Toolkit server license.

NOTE: The CTI Developer Toolkit may also be referred to as the prairieFyre.CallControl.Toolkit
namespace throughout this chapter and in the CHM help file documentation, as the CHM help file
included with the CTI Developer Toolkit is sourced from the source code, which refers to the
namespace by this name.
Table 57 lists and describes the top level classes available with the CTI Developer Toolkit.
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Table 57: Primary object classes
CLASS

DESCRIPTION

DeviceManager

This class contains functionality to manage the connection to the
Enterprise Server and provides access to configured agents, extensions,
and queues.

Device

This abstract class includes the core properties for all device types.
Objects of this class may not be directly instantiated.

Voice

This class is derived from the Device class and serves as the base class
for the agent and extension classes. It includes properties and
functionality that is specific to devices with voice characteristics.

Agent

This class is derived from the Voice class. It represents both traditional
ACD and hot desking agents. Specialized functionality handled in this
class includes agent control operations, such as agent login and
set/remove Make Busy.

Extension

Queue

This class is derived from the Voice class. It represents configured
extensions.
This class is derived from the Device class. It represents configured
queues. It includes properties and functionality that is specific to the
queue device. Specialized functionality handled in this class includes
set/remove Do Not Disturb, redirect call, and remove call.

CTI DEVELOPER TOOLKIT SAMPLE APPLICATIONS
There are currently four sample applications, including source code, that are included with the CTI
Developer Toolkit.
Device Monitor
The Device Monitor sample application provides a graphical user interface that enables developers
to connect to the Contact Center Solutions Enterprise Server, retrieve a list of devices, perform
agent control activities on the retrieved devices (for example, login/logout, set/remove Make Busy,
etc.), perform call control activities (for example, make call, answer call, clear call, etc.), and retrieve
call event notifications. (See Figure 153.)
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Figure 153: Device Monitor sample application
To use the CTI Developer Toolkit Device Monitor sample application
1. In Windows, navigate to the CTI Developer Toolkit and open Device Monitor.
2. Click File=>Connect.
3. Type the IP address of the Enterprise Server, user name, and password and click OK.
4. Click Devices and select one of the following options:
l

Retrieve agents for current login

l

Retrieve agents for all employees

l

Retrieve all agents

l

Retrieve all extensions

l

Retrieve all queues

l

Retrieve all devices

5. Once the devices you selected have loaded, you perform actions on the selected device(s) by
clicking Actions and selecting an available action or by right-clicking and selecting an
available action from the list:
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l

Set monitor=>Phone, Real time, All

l

Remove monitor=>Phone, Real time, All

l

Login

l

Logout

l

Set Make Busy

l

Remove Make Busy

l

Set DND

l

Remove DND

CTI Developer Toolkit sample applications

l

Cancel Work Timer

l

Make call

l

Answer call

l

Hold call

l

Retrieve call

l

Transfer call

l

Conference call

l

Clear call

l

Add call notes

l

Make consultation call

l

Transfer consultation call

l

Cancel consultation call

l

Trade call

Queue Monitor
The QueueMonitor sample application displays the functionality and support for queue device types
included with the CTI Developer Toolkit. The QueueMonitor application is similar to the optional
Interactive Visual Queue monitor that is housed in Contact Center Client. It enables developers to
connect to the Contact Center Solutions Enterprise Server, load a set of queues, and view real-time
call activity (calls entering and exiting queues) and queue statistics (for example, calls waiting,
number of agents available, longest waiting, etc.). (See Figure 154.)
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Figure 154: Queue monitor sample application
To use the CTI Developer Toolkit QueueMonitor sample application
1. In Windows, navigate to the CTI Developer Toolkit and open Queue Monitor.
2. Click File=>Connect.
3. Type the IP address of the Enterprise Server, user name, and password and click OK.
4. Click Actions.
5. Select one or more queues to open.
6. Click OK.
If you selected multiple queues, you can toggle between them using the tabs at the bottom of
the queue monitor.
7. Once the queues you selected have loaded, you perform actions on the selected device(s) by
clicking Actions and selecting an available action or by right-clicking and selecting an
available action from the list:
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l

Open queue

l

Close queue

l

Set DND

l

Remove DND

l

Redirect call

l

Remove call

CTI Developer Toolkit sample applications

Console Call Monitor
The ConsoleMonitor sample application displays call received information for either single or multiple
agents or extensions in a simple console application window. It is intended to be a very brief
example, with little error handling, that can be used to demonstrate the basics of coding screen pop
displays.
To use the CTI Developer Toolkit ConsoleCallMonitor sample application
1. In Windows, open the command prompt window.
2. Type cd "<installation_drive>:\Program Files (x86)\prairieFyre Software Inc\CTI
Developer Toolkit\Samples\ConsoleCallMonitor\bin" and click Enter.
3. Type ConsoleCallMonitor.exe Device Number/Telephone System IP Address/Type and
click Enter.
The ConsoleCallMonitor application takes multiple parameters in the following form, Device
Number/Telephone System IP Address/Type. For example, 2000/10.1.1.1/Agent
1800/10.1.1.10/Extension would invoke agent 2000 on telephone system 10.1.1.1 and
extension 1800 on telephone system 10.1.1.10.
Console Queue Monitor
The ConsoleQueueMonitor sample application displays information on calls entering/exiting queues
and queue statistics in a simple console application window. Similar to the Console Call Monitor
application, it represents a minimal set of code required to build a real-time queue monitoring
application.
To use the CTI Developer Toolkit Console Queue Monitor sample application
1. In Windows, open the command prompt window.
2. Type cd "<installation_drive>:\Program Files (x86)\prairieFyre Software Inc\CTI
Developer Toolkit\Samples\ConsoleQueueMonitor\bin" and click Enter.
3. Type ConsoleQueueMonitor.exe Queue/Telephone System IP Address and click Enter.
The ConsoleQueueMonitor application takes multiple parameters, in the following form:
Queue/Telephone System IP Address. For example: P200/10.1.1.1 P180/10.1.1.10 would
invoke monitoring calls on two queues, queue P200 on telephone system 10.1.1.1 and queue
P180 on telephone system 10.1.1.10.
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BEST PRACTICES FOR CUSTOM DEVELOPMENT
The following best practices must always be followed when developing custom developments to
work in conjunction with Contact Center Solutions software.
l

Before you begin development
l

l
l

l

l

l

l
l

l

Verify that the CTI Developer Toolkit and Contact Center Solutions software are the
same version and that you are properly licensed for all desired functionality
Verify that you have access to the Contact Center Management Enterprise Server
Verify that the Contact Center Solutions Enterprise Server has been properly set up and
configured with the extensions, agents, and queues that you will be using with your
custom application
Verify that the telephone system(s) in your enterprise has been properly set up and
configured with the extensions, agents, and queues that you will be using with your
custom application
Verify that all pre-installation and post installation steps have been completed. See the
Contact Center Management Installation Guide.
Confirm the telephone system conforms to the guidelines stated in the Golden Rules
document. In particular, aspects of the CTI Developer Toolkit rely on the ability to set
MiTAI monitors on devices. As such, the 'HCI Options' must be enabled for the Class
of Service on all monitored devices. See the Mitel Knowledge Base at
http://micc.mitel.com/kb/ and use the key words 'Golden Rules'.
Verify you have Microsoft .NET Framework Version 4.5 installed on your workstation
Verify you have an IDE installed on your workstation, either Visual Studio 2005/2008 or
SharpDevelop

When developing custom applications and integrations
l

l

l

Verify the what you are attempting to build is possible by attempting the functions from
an alternate client application, such as Contact Center Client, the Device Monitor
sample application, or MiTAI Browser
Routinely check the log files of all related services, specifically the Enterprise Server,
Collector, and MiTAI Proxy Server to ensure there are no unusual or unexpected
warnings or errors
Routinely check the log files of alternative client applications for any unusual or
unexpected warnings or errors (as listed in the previous bullet)

The following best practices must always be followed when developing custom connectors to thirdparty IVRs.
l

l
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Third-party IVR ports and IVR Routing ports must all be programmed in YourSite Explorer as
an extension type=>Messaging Port or RAD Port. When configuring the extension as a port
type, the disable real-time monitoring option will not be configurable.
In addition to whatever custom data your third-party IVR is sending, it must also send the
same data that IVR Routing does (using the same naming conventions). These are PFANI,
PFCALLERNAME, and PFDNIS. This will ensure that the existing MiTAI record linking logic
within the Contact Center Management Enterprise Server gets the correct information, which
is typically at the first controller/port

Common user scenarios and source code examples

COMMON USER SCENARIOS AND SOURCE CODE
EXAMPLES
This section details the following common user scenarios for developing custom integrations and
applications using the CTI Developer Toolkit
l

Click to dial

l

Call received notification

l

Add call detail (using a third-party IVR)

CLICK TO DIAL
NOTE: This code sample is not included in the sample project that is included with the CTI
Developer Toolkit.
The following C# code fragment provides sample source code that can be used to build a console
application with click-to-dial functionality.
static void Main()
{
DeviceManager dm = DeviceManager.Instance;
string pbxIpAddress = "10.1.1.10";
string server = "the-CCM-server-IP-address-here";
string username = "your-username-here";
string password = "your-password-here";
Voice extension;
if (!dm.Connect(server, 5024, username, password))
{
Console.WriteLine("Uable to connect to server");
return;
}
extension = dm.GetDevice("1100", pbxIpAddress, DeviceType.Extension) as Voice;
if (extension == null)
{
Console.WriteLine("Unable to retrieve extension device");
return;
}
if (!extension.SetMonitor())
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{
Console.WriteLine("Unable to monitor extension");
return;
}
extension.MakeCall("16135990045");
dm.ReleaseAllDevices();
dm.Disconnect();
Console.WriteLine("Exit application");
}
This source code will connect to the specific Enterprise Server using the supplied username and
password. It then initiates a call from extension 1100 on the telephone system with IP address
10.1.1.10 to the phone number 16135990045.

CALL RECEIVED NOTIFICATION
The following C# code fragment shows a condensed version of the source code provided with the
ConsoleCallMonitor sample application that is shipped with the CTI Developer Toolkit.
static void Main()
{
DeviceManager dm = DeviceManager.Instance;
string pbxIpAddress = "10.1.1.10";
string server = "the-CCM-server-IP-address-here";
string username = "your-username-here";
string password = "your-password-here";
Voice extension;
if (!dm.Connect(server, 5024, username, password))
{
Console.WriteLine("Uable to connect to server");
return;
}
extension = dm.GetDevice("1100", pbxIpAddress, DeviceType.Extension) as Voice;
if (extension == null)
{
Console.WriteLine("Unable to retrieve extension device");
return;
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}
if (!extension.SetMonitor())
{
Console.WriteLine("Unable to monitor extension");
return;
}
device.CallInfoReceived += CallInfoReceivedHandler;
Console.WriteLine("Listening for calls on extension 1100");
Console.WriteLine("Press any key to end application.");
while (!Console.KeyAvailable) ;
dm.ReleaseAllDevices();
dm.Disconnect();
Console.WriteLine("Exit application");
}
static void CallInfoReceivedHandler(object sender, CallInfoReceivedEventArgs e)
{
Console.WriteLine("-----------------------------------------------");
Console.WriteLine("Call Info Received:");
Console.WriteLine(" Caller Name : " + e.Info.CallerName);
Console.WriteLine(" Caller Number : " + e.Info.CallerNumber);
Console.WriteLine(" DNIS : " + e.Info.DNIS);
Console.WriteLine(" Collected Digits : " + e.Info.CollectedDigits);
}
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ADD CALL DETAIL (USING A THIRD-PARTY IVR)
The following C# code fragment shows a condensed version of using the AddCallDetail method to
toolkit users can invoke to add custom key/value pairs into call information.
In summary, this code fragment does the following:
l

l

l

Device_CallReceived is an event handler that is invoked whenever a monitored IVR
extension/port receives a call. This is needed to acquire the MiTAI Call ID which is used to
link these extra information records (--w records in ACD data files) to other call records
When this event handler is invoked, it makes three sequential calls to the AddCallDetail
method, adding call values for the following keys: PFANI, PFCALLERNAME, and PFDNIS
The keys used above are the ones that the default screen pop display recognizes but
developers can easily make up their own key names as well, provided they have toolkit code
on the client side to pull the custom information from the CallInfoReceivedEvent notifications

public void Device_CallReceived(object sender, CallReceivedEventArgs e)
{
Device device = sender as Device;
DeviceManager.Instance.AddCallDetail(
e.CallingDevice.CallReferenceID, device.PBXIPAddress, device.DeviceID,
"PFANI", "6135990045");
DeviceManager.Instance.AddCallDetail(
e.CallingDevice.CallReferenceID, device.PBXIPAddress, device.DeviceID,
"PFCALLERNAME", "John Smith");
DeviceManager.Instance.AddCallDetail(
e.CallingDevice.CallReferenceID, device.PBXIPAddress, device.DeviceID,
"PFDNIS", "8001");
}

TROUBLESHOOTING CTI DEVELOPER TOOLKIT
ISSUES
Diagnosing any issues experienced while using the CTI Developer Toolkit requires a high level of
familiarity with Contact Center Solutions and Business Reporter applications and CTI Developer
Toolkit functionality. This section details several troubleshooting tips and tricks when encountering
issues with CTI Developer Toolkit functionality.
The CTI Developer Toolkit and any custom applications created using it rely heavily on the proper
configuration and operation of the Contact Center Solutions Enterprise Server. Ensuring that the
server is operating correctly is the first diagnostic step that should be taken when troubleshooting
CTI Developer Toolkit issues. This includes:
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l

l

l

l

l

l

Verifying that the CTI Developer Toolkit and Contact Center Solutions software are the same
version and that you are properly licensed for the desired functionality
Verifying that all pre-installation and post installation steps have been completed. See the
Contact Center Management Installation Guide.
Checking the log files of all related services, specifically the Enterprise Server, Collector, and
MiTAI Proxy Server to ensure there are no unusual or unexpected warnings or errors
Attempting the same operation using an alternate client application. This can be any of the
following, depending on the underlying issue:
l

Contact Center Client

l

Device Monitor sample application

l

MiTAI Browser

Checking the log files of alternative client applications for any unusual or unexpected
warnings or errors (as listed in the previous step)
Confirming the telephone system conforms to the guidelines stated in the Golden Rules
document. In particular, aspects of the CTI Developer Toolkit rely on the ability to set MiTAI
monitors on devices. As such, the 'HCI Options' must be enabled for the Class of Service on
all monitored devices. See the Mitel Knowledge Base at http://micc.mitel.com/kb/ and use the
key words 'Golden Rules'.

TROUBLESHOOTING SPECIFIC ISSUES
This section describes some specific problems that may be encountered when working with the CTI
Developer Toolkit and provides any recommended steps for diagnosing issues and potential
solutions.

Retrieve All commands does not display any devices
If any of the Retrieve All commands in the Device Monitor application return an empty list of devices,
there may be a configuration problem with the IPAddress values stored in the CCMData database
table named tblEnterpriseConfig_Node.
To troubleshoot this issue, run the following SQL query and pay particular attention to values in the
[IP Address] column. This query simulates the query used by the CTI Developer Toolkit and will
return a list of agents and extensions for all voice media servers.
SELECT node.Name AS [Node],
node.IPAddress AS [IP Address],
'Agent' AS [Type],
device.FirstName AS [First Name],
device.LastName AS [Last Name],
device.Reporting AS [Reporting Number]
FROM tblConfig_Agent device INNER JOIN tblEnterpriseConfig_Node node
ON device.FKNode = node.Pkey INNER JOIN tblLookup_NodeType NodeType
ON node.FKNodeType = NodeType.Pkey
WHERE FKNodeFamily = 1
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UNION
SELECT
node.Name AS [Node],
node.IPAddress AS [IP Address],
'Extension' AS [Type],
'' AS [First Name], -- No first name on extensions
'' AS [Last Name], -- No last name on extensions
device.Reporting AS [Reporting Number]
FROM tblConfig_Extension device INNER JOIN tblEnterpriseConfig_Node node
ON device.FKNode = node.Pkey INNER JOIN tblLookup_NodeType NodeType
ON node.FKNodeType = NodeType.Pkey
WHERE FKNodeFamily = 1
ORDER BY [Node], [Type]
The [IP Address] values in the query results should contain the IP address of the telephone system
that is associated with the voice media server. If this value is incorrect or blank, use YourSite
Explorer to set the IP address to the correct value.

GetDevice method fails or returns null unexpectedly
If a custom applications calls the GetDevice method and returns null even though the device is valid
and programmed in Contact Center Management, there may be a timing issue with the Connect
operation. When a custom application calls the Connect method in the CTI Developer Toolkit, the
operation returns as soon as an authenticated connection has been established with the Enterprise
Server. However, there may still be some basic configuration loading occurring in the background,
which must complete before calls to GetDevice can be successful.
An event named ConfigurationLoaded is provided in the CTI Developer Toolkit, which is used to
notify custom applications that background configuration loading has completed. In previous
versions, the Device Monitor sample application used a workaround method of issuing aSleep
method call on the active thread to give background configuration loading time to complete.

Agent control actions succeed while call control actions fail
In this scenario, agent control actions (for example, login, logout, and set/remove Make Busy)
succeed, while call control actions (for example, make call, answer call, and clear call) fail. The key
difference between these two types of operations is that call control actions require a MiTAI monitor
set on the device and agent control actions do not. Your investigation should start with an analysis of
MiTAI related configuration, including:
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l

Verifying that the MitaiEnabled flag set properly for devices in the database

l

Checking telephone system (for example, HCI Options enabled)

l

Confirming the telephone system version is supported

Troubleshooting CTI Developer Toolkit issues

Unable to set monitor on agent device
In some cases, using the Device Monitor to issue a Set Monitor operation on an agent will fail. If you
have the Errors view open in the application, it displays a MiTAI error, indicating 'Operation failed:
MessageTag[8] ReturnCode [SXERR_FEATURE_NOT_ALLOWED]'
In this case, you should verify that the agent device is properly configured on the telephone system,
including HCI Options enabled for the associated Class Of Service. If the problem persists, check to
see if the CTI Developer Toolkit is Version 5.5 or earlier and if the agent is a traditional or hot desking
agent. There was a known issue setting monitors on traditional ACD agents using the CTI Developer
Toolkit that was corrected in 5.5 SP1. For earlier versions, one workaround is to set the monitor on
the extension the agent logs in to.

Web service errors occurring in log files
If you encounter Web service error messages in log files and an application built with the CTI
Developer Toolkit is experiencing errors, check to ensure that the Microsoft.Web.Services3.dll file is
present under the Windows system directory or in the custom application directory.

'Softphone proxy did not respond after 30 seconds' error
If you encounter this message and the Contact Center Solutions software is Version 5.5 SP2 or
earlier, there is a known licensing issue where the MiTAI Proxy Server will fail to send clients
messages unless there is at least one Contact Center Softphone or Contact Center PhoneSet
Manager license in your enterprise. This issue was corrected in version 5.5 SP3.
To work around this problem, contact Mitel technical support at 1-800-722-1301 (North American
customers) or your approved Mitel vendor (for customers residing in Latin America, Europe, the
Middle East, Africa, and Asia Pacific).and have them create new license files.
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Logging into your Contact Center
Salesforce.com Connector
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SALESFORCE.COM CONNECTOR
Salesforce.com Connector is an optional client application that works in conjunction with Contact
Center Management and/or Business Reporter and requires an account with Salesforce.com
(Enterprise and Professional editions of Salesforce.com), and, optionally, IVR Routing (for Collect
Caller Entered Digits only).
NOTE:
l
l

l

l

l
l

Salesforce.com Connector is currently supported for use with the 3300 ICP only.
Whether Salesforce.com is running on the cloud or on a server within your organization,
agents must have the Contact Center Salesforce.com Connector installed and running on
their client computers for Salesforce.com Connector to function properly.
The Contact Center Salesforce.com Connector refers to the Contact Center Softphone
application as it appears in Salesforce.com.
We test support for Salesforce.com Connector against Internet Explorer 9, 10, and 11, and
make every effort to test against the most recent versions of Mozilla Firefox and Google
Chrome. For information regarding Salesforce’s support requirements, please consult
Salesforce documentation.
If you use Internet Explorer 10 or 11, you must enable Compatibility View.
Ensure you enable the 'Display mixed content' option in Internet Explorer's local intranet
security settings before logging into Salesforce.com.

Salesforce.com Connector enhances the functionality of Salesforce by embedding your Mitel phone
directly into the Salesforce user interface. This improves productivity by providing fast and easy
access to accounts, contacts, cases, and other Salesforce objects directly related to incoming calls.
Using Salesforce.com Connector enables your contact center agents to perform their job functions
through a single user interface.
Salesforce.com Connector is compatible with the Salesforce.com Microsoft Outlook connector.
Users can synchronize their Salesforce.com contacts, tasks, and calendar events, associate
Outlook email messages, and map custom fields in Salesforce.com to fields in Outlook.
Salesforce.com Connector manages interactions between the Contact Center Management server
and the hosted Salesforce.com server through the Salesforce user interface. Salesforce.com
Connector offers a wide variety of enhancements and capabilities to agents, including
l

l

l
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Unified login
Salesforce automatically retrieves agent IDs and extensions to enable users to log in to
Contact Center Management directly from Salesforce.com.
Hot desking support
ACD hot desking agents and non-ACD general business hot desking extensions are
supported for use with the Salesforce.com Connector.
Click to dial
Agents can save time and avoid misdialed calls by using click to dial to contact customers,
co-workers, or extensions.

Setting up a Call Center in Salesforce.com

l

Screen pop
When an external call arrives, the relevant Salesforce customer record displays on the agent’s
screen. If the call is subsequently transferred or joins a conference, the record displays on the
screen of the agent receiving the transferred call or taking part in the conference. Immediate
access to customer information increases agent productivity and improves customer
satisfaction. Screen pop can be configured to work with Automatic Number Identification
(ANI), Dialed Number Identification Service (DNIS), or Collect Caller Entered Digits (requires
IVR Routing Premium ports).
Pertinent customer information also displays in the Salesforce user interface, for example,
Caller Name, Collect Caller Entered digits, ANI, DNIS, and any search results you configure
in the Salesforce soft phone layout. For information on configuring soft phone layouts in
Salesforce.com, see the Contact Center Management Installation Guide.
NOTE: If Salesforce is not providing Collect Caller Entered Digits in a screen pop, ensure you
disable caching if you use Internet Explorer.

l

l

l

Call control
Agents can save time by having all their typical desk phone functions embedded and available
directly from the Salesforce user interface. With complete customer information on the
screen, agents can quickly access alternate numbers for customers.
Call logging capabilities
Salesforce creates call tasks when agents make or receive internal or external calls. Use call
tasks to log caller information including notes, phone numbers, and the date and time of a call.
This assists compliance with your business processes by increasing consistency and
providing improved reporting.
Make Busy codes and Wrap-up codes (ACD agents only)
Agents can place themselves in and remove themselves from Make Busy to show their
availability to receive ACD calls. After agents indicate they are not ready for calls, they can
select from a variety of Make Busy codes that describe their activity. After finishing an ACD
call, enter the Work Timer state where they can select from a list of Wrap-up codes (also
known as Call Classification codes) and insert comments about the call. Supervisors can use
this information to track call activity and measure agent performance.
NOTE: To enable agents to complete their call logs, do not select the 'Cancel queue work
timer once code is entered' check box in the Queues pane in YourSite Explorer. This enables
an agent to stay in the Work Timer state and enter call log information until they click the Done
button in their Contact Center Salesforce.com Connector. See "Configuring general
information for voice queues " on page 143.

SETTING UP A CALL CENTER IN SALESFORCE.COM
To set up a Call Center in Salesforce.com, you must first ensure you are running the Call Center
version that is compatible with your version of Contact Center Solutions. Contact Center Solutions
Version. 7.1 requires Salesforce Call Center v. 4.0. For more information, see "Upgrading to Call
Center v.4.0 in Salesforce.com" on page 765.
Once you are running the appropriate version of the Call Center in Salesforce.com, you may create
and configure a Call Center, add users to the Call Center, and configure the soft phone layout from
within the Salesforce user interface. Optionally, you can configure Salesforce.com Connector to
display caller DNIS information to agents receiving calls. You can also optionally add custom ANI
and DNIS fields to call logs to save caller information.
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NOTE:
l

l

Whenever you make changes to your Call Center settings, you must log out of and back into
Salesforce for these changes to take effect.
Ensure you enable the 'Display mixed content' option in Internet Explorer's local intranet
security settings before logging into Salesforce.com.

UPGRADING TO CALL CENTER V.4.0 IN SALESFORCE.COM
Before creating and configuring a Call Center in Salesforce.com, ensure you are using a version of
Salesforce that is compatible with your version of Contact Center Solutions. If you upgrade to
Contact Center Management Version 7.1 or greater without Salesforce Call Center upgraded to
v.4.0, you will not be able to use your Contact Center Salesforce.com Connector.
Upgrading to Salesforce Call Center 4.0 requires you to:
l

Determine your current version of Salesforce Call Center

l

Import Salesforce Call Center 4.0

l

Remove users from a previous Call Center

l

Add users to the Call Center

To determine your current version of Salesforce Call Center
1. Double-click the Salesforce Connector icon on your desktop.
If the Salesforce Connector icon is not visible on your desktop, from the Start menu select
All Programs=>Mitel=>Salesforce Connector.
2. In the task bar, right-click the Contact Center Salesforce.com Connector icon and select
About.
The Salesforce.com About window opens.
3. Under Call Center Edition, note the version number listed.
If the version number is 4.0, you do not need to upgrade your Salesforce Call Center.
If the version is 3.0, 3.0a, or 3.0b, follow the procedures below to upgrade your Salesforce Call
Center to 4.
To import Salesforce Call Center 4.0
1. Log in to www.salesforce.com.
2. Click your user name and select Setup from the drop-down list.
3. Under App Setup, click Customize=>Call Center=>Call Centers.
The All Call Centers page opens.
4. Click Edit beside Mitel Contact Center Integration to view your Call Center configuration
settings.
NOTE: You will have to re-enter these settings in the Mitel Contact Center Integration page
when you upgrade to Salesforce Call Center 4.0. We recommend that you print or save this
page in order to reference your settings.
5. At the top of the screen, click All Call Centers to return to the All Call Centers page.
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6. Click Import=>Browse, and after File name navigate to the Mitel3300.xml file and click
Open.
NOTE: The file is generally held in C:\Program Files (x86)\prairieFyre Software
Inc\CCM\Applications\SalesforceIntegration.
For E.164 support, import the Mitel3300v4.0a - E164.xml file.
7. Click Import.
8. On the Call Center page, click Edit beside the new Call Center.
9. Using the information you saved or printed in step 4, enter the IP/Name of your Enterprise
Server and other configuration settings for the Call Center.
10. Click Save.
To remove a user from a Call Center
1. In Salesforce.com, click your user name and select Setup from the drop-down list.
2. Under App Setup, click Customize=>Call Center=>Call Centers.
The All Call Centers page opens.
3. In the All Call Centers page, select the Call Center from which you want to remove users.
4. At the bottom of the page, click Manage Call Center Users.
The Manage Users page opens.
5. Select the checkboxes beside the Call Center users you wish to remove and click Remove
Users.
To add a user to a Call Center
1. In Salesforce.com click, your user name and select Setup from the drop-down list.
2. Under App Setup, click Customize=>Call Center=>Call Centers.
The All Call Centers page opens.
3. In the All Call Centers page, select the Call Center to which you want to add users.
4. At the bottom of the page, click Manage Call Center Users.
The Manage Users page opens
5. Click Add More Users.
The Search for New Users page opens.
6. Specify your search parameters using the drop-down list for each search field and click Find.
NOTE: To see all users, do not select any parameters for the search fields.
7. Select the checkboxes for the users you want to add to the Call Center and click Add to Call
Center.
NOTE: Users can only be assigned to one Call Center at a time. Users who already belong to
a Call Center are excluded from search results.

CREATING CALL CENTERS IN SALESFORCE.COM
To use Salesforce.com Connector, you must first create a Call Center. For more information on
selecting call center configuration options, see Table 58.
NOTE: If you have imported your Call Center as part of upgrading to the latest Call Center version of
Salesforce.com, you can skip the following procedure.
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To create a Call Center in Salesforce.com
1. In Salesforce.com, click your user name and select Setup.
2. Under App Setup, click Customize=>Call Center=>Call Centers.
The All Call Centers page opens.
NOTE: If the Introducing Call Center Edition splash page opens, click Continue.
3. Click Import=>Browse and, after File name, navigate to the Mitel3300.xml file and click
Open.
NOTE: This file is generally held in C:\Program Files (x86)\prairieFyre Software
Inc\CCM\Applications\SalesForceIntegration\.
For E.164 support, import the Mitel3300v4.0a - E164.xml file.
4. Click Import.
5. In front of the Call Center's name, click Edit.
The Call Center Edit page opens.
NOTE: We recommend you do not alter any of the general information fields.
6. Under CTI Server Info, after IP/Name, type the IP address or name of your Enterprise
Server.
7. After Use SSL, type Yes or No.
8. Under Advanced Queries, after Search by IVR Routing Collected Digits, type the object
and the field to search using collected digits.
9. After Search Cases by ANI, type Yes or No.
10. Under If Records are Found for both ANI and DNIS, after Open the ANI Records, type
Yes or No.
11. After Open the DNIS Records, type Yes or No.
12. Under If Records are Found for both ANI and/or DNIS and Advanced Queries, after
Open the ANI and/or DNIS Records, type Yes or No.
13. After Open the Advanced Queries Records, type Yes or No.
NOTE:
l

l

Whether you open records matching the ANI or the DNIS depends on the information
you entered in If Records are Found for both ANI and DNIS.
Whether you open records matching IVR Routing Collected Digits or records attached
to Contact or Account objects matching the ANI depends on the information you
entered under Advanced Queries.

14. Under New Lead Button, after Enable, type Yes or No.
15. After DNIS (custom field ID), type the DNIS custom field ID.
16. Under Dialing Options, after Outside Prefix, type the number required to make an outbound
call.
17. After Long Distance Prefix, type the digit or digits to be appended to the front of a long
distance number.
18. After International Prefix, type the digit or digits to be appended to the front of an
international number.
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19. After Local Area Codes (comma-separated), type the area code(s) that do not require the
long distance prefix.
NOTE: To set the long distance prefix to always dial first, do not configure local area codes.
20. Under Call Log Options, after Save Extra Information to CallLog, type Yes or No.
21. After Create CallLogs For All Outbound Calls, type Yes or No.
22. If you want to enable E.164 support:
l

After Search Enabled, type Yes.

l

After Local Country Code, type your local E.164 local country code.

l

l

After Long Distance Call Prefix, type the digit or digits to be appended to the front of a
long distance number.
After International Call Prefix, type the digit or digits to be appended to the front of an
international number.

23. Click Save.

CONFIGURING CALL CENTERS IN SALESFORCE.COM
Table 58 describes configurable options for creating a Call Center in Salesforce.com. The
configuration options that you choose determine the Contact Center Salesforce.com Connector's
behavior during call handling and help streamline your contact center operations. The table lists
configurable options, the default setting for each option, the purpose each configuration option
serves in the Call Center setup, and our recommendations for configuring the option.
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Table 58: Configuration options for Salesforce Call Centers
SETTING

General
Information

General
Information

General
Information

General
Information
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OPTION

DEFAULT
SETTING

PURPOSE

RECOMMENDATION
Optionally, leave this as
the default

MitelContactCenter
IntegrationV4

Identifies the
call center
object internally

Display Name

Mitel Contact Center
Integration v4.0

Set the display name as
Identifies the
required.
Call Center
object in
This name will display
Salesforce.com in the agent's
Salesforce.com profile
Also used for
for the associated Call
readability and
Center and in the Call
administration
Center list.

Description

Mitel Contact Center
integration v4.0
(developed by Mitel
Networks)

Describes the
purpose of the
Call Center

Optionally, leave this as
the default

Mitel3300Adapter..1

Represents the
base
Component
Object Model
class of the
customized
Contact Center
Salesforce.com
Connector

CAUTION: Never
change this option as
this could cause
functionality issues
within the Contact
Center Salesforce.com
Connector.

Internal Name

CTI Connector
ProgId

NOTE: If using multiple
Call Centers, each Call
Center must have a
unique internal name
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Table 58: Configuration options for Salesforce Call Centers (continued)
SETTING

General
Information

OPTION

CTI Connector
ProgId

DEFAULT
SETTING

4.0

PURPOSE

Represents the
Contact Center
Salesforce.com
Connector
Toolkit against
CAUTION: Never
which the
Connector has change this option as
this could cause
been built
functionality issues
Identifies the
within the Contact
Salesforce API Center Salesforce.com
version against
Connector.
which the
Contact Center
Salesforce.com
Connector has
been built
Contains the IP
address of the
Enterprise
Server

CTI Server
Info

CTI Server
Info

IP/Name

Use SSL

Blank

No

RECOMMENDATION

This option can either
be the IP address of the
server or the DNIS
name

Points the
Contact Center
Salesforce.com
NOTE: We recommend
Connector to
using an IP address
the Enterprise
instead of a DNS name
Server
or DNS entry.
Specifies if the
client uses SSL Set this option to Yes if
to connect to
SSL is enabled on the
the Enterprise
Enterprise Server.
Server
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Table 58: Configuration options for Salesforce Call Centers (continued)
SETTING

Advanced
Queries

Advanced
Queries

If Records
are Found
for both
ANI and/or
DNIS

771

OPTION

Search by
IVR Routing
Collected
Digits

Search Cases
by ANI

Open the ANI
Records

DEFAULT
SETTING

PURPOSE

Case.CaseNumber

Specifies if the
Salesforce.com
object (case,
contact, lead)
and the field
(phone,
description, ID)
will search
using collected
digits from IVR
Routing

No

Specifies if the
Contact Center
Salesforce.com
Connector will
open records
using the ANI
as the search
value

Yes

Specifies if the
Contact Center
Salesforce.com
Connector
should open
records using
the ANI as the
search value

RECOMMENDATION
By default this option
searches for a case that
has a CaseNumber
equal to the collected
digits.
If you are running
Salesforce in
conjunction
with IVR Routing and
you have your call
center configured to
search the Salesforce
database by Collected
Digits, you must have
'Send to agent desktop'
enabled for the
'LastCollectedDigits'
variable.
If set to No, the Contact
Center Salesforce.com
Connector stops
searching records
based on the customer
phone number.

If set to No, the Contact
Center Salesforce.com
Connector stops
searching records
based on the customer
phone number.
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Table 58: Configuration options for Salesforce Call Centers (continued)
SETTING

If Records
are Found
for both
ANI and/or
DNIS

If Records
are Found
for both
ANI and/or
DNIS and
Advanced
Queries

If Records
are Found
for both
ANI and/or
DNIS and
Advanced
Queries

OPTION

Open the DNIS
Records

Open the ANI
and/or DNIS
Records

Open the
Advanced
Queries
Records

DEFAULT
SETTING

PURPOSE

RECOMMENDATION

Yes

Specifies if the
Contact Center
Salesforce.com
Connector
should open
records using
the DNIS as a
search value

If set to No, the Contact
Center Salesforce.com
Connector stops
searching records
based on the customer
dialed number.

Yes

Specifies if the
Contact Center
Salesforce.com
Connector
opens records
found using
ANI and/or
DNIS when
results are also
found using an
Advanced
Query

If set to Yes, this option
displays records in the
Contact Center
Salesforce.com
Connector that have
been found using ANI
and/or DNIS.

Yes

Specifies if the
Contact Center
Salesforce.com
Connector
opens records
found using the
Advanced
Query when
results are also
found using
customer ANI
and/or DNIS

If set to Yes, this option
displays records in the
Contact Center
Salesforce.com
Connector that have
been found using
Advanced Query.

772

Contact Center Solutions User Guide

Table 58: Configuration options for Salesforce Call Centers (continued)
SETTING

New Lead
Button

OPTION

Enable

DEFAULT
SETTING

No

PURPOSE

RECOMMENDATION
If set to Yes, a yellow
button for New Lead
displays in the Contact
Center Salesforce.com
Connector when you
are on a call with a
customer.

Enables or
disables the
New Lead
button within
the Contact
Center
Enabling this option will
Salesforce.com open the New Lead
Connector
page in Salesforce.com
or start a New Lead
workflow if one exists.
Find this value by
editing the field within
Salesforce.com and
copying the ID from the
URL bar.

New Lead
Button

E.164
Support

E.164
Support
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DNIS (custom
field ID)

Search
Enabled

Local Country
Code

Blank

Specifies the
New Lead field
into which the
DNIS
information is
automatically
entered

The custom field ID
begins immediately
after salesforce.com
and ends before the ? in
the URL.
For more information,
see "Configuring the
New Lead button to
display DNIS
information" on page
779.

No

Enables
searching using
Yes, if using E.164;
E.164 phone
otherwise No
numbering
format

31

Specifies the
E.164 country
code (example
31 for
Netherlands)

Change to your E.164
local country code
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Table 58: Configuration options for Salesforce Call Centers (continued)
SETTING

E.164
Support

E.164
Support

Dialing
Options

OPTION

Long Distance
Call Prefix

International
Call Prefix

Outside Prefix

DEFAULT
SETTING

PURPOSE

RECOMMENDATION

00

Specifies the
prefix required
to dial long
distance
numbers in an
E.164 country

Specify a long distance
prefix for click to dial
functionality to work
correctly. To specify,
type the digit or digits to
be appended to the front
of a long distance
number

00

Specifies the
prefix required
to dial
international
numbers in an
E.164 country

Specify an international
prefix for click to dial
functionality to work
correctly. To specify,
type the digit or digits to
be appended to the front
of an international
phone number

9

Specifies the
outbound
dialing digit(s)
that your Mitel
telephone
system
requires

Specify an outside
prefix for click to dial
functionality to work
correctly. To specify,
type the digit or digits to
be entered when
making an outbound
call.
For example, when an
agent clicks 613-5990045 the Contact
Center Salesforce.com
Connector will
automatically dial
96135990045.
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Table 58: Configuration options for Salesforce Call Centers (continued)
SETTING

Dialing
Options

Dialing
Options
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OPTION

Long Distance
Prefix

International
Prefix

DEFAULT
SETTING

1

011

PURPOSE

Specifies the
prefix required
to dial long
distance
numbers

Specifies the
prefix required
to dial
international
numbers

RECOMMENDATION
Specify a long distance
prefix for click to dial
functionality to work
correctly. To specify,
type the digit or digits to
be appended to the front
of a long distance
number.
For example, when an
agent clicks 416-5990045 the Contact
Center Salesforce.com
Connector will
automatically dial
914165990045.
Specify an international
prefix for click to dial
functionality to work
correctly. To specify,
type the digit or digits to
be appended to the front
of an international
phone number.
For example, when an
agent clicks a number
with a country code that
does not correspond to
the regional settings
(44-770-954-321) the
Contact Center
Salesforce.com
Connector will
automatically dial
901144770954321.
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Table 58: Configuration options for Salesforce Call Centers (continued)
SETTING

Dialing
Options

OPTION

Local Area
Codes

DEFAULT
SETTING

613,819

PURPOSE

Specifies your
local area
codes

RECOMMENDATION
Specify local area
codes for click to dial
functionality to work
correctly. To specify,
type the area code or
area codes for which
the long distance prefix
is not required.
NOTE: If your agents
are in multiple
geographic locations
each location must
have its own Call
Center with applicable
dialing options.
If set to Yes, the call log
must contain the
following custom fields:
ANI: Field name must
be ANI, Type must be
Text

Call Log
Options

Save Extra
Information To
CallLog

No

Saves or adds
extra ANI or
DNIS
information to
the call log

DNIS: Field name must
be DNIS, Type must be
Text.
Ensure that all agents
have write access to
these fields.
For more information,
see "Adding custom
ANI and DNIS fields to
Call Logs" on page 780.

Call Log
Options

Create
CallLogs For
All Outbound
Calls

Specifies if a
call log should
be created on
unanswered
outbound calls
No

Specifies that if
an agent makes
an unanswered
outbound call, a
call log is still
created

This option may be
required for continued
functionality when
switching from
traditional PRI trunks to
SIP trunks.
CAUTION: Setting this
to Yes when a Call
Center is already in
operation will impact
your Salesforce.com
task reporting.
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ADDING USERS TO CALL CENTERS
Salesforce users must be added to a Call Center before they can use Salesforce Call Center Edition
features. You must also add users to a Call Center to enable the Contact Center Salesforce.com
Connector to display in the Salesforce.com page upon login.
To add a user to a Call Center
1. In Salesforce, click your user name and select Setup=>Customize=>Call Center=>Call
Centers.
The All Call Centers page opens.
2. Select the Call Center to which you want to add users.
The Call Center Detail page opens.
3. At the bottom of the page, click Manage Call Center Users.
The Manage Users page opens.
4. Click Add More Users.
The Search for New Users page opens.
5. Specify your search parameters using the drop-down list for each search field and click Find.
NOTE: To see all users, do not select any parameters for the search fields.
6. Select the checkboxes beside the users you want to add to the Call Center and click Add to
Call Center.
NOTE: You can only assign users to one Call Center at a time. Users who already belong to a
Call Center are excluded from search results.

CONFIGURING SOFT PHONE LAYOUTS
Configuring soft phone layouts enables you to control the information that displays in a screen pop.
Once you have configured soft phone layouts, you can assign them to agents. Assigning
customized soft phone layouts increases service efficiency by giving agents access to the most
pertinent customer information.
NOTE: For more detailed information on the options for configuring soft phone layouts, click Help
about this section on the SoftPhone Layout Edit page in Salesforce.com.
To configure a soft phone layout
1. In Salesforce.com, click your user name and select Setup from the drop-down list.
2. Under App Setup, click Customize=>Call Center=>SoftPhone Layouts.
3. To create a new soft phone layout, click New.
4. To modify a soft phone layout, click Edit beside the existing layout's name.
The SoftPhone Layout Edit page opens.
5. After Name, type or modify the name for the soft phone layout.
6. To make this soft phone layout the default layout, select the Is Default Layout checkbox.
7. After Select Call type, select one of the following call types from the drop-down list:
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8. After Caller ID, Dialed Number, click Edit.
9. To add or remove a call-related field, in the Available or Selections pane, select the field and
click Add or Remove.
10. To change the order of call-related fields, in the Selections pane, select the field and click Up
or Down.
11. After Account, Contact, Lead, click Add/Remove Objects.
12. To add or remove an object, in the Available or Selections pane, select the object and click
Add or Remove.
13. To change the order of objects, in the Selections pane, select the object and click Up or
Down.
14. For each object, after each If single <name of object> found, display:, click Edit.
15. To display objects in the soft phone layout if a single record is found, in the Available pane,
select the field(s) and click Add.
16. To remove objects from display in the soft phone layout if a single record is found, in the
Selections pane, click Remove.
17. To change the order in which objects display, in the Selections pane, select the object and
click Up or Down.
18. At the top of the page, click Save.
NOTE: To configure soft phone layouts for additional call types, repeat steps 7-18 for each
type.
To configure screen pop settings for a soft phone
1. Under Screen Pop Settings:, after Screen pops open within:, click Edit and select a
screen pop location.
2. After No matching records:, click Edit and select a screen pop location.
3. If you select Pop to new, select a page from the drop-down list.
4. If you select Pop to Visualforce page, type the name of the page in the field provided or click
the Lookup button to search for a page.
5. After Single-matching record:, click Edit and select a screen pop location.
6. After Multiple-matching records:, click Edit and select a screen pop option.
7. At the top of the page, click Save.
To assign a soft phone layout to an agent
1. In Salesforce.com, click your user name and select Setup.
2. Under App Setup, click Customize=>Call Center=> SoftPhone Layouts.
3. Click SoftPhone Layout Assignment.
4. From the drop-down lists, select a soft phone layout for each agent.
NOTE: The list of agents only includes those who have been added to a Call Center.
5. Click Save.
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CONFIGURING THE NEW LEAD BUTTON TO DISPLAY DNIS
INFORMATION
You can configure the New Lead button to display caller DNIS information to agents receiving calls.
To configure the New Lead button to display DNIS information, you must
l

Add the DNIS custom field to the Leads form in Salesforce

l

Configure Salesforce to display a New Lead button when calls are received

To add the DNIS custom field to the Leads form in Salesforce
1. In Salesforce.com, click your username and select Setup.
2. Under App Setup, click Customize=>Leads=>Fields.
The Lead Fields page opens.
3. Under Lead Custom Fields & Relationships, click New.
The New Custom Field page opens.
4. Under Data Type, select Text and click Next.
5. After Field Label, type a label for the DNIS custom field.
6. After Length, type the number of characters permitted in the DNIS custom field.
7. After Field Name, type DNIS.
8. Click Next.
9. Under Field-Level Security for Profile, select the page layouts to which the DNIS custom
field will be added.
10. Click Next.
11. Click Save.
The Lead Fields page opens.
12. Under Lead Custom Fields & Relationships, select the DNIS custom field.
13. Take note of the URL that displays in your web browser. This is the DNIS custom field
information required in the following procedure.
For example, in the URL
https://na7.salesforce.com/00Nd0000005FhBE?setupid=LeadFields, the DNIS custom field
information is 00Nd0000005FhBE.
To configure Salesforce to display a New Lead button when calls are received
1. In Salesforce.com, click your username and select Setup.
2. Under App Setup, click Customize=>Call Center.
The Call Center page opens.
3. Under Call Center, select Manage call centers.
The All Call Centers page opens.
4. Under Action, for the appropriate Call Center, click Edit.
5. Under New Lead Button, after Enable, type Yes.
6. After DNIS (custom field ID), enter the DNIS custom field information as noted in the
previous procedure.
7. Click Save.
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ADDING CUSTOM ANI AND DNIS FIELDS TO CALL LOGS
Adding custom ANI and DNIS fields to call logs saves a caller’s phone number, or the number they
dialed to reach your organization, within Salesforce call logs. Adding ANI and DNIS fields enables
you to collect additional customer information by customizing your call logs in Salesforce.
NOTE: To see ANI and DNIS information in call logs, in the Call Center setup page under Call Log
Options, you must set the ‘Save Extra Information to CallLog’ field to ‘Yes’. For more information,
see "Configuring Call Centers in Salesforce.com" on page 768.
To add a custom ANI and DNIS field to a call log
1. In Salesforce.com, click your user name and select Setup.
2. Under App Setup, click Customize=>Activities=>Activity Custom Fields.
The Activity Fields page opens.
3. Click New.
The New Custom Field page opens.
4. Under Data Type, select Text and click Next.
5. After Field Label, type a name for this field as it will appear in the call log.
NOTE: We recommend using ‘ANI’ or ‘DNIS’ for ease of identification.
6. After Length, type the maximum length for the ANI or DNIS field.
7. After Field Name, type ANI or DNIS, depending on the field type you are adding.
NOTE: You must populate this field with “ANI”, or “DNIS”, only.
8. Click Next.
9. Under Field-Level Security, select the profiles that will be able to see the ANI or DNIS field.
10. Click Next.
11. If you are finished adding fields, click Save.
12. To add an additional field to a Salesforce call log, click Save & New and repeat steps 4-10.
NOTE: A call log can only have a single ANI or DNIS field. Clicking Save & New enables you
to create a DNIS field after creating an ANI field or an ANI field after creating a DNIS field.
13. To make these changes take effect, log out of Salesforce and log back in.

LOGGING INTO YOUR CONTACT CENTER
SALESFORCE.COM CONNECTOR
The Contact Center Salesforce.com Connector refers to the Contact Center Softphone application
as it appears in Salesforce.com. To integrate with Salesforce.com, you must first open Contact
Center Client and load the Contact Center Salesforce.com Connector toolbar. This sets the MiTAI
monitor on the extension and indicates to the telephone system that the extension is ready to make
and receive calls. Following this action, you can minimize Contact Center Client and log in, log out,
and perform all call control activities from within the Salesforce.com client.
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NOTE:
l

l

l

l

l

The Salesforce.com Connector must be running before logging into the Salesforce.com
website. Before logging into the Salesforce.com website, verify the Salesforce.com
Connector is running in the system tray on your computer (next to the clock and volume
controls). If the icon is displayed, the Salesforce.com Connector is open.
If you are using a desk phone, you do not need to open Contact Center Client before loading
the Contact Center Salesforce.com Connector toolbar.
Your login for Salesforce.com is different than the login used for the Contact Center
Salesforce.com Connector.
The Contact Center Salesforce.com Connector is located in the left pane of the Salesforce
user interface and appears only when you are assigned to Call Center in Salesforce.
If an employee is unlicensed, they will not be able to log in to the Contact Center
Salesforce.com Connector through Salesforce. For more information on employee licensing,
see the Contact Center Solutions and Business Reporter System Engineering Guide.

To log into your Contact Center Salesforce.com Connector
1. Start Internet Explorer and type http://login.salesforce.com/.
2. In the Login pane, type your Salesforce.com User Name and Password, and click Login.
See Figure 155.

Figure 155: Salesforce.com login pane
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After you log in, the Contact Center Salesforce.com Connector will initialize in the top-left
section of the Salesforce.com webpage. (See Figure 156.)
3. If you receive a message asking if you want to see the page content that was delivered
securely, click No.
NOTE: Clicking Yes or closing the window will disable the Contact Center Salesforce.com
Connector.

Figure 156: The initializing pane
4. Type your Call Center Username, Password, Agent ID, and Extension.
NOTE: If you do not have an agent ID associated with your employee ID, you will not have
ACD functionality. However, you can continue to log in and use your desk phone or soft phone
from within Salesforce for non-ACD calls.
5. To set Salesforce to remember your Contact Center Salesforce.com Connector login
credentials every time you log into Salesforce, enable the Remember me check box.
See Figure 157.

Figure 157: The login pane
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6. Click Log In.
The Contact Center Salesforce.com Connector will display 'Logged In' when you are logged in
as an ACD agent.
See Figure 158.

Figure 158: The 'Logged In' status display
If no agent ID was provided with the login credentials and you are not logged in as an ACD
agent, the Contact Center Salesforce.com Connector functions as a soft phone and displays
'Ready for Calls'. (See Figure 159.)

Figure 159: The 'Ready for Calls' status display
To automatically log into your Call Center when logging into Salesforce
1. In Salesforce, click your username and select Setup.
2. Under Personal Setup, select Call Center Settings =>My SoftPhone Settings.
3. Enable the Automatically log into your call center when logging into salesforce.com
checkbox.
4. Click Save.
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SALESFORCE.COM CONNECTOR FUNCTIONALITY
NOTE:
l

l

If using a true soft phone, you must first open Contact Center Client, click View => Soft phone
and configure soft phone options. You must keep Contact Center Client running in the
background as you use Salesforce. If you are using a desk phone there is no need to open
Contact Center Client.
Caller ANI/DNIS information is not included when you transfer a call between telephone
systems. When you transfer a call between telephone systems, the ANI/DNIS information
that displays in the screen pop for the receiving agent is that of the transferring agent, not the
caller.

You can use Salesforce.com Connector to perform the following functions:
l

Dial phone numbers
Dial a phone number by clicking Line 1, entering the number into the Contact Center
Salesforce.com Connector and clicking Dial. (See Figure 160.)
NOTE: Default digit lengths that determine whether a call is recognized as internal or external
in reports and the ‘My Calls Today’ interface can be modified in YourSite Explorer=>Media
servers in the ‘Min/Max digits to dial locally’ procedural steps. The default values are set to <
10 digits in length to signify an internal number and > = 10 digits in length to signify an external
number.

Figure 160: Dialpad

784

Contact Center Solutions User Guide

Alternatively, dial by clicking the icon next to a phone number associated with a contact, lead,
activity, account, or any other phone field you have created. (See Figure 161.) ACD agents
can dial by clicking on available employee or extension links. You can also dial numbers using
the dial pad on your desk phone.

Figure 161: The icon to dial a contact, lead, activity, account, or other phone field
l

Answer phone calls
Answer a phone call by clicking Answer or using your desk phone. If the caller's number is in
your Salesforce database, their customer information page appears. Salesforce.com
Connector supports one incoming line per user. (See Figure 162.)

Figure 162: Answer
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l

Place callers on hold
Place callers on hold by clicking Hold. Retrieve the call by clicking Retrieve from Hold. (See
Figure 163.)

Figure 163: Retrieve From Hold
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l

Perform one-step transfers (cold transfers)
A one-step transfer (cold transfer) is when you transfer a caller without speaking to the third
party destination first. Transfer a call directly to another number without speaking to the third
party by clicking Transfer, entering the third party’s phone number or extension, and clicking
One Step Transfer to complete the transfer. (See Figure 164.)

Figure 164: One-Step Transfer
l
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Perform initiated transfers (warm transfer)
An initiated transfer (or warm transfer) is when you place a caller on hold and speak to the third
party destination before transferring the call. To transfer a call directly to another number and
speak with the third party before transferring the call, click Initiate Transfer. Speak with the
third party and once the call is ready to be transferred click Complete Transfer to connect the
caller and remove yourself from the call.

Salesforce.com Connector functionality

l

Initiate conference calls
Initiate a conference call by clicking the Conference button while on a call, entering the phone
number to join to the conference and clicking Initiate Conference. Your caller is placed on hold
while you dial the third party to be added to the call. (See Figure 165.)

Figure 165: Initiate Conference
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Once you have connected to the third party number, click Complete Conference to place all
three parties on the same line. (See Figure 166.)

Figure 166: Complete Conference
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l

Ending calls
End a call by clicking End Call. (See Figure 167.)

Figure 167: End Call
l

Set make busy codes (ACD agents only)
To set a Make Busy code, click on the arrow in the agent state bar and select Not Ready for
Calls. (See Figure 168.) Make Busy codes are entered in YourSite Explorer and should be
maintained by your YSE Administrator.

Figure 168: Not Ready for Calls
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Select from the list of available Make Busy codes. (See Figure 169.)

Figure 169: Make Busy codes
You will now appear as unavailable for calls. (See Figure 170.)

Figure 170: Agent Status
Remove the Make Busy code and make yourself available for calls again by clicking Ready
for Calls in the agent state bar. (See Figure 171.)

Figure 171: Ready for Calls
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l

Create new leads while on calls
Once you have answered an internal/external call, the Contact Center Salesforce.com
Connector will display a New Lead button. Click the New Lead button to open a new lead and
auto-populate the Lead phone number field with the caller’s phone number. (See Figure 172.)

Figure 172: New Lead
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l

Relate Salesforce records to a call activity task
You can associate up to two records to a call. From the Related To list in the call log area,
select the Account, Opportunity, or Case to which you will associate the call. To associate a
Contact or Lead to the call, select it from the Name drop-down list in the call log area. (See
Figure 173.)

Figure 173: Call Log and Related To

NOTE: The Related To record cannot be selected when Name is set to a Lead.
l
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Search on outbound calls
Search results for outbound calls display in the Contact Center Salesforce.com Connector
user interface, but do not generate screen pops.

Salesforce.com Connector functionality

l

Tag calls with account codes
Click on Show Account Codes to display a list of available Account Codes, then click on the
account code link that you want to apply. (See Figure 174.)

Figure 174: Account Codes
l

l

Set wrap-up codes (ACD agents only)
When an external ACD call ends, select an appropriate Wrap-up code (also known as a Call
Classification code) from the Call Result list of the Current Call Log window.
Attach comments to a call
Attach comments to a call by typing text into the Comments field. When the call ends, the
comments are automatically saved. (See Figure 175.)
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Figure 175: Attach comments to call
Call log information can be accessed from either the My Calls Today section of the soft phone
or by scrolling to the Active History section of an object in Salesforce. (See Figure 176.)

Figure 176: Activity History
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l

View recent call activity
Access recent call activities by clicking Last Call or My Calls Today. To edit one of the last
call activities created, click the Last Calls arrow in the Contact Center Salesforce.com
Connector and enter the new comments you would like to add before clicking the Save button.
Clicking My Calls Today will take you to the My Calls Today webpage where you can view all
Call Activities that have been created for the entire day. (See Figure 177.)
NOTE: If call duration is not accurately displayed in My Calls Today, run Windows Update
and install the most recent updates on your work stations. For more information on running
Windows Update, see the Contact Center Management Installation Guide.

Figure 177: Call history
l

Edit completed call logs
Call logs are automatically created for all external calls an agent makes or receives. Edit a call
log by clicking on the link to the call. (See Figure 178.)

Figure 178: Edit call logs
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l

Search on outbound calls
Search results for outbound calls display in the Contact Center Salesforce.com Connector
user interface within Salesforce, but do not generate screen pops. Enter the phone number
into the dial pad and click Dial. The search will return results in the Contact Center
Salesforce.com Connector interface. You can click Account, Contact, etc. to view the details
of the search result. (See Figure 179.)

Figure 179: Search on outbound calls display
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CONTACT CENTER SOLUTIONS TERMS AND
DEFINITIONS
Abandoned call
An abandoned call is a call that the caller ends before the call is answered.
Account Code
Account Codes are classifiers that can be applied to call records and used to identify unique
attributes about the caller or call for individual departments, projects, or services to generate reports
on them. As well, they can be used by agents as classification codes for incoming calls. Account
codes can be verified, non-verified, fixed length, or forced.
See Classification Codes, Fixed Length Account Codes, Forced Account Codes, Non-Verified
Account Codes, Verified Account Codes.
ACD (Automatic Call Distribution)
ACD (Automatic Call Distribution) is a call distribution mechanism that distributes calls to a pool of
available queue members.
ACD (state)
ACD is a state applied to a queue member while they are handling an ACD call.
ACD calls handled
See Calls Handled.
ACD calls interflowed
See Interflow.
ACD calls offered
See Calls offered.
ACD calls requeued
See Calls requeued.
ACD handling time
ACD handling time is a parameter for Contact Center Management that provides the sum of all
events from answer to hang up of an ACD call.
ACD path
An ACD path is a predefined route that a call follows before reaching an agent. ACD paths direct
callers to the agents or agent groups best suited to handle the calls. For example, a contact center
can have an ACD path for sales, which routes callers to the agents taking sales orders.
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Active Directory
Active Directory is a directory service created by Microsoft that is used for managing a domain. In
Contact Center Solutions, Active Directory is synchronized with YourSite Explorer to align Active
Directory security groups and users with Contact Center Solutions employees and employee groups
within selected organizational units.
Agent
An agent is a contact center employee, assigned an Agent ID, who receives calls routed to
ACD paths.
Agents available
Agents available is a real-time statistic indicating the current number of agents who are logged in and
not in Make Busy or Do Not Disturb. If an agent is configured as a part of an agent group and is
logged in, the agent is counted as available, even if they are not present in that agent group. This
statistic can be used as a queue condition in IVR Routing.
ANI (Automatic Number Identification)
ANI (Automatic Number Identification) is a service that provides receivers of telephone calls with the
caller information. ANI can be used to create screen pops for agents or to route calls by caller phone
numbers.
Answered by
Answered by is the real-time name for the number of calls answered by the first, second, third, and
fourth answer points
Answering points
An answering point is a single point of communication available to callers where they can contact a
contact center, such as a queue, voice mail, or extension.
ASA
See Average Speed of Answer
Average Speed of Answer
Average speed of answer (ASA) is an ACD statistic that measures how long the average caller waits
on hold before the call is picked up by a queue member (including time in queue and ringing time).
Average abandon time
The average abandon time is the average number of seconds callers wait in queue before they
abandon a call.
Blocked call
A blocked call is a call that is unable to get into the contact center's telephone system because there
are no trunks available. The caller receives a busy signal.
Busy hour
Busy hour is a statistic that highlights the busiest hour of operation of a business day.
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Call abandoned parameter
The Call abandoned parameter is a queue configuration that defines short abandoned calls,
determining what abandoned calls are included as abandoned in call statistics. The default the short
abandon is configured at 6 seconds.
Call routing
Call routing is the set of instructions configured in Contact Center Solutions to automate the
movement of calls to their intended answering points.
Call type
Call type categorizes calls queue members receive, enabling them to be looked up in SMDR
Inspector. Call types include ACD or non-ACD, abandoned, interflowed, requeued, unavailable, or
outbound.
Callback
Callback is an optional feature of telephone systems that enables callers who are unable to reach an
agent in a contact center to be called back by the contact center. Contact Center Solutions and IVR
Routing offer several methods of providing callbacks, including Call me back, voice callbacks, web
callbacks, and abandon callbacks.
Calls abandoned
Calls abandoned is a report field detailing the total number of calls that abandoned in queue or while
the phone was still ringing at an extension. Calls abandoned ignores calls that were abandoned
before the short abandoned parameter had been passed.
See Abandoned calls.
Calls abandoned (long)
Calls abandoned (long) are abandoned calls where the caller hung up after the short abandon
parameter had been passed. By default, the short abandon is configured to be 6 seconds.
Calls abandoned (short)
Calls abandoned (short) are abandoned calls where the caller hung up before the short abandon
parameter had been passed and are not included in the call statistics.
Calls answered
See Calls handled.
Calls handled
A handled call is a call that has been picked up answered by a queue member. A call that listens to
in-queue RAD messages is not considered handled until it is answered by a queue member.
Calls interflowed
See Interflow
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Calls offered
1) Call offered are all calls received, regardless of how they are handled or routed, including calls
handled and both short and long abandoned calls.
2) Calls offered is a forecasting parameter used to determine the queue member requirement for a
contact center’s Service Level percent and Service Level time targets through applying the Erlang C
equation to the estimated Call Load and average ACD Handling Time.
Calls requeued
Requeued calls are all calls replaced back into the same queue and offered to another agent when an
agent receives an ACD call and fails to answer it after a pre-configured duration or number of rings.
Calls waiting
Calls waiting is the number of callers in a queue waiting for a queue member to become available,
including those listening to Music on hold or queue announcements.
Camp on
Camp on is a notification tool that enables callers to notify an employee, who is currently on a call,
that they are waiting to be answered. The employee is notified by a series of audible beeps.
Classification codes
Classification codes are classifiers appended to calls to categorize them, enabling reporting to
examine specific categories of calls, such as those relating to specific products or services.
Clustered environment
A clustered environment is a network environment where multiple telephone systems are linked
together to function as a single system.
Computer Telephony Integration
Computer Telephony Integration (CTI) are technologies that merge computer functions and
telephone systems, enabling PC-based telephone systems to deliver functions such as
synchronized voice and data delivery, voice and data conferencing, automatic information retrieval
for calls, caller-based messaging and routing, and desktop productivity tools.
CTI
See Computer Telephony Integration
Customer Relationship Management
Customer Relationship Management (CRM) is a model for customer management that relies on
technology to streamline and manage interactions with customers.
Date stamp
See Date/Time stamp.
Date/Time stamp
A date/time stamp is an indicator attached to a record or statistic detailing when it was created.
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Delayed call
A delayed call is a call placed in the ACD queue because it cannot be immediately answered by a
queue member. The ACD queue allows the client to wait for an available member rather than
blocking the client from entering the system.
Dialable number
The dialable number is a digit or series of digits dialed by a caller to reach an answering point, such
as a queue member, an extension, a queue, or voice mail.
Dialed Number Identification Service (DNIS)
Dialed Number Identification Service (DNIS) is a telecommunication service that identifies the
phone numbers dialed by inbound callers. DNIS can be used to route calls, enabling contact centers
managing multiple product lines or businesses to direct calls to the appropriate endpoint.
Division
A division is a grouping of several employee or extension groups that enable a single report to be run
for several groups simultaneously.
DND
See Do Not Disturb (state).
DNIS
See Dialed Number Identification Service.
Do Not Disturb (state)
Do Not Disturb (DND) is a state that prevents queue members from receiving inbound contacts and
transfers. For agents, Do Not Disturb is an employee-level configuration. When an employee is in
Do Not Disturb, they enter Do Not Disturb across all agent capabilities.
Employee
An employee is a person who is employed by an organization and configured as an employee in
Contact Center Solutions so that they have access to Contact Center Solution applications and may
have their associated devices reported on.
Enterprise
An enterprise is both the single site where the Enterprise Server is installed and all the connected
branch offices that comprise a company.
Enterprise Server
The Enterprise Server is the central server upon which Contact Center Solutions is installed and
from which Contact Center Solutions runs.
Erlang
An Erlang is a unit of measure for telephone traffic equal to one hour or 3,600 seconds of telephone
conversation, such as a single call lasting one hour or six calls lasting 10 minutes.
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Erlang B
Erlang B is an equation used to estimate the number of trunks required by a contact center.
Erlang C
Erlang C is a forecasting equation that uses historical Call Load data, Service Level Percentage,
Service Level Time, and Wrap up Time Used to predict the resources required to keep wait times
within a contact center ‘s Service Level objective for the time interval and data range selected in a
forecast.
External Hot Desking Agent
See Hot Desking Agent.
Extension
An extension is an endpoint for answering calls. Extensions can be assigned to Ring Groups, or can
be logged into by agents.
Fixed Length Account Codes
Fixed Length Account Codes are verified and non-verified Account Codes that are automatically
submitted to the system when the correct number of digits has been entered.
Forced Account Codes
Forced Account Codes are verified and non-verified account codes that must be entered at a specific
time in a call. Forced verified account codes must be entered as soon as the phone is off the hook.
Forced non-verified Account Codes must be entered after the phone number is dialed. Systems may
be configured to avoid the requirement of entering a forced non-verified Account Code when making
a call that must not be charged (for example, dialing a leading digit such as 8 to make a call without
entering an Account Code and dialing a leading digit such as 9 to make a call that requires an
Account Code).
Grade of service
The grade of service (GOS) is a measure of the likelihood of an attempted call receiving a busy
signal. GOS compares the number of trunks to the level of traffic and expresses the result as a
decimal fraction. A GOS of P.02, for example, indicates that a caller would have a two percent
chance of receiving a busy signal.
Handled by
Handled by is the real-time statistic for the number of calls answered by the first, second, third, and
fourth answer points.
Handled %
Handled % is the real-time statistic comparing the calls handled to the calls offered.
Handling time
Handling time is the measure of how long a call took to be handled by a queue member, from when
the call is answered when the call is finished. Handling time includes talk time, hold time, as well as
transfers and conferences on the call.
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Hot desking agent
Hot desking agents are employees configured with a hot desking agent ID that enables them to sit at
any extension in a network and log on to that extension with all their regular work settings available.
External hot desking agents can hot desk remotely using any phone or headset.
Hunt group
A hunt group is a series of telephone lines grouped by the telephone system that rotates incoming
calls through the lines until an available line is found and the caller is connected.
Inbound
Inbound is a descriptive term applied to forms of contact or communication, such as a phone call, to
indicate that it is being sent to a contact center from an external source.
Inbound calls
See Inbound.
Interflowed
Interflow is a mechanism that redirects contacts from queues to alternate answering points (for
example, to another queue or to voicemail). Interflow statistics include contacts manually transferred
from one queue to another. Contacts routed from queues to other answering points before the Short
Abandon time are not included in Interflow statistics.
Interactive Voice Response
Interactive Voice Response (IVR) is a technology that enables callers to interact with a contact
center’s phone system by pressing keys or speech recognition while following IVR dialog.
Internal calls
Internal calls are calls made from within a system to other answering points within the same system.
LAN
A Local Area Network (LAN) connects multiple computers together over short distances. LANs
typically operate within a building. The computers share information, applications, and peripherals,
such as printers.
Logged on
Logged on is an agent state applied to agents who have signed into the ACD system.
Logged off
Logged off is an agent state applied to agents who have signed out of the ACD system.
Longest waiting
Longest waiting is the duration, in minutes and seconds, of the call that has been waiting the longest
in queue.
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Make Busy (state)
Make Busy is an agent presence state applied to prevent an agent who is busy from receiving ACD
calls. Agents in Make Busy are able to receive non-ACD calls. Make Busy is an employee-level
configuration. When an employee is in Make Busy, they enter Make Busy across all agent
capabilities.
Media servers
A media server is a server or system, such as a telephone system, used to organize and distribute
communications throughout a contact center.
MiTAI
MiTAI is a Mitel implementation of TAPI that is used to connect the telephone system/PCs running
windows to external applications, such as ACD controllers.
Mitel OPS Manager
Mitel OPS Manager is a Mitel software application that provides network-wide administration and
maintenance for MCD and 3300 Network Elements or Nodes.
Non ACD (state)
Non ACD is a state applied to queue members involved in an incoming personal contact, a memberoriginated call, or a call dialed directly to their extension.
Non-verified Account Codes
Non-verified Account Codes are numbers entered onto the SMDR record for billing and call
management. During a call, non-verified Account Codes can be entered as often as required.
Outbound calls
Outbound calls are calls made from within a contact center to external answering points.
Overflow
Overflow is a call distribution mechanism that queues calls against two or more agent groups to limit
the delay faced by callers. If a call in an ACD queue is not answered after the configured Overflow
time, then it is placed into the queue of a second agent group in addition to the first queue.
PBX
See Telephone system.
Pooling principle
The pooling principle refers to the increased contact center efficiency gained by consolidating
contact center resources.
Port
A port is a communications endpoint in Contact Center Solutions used to link services.
Probability of delay
The probability of delay is a statistic that measures the likelihood of a call being delayed in the ACD
queue, comparing the number of queue members to the level of traffic carried by the trunks.
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PSTN
See Public Switched Telephone Network.
Public Switched Telephone Network (PSTN)
The Public Switched Telephone Network is a global collection of Central Offices (CO)
interconnected by long distance telephone switching systems.
Quality of service
Quality of service is a reflection of an agent's ability to provide excellent assistance to each
customer. Quality of service can be evaluated and managed through silent monitoring systems, IT
support systems, CTI, ANI, and DNIS.
Queue number
A queue number is the address of a queue or other answering point used in the telephone system.
The programming associated with the queue number defines the routing and timing options available
to the call.
Queue member
A queue member is an individual answering for the queue. For ACD paths, ‘members’ refers to
agents in the queue’s answering agent groups. For Ring Groups, ‘members’ refers to the extensions
assigned to the queue’s Ring Groups.
Queue unavailable
1) Queue unavailable is a routing option that reroutes calls to an unavailable answer point/overflow
point. Queues are unavailable when the call enters the system outside business hours, when all
queue members have removed their presence, when all queue members are in DND, or when the
queue has been placed in DND (ACD path only). Calls interflowed before the Short Abandon time
are included in Queue Unavailable statistics.
2) Queue unavailable is a real-time statistic that counts how many calls were re-rerouted to other
queues due to the queue being unavailable.
RAD
See Recorded announcement device.
Readerboard
See Wall sign.
Real-time adherence
Adherence refers to whether or not agents are performing the activities for which they are scheduled.
Workforce management tools enable supervisors to be notified of discrepancies between agents'
work schedules and the actual activities they perform.
Reason Code
Reason codes are descriptive classifiers applied to Make Busy and Do Not Disturb states to provide
more detailed information as to why the queue member applied the code.
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Recorded announcement device
Recorded Announcement Device is an IVR Routing feature that provides prerecorded messages to
callers waiting in the ACD queue.
Reporting number
A reporting number is the unique number assigned by the system to contact center resources for
reporting purposes.
Ring Group
A Ring Group is a collection of extensions, or a single dialing point for a collection of extensions, in a
business. Ring Groups are typically used to reach back office extensions. For example, a business
with agents taking sales orders may also have several phone extensions in the warehouse. These
warehouse phone extensions are compiled into a Ring Group, which can be reached via a single
dialing point.
Service Level percent
The Service Level percent is the number of calls that are handled, abandoned, and interflowed before
the Service Level time, compared to the total number of calls handled, abandoned, and interflowed.
Service Level time
The Service Level time is the specified time used in calculating the queue service objective in
conjunction with the Service level percent, such as 80% (Service Level percent) of contacts
answered within 120 seconds (Service Level time).
Silent monitoring
Silent monitoring is a Contact Center Solutions feature that facilitates the tracking of agentcall
handling techniques by enabling supervisors to listen to the voice conversations of internal or
external calls between agents and callers.
Site
A site is a physical location of a contact center with one or more media servers. It may be the same
location where the Enterprise Server is installed or a branch office.
Spectrum
Spectrum is a reporting feature configured for queues that provides a frequency distribution of calls
abandoned, answered, or interflowed based on a defined time scale.
SQL
SQL is a standard query language used to enter, query, and change data in a database, as well as
create and administer databases. Administration of YourSite Explorer is done using Microsoft's SQL
Server.
Subroutines
Subroutines are portions of workflows that can be reused in multiple workflows.
Talk-time
Talk-time is the measure of the time an agent spends talking to callers, excluding time spent on hold.
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TCP/IP
TCP/IP is the basic communication protocol of the Internet and is used as a communication protocol
in private networks (intranets).
Telephone system
A telephone system is a private branch exchange (PBX) or business telephone switch used to
process incoming and outgoing calls to a contact center.
Time to answer
Time to answer is the measure, in seconds, of how long an incoming call remained in queue before it
was answered. It is primarily used as an SMDR data mining criteria.
Time stamp
See Date/Time stamp.
True-talk time
See Talk Time.
Trunk
A trunk is a communication line between two telephone systems.
Trunk load
Trunk load is the duration of time from when a trunk receives a call to when the queue member
finishes handling the call and disconnects. Trunk load does not include Wrap Up Time.
Unavailable
Unavailable is an agent and employee state real-time column in Contact Center Client that includes
agents unavailable to take calls due to being in Do Not Disturb, Make Busy, Work Timer, Reseize
Timer, or Unknown.
Updated Position in Queue (UPiQ)
Updated Position in Queue (UPiQ) is a notification feature that provides messages to callers
informing them of their position in queue and keeps them informed of their position if it changes, at
preset intervals.
UPiQ
See Updated Position in Queue.
Verified Account Codes
Verified Account Codes are numbers entered before making a call to change the Class of Service or
Class of Restriction at the station. When the call ends, the station returns to normal. Verified
Account Codes can be tracked with SMDR for long-distance billing purposes and may be reported in
Internal SMDR logs.
Wall board
See Wall sign.
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Wall sign
A wall sign is an electronic sign used to display real-time ACD statistics to employees in a contact
center.
WAN
Wide Area Network (WAN) connects multiple computers over a wide geographic area. WANs
operate over telephone carrier lines through bridges or routers. Router options enable communication
between high speed LAN links and slower speed WAN links, which tie LAN segments together.
Whisper Coach
Whisper Coach is a silent monitor feature that enables supervisors to converse with and coach
agents handling calls without callers hearing the supervisor.
Workflow
Workflows are programed pathways in IVR Routing and Multimedia Contact Center, which control
how contacts are routed to queue members.
Workforce management
Workforce management is the scheduling of contact center agents to meet forecasted needs and the
managing of agents to ensure they adhere to their scheduled activities.
Wrap Up Time
Wrap Up Time is a real-time and reporting statistic detailing the total time an agent spends in the
Work Timer state.

809

© Copyright 2015, Mitel Networks Corporation. All Rights Reserved. The Mitel word and logo are trademarks of Mitel Networks Corporation.
Any reference to third party trademarks are for reference only and Mitel makes no representation of ownership of these marks.

